 API browser of migelValidator100 COM module
Interface version: | 1.00
Interface date: | 30 Aug 2002

The migelValidator is an ATL COM module which provides methods to browse, to query, and to validate records against the migel catalog. |  | space
Interfaces |  | 3 interface
IMigelValidator | database handling and global settings |
ISearch | search functionality |
IValidate | Validation of service records according to the rules |
Types |  |
type definitions | List of all used builtin, composite and enumeration types |
Important documents about the usage and handling |  |
Document | What to do in a 64bit environment - is there a 64bit Sumex1 COM dll? |
Document | Notice about the "configuration parameters" in the migelValidator100! |
Document | General usage of the migelValidator100 COM module - an overview |
14.09.21 - API Patch | List of patches for managing the new tariff 454 |
Document | migelValidatorServer100: Introduction, overview and usage of the Restful Webservice Server |

© by sumex1.net - all rights reserved


  • migelValidator100
  • IMigelValidator

IMigelValidator interface |  | V1.00/30 Aug 2002
The IMigelValidator interface handles connections to the migel database. It provides a means to open and close database connections, and set and retrieve general database parameters, such as the database or module versions. A connection to the database must be opened via IMigelValidator before methods from any of the other interfaces can be used. |  | space
space
Methods |  | 12 methods
Close | Closes the MiGel database. |
GetAbortInfo | Get the abort information. |
GetChapters | Method for collecting all Migel tariff chapter data covered by the validator and returned as JSON array |
GetFirstChapter | Retrieves the first chapter information |
GetFirstTPValue | Retrieves the first tax point value information. |
GetNextChapter | Retrieves the next chapter information. |
GetNextTPValue | Retrieves the next tax point value information. |
GetTPValues | Method for collecting all TPValue data covered by the validator and returned as JSON array |
GetTreatment | Get the treatment input data. |
Open | Opens the MiGel database. |
OpenEx | Opens the MiGel database. |
SetTreatment | Set the treatment input data. |
space
Properties |  | 19 properties
[get] CreateMigelValidator | Creates an instance of the main IMigelValidator interface |
[get] CreateSearch | Create an instance of the ISearch interface. |
[get] CreateValidate | Create an instance of the IValidate interface. |
[get/put] Date | Get and Set the current date for the migelValidator100 module |
[get] DBVersion | Get the version of the migelValidator100 database. |
[get] DBVersionDate | Get the version date of the migelValidator100 database. |
[get] DBVersionText | Get the textual version of the migelValidator100 database. |
[put] DestructMigelValidator | Destructs/invalidates a main instance of the IMigelValidator interface |
[put] DestructSearch | Destructs/invalidates this ISearch interface instance |
[put] DestructValidate | Destructs/invalidates this IValidate interface instance |
[get/put] EnableLog | Get and Set the log activity for the module |
[get/put] ExternalFactor | External scaling factor for the service. |
[get/put] Language | Get and Set the language for the migelValidator100 module |
[get] ModuleVersion | Get the version of the migelValidator100 module. |
[get] ModuleVersionText | Get the textual version of the migelValidator100 module. |
[get/put] PlaceType | Get and Set the place where the service is provided. |
[get/put] RoleType | Role type of the service provider. |
[get/put] WildCard | Get and Set the match-all wildcard character for SQL queries |
[get/put] WildCharacter | Get and Set the "match any single character" wildcard character for SQL queries |
space |


  • IMigelValidator
  • Close

IMigelValidator::Close method |  |  | space
Closes the MiGel database. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IMigelValidator/Close
[JSON input data] | pIMigelValidator: | longValue, //interface address
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT Close( | VARIANT_BOOL | *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IMigelValidator
  • GetAbortInfo

IMigelValidator::GetAbortInfo method |  |  | space
Get the abort information. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IMigelValidator/GetAbortInfo
[JSON input data] | pIMigelValidator: | longValue, //interface address
[JSON result data] | pbstrAbort: pbStatus: | "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetAbortInfo( | BSTR VARIANT_BOOL | *pbstrAbort, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrAbort | Abort information string. If the abort string is empty then there is no error condition - S_FALSE was set (e.g. in an iterator to signal end_of_data) |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IMigelValidator
  • GetChapters

IMigelValidator::GetChapters method |  |  | space
This method has a Restful Webservice representation only! Method for collecting all Migel tariff chapter data covered by the validator and returned as JSON array. Please note that IMigelValidator::GetChapters takes over the functionality of the iterator pair IMigelValidator::GetFirstChapter / IMigelValidator::GetNextChapter with a single call, making the latter superfluous. Method patched for searching tariff dependent on tariff 452 or 454 - cf. variable bstrCode! The list of all applied patches can be seen at "List of patches for managing the new tariff 454" |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IMigelValidator/GetChapters
[JSON input data] | pIMigelValidator: bstrCode: | longValue, //interface address "utf8StringValue"
[JSON result array] | { pbstrCode: pbstrName: pbstrInterpretation: pbstrLimitation: pbStatus: | "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", booleanValue },
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Calling argument description |  |  |
[in] BSTR | bstrCode | Query string for searching in the chapter code field of the tariff. Use asterisk symbol (*) to query for all records. Patch: prepend the tag ("454::" | "452::" | "") allows to focus the search onto the appropriate tariff catalog, with the empty tag as default for tariff 452. |
[out] BSTR | *pbstrCode | Chapter code |
[out] BSTR | *pbstrName | Chapter name |
[out] BSTR | *pbstrInterpretation | Chapter interpretation |
[out] BSTR | *pbstrLimitation | Chapter limitation |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IMigelValidator
  • GetFirstChapter

IMigelValidator::GetFirstChapter method |  |  | space
Retrieves the first chapter information. Method patched for searching tariff dependent on tariff 452 or 454 - cf. variable bstrCode! The list of all applied patches can be seen at "List of patches for managing the new tariff 454" |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IMigelValidator/GetFirstChapter
[JSON input data] | pIMigelValidator: bstrCode: | longValue, //interface address "utf8StringValue"
[JSON result data] | pbstrCode: pbstrName: pbstrInterpretation: pbstrLimitation: pbStatus: | "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetFirstChapter( | BSTR BSTR BSTR BSTR BSTR VARIANT_BOOL | bstrCode, *pbstrCode, *pbstrName, *pbstrInterpretation, *pbstrLimitation, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrCode | Query string for searching in the chapter code field of the tariff. Use asterisk symbol (*) to query for all records. Patch: prepend the tag ("454::" | "452::" | "") allows to focus the search onto the appropriate tariff catalog, with the empty tag as default for tariff 452. |
[out] BSTR | *pbstrCode | Chapter code |
[out] BSTR | *pbstrName | Chapter name |
[out] BSTR | *pbstrInterpretation | Chapter interpretation |
[out] BSTR | *pbstrLimitation | Chapter limitation |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IMigelValidator
  • GetFirstTPValue

IMigelValidator::GetFirstTPValue method |  |  | space
Retrieves the first tax point value information. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IMigelValidator/GetFirstTPValue
[JSON input data] | pIMigelValidator: | longValue, //interface address
[JSON result data] | pdTPValue: pdValidFrom: pdValidTo: pbStatus: | doubleValue, "stringISODateValue", "stringISODateValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetFirstTPValue( | double DATE DATE VARIANT_BOOL | *pdTPValue, *pdValidFrom, *pdValidTo, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] double | *pdTPValue | Tax point value. |
[out] DATE | *pdValidFrom | Tax point value valid from date. |
[out] DATE | *pdValidTo | Tax point value valid to date. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IMigelValidator
  • GetNextChapter

IMigelValidator::GetNextChapter method |  |  | space
Retrieves the next chapter information. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IMigelValidator/GetNextChapter
[JSON input data] | pIMigelValidator: | longValue, //interface address
[JSON result data] | pbstrCode: pbstrName: pbstrInterpretation: pbstrLimitation: pbStatus: | "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetNextChapter( | BSTR BSTR BSTR BSTR VARIANT_BOOL | *pbstrCode, *pbstrName, *pbstrInterpretation, *pbstrLimitation, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrCode | Chapter code |
[out] BSTR | *pbstrName | Chapter name |
[out] BSTR | *pbstrInterpretation | Chapter interpretation |
[out] BSTR | *pbstrLimitation | Chapter limitation |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IMigelValidator
  • GetNextTPValue

IMigelValidator::GetNextTPValue method |  |  | space
Retrieves the next tax point value information. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IMigelValidator/GetNextTPValue
[JSON input data] | pIMigelValidator: | longValue, //interface address
[JSON result data] | pdTPValue: pdValidFrom: pdValidTo: pbStatus: | doubleValue, "stringISODateValue", "stringISODateValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetNextTPValue( | double DATE DATE VARIANT_BOOL | *pdTPValue, *pdValidFrom, *pdValidTo, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] double | *pdTPValue | Tax point value. |
[out] DATE | *pdValidFrom | Tax point value valid from date. |
[out] DATE | *pdValidTo | Tax point value valid to date. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IMigelValidator
  • GetTPValues

IMigelValidator::GetTPValues method |  |  | space
This method has a Restful Webservice representation only! Method for collecting all TPValue data covered by the validator and returned as JSON array Please note that IMigelValidator::GetTPValues takes over the functionality of the iterator pair IMigelValidator::GetFirstTPValue / IMigelValidator::GetNextTPValue with a single call, making the latter superfluous. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IMigelValidator/GetTPValues
[JSON input data] | pIMigelValidator: | longValue, //interface address
[JSON result array] | { pdTPValue: pdValidFrom: pdValidTo: pbStatus: | doubleValue, "stringISODateValue", "stringISODateValue", booleanValue },
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Calling argument description |  |  |
[out] double | *pdTPValue | Tax point value. |
[out] DATE | *pdValidFrom | Tax point value valid from date. |
[out] DATE | *pdValidTo | Tax point value valid to date. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IMigelValidator
  • GetTreatment

IMigelValidator::GetTreatment method |  |  | space
Get the treatment input data. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IMigelValidator/GetTreatment
[JSON input data] | pIMigelValidator: | longValue, //interface address
[JSON result data] | peCanton: peLaw: peSettlement: pbStatus: | longValue, longValue, longValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetTreatment( | CantonType LawType SettlementType VARIANT_BOOL | *peCanton, *peLaw, *peSettlement, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] CantonType | *peCanton | Canton type. |
[out] LawType | *peLaw | Law type. |
[out] SettlementType | *peSettlement | Settlement type. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IMigelValidator
  • Open

IMigelValidator::Open method |  |  | space
Opens the MiGel database. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IMigelValidator/Open
[JSON input data] | pIMigelValidator: eLanguage: | longValue, //interface address longValue
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT Open( | LanguageType VARIANT_BOOL | eLanguage, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] LanguageType | eLanguage | The choosen language of the tariff that should be opened |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IMigelValidator
  • OpenEx

IMigelValidator::OpenEx method |  |  | space
Opens the MiGel database. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IMigelValidator/OpenEx
[JSON input data] | pIMigelValidator: bstrConnect: | longValue, //interface address "utf8StringValue"
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT OpenEx( | BSTR VARIANT_BOOL | bstrConnect, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrConnect | Connect string for the database. See the Open method for the ADO Connection object for a detailed description. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IMigelValidator
  • SetTreatment

IMigelValidator::SetTreatment method |  |  | space
Set the treatment input data. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IMigelValidator/SetTreatment
[JSON input data] | pIMigelValidator: eCanton: eLaw: eSettlement: | longValue, //interface address longValue, longValue, longValue
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT SetTreatment( | CantonType LawType SettlementType VARIANT_BOOL | eCanton, eLaw, eSettlement, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] CantonType | eCanton | Canton type. |
[in] LawType | eLaw | Law type. |
[in] SettlementType | eSettlement | Settlement type. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IMigelValidator
  • CreateMigelValidator

IMigelValidator::CreateMigelValidator property |  |  | space
This property has a Restful Webservice representation only! Creates an instance of the main IMigelValidator interface. To delete/invalidate this interface instance, the counterpart property PutDestructMigelValidator must be explicitly called, since the pIMigelValidator address has a global scope and is not automatically destructed. |  |  |
space
Restful webservice calling syntax |  |  |
[GET] | /baseURL/ IMigelValidator/GetCreateMigelValidator
[JSON result data] | pIMigelValidator: | longValue //interface address
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Remarks |  |  |
This property has a Restful Webservice representation only! |  |  |
space |


  • IMigelValidator
  • CreateSearch

IMigelValidator::CreateSearch property | space
Create an instance of the ISearch interface.
space
Restful webservice calling syntax
[GET] | /baseURL/ IMigelValidator/GetCreateSearch?param
[param] pIMigelValidator= longValue
[JSON result data] pISearch: longValue //interface address
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | CreateSearch( ISearch **peCreateSearch );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] ISearch | **peCreateSearch | The created instance of the Isearch interface
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • ISearch **GetCreateSearch(void);
space


  • IMigelValidator
  • CreateValidate

IMigelValidator::CreateValidate property | space
Create an instance of the IValidate interface.
space
Restful webservice calling syntax
[GET] | /baseURL/ IMigelValidator/GetCreateValidate?param
[param] pIMigelValidator= longValue
[JSON result data] pIValidate: longValue //interface address
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | CreateValidate( IValidate **peCreateValidate );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] IValidate | **peCreateValidate | The created instance of the IValidate interface
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • IValidate **GetCreateValidate(void);
space


  • IMigelValidator
  • Date

IMigelValidator::Date property | space
Get and Set the current date for the migelValidator100 module. This date will be used for each method where no explicit date must be specified, for example the SearchCode method in the ISearch interface. The default is the current date.
space
Restful webservice calling syntax
[GET] | /baseURL/ IMigelValidator/GetDate?param
[param] pIMigelValidator= longValue
[JSON result data] pdDate: "stringISODateValue"
[PUT] | /baseURL/ IMigelValidator/PutDate
[JSON input data] pIMigelValidator:
dDate: 		longValue, //interface address
variantDateValue | "stringISODateValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Date( DATE *pdDate );
[put] HRESULT | Date( DATE dDate );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] DATE | *pdDate | The defined date of the current service
[in] DATE | dDate | The defined date of the current service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • DATE *GetDate(void);
  • void PutDate( DATE dDate);
space


  • IMigelValidator
  • DBVersion

IMigelValidator::DBVersion property | space
Get the version of the migelValidator100 database.
space
Restful webservice calling syntax
[GET] | /baseURL/ IMigelValidator/GetDBVersion?param
[param] pIMigelValidator= longValue
[JSON result data] pbstrDBVersion: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | DBVersion( BSTR *pbstrDBVersion );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrDBVersion | The version of the currently open database
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetDBVersion(void);
space


  • IMigelValidator
  • DBVersionDate

IMigelValidator::DBVersionDate property | space
Get the version date of the migelValidator100 database.
space
Restful webservice calling syntax
[GET] | /baseURL/ IMigelValidator/GetDBVersionDate?param
[param] pIMigelValidator= longValue
[JSON result data] pdDBVersionDate: "stringISODateValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | DBVersionDate( DATE *pdDBVersionDate );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] DATE | *pdDBVersionDate | The version of the currently open database
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • DATE *GetDBVersionDate(void);
space


  • IMigelValidator
  • DBVersionText

IMigelValidator::DBVersionText property | space
Get the textual version of the migelValidator100 database.
space
Restful webservice calling syntax
[GET] | /baseURL/ IMigelValidator/GetDBVersionText?param
[param] pIMigelValidator= longValue
[JSON result data] pbstrDBVersionText: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | DBVersionText( BSTR *pbstrDBVersionText );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrDBVersionText | The textual version of the currently open database
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetDBVersionText(void);
space


  • IMigelValidator
  • DestructMigelValidator

IMigelValidator::DestructMigelValidator property |  |  | space
This property has a Restful Webservice representation only! Destructs/invalidates a main instance of the IMigelValidator interface. Please note, that all dependent, active interface instances generated with IMigelValidator::GetCreateValidate and/or IMigelSearch::GetCreateSearch under this main instances, are automatically destructed as well. The counterpart property to generate a main interface instance is IMigelValidator::GetCreateMigelValidator. |  |  |
space
Restful webservice calling syntax |  |  |
[PUT] | /baseURL/ IMigelValidator/PutDestructMigelValidator
[JSON input data] | pIMigelValidator: | longValue, //interface address
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Remarks |  |  |
This property has a Restful Webservice representation only! |  |  |
space |


  • IMigelValidator
  • DestructSearch

IMigelValidator::DestructSearch property |  |  | space
This property has a Restful Webservice representation only! Destructs/invalidates this ISearch interface instance. The counterpart property to generate an ISearch interface instance is IMigelValidator::GetCreateSearch. |  |  |
space
Restful webservice calling syntax |  |  |
[PUT] | /baseURL/ IMigelValidator/PutDestructSearch
[JSON input data] | pIMigelValidator: pISearch: | longValue, //interface address longValue, //interface address
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Remarks |  |  |
This property has a Restful Webservice representation only! |  |  |
space |


  • IMigelValidator
  • DestructValidate

IMigelValidator::DestructValidate property |  |  | space
This property has a Restful Webservice representation only! Destructs/invalidates this IValidate interface instance. The counterpart property to generate an Ivalidate interface instance is IMigelValidator::GetCreateValidate. |  |  |
space
Restful webservice calling syntax |  |  |
[PUT] | /baseURL/ IMigelValidator/PutDestructValidate
[JSON input data] | pIMigelValidator: pIValidate: | longValue, //interface address longValue, //interface address
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Remarks |  |  |
This property has a Restful Webservice representation only! |  |  |
space |


  • IMigelValidator
  • EnableLog

IMigelValidator::EnableLog property | space
Get and Set the log activity for the module. The default log activity is enYes.
space
Restful webservice calling syntax
[GET] | /baseURL/ IMigelValidator/GetEnableLog?param
[param] pIMigelValidator= longValue
[JSON result data] peEnableLog: longValue
[PUT] | /baseURL/ IMigelValidator/PutEnableLog
[JSON input data] pIMigelValidator:
eEnableLog: 		longValue, //interface address
longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | EnableLog( YesNoType *peEnableLog );
[put] HRESULT | EnableLog( YesNoType eEnableLog );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] YesNoType | *peEnableLog | Boolean that defines if the logging is enabled (enYes) or not (enNo)
[in] YesNoType | eEnableLog | Boolean that defines if the logging is enabled (enYes) or not (enNo)
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • YesNoType *GetEnableLog(void);
  • void PutEnableLog( YesNoType lEnableLog);
space


  • IMigelValidator
  • ExternalFactor

IMigelValidator::ExternalFactor property | space
External scaling factor for the service.
space
Restful webservice calling syntax
[GET] | /baseURL/ IMigelValidator/GetExternalFactor?param
[param] pIMigelValidator= longValue
[JSON result data] pdExternalFactor: doubleValue
[PUT] | /baseURL/ IMigelValidator/PutExternalFactor
[JSON input data] pIMigelValidator:
dExternalFactor: 		longValue, //interface address
doubleValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | ExternalFactor( double *pdExternalFactor );
[put] HRESULT | ExternalFactor( double dExternalFactor );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] double | *pdExternalFactor | The external scaling factor of the current services
[in] double | dExternalFactor | The external scaling factor of the current services
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • double *GetExternalFactor(void);
  • void PutExternalFactor( double dExternalFactor);
space


  • IMigelValidator
  • Language

IMigelValidator::Language property | space
Get and Set the language for the migelValidator100 module. The default language is enGerman.
space
Restful webservice calling syntax
[GET] | /baseURL/ IMigelValidator/GetLanguage?param
[param] pIMigelValidator= longValue
[JSON result data] peLanguage: longValue
[PUT] | /baseURL/ IMigelValidator/PutLanguage
[JSON input data] pIMigelValidator:
eLanguage: 		longValue, //interface address
longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Language( LanguageType *peLanguage );
[put] HRESULT | Language( LanguageType eLanguage );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] LanguageType | *peLanguage | The language for the main interface defining the language of the error messages
[in] LanguageType | eLanguage | The language for the main interface defining the language of the error messages
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • LanguageType *GetLanguage(void);
  • void PutLanguage( LanguageType lLanguage);
space


  • IMigelValidator
  • ModuleVersion

IMigelValidator::ModuleVersion property | space
Get the version of the migelValidator100 module.
space
Restful webservice calling syntax
[GET] | /baseURL/ IMigelValidator/GetModuleVersion?param
[param] pIMigelValidator= longValue
[JSON result data] pbstrModuleVersion: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | ModuleVersion( BSTR *pbstrModuleVersion );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrModuleVersion | The module version of the migelValidator module
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetModuleVersion(void);
space


  • IMigelValidator
  • ModuleVersionText

IMigelValidator::ModuleVersionText property | space
Get the textual version of the migelValidator100 module.
space
Restful webservice calling syntax
[GET] | /baseURL/ IMigelValidator/GetModuleVersionText?param
[param] pIMigelValidator= longValue
[JSON result data] pbstrModuleVersionText: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | ModuleVersionText( BSTR *pbstrModuleVersionText );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrModuleVersionText | The module version string of the migelValidator module
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetModuleVersionText(void);
space


  • IMigelValidator
  • PlaceType

IMigelValidator::PlaceType property | space
Get and Set the place where the service is provided.
space
Restful webservice calling syntax
[GET] | /baseURL/ IMigelValidator/GetPlaceType?param
[param] pIMigelValidator= longValue
[JSON result data] pePlaceType: longValue
[PUT] | /baseURL/ IMigelValidator/PutPlaceType
[JSON input data] pIMigelValidator:
ePlaceType: 		longValue, //interface address
longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | PlaceType( PlaceType *pePlaceType );
[put] HRESULT | PlaceType( PlaceType ePlaceType );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] PlaceType | *pePlaceType | The place type of that provides the services
[in] PlaceType | ePlaceType | The place type of that provides the services
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • PlaceType *GetPlaceType(void);
  • void PutPlaceType( PlaceType lPlaceType);
space


  • IMigelValidator
  • RoleType

IMigelValidator::RoleType property | space
Role type of the service provider.
space
Restful webservice calling syntax
[GET] | /baseURL/ IMigelValidator/GetRoleType?param
[param] pIMigelValidator= longValue
[JSON result data] peRoleType: longValue
[PUT] | /baseURL/ IMigelValidator/PutRoleType
[JSON input data] pIMigelValidator:
eRoleType: 		longValue, //interface address
longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | RoleType( RoleType *peRoleType );
[put] HRESULT | RoleType( RoleType eRoleType );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] RoleType | *peRoleType | The role type of that provides the services
[in] RoleType | eRoleType | The role type of that provides the services
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • RoleType *GetRoleType(void);
  • void PutRoleType( RoleType lRoleType);
space


  • IMigelValidator
  • WildCard

IMigelValidator::WildCard property | space
Get and Set the match-all wildcard character for SQL queries. You can use this property if you have imported the original MiGel database into another database, which uses a different wildcard character for queries. The default match-all wildcard character is the percent symbol (%). With the migelValidator100 module you can always formulate a query using the asterisk symbol (*) as a wildcard, as in each query string a * is replaced by the wildcard character specified by this property before being executed.
space
Restful webservice calling syntax
[GET] | /baseURL/ IMigelValidator/GetWildCard?param
[param] pIMigelValidator= longValue
[JSON result data] pbstrWildCard: "utf8StringValue"
[PUT] | /baseURL/ IMigelValidator/PutWildCard
[JSON input data] pIMigelValidator:
bstrWildCard: 		longValue, //interface address
"utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | WildCard( BSTR *pbstrWildCard );
[put] HRESULT | WildCard( BSTR bstrWildCard );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrWildCard | The wildcard symbol
[in] BSTR | bstrWildCard | The wildcard symbol
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetWildCard(void);
  • void PutWildCard( BSTR bstrWildCard);
space


  • IMigelValidator
  • WildCharacter

IMigelValidator::WildCharacter property | space
Get and Set the "match any single character" wildcard character for SQL queries. You can use this property if you have ported the original MiGel database into another database, which uses a different wild character for the queries. The default match-single-character wildcard character is the underscore symbol (_). With the migelValidator100 module you can always formulate a query using the question mark (?) as a wildcard, as in each query string a ? Is replaced by the wildcard character specified by this property before execution.
space
Restful webservice calling syntax
[GET] | /baseURL/ IMigelValidator/GetWildCharacter?param
[param] pIMigelValidator= longValue
[JSON result data] pbstrWildCharacter: "utf8StringValue"
[PUT] | /baseURL/ IMigelValidator/PutWildCharacter
[JSON input data] pIMigelValidator:
bstrWildCharacter: 		longValue, //interface address
"utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | WildCharacter( BSTR *pbstrWildCharacter );
[put] HRESULT | WildCharacter( BSTR bstrWildCharacter );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrWildCharacter | The wildcard character symbol
[in] BSTR | bstrWildCharacter | The wildcard character symbol
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetWildCharacter(void);
  • void PutWildCharacter( BSTR bstrWildCharacter);
space


  • ISearch

ISearch interface |  | V1.00/30 Aug 2002
The ISearch interface allows browsing of and retrieval of detailed information from the migel database. Searches can be performed by code or by name. The search terms may be specified in full, or may include wildcards. After a successful search, all of the available information directly related to the search term is made available through the interface"s properties. Every method which starts with the name Search (for example SearchName) produces as a result a selection list, composed of zero or more service records. The total number of records in the list can be retrieved using the method GetRecordCount. The record pointer is initially positioned at the first entry of the selection list. The available information related to the current record is made available through the interface"s properties. The methods MoveFirst, MoveLast, MoveNext, MovePrevious, PutAbsolutePosition, and GetAbsolutePosition are used to reposition the record pointer. |  | space
space
Methods |  | 11 methods
GetAbortInfo | Get the abort information. |
GetAbsolutePosition | Gets the current absolute position of the record pointer in the selection list |
GetRecordCount | Gets the number of service records in the selection list. |
GetServices | Method for collecting all service records of the resulting search space in one call without the necessity to call the record positioning methods and the appropriate properties of this interface |
MoveFirst | Moves the record pointer to the first record in the selection list and makes that record the current service record |
MoveLast | Moves to the last record in the selection list and makes that record the current service record |
MoveNext | Moves to the next record in the selection list and makes that record the current service record |
MovePrevious | Moves to the previous record in the selection list object and makes that record the current service record |
PutAbsolutePosition | Positions the record pointer at the specified absolute position in the selection list |
SearchCode | This method searches for services by code |
SearchName | This method searches for services by the service name |
space
Properties |  | 12 properties
[get] Code | Service code. |
[put] DestructSearch | Destructs/invalidates this ISearch interface instance |
[get] Interpretation | Service interpretation. |
[get] Limitation | Service limitation |
[get] Name | Service name. |
[get] OldCode | Obsolete: old MiGel code |
[get] Quantity | Quantity. |
[get] TP | Tax points of the service. |
[get] TPValue | Tax point value of the service. |
[get] Unit | Unit name (base unit). |
[get] ValidFrom | Service valid from date. |
[get] ValidTo | Service valid to date. |
space |


  • ISearch
  • GetAbortInfo

ISearch::GetAbortInfo method |  |  | space
Get the abort information. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearch/GetAbortInfo
[JSON input data] | pISearch: | longValue, //interface address
[JSON result data] | pbstrAbort: pbStatus: | "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetAbortInfo( | BSTR VARIANT_BOOL | *pbstrAbort, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrAbort | Abort information string. If the abort string is empty then there is no error condition - S_FALSE was set (e.g. in an iterator to signal end_of_data) |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ISearch
  • GetAbsolutePosition

ISearch::GetAbsolutePosition method |  |  | space
Gets the current absolute position of the record pointer in the selection list. This method can be useful for implementing virtual selection lists. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearch/GetAbsolutePosition
[JSON input data] | pISearch: | longValue, //interface address
[JSON result data] | plID: pbStatus: | longValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetAbsolutePosition( | long VARIANT_BOOL | *plID, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] long | *plID | The ID of the current service record |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ISearch
  • GetRecordCount

ISearch::GetRecordCount method |  |  | space
Gets the number of service records in the selection list. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearch/GetRecordCount
[JSON input data] | pISearch: | longValue, //interface address
[JSON result data] | plSize: pbStatus: | longValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetRecordCount( | long VARIANT_BOOL | *plSize, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] long | *plSize | The total number of service records included |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ISearch
  • GetServices

ISearch::GetServices method |  |  | space
This method has a Restful Webservice representation only! Method for collecting all service records of the resulting search space in one call without the necessity to call the record positioning methods and the appropriate properties of this interface. The services are returned as JSON array however large that search space might be. So this might be a memory and performance bottleneck. Possibly, one might call the IMigelSearch::GetRecordCount method to get the size of the search space prior to call GetServices unconditionally. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearch/GetServices
[JSON input data] | pISearch: | longValue, //interface address
[JSON result array] | { pbstrCode: pbstrName: pbstrInterpretation: pbstrLimitation: pdTP: pdTPValue: pdValidFrom: pdValidTo: pdQuantity: pbstrUnit: pbstrOldCode: pbStatus: | "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", doubleValue, doubleValue, "stringISODateValue", "stringISODateValue", doubleValue, "utf8StringValue", "utf8StringValue", booleanValue },
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrCode | The code of the currently focused service |
[out] BSTR | *pbstrName | The name of the currently focused service |
[out] BSTR | *pbstrInterpretation | The interpretation text of the currently focused service |
[out] BSTR | *pbstrLimitation | The limitation text of the currently focused service |
[out] double | *pdTP | The tax point (TP) of the currently focused service |
[out] double | *pdTPValue | The tax point value (TPV) of the currently focused service |
[out] DATE | *pdValidFrom | The validity start date of the currently focused service |
[out] DATE | *pdValidTo | The validity end date of the currently focused service |
[out] double | *pdQuantity | The defined quantity of the currently focused service |
[out] BSTR | *pbstrUnit | The defined unit of the currently focused service |
[out] BSTR | *pbstrOldCode | Obsolete: old MiGel code. Method patched to return the used tariff 452 or 454! The list of all applied patches can be seen at "List of patches for managing the new tariff 454" |
[out,retval] VARIANT_BOOL | *pbStatus | Boolean return status |
space |


  • ISearch
  • MoveFirst

ISearch::MoveFirst method |  |  | space
Moves the record pointer to the first record in the selection list and makes that record the current service record. If the action could not be performed false will be returned. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearch/MoveFirst
[JSON input data] | pISearch: | longValue, //interface address
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT MoveFirst( | VARIANT_BOOL | *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ISearch
  • MoveLast

ISearch::MoveLast method |  |  | space
Moves to the last record in the selection list and makes that record the current service record. If the action could not be performed false will be returned. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearch/MoveLast
[JSON input data] | pISearch: | longValue, //interface address
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT MoveLast( | VARIANT_BOOL | *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ISearch
  • MoveNext

ISearch::MoveNext method |  |  | space
Moves to the next record in the selection list and makes that record the current service record. If the action could not be performed false will be returned. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearch/MoveNext
[JSON input data] | pISearch: | longValue, //interface address
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT MoveNext( | VARIANT_BOOL | *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ISearch
  • MovePrevious

ISearch::MovePrevious method |  |  | space
Moves to the previous record in the selection list object and makes that record the current service record. If the action could not be performed false will be returned. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearch/MovePrevious
[JSON input data] | pISearch: | longValue, //interface address
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT MovePrevious( | VARIANT_BOOL | *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ISearch
  • PutAbsolutePosition

ISearch::PutAbsolutePosition method |  |  | space
Positions the record pointer at the specified absolute position in the selection list. This method can be useful for implementing virtual selection lists. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearch/PutAbsolutePosition
[JSON input data] | pISearch: lID: | longValue, //interface address longValue
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT PutAbsolutePosition( | long VARIANT_BOOL | lID, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] long | lID | The ID of the target service record |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ISearch
  • SearchCode

ISearch::SearchCode method |  |  | space
This method searches for services by code. Method patched for searching tariff dependent on tariff 452 or 454 - cf. variable bstrCode! The list of all applied patches can be seen at "List of patches for managing the new tariff 454" |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearch/SearchCode
[JSON input data] | pISearch: bstrCode: | longValue, //interface address "utf8StringValue"
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT SearchCode( | BSTR VARIANT_BOOL | bstrCode, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrCode | Query string for searching in the service code field of the tariff. Use asterisk symbol (*) to query for all records. Patch: prepend the tag ("454::" | "452::" | "") allows to focus the search onto the appropriate tariff catalog, with the empty tag as default for tariff 452. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ISearch
  • SearchName

ISearch::SearchName method |  |  | space
This method searches for services by the service name. Method patched for searching tariff dependent on tariff 452 or 454 - cf. variable bstrName! The list of all applied patches can be seen at "List of patches for managing the new tariff 454" |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearch/SearchName
[JSON input data] | pISearch: bstrName: | longValue, //interface address "utf8StringValue"
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT SearchName( | BSTR VARIANT_BOOL | bstrName, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrName | Query string for searching in the service name field of the tariff. Use asterisk symbol (*) to query for all records. Patch: prepend the tag ("454::" | "452::" | "") allows to focus the search onto the appropriate tariff catalog, with the empty tag as default for tariff 452. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ISearch
  • Code

ISearch::Code property | space
Service code.
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch/GetCode?param
[param] pISearch= longValue
[JSON result data] pbstrCode: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Code( BSTR *pbstrCode );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrCode | The code of the current service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetCode(void);
space


  • ISearch
  • DestructSearch

ISearch::DestructSearch property |  |  | space
This property has a Restful Webservice representation only! Destructs/invalidates this ISearch interface instance. The counterpart property to generate an ISearch interface instance is IMigelValidator::GetCreateSearch. |  |  |
space
Restful webservice calling syntax |  |  |
[PUT] | /baseURL/ ISearch/PutDestructSearch
[JSON input data] | pISearch: | longValue, //interface address
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Remarks |  |  |
This property has a Restful Webservice representation only! |  |  |
space |


  • ISearch
  • Interpretation

ISearch::Interpretation property | space
Service interpretation.
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch/GetInterpretation?param
[param] pISearch= longValue
[JSON result data] pbstrInterpretation: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Interpretation( BSTR *pbstrInterpretation );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrInterpretation | The interpretation text of the current service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetInterpretation(void);
space


  • ISearch
  • Limitation

ISearch::Limitation property | space
Service limitation
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch/GetLimitation?param
[param] pISearch= longValue
[JSON result data] pbstrLimitation: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Limitation( BSTR *pbstrLimitation );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrLimitation | The limitation text of the current service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetLimitation(void);
space


  • ISearch
  • Name

ISearch::Name property | space
Service name.
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch/GetName?param
[param] pISearch= longValue
[JSON result data] pbstrName: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Name( BSTR *pbstrName );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrName | The name of the current service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetName(void);
space


  • ISearch
  • OldCode

ISearch::OldCode property | space
Obsolete: old MiGel code.

Method patched to return the used tariff 452 or 454!
The list of all applied patches can be seen at "List of patches for managing the new tariff 454"
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch/GetOldCode?param
[param] pISearch= longValue
[JSON result data] pbstrOldCode: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | OldCode( BSTR *pbstrOldCode );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrOldCode | Patched to return the used tariff 452 or 454!
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetOldCode(void);
space


  • ISearch
  • Quantity

ISearch::Quantity property | space
Quantity.
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch/GetQuantity?param
[param] pISearch= longValue
[JSON result data] pdQuantity: doubleValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Quantity( double *pdQuantity );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] double | *pdQuantity | The quantity of the current service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • double *GetQuantity(void);
space


  • ISearch
  • TP

ISearch::TP property | space
Tax points of the service.
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch/GetTP?param
[param] pISearch= longValue
[JSON result data] pdTP: doubleValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | TP( double *pdTP );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] double | *pdTP | The tax points (TP) of the current service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • double *GetTP(void);
space


  • ISearch
  • TPValue

ISearch::TPValue property | space
Tax point value of the service.
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch/GetTPValue?param
[param] pISearch= longValue
[JSON result data] pdTPValue: doubleValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | TPValue( double *pdTPValue );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] double | *pdTPValue | The tax point value TPV of the current service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • double *GetTPValue(void);
space


  • ISearch
  • Unit

ISearch::Unit property | space
Unit name (base unit).
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch/GetUnit?param
[param] pISearch= longValue
[JSON result data] pbstrUnit: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Unit( BSTR *pbstrUnit );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrUnit | The unit of the current service e.g. 'per day', 'for rent'
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetUnit(void);
space


  • ISearch
  • ValidFrom

ISearch::ValidFrom property | space
Service valid from date.
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch/GetValidFrom?param
[param] pISearch= longValue
[JSON result data] pdValidFrom: "stringISODateValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | ValidFrom( DATE *pdValidFrom );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] DATE | *pdValidFrom | The validity start of the current service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • DATE *GetValidFrom(void);
space


  • ISearch
  • ValidTo

ISearch::ValidTo property | space
Service valid to date.
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch/GetValidTo?param
[param] pISearch= longValue
[JSON result data] pdValidTo: "stringISODateValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | ValidTo( DATE *pdValidTo );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] DATE | *pdValidTo | The validity end of the current service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • DATE *GetValidTo(void);
space


  • IValidate

IValidate interface |  | V1.00/30 Aug 2002
The IValidate interface checks whether supplied service data conform to the migel rules. In case of a conflict with another service, the service will be rejected. Textual information explaining why the code was rejected can be retrieved, in order to provide appropriate feedback to the user. |  | space
space
Methods |  | 9 methods
AddService | Adds a new service which will be validated against all the previously entered services of the same session |
CalculateSum | Calculate the sum of all services which have been added through the AddService method. |
GetAbortInfo | Get the information indicating why the service could not be added. |
GetService | Method for collecting all data of the currently focused service in one call without the necessity to call the appropriate properties of this interface |
Initialize | Initializes the validation, clears all the entered records. |
MoveFirst | Positions the record pointer at the first record in the result record set |
MoveLast | Positions the record pointer at the last record in the result record set |
MoveNext | Positions the record pointer at the next record in the result record set |
MovePrevious | Positions the record pointer at the previous record in the result record set |
space
Properties |  | 16 properties
[get] CantonType | Canton type. |
[get] Charge | The charge for the service in CHF. |
[get] Code | Service code. |
[get] Date | Date of the service. |
[put] DestructValidate | Destructs/invalidates this IValidate interface instance |
[get] ExternalFactor | Get and set the external scaling factor for the services. |
[get] Hook | The hook of the service (external ID). |
[get] ID | The internal ID of the service. |
[get] IgnoreValidate | Flag indicating whether the validation was ignored. |
[get] LawType | Law type. |
[get] Name | Service name. |
[get] Quantity | Quantity. |
[get] RoleType | Role type. |
[get] SettlementType | Settlement type. |
[get] TP | Tax points of the service. |
[get] TPValue | Tax point value of the service. |
space |


  • IValidate
  • AddService

IValidate::AddService method |  |  | space
Adds a new service which will be validated against all the previously entered services of the same session. If the code passed all the Validations a true value is returned. If the code was not accepted a value of false is returned and the variable plStatus contains the error code. Method patched for adding services from tariff 452 or 454 - cf. variable bstrCode! The list of all applied patches can be seen at "List of patches for managing the new tariff 454" |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IValidate/AddService
[JSON input data] | pIValidate: bstrCode: dQuantity: dTP: dTPValue: dDate: eIgnoreValidate: lHook: | longValue, //interface address "utf8StringValue", doubleValue, doubleValue, doubleValue, variantDateValue | "stringISODateValue", longValue, longValue
[JSON result data] | plStatus: pbStatus: | longValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT AddService( | long BSTR double double double DATE YesNoType long VARIANT_BOOL | *plStatus, bstrCode, dQuantity, dTP, dTPValue, dDate, eIgnoreValidate, lHook, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] long | *plStatus | A zero value is returned for success. A positive value indicates that a validation rule was not fulfilled, use the GetAbortInfo to get a description string and display an error message. A negative value indicates that the service was not added (see the AbortValidate Enumeration for possible codes). With the GetAbortInfo one can get a description, however preferable the required actions will be performed in the background. |
[in] BSTR | bstrCode | Code of the service. Patch: prepend the tag ("454::" | "452::" | "") select the appropriate tariff catalog, with the empty tag as default for tariff 452. |
[in] double | dQuantity | Quantity value. |
[in] double | dTP | Tax point of the service. A zero value will be substituted by the tax point form the catalog. |
[in] double | dTPValue | Tax point value of the service. A zero value will be substituted by the tax point value form the catalog. |
[in] DATE | dDate | Date of the service. |
[in] YesNoType | eIgnoreValidate | Flag indicating whether the validation was ignored. In the following situations this flag might be useful. The user wants to add the service even if the validation failed, perhaps he has a special agreement with the insurance or patient. When adding new services to already previously checked records, it is not necessary to check the existing records again. |
[in] long | lHook | External hook. The software house can provide for example the record ID of the service to identify the service later on. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IValidate
  • CalculateSum

IValidate::CalculateSum method |  |  | space
Calculate the sum of all services which have been added through the AddService method. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IValidate/CalculateSum
[JSON input data] | pIValidate: | longValue, //interface address
[JSON result data] | pdTotal: pbStatus: | doubleValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT CalculateSum( | double VARIANT_BOOL | *pdTotal, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] double | *pdTotal | Total of all services in CHF |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IValidate
  • GetAbortInfo

IValidate::GetAbortInfo method |  |  | space
Get the information indicating why the service could not be added. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IValidate/GetAbortInfo
[JSON input data] | pIValidate: | longValue, //interface address
[JSON result data] | pbstrAbort: pbStatus: | "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetAbortInfo( | BSTR VARIANT_BOOL | *pbstrAbort, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrAbort | Abort information string. If the abort string is empty then there is no error condition - S_FALSE was set (e.g. in an iterator to signal end_of_data) |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IValidate
  • GetService

IValidate::GetService method |  |  | space
This method has a Restful Webservice representation only! Method for collecting all data of the currently focused service in one call without the necessity to call the appropriate properties of this interface. The counterpart method to add services is IMigelValidator::AddService |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IValidate/GetService
[JSON input data] | pIValidate: | longValue, //interface address
[JSON result data] | plID: pbstrCode: pbstrName: pdQuantity: pdTP: pdTPValue: pdDate: peIgnoreValidate: plHook: pdExternalFactor: peCantonType: peLawType: peSettlementType: peRoleType: pdCharge: pbStatus: | longValue, "utf8StringValue", "utf8StringValue", doubleValue, doubleValue, doubleValue, "stringISODateValue", longValue, longValue, doubleValue, longValue, longValue, longValue, longValue, doubleValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Calling argument description |  |  |
[out] long | *plID | The internal ID of the currently focused service |
[out] BSTR | *pbstrCode | The code of the currently focused service |
[out] BSTR | *pbstrName | The name of the currently focused service |
[out] double | *pdQuantity | The quantity of the currently focused service |
[out] double | *pdTP | The tax point (TP) of the currently focused service |
[out] double | *pdTPValue | The tax point value (TPV) of the currently focused service |
[out] DATE | *pdDate | The application date of the currently focused service |
[out] YesNoType | *peIgnoreValidate | The flag indicating whether the currently focused service was ignored in validation (enNo) or not (enYes). |
[out] long | *plHook | The hook of the currently focused service |
[out] double | *pdExternalFactor | The external scaling factor applied to the currently focused service |
[out] CantonType | *peCantonType | The canton type applied to the currently focused service This canton setting is copied from the data supplied with the IMigelValidator::SetTreatment method. |
[out] LawType | *peLawType | The law type applied to the currently focused service This law setting is copied from the data supplied with the IMigelValidator::SetTreatment method. |
[out] SettlementType | *peSettlementType | The settlement type applied to the currently focused service This settlement setting is copied from the data supplied with the IMigelValidator::SetTreatment method. |
[out] RoleType | *peRoleType | The role type applied to the currently focused service This role setting is copied from the data supplied with the IMigelValidator::SetRoleType property. |
[out] double | *pdCharge | The charge in CHF of the currently focused service calculated as ( Charge = Quantity * TP * TPValue * ExternalFactor ) |
[out,retval] VARIANT_BOOL | *pbStatus | Boolean return status |
space |


  • IValidate
  • Initialize

IValidate::Initialize method |  |  | space
Initializes the validation, clears all the entered records. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IValidate/Initialize
[JSON input data] | pIValidate: | longValue, //interface address
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT Initialize( | VARIANT_BOOL | *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IValidate
  • MoveFirst

IValidate::MoveFirst method |  |  | space
Positions the record pointer at the first record in the result record set. If the action could not be performed false will be returned. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IValidate/MoveFirst
[JSON input data] | pIValidate: | longValue, //interface address
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT MoveFirst( | VARIANT_BOOL | *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IValidate
  • MoveLast

IValidate::MoveLast method |  |  | space
Positions the record pointer at the last record in the result record set. If the action could not be performed false will be returned. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IValidate/MoveLast
[JSON input data] | pIValidate: | longValue, //interface address
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT MoveLast( | VARIANT_BOOL | *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IValidate
  • MoveNext

IValidate::MoveNext method |  |  | space
Positions the record pointer at the next record in the result record set. If the action could not be performed false will be returned. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IValidate/MoveNext
[JSON input data] | pIValidate: | longValue, //interface address
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT MoveNext( | VARIANT_BOOL | *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IValidate
  • MovePrevious

IValidate::MovePrevious method |  |  | space
Positions the record pointer at the previous record in the result record set. If the action could not be performed false will be returned. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IValidate/MovePrevious
[JSON input data] | pIValidate: | longValue, //interface address
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT MovePrevious( | VARIANT_BOOL | *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IValidate
  • CantonType

IValidate::CantonType property | space
Canton type.
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetCantonType?param
[param] pIValidate= longValue
[JSON result data] peCantonType: longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | CantonType( CantonType *peCantonType );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] CantonType | *peCantonType | The canton type of the current service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • CantonType *GetCantonType(void);
space


  • IValidate
  • Charge

IValidate::Charge property | space
The charge for the service in CHF.
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetCharge?param
[param] pIValidate= longValue
[JSON result data] pdCharge: doubleValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Charge( double *pdCharge );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] double | *pdCharge | The charge in CHF of the current service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • double *GetCharge(void);
space


  • IValidate
  • Code

IValidate::Code property | space
Service code.
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetCode?param
[param] pIValidate= longValue
[JSON result data] pbstrCode: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Code( BSTR *pbstrCode );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrCode | The code of the current service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetCode(void);
space


  • IValidate
  • Date

IValidate::Date property | space
Date of the service.
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetDate?param
[param] pIValidate= longValue
[JSON result data] pdDate: doubleValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Date( double *pdDate );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] double | *pdDate | The defined date of the current service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • double *GetDate(void);
space


  • IValidate
  • DestructValidate

IValidate::DestructValidate property |  |  | space
This property has a Restful Webservice representation only! Destructs/invalidates this IValidate interface instance. The counterpart property to generate an IValidate interface instance is IMigelValidator::GetCreateValidate. |  |  |
space
Restful webservice calling syntax |  |  |
[PUT] | /baseURL/ IValidate/PutDestructValidate
[JSON input data] | pIValidate: | longValue, //interface address
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Remarks |  |  |
This property has a Restful Webservice representation only! |  |  |
space |


  • IValidate
  • ExternalFactor

IValidate::ExternalFactor property | space
Get and set the external scaling factor for the services.
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetExternalFactor?param
[param] pIValidate= longValue
[JSON result data] pdExternalFactor: doubleValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | ExternalFactor( double *pdExternalFactor );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] double | *pdExternalFactor | The external scaling factor of the current services
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • double *GetExternalFactor(void);
space


  • IValidate
  • Hook

IValidate::Hook property | space
The hook of the service (external ID).
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetHook?param
[param] pIValidate= longValue
[JSON result data] plHook: longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Hook( long *plHook );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] long | *plHook | The hook of the current service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • long *GetHook(void);
space


  • IValidate
  • ID

IValidate::ID property | space
The internal ID of the service.
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetID?param
[param] pIValidate= longValue
[JSON result data] plID: longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | ID( long *plID );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] long | *plID | The internal ID of the current service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • long *GetID(void);
space


  • IValidate
  • IgnoreValidate

IValidate::IgnoreValidate property | space
Flag indicating whether the validation was ignored.
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetIgnoreValidate?param
[param] pIValidate= longValue
[JSON result data] peIgnoreValidate: longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | IgnoreValidate( YesNoType *peIgnoreValidate );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] YesNoType | *peIgnoreValidate | Boolean that defines if the current service has a 'ignore validate' status (enYes) or not (enNo)
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • YesNoType *GetIgnoreValidate(void);
space


  • IValidate
  • LawType

IValidate::LawType property | space
Law type.
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetLawType?param
[param] pIValidate= longValue
[JSON result data] peLawType: longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | LawType( LawType *peLawType );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] LawType | *peLawType | The law type of the current service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • LawType *GetLawType(void);
space


  • IValidate
  • Name

IValidate::Name property | space
Service name.
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetName?param
[param] pIValidate= longValue
[JSON result data] pbstrName: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Name( BSTR *pbstrName );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrName | The name of the current service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetName(void);
space


  • IValidate
  • Quantity

IValidate::Quantity property | space
Quantity.
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetQuantity?param
[param] pIValidate= longValue
[JSON result data] pdQuantity: doubleValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Quantity( double *pdQuantity );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] double | *pdQuantity | The quantity of the current service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • double *GetQuantity(void);
space


  • IValidate
  • RoleType

IValidate::RoleType property | space
Role type.
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetRoleType?param
[param] pIValidate= longValue
[JSON result data] peRoleType: longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | RoleType( RoleType *peRoleType );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] RoleType | *peRoleType | The role type of that provides the services
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • RoleType *GetRoleType(void);
space


  • IValidate
  • SettlementType

IValidate::SettlementType property | space
Settlement type.
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetSettlementType?param
[param] pIValidate= longValue
[JSON result data] peSettlementType: longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | SettlementType( SettlementType *peSettlementType );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] SettlementType | *peSettlementType | The settlement type of the current service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • SettlementType *GetSettlementType(void);
space


  • IValidate
  • TP

IValidate::TP property | space
Tax points of the service.
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetTP?param
[param] pIValidate= longValue
[JSON result data] pdTP: doubleValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | TP( double *pdTP );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] double | *pdTP | The tax points (TP) of the current service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • double *GetTP(void);
space


  • IValidate
  • TPValue

IValidate::TPValue property | space
Tax point value of the service.
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetTPValue?param
[param] pIValidate= longValue
[JSON result data] pdTPValue: doubleValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | TPValue( double *pdTPValue );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] double | *pdTPValue | The tax point value TPV of the current service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • double *GetTPValue(void);
space


  • Type definitions

Builtin, composite & enumeration types |  | V1.00/30 Aug 2002
The following list shows ans defines all used data types either basic builtin, composite or enumeration types that are used in the interface of the ATL COM module. |  | space
space
Data types |  | 16 types
[enumeration] AbortValidateType | Enumerates the defined grounds for an aborted validation attempt. |
[builtin] BSTR | A BSTR, known as basic string or binary string, is a pointer to a wide character string used by Automation data manipulation functions |
[enumeration] CantonType | Enumerates the defined canton categories. |
[builtin] DATE | A value denoting a date and time was specified |
[builtin] double | An 8-byte IEEE real value. |
[builtin] HRESULT | The HRESULT data type is a 32-bit value that is used to describe an error or warning. |
[builtin] ISearch | ISearch interface. |
[builtin] IValidate | IValidate interface. |
[enumeration] LanguageType | Enumerates all supported languages. |
[enumeration] LawType | Enumerates the supported legal ruleset. |
[builtin] long | A 4-byte integer value. |
[enumeration] PlaceType | Enumerates the defined principal location of the service provider e.g |
[enumeration] RoleType | Enumerates the defined role categories. |
[enumeration] SettlementType | Enumerates the defined settlement categories. |
[builtin] VARIANT_BOOL | A 16 bit Boolean (True/False) value was specified |
[enumeration] YesNoType | Boolean enumerator. |
space |


  • Type definitions
  • AbortValidateType

AbortValidateType enumeration type |  |
Enumerates the defined grounds for an aborted validation attempt. |  | space
space
Set of enumeration values |  | 9 elements
enDatabaseNotOpen: 101 | The database is not open. |
enServiceNotFound: 301 | No service record found. |
enWrongTP: 401 | Wrong tax point specified. |
enWrongTPValue: 402 | Wrong tax point value specified. |
enNoTPValueFound: 403 | The tax point value could not be determined. |
enTreatmentDataChanged: 404 | Treatment input is not allowed to change. |
enExclusionRestriction: 405 | Exclusion restriction not fulfilled. |
enWrongAmount: 406 | Wrong amount specified. |
enValidateFailed: 999 | The validation failed - incompatible database parameters - contact the support. |
space


  • Type definitions
  • BSTR

BSTR type |
A BSTR, known as basic string or binary string, is a pointer to a wide character string used by Automation data manipulation functions. BSTRs are wide, double-byte (Unicode) strings on 32-bit Windows platforms. | space
space
space


  • Type definitions
  • CantonType

CantonType enumeration type |  |
Enumerates the defined canton categories. |  | space
space
Set of enumeration values |  | 31 elements
enCantonUndefined: 0 | Undefined or unknown canton. |
enAG: 1 | AG |
enAI: 2 | AI |
enAR: 3 | AR |
enBE: 4 | BE |
enBL: 5 | BL |
enBS: 6 | BS |
enFR: 7 | FR |
enGE: 8 | GE |
enGL: 9 | GL |
enGR: 10 | GR |
enJU: 11 | JU |
enLU: 12 | LU |
enNE: 13 | NE |
enNW: 14 | NW |
enOW: 15 | OW |
enSG: 16 | SG |
enSH: 17 | SH |
enSO: 18 | SO |
enSZ: 19 | SZ |
enTG: 20 | TG |
enTI: 21 | TI |
enUR: 22 | UR |
enVD: 23 | VD |
enVS: 24 | VS |
enZG: 25 | ZG |
enZH: 26 | ZH |
enGermany: 27 | Germany |
enItaly: 28 | Italy |
enFrance: 29 | France |
enLiechtenstein: 30 | Liechtenstein |
space


  • Type definitions
  • DATE

DATE type |
A value denoting a date and time was specified. Dates are represented as double-precision numbers, where midnight, January 1, 1900 is 2.0, January 2, 1900 is 3.0, and so on. The value is passed in date. | space
space
space


  • Type definitions
  • double

double type |
An 8-byte IEEE real value. | space
space
space


  • Type definitions
  • HRESULT

HRESULT type |
The HRESULT data type is a 32-bit value that is used to describe an error or warning. | space
space
space


  • Type definitions
  • ISearch

ISearch type |
ISearch interface. | space
space
space


  • Type definitions
  • IValidate

IValidate type |
IValidate interface. | space
space
space


  • Type definitions
  • LanguageType

LanguageType enumeration type |  |
Enumerates all supported languages. |  | space
space
Set of enumeration values |  | 4 elements
enGerman: 1 | German |
enFrench: 2 | French. |
enItalian: 3 | Italian |
enEnglish: 4 | English |
space


  • Type definitions
  • LawType

LawType enumeration type |  |
Enumerates the supported legal ruleset. |  | space
space
Set of enumeration values |  | 5 elements
enKVG: 0 | KVG |
enUVG: 1 | UVG |
enMVG: 2 | MVG |
enIVG: 3 | IVG |
enVVG: 4 | VVG |
space


  • Type definitions
  • long

long type |
A 4-byte integer value. | space
space
space


  • Type definitions
  • PlaceType

PlaceType enumeration type |  |
Enumerates the defined principal location of the service provider e.g. the principal authority under which the service provider is acting. |  | space
space
Set of enumeration values |  | 4 elements
enPlaceUndefined: 0 | Undefined or unknown place. |
enPlacePractice: 1 | Practice |
enPlaceHospital: 2 | Hospital |
enPlaceLab: 4 | Lab |
space


  • Type definitions
  • RoleType

RoleType enumeration type |  |
Enumerates the defined role categories. |  | space
space
Set of enumeration values |  | 12 elements
enRoleUndefined: 0 | Undefined or unknown role. |
enRolePhysician: 1 | Physician |
enRolePhysiotherapist: 2 | Physiotherapist |
enRoleChiropractor: 4 | Chiropractor |
enRoleErgotherapist: 8 | Ergotherapist |
enRoleNutritionist: 16 | Nutritionist |
enRoleMidwife: 32 | Midwife |
enRoleLogopedician: 64 | Logopedician |
enRoleOrthopedician: 128 | Orthopedician |
enRoleShoemaker: 256 | Shoemaker |
enRoleDentist: 512 | Dentist |
enRoleTechnician: 1024 | Specifies the principle role of person acting as a technician. The exact meaning of technician depends on the applied tariff system. For instance, in the context of the lab tariff a technician means a laboratory technician where as in the context of a dental tariff it would map to a dental technician. Anyway, a technician is never a person acting as person in medical care (e.g. physician, nurse, physiotherapist, ...) |
space


  • Type definitions
  • SettlementType

SettlementType enumeration type |  |
Enumerates the defined settlement categories. |  | space
space
Set of enumeration values |  | 2 elements
enSettlementElectronic: 0 | Electronic transmitting of the bill. |
enSettlementPaper: 1 | Print on paper of the bill. |
space


  • Type definitions
  • VARIANT_BOOL

VARIANT_BOOL type |
A 16 bit Boolean (True/False) value was specified. A value of 0xFFFF (all bits 1) indicates True; a value of 0 (all bits 0) indicates False. No other values are valid. | space
space
space


  • Type definitions
  • YesNoType

YesNoType enumeration type |  |
Boolean enumerator. |  | space
space
Set of enumeration values |  | 2 elements
enNo: 0 | No. |
enYes: 1 | Yes. |
space


 Sumex1 under a 64bit architecture...

All Sumex1 COM modules are written as 32bit managed C++ dll. As a consequence, a 64bit executable cannot load a 32bit COM dll into its process space due to the addressing differences.

Since some necessary underlying sub-modules are not available in a 64bit version, this problem must be addressed differently than by a 64bit compilation. As Microsoft suggests Sumex1 uses the out-of-process proxy approach where a 32bit COM server loads the 32bit COM dll into its process space and delegates each method call to the dll. Since a 32bit COM server exists in its own process space, the main 64bit process can handle the 64/32bit boundary without problems.

As a result, each 32bit Sumex1 COM dll has a 32bit COM server counterpart with the same name and an oopProxy prefix, e.g. oopProxyMigelValidator100.exe, where the prefix signifies the out-of-process proxy nature of the executable.

Any 64bit software now creates an instance of the 32bit oopProxy server and then calls the same methods and properties as with the 32bit COM dll. However, there is one crucial difference when using the oopProxy mechanism, namely the necessity to forcefully unload to the COM server at the end e.g. by using Marshal.ReleaseComObject() since the automatic garbage collection approach is too error prone.


 General use of the migelValidator ATL COM module

  • First create an instance of the migelValidator COM module.
  • Open the migel database with the Open method from the IMigelValidator interface. Set the localization language (if it differs from the default setting of German) using the SetLanguage from the IMigelValidator interface.
  • The following steps may then be performed, until the migelValidator module instance is released:
  • Let the user search for a code (see the Search functions from the ISearch interface).
  • Add the selected services to the AddService method from the IValidate interface.
  • Release the migelValidator COM module instance.


 Notice about the "configuration parameters" in the migelValidator!!

Please note:

The IMigelValidator module provides the method SetTreatment for setting treatment relevant parameters like the canton, the applied law (UVG, KVG,...), as well as the property RoleType for setting the principal role of the service provider (Physician, Hospital, Laboratory,...).

Currently these parameters are not relevant!
Neither are these parameters used for validating/limiting the set of available services nor is the evaluated tax point value in any way a function of these parameters.

However, the future might be different?
Should that occur, there is no further need for a software company to change any of their code, as the parameters are already supplied to the validator module. Therefore we strongly urge you to use this feature.


 List of patches for managing the new tariff 454

As of 1.10.2021 the new tariff 454 - "MiGel for Care Provider" becomes active.

For providers who do not require the new tariff 454, no changes whatsoever are necessary in the access/control of the migelValidator100. The tag "454::" can now be prepended to each code variable to indicate/use the new tariff 454 instead of 452.

The following list shows the patches made to reach the goal of managing tariff 454.

  • IMigelValidator interface
    • GetFirstChapter method
      One can prepend the tag ("454::" | "452::" | "") to the bstrCode variable to select the appropriate tariff catalog. Note, that the empty tag is the default, meaning to focus the chapter search onto the tariff 452.

  • ISearch interface
    • SearchName method
      One can prepend the tag ("454::" | "452::" | "") to the bstrCode variable to select the appropriate tariff catalog. Note, that the empty tag is the default, meaning to focus the code search onto the tariff 452.
    • SearchCode method
      One can prepend the tag ("454::" | "452::" | "") to the bstrCode variable to select the appropriate tariff catalog. Note, that the empty tag is the default, meaning to focus the naming search onto the tariff 452.
    • OldCode property
      Patched behavior, insofar as the used tariff number (454 | 452) is returned.

  • IValidate interface
    • AddValidate method
      One can prepend the tag ("454::" | "452::" | "") to the bstrCode variable to select the appropriate tariff catalog. Note, that the empty tag is the default, meaning to focus to tariff 452.
      It is possible to mix services of both tariffs. However, there is not possibility to signal back the tariff number of a given service.


 Introduction, overview and usage of the Restful Webservice Server

The application migelValidatorServer100.exe is a Restful Webservice Server, that has the same interface methods/properties as the COM module migelValidator100.dll. This allows to create a programming semantically similar to the COM approach but under the Restful Webservice paradigm. Consequently, on the Restful Client side there are no prevailing dependencies on Microsoft platforms and/or on Microsoft resources such as the database technology. Of course, the installation location of the server software is still subject to these restrictions.

In the next section of this document, the installation, configuration and operation of migelValidatorServer100.exe will be addressed.

Installation, registration and parameterization:
By installing the installer object migelValidator100 the COM module migelValidator100.dll as well as the out-of-process proxy component oopMigelValidator100.exe is automatically installed/registered in the system. However, the migelValidatorServer100.exe must be installed manually as a service.
migelValidatorServer100.exe -help | Creates a help window with the the name and full version of the applicationb as well as the currently define Webservice Endpoint. Furthermore the complete list of command line switches is shown.
migelValidatorServer100.exe -install | Installs/registers the Restful Webservice Server as a service. Please take into account, that the installation must be performed under administrator privileges
migelValidatorServer100.exe -uninstall | Uninstalls the service component. Please take into account, that the uninstallation must be performed under administrator privileges
migelValidatorServer100.exe -setport X | Sets the port X as part of the Webservice Endpoint
Restful Webservice Endpoint:
Installing migelValidatorServer100.exe as a service activates the Restful Webservice Endpoint:
http://localhost:34448/migelValidatorServer100
which is subsumed as baseURL in subsequent the API documentation.

To run the webservice under a different URL or under https protocol, a permanent webservice target endpoint mapping is performed on the target system.
For example, under Apache, the following rewrite rule is defined:
<VirtualHost *:*>
    ProxyPreserveHost Off
    Header always set Access-Control-Allow-Origin "*"
    Header always set Access-Control-Max-Age "1000"
    Header always set Access-Control-Allow-Headers "x-requested-with, Content-Type, origin, authorization, accept, client-security-token"

    ProxyPass /migelValidator/100/ http://localhost:34448/migelValidatorServer100/
    ProxyPassReverse /migelValidator/100/ http://localhost:34448/migelValidatorServer100/
</VirtualHost>
Restful Webservice Operation:
The service may be modified after installation, for example to start under a different account, to extend the recovery properties or to change the startup type. Finally, this should be set to 'Automatic' or 'Automatic (Delayed start)' so that the service is automatically available after a system restart.
Remarks about programming:
In the rest of this document we will discuss programming of the Restful web service and the differences to the C/C++ programming of the classic COM component.

As already mentioned, Restful programming is analogous to C++ programming with the addition that each instance of an interface (including the main interface) is created via the corresponding GET function. For example, an instance of the main interface is created with:
baseURL/IMigelValidator/GetCreateMigelValidator | returns the instance address as JSON out{pIMigelValidator: longValue,...}
In every further call of a method or a property of the main interface this instance address must be included as part of the JSON-In. The termination/deletion of an instance must be done via the corresponding PUT Destruct property:
baseURL/IMigelValidator/PutDestructMigelValidator | with JSON-In{pIMigelValidator: longValue}, deletes the corresponding main instance AND all at that moment still active dependent subinstances (subinstances which have been generated by the explicit main instance).
It should be noted that the webserver migelValidatorServer100.exe performs an internal management of the generated instances and automatically deletes instances that have no activity for a defined period of 2 hours. no activity over a defined period of 2 hours. If after this action a rest call with such an instance is made, an error (HTTP Status >= 400) is generated and the instance address is marked as unknown.
Code snippet:
Minimal code snippet to query the version of the module and the associated database:
    http://localhost:34448/migelValidatorServer100/IMigelValidator/GetCreateMigelValidator
        returns JSON-Out{pIMigelValidator: 45467}

    http://localhost:34448/migelValidatorServer100/IMigelValidator/GetModuleVersion?pIMigelValidator=45467
        returns JSON-Out{pbstrModuleVersion: "1.00.010"}

    http://localhost:34448/migelValidatorServer100/IMigelValidator/GetDBVersionText?pIMigelValidator=45467
        returns JSON-Out{pbstrDBVersionText: "3.22"}

    http://localhost:34448/migelValidatorServer100/IMigelValidator/GetDBVersionDate?pIMigelValidator=45467
        returns JSON-Out{pdDBVersionDate: "2021-11-29"}

    http://localhost:34778/migelValidatorServer100/IMigelValidator/GetCreateValidate?pIMigelValidator=45467
        returns JSON-Out{pIValidate: 47008}

    http://localhost:34778/migelValidatorServer100/IValidate/PutDestructValidate
        JSON-IN(pIValidate: 47008}

    http://localhost:34448/migelValidatorServer100/IMigelValidator/PutDestructMigelValidator
        JSON-IN{pIMigelValidator:45467}