 API browser of miscValidator200 COM module
Interface version: | 2.00
Interface date: | 1 May 2014

The miscValidator200 is an ATL COM module which provides methods to browse, search, and validate services from various included tariff catalogs. Provisions are made to browse these tariff catalogs and to retrieve possible restrictions in the usage of these tariff catalogs. |  | space
Interfaces |  | 4 interface
IChapter | Search and browse functionality of chapters over all included tariff catalogs |
IMiscValidator | Main interface for the database handling and global parameter settings |
ISearch | Search and browse functionality of services over all included tariff catalogs |
IValidate | Validation of services according to the rules |
Types |  |
type definitions | List of all used builtin, composite and enumeration types |
Important documents about the usage and handling |  |
Document | General usage of the miscValidator200 COM module - an overview |
Document | What to do in a 64bit environment - is there a 64bit Sumex1 COM dll? |
Document | VB code snippet for using the miscValidator200 COM module |
Document | miscValidatorServer200: Introduction, overview and usage of the Restful Webservice Server |

© by sumex1.net - all rights reserved


  • miscValidator200
  • IChapter

IChapter interface | V2.00/ 1 May 2014
The IChapter interface allows browsing and retrieval of detailed chapter information from the selected tariff catalog. A search process in the chapter domain of the selected tariff catalog can be performed by code or name, respectively. The search terms may be specified in literal or may include wildcards. After a successful search, all of the available information directly related to the search term is made available through the interface"s properties.

The search methods (e.g. SearchName) produce as a result a selection list, composed of zero or more chapter records. The total number of records in the list can be retrieved with the GetRecordCount method. The record pointer is initially positioned at the first entry of the selection list and the positioning methods MoveFirst, MoveLast, MoveNext, MovePrevious, PutAbsolutePosition, and GetAbsolutePosition are used to manipulate the selected record. The information related to the current record is made available through the interface"s properties like GetName for retrieving the chapter title.

space
space
Methods | 11 methods
GetAbortInfo | Fetches the abort/error information if there is any stored
GetAbsolutePosition | Gets the current absolute position of the record pointer in the selection list
GetChapters | Method for collecting all chapter data of the resulting search space in one call without the necessity to call the record positioning methods and the appropriate properties of this interface
GetRecordCount | Gets the number of chapter records in the selection list based on the last search call
MoveFirst | Moves the record pointer to the first record in the selection list and makes that record the current record
MoveLast | Moves the record pointer to the last record in the selection list and makes that record the current record
MoveNext | Moves the record pointer to the next record in the selection list and makes that record the current record
MovePrevious | Moves the record pointer to the previous record in the selection list and makes that record the current record
PutAbsolutePosition | Positions the record pointer at the specified absolute position in the selection list.
SearchCode | This method searches for chapters by chapter code
SearchName | This method searches for chapters by name
space
Properties | 8 properties
[get] Code | The chapter code of the selected chapter
[put] DestructChapter | Destructs/invalidates this IChapter interface instance
[get] Interpretation | The interpretation (exclusion and inclusion remarks, rules, comments and the like) of the selected chapter
[get] Name | The name of the chapter
[get] ParentCode | The parent chapter code.
[get] TariffType | The tariff type the selected service record belongs to
[get] ValidFrom | The validity start date of the selected chapter
[get] ValidTo | The validity end date of the selected chapter
space


  • IChapter
  • GetAbortInfo

IChapter::GetAbortInfo method |  |  | space
Fetches the abort/error information if there is any stored. If any method generates an error/error string than the error situation is signaled by the VARIANT_BOOL status of that method. GetAbortInfo can then be used to retrieve the error code und error string. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IChapter/GetAbortInfo
[JSON input data] | pIChapter: | longValue, //interface address
[JSON result data] | pbstrAbortText: plAbortCode: pbStatus: | "utf8StringValue", longValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetAbortInfo( | BSTR long VARIANT_BOOL | *pbstrAbortText, *plAbortCode, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrAbortText | The abort information string that corresponds with the abort/error code. The abort string is empty if there is no error condition. Possibly S_FALSE was set by an iterator to signal end_of_data, which is seen as a "non-error". |
[out] long | *plAbortCode | The abort code that corresponds with the abort/error string. The abort code is 0 if there is no error condition. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred! No further information can be retrieved. |
space |


  • IChapter
  • GetAbsolutePosition

IChapter::GetAbsolutePosition method |  |  | space
Gets the current absolute position of the record pointer in the selection list. This method can be useful for implementing virtual selection lists. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IChapter/GetAbsolutePosition
[JSON input data] | pIChapter: | longValue, //interface address
[JSON result data] | plID: pbStatus: | longValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetAbsolutePosition( | long VARIANT_BOOL | *plID, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] long | *plID | The ID of the service record |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IChapter
  • GetChapters

IChapter::GetChapters method |  |  | space
This method has a Restful Webservice representation only! Method for collecting all chapter data of the resulting search space in one call without the necessity to call the record positioning methods and the appropriate properties of this interface. The chapters are returned as JSON array however large that search space might be. So this might be a memory and performance bottleneck. Possibly, one might call the IMiscChapter::GetRecordCount method to get the size of the search space prior to call GetChapters unconditionally. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IChapter/GetChapters
[JSON input data] | pIChapter: | longValue, //interface address
[JSON result array] | { pbstrTariffType: pbstrParentCode: pbstrCode: pbstrName: pbstrInterpretation: pdValidFrom: pdValidTo: pbStatus: | "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", "stringISODateValue", "stringISODateValue", booleanValue },
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrTariffType | The tariff type (aka tariff number) of the currently focused chapter |
[out] BSTR | *pbstrParentCode | The parent chapter code of the currently focused chapter. If there is no parent chapter then an empty variable is supplied |
[out] BSTR | *pbstrCode | The chapter code of the currently focused chapter |
[out] BSTR | *pbstrName | The name of the currently focused chapter |
[out] BSTR | *pbstrInterpretation | The interpretation text of the currently focused chapter |
[out] DATE | *pdValidFrom | The validity start date of the currently focused chapter |
[out] DATE | *pdValidTo | The validity end date of the currently focused chapter |
[out,retval] VARIANT_BOOL | *pbStatus | Boolean return status |
space |


  • IChapter
  • GetRecordCount

IChapter::GetRecordCount method |  |  | space
Gets the number of chapter records in the selection list based on the last search call |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IChapter/GetRecordCount
[JSON input data] | pIChapter: | longValue, //interface address
[JSON result data] | plSize: pbStatus: | longValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetRecordCount( | long VARIANT_BOOL | *plSize, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] long | *plSize | The total number of service records included |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IChapter
  • MoveFirst

IChapter::MoveFirst method |  |  | space
Moves the record pointer to the first record in the selection list and makes that record the current record. All property functions act upon and return data from that current record If the action could not be performed or the selection list is empty than S_FALSE will be returned. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IChapter/MoveFirst
[JSON input data] | pIChapter: | longValue, //interface address
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT MoveFirst( | VARIANT_BOOL | *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out,retval] VARIANT_BOOL | *pbStatus | Return the status of the method. If pbStatus is VARIANT_TRUE than all is OK. whereas VARIANT_FALSE means that the action could no be completed due to an "end_of_data" message or an error situation. Call GetAbortInfo to check for possible errors. |
space |


  • IChapter
  • MoveLast

IChapter::MoveLast method |  |  | space
Moves the record pointer to the last record in the selection list and makes that record the current record. All property functions act upon and return data from that current record If the action could not be performed or the selection list is empty than S_FALSE will be returned. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IChapter/MoveLast
[JSON input data] | pIChapter: | longValue, //interface address
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT MoveLast( | VARIANT_BOOL | *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out,retval] VARIANT_BOOL | *pbStatus | Return the status of the method. If pbStatus is VARIANT_TRUE than all is OK. whereas VARIANT_FALSE means that the action could no be completed due to an "end_of_data" message or an error situation. Call GetAbortInfo to check for possible errors. |
space |


  • IChapter
  • MoveNext

IChapter::MoveNext method |  |  | space
Moves the record pointer to the next record in the selection list and makes that record the current record. All property functions act upon and return data from that current record If the action could not be performed or the selection list is empty than S_FALSE will be returned. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IChapter/MoveNext
[JSON input data] | pIChapter: | longValue, //interface address
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT MoveNext( | VARIANT_BOOL | *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out,retval] VARIANT_BOOL | *pbStatus | Return the status of the method. If pbStatus is VARIANT_TRUE than all is OK. whereas VARIANT_FALSE means that the action could no be completed due to an "end_of_data" message or an error situation. Call GetAbortInfo to check for possible errors. |
space |


  • IChapter
  • MovePrevious

IChapter::MovePrevious method |  |  | space
Moves the record pointer to the previous record in the selection list and makes that record the current record. All property functions act upon and return data from that current record If the action could not be performed or the selection list is empty than S_FALSE will be returned. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IChapter/MovePrevious
[JSON input data] | pIChapter: | longValue, //interface address
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT MovePrevious( | VARIANT_BOOL | *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out,retval] VARIANT_BOOL | *pbStatus | Return the status of the method. If pbStatus is VARIANT_TRUE than all is OK. whereas VARIANT_FALSE means that the action could no be completed due to an "end_of_data" message or an error situation. Call GetAbortInfo to check for possible errors. |
space |


  • IChapter
  • PutAbsolutePosition

IChapter::PutAbsolutePosition method |  |  | space
Positions the record pointer at the specified absolute position in the selection list. This method can be useful for implementing virtual selection lists. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IChapter/PutAbsolutePosition
[JSON input data] | pIChapter: lID: | longValue, //interface address longValue
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT PutAbsolutePosition( | long VARIANT_BOOL | lID, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] long | lID | The ID of the service record to position to |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IChapter
  • SearchCode

IChapter::SearchCode method |  |  | space
This method searches for chapters by chapter code |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IChapter/SearchCode
[JSON input data] | pIChapter: bstrTariffType: dDate: bstrCode: | longValue, //interface address "utf8StringValue", variantDateValue | "stringISODateValue", "utf8StringValue"
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT SearchCode( | BSTR DATE BSTR VARIANT_BOOL | bstrTariffType, dDate, bstrCode, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrTariffType | The tariff type to use in the query |
[in] DATE | dDate | The date to use for the query. Valid (and returned) records must have a validity date range that does include the given date! Supply a DATE <= 0 to turn off the date range check! |
[in] BSTR | bstrCode | Query string that is used for searching in the chapter code portion of the tariff catalog (cf. properties WildCard and WildCharacter for using wildcards) |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string and value. |
space |


  • IChapter
  • SearchName

IChapter::SearchName method |  |  | space
This method searches for chapters by name |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IChapter/SearchName
[JSON input data] | pIChapter: bstrTariffType: dDate: bstrName: | longValue, //interface address "utf8StringValue", variantDateValue | "stringISODateValue", "utf8StringValue"
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT SearchName( | BSTR DATE BSTR VARIANT_BOOL | bstrTariffType, dDate, bstrName, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrTariffType | The tariff type to use in the query |
[in] DATE | dDate | The date to use for the query. Valid (and returned) records must have a validity date range that does include the given date! Supply a DATE <= 0 to turn off the date range check! |
[in] BSTR | bstrName | Query string that is used for searching in the chapter name portion of the tariff catalog (cf. properties WildCard and WildCharacter for using wildcards) |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string and value. |
space |


  • IChapter
  • Code

IChapter::Code property | space
The chapter code of the selected chapter
space
Restful webservice calling syntax
[GET] | /baseURL/ IChapter/GetCode?param
[param] pIChapter= longValue
[JSON result data] pbstrCode: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Code( BSTR *pbstrCode );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrCode | The code of the current service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetCode(void);
space


  • IChapter
  • DestructChapter

IChapter::DestructChapter property |  |  | space
This property has a Restful Webservice representation only! Destructs/invalidates this IChapter interface instance. The counterpart property to generate an IChapter interface instance is IMiscValidator::GetCreateChapter. |  |  |
space
Restful webservice calling syntax |  |  |
[PUT] | /baseURL/ IChapter/PutDestructChapter
[JSON input data] | pIChapter: | longValue, //interface address
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Remarks |  |  |
This property has a Restful Webservice representation only! |  |  |
space |


  • IChapter
  • Interpretation

IChapter::Interpretation property | space
The interpretation (exclusion and inclusion remarks, rules, comments and the like) of the selected chapter
space
Restful webservice calling syntax
[GET] | /baseURL/ IChapter/GetInterpretation?param
[param] pIChapter= longValue
[JSON result data] pbstrInterpretation: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Interpretation( BSTR *pbstrInterpretation );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrInterpretation | The service interpretation of the current service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetInterpretation(void);
space


  • IChapter
  • Name

IChapter::Name property | space
The name of the chapter
space
Restful webservice calling syntax
[GET] | /baseURL/ IChapter/GetName?param
[param] pIChapter= longValue
[JSON result data] pbstrName: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Name( BSTR *pbstrName );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrName | The name of the current service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetName(void);
space


  • IChapter
  • ParentCode

IChapter::ParentCode property | space
The parent chapter code.
If there is no parent chapter then an empty BSTR is supplied
space
Restful webservice calling syntax
[GET] | /baseURL/ IChapter/GetParentCode?param
[param] pIChapter= longValue
[JSON result data] pbstrParentCode: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | ParentCode( BSTR *pbstrParentCode );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrParentCode | The parent chapter code of the current service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetParentCode(void);
space


  • IChapter
  • TariffType

IChapter::TariffType property | space
The tariff type the selected service record belongs to
space
Restful webservice calling syntax
[GET] | /baseURL/ IChapter/GetTariffType?param
[param] pIChapter= longValue
[JSON result data] pbstrTariffType: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | TariffType( BSTR *pbstrTariffType );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrTariffType | The tariff type (aka tariff number) of the current chapter
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetTariffType(void);
space


  • IChapter
  • ValidFrom

IChapter::ValidFrom property | space
The validity start date of the selected chapter
space
Restful webservice calling syntax
[GET] | /baseURL/ IChapter/GetValidFrom?param
[param] pIChapter= longValue
[JSON result data] pdValidFrom: "stringISODateValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | ValidFrom( DATE *pdValidFrom );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] DATE | *pdValidFrom | The validity start of the current chapter
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • DATE *GetValidFrom(void);
space


  • IChapter
  • ValidTo

IChapter::ValidTo property | space
The validity end date of the selected chapter
space
Restful webservice calling syntax
[GET] | /baseURL/ IChapter/GetValidTo?param
[param] pIChapter= longValue
[JSON result data] pdValidTo: "stringISODateValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | ValidTo( DATE *pdValidTo );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] DATE | *pdValidTo | The validity end of the current chapter
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • DATE *GetValidTo(void);
space


  • IMiscValidator

IMiscValidator interface |  | V2.00/ 1 May 2014
The IMiscValidator interface handles connections to the database holding miscellaneous tariff catalogs. It provides methods to handle the database connection, to set and retrieve general database parameters, and retrieve information about all covered tariff catalogs. A connection to the database must be opened via IMiscValidator::Open method before any methods dealing with tariff catalogs can be used. Furthermore the dependent interfaces IChapter, ISearch, and IValidate must be create with the appropriate create property prior the to use of these interface methods. |  | space
space
Methods |  | 8 methods
Close | Closes the tariff catalog database. |
GetAbortInfo | Fetches the abort/error information if there is any stored |
GetFirstTariff | Retrieves the information for the first tariff catalog covered by the applied tariff filter |
GetNextTariff | Retrieves the information for the next tariff catalog covered by the applied tariff filter |
GetTariffRestriction | Gets extended tariff information of possible usage restrictions of the tariff |
GetTariffs | Method for collecting all tariff catalogs constricted by a call to IMiscValidator::SetTariffFilter and returned as JSON array |
Open | Opens the tariff catalog database |
SetTariffFilter | Sets restriction criteria in the sense of that the usage of a certain tariff is possible under the defined criteria |
space
Properties |  | 16 properties
[get] CreateChapter | Creates an instance of the IChapter interface |
[get] CreateMiscValidator | Creates an instance of the main IMiscValidator interface |
[get] CreateSearch | Creates an instance of the ISearch interface |
[get] CreateValidate | Create an instance of the IValidate interface |
[get] DBDate | Get the issuer date of the selected tariff catalog |
[get] DBVersion | Get the database version of the selected tariff catalog |
[put] DestructChapter | Destructs/invalidates this IChapter interface instance |
[put] DestructMiscValidator | Destructs/invalidates a main instance of the IMiscValidator interface |
[put] DestructSearch | Destructs/invalidates this ISearch interface instance |
[put] DestructValidate | Destructs/invalidates this IValidate interface instance |
[get/put] EnableLog | Get and Set the log activity for the module |
[get/put] Language | Get and Set the language for the miscValidator module |
[get] ModuleVersion | Get the version of the miscValidator module |
[get] ModuleVersionText | Get the textual version of the miscValidator module |
[get/put] WildCard | Get and Set the match-all wildcard character for SQL queries. |
[get/put] WildCharacter | Get and Set the "match any single character" wildcard character for SQL queries. |
space |


  • IMiscValidator
  • Close

IMiscValidator::Close method |  |  | space
Closes the tariff catalog database. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IMiscValidator/Close
[JSON input data] | pIMiscValidator: | longValue, //interface address
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT Close( | VARIANT_BOOL | *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IMiscValidator
  • GetAbortInfo

IMiscValidator::GetAbortInfo method |  |  | space
Fetches the abort/error information if there is any stored. If any method generates an error/error string than the error situation is signaled by the VARIANT_BOOL status of that method. GetAbortInfo can then be used to retrieve the error code und error string. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IMiscValidator/GetAbortInfo
[JSON input data] | pIMiscValidator: | longValue, //interface address
[JSON result data] | pbstrAbortText: plAbortCode: pbStatus: | "utf8StringValue", longValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetAbortInfo( | BSTR long VARIANT_BOOL | *pbstrAbortText, *plAbortCode, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrAbortText | The abort information string that corresponds with the abort/error code. The abort string is empty if there is no error condition. Possibly S_FALSE was set by an iterator to signal end_of_data, which is seen as a "non-error". |
[out] long | *plAbortCode | The abort code that corresponds with the abort/error string. The abort code is 0 if there is no error condition. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred! No further information can be retrieved. |
space |


  • IMiscValidator
  • GetFirstTariff

IMiscValidator::GetFirstTariff method |  |  | space
Retrieves the information for the first tariff catalog covered by the applied tariff filter |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IMiscValidator/GetFirstTariff
[JSON input data] | pIMiscValidator: | longValue, //interface address
[JSON result data] | pbstrTariffType: pbstrName: pbstrVersion: pdValidFrom: pdValidTo: pbStatus: | "utf8StringValue", "utf8StringValue", "utf8StringValue", "stringISODateValue", "stringISODateValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetFirstTariff( | BSTR BSTR BSTR DATE DATE VARIANT_BOOL | *pbstrTariffType, *pbstrName, *pbstrVersion, *pdValidFrom, *pdValidTo, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrTariffType | The number (e.g. 311, S01,...) of the tariff catalog |
[out] BSTR | *pbstrName | The name of the tariff catalog |
[out] BSTR | *pbstrVersion | The version of the tariff catalog |
[out] DATE | *pdValidFrom | The end date of validity of the tariff catalog |
[out] DATE | *pdValidTo | The start date of validity of the tariff catalog |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IMiscValidator
  • GetNextTariff

IMiscValidator::GetNextTariff method |  |  | space
Retrieves the information for the next tariff catalog covered by the applied tariff filter |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IMiscValidator/GetNextTariff
[JSON input data] | pIMiscValidator: | longValue, //interface address
[JSON result data] | pbstrTariffType: pbstrName: pbstrVersion: pdValidFrom: pdValidTo: pbStatus: | "utf8StringValue", "utf8StringValue", "utf8StringValue", "stringISODateValue", "stringISODateValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetNextTariff( | BSTR BSTR BSTR DATE DATE VARIANT_BOOL | *pbstrTariffType, *pbstrName, *pbstrVersion, *pdValidFrom, *pdValidTo, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrTariffType | The number (e.g. 311, S01,...) of the tariff catalog |
[out] BSTR | *pbstrName | The name of the tariff catalog |
[out] BSTR | *pbstrVersion | The version of the tariff catalog |
[out] DATE | *pdValidFrom | The end date of validity of the tariff catalog |
[out] DATE | *pdValidTo | The start date of validity of the tariff catalog |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string and value. |
space |


  • IMiscValidator
  • GetTariffRestriction

IMiscValidator::GetTariffRestriction method | space
Gets extended tariff information of possible usage restrictions of the tariff
space
Restful webservice calling syntax
[POST] | /baseURL/ IMiscValidator/GetTariffRestriction
[JSON input data] pIMiscValidator:
bstrTariffType: 		longValue, //interface address
"utf8StringValue"
[JSON result data] plRoleRestriction:
plPlaceRestriction:
plLawRestriction:
pbstrEANRestriction:
pbStatus: 		longValue,
longValue,
longValue,
"utf8StringValue",
booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
HRESULT GetTariffRestriction( BSTR
long
long
long
BSTR
VARIANT_BOOL 		bstrTariffType,
*plRoleRestriction,
*plPlaceRestriction,
*plLawRestriction,
*pbstrEANRestriction,
*pbStatus);
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[in] BSTR | bstrTariffType | The tariff number for which the restriction information should be retrieved.
[out] long | *plRoleRestriction | If set the tariff usage is restricted to the ORed list the role enumeration
[out] long | *plPlaceRestriction | If set the tariff usage is restricted to the ORed list the place enumeration
[out] long *plLawRestriction If set the tariff usage is restricted to the ORed list law numbers..

The law numbers are defined as follows:

  • KVG=1
  • UVG=2
  • MVG=4
  • IVG=8
  • VVG=16
  • ORG=32
[out] BSTR | *pbstrEANRestriction | If set the tariff usage is restricted to the supplied list of comma separated EANs
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string and value.
space


  • IMiscValidator
  • GetTariffs

IMiscValidator::GetTariffs method | space
This method has a Restful Webservice representation only!
Method for collecting all tariff catalogs constricted by a call to IMiscValidator::SetTariffFilter and returned as JSON array.

Please note that IMiscValidator::GetTariffs takes over the functionality of the iterator pair IMiscValidator::GetFirstTariff / IMiscValidator::GetNextTariff with a single call, making the latter superfluous.
space
Restful webservice calling syntax
[POST] | /baseURL/ IMiscValidator/GetTariffs
[JSON input data] pIMiscValidator: longValue, //interface address
[JSON result array] { pbstrTariffType:
pbstrName:
pbstrVersion:
pdValidFrom:
pdValidTo:
pbStatus: 		"utf8StringValue",
"utf8StringValue",
"utf8StringValue",
"stringISODateValue",
"stringISODateValue",
booleanValue
},
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
Calling argument description
[out] BSTR | *pbstrTariffType | The number (e.g. 311, S01,...) of the tariff catalog
[out] BSTR | *pbstrName | The name of the tariff catalog
[out] BSTR | *pbstrVersion | The version of the tariff catalog
[out] DATE | *pdValidFrom | The end date of validity of the tariff catalog
[out] DATE | *pdValidTo | The start date of validity of the tariff catalog
[out,retval] VARIANT_BOOL *pbStatus Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name).
In the later case check for possible errors with the GetAbortInfo method.
space


  • IMiscValidator
  • Open

IMiscValidator::Open method |  |  | space
Opens the tariff catalog database |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IMiscValidator/Open
[JSON input data] | pIMiscValidator: eLanguage: | longValue, //interface address longValue
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT Open( | LanguageType VARIANT_BOOL | eLanguage, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] LanguageType | eLanguage | The choosen language of the tariff that should be opened |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string and value. |
space |


  • IMiscValidator
  • SetTariffFilter

IMiscValidator::SetTariffFilter method | space
Sets restriction criteria in the sense of that the usage of a certain tariff is possible under the defined criteria. The resulting list of applicable tariffs is returned with the GetFirstTariff/GetNextTariff iterator. The implicit default restriction criteria is "no tariff filter".

Please note that all tariff catalogs without any restriction will be returned in the tariff iterator whatever restriction criteria is set.

space
Restful webservice calling syntax
[POST] | /baseURL/ IMiscValidator/SetTariffFilter
[JSON input data] pIMiscValidator:
lRoleRestriction:
lPlaceRestriction:
lLawRestriction:
bstrEANRestriction: 		longValue, //interface address
longValue,
longValue,
longValue,
"utf8StringValue"
[JSON result data] pbStatus: booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
HRESULT SetTariffFilter( long
long
long
BSTR
VARIANT_BOOL 		lRoleRestriction,
lPlaceRestriction,
lLawRestriction,
bstrEANRestriction,
*pbStatus);
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[in] long | lRoleRestriction | Role restriction as a ORed list of roles. If the variable is enRoleUndefined then no role restriction is applied.
[in] long | lPlaceRestriction | Place restriction as a ORed list of places. If the variable is enPlaceUndefined then no place restriction is applied.
[in] long lLawRestriction Law restriction as an ORed list of law numbers. If the variable is 0 than no law restriction is applied.

The law numbers are defined as follows:

  • KVG=1
  • UVG=2
  • MVG=4
  • IVG=8
  • VVG=16
  • ORG=32
[in] BSTR | bstrEANRestriction | EAN restriction for tariffs of a certain insurance like the S01 tariff applicable only for the SUVA. A comma separated list of EANs can be supplied. If the variable is NULL then no restriction is applied.
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string and value.
space


  • IMiscValidator
  • CreateChapter

IMiscValidator::CreateChapter property | space
Creates an instance of the IChapter interface
space
Restful webservice calling syntax
[GET] | /baseURL/ IMiscValidator/GetCreateChapter?param
[param] pIMiscValidator= longValue
[JSON result data] pIChapter: longValue //interface address
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | CreateChapter( IChapter **peCreateChapter );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] IChapter | **peCreateChapter | The created instance of the Ichapter interface
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • IChapter **GetCreateChapter(void);
space


  • IMiscValidator
  • CreateMiscValidator

IMiscValidator::CreateMiscValidator property |  |  | space
This property has a Restful Webservice representation only! Creates an instance of the main IMiscValidator interface. To delete/invalidate this interface instance, the counterpart property PutDestructMiscValidator must be explicitly called, since the pIMiscValidator address has a global scope and is not automatically destructed. |  |  |
space
Restful webservice calling syntax |  |  |
[GET] | /baseURL/ IMiscValidator/GetCreateMiscValidator
[JSON result data] | pIMiscValidator: | longValue //interface address
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Remarks |  |  |
This property has a Restful Webservice representation only! |  |  |
space |


  • IMiscValidator
  • CreateSearch

IMiscValidator::CreateSearch property | space
Creates an instance of the ISearch interface
space
Restful webservice calling syntax
[GET] | /baseURL/ IMiscValidator/GetCreateSearch?param
[param] pIMiscValidator= longValue
[JSON result data] pISearch: longValue //interface address
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | CreateSearch( ISearch **peCreateSearch );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] ISearch | **peCreateSearch | The created instance of the Isearch interface
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • ISearch **GetCreateSearch(void);
space


  • IMiscValidator
  • CreateValidate

IMiscValidator::CreateValidate property | space
Create an instance of the IValidate interface
space
Restful webservice calling syntax
[GET] | /baseURL/ IMiscValidator/GetCreateValidate?param
[param] pIMiscValidator= longValue
[JSON result data] pIValidate: longValue //interface address
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | CreateValidate( IValidate **peCreateValidate );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] IValidate | **peCreateValidate | The created instance of the Ivalidate interface
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • IValidate **GetCreateValidate(void);
space


  • IMiscValidator
  • DBDate

IMiscValidator::DBDate property | space
Get the issuer date of the selected tariff catalog
space
Restful webservice calling syntax
[GET] | /baseURL/ IMiscValidator/GetDBDate?param
[param] pIMiscValidator=
bstrTariffType= 		longValue&
urlEncodedStringValue
[JSON result data] pdDBDate: "stringISODateValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT DBDate( BSTR bstrTariffType,
DATE *pdDBDate );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[in] BSTR | bstrTariffType | The tariff number for which the date should be returned.
[out,retval] DATE | *pdDBDate | The issuer date of the selected tariff catalog
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • DATE *GetDBDate( BSTR bstrTariffType);
space


  • IMiscValidator
  • DBVersion

IMiscValidator::DBVersion property | space
Get the database version of the selected tariff catalog
space
Restful webservice calling syntax
[GET] | /baseURL/ IMiscValidator/GetDBVersion?param
[param] pIMiscValidator=
bstrTariffType= 		longValue&
urlEncodedStringValue
[JSON result data] pbstrDBVersion: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT DBVersion( BSTR bstrTariffType,
BSTR *pbstrDBVersion );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[in] BSTR | bstrTariffType | The tariff number for which the version should be returned.
[out,retval] BSTR | *pbstrDBVersion | The database version of the selected tariff catalog
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetDBVersion( BSTR bstrTariffType);
space


  • IMiscValidator
  • DestructChapter

IMiscValidator::DestructChapter property |  |  | space
This property has a Restful Webservice representation only! Destructs/invalidates this IChapter interface instance. The counterpart property to generate an IChapter interface instance is IMiscValidator::GetCreateChapter. |  |  |
space
Restful webservice calling syntax |  |  |
[PUT] | /baseURL/ IMiscValidator/PutDestructChapter
[JSON input data] | pIMiscValidator: pIChapter: | longValue, //interface address longValue, //interface address
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Remarks |  |  |
This property has a Restful Webservice representation only! |  |  |
space |


  • IMiscValidator
  • DestructMiscValidator

IMiscValidator::DestructMiscValidator property |  |  | space
This property has a Restful Webservice representation only! Destructs/invalidates a main instance of the IMiscValidator interface. Please note, that all dependent, active interface instances generated with IMiscValidator::GetCreateValidate, IMiscValidator::GetCreateChapter and/or IMiscSearch::GetCreateSearch under this main instances, are automatically destructed as well. The counterpart property to generate a main interface instance is IMiscValidator::GetCreateMiscValidator. |  |  |
space
Restful webservice calling syntax |  |  |
[PUT] | /baseURL/ IMiscValidator/PutDestructMiscValidator
[JSON input data] | pIMiscValidator: | longValue, //interface address
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Remarks |  |  |
This property has a Restful Webservice representation only! |  |  |
space |


  • IMiscValidator
  • DestructSearch

IMiscValidator::DestructSearch property |  |  | space
This property has a Restful Webservice representation only! Destructs/invalidates this ISearch interface instance. The counterpart property to generate an ISearch interface instance is IMiscValidator::GetCreateSearch. |  |  |
space
Restful webservice calling syntax |  |  |
[PUT] | /baseURL/ IMiscValidator/PutDestructSearch
[JSON input data] | pIMiscValidator: pISearch: | longValue, //interface address longValue, //interface address
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Remarks |  |  |
This property has a Restful Webservice representation only! |  |  |
space |


  • IMiscValidator
  • DestructValidate

IMiscValidator::DestructValidate property |  |  | space
This property has a Restful Webservice representation only! Destructs/invalidates this IValidate interface instance. The counterpart property to generate an IValidate interface instance is IMiscValidator::GetCreateValidate. |  |  |
space
Restful webservice calling syntax |  |  |
[PUT] | /baseURL/ IMiscValidator/PutDestructValidate
[JSON input data] | pIMiscValidator: pIValidate: | longValue, //interface address longValue, //interface address
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Remarks |  |  |
This property has a Restful Webservice representation only! |  |  |
space |


  • IMiscValidator
  • EnableLog

IMiscValidator::EnableLog property | space
Get and Set the log activity for the module. The default log activity is enYes.
space
Restful webservice calling syntax
[GET] | /baseURL/ IMiscValidator/GetEnableLog?param
[param] pIMiscValidator= longValue
[JSON result data] peEnableLog: longValue
[PUT] | /baseURL/ IMiscValidator/PutEnableLog
[JSON input data] pIMiscValidator:
eEnableLog: 		longValue, //interface address
longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | EnableLog( YesNoType *peEnableLog );
[put] HRESULT | EnableLog( YesNoType eEnableLog );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] YesNoType | *peEnableLog | Boolean that defines if the logging is enabled (enYes) or not (enNo)
[in] YesNoType | eEnableLog | Boolean that defines if the logging is enabled (enYes) or not (enNo)
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • YesNoType *GetEnableLog(void);
  • void PutEnableLog( YesNoType lEnableLog);
space


  • IMiscValidator
  • Language

IMiscValidator::Language property | space
Get and Set the language for the miscValidator module. The default language is enGerman.
space
Restful webservice calling syntax
[GET] | /baseURL/ IMiscValidator/GetLanguage?param
[param] pIMiscValidator= longValue
[JSON result data] peLanguage: longValue
[PUT] | /baseURL/ IMiscValidator/PutLanguage
[JSON input data] pIMiscValidator:
eLanguage: 		longValue, //interface address
longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Language( LanguageType *peLanguage );
[put] HRESULT | Language( LanguageType eLanguage );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] LanguageType | *peLanguage | The language for the main interface defining the language of the error messages
[in] LanguageType | eLanguage | The language for the main interface defining the language of the error messages
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • LanguageType *GetLanguage(void);
  • void PutLanguage( LanguageType lLanguage);
space


  • IMiscValidator
  • ModuleVersion

IMiscValidator::ModuleVersion property | space
Get the version of the miscValidator module
space
Restful webservice calling syntax
[GET] | /baseURL/ IMiscValidator/GetModuleVersion?param
[param] pIMiscValidator= longValue
[JSON result data] pbstrModuleVersion: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | ModuleVersion( BSTR *pbstrModuleVersion );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrModuleVersion | The module version of the miscValidator module
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetModuleVersion(void);
space


  • IMiscValidator
  • ModuleVersionText

IMiscValidator::ModuleVersionText property | space
Get the textual version of the miscValidator module
space
Restful webservice calling syntax
[GET] | /baseURL/ IMiscValidator/GetModuleVersionText?param
[param] pIMiscValidator= longValue
[JSON result data] pbstrModuleVersionText: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | ModuleVersionText( BSTR *pbstrModuleVersionText );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrModuleVersionText | The module version string of the miscValidator module
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetModuleVersionText(void);
space


  • IMiscValidator
  • WildCard

IMiscValidator::WildCard property | space
Get and Set the match-all wildcard character for SQL queries.
You can use this property if you have imported the original tariff catalog database into another database, which uses a different wildcard character for queries. The default match-all wildcard character is the percent symbol (%). With the miscValidator module you can always formulate a query using the asterisk symbol (*) as a wildcard, as in each query string a * is replaced by the wildcard character specified by this property before being executed.
space
Restful webservice calling syntax
[GET] | /baseURL/ IMiscValidator/GetWildCard?param
[param] pIMiscValidator= longValue
[JSON result data] pbstrWildCard: "utf8StringValue"
[PUT] | /baseURL/ IMiscValidator/PutWildCard
[JSON input data] pIMiscValidator:
bstrWildCard: 		longValue, //interface address
"utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | WildCard( BSTR *pbstrWildCard );
[put] HRESULT | WildCard( BSTR bstrWildCard );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrWildCard | The wildcard symbol
[in] BSTR | bstrWildCard | The wildcard symbol
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetWildCard(void);
  • void PutWildCard( BSTR bstrWildCard);
space


  • IMiscValidator
  • WildCharacter

IMiscValidator::WildCharacter property | space
Get and Set the "match any single character" wildcard character for SQL queries.
You can use this property if you have imported the original tariff catalog database into another database, which uses a different wild character for the queries. The default match-single-character wildcard character is the underscore symbol (_). With the miscValidator module you can always formulate a query using the question mark (?) as a wildcard, as in each query string a ? is replaced by the wildcard character specified by this property before execution.
space
Restful webservice calling syntax
[GET] | /baseURL/ IMiscValidator/GetWildCharacter?param
[param] pIMiscValidator= longValue
[JSON result data] pbstrWildCharacter: "utf8StringValue"
[PUT] | /baseURL/ IMiscValidator/PutWildCharacter
[JSON input data] pIMiscValidator:
bstrWildCharacter: 		longValue, //interface address
"utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | WildCharacter( BSTR *pbstrWildCharacter );
[put] HRESULT | WildCharacter( BSTR bstrWildCharacter );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrWildCharacter | The wildcard character symbol
[in] BSTR | bstrWildCharacter | The wildcard character symbol
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetWildCharacter(void);
  • void PutWildCharacter( BSTR bstrWildCharacter);
space


  • ISearch

ISearch interface | V2.00/ 1 May 2014
The ISearch interface allows browsing and retrieval of detailed service information from the selected tariff catalog. A search process in the service record domain of the selected tariff catalog can be performed by code, name, or chapter respectively. The search terms may be specified in full or may include wildcards. After a successful search, all of the available information directly related to the search term is made available through the interface"s properties.

The search methods (e.g. SearchName) produce as a result a selection list, composed of zero or more service records. The total number of records in the list can be retrieved with the GetRecordCount method. The record pointer is initially positioned at the first entry of the selection list and the positioning methods MoveFirst, MoveLast, MoveNext, MovePrevious, PutAbsolutePosition, and GetAbsolutePosition are used to manipulate the selected record. The information related to the current record is made available through the interface"s properties like GetName for retrieving the service title.

space
space
Methods | 13 methods
GetAbortInfo | Fetches the abort/error information if there is any stored
GetAbsolutePosition | Gets the current absolute position of the record pointer in the selection list
GetPropertyValue | Gets the explicit value of predefined property always returned in string form
GetRecordCount | Gets the number of service records in the selection list based on the last search call
GetServices | Method for collecting all service records of the resulting search space in one call without the necessity to call the record positioning methods and the appropriate properties of this interface
MoveFirst | Moves the record pointer to the first record in the selection list and makes that record the current record
MoveLast | Moves the record pointer to the last record in the selection list and makes that record the current record
MoveNext | Moves the record pointer to the next record in the selection list and makes that record the current record
MovePrevious | Moves the record pointer to the previous record in the selection list and makes that record the current record
PutAbsolutePosition | Positions the record pointer at the specified absolute position in the selection list.
SearchChapter | This method searches for services included in the given chapter query expression
SearchCode | This method searches for services by code
SearchName | This method searches for services by name
space
Properties | 10 properties
[get] ChapterCode | The chapter code the given service record belongs to
[get] Code | The code of the selected service record
[put] DestructSearch | Destructs/invalidates this ISearch interface instance
[get] Interpretation | The interpretation (exclusion and inclusion remarks, rules, comments and the like) of the selected service
[get] Name | The name of the selected service record
[get] ReferenceCode | Returns a comma-separated list of reference codes where the selected service is obliged to map to one of the given services
[get] ServiceProperties | This value defines all semantic capabilities of a service
[get] TariffType | The tariff type the selected service record belongs to
[get] ValidFrom | The validity start date of the selected service record
[get] ValidTo | The validity end date of the selected service record
space


  • ISearch
  • GetAbortInfo

ISearch::GetAbortInfo method |  |  | space
Fetches the abort/error information if there is any stored. If any method generates an error/error string than the error situation is signaled by the VARIANT_BOOL status of that method. GetAbortInfo can then be used to retrieve the error code und error string. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearch/GetAbortInfo
[JSON input data] | pISearch: | longValue, //interface address
[JSON result data] | pbstrAbortText: plAbortCode: pbStatus: | "utf8StringValue", longValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetAbortInfo( | BSTR long VARIANT_BOOL | *pbstrAbortText, *plAbortCode, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrAbortText | The abort information string that corresponds with the abort/error code. The abort string is empty if there is no error condition. Possibly S_FALSE was set by an iterator to signal end_of_data, which is seen as a "non-error". |
[out] long | *plAbortCode | The abort code that corresponds with the abort/error string. The abort code is 0 if there is no error condition. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred! No further information can be retrieved. |
space |


  • ISearch
  • GetAbsolutePosition

ISearch::GetAbsolutePosition method |  |  | space
Gets the current absolute position of the record pointer in the selection list. This method can be useful for implementing virtual selection lists. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearch/GetAbsolutePosition
[JSON input data] | pISearch: | longValue, //interface address
[JSON result data] | plID: pbStatus: | longValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetAbsolutePosition( | long VARIANT_BOOL | *plID, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] long | *plID | The ID of the service record |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ISearch
  • GetPropertyValue

ISearch::GetPropertyValue method | space
Gets the explicit value of predefined property always returned in string form. Transform the string to a double or boolean as needed.

The list of properties whose value can be retrieved is given/returned by GetServiceProperties.
Please note that an error is returned for a property that is not "turned on" in the service properties.
space
Restful webservice calling syntax
[POST] | /baseURL/ ISearch/GetPropertyValue
[JSON input data] pISearch:
bstrPropertyName: 		longValue, //interface address
"utf8StringValue"
[JSON result data] pbstrPropertyValue:
pbStatus: 		"utf8StringValue",
booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
HRESULT GetPropertyValue( BSTR
BSTR
VARIANT_BOOL 		bstrPropertyName,
*pbstrPropertyValue,
*pbStatus);
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[in] BSTR bstrPropertyName The name of a property for which the value is requested. The possible property names are predefined as defined below. The names are treated in a case insensitive way.
  • "enServicePropertyHasTP" or in short "TP" returns the tax point of the service if the enServicePropertyHasTP bit is set by the GetServiceProperties property.
  • "enServicePropertyHasTPMin" or in short "TPmin" returns the minimal tax point of a variable TP service record if the enServicePropertyHasTPMin bit is set by the GetServiceProperties property.
    Note that the "enServicePropertyHasTPMax" bit is set as well if the "TPmin" bit is turned on.
  • "enServicePropertyHasTPMax" or in short "TPmax" returns the maximal tax point of a variable TP service record if the enServicePropertyHasTPMax bit is set by the GetServiceProperties property. If there is no explicit upper bound defined then 999999 is returned!
    Note that the "enServicePropertyHasTPMin" bit is set as well if the "TPmax" bit is turned on.
  • "enServicePropertyIsPercentService" or in short "percentService" returns the percent fraction of a percent service record if the enServicePropertyIsPercentService bit is set by the GetServiceProperties property.
    A percent service depends upon another prior defined service and the TP is the product of the scaled TP of the parent service times the (0.01*percent factor).
    Note that the "needsRefCode" bit is set as well if the "percentService" bit is turned on.
  • "enServicePropertyIsFrancService" or in short "francService" returns a Boolean value as string denoting the Franc status of the service.
    The returned value is one of
    • "0" aka is not a Franc service
    • "1" aka is a Franc service
  • "enServicePropertyIsNeedsRefCode" or in short "needsRefCode" returns a comma-separated list of target reference codes if the enServicePropertyIsNeedsRefCode bit is set by the GetServiceProperties property.
    The list of reference codes might be empty if the target reference code is unknown in advance.
    Note that the "needsRefCode" bit is set as well if the "percentService" bit is turned on.
  • "enServicePropertyHasVatRateCode" or in short "vatRateCode" returns the vat rate code the service record "belongs" to if the enServicePropertyHasVatRateCode bit is set by the GetServiceProperties property. Since all services belongs to a vat category this bit is always set.
    The returned vat rate code is one of
    • 0 = none (currently 0% vat rate)
    • 1 = reduced (currently 2.5% vat rate)
    • 2 = full (currently 7.7% vat rate)
  • "enServicePropertyHasExcludedVat" or in short "excludedVat" returns a Boolean value as string denoting the Brutto/Netto status of the service.
    The returned value is one of
    • "0" aka is a Brutto service with the vat included in the TP
    • "1" aka is a Netto service without an included vat in the TP
[out] BSTR | *pbstrPropertyValue | The property value given as a string.
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string and value.
space


  • ISearch
  • GetRecordCount

ISearch::GetRecordCount method |  |  | space
Gets the number of service records in the selection list based on the last search call |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearch/GetRecordCount
[JSON input data] | pISearch: | longValue, //interface address
[JSON result data] | plSize: pbStatus: | longValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetRecordCount( | long VARIANT_BOOL | *plSize, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] long | *plSize | The total number of service records included |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string and value. |
space |


  • ISearch
  • GetServices

ISearch::GetServices method |  |  | space
This method has a Restful Webservice representation only! Method for collecting all service records of the resulting search space in one call without the necessity to call the record positioning methods and the appropriate properties of this interface. The services are returned as JSON array however large that search space might be. So this might be a memory and performance bottleneck. Possibly, one might call the IMiscSearch::GetRecordCount method to get the size of the search space prior to call GetServices unconditionally. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearch/GetServices
[JSON input data] | pISearch: | longValue, //interface address
[JSON result array] | { pbstrTariffType: pbstrChapterCode: pbstrCode: pReferenceCode: pbstrName: pbstrInterpretation: pbstrLimitation: pdTP: pdTPMax: pdPercentFactor: plVatRateCode: pdValidFrom: pdValidTo: plServiceProperties: pbStatus: | "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", doubleValue, doubleValue, doubleValue, longValue, "stringISODateValue", "stringISODateValue", longValue, booleanValue },
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrTariffType | The tariff type (aka tariff number) of the currently focused service |
[out] BSTR | *pbstrChapterCode | The chapter code the currently focused service belongs to |
[out] BSTR | *pbstrCode | The code of the currently focused service |
[out] BSTR | *pReferenceCode | A comma-separated list of reference codes where the selected service is obliged to map to one of the given services. The list might be empty if target service is not known in advanced. If the selected service does not have the enServicePropertyIsNeedsRefCode bit set than the returned value is empty by definition. |
[out] BSTR | *pbstrName | The name of the currently focused service |
[out] BSTR | *pbstrInterpretation | The interpretation text of the currently focused service |
[out] BSTR | *pbstrLimitation | The limitation text of the currently focused service |
[out] double | *pdTP | The tax point (TP) or minimum tax point (TPmin) of the currently focused service |
[out] double | *pdTPMax | The maximum tax point (TPmax) of the currently focused service |
[out] double | *pdPercentFactor | The percent factor of the currently focused service |
[out] long | *plVatRateCode | The applicable vat rate code of the currently focused service |
[out] DATE | *pdValidFrom | The validity start date of the currently focused service |
[out] DATE | *pdValidTo | The validity end date of the currently focused service |
[out] long | *plServiceProperties | The service properties value defines all semantic capabilities of a service. The value is a 32-bit integer composed from Ored values of the ServicePropertyType enumeration list. Please note, that the explicit value of a certain capability is retrieved with the GetPropertyValue method. |
[out,retval] VARIANT_BOOL | *pbStatus | Boolean return status |
space |


  • ISearch
  • MoveFirst

ISearch::MoveFirst method |  |  | space
Moves the record pointer to the first record in the selection list and makes that record the current record. All property functions act upon and return data from that current record If the action could not be performed or the selection list is empty than S_FALSE will be returned. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearch/MoveFirst
[JSON input data] | pISearch: | longValue, //interface address
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT MoveFirst( | VARIANT_BOOL | *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out,retval] VARIANT_BOOL | *pbStatus | Return the status of the method. If pbStatus is VARIANT_TRUE than all is OK. whereas VARIANT_FALSE means that the action could no be completed due to an "end_of_data" message or an error situation. Call GetAbortInfo to check for possible errors. |
space |


  • ISearch
  • MoveLast

ISearch::MoveLast method |  |  | space
Moves the record pointer to the last record in the selection list and makes that record the current record. All property functions act upon and return data from that current record If the action could not be performed or the selection list is empty than S_FALSE will be returned. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearch/MoveLast
[JSON input data] | pISearch: | longValue, //interface address
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT MoveLast( | VARIANT_BOOL | *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out,retval] VARIANT_BOOL | *pbStatus | Return the status of the method. If pbStatus is VARIANT_TRUE than all is OK. whereas VARIANT_FALSE means that the action could no be completed due to an "end_of_data" message or an error situation. Call GetAbortInfo to check for possible errors. |
space |


  • ISearch
  • MoveNext

ISearch::MoveNext method |  |  | space
Moves the record pointer to the next record in the selection list and makes that record the current record. All property functions act upon and return data from that current record If the action could not be performed or the selection list is empty than S_FALSE will be returned. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearch/MoveNext
[JSON input data] | pISearch: | longValue, //interface address
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT MoveNext( | VARIANT_BOOL | *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out,retval] VARIANT_BOOL | *pbStatus | Return the status of the method. If pbStatus is VARIANT_TRUE than all is OK. whereas VARIANT_FALSE means that the action could no be completed due to an "end_of_data" message or an error situation. Call GetAbortInfo to check for possible errors. |
space |


  • ISearch
  • MovePrevious

ISearch::MovePrevious method |  |  | space
Moves the record pointer to the previous record in the selection list and makes that record the current record. All property functions act upon and return data from that current record If the action could not be performed or the selection list is empty than S_FALSE will be returned. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearch/MovePrevious
[JSON input data] | pISearch: | longValue, //interface address
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT MovePrevious( | VARIANT_BOOL | *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out,retval] VARIANT_BOOL | *pbStatus | Return the status of the method. If pbStatus is VARIANT_TRUE than all is OK. whereas VARIANT_FALSE means that the action could no be completed due to an "end_of_data" message or an error situation. Call GetAbortInfo to check for possible errors. |
space |


  • ISearch
  • PutAbsolutePosition

ISearch::PutAbsolutePosition method |  |  | space
Positions the record pointer at the specified absolute position in the selection list. This method can be useful for implementing virtual selection lists. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearch/PutAbsolutePosition
[JSON input data] | pISearch: lID: | longValue, //interface address longValue
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT PutAbsolutePosition( | long VARIANT_BOOL | lID, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] long | lID | The ID of the service record to position to |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string and value. |
space |


  • ISearch
  • SearchChapter

ISearch::SearchChapter method |  |  | space
This method searches for services included in the given chapter query expression. Thus this method can be used to get all services of a given chapter. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearch/SearchChapter
[JSON input data] | pISearch: bstrTariffType: dDate: bstrChapterCode: | longValue, //interface address "utf8StringValue", variantDateValue | "stringISODateValue", "utf8StringValue"
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT SearchChapter( | BSTR DATE BSTR VARIANT_BOOL | bstrTariffType, dDate, bstrChapterCode, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrTariffType | The tariff type to use in the query |
[in] DATE | dDate | The date to use for the query. Valid (and returned) records must have a validity date range that does include the given date! Supply a DATE <= 0 to turn off the date range check! |
[in] BSTR | bstrChapterCode | Query string that is used for searching in the chapter code portion of the tariff catalog (cf. properties WildCard and WildCharacter for using wildcards) |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string and value. |
space |


  • ISearch
  • SearchCode

ISearch::SearchCode method |  |  | space
This method searches for services by code |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearch/SearchCode
[JSON input data] | pISearch: bstrTariffType: dDate: bstrCode: | longValue, //interface address "utf8StringValue", variantDateValue | "stringISODateValue", "utf8StringValue"
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT SearchCode( | BSTR DATE BSTR VARIANT_BOOL | bstrTariffType, dDate, bstrCode, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrTariffType | The tariff type to use in the query |
[in] DATE | dDate | The date to use for the query. Valid (and returned) records must have a validity date range that does include the given date! Supply a DATE <= 0 to turn off the date range check! |
[in] BSTR | bstrCode | Query string that is used for searching in the code portion of the tariff catalog (cf. properties WildCard and WildCharacter for using wildcards) |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string and value. |
space |


  • ISearch
  • SearchName

ISearch::SearchName method |  |  | space
This method searches for services by name |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearch/SearchName
[JSON input data] | pISearch: bstrTariffType: dDate: bstrName: | longValue, //interface address "utf8StringValue", variantDateValue | "stringISODateValue", "utf8StringValue"
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT SearchName( | BSTR DATE BSTR VARIANT_BOOL | bstrTariffType, dDate, bstrName, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrTariffType | The tariff type to use in the query |
[in] DATE | dDate | The date to use for the query. Valid (and returned) records must have a validity date range that does include the given date! Supply a DATE <= 0 to turn off the date range check! |
[in] BSTR | bstrName | Query string that is used for searching in the name portion of the tariff catalog (cf. properties WildCard and WildCharacter for using wildcards) |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string and value. |
space |


  • ISearch
  • ChapterCode

ISearch::ChapterCode property | space
The chapter code the given service record belongs to
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch/GetChapterCode?param
[param] pISearch= longValue
[JSON result data] pbstrChapterCode: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | ChapterCode( BSTR *pbstrChapterCode );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrChapterCode | The chapter code that the current service belongs to
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetChapterCode(void);
space


  • ISearch
  • Code

ISearch::Code property | space
The code of the selected service record
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch/GetCode?param
[param] pISearch= longValue
[JSON result data] pbstrCode: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Code( BSTR *pbstrCode );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrCode | The code of the current service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetCode(void);
space


  • ISearch
  • DestructSearch

ISearch::DestructSearch property |  |  | space
This property has a Restful Webservice representation only! Destructs/invalidates this ISearch interface instance. The counterpart property to generate an ISearch interface instance is IMiscValidator::GetCreateSearch. |  |  |
space
Restful webservice calling syntax |  |  |
[PUT] | /baseURL/ ISearch/PutDestructSearch
[JSON input data] | pISearch: | longValue, //interface address
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Remarks |  |  |
This property has a Restful Webservice representation only! |  |  |
space |


  • ISearch
  • Interpretation

ISearch::Interpretation property | space
The interpretation (exclusion and inclusion remarks, rules, comments and the like) of the selected service
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch/GetInterpretation?param
[param] pISearch= longValue
[JSON result data] pbstrInterpretation: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Interpretation( BSTR *pbstrInterpretation );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrInterpretation | The service interpretation of the current service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetInterpretation(void);
space


  • ISearch
  • Name

ISearch::Name property | space
The name of the selected service record
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch/GetName?param
[param] pISearch= longValue
[JSON result data] pbstrName: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Name( BSTR *pbstrName );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrName | The name of the current service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetName(void);
space


  • ISearch
  • ReferenceCode

ISearch::ReferenceCode property | space
Returns a comma-separated list of reference codes where the selected service is obliged to map to one of the given services.
The list might be empty if target service is not known in advanced.

If the selected service does not have the enServicePropertyIsNeedsRefCode bit set than the returned value is empty by definition.

space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch/GetReferenceCode?param
[param] pISearch= longValue
[JSON result data] pbstrReferenceCode: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | ReferenceCode( BSTR *pbstrReferenceCode );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrReferenceCode | The reference code of the current service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetReferenceCode(void);
space


  • ISearch
  • ServiceProperties

ISearch::ServiceProperties property | space
This value defines all semantic capabilities of a service.
The value is a 32-bit integer composed from ORed values of the ServicePropertyType enumeration list.

Please note, that the explicit value of a certain capability is retrieved with the GetPropertyValue method.

space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch/GetServiceProperties?param
[param] pISearch= longValue
[JSON result data] plServiceProperties: longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | ServiceProperties( long *plServiceProperties );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] long | *plServiceProperties | The ORed service properties of the current service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • long *GetServiceProperties(void);
space


  • ISearch
  • TariffType

ISearch::TariffType property | space
The tariff type the selected service record belongs to
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch/GetTariffType?param
[param] pISearch= longValue
[JSON result data] pbstrTariffType: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | TariffType( BSTR *pbstrTariffType );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrTariffType | The tariff type (aka tariff number) of the current service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetTariffType(void);
space


  • ISearch
  • ValidFrom

ISearch::ValidFrom property | space
The validity start date of the selected service record
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch/GetValidFrom?param
[param] pISearch= longValue
[JSON result data] pdValidFrom: "stringISODateValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | ValidFrom( DATE *pdValidFrom );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] DATE | *pdValidFrom | The validity start of the current service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • DATE *GetValidFrom(void);
space


  • ISearch
  • ValidTo

ISearch::ValidTo property | space
The validity end date of the selected service record
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch/GetValidTo?param
[param] pISearch= longValue
[JSON result data] pdValidTo: "stringISODateValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | ValidTo( DATE *pdValidTo );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] DATE | *pdValidTo | The validity end of the current service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • DATE *GetValidTo(void);
space


  • IValidate

IValidate interface |  | V2.00/ 1 May 2014
The IValidate interface allows for the input and validation of supplied service data. the validation checks whether the data conforms to the rule set of the selected service. There will be a rejection of a supplied service if it is in conflict with another service. All data and the calculated amount of a service can be retrieved can be retrieved with the interface"s properties. Finally, after all service records have been added the finalize methods starts all finale rule checks and returns the summed up amount over all services. |  | space
space
Methods |  | 10 methods
AddService | Adds a new service which will be validated against all previously added services of the same session |
Finalize | Validate all services of the given tariff type by running the "late binding" rules and than finalizes all records added so far and finally calculates the total amount in CHF over all service amounts of the given tariff type |
GetAbortInfo | Fetches the abort/error information if there is any stored |
GetService | Method for collecting all data of the currently focused service in one call without the necessity to call the appropriate properties of this interface |
Initialize | Initializes the validation and clears all previously added records of a certain tariff type |
MoveFirst | Moves the record pointer to the first record in the selection list and makes that record the current record |
MoveLast | Moves the record pointer to the last record in the selection list and makes that record the current record |
MoveNext | Moves the record pointer to the next record in the selection list and makes that record the current record |
MovePrevious | Moves the record pointer to the previous record in the selection list and makes that record the current record |
SetTreatmentData | Sets the treatment input data constant over all tariffs |
space
Properties |  | 14 properties
[get] Amount | The amount of the service in CHF calculated by the equation Amount = (ExternalFactor * Quantity * TP * TPValue). |
[get] Code | The code of the selected service record |
[get] Date | Date of the service record |
[put] DestructValidate | Destructs/invalidates this IValidate interface instance |
[get] ExternalFactor | External factor that is used |
[get] Hook | The hook of the selected service (external ID) |
[get] IgnoreValidate | Flag indicating whether the validation was ignored or not |
[get] Name | The name of the service record |
[get] Quantity | The quantity of the service record |
[get] ReferenceCode | The reference code of the service |
[get] SessionNumber | Number of the session |
[get] TariffType | The tariff type the selected service record belongs to |
[get] TP | Tax points of the service record |
[get] TPValue | Tax point value of the service |
space |


  • IValidate
  • AddService

IValidate::AddService method | space
Adds a new service which will be validated against all previously added services of the same session. If the code supplied passes all validations a VARIANT_TRUE value is returned. If the code was not accepted VARIANT_FALSE is returned and the variable plStatus contains the error code.
space
Restful webservice calling syntax
[POST] | /baseURL/ IValidate/AddService
[JSON input data] pIValidate:
bstrTariffType:
bstrCode:
bstrReferenceCode:
dQuantity:
dTP:
dTPValue:
dExternalFactor:
lSessionNumber:
dDate:
eIgnoreValidate:
lHook: 		longValue, //interface address
"utf8StringValue",
"utf8StringValue",
"utf8StringValue",
doubleValue,
doubleValue,
doubleValue,
doubleValue,
longValue,
variantDateValue | "stringISODateValue",
longValue,
longValue
[JSON result data] pbStatus: booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
HRESULT AddService( BSTR
BSTR
BSTR
double
double
double
double
long
DATE
YesNoType
long
VARIANT_BOOL 		bstrTariffType,
bstrCode,
bstrReferenceCode,
dQuantity,
dTP,
dTPValue,
dExternalFactor,
lSessionNumber,
dDate,
eIgnoreValidate,
lHook,
*pbStatus);
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[in] BSTR bstrTariffType Tariff catalog to use.
Use the methods miscValidator::GetFirstTariff/miscValidator::GetNextTariff to iterate over all (filtered) tariff catalogs
[in] BSTR | bstrCode | Code of the service
[in] BSTR bstrReferenceCode The reference code of the service. The reference code must be set if the enServicePropertyIsNeedsRefCode bit of that service is set.
If a reference code is needed than that parent service must be supplied before this one.
[in] double dQuantity Quantity of the service
If enIgnoreValidate=enNo and dQuantity=0 then the quantity is auto-expanded to 1.0 by the validator
[in] double dTP Tax point of the service.
If enIgnoreValidate=enNo and dTP=0 then the tax point is auto-expanded to the correct TP by the validator. The auto-expansion of a variable TP service is set as (TPMax+TPmin)/2.
If the upper bound of a variable TP service is undefined than TP is set 0 in the auto-expansion!
[in] double dTPValue Tax point value of the service
Please note that there is no internal database for the various tax point values. Therefore, there is no auto-expansion of the TPV possible.
[in] double dExternalFactor External factor to set
If enIgnoreValidate=enNo and dExternalFactor=0 then the external factor is auto-expanded to 1.0 by the validator
[in] long lSessionNumber Session number
If enIgnoreValidate=enNo and lSessionNumber=0 then the session number is auto-expanded to 1 by the validator
[in] DATE | dDate | Date of the service to ensure a valid date range of the service record itself
[in] YesNoType eIgnoreValidate Flag indicating whether the validation should be ignored or not.
To turn off the validation might be useful in the situation when a service should be added even if the validation failed due to a special agreement with the insurance or patient.
[in] long | lHook | External hook. The software house can provide e.g. a record ID of the service to identify this service later on when reading data back.
[out,retval] VARIANT_BOOL *pbStatus The principal validation status
  • =0 is returned for success
  • >0 indicates that a validation rule was not fulfilled - the service is not added. Use the GetAbortInfo to get an error description string.
  • <0 indicates a severe principal COM automation error - the service is not added. Use the GetAbortInfo to get an error description string.
space


  • IValidate
  • Finalize

IValidate::Finalize method |  |  | space
Validate all services of the given tariff type by running the "late binding" rules and than finalizes all records added so far and finally calculates the total amount in CHF over all service amounts of the given tariff type. This method is the counterpart to the Initialize method. Note, this method should be called after all data have been set in the IValidate:AddService method. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IValidate/Finalize
[JSON input data] | pIValidate: bstrTariffType: | longValue, //interface address "utf8StringValue"
[JSON result data] | pdTotalAmount: pbStatus: | doubleValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT Finalize( | BSTR double VARIANT_BOOL | bstrTariffType, *pdTotalAmount, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrTariffType | The tariff type for which the total amount should be to calculated. If bstrTariffType is NULL then the total amount over all tariff types is calculated. |
[out] double | *pdTotalAmount | The total amount in CHF over all service amounts of the given tariff type. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IValidate
  • GetAbortInfo

IValidate::GetAbortInfo method |  |  | space
Fetches the abort/error information if there is any stored. If any method generates an error/error string than the error situation is signaled by the VARIANT_BOOL status of that method. GetAbortInfo can then be used to retrieve the error code und error string. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IValidate/GetAbortInfo
[JSON input data] | pIValidate: | longValue, //interface address
[JSON result data] | pbstrAbortText: plAbortCode: pbStatus: | "utf8StringValue", longValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetAbortInfo( | BSTR long VARIANT_BOOL | *pbstrAbortText, *plAbortCode, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrAbortText | The abort information string that corresponds with the abort/error code. The abort string is empty if there is no error condition. Possibly S_FALSE was set by an iterator to signal end_of_data, which is seen as a "non-error". |
[out] long | *plAbortCode | The abort code that corresponds with the abort/error string. The abort code is 0 if there is no error condition. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred! No further information can be retrieved. |
space |


  • IValidate
  • GetService

IValidate::GetService method |  |  | space
This method has a Restful Webservice representation only! Method for collecting all data of the currently focused service in one call without the necessity to call the appropriate properties of this interface. The counterpart method to add services is IMiscValidator::AddService |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IValidate/GetService
[JSON input data] | pIValidate: | longValue, //interface address
[JSON result data] | pbstrTariffType: pbstrCode: pbstrReferenceCode: pbstrName: pdQuantity: pdTP: pdTPValue: pdDate: peIgnoreValidate: pdExternalFactor: plSessionNumber: plHook: pdAmount: pbStatus: | "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", doubleValue, doubleValue, doubleValue, "stringISODateValue", longValue, doubleValue, longValue, longValue, doubleValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrTariffType | The tariff type (aka tariff number) of the currently focused service |
[out] BSTR | *pbstrCode | The code of the currently focused service |
[out] BSTR | *pbstrReferenceCode | The applied reference code of the currently focused service |
[out] BSTR | *pbstrName | The name of the currently focused service |
[out] double | *pdQuantity | The quantity of the currently focused service |
[out] double | *pdTP | The tax point (TP) of the currently focused service |
[out] double | *pdTPValue | The tax point value (TPV) of the currently focused service |
[out] DATE | *pdDate | The application date of the currently focused service |
[out] YesNoType | *peIgnoreValidate | The flag indicating whether the currently focused service was ignored in validation (enNo) or not (enYes). |
[out] double | *pdExternalFactor | The external scaling factor applied to the currently focused service |
[out] long | *plSessionNumber | The applied session number of the currently focused service |
[out] long | *plHook | The hook of the currently focused service |
[out] double | *pdAmount | The amount in CHF of the currently focused service calculated as ( Amount = Quantity * TP * TPValue * ExternalFactor ) |
[out,retval] VARIANT_BOOL | *pbStatus | Boolean return status |
space |


  • IValidate
  • Initialize

IValidate::Initialize method |  |  | space
Initializes the validation and clears all previously added records of a certain tariff type |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IValidate/Initialize
[JSON input data] | pIValidate: bstrTariffType: eRole: ePlace: | longValue, //interface address "utf8StringValue", longValue, longValue
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT Initialize( | BSTR RoleType PlaceType VARIANT_BOOL | bstrTariffType, eRole, ePlace, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrTariffType | Tariff number for which the initialization should be performed. If the variable is NULL then all tariff types are cleared. |
[in] RoleType | eRole | Supplies the role for which the given tariff type is used. If bstrTariffType is NULL then the role is applied for all tariffs. Note that this information is currently not used. |
[in] PlaceType | ePlace | Supplies the place for which the given tariff type is used. If bstrTariffType is NULL then the place is applied for all tariffs. Note that this information is currently not used. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string and value. |
space |


  • IValidate
  • MoveFirst

IValidate::MoveFirst method |  |  | space
Moves the record pointer to the first record in the selection list and makes that record the current record. All property functions act upon and return data from that current record If the action could not be performed or the selection list is empty than S_FALSE will be returned. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IValidate/MoveFirst
[JSON input data] | pIValidate: bstrTariffType: | longValue, //interface address "utf8StringValue"
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT MoveFirst( | BSTR VARIANT_BOOL | bstrTariffType, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrTariffType | The tariff type for which the positioning methods (MoveNext etc.) act and for which the position is set to the first record. All other positioning methods act upon the same tariff. |
[out,retval] VARIANT_BOOL | *pbStatus | Return the status of the method. If pbStatus is VARIANT_TRUE than all is OK. whereas VARIANT_FALSE means that the action could no be completed due to an "end_of_data" message or an error situation. Call GetAbortInfo to check for possible errors. |
space |


  • IValidate
  • MoveLast

IValidate::MoveLast method |  |  | space
Moves the record pointer to the last record in the selection list and makes that record the current record. All property functions act upon and return data from that current record If the action could not be performed or the selection list is empty than S_FALSE will be returned. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IValidate/MoveLast
[JSON input data] | pIValidate: | longValue, //interface address
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT MoveLast( | VARIANT_BOOL | *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out,retval] VARIANT_BOOL | *pbStatus | Return the status of the method. If pbStatus is VARIANT_TRUE than all is OK. whereas VARIANT_FALSE means that the action could no be completed due to an "end_of_data" message or an error situation. Call GetAbortInfo to check for possible errors. |
space |


  • IValidate
  • MoveNext

IValidate::MoveNext method |  |  | space
Moves the record pointer to the next record in the selection list and makes that record the current record. All property functions act upon and return data from that current record If the action could not be performed or the selection list is empty than S_FALSE will be returned. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IValidate/MoveNext
[JSON input data] | pIValidate: | longValue, //interface address
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT MoveNext( | VARIANT_BOOL | *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out,retval] VARIANT_BOOL | *pbStatus | Return the status of the method. If pbStatus is VARIANT_TRUE than all is OK. whereas VARIANT_FALSE means that the action could no be completed due to an "end_of_data" message or an error situation. Call GetAbortInfo to check for possible errors. |
space |


  • IValidate
  • MovePrevious

IValidate::MovePrevious method |  |  | space
Moves the record pointer to the previous record in the selection list and makes that record the current record. All property functions act upon and return data from that current record If the action could not be performed or the selection list is empty than S_FALSE will be returned. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IValidate/MovePrevious
[JSON input data] | pIValidate: | longValue, //interface address
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT MovePrevious( | VARIANT_BOOL | *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out,retval] VARIANT_BOOL | *pbStatus | Return the status of the method. If pbStatus is VARIANT_TRUE than all is OK. whereas VARIANT_FALSE means that the action could no be completed due to an "end_of_data" message or an error situation. Call GetAbortInfo to check for possible errors. |
space |


  • IValidate
  • SetTreatmentData

IValidate::SetTreatmentData method |  |  | space
Sets the treatment input data constant over all tariffs |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IValidate/SetTreatmentData
[JSON input data] | pIValidate: eCanton: eLaw: ePatientSex: dPatientBirthdate: | longValue, //interface address longValue, longValue, longValue, variantDateValue | "stringISODateValue"
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT SetTreatmentData( | CantonType LawType SexType DATE VARIANT_BOOL | eCanton, eLaw, ePatientSex, dPatientBirthdate, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] CantonType | eCanton | Canton where the services are applied |
[in] LawType | eLaw | Law under which the services are applied |
[in] SexType | ePatientSex | Gender of the patient |
[in] DATE | dPatientBirthdate | Birth date of the patient |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string and value. |
space |


  • IValidate
  • Amount

IValidate::Amount property | space
The amount of the service in CHF calculated by the equation Amount = (ExternalFactor * Quantity * TP * TPValue).
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetAmount?param
[param] pIValidate= longValue
[JSON result data] pdAmount: doubleValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Amount( double *pdAmount );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] double | *pdAmount | The amount of the service in CHF
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • double *GetAmount(void);
space


  • IValidate
  • Code

IValidate::Code property | space
The code of the selected service record
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetCode?param
[param] pIValidate= longValue
[JSON result data] pbstrCode: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Code( BSTR *pbstrCode );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrCode | The code of the current service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetCode(void);
space


  • IValidate
  • Date

IValidate::Date property | space
Date of the service record
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetDate?param
[param] pIValidate= longValue
[JSON result data] pdDate: doubleValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Date( double *pdDate );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] double | *pdDate | The defined date of the current service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • double *GetDate(void);
space


  • IValidate
  • DestructValidate

IValidate::DestructValidate property |  |  | space
This property has a Restful Webservice representation only! Destructs/invalidates this IValidate interface instance. The counterpart property to generate an Ivalidate interface instance is IMiscValidator::GetCreateValidate. |  |  |
space
Restful webservice calling syntax |  |  |
[PUT] | /baseURL/ IValidate/PutDestructValidate
[JSON input data] | pIValidate: | longValue, //interface address
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Remarks |  |  |
This property has a Restful Webservice representation only! |  |  |
space |


  • IValidate
  • ExternalFactor

IValidate::ExternalFactor property | space
External factor that is used
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetExternalFactor?param
[param] pIValidate= longValue
[JSON result data] pdExternalFactor: doubleValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | ExternalFactor( double *pdExternalFactor );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] double | *pdExternalFactor | The external scaling factor of the current services
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • double *GetExternalFactor(void);
space


  • IValidate
  • Hook

IValidate::Hook property | space
The hook of the selected service (external ID)
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetHook?param
[param] pIValidate= longValue
[JSON result data] plHook: longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Hook( long *plHook );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] long | *plHook | The hook of the current service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • long *GetHook(void);
space


  • IValidate
  • IgnoreValidate

IValidate::IgnoreValidate property | space
Flag indicating whether the validation was ignored or not
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetIgnoreValidate?param
[param] pIValidate= longValue
[JSON result data] peIgnoreValidate: longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | IgnoreValidate( YesNoType *peIgnoreValidate );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] YesNoType | *peIgnoreValidate | Boolean that defines if the current service has a 'ignore validate' status (enYes) or not (enNo)
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • YesNoType *GetIgnoreValidate(void);
space


  • IValidate
  • Name

IValidate::Name property | space
The name of the service record
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetName?param
[param] pIValidate= longValue
[JSON result data] pbstrName: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Name( BSTR *pbstrName );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrName | The name of the current service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetName(void);
space


  • IValidate
  • Quantity

IValidate::Quantity property | space
The quantity of the service record
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetQuantity?param
[param] pIValidate= longValue
[JSON result data] pdQuantity: doubleValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Quantity( double *pdQuantity );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] double | *pdQuantity | The quantity of the current service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • double *GetQuantity(void);
space


  • IValidate
  • ReferenceCode

IValidate::ReferenceCode property | space
The reference code of the service
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetReferenceCode?param
[param] pIValidate= longValue
[JSON result data] pbstrReferenceCode: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | ReferenceCode( BSTR *pbstrReferenceCode );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrReferenceCode | The reference code of the current service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetReferenceCode(void);
space


  • IValidate
  • SessionNumber

IValidate::SessionNumber property | space
Number of the session
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetSessionNumber?param
[param] pIValidate= longValue
[JSON result data] plSessionNumber: longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | SessionNumber( long *plSessionNumber );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] long | *plSessionNumber | The session number of the current service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • long *GetSessionNumber(void);
space


  • IValidate
  • TariffType

IValidate::TariffType property | space
The tariff type the selected service record belongs to
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetTariffType?param
[param] pIValidate= longValue
[JSON result data] pbstrTariffType: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | TariffType( BSTR *pbstrTariffType );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrTariffType | The tariff type (aka tariff number) of the current service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetTariffType(void);
space


  • IValidate
  • TP

IValidate::TP property | space
Tax points of the service record
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetTP?param
[param] pIValidate= longValue
[JSON result data] pdTP: doubleValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | TP( double *pdTP );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] double | *pdTP | The tax points (TP) of the current service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • double *GetTP(void);
space


  • IValidate
  • TPValue

IValidate::TPValue property | space
Tax point value of the service
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetTPValue?param
[param] pIValidate= longValue
[JSON result data] pdTPValue: doubleValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | TPValue( double *pdTPValue );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] double | *pdTPValue | The tax point value TPV of the current service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • double *GetTPValue(void);
space


  • Type definitions

Builtin, composite & enumeration types |  | V2.00/ 1 May 2014
The following list shows ans defines all used data types either basic builtin, composite or enumeration types that are used in the interface of the ATL COM module. |  | space
space
Data types |  | 17 types
[builtin] BSTR | A BSTR, known as basic string or binary string, is a pointer to a wide character string used by Automation data manipulation functions |
[enumeration] CantonType | Enumerates the defined Swiss cantons or neighboring countries. |
[builtin] DATE | A value denoting a date and time was specified |
[builtin] double | An 8-byte IEEE real value |
[builtin] HRESULT | The HRESULT data type is a 32-bit value that is used to describe an error or warning |
[builtin] IChapter | IChapter interface |
[builtin] ISearch | ISearch interface |
[builtin] IValidate | IValidate interface |
[enumeration] LanguageType | Enumerates all supported languages |
[enumeration] LawType | Enumerates the supported legal law set. |
[builtin] long | A 4-byte integer value |
[enumeration] PlaceType | Enumerates the defined places where the main provider is located |
[enumeration] RoleType | Enumerates the defined role categories that the main provider is best categorized |
[enumeration] ServicePropertyType | Defines properties a service possibly can possess in terms of an orthogonal bit list. |
[enumeration] SexType | Enumerates the defined gender categories |
[builtin] VARIANT_BOOL | A 16 bit Boolean (True/False) value was specified |
[enumeration] YesNoType | Boolean enumerator |
space |


  • Type definitions
  • BSTR

BSTR type |
A BSTR, known as basic string or binary string, is a pointer to a wide character string used by Automation data manipulation functions. BSTRs are wide, double-byte (Unicode) strings on 32-bit Windows platforms. | space
space
space


  • Type definitions
  • CantonType

CantonType enumeration type |  |
Enumerates the defined Swiss cantons or neighboring countries. |  | space
space
Set of enumeration values |  | 32 elements
enCantonUndefined: 0 | The canton is undefined |
enAG: 1 | The Swiss canton AG |
enAI: 2 | The Swiss canton AI |
enAR: 3 | The Swiss canton AR |
enBE: 4 | The Swiss canton BE |
enBL: 5 | The Swiss canton BL |
enBS: 6 | The Swiss canton BS |
enFR: 7 | The Swiss canton FR |
enGE: 8 | The Swiss canton GE |
enGL: 9 | The Swiss canton GL |
enGR: 10 | The Swiss canton GR |
enJU: 11 | The Swiss canton JU |
enLU: 12 | The Swiss canton LU |
enNE: 13 | The Swiss canton NE |
enNW: 14 | The Swiss canton NW |
enOW: 15 | The Swiss canton OW |
enSG: 16 | The Swiss canton SG |
enSH: 17 | The Swiss canton SH |
enSO: 18 | The Swiss canton SO |
enSZ: 19 | The Swiss canton SZ |
enTG: 20 | The Swiss canton TG |
enTI: 21 | The Swiss canton TI |
enUR: 22 | The Swiss canton UR |
enVD: 23 | The Swiss canton VD |
enVS: 24 | The Swiss canton VS |
enZG: 25 | The Swiss canton ZG |
enZH: 26 | The Swiss canton ZH |
enLiechtenstein: 27 | The country is Liechtenstein |
enAustria: 28 | The country is Austria |
enGermany: 29 | The country is Germany |
enItaly: 30 | The country is Italy |
enFrance: 31 | The country is France |
space


  • Type definitions
  • DATE

DATE type |
A value denoting a date and time was specified. Dates are represented as double-precision numbers, where midnight, January 1, 1900 is 2.0, January 2, 1900 is 3.0, and so on. The value is passed in date. | space
space
space


  • Type definitions
  • double

double type |
An 8-byte IEEE real value | space
space
space


  • Type definitions
  • HRESULT

HRESULT type |
The HRESULT data type is a 32-bit value that is used to describe an error or warning | space
space
space


  • Type definitions
  • IChapter

IChapter type |
IChapter interface | space
space
space


  • Type definitions
  • ISearch

ISearch type |
ISearch interface | space
space
space


  • Type definitions
  • IValidate

IValidate type |
IValidate interface | space
space
space


  • Type definitions
  • LanguageType

LanguageType enumeration type |  |
Enumerates all supported languages |  | space
space
Set of enumeration values |  | 3 elements
enGerman: 1 | language German |
enFrench: 2 | language French |
enItalian: 3 | language Italian |
space


  • Type definitions
  • LawType

LawType enumeration type |  |
Enumerates the supported legal law set. |  | space
space
Set of enumeration values |  | 7 elements
enLawUndefined: -1 | The applicable law is undefined |
enKVG: 0 | The applicable law is KVG - "Krankenversicherungsgesetz" |
enUVG: 1 | The applicable law is UVG - "Unfallversicherungsgesetz" |
enMVG: 2 | The applicable law is MVG - "Militäversicherungsgesetz" |
enIVG: 3 | The applicable law is IVG - "Invalidenversicherungsgesetz" |
enVVG: 4 | The applicable law is VVG - "Versicherungsvertragsgesetz" |
enORG: 5 | The applicable law is ORG - "Obligationenrecht" This is primarily for invoices e.g. of dentists. |
space


  • Type definitions
  • long

long type |
A 4-byte integer value | space
space
space


  • Type definitions
  • PlaceType

PlaceType enumeration type |  |
Enumerates the defined places where the main provider is located |  | space
space
Set of enumeration values |  | 6 elements
enPlaceUndefined: 0 | the place is not yet defined |
enPlacePractice: 1 | place is Practice Note that enPlacePractice, enPlaceLab, enPlaceAssociation, enPlaceCompany are treated as synonyms for a working place that is not a hospital |
enPlaceHospital: 2 | place is Hospital |
enPlaceLab: 4 | place is Laboratory Note that enPlacePractice, enPlaceLab, enPlaceAssociation, enPlaceCompany are treated as synonyms for a working place that is not a hospital |
enPlaceAssociation: 8 | place is Association Note that enPlacePractice, enPlaceLab, enPlaceAssociation, enPlaceCompany are treated as synonyms for a working place that is not a hospital |
enPlaceCompany: 16 | place is Company Note that enPlacePractice, enPlaceLab, enPlaceAssociation, enPlaceCompany are treated as synonyms for a working place that is not a hospital |
space


  • Type definitions
  • RoleType

RoleType enumeration type |  |
Enumerates the defined role categories that the main provider is best categorized |  | space
space
Set of enumeration values |  | 23 elements
enRoleUndefined: 0 | the role is not yet defined |
enRolePhysician: 1 | the role of the service provider is a university degree MD |
enRolePhysiotherapist: 2 | the role of the service provider is a physiotherapist |
enRoleChiropractor: 4 | the role of the service provider is a chiropractor |
enRoleErgotherapist: 8 | the role of the service provider is an ergotherapist |
enRoleNutritionist: 16 | the role of the service provider is a nutritionist including dietitians and nutrition advisors for diabetics |
enRoleMidwife: 32 | the role of the service provider is a midwife |
enRoleLogotherapist: 64 | the role of the service provider is a logotherapist |
enRoleHospital: 128 | this is a "virtual" role covering any medical/paramedical role in a hospital |
enRolePharmacist: 256 | the role of the service provider is a pharmacist |
enRoleDentist: 512 | the role of the service provider is a dentist including dental hygienists |
enRoleLabTechnician: 1024 | the role of the service provider is a laboratory technician |
enRoleDentalTechnician: 2048 | the role of the service provider is a dental technician |
enRoleOtherTechnician: 4096 | the role of the service provider is a technician including shoemakers other than dental or lab technicians |
enRolePsychologist: 16384 | the role of the service provider is psychologist |
enRoleFlatrateService: 32768 | this is a "virtual" role covering services of flat rate tariffs like 910,920,930,940 |
enRoleWholesaler: 65536 | the role of the service provider is a wholesaler |
enRoleNursingStaff: 131072 | the role of the service provider either from the nursing staff or nursing auxiliary |
enRoleTransport: 262144 | the role of the service provider is from the transport area e.g. ambulance or carrier |
enRoleDruggist: 524288 | the role of the service provider is a druggist |
enRoleNaturopathicDoctor: 1048576 | the role of the service provider covers professionals of natural medicine other than university degree MDs |
enRoleNaturopathicTherapist: 2097152 | the role of the service provider covers therapists of natural medicine as well as professionals of the wellness area |
enRoleOther: 4194304 | the role of the service provider is not explicitly mentioned in the list |
space


  • Type definitions
  • ServicePropertyType

ServicePropertyType enumeration type
Defines properties a service possibly can possess in terms of an orthogonal bit list. | space
space
Set of enumeration values | 8 elements
enServicePropertyHasTP: 1 This bit position characterizes the service as one with a fixed tax point (TP) as opposed to a variable TP services. As a consequence the TPmin and TPmax bits are not set (cf below)!

To retrieve the TP of that service call the ISearch::GetPropertyValue method with a property name of "enServicePropertyHasTP" or just "TP".
enServicePropertyHasTPMin: 2 This bit position characterizes the service as one with a variable tax point (TP) as opposed to a fixed TP services. As a consequence the TP bit is not set and TPmax bit is set as well!

To retrieve the lower bound of the TP interval of that service (TP min) call the ISearch::GetPropertyValue method with a property name of "enServicePropertyHasTPMin" or just "TPmin".
enServicePropertyHasTPMax: 4 This bit position characterizes the service as one with a variable tax point (TP) as opposed to a fixed TP services. As a consequence the TP bit is not set and TPmin bit is set as well!

To retrieve the upper bound of the TP interval of that service (TP max) call the ISearch::GetPropertyValue method with a property name of "enServicePropertyHasTPMax" or just "TPmax".
enServicePropertyIsFrancService: 8 | This bit position characterizes the service as defined in Francs and therefore the tax point value (TPV) must be 1.0.
enServicePropertyIsPercentService: 16 This bit position characterizes the service as a percent service meaning that the TP is calculated as a percent fraction from another service defined by a reference code. Consequently, all services with the enServicePropertyIsPercentService bit set have the enServicePropertyIsNeedsRefCode bit set as well.

To retrieve the percent fraction of that service, call the ISearch::GetPropertyValue method with a property name of "enServicePropertyIsPercentService" or just "percentService".
enServicePropertyIsNeedsRefCode: 32 This bit position characterizes the service as one that needs a reference code basically defining a chain of codes. If a service needs a reference code than that referenced service must be supplied prior than the current service.

To retrieve the reference code, call either the ISearch::GetReferenceCode property or the ISearch::GetPropertyValue method with a property name of "enServicePropertyIsNeedsRefCode" or just "needsRefCode". The such retrieved reference code might be empty in cases where the explicit reference code is unknown and only the property to need a reference code is known.

Note, that all services with a turned on "isPercentService" bit have the "needsRefCode" bit turned on as well but not vice versa!
enServicePropertyHasVatRateCode: 64 This bit position characterizes that a vat rate is defined for the service. Since all services have a vat rate this bit is always set.

To retrieve the applicable vat rate code, call the ISearch::GetPropertyValue method with a property name of "enServicePropertyHasVatRateCode" or just "vatRateCode". The returned value is one of
  • 0 = none (currently 0% vat rate)
  • 1 = reduced (currently 2.5% vat rate)
  • 2 = full (currently 8% vat rate)
enServicePropertyHasExcludedVat: 128 | This bit position characterizes that the service is a Netto service that has the vat rate not yet included. The currently used invoice system assumes a Brutto system meaning that a TP value has the vat rate included.
space


  • Type definitions
  • SexType

SexType enumeration type |  |
Enumerates the defined gender categories |  | space
space
Set of enumeration values |  | 2 elements
enMale: 0 | gender is Male |
enFemale: 1 | gender is Female |
space


  • Type definitions
  • VARIANT_BOOL

VARIANT_BOOL type |
A 16 bit Boolean (True/False) value was specified. A value of 0xFFFF (all bits 1) indicates True; a value of 0 (all bits 0) indicates False. No other values are valid. | space
space
space


  • Type definitions
  • YesNoType

YesNoType enumeration type |  |
Boolean enumerator |  | space
space
Set of enumeration values |  | 2 elements
enNo: 0 | boolean value No. |
enYes: 1 | boolean value Yes. |
space


 Sumex1 under a 64bit architecture...

All Sumex1 COM modules are written as 32bit managed C++ dll. As a consequence, a 64bit executable cannot load a 32bit COM dll into its process space due to the addressing differences.

Since some necessary underlying sub-modules are not available in a 64bit version, this problem must be addressed differently than by a 64bit compilation. As Microsoft suggests Sumex1 uses the out-of-process proxy approach where a 32bit COM server loads the 32bit COM dll into its process space and delegates each method call to the dll. Since a 32bit COM server exists in its own process space, the main 64bit process can handle the 64/32bit boundary without problems.

As a result, each 32bit Sumex1 COM dll has a 32bit COM server counterpart with the same name and an oopProxy prefix, e.g. oopProxyMiscValidator200.exe, where the prefix signifies the out-of-process proxy nature of the executable.

Any 64bit software now creates an instance of the 32bit oopProxy server and then calls the same methods and properties as with the 32bit COM dll. However, there is one crucial difference when using the oopProxy mechanism, namely the necessity to forcefully unload to the COM server at the end e.g. by using Marshal.ReleaseComObject() since the automatic garbage collection approach is too error prone.


 Visual Basic code snippet for using the miscValidator200 COM module

Private Sub miscValidator200Test_Click()
    On Error GoTo Err_Trap

    Dim bStatus As Boolean

    ' ### IMiscValidatorInterface
    ' obtain the misc validator main interface
    ' ###
    Dim IMiscValidator As MISCVALIDATOR200Lib.MiscValidator
    Set IMiscValidator = New MiscValidator

    ' open the database first and set the language
    ' ###
    bStatus = IMiscValidator.Open(enGerman)
    If bStatus Then
        ' Restrict the role of the provider to be a physiotherapist working under KVG
        ' ###
        lRoleRestrict = MISCVALIDATOR200Lib.enRolePhysiotherapist
        lPlaceRestrict = MISCVALIDATOR200Lib.enPlacePractice
        lLawRestrict = MISCVALIDATOR200Lib.enKVG
        Dim strEAN As String
        strEAN = ""
        bStatus = IMiscValidator.SetTariffFilter(lRoleRestrict, lPlaceRestrict, lLawRestrict, strEAN)

        Dim bstrTariffType As String
        Dim bstrTariffName As String
        Dim bstrVersion As String
        Dim dValidFrom As Date
        Dim dValidTo As Date

        'Loop over all tariffs that match the criteria
        bFoundTariffs = IMiscValidator.GetFirstTariff(bstrTariffType, bstrTariffName,  _
                                                      bstrVersion, dValidFrom, dValidTo)
        If bFoundTariffs Then
            While IMiscValidator.GetNextTariff(bstrTariffType, bstrTariffName, bstrVersion, _
                                               dValidFrom, dValidTo)
               ' ###
               ' do something in here
               ' ###
            Wend
        End If

        '### IChapter interface
        ' Chapters group a specific tariff in to a hierarchical order
        ' e.g. for Physio
        '   311:5
        '   311:5.1
        '   311:5.2
        ' ###
        Dim IChapter As MISCVALIDATOR200Lib.Chapter

        ' Get the chapter interface from the main interface
        ' ###
        Set IChapter = IMiscValidator.CreateChapter
        Dim dDate As Date
        Dim bstrCode As String
        bstrTariffType = "311"       ' use the physiotherapy tariff
        bstrCode = ""                ' this will return all chapters
        dDate = DateValue(Now)

        bStatus = IChapter.SearchName(bstrTariffType, dDate, bstrCode)
        If bStatus Then
            Dim bContinue As Boolean
            bContinue = IChapter.MoveFirst
            While bContinue
                bstrCode = IChapter.Code
                bstrParentCode = IChapter.ParentCode
                bstrName = IChapter.Name
                bstrInterpretation = IChapter.Interpretation

                ' ###
                ' do something
                ' ###

                bContinue = IChapter.MoveNext
            Wend
        End If

        ' ### ISearch interface
        ' search vor tariffe positions/codes
        ' ###
        Dim ISearch As MISCVALIDATOR200Lib.Search
        Set ISearch = IMiscValidator.CreateSearch

        ' search within the physiotherapy tariff 311
        ' for all codes starting with 73
        ' ###
        bResult = ISearch.SearchCode("311", dDate, "73*")
        If bResult Then
            Dim bHasResult As Boolean
            bHasMoreCodes = ISearch.MoveFirst
            While bHasMoreCodes
                bstrCode = ISearch.Code
                bstrChapterCode = ISearch.ChapterCode
                bstrName = ISearch.Name
                bstrTariffType = ISearch.TariffType

                ' servicesProperties defines available properties by an
                ' ORed long value of ServicePropertyType enumerators
                ' the meaning if the bits is defined in the ServicePropertyType enum
                ' ###
                lServiceProperties = ISearch.ServiceProperties
                'check if the TP property is available
                If (enServicePropertyHasTP & lServiceProperties) > 0 Then
                    Dim bstrPropName As String
                    bstrPropName = "TP" 'also works with the full name enServicePropertyHasTP
                    Dim bstrPropValue As String
                    bResult = ISearch.GetPropertyValue(bstrPropName, bstrPropValue)
                    If bResult Then

                        ' ###
                        ' do someting TP value
                        ' ###

                    End If
                End If
                bHasMoreCodes = ISearch.MoveNext
            Wend
        End If

        ' ### IValidate ###
        ' Input and validate services
        ' ###
        Dim IValidate As MISCVALIDATOR200Lib.Validate
        Set IValidate = IMiscValidator.CreateValidate

        ' Initialize the module for the physiotherapist example
        ' ###
        bStatus = IValidate.Initialize("311", enRolePhysiotherapist, enPlacePractice)
        If bStatus Then
            bstrTariffType = "311"      ' physio tariffe number
            bstrCode = "7301"           ' code 7301 = Sitzungspauschale
            bstrRefCode = ""            ' parent code is empty due to enServicePropertyIsNeedsRefCode bit
            dQuantity = 1               ' the quantity
            dTP = 0                     ' the tax points: if given as 0 then the TP is auto expaned
                                        ' if dTP>0 then it is checked against the internal TP. An error
                                        ' is raised if dTP > dTpinternal
            dTPV = 1                    ' tax point value of the service.
                                        ' Please note that the TPV must be supplied as input
            dExternalFactor = 1         ' defines a discount or an upscaling
            lSessionNumber = 1          ' session number
            Dim dServiceDate As Date
            dServiceDate = DateValue(Now)
            Dim lHook As Long
            lHook = 1234                ' a hook, e.g. software specific recordID
                                        ' to identifiy a potentially errorneous position

            ' Input the service and validate the current services against the previous records supplied
            ' ###
            bStatus = IValidate.AddService(bstrTariffType, bstrCode, bstrRefCode, dQuantity, dTP, dTPV,  _
                                           dExternalFactor, lSessionNumber, dServiceDate, enNo, lHook)

            If Not bStatus Then
                MsgBox "Failed to add Service " & bstrCode
            End If

            ' calculate the total amount for a specific service
            ' ###
            Dim dTotalAmount As Double
            dTotalAmount = 0
            bResult = IValidate.Finalize(bstrTariffType, dTotalAmount)
            If Not bStatus Then
                MsgBox "something dammed wrong here "
            End If

        End If
    End If

    Exit Sub

Err_Trap:
    MsgBox "Error: " & Err.Description, vbCritical, _
           "Opps! Error" & Str$(Err.Number)

End Sub


 General use of the miscValidator200 ATL COM module

  • First create an instance of the miscValidator COM module.

    Open the tariff database with the IMiscValidator::Open method. Set the localization language using the IMiscValidator::SetLanguage. Loop over the supplied tariff catalogs by using IMiscValidator/GetFirstTariff/IMiscValidator/GetNextTariff. Optionally the list of available tariff catalogs can be shrinked with the IMiscValidator::SetTariffFilter method prior to use the iterator.
  • Let the user search for a code, name or chapter of a selected tariff catalog with the the ISearch and IChapter search methods. Each of these methods produced a list of service records that can be traversed with the positioning methods MoveFirst / MoveNext. The properties of a loaded record are supplied with various property functions like GetCode, GetValidFrom.
  • Set the treatment data using the IValidate::SetTreatmentData method before adding any services.
    Then add the selected services with the IValidate::AddService method until all is done and lastly call the IValidate::Finalize method.
  • Release the miscValidator200 COM module instance.


 Introduction, overview and usage of the Restful Webservice Server

The application miscValidatorServer200.exe is a Restful Webservice Server, that has the same interface methods/properties as the COM module miscValidator200.dll. This allows to create a programming semantically similar to the COM approach but under the Restful Webservice paradigm. Consequently, on the Restful Client side there are no prevailing dependencies on Microsoft platforms and/or on Microsoft resources such as the database technology. Of course, the installation location of the server software is still subject to these restrictions.

In the next section of this document, the installation, configuration and operation of miscValidatorServer200.exe will be addressed.

Installation, registration and parameterization:
By installing the installer object miscValidator200 the COM module miscValidator200.dll as well as the out-of-process proxy component oopMiscValidator200.exe is automatically installed/registered in the system. However, the miscValidatorServer200.exe must be installed manually as a service.
miscValidatorServer200.exe -help | Creates a help window with the the name and full version of the applicationb as well as the currently define Webservice Endpoint. Furthermore the complete list of command line switches is shown.
miscValidatorServer200.exe -install | Installs/registers the Restful Webservice Server as a service. Please take into account, that the installation must be performed under administrator privileges
miscValidatorServer200.exe -uninstall | Uninstalls the service component. Please take into account, that the uninstallation must be performed under administrator privileges
miscValidatorServer200.exe -setport X | Sets the port X as part of the Webservice Endpoint
Restful Webservice Endpoint:
Installing miscValidatorServer200.exe as a service activates the Restful Webservice Endpoint:
http://localhost:34558/miscValidatorServer200
which is subsumed as baseURL in subsequent the API documentation.

To run the webservice under a different URL or under https protocol, a permanent webservice target endpoint mapping is performed on the target system.
For example, under Apache, the following rewrite rule is defined:
<VirtualHost *:*>
    ProxyPreserveHost Off
    Header always set Access-Control-Allow-Origin "*"
    Header always set Access-Control-Max-Age "1000"
    Header always set Access-Control-Allow-Headers "x-requested-with, Content-Type, origin, authorization, accept, client-security-token"

    ProxyPass /miscValidator/200/ http://localhost:34558/miscValidatorServer200/
    ProxyPassReverse /miscValidator/200/ http://localhost:34558/miscValidatorServer200/
</VirtualHost>
Restful Webservice Operation:
The service may be modified after installation, for example to start under a different account, to extend the recovery properties or to change the startup type. Finally, this should be set to 'Automatic' or 'Automatic (Delayed start)' so that the service is automatically available after a system restart.
Remarks about programming:
In the rest of this document we will discuss programming of the Restful web service and the differences to the C/C++ programming of the classic COM component.

As already mentioned, Restful programming is analogous to C++ programming with the addition that each instance of an interface (including the main interface) is created via the corresponding GET function. For example, an instance of the main interface is created with:
baseURL/IMiscValidator/GetCreateMiscValidator | returns the instance address as JSON out{pIMiscValidator: longValue,...}
In every further call of a method or a property of the main interface this instance address must be included as part of the JSON-In. The termination/deletion of an instance must be done via the corresponding PUT Destruct property:
baseURL/IMiscValidator/PutDestructMiscValidator | with JSON-In{pIMiscValidator: longValue}, deletes the corresponding main instance AND all at that moment still active dependent subinstances (subinstances which have been generated by the explicit main instance).
It should be noted that the webserver miscValidatorServer200.exe performs an internal management of the generated instances and automatically deletes instances that have no activity for a defined period of 2 hours. no activity over a defined period of 2 hours. If after this action a rest call with such an instance is made, an error (HTTP Status >= 400) is generated and the instance address is marked as unknown.
Code snippet:
Minimal code snippet to query the version of the module and the associated database:
    http://localhost:34558/miscValidatorServer200/IMiscValidator/GetCreateMiscValidator
        returns JSON-Out{pIMiscValidator: 45467}

    http://localhost:34558/miscValidatorServer200/IMiscValidator/GetModuleVersion?pIMiscValidator=45467
        returns JSON-Out{pbstrModuleVersion: "1.00.010"}

    http://localhost:34558/miscValidatorServer200/IMiscValidator/GetDBVersionText?pIMiscValidator=45467
        returns JSON-Out{pbstrDBVersionText: "3.22"}

    http://localhost:34558/miscValidatorServer200/IMiscValidator/GetDBVersionDate?pIMiscValidator=45467
        returns JSON-Out{pdDBVersionDate: "2021-11-29"}

    http://localhost:34778/miscValidatorServer200/IMiscValidator/GetCreateValidate?pIMiscValidator=45467
        returns JSON-Out{pIValidate: 47008}

    http://localhost:34778/miscValidatorServer200/IValidate/PutDestructValidate
        JSON-IN(pIValidate: 47008}

    http://localhost:34558/miscValidatorServer200/IMiscValidator/PutDestructMiscValidator
        JSON-IN{pIMiscValidator:45467}