Validators: physioValidator overview

 physioValidator module - API browser

Interface version: | 1.00
Interface date: | 30 Aug 2002
The physioValidator is an ATL COM module which provides methods to browse, to query, and to validate records against the physio catalog.

Interfaces | 3 interfaces
IPhysioValidator | database handling and global settings
ISearch | search functionality
IValidate | Validation of service records according to the rules
Types |
type definitions | list of all used builtin, composite and enumeration types
Important information about the usage and handling of the module
Document: | Notice about the "configuration parameters" in the physioValidator!!
Document: | General useage of the physioValidator module

© by sumex1.net - all rights reserved


 IPhysioValidator interface

Description V1.00/30 Aug 2002
The IPhysioValidator interface handles connections to the physio database. It provides a means to open and close database connections, and set and retrieve general database parameters, such as the database or module versions. A connection to the database must be opened via IPhysioValidator before methods from any of the other interfaces can be used.
physioValidator
IPhysioValidator

Methods 8 methods
Close | GetTreatment
GetAbortInfo | Open
GetFirstTPValue | OpenEx
GetNextTPValue | SetTreatment

Properties 15 properties
[get] | CreateSearch | [get/put] | Language
[get] | CreateValidate | [get] | ModuleVersion
[get/put] | Date | [get] | ModuleVersionText
[get] | DBVersion | [get/put] | PlaceType
[get] | DBVersionDate | [get/put] | RoleType
[get] | DBVersionText | [get/put] | WildCard
[get/put] | EnableLog | [get/put] | WildCharacter
[get/put] | ExternalFactor |  |


 IPhysioValidator::Close method

Closes the physio database.
physioValidator
IPhysioValidator
Close

C/C++ syntax
HRESULT Close( VARIANT_BOOL *pbStatus);

Parameter description
[out, retval] VARIANT_BOOL *pbStatus

C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


 IPhysioValidator::GetAbortInfo method

Get the abort information.
physioValidator
IPhysioValidator
GetAbortInfo

C/C++ syntax
HRESULT GetAbortInfo( | BSTR | *pbstrAbort,
 | VARIANT_BOOL | *pbStatus);

Parameter description
[out] | BSTR | *pbstrAbort | Abort information string.
[out, retval] | VARIANT_BOOL | *pbStatus |

C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


 IPhysioValidator::GetFirstTPValue method

Retrieves the first tax point value information.
physioValidator
IPhysioValidator
GetFirstTPValue

C/C++ syntax
HRESULT GetFirstTPValue( | double | *pdTPValue,
 | DATE | *pdValidFrom,
 | DATE | *pdValidTo,
 | VARIANT_BOOL | *pbStatus);

Parameter description
[out] | double | *pdTPValue | Tax point value.
[out] | DATE | *pdValidFrom | Tax point value valid from date.
[out] | DATE | *pdValidTo | Tax point value valid to date.
[out, retval] | VARIANT_BOOL | *pbStatus |

C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


 IPhysioValidator::GetNextTPValue method

Retrieves the next tax point value information.
physioValidator
IPhysioValidator
GetNextTPValue

C/C++ syntax
HRESULT GetNextTPValue( | double | *pdTPValue,
 | DATE | *pdValidFrom,
 | DATE | *pdValidTo,
 | VARIANT_BOOL | *pbStatus);

Parameter description
[out] | double | *pdTPValue | Tax point value.
[out] | DATE | *pdValidFrom | Tax point value valid from date.
[out] | DATE | *pdValidTo | Tax point value valid to date.
[out, retval] | VARIANT_BOOL | *pbStatus |

C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


 IPhysioValidator::GetTreatment method

Get the treatment input data.
physioValidator
IPhysioValidator
GetTreatment

C/C++ syntax
HRESULT GetTreatment( | CantonType | *peCanton,
 | LawType | *peLaw,
 | SettlementType | *peSettlement,
 | VARIANT_BOOL | *pbStatus);

Parameter description
[out] | CantonType | *peCanton | Canton type.
[out] | LawType | *peLaw | Law type.
[out] | SettlementType | *peSettlement | Settlement type.
[out, retval] | VARIANT_BOOL | *pbStatus |

C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


 IPhysioValidator::Open method

Opens the physio database.
physioValidator
IPhysioValidator
Open

C/C++ syntax
HRESULT Open( | LanguageType | enLanguage,
 | VARIANT_BOOL | *pbStatus);

Parameter description
[in] | LanguageType | enLanguage | Language type of the catalog.
[out, retval] | VARIANT_BOOL | *pbStatus |

C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


 IPhysioValidator::OpenEx method

Opens the physio database.
physioValidator
IPhysioValidator
OpenEx

C/C++ syntax
HRESULT OpenEx( | LanguageType | enLanguage,
 | BSTR | bstrConnect,
 | VARIANT_BOOL | *pbStatus);

Parameter description
[in] | LanguageType | enLanguage | Language type of the catalog.
[in] | BSTR | bstrConnect | Connect string for the database. See the Open method for the ADO Connection object for a detailed description.
[out, retval] | VARIANT_BOOL | *pbStatus |

C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


 IPhysioValidator::SetTreatment method

Set the treatment input data.
physioValidator
IPhysioValidator
SetTreatment

C/C++ syntax
HRESULT SetTreatment( | CantonType | eCanton,
 | LawType | eLaw,
 | SettlementType | eSettlement,
 | VARIANT_BOOL | *pbStatus);

Parameter description
[in] | CantonType | eCanton | Canton type.
[in] | LawType | eLaw | Law type.
[in] | SettlementType | eSettlement | Settlement type.
[out, retval] | VARIANT_BOOL | *pbStatus |

C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


 IPhysioValidator::CreateSearch property

Create an instance of the ISearch interface.
physioValidator
IPhysioValidator
CreateSearch

C/C++ syntax
[get] HRESULT CreateSearch( ISearch **aISearch);

Parameter description
[out, retval] ISearch **aISearch

C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that an exception is thrown under these conditions if you are using SmartPointers.

Remarks
If you are using SmartPointers the function names and calls are rewritten by Microsoft into the form:
  • ISearch **GetCreateSearch(void);


 IPhysioValidator::CreateValidate property

Create an instance of the IValidate interface.
physioValidator
IPhysioValidator
CreateValidate

C/C++ syntax
[get] HRESULT CreateValidate( IValidate **aIValidate);

Parameter description
[out, retval] IValidate **aIValidate

C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that an exception is thrown under these conditions if you are using SmartPointers.

Remarks
If you are using SmartPointers the function names and calls are rewritten by Microsoft into the form:
  • IValidate **GetCreateValidate(void);


 IPhysioValidator::Date property

Get and Set the current date for the physioValidator module. This date will be used for each method where no explicit date must be specified, for example the SearchCode method in the ISearch interface. The default is the current date.
physioValidator
IPhysioValidator
Date

C/C++ syntax
[get] HRESULT Date( | DATE | *aDATE);
[put] HRESULT Date( | DATE | aDATE);

Parameter description
[out,retval]
[in] 		DATE
DATE 		*aDATE
aDATE

C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that an exception is thrown under these conditions if you are using SmartPointers.

Remarks
If you are using SmartPointers the function names and calls are rewritten by Microsoft into the form:
  • DATE *GetDate(void);
  • void PutDate(DATE aDATE);


 IPhysioValidator::DBVersion property

Get the version of the physioValidator database.
physioValidator
IPhysioValidator
DBVersion

C/C++ syntax
[get] HRESULT DBVersion( BSTR *aBSTR);

Parameter description
[out, retval] BSTR *aBSTR

C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that an exception is thrown under these conditions if you are using SmartPointers.

Remarks
If you are using SmartPointers the function names and calls are rewritten by Microsoft into the form:
  • BSTR *GetDBVersion(void);


 IPhysioValidator::DBVersionDate property

Get the version date of the physioValidator database.
physioValidator
IPhysioValidator
DBVersionDate

C/C++ syntax
[get] HRESULT DBVersionDate( DATE *aDATE);

Parameter description
[out, retval] DATE *aDATE

C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that an exception is thrown under these conditions if you are using SmartPointers.

Remarks
If you are using SmartPointers the function names and calls are rewritten by Microsoft into the form:
  • DATE *GetDBVersionDate(void);


 IPhysioValidator::DBVersionText property

Get the textual version of the physioValidator database.
physioValidator
IPhysioValidator
DBVersionText

C/C++ syntax
[get] HRESULT DBVersionText( BSTR *aBSTR);

Parameter description
[out, retval] BSTR *aBSTR

C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that an exception is thrown under these conditions if you are using SmartPointers.

Remarks
If you are using SmartPointers the function names and calls are rewritten by Microsoft into the form:
  • BSTR *GetDBVersionText(void);


 IPhysioValidator::EnableLog property

Get and Set the log activity for the module. The default log activity is enYes.
physioValidator
IPhysioValidator
EnableLog

C/C++ syntax
[get] HRESULT EnableLog( | YesNoType | *aYesNoType);
[put] HRESULT EnableLog( | YesNoType | aYesNoType);

Parameter description
[out,retval]
[in] 		YesNoType
YesNoType 		*aYesNoType
aYesNoType

C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that an exception is thrown under these conditions if you are using SmartPointers.

Remarks
If you are using SmartPointers the function names and calls are rewritten by Microsoft into the form:
  • YesNoType *GetEnableLog(void);
  • void PutEnableLog(YesNoType aYesNoType);


 IPhysioValidator::ExternalFactor property

External scaling factor for the service.
physioValidator
IPhysioValidator
ExternalFactor

C/C++ syntax
[get] HRESULT ExternalFactor( | double | *adouble);
[put] HRESULT ExternalFactor( | double | adouble);

Parameter description
[out,retval]
[in] 		double
double 		*adouble
adouble

C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that an exception is thrown under these conditions if you are using SmartPointers.

Remarks
If you are using SmartPointers the function names and calls are rewritten by Microsoft into the form:
  • double *GetExternalFactor(void);
  • void PutExternalFactor(double adouble);


 IPhysioValidator::Language property

Get and Set the language for the physioValidator module. The default language is enGerman.
physioValidator
IPhysioValidator
Language

C/C++ syntax
[get] HRESULT Language( | LanguageType | *aLanguageType);
[put] HRESULT Language( | LanguageType | aLanguageType);

Parameter description
[out,retval]
[in] 		LanguageType
LanguageType 		*aLanguageType
aLanguageType

C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that an exception is thrown under these conditions if you are using SmartPointers.

Remarks
If you are using SmartPointers the function names and calls are rewritten by Microsoft into the form:
  • LanguageType *GetLanguage(void);
  • void PutLanguage(LanguageType aLanguageType);


 IPhysioValidator::ModuleVersion property

Get the version of the physioValidator module.
physioValidator
IPhysioValidator
ModuleVersion

C/C++ syntax
[get] HRESULT ModuleVersion( BSTR *aBSTR);

Parameter description
[out, retval] BSTR *aBSTR

C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that an exception is thrown under these conditions if you are using SmartPointers.

Remarks
If you are using SmartPointers the function names and calls are rewritten by Microsoft into the form:
  • BSTR *GetModuleVersion(void);


 IPhysioValidator::ModuleVersionText property

Get the textual version of the physioValidator module.
physioValidator
IPhysioValidator
ModuleVersionText

C/C++ syntax
[get] HRESULT ModuleVersionText( BSTR *aBSTR);

Parameter description
[out, retval] BSTR *aBSTR

C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that an exception is thrown under these conditions if you are using SmartPointers.

Remarks
If you are using SmartPointers the function names and calls are rewritten by Microsoft into the form:
  • BSTR *GetModuleVersionText(void);


 IPhysioValidator::PlaceType property

Get and Set the place where the service is provided.
physioValidator
IPhysioValidator
PlaceType

C/C++ syntax
[get] HRESULT PlaceType( | PlaceType | *aPlaceType);
[put] HRESULT PlaceType( | PlaceType | aPlaceType);

Parameter description
[out,retval]
[in] 		PlaceType
PlaceType 		*aPlaceType
aPlaceType

C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that an exception is thrown under these conditions if you are using SmartPointers.

Remarks
If you are using SmartPointers the function names and calls are rewritten by Microsoft into the form:
  • PlaceType *GetPlaceType(void);
  • void PutPlaceType(PlaceType aPlaceType);


 IPhysioValidator::RoleType property

Role type of the service provider.
physioValidator
IPhysioValidator
RoleType

C/C++ syntax
[get] HRESULT RoleType( | RoleType | *aRoleType);
[put] HRESULT RoleType( | RoleType | aRoleType);

Parameter description
[out,retval]
[in] 		RoleType
RoleType 		*aRoleType
aRoleType

C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that an exception is thrown under these conditions if you are using SmartPointers.

Remarks
If you are using SmartPointers the function names and calls are rewritten by Microsoft into the form:
  • RoleType *GetRoleType(void);
  • void PutRoleType(RoleType aRoleType);


 IPhysioValidator::WildCard property

Get and Set the match-all wildcard character for SQL queries. You can use this property if you have imported the original physio database into another database, which uses a different wildcard character for queries. The default match-all wildcard character is the percent symbol (%). With the physioValidator Module you can always formulate a query using the asterisk symbol (*) as a wildcard, as in each query string a * is replaced by the wildcard character specified by this property before being executed.
physioValidator
IPhysioValidator
WildCard

C/C++ syntax
[get] HRESULT WildCard( | BSTR | *aBSTR);
[put] HRESULT WildCard( | BSTR | aBSTR);

Parameter description
[out,retval]
[in] 		BSTR
BSTR 		*aBSTR
aBSTR

C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that an exception is thrown under these conditions if you are using SmartPointers.

Remarks
If you are using SmartPointers the function names and calls are rewritten by Microsoft into the form:
  • BSTR *GetWildCard(void);
  • void PutWildCard(BSTR aBSTR);


 IPhysioValidator::WildCharacter property

Get and Set the "match any single character" wildcard character for SQL queries. You can use this property if you have ported the original physio database into another database, which uses a different wild character for the queries. The default match-single-character wildcard character is the underscore symbol (_). With the physioValidator Module you can always formulate a query using the question mark (?) as a wildcard, as in each query string a ? is replaced by the wildcard character specified by this property before execution.
physioValidator
IPhysioValidator
WildCharacter

C/C++ syntax
[get] HRESULT WildCharacter( | BSTR | *aBSTR);
[put] HRESULT WildCharacter( | BSTR | aBSTR);

Parameter description
[out,retval]
[in] 		BSTR
BSTR 		*aBSTR
aBSTR

C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that an exception is thrown under these conditions if you are using SmartPointers.

Remarks
If you are using SmartPointers the function names and calls are rewritten by Microsoft into the form:
  • BSTR *GetWildCharacter(void);
  • void PutWildCharacter(BSTR aBSTR);


 ISearch interface

The ISearch interface allows browsing of and retrieval of detailed information from the physio database. Searches can be performed by code or by name. The search terms may be specified in full, or may include wildcards. After a successful search, all of the available information directly related to the search term is made available through the interface's properties.

Every method which starts with the name Search (for example SearchName) produces as a result a selection list, composed of zero or more service records. The total number of records in the list can be retrieved using the method GetRecordCount. The record pointer is initially positioned at the first entry of the selection list. The available information related to the current record is made available through the interface's properties. The methods MoveFirst, MoveLast, MoveNext, MovePrevious, PutAbsolutePosition, and GetAbsolutePosition are used to reposition the record pointer.
physioValidator
ISearch

Methods 10 methods
GetAbortInfo | MoveNext
GetAbsolutePosition | MovePrevious
GetRecordCount | PutAbsolutePosition
MoveFirst | SearchCode
MoveLast | SearchName

Properties 9 properties
[get] | Code | [get] | TPValue
[get] | Interpretation | [get] | UsableBy
[get] | Limitation | [get] | ValidFrom
[get] | Name | [get] | ValidTo
[get] | TP |  |


 ISearch::GetAbortInfo method

Get the abort information.
physioValidator
ISearch
GetAbortInfo

C/C++ syntax
HRESULT GetAbortInfo( | BSTR | *pbstrAbort,
 | VARIANT_BOOL | *pbStatus);

Parameter description
[out] | BSTR | *pbstrAbort | Abort information string.
[out, retval] | VARIANT_BOOL | *pbStatus |

C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


 ISearch::GetAbsolutePosition method

Gets the current absolute position of the record pointer in the selection list. This method can be useful for implementing virtual selection lists.
physioValidator
ISearch
GetAbsolutePosition

C/C++ syntax
HRESULT GetAbsolutePosition( | long | *pVal,
 | VARIANT_BOOL | *pbStatus);

Parameter description
[out] | long | *pVal
[out, retval] | VARIANT_BOOL | *pbStatus

C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


 ISearch::GetRecordCount method

Gets the number of service records in the selection list.
physioValidator
ISearch
GetRecordCount

C/C++ syntax
HRESULT GetRecordCount( | long | *pVal,
 | VARIANT_BOOL | *pbStatus);

Parameter description
[out] | long | *pVal
[out, retval] | VARIANT_BOOL | *pbStatus

C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


 ISearch::MoveFirst method

Moves the record pointer to the first record in the selection list and makes that record the current service record. If the action could not be performed false will be returned.
physioValidator
ISearch
MoveFirst

C/C++ syntax
HRESULT MoveFirst( VARIANT_BOOL *pbStatus);

Parameter description
[out, retval] VARIANT_BOOL *pbStatus

C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


 ISearch::MoveLast method

Moves to the last record in the selection list and makes that record the current service record. If the action could not be performed false will be returned.
physioValidator
ISearch
MoveLast

C/C++ syntax
HRESULT MoveLast( VARIANT_BOOL *pbStatus);

Parameter description
[out, retval] VARIANT_BOOL *pbStatus

C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


 ISearch::MoveNext method

Moves to the next record in the selection list and makes that record the current service record. If the action could not be performed false will be returned.
physioValidator
ISearch
MoveNext

C/C++ syntax
HRESULT MoveNext( VARIANT_BOOL *pbStatus);

Parameter description
[out, retval] VARIANT_BOOL *pbStatus

C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


 ISearch::MovePrevious method

Moves to the previous record in the selection list object and makes that record the current service record. If the action could not be performed false will be returned.
physioValidator
ISearch
MovePrevious

C/C++ syntax
HRESULT MovePrevious( VARIANT_BOOL *pbStatus);

Parameter description
[out, retval] VARIANT_BOOL *pbStatus

C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


 ISearch::PutAbsolutePosition method

Positions the record pointer at the specified absolute position in the selection list. This method can be useful for implementing virtual selection lists.
physioValidator
ISearch
PutAbsolutePosition

C/C++ syntax
HRESULT PutAbsolutePosition( | long | newVal,
 | VARIANT_BOOL | *pbStatus);

Parameter description
[in] | long | newVal
[out, retval] | VARIANT_BOOL | *pbStatus

C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


 ISearch::SearchCode method

This method searches for services by code.
physioValidator
ISearch
SearchCode

C/C++ syntax
HRESULT SearchCode( | BSTR | bstrCode,
 | YesNoType | eDeactivateRoleFilter,
 | VARIANT_BOOL | *pbStatus);

Parameter description
[in] | BSTR | bstrCode | Service code.
[in] | YesNoType | eDeactivateRoleFilter | Some physio services might only be applicable for certain role types. The flag eDeactivateRoleFilter specifies whether to deactivate the role filter initially set when the validator was initialized. Setting the value to enYes deactivates the role filter for that specific search.
[out, retval] | VARIANT_BOOL | *pbStatus |

C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


 ISearch::SearchName method

This method searches for services by the service name.
physioValidator
ISearch
SearchName

C/C++ syntax
HRESULT SearchName( | BSTR | bstrName,
 | YesNoType | eDeactivateRoleFilter,
 | VARIANT_BOOL | *pbStatus);

Parameter description
[in] | BSTR | bstrName | Service name.
[in] | YesNoType | eDeactivateRoleFilter | Some physio services might only be applicable for certain role types. The flag eDeactivateRoleFilter specifies whether to deactivate the role filter initially set when the validator was initialized. Setting the value to enYes deactivates the role filter for that specific search.
[out, retval] | VARIANT_BOOL | *pbStatus |

C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


 ISearch::Code property

Service code.
physioValidator
ISearch
Code

C/C++ syntax
[get] HRESULT Code( BSTR *aBSTR);

Parameter description
[out, retval] BSTR *aBSTR

C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that an exception is thrown under these conditions if you are using SmartPointers.

Remarks
If you are using SmartPointers the function names and calls are rewritten by Microsoft into the form:
  • BSTR *GetCode(void);


 ISearch::Interpretation property

Service interpretation.
physioValidator
ISearch
Interpretation

C/C++ syntax
[get] HRESULT Interpretation( BSTR *aBSTR);

Parameter description
[out, retval] BSTR *aBSTR

C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that an exception is thrown under these conditions if you are using SmartPointers.

Remarks
If you are using SmartPointers the function names and calls are rewritten by Microsoft into the form:
  • BSTR *GetInterpretation(void);


 ISearch::Limitation property

Service limitation
physioValidator
ISearch
Limitation

C/C++ syntax
[get] HRESULT Limitation( BSTR *aBSTR);

Parameter description
[out, retval] BSTR *aBSTR

C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that an exception is thrown under these conditions if you are using SmartPointers.

Remarks
If you are using SmartPointers the function names and calls are rewritten by Microsoft into the form:
  • BSTR *GetLimitation(void);


 ISearch::Name property

Service name.
physioValidator
ISearch
Name

C/C++ syntax
[get] HRESULT Name( BSTR *aBSTR);

Parameter description
[out, retval] BSTR *aBSTR

C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that an exception is thrown under these conditions if you are using SmartPointers.

Remarks
If you are using SmartPointers the function names and calls are rewritten by Microsoft into the form:
  • BSTR *GetName(void);


 ISearch::TP property

Tax points of the service.
physioValidator
ISearch
TP

C/C++ syntax
[get] HRESULT TP( double *adouble);

Parameter description
[out, retval] double *adouble

C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that an exception is thrown under these conditions if you are using SmartPointers.

Remarks
If you are using SmartPointers the function names and calls are rewritten by Microsoft into the form:
  • double *GetTP(void);


 ISearch::TPValue property

Tax point value of the service.
physioValidator
ISearch
TPValue

C/C++ syntax
[get] HRESULT TPValue( double *adouble);

Parameter description
[out, retval] double *adouble

C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that an exception is thrown under these conditions if you are using SmartPointers.

Remarks
If you are using SmartPointers the function names and calls are rewritten by Microsoft into the form:
  • double *GetTPValue(void);


 ISearch::UsableBy property

Returns the information which service provider role is allowed to use that service. The long value i.e the mask is the sum ORed concatenation of the different RoleType values. As the RoleType enumerator values are powers of 2 and therefore a bitwise AND operation can test for a certain role.
physioValidator
ISearch
UsableBy

C/C++ syntax
[get] HRESULT UsableBy( long *along);

Parameter description
[out, retval] long *along

C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that an exception is thrown under these conditions if you are using SmartPointers.

Remarks
If you are using SmartPointers the function names and calls are rewritten by Microsoft into the form:
  • long *GetUsableBy(void);


 ISearch::ValidFrom property

Service valid from date.
physioValidator
ISearch
ValidFrom

C/C++ syntax
[get] HRESULT ValidFrom( DATE *aDATE);

Parameter description
[out, retval] DATE *aDATE

C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that an exception is thrown under these conditions if you are using SmartPointers.

Remarks
If you are using SmartPointers the function names and calls are rewritten by Microsoft into the form:
  • DATE *GetValidFrom(void);


 ISearch::ValidTo property

Service valid to date.
physioValidator
ISearch
ValidTo

C/C++ syntax
[get] HRESULT ValidTo( DATE *aDATE);

Parameter description
[out, retval] DATE *aDATE

C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that an exception is thrown under these conditions if you are using SmartPointers.

Remarks
If you are using SmartPointers the function names and calls are rewritten by Microsoft into the form:
  • DATE *GetValidTo(void);


 IValidate interface

The IValidate interface checks whether supplied service data conform to the physio rules. In case of a conflict with another service, the service will be rejected. Textual information explaining why the code was rejected can be retrieved, in order to provide appropriate feedback to the user.
physioValidator
IValidate

Methods 8 methods
AddService | MoveFirst
CalculateSum | MoveLast
GetAbortInfo | MoveNext
Initialize | MovePrevious

Properties 16 properties
[get] | CantonType | [get] | LawType
[get] | Charge | [get] | Name
[get] | Code | [get] | Quantity
[get] | Date | [get] | RoleType
[get] | ExternalFactor | [get] | SessionNumber
[get] | Hook | [get] | SettlementType
[get] | ID | [get] | TP
[get] | IgnoreValidate | [get] | TPValue


 IValidate::AddService method

Adds a new service which will be validated against all the previously entered services of the same session. If the code passed all the Validations a true value is returned. If the code was not accepted a value of false is returned and the variable plStatus contains the error code.
physioValidator
IValidate
AddService

C/C++ syntax
HRESULT AddService( | long | *plStatus,
 | BSTR | bstrCode,
 | double | dQuantity,
 | double | dTP,
 | double | dTPValue,
 | long | lSessionNumber,
 | DATE | dDate,
 | YesNoType | enIgnoreValidate,
 | long | lHook,
 | VARIANT_BOOL | *pbStatus);

Parameter description
[out] | long | *plStatus | A zero value is returned for success. A positive value indicates that a validation rule was not fulfilled, use the GetAbortInfo to get a description string and display an error message. A negative value indicates that the service was not added (see the AbortValidate Enumeration for possible codes). With the GetAbortInfo one can get a description, however preferable the required actions will be performed in the background.
[in] | BSTR | bstrCode | Code of the service.
[in] | double | dQuantity | Quantity value.
[in] | double | dTP | Tax point of the service. A zero value will be substituted by the tax point form the catalog.
[in] | double | dTPValue | Tax point value of the service. A zero value will be substituted by the tax point value form the catalog.
[in] | long | lSessionNumber | Session number.
[in] | DATE | dDate | Date of the service.
[in] | YesNoType | enIgnoreValidate | Flag indicating whether the validation was ignored.In the following situations this flag might be useful. The user wants to add the service even if the validation failed, perhaps he has a special agreement with the insurance or patient. When adding new services to already previously checked records, it is not necessary to check the existing records again.
[in] | long | lHook | External hook. The software house can provide for example the record ID of the service to identify the service later on.
[out, retval] | VARIANT_BOOL | *pbStatus |

C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


 IValidate::CalculateSum method

Calculate the sum of all services which have been added through the AddService method.
physioValidator
IValidate
CalculateSum

C/C++ syntax
HRESULT CalculateSum( | double | *pdTotal,
 | VARIANT_BOOL | *pbStatus);

Parameter description
[out] | double | *pdTotal | Total.
[out, retval] | VARIANT_BOOL | *pbStatus |

C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


 IValidate::GetAbortInfo method

Get the information indicating why the service could not be added.
physioValidator
IValidate
GetAbortInfo

C/C++ syntax
HRESULT GetAbortInfo( | BSTR | *pbstrAbort,
 | VARIANT_BOOL | *pbStatus);

Parameter description
[out] | BSTR | *pbstrAbort | Abort information string.
[out, retval] | VARIANT_BOOL | *pbStatus |

C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


 IValidate::Initialize method

Initializes the validation, clears all the entered records.
physioValidator
IValidate
Initialize

C/C++ syntax
HRESULT Initialize( VARIANT_BOOL *pbStatus);

Parameter description
[out, retval] VARIANT_BOOL *pbStatus

C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


 IValidate::MoveFirst method

Positions the record pointer at the first record in the result record set. If the action could not be performed false will be returned.
physioValidator
IValidate
MoveFirst

C/C++ syntax
HRESULT MoveFirst( VARIANT_BOOL *pbStatus);

Parameter description
[out, retval] VARIANT_BOOL *pbStatus

C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


 IValidate::MoveLast method

Positions the record pointer at the last record in the result record set. If the action could not be performed false will be returned.
physioValidator
IValidate
MoveLast

C/C++ syntax
HRESULT MoveLast( VARIANT_BOOL *pbStatus);

Parameter description
[out, retval] VARIANT_BOOL *pbStatus

C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


 IValidate::MoveNext method

Positions the record pointer at the next record in the result record set. If the action could not be performed false will be returned.
physioValidator
IValidate
MoveNext

C/C++ syntax
HRESULT MoveNext( VARIANT_BOOL *pbStatus);

Parameter description
[out, retval] VARIANT_BOOL *pbStatus

C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


 IValidate::MovePrevious method

Positions the record pointer at the previous record in the result record set. If the action could not be performed false will be returned.
physioValidator
IValidate
MovePrevious

C/C++ syntax
HRESULT MovePrevious( VARIANT_BOOL *pbStatus);

Parameter description
[out, retval] VARIANT_BOOL *pbStatus

C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


 IValidate::CantonType property

Canton type.
physioValidator
IValidate
CantonType

C/C++ syntax
[get] HRESULT CantonType( CantonType *aCantonType);

Parameter description
[out, retval] CantonType *aCantonType

C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that an exception is thrown under these conditions if you are using SmartPointers.

Remarks
If you are using SmartPointers the function names and calls are rewritten by Microsoft into the form:
  • CantonType *GetCantonType(void);


 IValidate::Charge property

The charge for the service in CHF.
physioValidator
IValidate
Charge

C/C++ syntax
[get] HRESULT Charge( double *adouble);

Parameter description
[out, retval] double *adouble

C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that an exception is thrown under these conditions if you are using SmartPointers.

Remarks
If you are using SmartPointers the function names and calls are rewritten by Microsoft into the form:
  • double *GetCharge(void);


 IValidate::Code property

Service code.
physioValidator
IValidate
Code

C/C++ syntax
[get] HRESULT Code( BSTR *aBSTR);

Parameter description
[out, retval] BSTR *aBSTR

C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that an exception is thrown under these conditions if you are using SmartPointers.

Remarks
If you are using SmartPointers the function names and calls are rewritten by Microsoft into the form:
  • BSTR *GetCode(void);


 IValidate::Date property

Date of the service.
physioValidator
IValidate
Date

C/C++ syntax
[get] HRESULT Date( double *adouble);

Parameter description
[out, retval] double *adouble

C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that an exception is thrown under these conditions if you are using SmartPointers.

Remarks
If you are using SmartPointers the function names and calls are rewritten by Microsoft into the form:
  • double *GetDate(void);


 IValidate::ExternalFactor property

Get and set the external scaling factor for the services.
physioValidator
IValidate
ExternalFactor

C/C++ syntax
[get] HRESULT ExternalFactor( double *adouble);

Parameter description
[out, retval] double *adouble

C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that an exception is thrown under these conditions if you are using SmartPointers.

Remarks
If you are using SmartPointers the function names and calls are rewritten by Microsoft into the form:
  • double *GetExternalFactor(void);


 IValidate::Hook property

The hook of the service (external ID).
physioValidator
IValidate
Hook

C/C++ syntax
[get] HRESULT Hook( long *along);

Parameter description
[out, retval] long *along

C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that an exception is thrown under these conditions if you are using SmartPointers.

Remarks
If you are using SmartPointers the function names and calls are rewritten by Microsoft into the form:
  • long *GetHook(void);


 IValidate::ID property

The internal ID of the service.
physioValidator
IValidate
ID

C/C++ syntax
[get] HRESULT ID( long *along);

Parameter description
[out, retval] long *along

C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that an exception is thrown under these conditions if you are using SmartPointers.

Remarks
If you are using SmartPointers the function names and calls are rewritten by Microsoft into the form:
  • long *GetID(void);


 IValidate::IgnoreValidate property

Flag indicating whether the validation was ignored.
physioValidator
IValidate
IgnoreValidate

C/C++ syntax
[get] HRESULT IgnoreValidate( YesNoType *aYesNoType);

Parameter description
[out, retval] YesNoType *aYesNoType

C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that an exception is thrown under these conditions if you are using SmartPointers.

Remarks
If you are using SmartPointers the function names and calls are rewritten by Microsoft into the form:
  • YesNoType *GetIgnoreValidate(void);


 IValidate::LawType property

Law type.
physioValidator
IValidate
LawType

C/C++ syntax
[get] HRESULT LawType( LawType *aLawType);

Parameter description
[out, retval] LawType *aLawType

C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that an exception is thrown under these conditions if you are using SmartPointers.

Remarks
If you are using SmartPointers the function names and calls are rewritten by Microsoft into the form:
  • LawType *GetLawType(void);


 IValidate::Name property

Service name.
physioValidator
IValidate
Name

C/C++ syntax
[get] HRESULT Name( BSTR *aBSTR);

Parameter description
[out, retval] BSTR *aBSTR

C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that an exception is thrown under these conditions if you are using SmartPointers.

Remarks
If you are using SmartPointers the function names and calls are rewritten by Microsoft into the form:
  • BSTR *GetName(void);


 IValidate::Quantity property

Quantity.
physioValidator
IValidate
Quantity

C/C++ syntax
[get] HRESULT Quantity( double *adouble);

Parameter description
[out, retval] double *adouble

C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that an exception is thrown under these conditions if you are using SmartPointers.

Remarks
If you are using SmartPointers the function names and calls are rewritten by Microsoft into the form:
  • double *GetQuantity(void);


 IValidate::RoleType property

Role type.
physioValidator
IValidate
RoleType

C/C++ syntax
[get] HRESULT RoleType( RoleType *aRoleType);

Parameter description
[out, retval] RoleType *aRoleType

C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that an exception is thrown under these conditions if you are using SmartPointers.

Remarks
If you are using SmartPointers the function names and calls are rewritten by Microsoft into the form:
  • RoleType *GetRoleType(void);


 IValidate::SessionNumber property

Session number.
physioValidator
IValidate
SessionNumber

C/C++ syntax
[get] HRESULT SessionNumber( long *along);

Parameter description
[out, retval] long *along

C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that an exception is thrown under these conditions if you are using SmartPointers.

Remarks
If you are using SmartPointers the function names and calls are rewritten by Microsoft into the form:
  • long *GetSessionNumber(void);


 IValidate::SettlementType property

Settlement type.
physioValidator
IValidate
SettlementType

C/C++ syntax
[get] HRESULT SettlementType( SettlementType *aSettlementType);

Parameter description
[out, retval] SettlementType *aSettlementType

C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that an exception is thrown under these conditions if you are using SmartPointers.

Remarks
If you are using SmartPointers the function names and calls are rewritten by Microsoft into the form:
  • SettlementType *GetSettlementType(void);


 IValidate::TP property

Tax points of the service.
physioValidator
IValidate
TP

C/C++ syntax
[get] HRESULT TP( double *adouble);

Parameter description
[out, retval] double *adouble

C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that an exception is thrown under these conditions if you are using SmartPointers.

Remarks
If you are using SmartPointers the function names and calls are rewritten by Microsoft into the form:
  • double *GetTP(void);


 IValidate::TPValue property

Tax point value of the service.
physioValidator
IValidate
TPValue

C/C++ syntax
[get] HRESULT TPValue( double *adouble);

Parameter description
[out, retval] double *adouble

C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that an exception is thrown under these conditions if you are using SmartPointers.

Remarks
If you are using SmartPointers the function names and calls are rewritten by Microsoft into the form:
  • double *GetTPValue(void);


all type definitions

 All builtin, composite and enumeration types

The following list shows all used types either basic builtin, composite or enumeration that are used in the public interface of the ATL COM module.
physioValidator
Type definitions

All used types 16 types
[enumeration] | AbortValidateType | [builtin] | BSTR
[enumeration] | CantonType | [builtin] | DATE
[builtin] | double | [builtin] | HRESULT
[builtin] | ISearch | [builtin] | IValidate
[enumeration] | LanguageType | [enumeration] | LawType
[builtin] | long | [enumeration] | PlaceType
[enumeration] | RoleType | [enumeration] | SettlementType
[builtin] | VARIANT_BOOL | [enumeration] | YesNoType


 AbortValidateType enumeration type

Enumerates the defined grounds for an aborted validation attempt.
physioValidator
Type definitions
AbortValidateType

Set of enumeration values 9 values
enDatabaseNotOpen | The database is not open.
enServiceNotFound | No service record found.
enWrongTP | Wrong tax point specified.
enWrongTPValue | Wrong tax point value specified.
enNoTPValueFound | The tax point value could not be determined.
enTreatmentDataChanged | Treatment input is not allowed to change.
enExclusionRestriction | Exclusion restriction not fulfilled.
enRoleRestriction | Role restriction not fulfilled.
enValidateFailed | The validation failed - incompatible database parameters - contact the support.


 BSTR type

A BSTR, known as basic string or binary string, is a pointer to a wide character string used by Automation data manipulation functions.
BSTRs are wide, double-byte (Unicode) strings on 32-bit Windows platforms.
physioValidator
Type definitions
BSTR


 CantonType enumeration type

Enumerates the defined canton categories.
physioValidator
Type definitions
CantonType

Set of enumeration values 31 values
enCantonUndefined | Undefined or unknown canton.
enAG | AG
enAI | AI
enAR | AR
enBE | BE
enBL | BL
enBS | BS
enFR | FR
enGE | GE
enGL | GL
enGR | GR
enJU | JU
enLU | LU
enNE | NE
enNW | NW
enOW | OW
enSG | SG
enSH | SH
enSO | SO
enSZ | SZ
enTG | TG
enTI | TI
enUR | UR
enVD | VD
enVS | VS
enZG | ZG
enZH | ZH
enGermany | Germany
enItaly | Italy
enFrance | France
enLiechtenstein | Liechtenstein


 DATE type

A value denoting a date and time was specified. Dates are represented as double-precision numbers, where midnight, January 1, 1900 is 2.0, January 2, 1900 is 3.0, and so on. The value is passed in date.
physioValidator
Type definitions
DATE


 double type

An 8-byte IEEE real value.
physioValidator
Type definitions
double


 HRESULT type

The HRESULT data type is a 32-bit value that is used to describe an error or warning.
physioValidator
Type definitions
HRESULT


 ISearch type

ISearch interface.
physioValidator
Type definitions
ISearch


 IValidate type

IValidate interface.
physioValidator
Type definitions
IValidate


 LanguageType enumeration type

Enumerates all supported languages.
physioValidator
Type definitions
LanguageType

Set of enumeration values 4 values
enGerman | German
enFrench | French.
enItalian | Italian
enEnglish | English


 LawType enumeration type

Enumerates the supported legal ruleset.
physioValidator
Type definitions
LawType

Set of enumeration values 5 values
enKVG | KVG
enUVG | UVG
enMVG | MVG
enIVG | IVG
enVVG | VVG


 long type

A 4-byte integer value.
physioValidator
Type definitions
long


 PlaceType enumeration type

Enumerates the defined principal location of the service provider e.g. the principal authority under which the service provider is acting.
physioValidator
Type definitions
PlaceType

Set of enumeration values 4 values
enPlaceUndefined | Undefined or unknown place.
enPlacePractice | Practice
enPlaceHospital | Hospital
enPlaceLab | Lab


 RoleType enumeration type

Enumerates the defined role categories.
physioValidator
Type definitions
RoleType

Set of enumeration values 12 values
enRoleUndefined | Undefined or unknown role.
enRolePhysician | Physician
enRolePhysiotherapist | Physiotherapist
enRoleChiropractor | Chiropractor
enRoleErgotherapist | Ergotherapist
enRoleNutritionist | Nutritionist
enRoleMidwife | Midwife
enRoleLogopedician | Logopedician
enRoleOrthopedician | Orthopedician
enRoleShoemaker | Shoemaker
enRoleDentist | Dentist
enRoleTechnician | Specifies the principle role of person acting as a technician. The exact meaning of technician depends on the applied tariff system. For instance, in the context of the lab tariff a technician means a laboratory technician where as in the context of a dental tariff it would map to a dental technician. Anyway, a technician is never a person acting as person in medical care (e.g. physician, nurse, physiotherapist, ...)


 SettlementType enumeration type

Enumerates the defined settlement categories.
physioValidator
Type definitions
SettlementType

Set of enumeration values 2 values
enSettlementElectronic | Electronic transmitting of the bill.
enSettlementPaper | Print on paper of the bill.


 VARIANT_BOOL type

A 16 bit Boolean (True/False) value was specified. A value of 0xFFFF (all bits 1) indicates True; a value of 0 (all bits 0) indicates False. No other values are valid.
physioValidator
Type definitions
VARIANT_BOOL


 YesNoType enumeration type

Boolean enumerator.
physioValidator
Type definitions
YesNoType

Set of enumeration values 2 values
enNo | No.
enYes | Yes.


General use of the physioValidator module/en

General use of the physioValidator ATL COM module

  • First create an instance of the physioValidator COM module.
  • Open the physio database with the Open method from the IPhysioValidator interface. Set the localization language (if it differs from the default setting of German) using the SetLanguage from the IPhysioValidator interface.
  • The following steps may then be performed, until the physioValidator module instance is released:
  • Let the user search for a code (see the Search functions from the ISearch interface).
  • Add the selected services to the AddService method from the IValidate interface.
  • Release the physioValidator COM module instance.


Notice about the "configuration parameters"/en

Notice about the
"configuration parameters" in the physioValidator!!

Please note:

  • The IPhysioValidator module provides methods like SetTreatment for setting treatment relevant parameters like the settlement type (electronic invoice or not).

    Currently the "settlement type" parameter is not relevant!
    Neither is this parameter used for validating/limiting the set of available services nor is the evaluated tax point value in any way a function of this parameter.

    However, the future might be different?
    Should that occur, there is no further need for a software company to change any of their code, as the parameter is already supplied to the validator module. Therefore we strongly urge you to use this feature.
  • The tax point values per canton for the KVG law used by the physician are not yet defined. For the moment they are set equal to the physiotherapist tax point value in order to have a functional module. As soon as the negotiations between the partners succeed the resulting set of values these will be integrated.
  • The methods SearchCode and SearchName have eDeactivateRoleFilter as a parameter. Since the filtering function of the role (physician, physio, hospital,...) upon the tariff is not yet defined, eDeactivateRoleFilter is internally set to true (that is no filter applied!!) independant of the value given as the argument! As a consequence the property UsableBy always returns a value signifying that the service is usable by all roles!

    In the future it might likely be that certain services are restricted to a certain role. Therefore be prepared for the intended functionality of eDeactivateRoleFilter and UsableBy!