 API browser of tarmedValidator100 COM module
Interface version: | 1.00
Interface date: | 30 Aug 2002

The tarmedValidator100 is an ATL COM module which provides methods to browse, search, and validate services from the included tariff catalogs TARMED 1.08BR and/or TARMED 1.09. |  | space
Interfaces |  | 6 interface
ICatalog | catalog functionality |
ISearch | Search and browse functionality of services over the included tariff catalogs |
ITarmedInput | Input of data |
ITarmedValidator | Main interface for the database handling and global parameter settings |
IUtility | Automatic generation of service records |
IValidate | Validation of service records according to the rules |
Types |  |
type definitions | List of all used builtin, composite and enumeration types |
Important documents about the usage and handling |  |
Document | General usage of the tarmedValidator100 COM module - an overview |
Document | What to do in a 64bit environment - is there a 64bit Sumex1 COM dll? |
Document | How to search for a code and find further related child codes |
Document | tarmedValidatorServer100: Introduction, overview and usage of the Restful Webservice Server |
01.12.03 - Patch | Documentation: how to set the TPV for law=KVG|VVG |
14.03.05 - Patch | Documentation: how to retrieve the group and/or block affiliation of a service |
24.06.05 - Patch | Documentation: how to retrieve the non-expandable minutes in a code expansion chain |
21.03.06 - Patch | Documentation: how to retrieve a possible gender relevance of a service |
17.01.08 - Patch | Documentation: how to filter inclusion services for law and/or gender relevance |
25.02.09 - Patch | Documentation: how to retrieve gender/group/block affiliation of additional services |
08.11.17 - Patch | Patches included to the tarmedValidator100 for Tarmed 1.09/1.08.2 |
23.03.18 - Patch | Documentation: how to set the validity barrier between Tarmed 1.08BR and Tarmed 1.09 UV/IV/MV |

© by sumex1.net - all rights reserved


  • tarmedValidator100
  • ICatalog

ICatalog interface |  | V1.00/30 Aug 2002
The ICatalog interface allows the retrieval of catalog information from the Tarmed database. This information is most commonly used for populating lists or combo boxes, from which a user will select Tarmed service codes and/or options. The selected catalog entry can then be used as input for other interfaces. All methods fill the pbStatus variable with VARIANT_TRUE, and return S_OK, if the information is successfully retrieved. A pbStatus value of VARIANT_FALSE and a return value of S_FALSE indicate that no more data is available. |  | space
space
Methods |  | 39 methods
GetAbortInfo | Get the abort information. |
GetAnaesthesiaCodeTypes | Method for collecting all anaesthesia code type data of a certain code in one call without the necessity to call iterator pair GetFirstAnaesthesiaCodeType / GetNextAnaesthesiaCodeType |
GetChapters | Method for collecting all chapter information of a certain code in one call without the necessity to call iterator pair GetFirstChapter / GetNextChapter |
GetFirstAnaesthesiaCodeType | Retrieves the first anaesthesia code type information. |
GetFirstAnaesthesiaRiskClass | Retrieves the first anaesthesia risk class information. |
GetFirstChapter | Retrieves the first chapter information |
GetFirstMechanicCode | Retrieves the first utility information |
GetFirstQualitativeDignity | Retrieves the first qualitative dignity information |
GetFirstQualitativeDignitySet | Retrieves the first qualitative dignity set information. |
GetFirstSection | Retrieves the first section information. |
GetFirstServiceBlock | Retrieves the first service block information. |
GetFirstServiceGroup | Retrieves the first service group information. |
GetFirstServiceObligationCode | Retrieves the first service obligation information. |
GetFirstServiceType | Retrieves the first service type information |
GetFirstTimeSpan | Retrieves the first time span information. |
GetFirstUnit | Retrieves the first measurement-unit information. |
GetMechanicCodes | Method for collecting all utility information (aka mechanic codes) of a certain code in one call without the necessity to call iterator pair GetFirstMechanicCode / GetNextMechanicCode |
GetNextAnaesthesiaCodeType | Retrieves the next anaesthesia code type information. |
GetNextAnaesthesiaRiskClass | Retrieves the next anaesthesia risk class information. |
GetNextChapter | Retrieves the next chapter information |
GetNextMechanicCode | Retrieves the next utility information |
GetNextQualitativeDignity | Retrieves the next qualitative dignity information |
GetNextQualitativeDignitySet | Retrieves the next qualitative dignity set information. |
GetNextSection | Retrieves the next section information. |
GetNextServiceBlock | Retrieves the next service block information. |
GetNextServiceGroup | Retrieves the next service group information. |
GetNextServiceObligationCode | Retrieves the next service obligation information. |
GetNextServiceType | Retrieves the next service type information |
GetNextTimeSpan | Retrieves the next time span information. |
GetNextUnit | Retrieves the first measurement-unit information. |
GetQualitativeDignities | Method for collecting all qualitative dignity set of a certain code in one call without the necessity to call iterator pair GetFirstQualitativeDignity / GetNextQualitativeDignity |
GetQualitativeDignitySets | Method for collecting all qualitative dignity sets of a certain code in one call without the necessity to call iterator pair GetFirstQualitativeDignitySet / GetNextQualitativeDignitySet |
GetSections | Method for collecting all section information of a certain code in one call without the necessity to call iterator pair GetFirstSection / GetNextSection |
GetServiceBlocks | Method for collecting all service block information of a certain code in one call without the necessity to call iterator pair GetFirstServiceBlock / GetNextServiceBlock |
GetServiceGroups | Method for collecting all service group information of a certain code in one call without the necessity to call iterator pair GetFirstServiceGroup / GetNextServiceGroup |
GetServiceObligationCodes | Method for collecting all service obligation information of a certain set code in one call without the necessity to call iterator pair GetFirstServiceObligationCode / GetNextServiceObligationCode |
GetServiceTypes | Method for collecting all service type information of a certain code in one call without the necessity to call iterator pair GetFirstServiceType / GetNextServiceType |
GetTimeSpans | Method for collecting all time span information of a certain code in one call without the necessity to call iterator pair GetFirstTimeSpan / GetNextTimeSpan |
GetUnits | Method for collecting all measurement-unit information of a certain code in one call without the necessity to call iterator pair GetFirstUnit / GetNextUnit |
space
Properties |  | 1 properties
[put] DestructCatalog | Destructs/invalidates this ICatalog interface instance |
space |


  • ICatalog
  • GetAbortInfo

ICatalog::GetAbortInfo method |  |  | space
Get the abort information. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ICatalog/GetAbortInfo
[JSON input data] | pICatalog: | longValue, //interface address
[JSON result data] | pbstrAbort: pbStatus: | "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetAbortInfo( | BSTR VARIANT_BOOL | *pbstrAbort, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrAbort | Abort information string. If the abort string is empty then there is no error condition - S_FALSE was set (e.g. in an iterator to signal end_of_data) |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ICatalog
  • GetAnaesthesiaCodeTypes

ICatalog::GetAnaesthesiaCodeTypes method |  |  | space
This method has a Restful Webservice representation only! Method for collecting all anaesthesia code type data of a certain code in one call without the necessity to call iterator pair GetFirstAnaesthesiaCodeType / GetNextAnaesthesiaCodeType. The services are returned as JSON array however large that search space might be. So this might be a memory and performance bottleneck. PATCH to request information if a given qualitative dignity qualifies as "FMH Specialist" dignity or not (cf. bstrCode argument). |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ICatalog/GetAnaesthesiaCodeTypes
[JSON input data] | pICatalog: eAnaesthesiaCode: | longValue, //interface address longValue
[JSON result array] | { peAnaesthesiaCode: pbstrName: pbStatus: | longValue, "utf8StringValue", booleanValue },
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Calling argument description |  |  |
[in] AnaesthesiaCodeType | eAnaesthesiaCode | Anaesthesia code type to search for. Use enTypeUnknown to search all records. |
[out] AnaesthesiaCodeType | *peAnaesthesiaCode | Anaesthesia code type. |
[out] BSTR | *pbstrName | Anaesthesia code type name. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ICatalog
  • GetChapters

ICatalog::GetChapters method |  |  | space
This method has a Restful Webservice representation only! Method for collecting all chapter information of a certain code in one call without the necessity to call iterator pair GetFirstChapter / GetNextChapter. The services are returned as JSON array however large that search space might be. So this might be a memory and performance bottleneck. PATCH to request information if a given qualitative dignity qualifies as "FMH Specialist" dignity or not (cf. bstrCode argument). PATCH: append "#INFO" to the bstrCode to request that chapter interpretations rather than chapter codes and names must be returned. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ICatalog/GetChapters
[JSON input data] | pICatalog: bstrCode: | longValue, //interface address "utf8StringValue"
[JSON result array] | { pbstrCode: pbstrName: pbStatus: | "utf8StringValue", "utf8StringValue", booleanValue },
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Calling argument description |  |  |
[in] BSTR | bstrCode | Chapter code to search for. Use asterisk symbol (*) to search all records. PATCH: bstrCode can be appended with the instruction "#INFO" to request chapter interpretations rather than chapter codes and names. |
[out] BSTR | *pbstrCode | Chapter code. PATCH: when chapter interpretations is requested, than pbstrCode holds the interpretation title. |
[out] BSTR | *pbstrName | Chapter name. PATCH: when chapter interpretations is requested, than pbstrName holds the interpretation text. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ICatalog
  • GetFirstAnaesthesiaCodeType

ICatalog::GetFirstAnaesthesiaCodeType method |  |  | space
Retrieves the first anaesthesia code type information. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ICatalog/GetFirstAnaesthesiaCodeType
[JSON input data] | pICatalog: eAnaesthesiaCode: | longValue, //interface address longValue
[JSON result data] | peAnaesthesiaCode: pbstrName: pbStatus: | longValue, "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetFirstAnaesthesiaCodeType( | AnaesthesiaCodeType AnaesthesiaCodeType BSTR VARIANT_BOOL | eAnaesthesiaCode, *peAnaesthesiaCode, *pbstrName, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] AnaesthesiaCodeType | eAnaesthesiaCode | Anaesthesia code type to search for. Use enTypeUnknown to search all records. |
[out] AnaesthesiaCodeType | *peAnaesthesiaCode | Anaesthesia code type. |
[out] BSTR | *pbstrName | Anaesthesia code type name. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ICatalog
  • GetFirstAnaesthesiaRiskClass

ICatalog::GetFirstAnaesthesiaRiskClass method |  |  | space
Retrieves the first anaesthesia risk class information. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ICatalog/GetFirstAnaesthesiaRiskClass
[JSON input data] | pICatalog: eCode: | longValue, //interface address longValue
[JSON result data] | peCode: pbstrName: pbStatus: | longValue, "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetFirstAnaesthesiaRiskClass( | AnaesthesiaRiskClassType AnaesthesiaRiskClassType BSTR VARIANT_BOOL | eCode, *peCode, *pbstrName, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] AnaesthesiaRiskClassType | eCode | Anaesthesia risk class code to search for. Use enRiskClassUnknown to search all records. |
[out] AnaesthesiaRiskClassType | *peCode | Anaesthesia risk class code. |
[out] BSTR | *pbstrName | Anaesthesia risk class name. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ICatalog
  • GetFirstChapter

ICatalog::GetFirstChapter method |  |  | space
Retrieves the first chapter information. PATCH: append "#INFO" to the bstrCode to request that chapter interpretations rather than chapter codes and names must be returned. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ICatalog/GetFirstChapter
[JSON input data] | pICatalog: bstrCode: | longValue, //interface address "utf8StringValue"
[JSON result data] | pbstrCode: pbstrName: pbStatus: | "utf8StringValue", "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetFirstChapter( | BSTR BSTR BSTR VARIANT_BOOL | bstrCode, *pbstrCode, *pbstrName, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrCode | Chapter code to search for. Use asterisk symbol (*) to search all records. PATCH: bstrCode can be appended with the instruction "#INFO" to request chapter interpretations rather than chapter codes and names. |
[out] BSTR | *pbstrCode | Chapter code. PATCH: when chapter interpretations is requested, than pbstrCode holds the interpretation title. |
[out] BSTR | *pbstrName | Chapter name. PATCH: when chapter interpretations is requested, than pbstrName holds the interpretation text. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ICatalog
  • GetFirstMechanicCode

ICatalog::GetFirstMechanicCode method |  |  | space
Retrieves the first utility information. All tarmed services have associated utility information specified with a so-called mechanic code. Depending on the mechanic code, different rules may apply for the service. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ICatalog/GetFirstMechanicCode
[JSON input data] | pICatalog: bstrCode: | longValue, //interface address "utf8StringValue"
[JSON result data] | pbstrCode: pbstrName: pbStatus: | "utf8StringValue", "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetFirstMechanicCode( | BSTR BSTR BSTR VARIANT_BOOL | bstrCode, *pbstrCode, *pbstrName, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrCode | Mechanic code to search for. Use asterisk symbol (*) to search all records. |
[out] BSTR | *pbstrCode | Mechanic code. |
[out] BSTR | *pbstrName | Name of mechanism. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ICatalog
  • GetFirstQualitativeDignity

ICatalog::GetFirstQualitativeDignity method | space
Retrieves the first qualitative dignity information.

PATCH to request information if a given qualitative dignity qualifies as "FMH Specialist" dignity or not (cf. bstrCode argument).
space
Restful webservice calling syntax
[POST] | /baseURL/ ICatalog/GetFirstQualitativeDignity
[JSON input data] pICatalog:
bstrCode: 		longValue, //interface address
"utf8StringValue"
[JSON result data] pbstrCode:
pbstrName:
peExclusive:
peQualitativeDignitySet:
pbStatus: 		"utf8StringValue",
"utf8StringValue",
longValue,
longValue,
booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
HRESULT GetFirstQualitativeDignity( BSTR
BSTR
BSTR
YesNoType
YesNoType
VARIANT_BOOL 		bstrCode,
*pbstrCode,
*pbstrName,
*peExclusive,
*peQualitativeDignitySet,
*pbStatus);
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[in] BSTR bstrCode Qualitative dignity code to search for.
Use asterisk symbol (*) to search for all dignities.

PATCH: bstrCode can be appended with the instruction "#FMH" to request the additional information about the "FMH Specialist" status in the pbstrCode variable.
[out] BSTR *pbstrCode Qualitative dignity code.

PATCH: when additional information about the "FMH Specialist" status is requested, than the qualitative dignity is returned hash separated with the additional information tag
  • #FMH0 == dignity is not a "FMH Specialist" dignity
  • #FMH1 == dignity is a "FMH Specialist" dignity
[out] BSTR | *pbstrName | Qualitative dignity name.
[out] YesNoType | *peExclusive | A value of enYes indicates that during a session where the physician specifies this qualitative dignity, he can only report services which have a matching qualitative dignity. No services with another qualitative dignity are allowed, even if the physician has the required qualitative dignity as well.
[out] YesNoType | *peQualitativeDignitySet | A value of enYes indicates that the qualitative dignity code represents a dignity set code (see GetFirstQualitativeDignitySet).
[out,retval] VARIANT_BOOL *pbStatus Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name).
In the later case check for possible errors with the GetAbortInfo method.
space


  • ICatalog
  • GetFirstQualitativeDignitySet

ICatalog::GetFirstQualitativeDignitySet method |  |  | space
Retrieves the first qualitative dignity set information. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ICatalog/GetFirstQualitativeDignitySet
[JSON input data] | pICatalog: bstrSetCode: | longValue, //interface address "utf8StringValue"
[JSON result data] | pbstrSetCode: pbstrCode: pbstrName: pbStatus: | "utf8StringValue", "utf8StringValue", "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetFirstQualitativeDignitySet( | BSTR BSTR BSTR BSTR VARIANT_BOOL | bstrSetCode, *pbstrSetCode, *pbstrCode, *pbstrName, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrSetCode | Qualitative dignity set code to search for. Use asterisk symbol (*) to search all records |
[out] BSTR | *pbstrSetCode | Qualitative dignity set code. |
[out] BSTR | *pbstrCode | Qualitative dignity code. |
[out] BSTR | *pbstrName | Qualitative dignity name. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ICatalog
  • GetFirstSection

ICatalog::GetFirstSection method |  |  | space
Retrieves the first section information. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ICatalog/GetFirstSection
[JSON input data] | pICatalog: bstrCode: eShowMandatoryOnly: | longValue, //interface address "utf8StringValue", longValue
[JSON result data] | pbstrCode: pbstrName: peMandatory: pbStatus: | "utf8StringValue", "utf8StringValue", longValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetFirstSection( | BSTR YesNoType BSTR BSTR YesNoType VARIANT_BOOL | bstrCode, eShowMandatoryOnly, *pbstrCode, *pbstrName, *peMandatory, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrCode | Section code to search for. Use asterisk symbol (*) to search all records. |
[in] YesNoType | eShowMandatoryOnly | Flag specifying whether to list only mandatory sections. |
[out] BSTR | *pbstrCode | Section code. |
[out] BSTR | *pbstrName | Section name. |
[out] YesNoType | *peMandatory | A value of enYes means that for this section an EAN number is required. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ICatalog
  • GetFirstServiceBlock

ICatalog::GetFirstServiceBlock method |  |  | space
Retrieves the first service block information. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ICatalog/GetFirstServiceBlock
[JSON input data] | pICatalog: bstrCode: | longValue, //interface address "utf8StringValue"
[JSON result data] | pbstrCode: pbstrName: pbStatus: | "utf8StringValue", "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetFirstServiceBlock( | BSTR BSTR BSTR VARIANT_BOOL | bstrCode, *pbstrCode, *pbstrName, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrCode | Service block code to search for. Use asterisk symbol (*) to search all records. |
[out] BSTR | *pbstrCode | Service block code. |
[out] BSTR | *pbstrName | Service block name. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ICatalog
  • GetFirstServiceGroup

ICatalog::GetFirstServiceGroup method |  |  | space
Retrieves the first service group information. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ICatalog/GetFirstServiceGroup
[JSON input data] | pICatalog: bstrCode: | longValue, //interface address "utf8StringValue"
[JSON result data] | pbstrCode: pbstrName: pbStatus: | "utf8StringValue", "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetFirstServiceGroup( | BSTR BSTR BSTR VARIANT_BOOL | bstrCode, *pbstrCode, *pbstrName, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrCode | Service group code to search for. Use asterisk symbol (*) to search all records. |
[out] BSTR | *pbstrCode | Service group code. |
[out] BSTR | *pbstrName | Service group name. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ICatalog
  • GetFirstServiceObligationCode

ICatalog::GetFirstServiceObligationCode method |  |  | space
Retrieves the first service obligation information. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ICatalog/GetFirstServiceObligationCode
[JSON input data] | pICatalog: bstrCode: | longValue, //interface address "utf8StringValue"
[JSON result data] | pbstrCode: pbstrName: pbStatus: | "utf8StringValue", "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetFirstServiceObligationCode( | BSTR BSTR BSTR VARIANT_BOOL | bstrCode, *pbstrCode, *pbstrName, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrCode | Service obligation code to search for. Use asterisk symbol (*) to search all records. |
[out] BSTR | *pbstrCode | Service obligation code. |
[out] BSTR | *pbstrName | Service obligation name. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ICatalog
  • GetFirstServiceType

ICatalog::GetFirstServiceType method | space
Retrieves the first service type information.

New features:
  • as of 1.4.2007 the value 'R' denotes services that require a reference code when applied as a service record.
    Formerly the value of these new 'R' services have been 'H'!
  • as of 1.1.2007 the value 'F' denotes services that are in Swiss francs instead of tax points (as of 1.1.2007 the newly included IAP services ("Belegarzt Tarif") of chapter 50 are of this type). Therefore, a service with Type='F' must be supplied with a tax point value of 1.0!
space
Restful webservice calling syntax
[POST] | /baseURL/ ICatalog/GetFirstServiceType
[JSON input data] pICatalog:
bstrCode: 		longValue, //interface address
"utf8StringValue"
[JSON result data] pbstrCode:
pbstrName:
pbStatus: 		"utf8StringValue",
"utf8StringValue",
booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
HRESULT GetFirstServiceType( BSTR
BSTR
BSTR
VARIANT_BOOL 		bstrCode,
*pbstrCode,
*pbstrName,
*pbStatus);
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[in] BSTR | bstrCode | Service type code to search for. Use asterisk symbol (*) to search all records.
[out] BSTR | *pbstrCode | Service type code.
[out] BSTR | *pbstrName | Service type name.
[out,retval] VARIANT_BOOL *pbStatus Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name).
In the later case check for possible errors with the GetAbortInfo method.
space


  • ICatalog
  • GetFirstTimeSpan

ICatalog::GetFirstTimeSpan method |  |  | space
Retrieves the first time span information. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ICatalog/GetFirstTimeSpan
[JSON input data] | pICatalog: bstrCode: | longValue, //interface address "utf8StringValue"
[JSON result data] | pbstrCode: pbstrName: pbStatus: | "utf8StringValue", "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetFirstTimeSpan( | BSTR BSTR BSTR VARIANT_BOOL | bstrCode, *pbstrCode, *pbstrName, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrCode | Time span code to search for. Use asterisk symbol (*) to search all records. |
[out] BSTR | *pbstrCode | Time span code. |
[out] BSTR | *pbstrName | Time span name. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ICatalog
  • GetFirstUnit

ICatalog::GetFirstUnit method |  |  | space
Retrieves the first measurement-unit information. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ICatalog/GetFirstUnit
[JSON input data] | pICatalog: bstrCode: | longValue, //interface address "utf8StringValue"
[JSON result data] | pbstrCode: pbstrName: pbStatus: | "utf8StringValue", "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetFirstUnit( | BSTR BSTR BSTR VARIANT_BOOL | bstrCode, *pbstrCode, *pbstrName, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrCode | Unit code to search for. Use asterisk symbol (*) to search all records. |
[out] BSTR | *pbstrCode | Unit code. |
[out] BSTR | *pbstrName | Unit name (Minutes, hours, pieces etc.). |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ICatalog
  • GetMechanicCodes

ICatalog::GetMechanicCodes method |  |  | space
This method has a Restful Webservice representation only! Method for collecting all utility information (aka mechanic codes) of a certain code in one call without the necessity to call iterator pair GetFirstMechanicCode / GetNextMechanicCode. The services are returned as JSON array however large that search space might be. So this might be a memory and performance bottleneck. All Tarmed services have associated utility information specified with a so-called mechanic code. Depending on the mechanic code, different rules may apply for the service. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ICatalog/GetMechanicCodes
[JSON input data] | pICatalog: bstrCode: | longValue, //interface address "utf8StringValue"
[JSON result array] | { pbstrCode: pbstrName: pbStatus: | "utf8StringValue", "utf8StringValue", booleanValue },
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Calling argument description |  |  |
[in] BSTR | bstrCode | Mechanic code to search for. Use asterisk symbol (*) to search all records. |
[out] BSTR | *pbstrCode | Mechanic code. |
[out] BSTR | *pbstrName | Name of mechanism. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ICatalog
  • GetNextAnaesthesiaCodeType

ICatalog::GetNextAnaesthesiaCodeType method |  |  | space
Retrieves the next anaesthesia code type information. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ICatalog/GetNextAnaesthesiaCodeType
[JSON input data] | pICatalog: | longValue, //interface address
[JSON result data] | peAnaesthesiaCode: pbstrName: pbStatus: | longValue, "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetNextAnaesthesiaCodeType( | AnaesthesiaCodeType BSTR VARIANT_BOOL | *peAnaesthesiaCode, *pbstrName, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] AnaesthesiaCodeType | *peAnaesthesiaCode | Anaesthesia code type. |
[out] BSTR | *pbstrName | Anaesthesia code type name. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ICatalog
  • GetNextAnaesthesiaRiskClass

ICatalog::GetNextAnaesthesiaRiskClass method |  |  | space
Retrieves the next anaesthesia risk class information. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ICatalog/GetNextAnaesthesiaRiskClass
[JSON input data] | pICatalog: | longValue, //interface address
[JSON result data] | peCode: pbstrName: pbStatus: | longValue, "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetNextAnaesthesiaRiskClass( | AnaesthesiaRiskClassType BSTR VARIANT_BOOL | *peCode, *pbstrName, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] AnaesthesiaRiskClassType | *peCode | Anaesthesia risk class code. |
[out] BSTR | *pbstrName | Anaesthesia risk class name. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ICatalog
  • GetNextChapter

ICatalog::GetNextChapter method |  |  | space
Retrieves the next chapter information. PATCH to request that chapter interpretations rather than chapter codes and names must be returned, call GetFirstChapter("aCode#INFO",...) in the first place. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ICatalog/GetNextChapter
[JSON input data] | pICatalog: | longValue, //interface address
[JSON result data] | pbstrCode: pbstrName: pbStatus: | "utf8StringValue", "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetNextChapter( | BSTR BSTR VARIANT_BOOL | *pbstrCode, *pbstrName, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrCode | Chapter code. PATCH: when chapter interpretations is requested, than pbstrCode holds the interpretation title. |
[out] BSTR | *pbstrName | Chapter name. PATCH: when chapter interpretations is requested, than pbstrName holds the interpretation text. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ICatalog
  • GetNextMechanicCode

ICatalog::GetNextMechanicCode method |  |  | space
Retrieves the next utility information. All tarmed services have associated utility information specified with a so-called mechanic code. Depending on the mechanic code, different rules may apply for the service. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ICatalog/GetNextMechanicCode
[JSON input data] | pICatalog: | longValue, //interface address
[JSON result data] | pbstrCode: pbstrName: pbStatus: | "utf8StringValue", "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetNextMechanicCode( | BSTR BSTR VARIANT_BOOL | *pbstrCode, *pbstrName, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrCode | Mechanic code. |
[out] BSTR | *pbstrName | Name of mechanism. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ICatalog
  • GetNextQualitativeDignity

ICatalog::GetNextQualitativeDignity method | space
Retrieves the next qualitative dignity information.

PATCH to request information if a given qualitative dignity qualifies as "FMH Specialist" dignity or not, call GetFirstQualitativeDignity("aCode#FMH",...) in the first place.
space
Restful webservice calling syntax
[POST] | /baseURL/ ICatalog/GetNextQualitativeDignity
[JSON input data] pICatalog: longValue, //interface address
[JSON result data] pbstrCode:
pbstrName:
peExclusive:
peQualitativeDignitySet:
pbStatus: 		"utf8StringValue",
"utf8StringValue",
longValue,
longValue,
booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
HRESULT GetNextQualitativeDignity( BSTR
BSTR
YesNoType
YesNoType
VARIANT_BOOL 		*pbstrCode,
*pbstrName,
*peExclusive,
*peQualitativeDignitySet,
*pbStatus);
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out] BSTR *pbstrCode Qualitative dignity code.

PATCH: when additional information about the "FMH Specialist" status is requested, than the qualitative dignity is returned hash separated with the additional information tag
  • #FMH0 == dignity is not a "FMH Specialist" dignity
  • #FMH1 == dignity is a "FMH Specialist" dignity
[out] BSTR | *pbstrName | Qualitative dignity name.
[out] YesNoType | *peExclusive | A value of enYes indicates that during a session where the physician specifies this qualitative dignity, he can only report services which have a matching qualitative dignity. No services with another qualitative dignity are allowed, even if the physician has the required qualitative dignity as well.
[out] YesNoType | *peQualitativeDignitySet | A value of enYes indicates that the qualitative dignity code represents a dignity set code (see GetFirstQualitativeDignitySet).
[out,retval] VARIANT_BOOL *pbStatus Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name).
In the later case check for possible errors with the GetAbortInfo method.
space


  • ICatalog
  • GetNextQualitativeDignitySet

ICatalog::GetNextQualitativeDignitySet method |  |  | space
Retrieves the next qualitative dignity set information. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ICatalog/GetNextQualitativeDignitySet
[JSON input data] | pICatalog: | longValue, //interface address
[JSON result data] | pbstrSetCode: pbstrCode: pbstrName: pbStatus: | "utf8StringValue", "utf8StringValue", "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetNextQualitativeDignitySet( | BSTR BSTR BSTR VARIANT_BOOL | *pbstrSetCode, *pbstrCode, *pbstrName, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrSetCode | Qualitative dignity set code. |
[out] BSTR | *pbstrCode | Qualitative dignity code. |
[out] BSTR | *pbstrName | Qualitative dignity name. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ICatalog
  • GetNextSection

ICatalog::GetNextSection method |  |  | space
Retrieves the next section information. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ICatalog/GetNextSection
[JSON input data] | pICatalog: | longValue, //interface address
[JSON result data] | pbstrCode: pbstrName: peMandatory: pbStatus: | "utf8StringValue", "utf8StringValue", longValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetNextSection( | BSTR BSTR YesNoType VARIANT_BOOL | *pbstrCode, *pbstrName, *peMandatory, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrCode | Section code. |
[out] BSTR | *pbstrName | Section name. |
[out] YesNoType | *peMandatory | A value of enYes means that for this section an EAN number is required. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ICatalog
  • GetNextServiceBlock

ICatalog::GetNextServiceBlock method |  |  | space
Retrieves the next service block information. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ICatalog/GetNextServiceBlock
[JSON input data] | pICatalog: | longValue, //interface address
[JSON result data] | pbstrCode: pbstrName: pbStatus: | "utf8StringValue", "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetNextServiceBlock( | BSTR BSTR VARIANT_BOOL | *pbstrCode, *pbstrName, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrCode | Service block code. |
[out] BSTR | *pbstrName | Service block name. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ICatalog
  • GetNextServiceGroup

ICatalog::GetNextServiceGroup method |  |  | space
Retrieves the next service group information. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ICatalog/GetNextServiceGroup
[JSON input data] | pICatalog: | longValue, //interface address
[JSON result data] | pbstrCode: pbstrName: pbStatus: | "utf8StringValue", "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetNextServiceGroup( | BSTR BSTR VARIANT_BOOL | *pbstrCode, *pbstrName, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrCode | Service group code. |
[out] BSTR | *pbstrName | Service group name. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ICatalog
  • GetNextServiceObligationCode

ICatalog::GetNextServiceObligationCode method |  |  | space
Retrieves the next service obligation information. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ICatalog/GetNextServiceObligationCode
[JSON input data] | pICatalog: | longValue, //interface address
[JSON result data] | pbstrCode: pbstrName: pbStatus: | "utf8StringValue", "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetNextServiceObligationCode( | BSTR BSTR VARIANT_BOOL | *pbstrCode, *pbstrName, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrCode | Service obligation code. |
[out] BSTR | *pbstrName | Service obligation name. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ICatalog
  • GetNextServiceType

ICatalog::GetNextServiceType method | space
Retrieves the next service type information.

New features:
  • as of 1.4.2007 the value 'R' denotes services that require a reference code when applied as a service record.
    Formerly the value of these new 'R' services have been 'H'!
  • as of 1.1.2007 the value 'F' denotes services that are in Swiss francs instead of tax points (as of 1.1.2007 the newly included IAP services ("Belegarzt Tarif") of chapter 50 are of this type). Therefore, a service with Type='F' must be supplied with a tax point value of 1.0!
space
Restful webservice calling syntax
[POST] | /baseURL/ ICatalog/GetNextServiceType
[JSON input data] pICatalog: longValue, //interface address
[JSON result data] pbstrCode:
pbstrName:
pbStatus: 		"utf8StringValue",
"utf8StringValue",
booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
HRESULT GetNextServiceType( BSTR
BSTR
VARIANT_BOOL 		*pbstrCode,
*pbstrName,
*pbStatus);
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out] BSTR | *pbstrCode | Service type code.
[out] BSTR | *pbstrName | Service type name.
[out,retval] VARIANT_BOOL *pbStatus Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name).
In the later case check for possible errors with the GetAbortInfo method.
space


  • ICatalog
  • GetNextTimeSpan

ICatalog::GetNextTimeSpan method |  |  | space
Retrieves the next time span information. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ICatalog/GetNextTimeSpan
[JSON input data] | pICatalog: | longValue, //interface address
[JSON result data] | pbstrCode: pbstrName: pbStatus: | "utf8StringValue", "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetNextTimeSpan( | BSTR BSTR VARIANT_BOOL | *pbstrCode, *pbstrName, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrCode | Time span code. |
[out] BSTR | *pbstrName | Time span name. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ICatalog
  • GetNextUnit

ICatalog::GetNextUnit method |  |  | space
Retrieves the first measurement-unit information. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ICatalog/GetNextUnit
[JSON input data] | pICatalog: | longValue, //interface address
[JSON result data] | pbstrCode: pbstrName: pbStatus: | "utf8StringValue", "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetNextUnit( | BSTR BSTR VARIANT_BOOL | *pbstrCode, *pbstrName, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrCode | Unit code. |
[out] BSTR | *pbstrName | Unit name (Minutes, hours, pieces etc.). |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ICatalog
  • GetQualitativeDignities

ICatalog::GetQualitativeDignities method | space
This method has a Restful Webservice representation only!
Method for collecting all qualitative dignity set of a certain code in one call without the necessity to call iterator pair GetFirstQualitativeDignity / GetNextQualitativeDignity.

The services are returned as JSON array however large that search space might be. So this might be a memory and performance bottleneck.

PATCH to request information if a given qualitative dignity qualifies as "FMH Specialist" dignity or not (cf. bstrCode argument).
space
Restful webservice calling syntax
[POST] | /baseURL/ ICatalog/GetQualitativeDignities
[JSON input data] pICatalog:
bstrCode: 		longValue, //interface address
"utf8StringValue"
[JSON result array] { pbstrCode:
pbstrName:
peExclusive:
peQualitativeDignitySet:
pbStatus: 		"utf8StringValue",
"utf8StringValue",
longValue,
longValue,
booleanValue
},
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
Calling argument description
[in] BSTR bstrCode Qualitative dignity code to search for.
Use asterisk symbol (*) to search for all dignities.

PATCH: bstrCode can be appended with the instruction "#FMH" to request the additional information about the "FMH Specialist" status in the pbstrCode variable.
[out] BSTR *pbstrCode Qualitative dignity code.

PATCH: when additional information about the "FMH Specialist" status is requested, than the qualitative dignity is returned hash separated with the additional information tag
  • #FMH0 == dignity is not a "FMH Specialist" dignity
  • #FMH1 == dignity is a "FMH Specialist" dignity
[out] BSTR | *pbstrName | Qualitative dignity name.
[out] YesNoType | *peExclusive | A value of enYes indicates that during a session where the physician specifies this qualitative dignity, he can only report services which have a matching qualitative dignity. No services with another qualitative dignity are allowed, even if the physician has the required qualitative dignity as well.
[out] YesNoType | *peQualitativeDignitySet | A value of enYes indicates that the qualitative dignity code represents a dignity set code (see GetFirstQualitativeDignitySet).
[out,retval] VARIANT_BOOL *pbStatus Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name).
In the later case check for possible errors with the GetAbortInfo method.
space


  • ICatalog
  • GetQualitativeDignitySets

ICatalog::GetQualitativeDignitySets method |  |  | space
This method has a Restful Webservice representation only! Method for collecting all qualitative dignity sets of a certain code in one call without the necessity to call iterator pair GetFirstQualitativeDignitySet / GetNextQualitativeDignitySet. The services are returned as JSON array however large that search space might be. So this might be a memory and performance bottleneck. PATCH to request information if a given qualitative dignity qualifies as "FMH Specialist" dignity or not (cf. bstrCode argument). |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ICatalog/GetQualitativeDignitySets
[JSON input data] | pICatalog: bstrSetCode: | longValue, //interface address "utf8StringValue"
[JSON result array] | { pbstrSetCode: pbstrCode: pbstrName: pbStatus: | "utf8StringValue", "utf8StringValue", "utf8StringValue", booleanValue },
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Calling argument description |  |  |
[in] BSTR | bstrSetCode | Qualitative dignity set code to search for. Use asterisk symbol (*) to search all records |
[out] BSTR | *pbstrSetCode | Qualitative dignity set code. |
[out] BSTR | *pbstrCode | Qualitative dignity code. |
[out] BSTR | *pbstrName | Qualitative dignity name. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ICatalog
  • GetSections

ICatalog::GetSections method |  |  | space
This method has a Restful Webservice representation only! Method for collecting all section information of a certain code in one call without the necessity to call iterator pair GetFirstSection / GetNextSection. The services are returned as JSON array however large that search space might be. So this might be a memory and performance bottleneck. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ICatalog/GetSections
[JSON input data] | pICatalog: bstrCode: eShowMandatoryOnly: | longValue, //interface address "utf8StringValue", longValue
[JSON result array] | { pbstrCode: pbstrName: peMandatory: pbStatus: | "utf8StringValue", "utf8StringValue", longValue, booleanValue },
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Calling argument description |  |  |
[in] BSTR | bstrCode | Section code to search for. Use asterisk symbol (*) to search all records. |
[in] YesNoType | eShowMandatoryOnly | Flag specifying whether to list only mandatory sections. |
[out] BSTR | *pbstrCode | Section code. |
[out] BSTR | *pbstrName | Section name. |
[out] YesNoType | *peMandatory | A value of enYes means that for this section an EAN number is required. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ICatalog
  • GetServiceBlocks

ICatalog::GetServiceBlocks method |  |  | space
This method has a Restful Webservice representation only! Method for collecting all service block information of a certain code in one call without the necessity to call iterator pair GetFirstServiceBlock / GetNextServiceBlock. The services are returned as JSON array however large that search space might be. So this might be a memory and performance bottleneck. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ICatalog/GetServiceBlocks
[JSON input data] | pICatalog: bstrCode: | longValue, //interface address "utf8StringValue"
[JSON result array] | { pbstrCode: pbstrName: pbStatus: | "utf8StringValue", "utf8StringValue", booleanValue },
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Calling argument description |  |  |
[in] BSTR | bstrCode | Service block code to search for. Use asterisk symbol (*) to search all records. |
[out] BSTR | *pbstrCode | Service block code. |
[out] BSTR | *pbstrName | Service block name. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ICatalog
  • GetServiceGroups

ICatalog::GetServiceGroups method |  |  | space
This method has a Restful Webservice representation only! Method for collecting all service group information of a certain code in one call without the necessity to call iterator pair GetFirstServiceGroup / GetNextServiceGroup. The services are returned as JSON array however large that search space might be. So this might be a memory and performance bottleneck. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ICatalog/GetServiceGroups
[JSON input data] | pICatalog: bstrCode: | longValue, //interface address "utf8StringValue"
[JSON result array] | { pbstrCode: pbstrName: pbStatus: | "utf8StringValue", "utf8StringValue", booleanValue },
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Calling argument description |  |  |
[in] BSTR | bstrCode | Service group code to search for. Use asterisk symbol (*) to search all records. |
[out] BSTR | *pbstrCode | Service group code. |
[out] BSTR | *pbstrName | Service group name. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ICatalog
  • GetServiceObligationCodes

ICatalog::GetServiceObligationCodes method |  |  | space
This method has a Restful Webservice representation only! Method for collecting all service obligation information of a certain set code in one call without the necessity to call iterator pair GetFirstServiceObligationCode / GetNextServiceObligationCode. The services are returned as JSON array however large that search space might be. So this might be a memory and performance bottleneck. PATCH to request information if a given qualitative dignity qualifies as "FMH Specialist" dignity or not (cf. bstrCode argument). |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ICatalog/GetServiceObligationCodes
[JSON input data] | pICatalog: bstrCode: | longValue, //interface address "utf8StringValue"
[JSON result array] | { pbstrCode: pbstrName: pbStatus: | "utf8StringValue", "utf8StringValue", booleanValue },
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Calling argument description |  |  |
[in] BSTR | bstrCode | Service obligation code to search for. Use asterisk symbol (*) to search all records. |
[out] BSTR | *pbstrCode | Service obligation code. |
[out] BSTR | *pbstrName | Service obligation name. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ICatalog
  • GetServiceTypes

ICatalog::GetServiceTypes method | space
This method has a Restful Webservice representation only!
Method for collecting all service type information of a certain code in one call without the necessity to call iterator pair GetFirstServiceType / GetNextServiceType.

The services are returned as JSON array however large that search space might be. So this might be a memory and performance bottleneck.

PATCH to request information if a given qualitative dignity qualifies as "FMH Specialist" dignity or not (cf. bstrCode argument).

New features:
  • as of 1.4.2007 the value 'R' denotes services that require a reference code when applied as a service record.
    Formerly the value of these new 'R' services have been 'H'!
  • as of 1.1.2007 the value 'F' denotes services that are in Swiss francs instead of tax points (as of 1.1.2007 the newly included IAP services ("Belegarzt Tarif") of chapter 50 are of this type). Therefore, a service with Type='F' must be supplied with a tax point value of 1.0!
space
Restful webservice calling syntax
[POST] | /baseURL/ ICatalog/GetServiceTypes
[JSON input data] pICatalog:
bstrCode: 		longValue, //interface address
"utf8StringValue"
[JSON result array] { pbstrCode:
pbstrName:
pbStatus: 		"utf8StringValue",
"utf8StringValue",
booleanValue
},
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
Calling argument description
[in] BSTR | bstrCode | Service type code to search for. Use asterisk symbol (*) to search all records.
[out] BSTR | *pbstrCode | Service type code.
[out] BSTR | *pbstrName | Service type name.
[out,retval] VARIANT_BOOL *pbStatus Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name).
In the later case check for possible errors with the GetAbortInfo method.
space


  • ICatalog
  • GetTimeSpans

ICatalog::GetTimeSpans method |  |  | space
This method has a Restful Webservice representation only! Method for collecting all time span information of a certain code in one call without the necessity to call iterator pair GetFirstTimeSpan / GetNextTimeSpan. The services are returned as JSON array however large that search space might be. So this might be a memory and performance bottleneck. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ICatalog/GetTimeSpans
[JSON input data] | pICatalog: bstrCode: | longValue, //interface address "utf8StringValue"
[JSON result array] | { pbstrCode: pbstrName: pbStatus: | "utf8StringValue", "utf8StringValue", booleanValue },
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Calling argument description |  |  |
[in] BSTR | bstrCode | Time span code to search for. Use asterisk symbol (*) to search all records. |
[out] BSTR | *pbstrCode | Time span code. |
[out] BSTR | *pbstrName | Time span name. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ICatalog
  • GetUnits

ICatalog::GetUnits method |  |  | space
This method has a Restful Webservice representation only! Method for collecting all measurement-unit information of a certain code in one call without the necessity to call iterator pair GetFirstUnit / GetNextUnit. The services are returned as JSON array however large that search space might be. So this might be a memory and performance bottleneck. PATCH to request information if a given qualitative dignity qualifies as "FMH Specialist" dignity or not (cf. bstrCode argument). |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ICatalog/GetUnits
[JSON input data] | pICatalog: bstrCode: | longValue, //interface address "utf8StringValue"
[JSON result array] | { pbstrCode: pbstrName: pbStatus: | "utf8StringValue", "utf8StringValue", booleanValue },
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Calling argument description |  |  |
[in] BSTR | bstrCode | Unit code to search for. Use asterisk symbol (*) to search all records. |
[out] BSTR | *pbstrCode | Unit code. |
[out] BSTR | *pbstrName | Unit name (Minutes, hours, pieces etc.). |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ICatalog
  • DestructCatalog

ICatalog::DestructCatalog property |  |  | space
This property has a Restful Webservice representation only! Destructs/invalidates this ICatalog interface instance. The counterpart property to generate an ICatalog interface instance is ITarmedValidator::GetCreateCatalog. |  |  |
space
Restful webservice calling syntax |  |  |
[PUT] | /baseURL/ ICatalog/PutDestructCatalog
[JSON input data] | pICatalog: eDestructCatalog: | longValue, //interface address longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Remarks |  |  |
This property has a Restful Webservice representation only! |  |  |
space |


  • ISearch

ISearch interface | V1.00/30 Aug 2002
The ISearch interface allows browsing of and retrieval of detailed information from the Tarmed database. Searches can be performed by code or by name. The search terms may be specified in full, or may include wildcards. After a successful search, all of the available information directly related to the search term is made available through the interface"s properties. Inclusions, Descendants and allowed Combinations for a given code can also be retrieved.

Every method which starts with the name Search (for example SearchName255) produces as a result a selection list, composed of zero or more service records. The total number of records in the list can be retrieved using the method GetRecordCount. The record pointer is initially positioned at the first entry of the selection list. The available information related to the current record is made available through the interface"s properties. The methods MoveFirst, MoveLast, MoveNext, MovePrevious, PutAbsolutePosition, and GetAbsolutePosition are used to reposition the record pointer.

space
space
Methods | 38 methods
CanExpand | If this method returns true, the base service can be expanded to further service records (see Expand method from the IUtility interface).
CanHaveAdditionalServices | Many codes represent base services with which additional services may be provided, such as OP utilization
CanHaveAnaesthesiaServices | If this method returns true, anaesthesia services may be provided (see Anaesthesia method from the IUtility ).
FindCombination | This method finds the first combination service for a base service.
FindCombinations | Method for collecting all combination services of a base service in one call without the necessity to call iterator pair FindCombination / FindNextCombination
FindDescendant | Method to find any services that are descendants of a base service using a recursive-decent approach
FindDescendants | Method for collecting all services that are descendants of a base service in one call without the necessity to call iterator pair FindDescendant / FindNextDescendant
FindInclusion | This method finds the first inclusion service for a base service
FindInclusions | Method for collecting all inclusion services of a base service in one call without the necessity to call iterator pair FindInclusion / FindNextInclusion
FindNextCombination | This method finds the next combination service for a base service.
FindNextDescendant | Method to find any services that are descendants of a base service using a recursive-decent approach
FindNextInclusion | This method finds the next inclusion service for a base service.
GetAbortInfo | Get the abort information.
GetAbsolutePosition | Gets the current absolute position of the record pointer in the selection list
GetAgeRestriction | This method retrieves a possible age restriction interval of the service
GetFirstQualitativeDignity | Retrieves the first qualitative dignity information.
GetFirstQuantityMultiSessionRestriction | This method retrieves the first multi session quantity restriction for the service
GetMedicalRoleRestriction | This method retrieves the medical role restriction for the service
GetNextQualitativeDignity | Retrieves the next qualitative dignity information.
GetNextQuantityMultiSessionRestriction | This method retrieves the next multi session quantity restriction for the service.
GetQualitativeDignities | Method for collecting all qualitative dignity data of a base service in one call without the necessity to call iterator pair GetFirstQualitativeDignity / GetNextQualitativeDignity
GetQuantityMultiSessionRestrictions | Method for collecting all multi session quantity restrictions of a base service in one call without the necessity to call iterator pair GetFirstQuantityMultiSessionRestriction / GetNextQuantityMultiSessionRestriction
GetRecordCount | Gets the number of service records in the selection list.
GetServices | Method for collecting all service records junk wise of the resulting search space in one call without the necessity to call the record positioning methods and the appropriate properties of this interface
MoveFirst | Moves the record pointer to the first record in the selection list and makes that record the current service record
MoveLast | Moves to the last record in the selection list and makes that record the current service record
MoveNext | Moves to the next record in the selection list and makes that record the current service record
MovePrevious | Moves to the previous record in the selection list object and makes that record the current service record
PutAbsolutePosition | Positions the record pointer at the specified absolute position in the selection list
SearchAdditionalService | This method searches for additional services which may be provided for a base service
SearchChapter | This method searches for services which belong to the base chapter.
SearchCode | This method searches for services by code
SearchName255 | This method searches for services by the full service name.
SearchName35 | This method searches for services by the service short name.
SearchPopular | This method searches for services by popular name.
SearchServiceBlock | This method searches for services which belong to the base service block.
SearchServiceGroup | This method searches for services which belong to the base service group.
SearchSlave | This method searches the slave services for a base service.
space
Properties | 36 properties
[get] AdditionalServiceReferenceCode | Gets a reference code from a service record set obtained by SearchAdditionalService.
[get] AnaesthesiaMin | The time of an anaesthesia in minutes (including everything).
[get] AnaesthesiaRiskClass | Maximal anaesthesia risk class code (see AnaesthesiaRiskClassType enumeration for possible values, an empty value indicates that the sevice does normally not need anaesthesia).
[get] ChangeMin | Minutes in the context of change time (see the Tarmed documentation for details).
[get] Chapter | Chapter code.
[get] Code | Service code.
[put] DestructSearch | Destructs/invalidates this ISearch interface instance
[get/put] DignityFilter | Set/Get the dignity filter as specified in the ITarmedInput inteface for the responible physician.
[get] FindingsMin | Minutes in the context of making findings (see the Tarmed documentation for details).
[get] InternalFactor_MT | Scaling factor for the medical part.
[get] InternalFactor_TT | Scaling factor for the technical part.
[get] KVGObligationCode | KVG obligation code (see ICatalog interface ).
[get] MasterCode | The parent code of the service code, if the service code is a slave
[get] MechanicCode Mechanic code
[get] MedicalInfo | Medical information for the service (BLOB field).
[get] Name255 | Full service name.
[get] Name35 | Short service name.
[get] NamePopular | Popular name of the service.
[get] NumAssistants | Number of assistants needed for performing the service.
[get] PlaceMin | Minutes in the context of room or location utilization (see the Tarmed documentation for details)
[get] PrePostServiceMin | The time needed before and after the service expressed in minutes.
[get] Section | Section code (see ICatalog interface ).
[get] ServiceMin | The medical part of the service expressed in minutes.
[get] ServiceType | Service type, see the ICatalog interface for a description of the meaning of this value
[get] SexRequired | Sex information is required for the service.
[get] SideRequired | Side information is required for the service.
[get] TechnicalInfo | Technical information for the service (BLOB field).
[get] TP_Assistant | Tax points for the assistant part of the service.
[get] TP_MT | Tax points for the medical part of the service.
[get] TP_TT | Tax points for the technical part.
[get] TreatmentType | Treatment type (see TreatmentType enumeration for possible values, an empty value indicates that the treatment type does not matter).
[get] Unit | Unit name (base unit).
[get] UnitCode | Unit code (see Unit or ICatalog interface).
[get] UnitQuantity | The quantity of base units which are included in the service.
[get] ValidFrom | Get the validity start date of the current service.
[get] ValidTo | Get the validity end date of the current service.
space


  • ISearch
  • CanExpand

ISearch::CanExpand method |  |  | space
If this method returns true, the base service can be expanded to further service records (see Expand method from the IUtility interface). |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearch/CanExpand
[JSON input data] | pISearch: | longValue, //interface address
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT CanExpand( | VARIANT_BOOL | *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ISearch
  • CanHaveAdditionalServices

ISearch::CanHaveAdditionalServices method |  |  | space
Many codes represent base services with which additional services may be provided, such as OP utilization. If this method returns true the base service may have additional services (see SearchAdditionalServices method). |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearch/CanHaveAdditionalServices
[JSON input data] | pISearch: | longValue, //interface address
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT CanHaveAdditionalServices( | VARIANT_BOOL | *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ISearch
  • CanHaveAnaesthesiaServices

ISearch::CanHaveAnaesthesiaServices method |  |  | space
If this method returns true, anaesthesia services may be provided (see Anaesthesia method from the IUtility ). |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearch/CanHaveAnaesthesiaServices
[JSON input data] | pISearch: | longValue, //interface address
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT CanHaveAnaesthesiaServices( | VARIANT_BOOL | *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ISearch
  • FindCombination

ISearch::FindCombination method |  |  | space
This method finds the first combination service for a base service. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearch/FindCombination
[JSON input data] | pISearch: bstrCode: | longValue, //interface address "utf8StringValue"
[JSON result data] | pbstrCombinationCode: pbstrType: plNumber: pbStatus: | "utf8StringValue", "utf8StringValue", longValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT FindCombination( | BSTR BSTR BSTR long VARIANT_BOOL | bstrCode, *pbstrCombinationCode, *pbstrType, *plNumber, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrCode | Base service code. |
[out] BSTR | *pbstrCombinationCode | Combination service code. |
[out] BSTR | *pbstrType | Combination type. |
[out] long | *plNumber | Combination number, indicating which combination services belong together, if a code has multiple combination schemes. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ISearch
  • FindCombinations

ISearch::FindCombinations method |  |  | space
This method has a Restful Webservice representation only! Method for collecting all combination services of a base service in one call without the necessity to call iterator pair FindCombination / FindNextCombination. The services are returned as JSON array however large that search space might be. So this might be a memory and performance bottleneck. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearch/FindCombinations
[JSON input data] | pISearch: bstrCode: | longValue, //interface address "utf8StringValue"
[JSON result array] | { pbstrCombinationCode: pbstrType: plNumber: pbStatus: | "utf8StringValue", "utf8StringValue", longValue, booleanValue },
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Calling argument description |  |  |
[in] BSTR | bstrCode | Base service code. |
[out] BSTR | *pbstrCombinationCode | Combination service code. |
[out] BSTR | *pbstrType | Combination type. |
[out] long | *plNumber | Combination number, indicating which combination services belong together, if a code has multiple combination schemes. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ISearch
  • FindDescendant

ISearch::FindDescendant method |  |  | space
Method to find any services that are descendants of a base service using a recursive-decent approach. PATCH to restrict the result space to services that are not 123 aka "First-Next-Last" type services (cf. bstrCode argument). |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearch/FindDescendant
[JSON input data] | pISearch: bstrCode: | longValue, //interface address "utf8StringValue"
[JSON result data] | pbstrDescendantCode: pbstrDescendantReference: plLevel: pbStatus: | "utf8StringValue", "utf8StringValue", longValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT FindDescendant( | BSTR BSTR BSTR long VARIANT_BOOL | bstrCode, *pbstrDescendantCode, *pbstrDescendantReference, *plLevel, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrCode | Base service code. PATCH: bstrCode can be appended with the instruction "#no123TypeServices" to restrict the search space to services that are not 123 aka "First-Next-Last" type services. |
[out] BSTR | *pbstrDescendantCode | Descendant service code. |
[out] BSTR | *pbstrDescendantReference | Immediate parent reference code of the descendant service (note that this may differ from the base service code, since the entire descendant tree is searched). |
[out] long | *plLevel | The nesting level of the descendant service code. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ISearch
  • FindDescendants

ISearch::FindDescendants method |  |  | space
This method has a Restful Webservice representation only! Method for collecting all services that are descendants of a base service in one call without the necessity to call iterator pair FindDescendant / FindNextDescendant. The services are returned as JSON array however large that search space might be. So this might be a memory and performance bottleneck. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearch/FindDescendants
[JSON input data] | pISearch: bstrCode: | longValue, //interface address "utf8StringValue"
[JSON result array] | { pbstrDescendantCode: pbstrDescendantReference: plLevel: pbStatus: | "utf8StringValue", "utf8StringValue", longValue, booleanValue },
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Calling argument description |  |  |
[in] BSTR | bstrCode | Base service code. PATCH: bstrCode can be appended with the instruction "#no123TypeServices" to restrict the search space to services that are not 123 aka "First-Next-Last" type services. |
[out] BSTR | *pbstrDescendantCode | Descendant service code. |
[out] BSTR | *pbstrDescendantReference | Immediate parent reference code of the descendant service (note that this may differ from the base service code, since the entire descendant tree is searched). |
[out] long | *plLevel | The nesting level of the descendant service code. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ISearch
  • FindInclusion

ISearch::FindInclusion method | space
This method finds the first inclusion service for a base service.

PATCH
Due to the fact that certain services are for specific laws and/or gender the ISearch::FindInclusion method is patched to allow for a filtering of law and/or gender information in the aforementioned services. The patch is applied by using one of the specific code {"GetLawRestriction", "GetSexRestriction"}.
space
Restful webservice calling syntax
[POST] | /baseURL/ ISearch/FindInclusion
[JSON input data] pISearch:
bstrCode: 		longValue, //interface address
"utf8StringValue"
[JSON result data] pbstrInclusionCode:
pbStatus: 		"utf8StringValue",
booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
HRESULT FindInclusion( BSTR
BSTR
VARIANT_BOOL 		bstrCode,
*pbstrInclusionCode,
*pbStatus);
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[in] BSTR bstrCode Base service code.

Patch
The virtual codes "GetLawRestriction" or "GetSexRestriction" can be used to find law or gender dependent inclusion services.
[out] BSTR *pbstrInclusionCode Inclusion service code.

PATCH
  • by setting bstrCode="GetLawRestriction", pbstrInclusionCode includes a semicolon separated list of applicable laws. If there is no restriction, an empty string will be returned!!
  • by setting bstrCode="GetSexRestriction", pbstrInclusionCode includes a gender code, namely
    • empty string == no sex restriction
    • {0|enMale} == restricted to males only
    • {1|enFemale} == restricted to females only
[out,retval] VARIANT_BOOL *pbStatus Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name).
In the later case check for possible errors with the GetAbortInfo method.
space


  • ISearch
  • FindInclusions

ISearch::FindInclusions method | space
This method has a Restful Webservice representation only!
Method for collecting all inclusion services of a base service in one call without the necessity to call iterator pair FindInclusion / FindNextInclusion.

The services are returned as JSON array however large that search space might be. So this might be a memory and performance bottleneck.
space
Restful webservice calling syntax
[POST] | /baseURL/ ISearch/FindInclusions
[JSON input data] pISearch:
bstrCode: 		longValue, //interface address
"utf8StringValue"
[JSON result array] { pbstrInclusionCode:
pbStatus: 		"utf8StringValue",
booleanValue
},
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
Calling argument description
[in] BSTR bstrCode Base service code.

Patch
The virtual codes "GetLawRestriction" or "GetSexRestriction" can be used to find law or gender dependent inclusion services.
[out] BSTR *pbstrInclusionCode Inclusion service code.

PATCH
  • by setting bstrCode="GetLawRestriction", pbstrInclusionCode includes a semicolon separated list of applicable laws. If there is no restriction, an empty string will be returned!!
  • by setting bstrCode="GetSexRestriction", pbstrInclusionCode includes a gender code, namely
    • empty string == no sex restriction
    • {0|enMale} == restricted to males only
    • {1|enFemale} == restricted to females only
[out,retval] VARIANT_BOOL *pbStatus Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name).
In the later case check for possible errors with the GetAbortInfo method.
space


  • ISearch
  • FindNextCombination

ISearch::FindNextCombination method |  |  | space
This method finds the next combination service for a base service. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearch/FindNextCombination
[JSON input data] | pISearch: bstrCode: | longValue, //interface address "utf8StringValue"
[JSON result data] | pbstrCombinationCode: pbstrType: plNumber: pbStatus: | "utf8StringValue", "utf8StringValue", longValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT FindNextCombination( | BSTR BSTR BSTR long VARIANT_BOOL | bstrCode, *pbstrCombinationCode, *pbstrType, *plNumber, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrCode | Base service code. |
[out] BSTR | *pbstrCombinationCode | Combination service code. |
[out] BSTR | *pbstrType | Combination type. |
[out] long | *plNumber | Combination number, indicating which combination services belong together, if a code has multiple combination schemes. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ISearch
  • FindNextDescendant

ISearch::FindNextDescendant method |  |  | space
Method to find any services that are descendants of a base service using a recursive-decent approach. The crawling is initiated by the FindDescendant method. PATCH to restrict the result space to services that are not 123 aka "First-Next-Last" type services, call FindDescendant("aCode#no123TypeService",...) in the first place. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearch/FindNextDescendant
[JSON input data] | pISearch: | longValue, //interface address
[JSON result data] | pbstrDescendantCode: pbstrDescendantReference: plLevel: pbStatus: | "utf8StringValue", "utf8StringValue", longValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT FindNextDescendant( | BSTR BSTR long VARIANT_BOOL | *pbstrDescendantCode, *pbstrDescendantReference, *plLevel, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrDescendantCode | Descendant service code. |
[out] BSTR | *pbstrDescendantReference | Immediate parent reference code of the descendant service. |
[out] long | *plLevel | The nesting level of the descendant service code. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ISearch
  • FindNextInclusion

ISearch::FindNextInclusion method |  |  | space
This method finds the next inclusion service for a base service. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearch/FindNextInclusion
[JSON input data] | pISearch: bstrCode: | longValue, //interface address "utf8StringValue"
[JSON result data] | pbstrInclusionCode: pbStatus: | "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT FindNextInclusion( | BSTR BSTR VARIANT_BOOL | bstrCode, *pbstrInclusionCode, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrCode | Base service code. |
[out] BSTR | *pbstrInclusionCode | Inclusion service code. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ISearch
  • GetAbortInfo

ISearch::GetAbortInfo method |  |  | space
Get the abort information. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearch/GetAbortInfo
[JSON input data] | pISearch: | longValue, //interface address
[JSON result data] | pbstrAbort: pbStatus: | "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetAbortInfo( | BSTR VARIANT_BOOL | *pbstrAbort, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrAbort | Abort information string. If the abort string is empty then there is no error condition - S_FALSE was set (e.g. in an iterator to signal end_of_data) |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ISearch
  • GetAbsolutePosition

ISearch::GetAbsolutePosition method |  |  | space
Gets the current absolute position of the record pointer in the selection list. This method can be useful for implementing virtual selection lists. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearch/GetAbsolutePosition
[JSON input data] | pISearch: | longValue, //interface address
[JSON result data] | plID: pbStatus: | longValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetAbsolutePosition( | long VARIANT_BOOL | *plID, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] long | *plID | The ID of the service record |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ISearch
  • GetAgeRestriction

ISearch::GetAgeRestriction method | space
This method retrieves a possible age restriction interval of the service.

There are 3 different predications/interpretations possible with the returned data:
  • FALSE is returned: there is no age restriction at all
  • dDaysFrom < dDaysTo: means that there is an age restriction AND the age of the patient must lay inside the interval [ dDaysFrom, dDaysTo]
  • dDaysFrom > dDaysTo: means that there is an age restriction AND the age of the patient must lay outside the interval [dDaysTo , dDaysFrom] (this is the negation of the standard case!)
space
Restful webservice calling syntax
[POST] | /baseURL/ ISearch/GetAgeRestriction
[JSON input data] pISearch: longValue, //interface address
[JSON result data] pdDaysFrom:
pdDaysTo:
pbStatus: 		doubleValue,
doubleValue,
booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
HRESULT GetAgeRestriction( double
double
VARIANT_BOOL 		*pdDaysFrom,
*pdDaysTo,
*pbStatus);
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out] double | *pdDaysFrom | Lower bound of the restriction in days
[out] double | *pdDaysTo | Upper bound of the restriction in days
[out,retval] VARIANT_BOOL *pbStatus Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name).
In the later case check for possible errors with the GetAbortInfo method.
space


  • ISearch
  • GetFirstQualitativeDignity

ISearch::GetFirstQualitativeDignity method |  |  | space
Retrieves the first qualitative dignity information. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearch/GetFirstQualitativeDignity
[JSON input data] | pISearch: | longValue, //interface address
[JSON result data] | pbstrQLDignity: pbstrName: peQualitativeDignitySet: pbStatus: | "utf8StringValue", "utf8StringValue", longValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetFirstQualitativeDignity( | BSTR BSTR YesNoType VARIANT_BOOL | *pbstrQLDignity, *pbstrName, *peQualitativeDignitySet, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrQLDignity | Qualitative dignity code. |
[out] BSTR | *pbstrName | Qualitative dignity name. |
[out] YesNoType | *peQualitativeDignitySet | A value of enYes indicates that the qualitative dignity code represents a dignity set code (see GetFirstQualitativeDignitySet). |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ISearch
  • GetFirstQuantityMultiSessionRestriction

ISearch::GetFirstQuantityMultiSessionRestriction method |  |  | space
This method retrieves the first multi session quantity restriction for the service. If the method returns false there are no restrictions. If the method returns true there are quantity restrictions which will not be tested by the tarmedValidator. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearch/GetFirstQuantityMultiSessionRestriction
[JSON input data] | pISearch: pdQuantity: | longValue, //interface address doubleValue
[JSON result data] | pbstrOperator: pdQuantity: pdDays: pbstrTimeUnit: pbstrSettlementType: pbstrServiceGroup: pbStatus: | "utf8StringValue", doubleValue, doubleValue, "utf8StringValue", "utf8StringValue", "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetFirstQuantityMultiSessionRestriction( | BSTR double double BSTR BSTR BSTR VARIANT_BOOL | *pbstrOperator, *pdQuantity, *pdDays, *pbstrTimeUnit, *pbstrSettlementType, *pbstrServiceGroup, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrOperator | Operator. |
[in,out] double | *pdQuantity | Quantity. |
[out] double | *pdDays | Number of days for which the quantity restriction applies. |
[out] BSTR | *pbstrTimeUnit | Time unit code. |
[out] BSTR | *pbstrSettlementType | SettlementType for which the restriction applies, an empty value indicates that the restriction applies to the service independently of the settlement type. |
[out] BSTR | *pbstrServiceGroup | Service group code. If not empty the quantity restriction applies to the whole service group. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ISearch
  • GetMedicalRoleRestriction

ISearch::GetMedicalRoleRestriction method |  |  | space
This method retrieves the medical role restriction for the service. If the method returns false, there is no medical role restriction. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearch/GetMedicalRoleRestriction
[JSON input data] | pISearch: | longValue, //interface address
[JSON result data] | peMedicalRole: pbStatus: | longValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetMedicalRoleRestriction( | MedicalRoleType VARIANT_BOOL | *peMedicalRole, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] MedicalRoleType | *peMedicalRole | Medical role type. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ISearch
  • GetNextQualitativeDignity

ISearch::GetNextQualitativeDignity method |  |  | space
Retrieves the next qualitative dignity information. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearch/GetNextQualitativeDignity
[JSON input data] | pISearch: | longValue, //interface address
[JSON result data] | pbstrQLDignity: pbstrName: peQualitativeDignitySet: pbStatus: | "utf8StringValue", "utf8StringValue", longValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetNextQualitativeDignity( | BSTR BSTR YesNoType VARIANT_BOOL | *pbstrQLDignity, *pbstrName, *peQualitativeDignitySet, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrQLDignity | Qualitative dignity code. |
[out] BSTR | *pbstrName | Qualitative dignity name. |
[out] YesNoType | *peQualitativeDignitySet | A value of enYes indicates that the qualitative dignity code represents a dignity set code (see GetFirstQualitativeDignitySet). |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ISearch
  • GetNextQuantityMultiSessionRestriction

ISearch::GetNextQuantityMultiSessionRestriction method |  |  | space
This method retrieves the next multi session quantity restriction for the service. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearch/GetNextQuantityMultiSessionRestriction
[JSON input data] | pISearch: pdQuantity: | longValue, //interface address doubleValue
[JSON result data] | pbstrOperator: pdQuantity: pdDays: pbstrTimeUnit: pbstrSettlementType: pbstrServiceGroup: pbStatus: | "utf8StringValue", doubleValue, doubleValue, "utf8StringValue", "utf8StringValue", "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetNextQuantityMultiSessionRestriction( | BSTR double double BSTR BSTR BSTR VARIANT_BOOL | *pbstrOperator, *pdQuantity, *pdDays, *pbstrTimeUnit, *pbstrSettlementType, *pbstrServiceGroup, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrOperator | Operator. |
[in,out] double | *pdQuantity | Quantity. |
[out] double | *pdDays | Number of days for which the quantity restriction applies. |
[out] BSTR | *pbstrTimeUnit | Time unit code. |
[out] BSTR | *pbstrSettlementType | SettlementType for which the restriction applies, an empty value indicates that the restriction applies to the service independently of the settlement type. |
[out] BSTR | *pbstrServiceGroup | Service group code. If not empty the quantity restriction applies to the whole service group. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ISearch
  • GetQualitativeDignities

ISearch::GetQualitativeDignities method |  |  | space
This method has a Restful Webservice representation only! Method for collecting all qualitative dignity data of a base service in one call without the necessity to call iterator pair GetFirstQualitativeDignity / GetNextQualitativeDignity. The services are returned as JSON array however large that search space might be. So this might be a memory and performance bottleneck. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearch/GetQualitativeDignities
[JSON input data] | pISearch: lRecordID: | longValue, //interface address longValue
[JSON result array] | { pbstrQLDignity: pbstrName: peQualitativeDignitySet: pbStatus: | "utf8StringValue", "utf8StringValue", longValue, booleanValue },
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Calling argument description |  |  |
[in] long | lRecordID | The RecordID for whichqualitative dignity data are requested |
[out] BSTR | *pbstrQLDignity | Qualitative dignity code. |
[out] BSTR | *pbstrName | Qualitative dignity name. |
[out] YesNoType | *peQualitativeDignitySet | A value of enYes indicates that the qualitative dignity code represents a dignity set code (see GetFirstQualitativeDignitySet). |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ISearch
  • GetQuantityMultiSessionRestrictions

ISearch::GetQuantityMultiSessionRestrictions method |  |  | space
This method has a Restful Webservice representation only! Method for collecting all multi session quantity restrictions of a base service in one call without the necessity to call iterator pair GetFirstQuantityMultiSessionRestriction / GetNextQuantityMultiSessionRestriction. The services are returned as JSON array however large that search space might be. So this might be a memory and performance bottleneck. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearch/GetQuantityMultiSessionRestrictions
[JSON input data] | pISearch: lRecordID: pdQuantity: | longValue, //interface address longValue, doubleValue
[JSON result array] | { pbstrOperator: pdQuantity: pdDays: pbstrTimeUnit: pbstrSettlementType: pbstrServiceGroup: pbStatus: | "utf8StringValue", doubleValue, doubleValue, "utf8StringValue", "utf8StringValue", "utf8StringValue", booleanValue },
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Calling argument description |  |  |
[in] long | lRecordID | The RecordID for which all multi session quantity restrictions are requested |
[out] BSTR | *pbstrOperator | Operator. |
[in,out] double | *pdQuantity | Quantity. |
[out] double | *pdDays | Number of days for which the quantity restriction applies. |
[out] BSTR | *pbstrTimeUnit | Time unit code. |
[out] BSTR | *pbstrSettlementType | SettlementType for which the restriction applies, an empty value indicates that the restriction applies to the service independently of the settlement type. |
[out] BSTR | *pbstrServiceGroup | Service group code. If not empty the quantity restriction applies to the whole service group. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ISearch
  • GetRecordCount

ISearch::GetRecordCount method |  |  | space
Gets the number of service records in the selection list. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearch/GetRecordCount
[JSON input data] | pISearch: | longValue, //interface address
[JSON result data] | plSize: pbStatus: | longValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetRecordCount( | long VARIANT_BOOL | *plSize, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] long | *plSize | The total number of service records included |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ISearch
  • GetServices

ISearch::GetServices method | space
This method has a Restful Webservice representation only!
Method for collecting all service records junk wise of the resulting search space in one call without the necessity to call the record positioning methods and the appropriate properties of this interface.

The services are returned as JSON array in junks of 50 records beginning with the supplied lStartRecordID, where the array starts with 1. Therefore, after getting the first junk, request the next by incrementing the lRecordID of the last array element and call GetServices again until the statusCode=NoContent. Alternatively, one might call the IMiscSearch::GetRecordCount method to get the size of the search space prior to call GetServices.
space
Restful webservice calling syntax
[POST] | /baseURL/ ISearch/GetServices
[JSON input data] pISearch:
lStartRecordID: 		longValue, //interface address
longValue
[JSON result array] { plRecordID:
pbstrCode:
pbstrName255:
pbstrName35:
pbstrNamePopular:
pbstrServiceType:
pbstrMedicalInfo:
pbstrTechnicalInfo:
pbstrMechanicCode:
pbstrUnitCode:
pbstrUnit:
pdUnitQuantity:
pbstrAnaesthesiaRiskClass:
pbstrTreatmentType:
pbstrSection:
pbstrChapter:
peSexRequired:
peSideRequired:
pbstrKVGObligationCode:
pdTP_MT:
pdTP_TT:
pdInternalFactor_MT:
pdInternalFactor_TT:
pdNumAssistants:
pdServiceMin:
pdPrePostServiceMin:
pdFindingsMin:
pdPlaceMin:
pdChangeMin:
pdAnaesthesiaMin:
pdTP_Assistant:
pbstrMasterCode:
pbstrAdditionalServiceReferenceCode:
peCanHaveAdditionalServices:
peCanHaveAnasthesiaServices:
peCanExpand:
peHasMedicalRoleRestriction:
peMedicalRoleRestriction:
peHasAgeRestriction:
pdRestrictionDaysFrom:
pdRestrictionDaysTo:
pdValidFrom:
pdValidTo:
pbStatus: 		longValue,
"utf8StringValue",
"utf8StringValue",
"utf8StringValue",
"utf8StringValue",
"utf8StringValue",
"utf8StringValue",
"utf8StringValue",
"utf8StringValue",
"utf8StringValue",
"utf8StringValue",
doubleValue,
"utf8StringValue",
"utf8StringValue",
"utf8StringValue",
"utf8StringValue",
longValue,
longValue,
"utf8StringValue",
doubleValue,
doubleValue,
doubleValue,
doubleValue,
doubleValue,
doubleValue,
doubleValue,
doubleValue,
doubleValue,
doubleValue,
doubleValue,
doubleValue,
"utf8StringValue",
"utf8StringValue",
longValue,
longValue,
longValue,
longValue,
longValue,
longValue,
doubleValue,
doubleValue,
"stringISODateValue",
"stringISODateValue",
booleanValue
},
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
Calling argument description
[in] long | lStartRecordID | The starting recordID from which the junk of 50 records starts. The very first recordID is 1.
[out] long | *plRecordID | The RecordID of the current service record
[out] BSTR | *pbstrCode | The code of the currently focused service
[out] BSTR | *pbstrName255 | The full name of the currently focused service
[out] BSTR | *pbstrName35 | The short name (maximum of 35 characters) of the currently focused service
[out] BSTR | *pbstrNamePopular | The popular name of the currently focused service
[out] BSTR *pbstrServiceType The service type of the currently focused service.

New feature: as of 1.1.2007 the value 'F' (aka service is in Swiss Francs instead of tax points) is returned for the newly included IAP services ("Belegarzt Tarif"). Therefore, such a service must be supplied with a tax point value of 1.0!
[out] BSTR | *pbstrMedicalInfo | The medical information text of the currently focused service
[out] BSTR | *pbstrTechnicalInfo | The rechnical information text of the currently focused service
[out] BSTR *pbstrMechanicCode The mechanic code of the currently focused service

To translate the mechanic code into a human readable string, use the Icatalog::GetFirstMechanicCode method.

PATCH:
The returned code might possibly be appened with additional information like the service block, service groupe affilliation and/or gender relevance information when requested in the Isearch::SearchCode or Isearch::SearchAdditionalService methods.

E.g.when search for Isearch::SearchCode("00.0150#SB#SG#SEX",enYes) the code "01#SB01#SG18#SG58#SEX0" is returned, meaning that the service 00.0150
  • has the mechanic code 01
  • is a member of the service block 01
  • belongs to the service groups 18 and 58.
  • has a gender relevance of 0
    where the possible value codes are: 0 == not relevant; 1 == male only; 2 == female only
[out] BSTR *pbstrUnitCode The unit code of the currently focused service

cf. Unit in Icatalog interface for an indepth description.
[out] BSTR | *pbstrUnit | The unit name (base unit) of the currently focused service
[out] double | *pdUnitQuantity | The quantity of base units that are included in the currently focused service
[out] BSTR *pbstrAnaesthesiaRiskClass The maximal anaesthesia risk class code of the currently focused service.

cf. AnaesthesiaRiskClassType enumeration for possible values, an empty value indicates that the sevice does normally not need anaesthesia.
[out] BSTR *pbstrTreatmentType The treatment type of the currently focused service

cf. TreatmentType enumeration for possible values, an empty value indicates that the treatment type does not matter.
[out] BSTR *pbstrSection The section code of the currently focused service

cf. Icatalog interface for an indepth description.
[out] BSTR | *pbstrChapter | The chapter code that the currently focused service belongs to
[out] YesNoType | *peSexRequired | The flag indicating whether the currently focused service requires the sex information (enYes) or not (enNo).
[out] YesNoType | *peSideRequired | The flag indicating whether the currently focused service requires the side information (enYes) or not (enNo).
[out] BSTR *pbstrKVGObligationCode The KVG obligation code of the currently focused service

cf. ICatalog interface for an indepth description.
[out] double | *pdTP_MT | The medical tax point (TP_MT) of the currently focused service
[out] double | *pdTP_TT | The technical tax point (TP_TT) of the currently focused service
[out] double | *pdInternalFactor_MT | The internal scaling factor of the medical part of the currently focused service
[out] double | *pdInternalFactor_TT | The internal scaling factor of the technical part of the currently focused service
[out] double | *pdNumAssistants | The number of assistants needed for applying the currently focused service
[out] double | *pdServiceMin | The defined minutes of the medical part of the currently focused service
[out] double | *pdPrePostServiceMin | The defined minutes for the ante and post treatment of the currently focused service
[out] double *pdFindingsMin The defined minutes for making any findings of the currently focused service

cf. Tarmed documentation for an indepth description.
[out] double *pdPlaceMin The defined minutes in the context of room or location utilization of the currently focused service

cf. Tarmed documentation for an indepth description.
[out] double *pdChangeMin The defined minutes in the context of change time of the currently focused service

cf. Tarmed documentation for an indepth description.
[out] double | *pdAnaesthesiaMin | The defined minutes of an anaesthesia of the currently focused service
[out] double | *pdTP_Assistant | The tax points (TP) for the assistant part of the currently focused service
[out] BSTR | *pbstrMasterCode | The master or parent code if the currently focused service is a slave service or empty otherwise
[out] BSTR | *pbstrAdditionalServiceReferenceCode | A reference code attached to the currently focused service and obtained by a SearchAdditionalService call.
[out] YesNoType | *peCanHaveAdditionalServices | The flag indicating whether the currently focused service can have additional services/reference services (enYes) or not (enNo).
[out] YesNoType | *peCanHaveAnasthesiaServices | The flag indicating whether the currently focused service can have anaesthesia services attachted (enYes) or not (enNo).
[out] YesNoType | *peCanExpand | The flag indicating whether the currently focused service can be expanded (enYes) or not (enNo).
[out] YesNoType | *peHasMedicalRoleRestriction | The flag indicating whether the currently focused service has a medical role restriction (enYes) or not (enNo).
[out] MedicalRoleType | *peMedicalRoleRestriction | The defined medical role restriction if and only if peHasMedicalRoleRestriction=enYes. The medical role restriction is undefined if peHasMedicalRoleRestriction=enNo.
[out] YesNoType | *peHasAgeRestriction | The flag indicating whether the currently focused service has a age restriction (enYes) or not (enNo).
[out] double | *pdRestrictionDaysFrom | The lower bound of the restriction in days if and only if peHasAgeRestriction=enYes. The value is undefined if peHasAgeRestriction=enNo.
[out] double | *pdRestrictionDaysTo | The upper bound of the restriction in days if and only if peHasAgeRestriction=enYes. The value is undefined if peHasAgeRestriction=enNo.
[out] DATE | *pdValidFrom | The validity start date of the currently focused service
[out] DATE | *pdValidTo | The validity end date of the currently focused service
[out,retval] VARIANT_BOOL | *pbStatus | Boolean return status
space


  • ISearch
  • MoveFirst

ISearch::MoveFirst method |  |  | space
Moves the record pointer to the first record in the selection list and makes that record the current service record. If the action could not be performed false will be returned. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearch/MoveFirst
[JSON input data] | pISearch: | longValue, //interface address
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT MoveFirst( | VARIANT_BOOL | *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ISearch
  • MoveLast

ISearch::MoveLast method |  |  | space
Moves to the last record in the selection list and makes that record the current service record. If the action could not be performed false will be returned. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearch/MoveLast
[JSON input data] | pISearch: | longValue, //interface address
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT MoveLast( | VARIANT_BOOL | *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ISearch
  • MoveNext

ISearch::MoveNext method |  |  | space
Moves to the next record in the selection list and makes that record the current service record. If the action could not be performed false will be returned. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearch/MoveNext
[JSON input data] | pISearch: | longValue, //interface address
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT MoveNext( | VARIANT_BOOL | *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method |
space |


  • ISearch
  • MovePrevious

ISearch::MovePrevious method |  |  | space
Moves to the previous record in the selection list object and makes that record the current service record. If the action could not be performed false will be returned. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearch/MovePrevious
[JSON input data] | pISearch: | longValue, //interface address
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT MovePrevious( | VARIANT_BOOL | *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ISearch
  • PutAbsolutePosition

ISearch::PutAbsolutePosition method |  |  | space
Positions the record pointer at the specified absolute position in the selection list. This method can be useful for implementing virtual selection lists. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearch/PutAbsolutePosition
[JSON input data] | pISearch: lID: | longValue, //interface address longValue
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT PutAbsolutePosition( | long VARIANT_BOOL | lID, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] long | lID | The ID of the current service record |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ISearch
  • SearchAdditionalService

ISearch::SearchAdditionalService method | space
This method searches for additional services which may be provided for a base service.

When retrieving the service record from the result list, call the property AdditionalServiceReferenceCode to get the proper reference code.

PATCH to request additional service block, service group affiliation and/or gender relevance information from the searching process (cf. bstrCode argument).
space
Restful webservice calling syntax
[POST] | /baseURL/ ISearch/SearchAdditionalService
[JSON input data] pISearch:
bstrCode:
eTreatType:
ePraxisOP: 		longValue, //interface address
"utf8StringValue",
longValue,
longValue
[JSON result data] pbStatus: booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
HRESULT SearchAdditionalService( BSTR
TreatmentType
YesNoType
VARIANT_BOOL 		bstrCode,
eTreatType,
ePraxisOP,
*pbStatus);
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[in] BSTR bstrCode Code of the base service.

PATCH: bstrCode can be appended with instructions to request additional information, namely
  • #SB to retrieve the service block numbers
  • #SG to retrieve the service group numbers
  • #SEX to retrieve the gender relevance information
After searching, position to the first record with Isearch::MoveFirst and the ISearch::MechanicCode() property returns a hash separated string with the mechanic code and the hash separated additional information.

E.g. when search for ISearch:: SearchAdditionalService ("24.6760#SB#SG#SEX",...) the property ISearch::MechanicCode returns the string "15# SG18#SG64#SEX0" for service 00.1420 , meaning that the service
  • has the mechanic code 15
  • is not> a member of a service block
  • belongs to the service groups 18 and 64.
  • has a gender relevance of 0
    where the possible value codes are: 0 == not relevant; 1 == male only; 2 == female only
[in] TreatmentType | eTreatType | Treatment type.
[in] YesNoType | ePraxisOP | Flag specifying whether the location has a praxis OP.
[out,retval] VARIANT_BOOL *pbStatus Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name).
In the later case check for possible errors with the GetAbortInfo method.
space


  • ISearch
  • SearchChapter

ISearch::SearchChapter method | space
This method searches for services which belong to the base chapter.
Patched to get service block, group, and gender relevance information
space
Restful webservice calling syntax
[POST] | /baseURL/ ISearch/SearchChapter
[JSON input data] pISearch:
bstrChapterCode:
eOnlyMainServices: 		longValue, //interface address
"utf8StringValue",
longValue
[JSON result data] pbStatus: booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
HRESULT SearchChapter( BSTR
YesNoType
VARIANT_BOOL 		bstrChapterCode,
eOnlyMainServices,
*pbStatus);
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[in] BSTR bstrChapterCode Chapter code.
Patch: the parameter can be appended with
  • #SB to retrieve the service block numbers
    and/or
  • #SG to retrieve the service group numbers
    and/or
  • #SEX to retrieve the gender relevance, where the possible codes are: 0=not relevant; 1=male only; 2=female only
cf. ISearch::SearchCode for an example
[in] YesNoType | eOnlyMainServices | Flag specifying whether to search for main services only. Main services mean services which are not subsidiary to any other service, i.e. base services.
[out,retval] VARIANT_BOOL *pbStatus Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name).
In the later case check for possible errors with the GetAbortInfo method.
space


  • ISearch
  • SearchCode

ISearch::SearchCode method | space
This method searches for services by code.

PATCH to request additional service block, service group affiliation and/or gender relevance information from the searching process (cf. bstrCode argument).
space
Restful webservice calling syntax
[POST] | /baseURL/ ISearch/SearchCode
[JSON input data] pISearch:
bstrCode:
eOnlyMainServices: 		longValue, //interface address
"utf8StringValue",
longValue
[JSON result data] pbStatus: booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
HRESULT SearchCode( BSTR
YesNoType
VARIANT_BOOL 		bstrCode,
eOnlyMainServices,
*pbStatus);
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[in] BSTR bstrCode Service code to search for.

PATCH: bstrCode can be appended with instructions to request additional information, namely
  • #SB to retrieve the service block numbers
  • #SG to retrieve the service group numbers
  • #SEX to retrieve the gender relevance information
After searching, the ISearch::MechanicCode() property returns a hash separated string with the mechanic code and the hash separated additional information.

E.g. when search for ISearch::SearchCode("00.0150#SB#SG#SEX",enYes) the property ISearch::MechanicCode returns the string "01#SB01#SG18#SG58#SEX0", meaning that the service 00.0150
  • has the mechanic code 01
  • is a member of the service block 01
  • belongs to the service groups 18 and 58.
  • has a gender relevance of 0
    where the possible value codes are: 0 == not relevant; 1 == male only; 2 == female only
[in] YesNoType | eOnlyMainServices | Flag specifying whether to search for main services only. Main services mean services which are not subsidiary to any other service, i.e. base services.
[out,retval] VARIANT_BOOL *pbStatus Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name).
In the later case check for possible errors with the GetAbortInfo method.
space


  • ISearch
  • SearchName255

ISearch::SearchName255 method | space
This method searches for services by the full service name.
Patched to get service block, group, and gender relevance information
space
Restful webservice calling syntax
[POST] | /baseURL/ ISearch/SearchName255
[JSON input data] pISearch:
bstrName255:
eOnlyMainServices: 		longValue, //interface address
"utf8StringValue",
longValue
[JSON result data] pbStatus: booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
HRESULT SearchName255( BSTR
YesNoType
VARIANT_BOOL 		bstrName255,
eOnlyMainServices,
*pbStatus);
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[in] BSTR bstrName255 Full service name.
Patch: the parameter can be appended with
  • #SB to retrieve the service block numbers
    and/or
  • #SG to retrieve the service group numbers
    and/or
  • #SEX to retrieve the gender relevance, where the possible codes are: 0=not relevant; 1=male only; 2=female only
cf. ISearch::SearchCode for an example
[in] YesNoType | eOnlyMainServices | Flag specifying whether to search for main services only. Main services mean services which are not subsidiary to any other service, i.e. base services.
[out,retval] VARIANT_BOOL *pbStatus Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name).
In the later case check for possible errors with the GetAbortInfo method.
space


  • ISearch
  • SearchName35

ISearch::SearchName35 method | space
This method searches for services by the service short name.
Patched to get service block, group, and gender relevance information
space
Restful webservice calling syntax
[POST] | /baseURL/ ISearch/SearchName35
[JSON input data] pISearch:
bstrName35:
eOnlyMainServices: 		longValue, //interface address
"utf8StringValue",
longValue
[JSON result data] pbStatus: booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
HRESULT SearchName35( BSTR
YesNoType
VARIANT_BOOL 		bstrName35,
eOnlyMainServices,
*pbStatus);
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[in] BSTR bstrName35 Short service name.
Patch: the parameter can be appended with
  • #SB to retrieve the service block numbers
    and/or
  • #SG to retrieve the service group numbers
    and/or
  • #SEX to retrieve the gender relevance, where the possible codes are: 0=not relevant; 1=male only; 2=female only
cf. ISearch::SearchCode for an example
[in] YesNoType | eOnlyMainServices | Flag specifying whether to search for main services only. Main services mean services which are not subsidiary to any other service, i.e. base services.
[out,retval] VARIANT_BOOL *pbStatus Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name).
In the later case check for possible errors with the GetAbortInfo method.
space


  • ISearch
  • SearchPopular

ISearch::SearchPopular method | space
This method searches for services by popular name.
Patched to get service block, group, and gender relevance information
space
Restful webservice calling syntax
[POST] | /baseURL/ ISearch/SearchPopular
[JSON input data] pISearch:
bstrNamePopular:
eOnlyMainServices: 		longValue, //interface address
"utf8StringValue",
longValue
[JSON result data] pbStatus: booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
HRESULT SearchPopular( BSTR
YesNoType
VARIANT_BOOL 		bstrNamePopular,
eOnlyMainServices,
*pbStatus);
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[in] BSTR bstrNamePopular Popular name of the service.
Patch: the parameter can be appended with
  • #SB to retrieve the service block numbers
    and/or
  • #SG to retrieve the service group numbers
    and/or
  • #SEX to retrieve the gender relevance, where the possible codes are: 0=not relevant; 1=male only; 2=female only
cf. ISearch::SearchCode for an example
[in] YesNoType | eOnlyMainServices | Flag specifying whether to search for main services only. Main services mean services which are not subsidiary to any other service, i.e. base services.
[out,retval] VARIANT_BOOL *pbStatus Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name).
In the later case check for possible errors with the GetAbortInfo method.
space


  • ISearch
  • SearchServiceBlock

ISearch::SearchServiceBlock method | space
This method searches for services which belong to the base service block.
Patched to get service block, group, and gender relevance information
space
Restful webservice calling syntax
[POST] | /baseURL/ ISearch/SearchServiceBlock
[JSON input data] pISearch:
bstrBlockCode:
eOnlyMainServices: 		longValue, //interface address
"utf8StringValue",
longValue
[JSON result data] pbStatus: booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
HRESULT SearchServiceBlock( BSTR
YesNoType
VARIANT_BOOL 		bstrBlockCode,
eOnlyMainServices,
*pbStatus);
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[in] BSTR bstrBlockCode Service block code.
Patch: the parameter can be appended with
  • #SB to retrieve the service block numbers
    and/or
  • #SG to retrieve the service group numbers
    and/or
  • #SEX to retrieve the gender relevance, where the possible codes are: 0=not relevant; 1=male only; 2=female only
cf. ISearch::SearchCode for an example
[in] YesNoType | eOnlyMainServices | Flag specifying whether to search for main services only. Main services mean services which are not subsidiary to any other service, i.e. base services.
[out,retval] VARIANT_BOOL *pbStatus Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name).
In the later case check for possible errors with the GetAbortInfo method.
space


  • ISearch
  • SearchServiceGroup

ISearch::SearchServiceGroup method | space
This method searches for services which belong to the base service group.
Patched to get service block, group, and gender relevance information
space
Restful webservice calling syntax
[POST] | /baseURL/ ISearch/SearchServiceGroup
[JSON input data] pISearch:
bstrGroupCode:
eOnlyMainServices: 		longValue, //interface address
"utf8StringValue",
longValue
[JSON result data] pbStatus: booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
HRESULT SearchServiceGroup( BSTR
YesNoType
VARIANT_BOOL 		bstrGroupCode,
eOnlyMainServices,
*pbStatus);
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[in] BSTR bstrGroupCode Service group code.
Patch: the parameter can be appended with
  • #SB to retrieve the service block numbers
    and/or
  • #SG to retrieve the service group numbers
    and/or
  • #SEX to retrieve the gender relevance, where the possible codes are: 0=not relevant; 1=male only; 2=female only
cf. ISearch::SearchCode for an example
[in] YesNoType | eOnlyMainServices | Flag specifying whether to search for main services only. Main services mean services which are not subsidiary to any other service, i.e. base services.
[out,retval] VARIANT_BOOL *pbStatus Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name).
In the later case check for possible errors with the GetAbortInfo method.
space


  • ISearch
  • SearchSlave

ISearch::SearchSlave method | space
This method searches the slave services for a base service.
Patched to get service block, group, and gender relevance information
space
Restful webservice calling syntax
[POST] | /baseURL/ ISearch/SearchSlave
[JSON input data] pISearch:
bstrCode:
eExpandFilter: 		longValue, //interface address
"utf8StringValue",
longValue
[JSON result data] pbStatus: booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
HRESULT SearchSlave( BSTR
YesNoType
VARIANT_BOOL 		bstrCode,
eExpandFilter,
*pbStatus);
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[in] BSTR bstrCode Tarmed service code.
Patch: the parameter can be appended with
  • #SB to retrieve the service block numbers
    and/or
  • #SG to retrieve the service group numbers
    and/or
  • #SEX to retrieve the gender relevance, where the possible codes are: 0=not relevant; 1=male only; 2=female only
cf. ISearch::SearchCode for an example
[in] YesNoType | eExpandFilter | If the ExpandFilter is set to enYes the services which can be obtained by the Expand method from the IUtility interface will be filtered out.
[out,retval] VARIANT_BOOL *pbStatus Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name).
In the later case check for possible errors with the GetAbortInfo method.
space


  • ISearch
  • AdditionalServiceReferenceCode

ISearch::AdditionalServiceReferenceCode property | space
Gets a reference code from a service record set obtained by SearchAdditionalService.
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch/GetAdditionalServiceReferenceCode?param
[param] pISearch= longValue
[JSON result data] pbstrAdditionalServiceReferenceCode: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | AdditionalServiceReferenceCode( BSTR *pbstrAdditionalServiceReferenceCode );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrAdditionalServiceReferenceCode | The referemce code of the current focused service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetAdditionalServiceReferenceCode(void);
space


  • ISearch
  • AnaesthesiaMin

ISearch::AnaesthesiaMin property | space
The time of an anaesthesia in minutes (including everything).
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch/GetAnaesthesiaMin?param
[param] pISearch= longValue
[JSON result data] pdAnaesthesiaMin: doubleValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | AnaesthesiaMin( double *pdAnaesthesiaMin );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] double | *pdAnaesthesiaMin | The anaesthesia time (in minutes) of the current focused service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • double *GetAnaesthesiaMin(void);
space


  • ISearch
  • AnaesthesiaRiskClass

ISearch::AnaesthesiaRiskClass property | space
Maximal anaesthesia risk class code (see AnaesthesiaRiskClassType enumeration for possible values, an empty value indicates that the sevice does normally not need anaesthesia).
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch/GetAnaesthesiaRiskClass?param
[param] pISearch= longValue
[JSON result data] pbstrAnaesthesiaRiskClass: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | AnaesthesiaRiskClass( BSTR *pbstrAnaesthesiaRiskClass );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrAnaesthesiaRiskClass | The anaesthesia risk class of the current focused service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetAnaesthesiaRiskClass(void);
space


  • ISearch
  • ChangeMin

ISearch::ChangeMin property | space
Minutes in the context of change time (see the Tarmed documentation for details).
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch/GetChangeMin?param
[param] pISearch= longValue
[JSON result data] pdChangeMin: doubleValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | ChangeMin( double *pdChangeMin );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] double | *pdChangeMin | The context change time (in minutes) of the current focused service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • double *GetChangeMin(void);
space


  • ISearch
  • Chapter

ISearch::Chapter property | space
Chapter code.
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch/GetChapter?param
[param] pISearch= longValue
[JSON result data] pbstrChapter: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Chapter( BSTR *pbstrChapter );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrChapter | The chapter code of the current focused service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetChapter(void);
space


  • ISearch
  • Code

ISearch::Code property | space
Service code.
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch/GetCode?param
[param] pISearch= longValue
[JSON result data] pbstrCode: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Code( BSTR *pbstrCode );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrCode | The code of the current focused service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetCode(void);
space


  • ISearch
  • DestructSearch

ISearch::DestructSearch property |  |  | space
This property has a Restful Webservice representation only! Destructs/invalidates this ISearch interface instance. The counterpart property to generate an ISearch interface instance is ITarmedValidator::GetCreateSearch. |  |  |
space
Restful webservice calling syntax |  |  |
[PUT] | /baseURL/ ISearch/PutDestructSearch
[JSON input data] | pISearch: | longValue, //interface address
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Remarks |  |  |
This property has a Restful Webservice representation only! |  |  |
space |


  • ISearch
  • DignityFilter

ISearch::DignityFilter property | space
Set/Get the dignity filter as specified in the ITarmedInput inteface for the responible physician.
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch/GetDignityFilter?param
[param] pISearch= longValue
[JSON result data] pITarmedInput: longValue
[PUT] | /baseURL/ ISearch/PutDignityFilter
[JSON input data] pISearch:
ITarmedInput: 		longValue, //interface address
longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | DignityFilter( ITarmedInput **pITarmedInput );
[put] HRESULT | DignityFilter( ITarmedInput **pITarmedInput );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] ITarmedInput | **pITarmedInput | The ITarmedInput interface instance
[in] ITarmedInput | **pITarmedInput | The ITarmedInput interface instance
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • ITarmedInput **GetDignityFilter(void);
  • void PutDignityFilter( ITarmedInput *pITarmedInput);
space


  • ISearch
  • FindingsMin

ISearch::FindingsMin property | space
Minutes in the context of making findings (see the Tarmed documentation for details).
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch/GetFindingsMin?param
[param] pISearch= longValue
[JSON result data] pdFindingsMin: doubleValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | FindingsMin( double *pdFindingsMin );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] double | *pdFindingsMin | The context finding time (in minutes) of the current focused service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • double *GetFindingsMin(void);
space


  • ISearch
  • InternalFactor_MT

ISearch::InternalFactor_MT property | space
Scaling factor for the medical part.
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch/GetInternalFactor_MT?param
[param] pISearch= longValue
[JSON result data] pdInternalFactor_MT: doubleValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | InternalFactor_MT( double *pdInternalFactor_MT );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] double | *pdInternalFactor_MT | The scaling factor of the medical part of the current focused service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • double *GetInternalFactor_MT(void);
space


  • ISearch
  • InternalFactor_TT

ISearch::InternalFactor_TT property | space
Scaling factor for the technical part.
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch/GetInternalFactor_TT?param
[param] pISearch= longValue
[JSON result data] pdInternalFactor_TT: doubleValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | InternalFactor_TT( double *pdInternalFactor_TT );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] double | *pdInternalFactor_TT | The scaling factor of the technical part of the current focused service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • double *GetInternalFactor_TT(void);
space


  • ISearch
  • KVGObligationCode

ISearch::KVGObligationCode property | space
KVG obligation code (see ICatalog interface ).
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch/GetKVGObligationCode?param
[param] pISearch= longValue
[JSON result data] pbstrKVGObligationCode: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | KVGObligationCode( BSTR *pbstrKVGObligationCode );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrKVGObligationCode | The KVG obligation code of the current focused service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetKVGObligationCode(void);
space


  • ISearch
  • MasterCode

ISearch::MasterCode property | space
The parent code of the service code, if the service code is a slave. Otherwise empty.
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch/GetMasterCode?param
[param] pISearch= longValue
[JSON result data] pbstrMasterCode: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | MasterCode( BSTR *pbstrMasterCode );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrMasterCode | The defined parent code of the current focused service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetMasterCode(void);
space


  • ISearch
  • MechanicCode

ISearch::MechanicCode property | space
Mechanic code

To translate the mechanic code into a human readable string, use the ICatalog::GetFirstMechanicCode method.

PATCH:
The returned code might possibly be appened with additional information like the service block, service groupe affilliation and/or gender relevance information when requested in the ISearch::SearchCode or ISearch::SearchAdditionalService methods.

E.g.when search for ISearch::SearchCode("00.0150#SB#SG#SEX",enYes) the code "01#SB01#SG18#SG58#SEX0" is returned, meaning that the service 00.0150
  • has the mechanic code 01
  • is a member of the service block 01
  • belongs to the service groups 18 and 58.
  • has a gender relevance of 0
    where the possible value codes are: 0 == not relevant; 1 == male only; 2 == female only
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch/GetMechanicCode?param
[param] pISearch= longValue
[JSON result data] pbstrMechanicCode: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | MechanicCode( BSTR *pbstrMechanicCode );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrMechanicCode | The defined mechanic code of the current focused service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetMechanicCode(void);
space


  • ISearch
  • MedicalInfo

ISearch::MedicalInfo property | space
Medical information for the service (BLOB field).
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch/GetMedicalInfo?param
[param] pISearch= longValue
[JSON result data] pbstrMedicalInfo: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | MedicalInfo( BSTR *pbstrMedicalInfo );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrMedicalInfo | The medical info of the current focused service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetMedicalInfo(void);
space


  • ISearch
  • Name255

ISearch::Name255 property | space
Full service name.
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch/GetName255?param
[param] pISearch= longValue
[JSON result data] pbstrName255: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Name255( BSTR *pbstrName255 );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrName255 | The full service name of the current focused service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetName255(void);
space


  • ISearch
  • Name35

ISearch::Name35 property | space
Short service name.
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch/GetName35?param
[param] pISearch= longValue
[JSON result data] pbstrName35: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Name35( BSTR *pbstrName35 );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrName35 | The short service name (max. 35 characters) of the current focused service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetName35(void);
space


  • ISearch
  • NamePopular

ISearch::NamePopular property | space
Popular name of the service.
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch/GetNamePopular?param
[param] pISearch= longValue
[JSON result data] pbstrNamePopular: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | NamePopular( BSTR *pbstrNamePopular );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrNamePopular | The popular service name of the current focused service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetNamePopular(void);
space


  • ISearch
  • NumAssistants

ISearch::NumAssistants property | space
Number of assistants needed for performing the service.
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch/GetNumAssistants?param
[param] pISearch= longValue
[JSON result data] pdNumAssistants: doubleValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | NumAssistants( double *pdNumAssistants );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] double | *pdNumAssistants | The defined number of assistants of the current focused service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • double *GetNumAssistants(void);
space


  • ISearch
  • PlaceMin

ISearch::PlaceMin property | space
Minutes in the context of room or location utilization (see the Tarmed documentation for details)
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch/GetPlaceMin?param
[param] pISearch= longValue
[JSON result data] pdPlaceMin: doubleValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | PlaceMin( double *pdPlaceMin );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] double | *pdPlaceMin | The context room/location time (in minutes) of the current focused service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • double *GetPlaceMin(void);
space


  • ISearch
  • PrePostServiceMin

ISearch::PrePostServiceMin property | space
The time needed before and after the service expressed in minutes.
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch/GetPrePostServiceMin?param
[param] pISearch= longValue
[JSON result data] pdPrePostServiceMin: doubleValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | PrePostServiceMin( double *pdPrePostServiceMin );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] double | *pdPrePostServiceMin | The defined pre and post treatment time (in minutes) of the current focused service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • double *GetPrePostServiceMin(void);
space


  • ISearch
  • Section

ISearch::Section property | space
Section code (see ICatalog interface ).
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch/GetSection?param
[param] pISearch= longValue
[JSON result data] pbstrSection: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Section( BSTR *pbstrSection );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrSection | The section code of the current focused service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetSection(void);
space


  • ISearch
  • ServiceMin

ISearch::ServiceMin property | space
The medical part of the service expressed in minutes.
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch/GetServiceMin?param
[param] pISearch= longValue
[JSON result data] pdServiceMin: doubleValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | ServiceMin( double *pdServiceMin );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] double | *pdServiceMin | The defined medical service time (in minutes) of the current focused service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • double *GetServiceMin(void);
space


  • ISearch
  • ServiceType

ISearch::ServiceType property | space
Service type, see the ICatalog interface for a description of the meaning of this value.

New feature: as of 1.1.2007 the value 'F' (aka service is in Swiss Francs instead of tax points) is returned for the newly included IAP services ("Belegarzt Tarif"). Therefore, such a service must be supplied with a tax point value of 1.0!
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch/GetServiceType?param
[param] pISearch= longValue
[JSON result data] pbstrServiceType: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | ServiceType( BSTR *pbstrServiceType );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrServiceType | The defined service type of the current focused service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetServiceType(void);
space


  • ISearch
  • SexRequired

ISearch::SexRequired property | space
Sex information is required for the service.
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch/GetSexRequired?param
[param] pISearch= longValue
[JSON result data] peSexRequired: longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | SexRequired( YesNoType *peSexRequired );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] YesNoType | *peSexRequired | The Boolean if the sex is required of the current focused service record (enYes) or not (enNo)
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • YesNoType *GetSexRequired(void);
space


  • ISearch
  • SideRequired

ISearch::SideRequired property | space
Side information is required for the service.
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch/GetSideRequired?param
[param] pISearch= longValue
[JSON result data] peSideRequired: longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | SideRequired( YesNoType *peSideRequired );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] YesNoType | *peSideRequired | The Boolean if the side is required of the current focused service record (enYes) or not (enNo)
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • YesNoType *GetSideRequired(void);
space


  • ISearch
  • TechnicalInfo

ISearch::TechnicalInfo property | space
Technical information for the service (BLOB field).
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch/GetTechnicalInfo?param
[param] pISearch= longValue
[JSON result data] pbstrTechnicalInfo: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | TechnicalInfo( BSTR *pbstrTechnicalInfo );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrTechnicalInfo | The technical info of the current focused service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetTechnicalInfo(void);
space


  • ISearch
  • TP_Assistant

ISearch::TP_Assistant property | space
Tax points for the assistant part of the service.
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch/GetTP_Assistant?param
[param] pISearch= longValue
[JSON result data] pdTP_Assistant: doubleValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | TP_Assistant( double *pdTP_Assistant );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] double | *pdTP_Assistant | The defined tax points (TP) for the assistante of the current focused service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • double *GetTP_Assistant(void);
space


  • ISearch
  • TP_MT

ISearch::TP_MT property | space
Tax points for the medical part of the service.
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch/GetTP_MT?param
[param] pISearch= longValue
[JSON result data] pdTP_MT: doubleValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | TP_MT( double *pdTP_MT );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] double | *pdTP_MT | The defined tax points (TP) of the medical part of the current focused service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • double *GetTP_MT(void);
space


  • ISearch
  • TP_TT

ISearch::TP_TT property | space
Tax points for the technical part.
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch/GetTP_TT?param
[param] pISearch= longValue
[JSON result data] pdTP_TT: doubleValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | TP_TT( double *pdTP_TT );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] double | *pdTP_TT | The defined tax points (TP) of the technical part of the current focused service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • double *GetTP_TT(void);
space


  • ISearch
  • TreatmentType

ISearch::TreatmentType property | space
Treatment type (see TreatmentType enumeration for possible values, an empty value indicates that the treatment type does not matter).
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch/GetTreatmentType?param
[param] pISearch= longValue
[JSON result data] pbstrTreatmentType: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | TreatmentType( BSTR *pbstrTreatmentType );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrTreatmentType | The defined treatment type of the current focused service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetTreatmentType(void);
space


  • ISearch
  • Unit

ISearch::Unit property | space
Unit name (base unit).
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch/GetUnit?param
[param] pISearch= longValue
[JSON result data] pbstrUnit: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Unit( BSTR *pbstrUnit );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrUnit | The defined unit name of the current focused service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetUnit(void);
space


  • ISearch
  • UnitCode

ISearch::UnitCode property | space
Unit code (see Unit or ICatalog interface).
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch/GetUnitCode?param
[param] pISearch= longValue
[JSON result data] pbstrUnitCode: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | UnitCode( BSTR *pbstrUnitCode );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrUnitCode | The defined unit code of the current focused service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetUnitCode(void);
space


  • ISearch
  • UnitQuantity

ISearch::UnitQuantity property | space
The quantity of base units which are included in the service.
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch/GetUnitQuantity?param
[param] pISearch= longValue
[JSON result data] pdUnitQuantity: doubleValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | UnitQuantity( double *pdUnitQuantity );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] double | *pdUnitQuantity | The defined unit quantity of the current focused service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • double *GetUnitQuantity(void);
space


  • ISearch
  • ValidFrom

ISearch::ValidFrom property | space
Get the validity start date of the current service.
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch/GetValidFrom?param
[param] pISearch= longValue
[JSON result data] pdValidFrom: "stringISODateValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | ValidFrom( DATE *pdValidFrom );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] DATE | *pdValidFrom | The defined validity start of the current focused service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • DATE *GetValidFrom(void);
space


  • ISearch
  • ValidTo

ISearch::ValidTo property | space
Get the validity end date of the current service.
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch/GetValidTo?param
[param] pISearch= longValue
[JSON result data] pdValidTo: "stringISODateValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | ValidTo( DATE *pdValidTo );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] DATE | *pdValidTo | The defined validity end of the current focused service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • DATE *GetValidTo(void);
space


  • ITarmedInput

ITarmedInput interface |  | V1.00/30 Aug 2002
The ITarmedInput interface provides methods for the input of data which will mainly stay constant for a particular installation of the program, such as the dignities of the physicians, or stay constant throughout a session, such as the patient sex or patient birth date. It is used in conjunction with the IValidate interface. The physician, patient and treatment data are entered via the ITarmedInput interface, then the service data are entered via the IValidate interface. |  | space
space
Methods |  | 18 methods
AddDignity | Adds the qualitative dignity for the supplied physician EAN number |
AddSection | Adds the service location section. |
GetAbortInfo | Get the abort information. |
GetDignities | Method for collecting all filtered dignity information inputted so far by AddDignity in one call without the necessity to call iterator pair GetFirstDignity / GetNextDignity |
GetFirstDignity | Retrieves the first dignity information. |
GetFirstSection | Retrieves the first section information. |
GetNextDignity | Retrieves the next dignity information. |
GetNextSection | Retrieves the next section information. |
GetPatient | Get the patient input data. |
GetPhysician | Get the physician input data. |
GetSections | Method for collecting all filtered section information inputted so far by AddSection in one call without the necessity to call iterator pair GetFirstSection / GetNextSection |
GetTreatment | Get the treatment input data. |
InitDignity | Initializes the dignity-relevant input data. |
Initialize | Initializes the input data. |
InitSection | Initializes the section-relevant input data. |
SetPatient | Set the patient input data. |
SetPhysician | Set the physician input data. |
SetTreatment | Set the treatment input data |
space
Properties |  | 3 properties
[put] DestructTarmedInput | Destructs/invalidates this ITarmedInput interface instance |
[get/put] ExternalFactor_MT | Get and set the external scaling factor for the MT services |
[get/put] ExternalFactor_TT | Get and set the external scaling factor for the MT services |
space |


  • ITarmedInput
  • AddDignity

ITarmedInput::AddDignity method |  |  | space
Adds the qualitative dignity for the supplied physician EAN number. PATCH: The self-declaration of the dignities controls the selection of available services. With the introduction of Tarmed 1.09, the medical TP is also affected, insofar as in the case of the dignity 3000 aka "Practical Physician" a TP reduction is automatically performed by means of the internal scaling factor. Whilst the addition of dignities enlarges to the spectrum of available services, there is a hierarchical approach regarding the TP reduction! The addition of any "FMH Specialist" dignity outdo the "Practical Physician" dignity and turns off the TP reduction! When appending the instruction "#IMPORTANT" to dignity 3000 aka "Practical Physician" the TP reduction aspect is not overdo by a "FMH Specialist" dignity. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ITarmedInput/AddDignity
[JSON input data] | pITarmedInput: bstrEanNumber: bstrQLCode: | longValue, //interface address "utf8StringValue", "utf8StringValue"
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT AddDignity( | BSTR BSTR VARIANT_BOOL | bstrEanNumber, bstrQLCode, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrEanNumber | EAN number of the physician. |
[in] BSTR | bstrQLCode | Qualitative dignity code (cf. ICatalog methods for human readable dignity code translations). PATCH: dignity code 3000 can be appended with "#IMPORTANT" to keep the TP reduction aspect valid. #SB to retrieve the service block numbers |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ITarmedInput
  • AddSection

ITarmedInput::AddSection method |  |  | space
Adds the service location section. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ITarmedInput/AddSection
[JSON input data] | pITarmedInput: bstrEanNumber: bstrCode: | longValue, //interface address "utf8StringValue", "utf8StringValue"
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT AddSection( | BSTR BSTR VARIANT_BOOL | bstrEanNumber, bstrCode, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrEanNumber | EAN number of the section. |
[in] BSTR | bstrCode | Section code (see ICatalog interface). |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ITarmedInput
  • GetAbortInfo

ITarmedInput::GetAbortInfo method |  |  | space
Get the abort information. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ITarmedInput/GetAbortInfo
[JSON input data] | pITarmedInput: | longValue, //interface address
[JSON result data] | pbstrAbort: pbStatus: | "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetAbortInfo( | BSTR VARIANT_BOOL | *pbstrAbort, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrAbort | Abort information string. If the abort string is empty then there is no error condition - S_FALSE was set (e.g. in an iterator to signal end_of_data) |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ITarmedInput
  • GetDignities

ITarmedInput::GetDignities method |  |  | space
This method has a Restful Webservice representation only! Method for collecting all filtered dignity information inputted so far by AddDignity in one call without the necessity to call iterator pair GetFirstDignity / GetNextDignity. The services are returned as JSON array however large that search space might be. So this might be a memory and performance bottleneck. PATCH to request information if a given qualitative dignity qualifies as "FMH Specialist" dignity or not (cf. bstrCode argument). |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ITarmedInput/GetDignities
[JSON input data] | pITarmedInput: bstrEanNumber: bstrQLCode: | longValue, //interface address "utf8StringValue", "utf8StringValue"
[JSON result array] | { pbstrEanNumber: pbstrQLCode: pbStatus: | "utf8StringValue", "utf8StringValue", booleanValue },
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Calling argument description |  |  |
[in] BSTR | bstrEanNumber | Search filter for the EAN to willingly limit the search space. Supply an empty variable to avoid a filter. |
[in] BSTR | bstrQLCode | Search filter for the qualitative dignity to willingly limit the search space. Supply an empty variable to avoid a filter. |
[out] BSTR | *pbstrEanNumber | EAN number. |
[out] BSTR | *pbstrQLCode | Qualitative dignity code. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ITarmedInput
  • GetFirstDignity

ITarmedInput::GetFirstDignity method |  |  | space
Retrieves the first dignity information. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ITarmedInput/GetFirstDignity
[JSON input data] | pITarmedInput: bstrEanNumber: bstrQLCode: | longValue, //interface address "utf8StringValue", "utf8StringValue"
[JSON result data] | pbstrEanNumber: pbstrQLCode: pbStatus: | "utf8StringValue", "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetFirstDignity( | BSTR BSTR BSTR BSTR VARIANT_BOOL | bstrEanNumber, bstrQLCode, *pbstrEanNumber, *pbstrQLCode, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrEanNumber | Search filter for the EAN to willingly limit the search space. Supply an empty variable to avoid a filter. |
[in] BSTR | bstrQLCode | Search filter for the qualitative dignity to willingly limit the search space. Supply an empty variable to avoid a filter. |
[out] BSTR | *pbstrEanNumber | EAN number. |
[out] BSTR | *pbstrQLCode | Qualitative dignity code. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ITarmedInput
  • GetFirstSection

ITarmedInput::GetFirstSection method |  |  | space
Retrieves the first section information. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ITarmedInput/GetFirstSection
[JSON input data] | pITarmedInput: bstrEanNumber: bstrCode: | longValue, //interface address "utf8StringValue", "utf8StringValue"
[JSON result data] | pbstrEanNumber: pbstrCode: pbStatus: | "utf8StringValue", "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetFirstSection( | BSTR BSTR BSTR BSTR VARIANT_BOOL | bstrEanNumber, bstrCode, *pbstrEanNumber, *pbstrCode, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrEanNumber | Search filter for the EAN to willingly limit the search space. Supply an empty variable to avoid a filter. |
[in] BSTR | bstrCode | Search filter for the section code to willingly limit the search space. Supply an empty variable to avoid a filter. |
[out] BSTR | *pbstrEanNumber | EAN section number. |
[out] BSTR | *pbstrCode | Section code. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ITarmedInput
  • GetNextDignity

ITarmedInput::GetNextDignity method |  |  | space
Retrieves the next dignity information. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ITarmedInput/GetNextDignity
[JSON input data] | pITarmedInput: | longValue, //interface address
[JSON result data] | pbstrEanNumber: pbstrQLCode: pbStatus: | "utf8StringValue", "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetNextDignity( | BSTR BSTR VARIANT_BOOL | *pbstrEanNumber, *pbstrQLCode, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrEanNumber | EAN number. |
[out] BSTR | *pbstrQLCode | Qualitative dignity code. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ITarmedInput
  • GetNextSection

ITarmedInput::GetNextSection method |  |  | space
Retrieves the next section information. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ITarmedInput/GetNextSection
[JSON input data] | pITarmedInput: | longValue, //interface address
[JSON result data] | pbstrEanNumber: pbstrCode: pbStatus: | "utf8StringValue", "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetNextSection( | BSTR BSTR VARIANT_BOOL | *pbstrEanNumber, *pbstrCode, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrEanNumber | EAN section number. |
[out] BSTR | *pbstrCode | Section code. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ITarmedInput
  • GetPatient

ITarmedInput::GetPatient method |  |  | space
Get the patient input data. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ITarmedInput/GetPatient
[JSON input data] | pITarmedInput: | longValue, //interface address
[JSON result data] | pdBirthdate: peSex: pbStatus: | "stringISODateValue", longValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetPatient( | DATE SexType VARIANT_BOOL | *pdBirthdate, *peSex, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] DATE | *pdBirthdate | Patient"s birth date. |
[out] SexType | *peSex | Sex type. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ITarmedInput
  • GetPhysician

ITarmedInput::GetPhysician method |  |  | space
Get the physician input data. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ITarmedInput/GetPhysician
[JSON input data] | pITarmedInput: | longValue, //interface address
[JSON result data] | peMedicalRole: peBillingRole: pbstrEanNumberProvider: pbstrEanNumberResponsible: pbStatus: | longValue, longValue, "utf8StringValue", "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetPhysician( | MedicalRoleType BillingRoleType BSTR BSTR VARIANT_BOOL | *peMedicalRole, *peBillingRole, *pbstrEanNumberProvider, *pbstrEanNumberResponsible, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] MedicalRoleType | *peMedicalRole | Medical role type. |
[out] BillingRoleType | *peBillingRole | Billing role type. |
[out] BSTR | *pbstrEanNumberProvider | EAN number of the service provider. |
[out] BSTR | *pbstrEanNumberResponsible | EAN number of the responsible physician |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ITarmedInput
  • GetSections

ITarmedInput::GetSections method |  |  | space
This method has a Restful Webservice representation only! Method for collecting all filtered section information inputted so far by AddSection in one call without the necessity to call iterator pair GetFirstSection / GetNextSection. The services are returned as JSON array however large that search space might be. So this might be a memory and performance bottleneck. PATCH to request information if a given qualitative dignity qualifies as "FMH Specialist" dignity or not (cf. bstrCode argument). |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ITarmedInput/GetSections
[JSON input data] | pITarmedInput: bstrEanNumber: bstrCode: | longValue, //interface address "utf8StringValue", "utf8StringValue"
[JSON result array] | { pbstrEanNumber: pbstrCode: pbStatus: | "utf8StringValue", "utf8StringValue", booleanValue },
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Calling argument description |  |  |
[in] BSTR | bstrEanNumber | Search filter for the EAN to willingly limit the search space. Supply an empty variable to avoid a filter. |
[in] BSTR | bstrCode | Search filter for the section code to willingly limit the search space. Supply an empty variable to avoid a filter. |
[out] BSTR | *pbstrEanNumber | EAN section number. |
[out] BSTR | *pbstrCode | Section code. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ITarmedInput
  • GetTreatment

ITarmedInput::GetTreatment method |  |  | space
Get the treatment input data. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ITarmedInput/GetTreatment
[JSON input data] | pITarmedInput: | longValue, //interface address
[JSON result data] | peCanton: peLaw: peType: peSettlement: pbstrEanNumberSection: pbStatus: | longValue, longValue, longValue, longValue, "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetTreatment( | CantonType LawType TreatmentType SettlementType BSTR VARIANT_BOOL | *peCanton, *peLaw, *peType, *peSettlement, *pbstrEanNumberSection, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] CantonType | *peCanton | Canton type. |
[out] LawType | *peLaw | Law type. |
[out] TreatmentType | *peType | Treatment type. |
[out] SettlementType | *peSettlement | Settlement type. |
[out] BSTR | *pbstrEanNumberSection | EAN number of the section. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ITarmedInput
  • InitDignity

ITarmedInput::InitDignity method |  |  | space
Initializes the dignity-relevant input data. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ITarmedInput/InitDignity
[JSON input data] | pITarmedInput: | longValue, //interface address
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT InitDignity( | VARIANT_BOOL | *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ITarmedInput
  • Initialize

ITarmedInput::Initialize method |  |  | space
Initializes the input data. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ITarmedInput/Initialize
[JSON input data] | pITarmedInput: | longValue, //interface address
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT Initialize( | VARIANT_BOOL | *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ITarmedInput
  • InitSection

ITarmedInput::InitSection method |  |  | space
Initializes the section-relevant input data. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ITarmedInput/InitSection
[JSON input data] | pITarmedInput: | longValue, //interface address
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT InitSection( | VARIANT_BOOL | *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ITarmedInput
  • SetPatient

ITarmedInput::SetPatient method |  |  | space
Set the patient input data. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ITarmedInput/SetPatient
[JSON input data] | pITarmedInput: dBirthdate: eSex: | longValue, //interface address variantDateValue | "stringISODateValue", longValue
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT SetPatient( | DATE SexType VARIANT_BOOL | dBirthdate, eSex, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] DATE | dBirthdate | Patient"s birth date. |
[in] SexType | eSex | Sex type. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ITarmedInput
  • SetPhysician

ITarmedInput::SetPhysician method |  |  | space
Set the physician input data. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ITarmedInput/SetPhysician
[JSON input data] | pITarmedInput: eMedicalRole: eBillingRole: bstrEanNumberProvider: bstrEanNumberResponsible: | longValue, //interface address longValue, longValue, "utf8StringValue", "utf8StringValue"
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT SetPhysician( | MedicalRoleType BillingRoleType BSTR BSTR VARIANT_BOOL | eMedicalRole, eBillingRole, bstrEanNumberProvider, bstrEanNumberResponsible, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] MedicalRoleType | eMedicalRole | Medical role type. |
[in] BillingRoleType | eBillingRole | Billing role type. |
[in] BSTR | bstrEanNumberProvider | EAN number of the provider. |
[in] BSTR | bstrEanNumberResponsible | EAN number of the responsible physician. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ITarmedInput
  • SetTreatment

ITarmedInput::SetTreatment method |  |  | space
Set the treatment input data. PATCH Due to the disagreement between the tariff partners in the social insurance area, Tarmed 1.09 cannot be introduced uniformly as of April 1, 2018. This patch describes how to externally set the validity barrier between Tarmed 1.08BR and Tarmed 1.09 UV/IV/MV by using the bstrEanNumberSection variable. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ITarmedInput/SetTreatment
[JSON input data] | pITarmedInput: eCanton: eLaw: eType: eSettlement: bstrEanNumberSection: | longValue, //interface address longValue, longValue, longValue, longValue, "utf8StringValue"
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT SetTreatment( | CantonType LawType TreatmentType SettlementType BSTR VARIANT_BOOL | eCanton, eLaw, eType, eSettlement, bstrEanNumberSection, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] CantonType | eCanton | Canton type. |
[in] LawType | eLaw | Law type. |
[in] TreatmentType | eType | Treatment type. |
[in] SettlementType | eSettlement | Settlement type. |
[in] BSTR | bstrEanNumberSection | EAN number of the section - leave empty if the section concept is unused. PATCH Append the validity barrier '#VB109=dd.mm.yyyy' to the bstrEanNumberSection variable, where the patch is case-insensitive and applicable for eLaw = UV|MV|IV only. By defining the validity barrier, the tarmedValidator automatically switches between the two Tarmed versions UV/IV/MV and its different rule spaces. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ITarmedInput
  • DestructTarmedInput

ITarmedInput::DestructTarmedInput property |  |  | space
This property has a Restful Webservice representation only! Destructs/invalidates this ITarmedInput interface instance. The counterpart property to generate an ITarmedInput interface instance is ITarmedValidator::GetCreateTarmedInput. |  |  |
space
Restful webservice calling syntax |  |  |
[PUT] | /baseURL/ ITarmedInput/PutDestructTarmedInput
[JSON input data] | pITarmedInput: eDestructTarmedInput: | longValue, //interface address longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Remarks |  |  |
This property has a Restful Webservice representation only! |  |  |
space |


  • ITarmedInput
  • ExternalFactor_MT

ITarmedInput::ExternalFactor_MT property | space
Get and set the external scaling factor for the MT services.

PATCH:
A positive external scaling factor f(ex,MT|TT)=number will be interpreted as external scaling factor.
A negative external scaling factor f(ex,MT|TT)= -number will be interpreted as a tax point value (TPV) of type MT|TT and f(ex,MT|TT)=1 is set and used internally and given back as value.
If no external scaling factor is defined, the normal procedure is applied with a default TPV=1.

REASONING FOR THE PATCH:
Since the tax point value (TPV) can not be set with the current interface methods and the publication date of the official TPV table is unclear at the moment, the meaning of the external factors is patched!!
The patch therefore allows for a self declaration system of TPVs.
space
Restful webservice calling syntax
[GET] | /baseURL/ ITarmedInput/GetExternalFactor_MT?param
[param] pITarmedInput= longValue
[JSON result data] pdExternalFactor_MT: doubleValue
[PUT] | /baseURL/ ITarmedInput/PutExternalFactor_MT
[JSON input data] pITarmedInput:
dExternalFactor_MT: 		longValue, //interface address
doubleValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | ExternalFactor_MT( double *pdExternalFactor_MT );
[put] HRESULT | ExternalFactor_MT( double dExternalFactor_MT );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] double | *pdExternalFactor_MT | The external scaling factor of the medical part of the current service
[in] double | dExternalFactor_MT | The external scaling factor of the medical part of the current service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • double *GetExternalFactor_MT(void);
  • void PutExternalFactor_MT( double dExternalFactor_MT);
space


  • ITarmedInput
  • ExternalFactor_TT

ITarmedInput::ExternalFactor_TT property | space
Get and set the external scaling factor for the MT services.

PATCH:
A positive external scaling factor f(ex,MT|TT)=number will be interpreted as external scaling factor.
A negative external scaling factor f(ex,MT|TT)= -number will be interpreted as a tax point value (TPV) of type MT|TT and f(ex,MT|TT)=1 is set and used internally and given back as value.
If no external scaling factor is defined, the normal procedure is applied with a default TPV=1.

REASONING FOR THE PATCH:
Since the tax point value (TPV) can not be set with the current interface methods and the publication date of the official TPV table is unclear at the moment, the meaning of the external factors is patched!!
The patch therefore allows for a self declaration system of TPVs.
space
Restful webservice calling syntax
[GET] | /baseURL/ ITarmedInput/GetExternalFactor_TT?param
[param] pITarmedInput= longValue
[JSON result data] pdExternalFactor_TT: doubleValue
[PUT] | /baseURL/ ITarmedInput/PutExternalFactor_TT
[JSON input data] pITarmedInput:
dExternalFactor_TT: 		longValue, //interface address
doubleValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | ExternalFactor_TT( double *pdExternalFactor_TT );
[put] HRESULT | ExternalFactor_TT( double dExternalFactor_TT );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] double | *pdExternalFactor_TT | The external scaling factor of the technical part of the current service
[in] double | dExternalFactor_TT | The external scaling factor of the technical part of the current service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • double *GetExternalFactor_TT(void);
  • void PutExternalFactor_TT( double dExternalFactor_TT);
space


  • ITarmedValidator

ITarmedValidator interface |  | V1.00/30 Aug 2002
The ITarmedValidator interface handles connections to the Tarmed database. It provides a means to open and close database connections, and set and retrieve general database parameters, such as the database or module versions. A connection to the database must be opened via ITarmedValidator before methods from any of the other interfaces can be used. |  | space
space
Methods |  | 4 methods
Close | Closes the Tarmed database. |
GetAbortInfo | Get the abort information. |
Open | Opens the Tarmed database. |
OpenEx | Opens the Tarmed database. |
space
Properties |  | 22 properties
[get] CreateCatalog | Create an instance of the ICatalog interface. |
[get] CreateSearch | Create an instance of the ISearch interface. |
[get] CreateTarmedInput | Create an instance of the ITarmedInput interface. |
[get] CreateTarmedValidator | Creates an instance of the main ITarmedValidator interface |
[get] CreateUtility | Create an instance of the IUtility interface. |
[get] CreateValidate | Create an instance of the IValidate interface. |
[get/put] Date | Get and Set the current date for the TarmedValidator module |
[get] DBVersion | Get the version of the TarmedValidator database. |
[get] DBVersionDate | Get the version date of the TarmedValidator database. |
[get] DBVersionText | Get the textual version of the TarmedValidator database. |
[put] DestructCatalog | Destructs/invalidates this ICatalog interface instance |
[put] DestructSearch | Destructs/invalidates this ISearch interface instance |
[put] DestructTarmedInput | Destructs/invalidates this ITarmedInput interface instance |
[put] DestructTarmedValidator | Destructs/invalidates a main instance of the ITarmedValidator interface |
[put] DestructUtility | Destructs/invalidates this IUtility interface instance |
[put] DestructValidate | Destructs/invalidates this IValidate interface instance |
[get/put] EnableLog | Get and Set the log activity for the module |
[get/put] Language | Get and Set the language for the TarmedValidator module |
[get] ModuleVersion | Get the version of the tarmedValidator module. |
[get] ModuleVersionText | Get the textual version of the TarmedValidator module. |
[get/put] WildCard | Get and Set the match-all wildcard character for SQL queries |
[get/put] WildCharacter | Get and Set the "match any single character" wildcard character for SQL queries |
space |


  • ITarmedValidator
  • Close

ITarmedValidator::Close method |  |  | space
Closes the Tarmed database. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ITarmedValidator/Close
[JSON input data] | pITarmedValidator: | longValue, //interface address
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT Close( | VARIANT_BOOL | *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ITarmedValidator
  • GetAbortInfo

ITarmedValidator::GetAbortInfo method |  |  | space
Get the abort information. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ITarmedValidator/GetAbortInfo
[JSON input data] | pITarmedValidator: | longValue, //interface address
[JSON result data] | pbstrAbort: pbStatus: | "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetAbortInfo( | BSTR VARIANT_BOOL | *pbstrAbort, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrAbort | Abort information string. If the abort string is empty then there is no error condition - S_FALSE was set (e.g. in an iterator to signal end_of_data) |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ITarmedValidator
  • Open

ITarmedValidator::Open method |  |  | space
Opens the Tarmed database. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ITarmedValidator/Open
[JSON input data] | pITarmedValidator: eLanguage: | longValue, //interface address longValue
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT Open( | LanguageType VARIANT_BOOL | eLanguage, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] LanguageType | eLanguage | The choosen language of the tariff that should be opened |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ITarmedValidator
  • OpenEx

ITarmedValidator::OpenEx method |  |  | space
Opens the Tarmed database. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ITarmedValidator/OpenEx
[JSON input data] | pITarmedValidator: bstrConnect: | longValue, //interface address "utf8StringValue"
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT OpenEx( | BSTR VARIANT_BOOL | bstrConnect, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrConnect | Connect string for the database. See the Open method for the ADO Connection object for a detailed description. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ITarmedValidator
  • CreateCatalog

ITarmedValidator::CreateCatalog property | space
Create an instance of the ICatalog interface.
space
Restful webservice calling syntax
[GET] | /baseURL/ ITarmedValidator/GetCreateCatalog?param
[param] pITarmedValidator= longValue
[JSON result data] peCreateCatalog: longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | CreateCatalog( ICatalog **peCreateCatalog );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] ICatalog | **peCreateCatalog | The created instance of the Icatalog interface
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • ICatalog **GetCreateCatalog(void);
space


  • ITarmedValidator
  • CreateSearch

ITarmedValidator::CreateSearch property | space
Create an instance of the ISearch interface.
space
Restful webservice calling syntax
[GET] | /baseURL/ ITarmedValidator/GetCreateSearch?param
[param] pITarmedValidator= longValue
[JSON result data] pISearch: longValue //interface address
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | CreateSearch( ISearch **peCreateSearch );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] ISearch | **peCreateSearch | The created instance of the Isearch interface
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • ISearch **GetCreateSearch(void);
space


  • ITarmedValidator
  • CreateTarmedInput

ITarmedValidator::CreateTarmedInput property | space
Create an instance of the ITarmedInput interface.
space
Restful webservice calling syntax
[GET] | /baseURL/ ITarmedValidator/GetCreateTarmedInput?param
[param] pITarmedValidator= longValue
[JSON result data] peCreateTarmedInput: longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | CreateTarmedInput( ITarmedInput **peCreateTarmedInput );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] ITarmedInput | **peCreateTarmedInput | The created instance of the ITarmedInput interface
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • ITarmedInput **GetCreateTarmedInput(void);
space


  • ITarmedValidator
  • CreateTarmedValidator

ITarmedValidator::CreateTarmedValidator property |  |  | space
This property has a Restful Webservice representation only! Creates an instance of the main ITarmedValidator interface. To delete/invalidate this interface instance, the counterpart property PutDestructTarmedValidator must be explicitly called, since the pITarmedValidator address has a global scope and is not automatically destructed. |  |  |
space
Restful webservice calling syntax |  |  |
[GET] | /baseURL/ ITarmedValidator/GetCreateTarmedValidator
[JSON result data] | pITarmedValidator: | longValue //interface address
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Remarks |  |  |
This property has a Restful Webservice representation only! |  |  |
space |


  • ITarmedValidator
  • CreateUtility

ITarmedValidator::CreateUtility property | space
Create an instance of the IUtility interface.
space
Restful webservice calling syntax
[GET] | /baseURL/ ITarmedValidator/GetCreateUtility?param
[param] pITarmedValidator= longValue
[JSON result data] peCreateUtility: longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | CreateUtility( IUtility **peCreateUtility );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] IUtility | **peCreateUtility | The created instance of the Iutility interface
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • IUtility **GetCreateUtility(void);
space


  • ITarmedValidator
  • CreateValidate

ITarmedValidator::CreateValidate property | space
Create an instance of the IValidate interface.
space
Restful webservice calling syntax
[GET] | /baseURL/ ITarmedValidator/GetCreateValidate?param
[param] pITarmedValidator= longValue
[JSON result data] pIValidate: longValue //interface address
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | CreateValidate( IValidate **peCreateValidate );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] IValidate | **peCreateValidate | The created instance of the IValidate interface
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • IValidate **GetCreateValidate(void);
space


  • ITarmedValidator
  • Date

ITarmedValidator::Date property | space
Get and Set the current date for the TarmedValidator module.

This date will be used for each method where no explicit date must be specified, for example the SearchCode method in the ISearch interface. The default is the current date.
space
Restful webservice calling syntax
[GET] | /baseURL/ ITarmedValidator/GetDate?param
[param] pITarmedValidator= longValue
[JSON result data] pdDate: "stringISODateValue"
[PUT] | /baseURL/ ITarmedValidator/PutDate
[JSON input data] pITarmedValidator:
dDate: 		longValue, //interface address
variantDateValue | "stringISODateValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Date( DATE *pdDate );
[put] HRESULT | Date( DATE dDate );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] DATE | *pdDate | The defined date of the current service
[in] DATE | dDate | The defined date of the current service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • DATE *GetDate(void);
  • void PutDate( DATE dDate);
space


  • ITarmedValidator
  • DBVersion

ITarmedValidator::DBVersion property | space
Get the version of the TarmedValidator database.
space
Restful webservice calling syntax
[GET] | /baseURL/ ITarmedValidator/GetDBVersion?param
[param] pITarmedValidator= longValue
[JSON result data] pbstrDBVersion: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | DBVersion( BSTR *pbstrDBVersion );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrDBVersion | The version of the currently open database
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetDBVersion(void);
space


  • ITarmedValidator
  • DBVersionDate

ITarmedValidator::DBVersionDate property | space
Get the version date of the TarmedValidator database.
space
Restful webservice calling syntax
[GET] | /baseURL/ ITarmedValidator/GetDBVersionDate?param
[param] pITarmedValidator= longValue
[JSON result data] pdDBVersionDate: "stringISODateValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | DBVersionDate( DATE *pdDBVersionDate );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] DATE | *pdDBVersionDate | The version of the currently open database
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • DATE *GetDBVersionDate(void);
space


  • ITarmedValidator
  • DBVersionText

ITarmedValidator::DBVersionText property | space
Get the textual version of the TarmedValidator database.
space
Restful webservice calling syntax
[GET] | /baseURL/ ITarmedValidator/GetDBVersionText?param
[param] pITarmedValidator= longValue
[JSON result data] pbstrDBVersionText: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | DBVersionText( BSTR *pbstrDBVersionText );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrDBVersionText | The textual version of the currently open database
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetDBVersionText(void);
space


  • ITarmedValidator
  • DestructCatalog

ITarmedValidator::DestructCatalog property |  |  | space
This property has a Restful Webservice representation only! Destructs/invalidates this ICatalog interface instance. The counterpart property to generate an ICatalog interface instance is ITarmedValidator::GetCreateCatalog. |  |  |
space
Restful webservice calling syntax |  |  |
[PUT] | /baseURL/ ITarmedValidator/PutDestructCatalog
[JSON input data] | pITarmedValidator: eDestructCatalog: | longValue, //interface address longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Remarks |  |  |
This property has a Restful Webservice representation only! |  |  |
space |


  • ITarmedValidator
  • DestructSearch

ITarmedValidator::DestructSearch property |  |  | space
This property has a Restful Webservice representation only! Destructs/invalidates this ISearch interface instance. The counterpart property to generate an ISearch interface instance is ITarmedValidator::GetCreateSearch. |  |  |
space
Restful webservice calling syntax |  |  |
[PUT] | /baseURL/ ITarmedValidator/PutDestructSearch
[JSON input data] | pITarmedValidator: pISearch: | longValue, //interface address longValue, //interface address
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Remarks |  |  |
This property has a Restful Webservice representation only! |  |  |
space |


  • ITarmedValidator
  • DestructTarmedInput

ITarmedValidator::DestructTarmedInput property |  |  | space
This property has a Restful Webservice representation only! Destructs/invalidates this ITarmedInput interface instance. The counterpart property to generate an ITarmedInput interface instance is ITarmedValidator::GetCreateTarmedInput. |  |  |
space
Restful webservice calling syntax |  |  |
[PUT] | /baseURL/ ITarmedValidator/PutDestructTarmedInput
[JSON input data] | pITarmedValidator: eDestructTarmedInput: | longValue, //interface address longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Remarks |  |  |
This property has a Restful Webservice representation only! |  |  |
space |


  • ITarmedValidator
  • DestructTarmedValidator

ITarmedValidator::DestructTarmedValidator property |  |  | space
This property has a Restful Webservice representation only! Destructs/invalidates a main instance of the ITarmedValidator interface. Please note, that all dependent, active interface instances generated with ITarmedValidator::GetCreateValidate, ITarmedValidator::GetCreateCatalog, ITarmedValidator::GetCreateUtility, ITarmedValidator::GetCreateTarmedInput and/or ITarmedSearch::GetCreateSearch under this main instances, are automatically destructed as well. The counterpart property to generate a main interface instance is ITarmedValidator::GetCreateTarmedValidator. |  |  |
space
Restful webservice calling syntax |  |  |
[PUT] | /baseURL/ ITarmedValidator/PutDestructTarmedValidator
[JSON input data] | pITarmedValidator: | longValue, //interface address
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Remarks |  |  |
This property has a Restful Webservice representation only! |  |  |
space |


  • ITarmedValidator
  • DestructUtility

ITarmedValidator::DestructUtility property |  |  | space
This property has a Restful Webservice representation only! Destructs/invalidates this IUtility interface instance. The counterpart property to generate an IUtility interface instance is ITarmedValidator::GetCreateUtility. |  |  |
space
Restful webservice calling syntax |  |  |
[PUT] | /baseURL/ ITarmedValidator/PutDestructUtility
[JSON input data] | pITarmedValidator: eDestructUtility: | longValue, //interface address longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Remarks |  |  |
This property has a Restful Webservice representation only! |  |  |
space |


  • ITarmedValidator
  • DestructValidate

ITarmedValidator::DestructValidate property |  |  | space
This property has a Restful Webservice representation only! Destructs/invalidates this IValidate interface instance. The counterpart property to generate an IValidate interface instance is ITarmedValidator::GetCreateValidate. |  |  |
space
Restful webservice calling syntax |  |  |
[PUT] | /baseURL/ ITarmedValidator/PutDestructValidate
[JSON input data] | pITarmedValidator: pIValidate: | longValue, //interface address longValue, //interface address
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Remarks |  |  |
This property has a Restful Webservice representation only! |  |  |
space |


  • ITarmedValidator
  • EnableLog

ITarmedValidator::EnableLog property | space
Get and Set the log activity for the module. The default log activity is enYes.
space
Restful webservice calling syntax
[GET] | /baseURL/ ITarmedValidator/GetEnableLog?param
[param] pITarmedValidator= longValue
[JSON result data] peEnableLog: longValue
[PUT] | /baseURL/ ITarmedValidator/PutEnableLog
[JSON input data] pITarmedValidator:
eEnableLog: 		longValue, //interface address
longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | EnableLog( YesNoType *peEnableLog );
[put] HRESULT | EnableLog( YesNoType eEnableLog );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] YesNoType | *peEnableLog | Boolean that defines if the logging is enabled (enYes) or not (enNo)
[in] YesNoType | eEnableLog | Boolean that defines if the logging is enabled (enYes) or not (enNo)
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • YesNoType *GetEnableLog(void);
  • void PutEnableLog( YesNoType lEnableLog);
space


  • ITarmedValidator
  • Language

ITarmedValidator::Language property | space
Get and Set the language for the TarmedValidator module. The default language is enGerman.
space
Restful webservice calling syntax
[GET] | /baseURL/ ITarmedValidator/GetLanguage?param
[param] pITarmedValidator= longValue
[JSON result data] peLanguage: longValue
[PUT] | /baseURL/ ITarmedValidator/PutLanguage
[JSON input data] pITarmedValidator:
eLanguage: 		longValue, //interface address
longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Language( LanguageType *peLanguage );
[put] HRESULT | Language( LanguageType eLanguage );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] LanguageType | *peLanguage | The language for the main interface defining the language of the error messages
[in] LanguageType | eLanguage | The language for the main interface defining the language of the error messages
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • LanguageType *GetLanguage(void);
  • void PutLanguage( LanguageType lLanguage);
space


  • ITarmedValidator
  • ModuleVersion

ITarmedValidator::ModuleVersion property | space
Get the version of the tarmedValidator module.
space
Restful webservice calling syntax
[GET] | /baseURL/ ITarmedValidator/GetModuleVersion?param
[param] pITarmedValidator= longValue
[JSON result data] pbstrModuleVersion: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | ModuleVersion( BSTR *pbstrModuleVersion );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrModuleVersion | The module version of the tarmedValidator module
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetModuleVersion(void);
space


  • ITarmedValidator
  • ModuleVersionText

ITarmedValidator::ModuleVersionText property | space
Get the textual version of the TarmedValidator module.
space
Restful webservice calling syntax
[GET] | /baseURL/ ITarmedValidator/GetModuleVersionText?param
[param] pITarmedValidator= longValue
[JSON result data] pbstrModuleVersionText: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | ModuleVersionText( BSTR *pbstrModuleVersionText );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrModuleVersionText | The module version string of the tarmedValidator module
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetModuleVersionText(void);
space


  • ITarmedValidator
  • WildCard

ITarmedValidator::WildCard property | space
Get and Set the match-all wildcard character for SQL queries. You can use this property if you have imported the original Tarmed database into another database, which uses a different wildcard character for queries. The default match-all wildcard character is the percent symbol (%). With the TarmedValidator Module you can always formulate a query using the asterisk symbol (*) as a wildcard, as in each query string a * is replaced by the wildcard character specified by this property before being executed.
space
Restful webservice calling syntax
[GET] | /baseURL/ ITarmedValidator/GetWildCard?param
[param] pITarmedValidator= longValue
[JSON result data] pbstrWildCard: "utf8StringValue"
[PUT] | /baseURL/ ITarmedValidator/PutWildCard
[JSON input data] pITarmedValidator:
bstrWildCard: 		longValue, //interface address
"utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | WildCard( BSTR *pbstrWildCard );
[put] HRESULT | WildCard( BSTR bstrWildCard );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrWildCard | The wildcard symbol
[in] BSTR | bstrWildCard | The wildcard symbol
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetWildCard(void);
  • void PutWildCard( BSTR bstrWildCard);
space


  • ITarmedValidator
  • WildCharacter

ITarmedValidator::WildCharacter property | space
Get and Set the "match any single character" wildcard character for SQL queries. You can use this property if you have ported the original Tarmed database into another database, which uses a different wild character for the queries. The default match-single-character wildcard character is the underscore symbol (_). With the TarmedValidator Module you can always formulate a query using the question mark (?) as a wildcard, as in each query string a ? is replaced by the wildcard character specified by this property before execution.
space
Restful webservice calling syntax
[GET] | /baseURL/ ITarmedValidator/GetWildCharacter?param
[param] pITarmedValidator= longValue
[JSON result data] pbstrWildCharacter: "utf8StringValue"
[PUT] | /baseURL/ ITarmedValidator/PutWildCharacter
[JSON input data] pITarmedValidator:
bstrWildCharacter: 		longValue, //interface address
"utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | WildCharacter( BSTR *pbstrWildCharacter );
[put] HRESULT | WildCharacter( BSTR bstrWildCharacter );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrWildCharacter | The wildcard character symbol
[in] BSTR | bstrWildCharacter | The wildcard character symbol
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetWildCharacter(void);
  • void PutWildCharacter( BSTR bstrWildCharacter);
space


  • IUtility

IUtility interface |  | V1.00/30 Aug 2002
The IUtility interface automatically generates a service record for a given code. For example, a record describing a consultation of n minutes will automatically be constructed according to the Tarmed rules. The anaesthesia rules are also covered. |  | space
space
Methods |  | 22 methods
Anaesthesia | Determines the anaesthesia records corresponding to the specified code |
EmergencyAdmission | Finds the emergency admission records. |
EmergencyInconvenience | Finds the emergency inconvenience |
Expand | Expands the given main code, according to the supplied number and as multiples of the base unit |
GetAbortInfo | Get the abort information. |
GetAnaesthesiaRecords | Method for collecting all anaesthesia records resulting from the Anaesthesia search method in one call without the necessity to call iterator pair GetFirstEmergencyInconvenienceRecord / GetNextEmergencyInconvenienceRecord |
GetEmergencyAdmissionRecords | Method for collecting all emergency admission records resulting from the EmergencyAdmission search method in one call without the necessity to call iterator pair GetFirstEmergencyAdmissionRecord / GetNextEmergencyAdmissionRecord |
GetEmergencyInconvenienceRecords | Method for collecting all emergency inconvenience records resulting from the EmergencyInconvenience search method in one call without the necessity to call iterator pair GetFirstEmergencyInconvenienceRecord / GetNextEmergencyInconvenienceRecord |
GetExpandRecords | Method for collecting all expanded records resulting from the Expand search method in one call without the necessity to call iterator pair GetFirstExpandRecord / GetNextExpandRecord |
GetFirstAnaesthesiaRecord | Gets the first anaesthesia record |
GetFirstEmergencyAdmissionRecord | Gets the first emergency admission record. |
GetFirstEmergencyInconvenienceRecord | Gets the first emergency inconvenience record. |
GetFirstExpandRecord | Gets the first expanded record |
GetFirstNoneMedicalCareRecord | Gets the first non-medical care record. |
GetNextAnaesthesiaRecord | Gets the next anaesthesia record |
GetNextEmergencyAdmissionRecord | Gets the next emergency admission record. |
GetNextEmergencyInconvenienceRecord | Gets the next emergency inconvenience record. |
GetNextExpandRecord | Gets the next expanded record. |
GetNextNoneMedicalCareRecord | Gets the next non-medical care record. |
GetNoneMedicalCareRecords | Method for collecting all non-medical care records resulting from the NoneMedicalCare search method in one call without the necessity to call iterator pair GetFirstNoneMedicalCareRecord / GetNextNoneMedicalCareRecord |
InitAnaesthesia | Initialize the anaesthesia method |
NoneMedicalCare | Finds the non-medical care records |
space
Properties |  | 1 properties
[put] DestructUtility | Destructs/invalidates this IUtility interface instance |
space |


  • IUtility
  • Anaesthesia

IUtility::Anaesthesia method |  |  | space
Determines the anaesthesia records corresponding to the specified code. If there are several codes with anaesthesia records within the same session, you have to enter all the codes using this method. When you retrieve the records with the methods GetFirstAnaesthesiaRecord or GetNextAnaesthesiaRecord, you have to discard all services with a quantity of 0. NEW FEATURE: The service code 24.0250 can now be included by appending an underscore "_" and the appropriate reference code to the service code, e.g. Anaesthesia("07.0200",....) Anaesthesia("24.0250_07.0200",....) The reference codes of the resulting anaesthesia services (fetching with IUtility::GetFirstAnaesthesiaRecord, IUtility::GetNextAnaesthesiaRecord) will contain the underscore "_" and the initial reference code as well, e.g. ("24.0250_07.0200") to define the full reference chain (strip of the reference code if you use the results in other methods like IValidate::AddService) |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IUtility/Anaesthesia
[JSON input data] | pIUtility: bstrCode: eRiskClass: dBirthdate: dDate: | longValue, //interface address "utf8StringValue", longValue, variantDateValue | "stringISODateValue", variantDateValue | "stringISODateValue"
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT Anaesthesia( | BSTR AnaesthesiaRiskClassType DATE DATE VARIANT_BOOL | bstrCode, eRiskClass, dBirthdate, dDate, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrCode | Tarmed service code. |
[in] AnaesthesiaRiskClassType | eRiskClass | Risk class type. |
[in] DATE | dBirthdate | Patient"s birth date. |
[in] DATE | dDate | Date of the service. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IUtility
  • EmergencyAdmission

IUtility::EmergencyAdmission method |  |  | space
Finds the emergency admission records. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IUtility/EmergencyAdmission
[JSON input data] | pIUtility: eEmergencyAdmission: eTreatType: dMinutesMT: dMinutesTT: dDate: | longValue, //interface address longValue, longValue, doubleValue, doubleValue, variantDateValue | "stringISODateValue"
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT EmergencyAdmission( | EmergencyAdmissionType TreatmentType double double DATE VARIANT_BOOL | eEmergencyAdmission, eTreatType, dMinutesMT, dMinutesTT, dDate, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] EmergencyAdmissionType | eEmergencyAdmission | Emergengy admission type. |
[in] TreatmentType | eTreatType | Treatment type. |
[in] double | dMinutesMT | Number of Minutes MT (physician). |
[in] double | dMinutesTT | Number of Minutes TT. |
[in] DATE | dDate | Date of the service. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IUtility
  • EmergencyInconvenience

IUtility::EmergencyInconvenience method |  |  | space
Finds the emergency inconvenience. If the emergency type is set to automatic and a code is supplied, the TarmedValidator module will choose the corresponding emergency inconvenience. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IUtility/EmergencyInconvenience
[JSON input data] | pIUtility: bstrCode: dDate: eEmergency: eHoliday: | longValue, //interface address "utf8StringValue", variantDateValue | "stringISODateValue", longValue, longValue
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT EmergencyInconvenience( | BSTR DATE EmergencyType YesNoType VARIANT_BOOL | bstrCode, dDate, eEmergency, eHoliday, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrCode | Tarmed service code. |
[in] DATE | dDate | Date of the service. |
[in] EmergencyType | eEmergency | Emergency type. |
[in] YesNoType | eHoliday | Flag which indicates whether the specified date is a holiday. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IUtility
  • Expand

IUtility::Expand method | space
Expands the given main code, according to the supplied number and as multiples of the base unit.

PATCH:
  • If the instruction "#noTimeLimit" is appended to the service code (e.g. "00.0010#noTimeLimit"), then a full expansion without obeying any time restrictions or limits is performed.

    A suchwise generated expansion of a service chain might of course provoke validation errors and then generates messages about the violation of the quantity limit! The newly built-in
    time restrictions of Tarmed 1.09 are thus made "visible" and the over time is not silently discarded.
  • If the instruction #INFO is appened to the service code (e.g. "00.0010#INFO") the IUtility::GetFirstExpandRecord method returns "non-expandable, dropped" fraction too large for a full expansion under the current rule regime.

    For example, after expanding IUtility::Expand("00.0010#INFO",23,) under a "paper limits", the method IUtility::GetFirstExpandRecord returns "00.0010#INFO3" as code meaning that 3 min out of 23 min are not applicable (aka dropped) within the current TarMed rule set regime.
space
Restful webservice calling syntax
[POST] | /baseURL/ IUtility/Expand
[JSON input data] pIUtility:
bstrCode:
dNumber:
dDate:
eSettlement: 		longValue, //interface address
"utf8StringValue",
doubleValue,
variantDateValue | "stringISODateValue",
longValue
[JSON result data] pbStatus: booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
HRESULT Expand( BSTR
double
DATE
SettlementType
VARIANT_BOOL 		bstrCode,
dNumber,
dDate,
eSettlement,
*pbStatus);
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[in] BSTR bstrCode Tarmed main service code

Patch:
  • bstrCode can be appended with #noTimeLimit to fully expand the service chain without any time restriction.
  • bstrCode can be appended with #INFO to retrieve the droped minutes in the IUtility::GetFirstExpandRecord method
[in] double dNumber Number supplied as multiples of the base unit.
For example if a consultation lasted 23 Minutes, 23 would be entered.

The base unit information for the code can be retrieved from the ISearch::GetUnit property interface.
[in] DATE | dDate | Date of the service.
[in] SettlementType | eSettlement | Settlement type.
[out,retval] VARIANT_BOOL *pbStatus Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name).
In the later case check for possible errors with the GetAbortInfo method.
space


  • IUtility
  • GetAbortInfo

IUtility::GetAbortInfo method |  |  | space
Get the abort information. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IUtility/GetAbortInfo
[JSON input data] | pIUtility: | longValue, //interface address
[JSON result data] | pbstrAbort: pbStatus: | "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetAbortInfo( | BSTR VARIANT_BOOL | *pbstrAbort, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrAbort | Abort information string. If the abort string is empty then there is no error condition - S_FALSE was set (e.g. in an iterator to signal end_of_data) |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IUtility
  • GetAnaesthesiaRecords

IUtility::GetAnaesthesiaRecords method |  |  | space
This method has a Restful Webservice representation only! Method for collecting all anaesthesia records resulting from the Anaesthesia search method in one call without the necessity to call iterator pair GetFirstEmergencyInconvenienceRecord / GetNextEmergencyInconvenienceRecord. The services are returned as JSON array however large that search space might be. So this might be a memory and performance bottleneck. Discard a record with quantity 0. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IUtility/GetAnaesthesiaRecords
[JSON input data] | pIUtility: | longValue, //interface address
[JSON result array] | { pbstrCode: pbstrReferenceCode: peAnaesthesiaCode: peAnaesthesiaRiskClass: pdQuantity: pbStatus: | "utf8StringValue", "utf8StringValue", longValue, longValue, doubleValue, booleanValue },
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrCode | Tarmed service code. |
[out] BSTR | *pbstrReferenceCode | Reference code. |
[out] AnaesthesiaCodeType | *peAnaesthesiaCode | Anaesthesia type |
[out] AnaesthesiaRiskClassType | *peAnaesthesiaRiskClass | Anaesthesia risk class. |
[out] double | *pdQuantity | Quantity. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IUtility
  • GetEmergencyAdmissionRecords

IUtility::GetEmergencyAdmissionRecords method |  |  | space
This method has a Restful Webservice representation only! Method for collecting all emergency admission records resulting from the EmergencyAdmission search method in one call without the necessity to call iterator pair GetFirstEmergencyAdmissionRecord / GetNextEmergencyAdmissionRecord. The services are returned as JSON array however large that search space might be. So this might be a memory and performance bottleneck. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IUtility/GetEmergencyAdmissionRecords
[JSON input data] | pIUtility: | longValue, //interface address
[JSON result array] | { pbstrCode: pbstrReferenceCode: pdQuantity: pbStatus: | "utf8StringValue", "utf8StringValue", doubleValue, booleanValue },
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrCode | Code of the Tarmed service. |
[out] BSTR | *pbstrReferenceCode | Reference code. |
[out] double | *pdQuantity | Quantity. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IUtility
  • GetEmergencyInconvenienceRecords

IUtility::GetEmergencyInconvenienceRecords method |  |  | space
This method has a Restful Webservice representation only! Method for collecting all emergency inconvenience records resulting from the EmergencyInconvenience search method in one call without the necessity to call iterator pair GetFirstEmergencyInconvenienceRecord / GetNextEmergencyInconvenienceRecord. The services are returned as JSON array however large that search space might be. So this might be a memory and performance bottleneck. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IUtility/GetEmergencyInconvenienceRecords
[JSON input data] | pIUtility: | longValue, //interface address
[JSON result array] | { pbstrCode: pbstrReferenceCode: pdQuantity: pbStatus: | "utf8StringValue", "utf8StringValue", doubleValue, booleanValue },
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrCode | Tarmed service code. |
[out] BSTR | *pbstrReferenceCode | Reference code. |
[out] double | *pdQuantity | Quantity. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IUtility
  • GetExpandRecords

IUtility::GetExpandRecords method |  |  | space
This method has a Restful Webservice representation only! Method for collecting all expanded records resulting from the Expand search method in one call without the necessity to call iterator pair GetFirstExpandRecord / GetNextExpandRecord. The services are returned as JSON array however large that search space might be. So this might be a memory and performance bottleneck. PATCH: If the instruction #INFO is appened to the service code in Expand("aCode#INFO",...) than the "non-expandable, dropped" fraction too large for a full expansion under the current rule regime is returned in *pbstrCode. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IUtility/GetExpandRecords
[JSON input data] | pIUtility: | longValue, //interface address
[JSON result array] | { pbstrCode: pbstrReferenceCode: pdQuantity: plID: pbStatus: | "utf8StringValue", "utf8StringValue", doubleValue, longValue, booleanValue },
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrCode | Tarmed service code. Patch: after expanding IUtility::Expand("00.0010#INFO",23,) under "paper limits", the returned service code is "00.0010#INFO3" meaning that 3 min out of 23 min are not applicable (aka dropped) within the current TarMed rule set regime. |
[out] BSTR | *pbstrReferenceCode | Reference code |
[out] double | *pdQuantity | Quantity value. |
[out] long | *plID | Some services can expand with more then one slave service, all services with the same ID are possible expansion pairs. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IUtility
  • GetFirstAnaesthesiaRecord

IUtility::GetFirstAnaesthesiaRecord method |  |  | space
Gets the first anaesthesia record. Discard a record with quantity 0. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IUtility/GetFirstAnaesthesiaRecord
[JSON input data] | pIUtility: | longValue, //interface address
[JSON result data] | pbstrCode: pbstrReferenceCode: peAnaesthesiaCode: peAnaesthesiaRiskClass: pdQuantity: pbStatus: | "utf8StringValue", "utf8StringValue", longValue, longValue, doubleValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetFirstAnaesthesiaRecord( | BSTR BSTR AnaesthesiaCodeType AnaesthesiaRiskClassType double VARIANT_BOOL | *pbstrCode, *pbstrReferenceCode, *peAnaesthesiaCode, *peAnaesthesiaRiskClass, *pdQuantity, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrCode | Tarmed service code. |
[out] BSTR | *pbstrReferenceCode | Reference code. |
[out] AnaesthesiaCodeType | *peAnaesthesiaCode | Anaesthesia type |
[out] AnaesthesiaRiskClassType | *peAnaesthesiaRiskClass | Anaesthesia risk class. |
[out] double | *pdQuantity | Quantity. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IUtility
  • GetFirstEmergencyAdmissionRecord

IUtility::GetFirstEmergencyAdmissionRecord method |  |  | space
Gets the first emergency admission record. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IUtility/GetFirstEmergencyAdmissionRecord
[JSON input data] | pIUtility: | longValue, //interface address
[JSON result data] | pbstrCode: pbstrReferenceCode: pdQuantity: pbStatus: | "utf8StringValue", "utf8StringValue", doubleValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetFirstEmergencyAdmissionRecord( | BSTR BSTR double VARIANT_BOOL | *pbstrCode, *pbstrReferenceCode, *pdQuantity, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrCode | Code of the Tarmed service. |
[out] BSTR | *pbstrReferenceCode | Reference code. |
[out] double | *pdQuantity | Quantity. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IUtility
  • GetFirstEmergencyInconvenienceRecord

IUtility::GetFirstEmergencyInconvenienceRecord method |  |  | space
Gets the first emergency inconvenience record. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IUtility/GetFirstEmergencyInconvenienceRecord
[JSON input data] | pIUtility: | longValue, //interface address
[JSON result data] | pbstrCode: pbstrReferenceCode: pdQuantity: pbStatus: | "utf8StringValue", "utf8StringValue", doubleValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetFirstEmergencyInconvenienceRecord( | BSTR BSTR double VARIANT_BOOL | *pbstrCode, *pbstrReferenceCode, *pdQuantity, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrCode | Tarmed service code. |
[out] BSTR | *pbstrReferenceCode | Reference code. |
[out] double | *pdQuantity | Quantity. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IUtility
  • GetFirstExpandRecord

IUtility::GetFirstExpandRecord method |  |  | space
Gets the first expanded record. PATCH: If the instruction #INFO is appened to the service code in Expand("aCode#INFO",...) than the "non-expandable, dropped" fraction too large for a full expansion under the current rule regime is returned in *pbstrCode. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IUtility/GetFirstExpandRecord
[JSON input data] | pIUtility: | longValue, //interface address
[JSON result data] | pbstrCode: pbstrReferenceCode: pdQuantity: plID: pbStatus: | "utf8StringValue", "utf8StringValue", doubleValue, longValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetFirstExpandRecord( | BSTR BSTR double long VARIANT_BOOL | *pbstrCode, *pbstrReferenceCode, *pdQuantity, *plID, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrCode | Tarmed service code. Patch: after expanding IUtility::Expand("00.0010#INFO",23,) under "paper limits", the returned service code is "00.0010#INFO3" meaning that 3 min out of 23 min are not applicable (aka dropped) within the current TarMed rule set regime. |
[out] BSTR | *pbstrReferenceCode | Reference code |
[out] double | *pdQuantity | Quantity value. |
[out] long | *plID | Some services can expand with more then one slave service, all services with the same ID are possible expansion pairs. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IUtility
  • GetFirstNoneMedicalCareRecord

IUtility::GetFirstNoneMedicalCareRecord method |  |  | space
Gets the first non-medical care record. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IUtility/GetFirstNoneMedicalCareRecord
[JSON input data] | pIUtility: | longValue, //interface address
[JSON result data] | pbstrCode: pbstrReferenceCode: pdQuantity: pbStatus: | "utf8StringValue", "utf8StringValue", doubleValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetFirstNoneMedicalCareRecord( | BSTR BSTR double VARIANT_BOOL | *pbstrCode, *pbstrReferenceCode, *pdQuantity, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrCode | Tarmed service code. |
[out] BSTR | *pbstrReferenceCode | Reference code. |
[out] double | *pdQuantity | Quantity. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IUtility
  • GetNextAnaesthesiaRecord

IUtility::GetNextAnaesthesiaRecord method |  |  | space
Gets the next anaesthesia record. Discard a record with quantity 0. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IUtility/GetNextAnaesthesiaRecord
[JSON input data] | pIUtility: | longValue, //interface address
[JSON result data] | pbstrCode: pbstrReferenceCode: peAnaesthesiaCode: peAnaesthesiaRiskClass: pdQuantity: pbStatus: | "utf8StringValue", "utf8StringValue", longValue, longValue, doubleValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetNextAnaesthesiaRecord( | BSTR BSTR AnaesthesiaCodeType AnaesthesiaRiskClassType double VARIANT_BOOL | *pbstrCode, *pbstrReferenceCode, *peAnaesthesiaCode, *peAnaesthesiaRiskClass, *pdQuantity, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrCode | Tarmed service code. |
[out] BSTR | *pbstrReferenceCode | Reference code. |
[out] AnaesthesiaCodeType | *peAnaesthesiaCode | Anaesthesia type |
[out] AnaesthesiaRiskClassType | *peAnaesthesiaRiskClass | Anaesthesia risk class. |
[out] double | *pdQuantity | Quantity. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IUtility
  • GetNextEmergencyAdmissionRecord

IUtility::GetNextEmergencyAdmissionRecord method |  |  | space
Gets the next emergency admission record. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IUtility/GetNextEmergencyAdmissionRecord
[JSON input data] | pIUtility: | longValue, //interface address
[JSON result data] | pbstrCode: pbstrReferenceCode: pdQuantity: pbStatus: | "utf8StringValue", "utf8StringValue", doubleValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetNextEmergencyAdmissionRecord( | BSTR BSTR double VARIANT_BOOL | *pbstrCode, *pbstrReferenceCode, *pdQuantity, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrCode | Code of the Tarmed service. |
[out] BSTR | *pbstrReferenceCode | Reference code. |
[out] double | *pdQuantity | Quantity. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IUtility
  • GetNextEmergencyInconvenienceRecord

IUtility::GetNextEmergencyInconvenienceRecord method |  |  | space
Gets the next emergency inconvenience record. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IUtility/GetNextEmergencyInconvenienceRecord
[JSON input data] | pIUtility: | longValue, //interface address
[JSON result data] | pbstrCode: pbstrReferenceCode: pdQuantity: pbStatus: | "utf8StringValue", "utf8StringValue", doubleValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetNextEmergencyInconvenienceRecord( | BSTR BSTR double VARIANT_BOOL | *pbstrCode, *pbstrReferenceCode, *pdQuantity, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrCode | Tarmed service code. |
[out] BSTR | *pbstrReferenceCode | Reference code. |
[out] double | *pdQuantity | Quantity. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IUtility
  • GetNextExpandRecord

IUtility::GetNextExpandRecord method |  |  | space
Gets the next expanded record. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IUtility/GetNextExpandRecord
[JSON input data] | pIUtility: | longValue, //interface address
[JSON result data] | pbstrCode: pbstrReferenceCode: pdQuantity: plID: pbStatus: | "utf8StringValue", "utf8StringValue", doubleValue, longValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetNextExpandRecord( | BSTR BSTR double long VARIANT_BOOL | *pbstrCode, *pbstrReferenceCode, *pdQuantity, *plID, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrCode | Tarmed service code. |
[out] BSTR | *pbstrReferenceCode | Reference code |
[out] double | *pdQuantity | Quantity value. |
[out] long | *plID | Some services can expand with more then one slave service, all services with the same ID are possible expansion pairs. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IUtility
  • GetNextNoneMedicalCareRecord

IUtility::GetNextNoneMedicalCareRecord method |  |  | space
Gets the next non-medical care record. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IUtility/GetNextNoneMedicalCareRecord
[JSON input data] | pIUtility: | longValue, //interface address
[JSON result data] | pbstrCode: pbstrReferenceCode: pdQuantity: pbStatus: | "utf8StringValue", "utf8StringValue", doubleValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetNextNoneMedicalCareRecord( | BSTR BSTR double VARIANT_BOOL | *pbstrCode, *pbstrReferenceCode, *pdQuantity, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrCode | Tarmed service code. |
[out] BSTR | *pbstrReferenceCode | Reference code. |
[out] double | *pdQuantity | Quantity. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IUtility
  • GetNoneMedicalCareRecords

IUtility::GetNoneMedicalCareRecords method |  |  | space
This method has a Restful Webservice representation only! Method for collecting all non-medical care records resulting from the NoneMedicalCare search method in one call without the necessity to call iterator pair GetFirstNoneMedicalCareRecord / GetNextNoneMedicalCareRecord. The services are returned as JSON array however large that search space might be. So this might be a memory and performance bottleneck. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IUtility/GetNoneMedicalCareRecords
[JSON input data] | pIUtility: | longValue, //interface address
[JSON result array] | { pbstrCode: pbstrReferenceCode: pdQuantity: pbStatus: | "utf8StringValue", "utf8StringValue", doubleValue, booleanValue },
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrCode | Tarmed service code. |
[out] BSTR | *pbstrReferenceCode | Reference code. |
[out] double | *pdQuantity | Quantity. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IUtility
  • InitAnaesthesia

IUtility::InitAnaesthesia method |  |  | space
Initialize the anaesthesia method. Always call this method before entering data for a new session. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IUtility/InitAnaesthesia
[JSON input data] | pIUtility: | longValue, //interface address
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT InitAnaesthesia( | VARIANT_BOOL | *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IUtility
  • NoneMedicalCare

IUtility::NoneMedicalCare method |  |  | space
Finds the non-medical care records. For example use of a recovery room after anaesthesia. NEW FEATURE: If dMinutes is set as a negative value (e.g. -300) in NoneMedicalCare(), and it is an ambulatory treatment then IUtility::GetFirstNoneMedicalCareRecord/IUtility::GetNextNoneMedicalCareRecord return the needed number of 35.0230 services to match the entered total minutes. The implemenation was done due to a change request, but keep in mind that it is very dangerous to use this feature as an automatic scheme because the physician would have to indicate (in principle) the duration of the patient residing in the day clinic. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IUtility/NoneMedicalCare
[JSON input data] | pIUtility: eTreatType: ePraxis: dMinutes: dDate: | longValue, //interface address longValue, longValue, doubleValue, variantDateValue | "stringISODateValue"
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT NoneMedicalCare( | TreatmentType YesNoType double DATE VARIANT_BOOL | eTreatType, ePraxis, dMinutes, dDate, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] TreatmentType | eTreatType | Treatment type. |
[in] YesNoType | ePraxis | Flag specifying whether the location is at the medical practice (praxis). . |
[in] double | dMinutes | Number of minutes. |
[in] DATE | dDate | Date of the service. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IUtility
  • DestructUtility

IUtility::DestructUtility property |  |  | space
This property has a Restful Webservice representation only! Destructs/invalidates this IUtility interface instance. The counterpart property to generate an IUtility interface instance is ITarmedValidator::GetCreateUtility. |  |  |
space
Restful webservice calling syntax |  |  |
[PUT] | /baseURL/ IUtility/PutDestructUtility
[JSON input data] | pIUtility: eDestructUtility: | longValue, //interface address longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Remarks |  |  |
This property has a Restful Webservice representation only! |  |  |
space |


  • IValidate

IValidate interface |  | V1.00/30 Aug 2002
The IValidate interface checks whether supplied service data conform to the Tarmed rules. In case of a conflict with another service, the service will be rejected. Textual information explaining why the code was rejected can be retrieved, in order to provide appropriate feedback to the user. |  | space
space
Methods |  | 9 methods
AddService | Adds a new service which will be validated against all the previously entered services of the same session |
CalculateSum | Calculate the sum of all services which have been added through the AddService method. |
GetAbortInfo | Get the information indicating why the service could not be added. |
GetService | Method for collecting all data of the currently focused service in one call without the necessity to call the appropriate properties of this interface |
Initialize | Initializes the validation, clears all the entered records. |
MoveFirst | Positions the record pointer at the first record in the result record set |
MoveLast | Positions the record pointer at the last record in the result record set |
MoveNext | Positions the record pointer at the next record in the result record set |
MovePrevious | Positions the record pointer at the previous record in the result record set |
space
Properties |  | 37 properties
[get] AbortHook | The hook of the service which generated the abort situation. |
[get] AnaesthesiaMin | The time of an anaesthesia in minutes (including everything). |
[get] BillingRoleType | Billing role type. |
[get] CantonType | Canton type. |
[get] Charge_MT | The charge for the medical service in CHF. |
[get] Charge_TT | The charge for the technical service in CHF. |
[get] Code | Tarmed service code. |
[get] Date | Date of the service. |
[put] DestructValidate | Destructs/invalidates this IValidate interface instance |
[get] EanNumberProvider | EAN number of the provider. |
[get] EanNumberResponsible | EAN number of the responsible physician. |
[get] EanNumberSection | The EAN number of the section. |
[get] ExternalFactor_MT | The external scaling factor for the MT part of the service. |
[get] ExternalFactor_TT | The external scaling factor for the TT part of the service. |
[get] Hook | The hook of the service (external ID). |
[get] ID | The internal ID of the service. |
[get] IgnoreValidate | Flag indicating whether the validation was ignored. |
[get] InternalFactor_MT | Scaling factor for the medical part. |
[get] InternalFactor_TT | Scaling factor for the technical part. |
[get] LawType | Law type. |
[get] MechanicCode | Mechanic code |
[get] MedicalRoleType | Medical role type. |
[get] Name255 | Full service name. |
[get] Name35 | Short service name. |
[get] NamePopular | Popular name of the service. |
[get] NumAssistants | Number of assistants needed for performing the service. |
[get] Quantity | Quantity. |
[get] ReferenceCode | Tarmed code of parent service. |
[get] SessionNumber | Session number. |
[get] SettlementType | Settlement type. |
[get] Side | Side type. |
[get] TP_Assistant | Tax points for the assistant part of the service. |
[get] TP_MT | Tax points for the medical part of the service. |
[get] TP_TT | Tax points for the technical part. |
[get] TreatmentType | Treatment type. |
[get] UnitFactor_MT | Tax point value for the medical part of the service. |
[get] UnitFactor_TT | Tax point value for the technical part. |
space |


  • IValidate
  • AddService

IValidate::AddService method |  |  | space
Adds a new service which will be validated against all the previously entered services of the same session. If the code passed all the Validations a true value is returned. If the code was not accepted a value of false is returned and the variable plStatus contains the error code. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IValidate/AddService
[JSON input data] | pIValidate: pITarmedInput: bstrCode: bstrReferenceCode: dQuantity: lSessionNumber: dDate: eSide: eIgnoreValidate: lHook: | longValue, //interface address longValue, "utf8StringValue", "utf8StringValue", doubleValue, longValue, variantDateValue | "stringISODateValue", longValue, longValue, longValue
[JSON result data] | plStatus: pbStatus: | longValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT AddService( | ITarmedInput BSTR BSTR double long DATE SideType YesNoType long long VARIANT_BOOL | *pITarmedInput, bstrCode, bstrReferenceCode, dQuantity, lSessionNumber, dDate, eSide, eIgnoreValidate, lHook, *plStatus, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] ITarmedInput | *pITarmedInput | ITarmedInput instance. |
[in] BSTR | bstrCode | Code of the Tarmed service. |
[in] BSTR | bstrReferenceCode | Reference code. |
[in] double | dQuantity | Quantity value. |
[in] long | lSessionNumber | Session number. |
[in] DATE | dDate | Date of the service. |
[in] SideType | eSide | Side type. |
[in] YesNoType | eIgnoreValidate | Flag indicating whether the validation was ignored.In the following situations this flag might be useful. The user wants to add the service even if the validation failed, perhaps he has a special agreement with the insurance or patient. When adding new services to already previously checked records, it is not necessary to check the existing records again. |
[in] long | lHook | External hook. The software house can provide for example the record ID of the service to identify the service later on. |
[out] long | *plStatus | A zero value is returned for success. A positive value indicates that a validation rule was not fulfilled, use the GetAbortInfo to get a description string and display an error message. A negative value indicates that the service was not added (see the AbortValidate Enumeration for possible codes). With the GetAbortInfo one can get a description, however preferable the required actions will be performed in the background. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IValidate
  • CalculateSum

IValidate::CalculateSum method |  |  | space
Calculate the sum of all services which have been added through the AddService method. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IValidate/CalculateSum
[JSON input data] | pIValidate: | longValue, //interface address
[JSON result data] | pdSumMT: pdSumTT: pdTotal: plStatus: pbStatus: | doubleValue, doubleValue, doubleValue, longValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT CalculateSum( | double double double long VARIANT_BOOL | *pdSumMT, *pdSumTT, *pdTotal, *plStatus, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] double | *pdSumMT | Sum of all the MT parts. |
[out] double | *pdSumTT | Sum of all the TT parts. |
[out] double | *pdTotal | Total (AL + TL). |
[out] long | *plStatus | A zero value is returned for success. Any other value indicates that a validation rule was not fulfilled, use the GetAbortInfo to get a description string and display an error message (see the AbortValidate Enumeration for possible codes). |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IValidate
  • GetAbortInfo

IValidate::GetAbortInfo method |  |  | space
Get the information indicating why the service could not be added. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IValidate/GetAbortInfo
[JSON input data] | pIValidate: | longValue, //interface address
[JSON result data] | pbstrAbort: pbStatus: | "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetAbortInfo( | BSTR VARIANT_BOOL | *pbstrAbort, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrAbort | Abort information string. If the abort string is empty then there is no error condition - S_FALSE was set (e.g. in an iterator to signal end_of_data) |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IValidate
  • GetService

IValidate::GetService method |  |  | space
This method has a Restful Webservice representation only! Method for collecting all data of the currently focused service in one call without the necessity to call the appropriate properties of this interface. The counterpart method to add services is ITarmedValidator::AddService |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IValidate/GetService
[JSON input data] | pIValidate: | longValue, //interface address
[JSON result data] | plID: pbstrCode: pbstrReferenceCode: pbstrName255: pbstrName35: pbstrNamePopular: pdQuantity: plSessionNumber: pdDate: pdTP_MT: pdTP_TT: pdInternalFactor_MT: pdInternalFactor_TT: pdUnitFactor_MT: pdUnitFactor_TT: pdExternalFactor_MT: pdExternalFactor_TT: pdCharge_MT: pdCharge_TT: peSide: peIgnoreValidate: peTreatment: peLawType: peCantonType: pbstrEanNumberProvider: pbstrEanNumberResponsible: pbstrEanNumberSection: peMedicalRole: peBillingRole: peSettlement: pbstrMechanicCode: pdAnaesthesiaMin: pdNumAssistants: pdTP_Assistant: plHook: plAbortHook: pbStatus: | longValue, "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", doubleValue, longValue, "stringISODateValue", doubleValue, doubleValue, doubleValue, doubleValue, doubleValue, doubleValue, doubleValue, doubleValue, doubleValue, doubleValue, longValue, longValue, longValue, longValue, longValue, "utf8StringValue", "utf8StringValue", "utf8StringValue", longValue, longValue, longValue, "utf8StringValue", doubleValue, doubleValue, doubleValue, longValue, longValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Calling argument description |  |  |
[out] long | *plID | The internal ID of the currently focused service |
[out] BSTR | *pbstrCode | The code of the currently focused service |
[out] BSTR | *pbstrReferenceCode | The defined reference code of the currently focused service |
[out] BSTR | *pbstrName255 | The full name of the currently focused service |
[out] BSTR | *pbstrName35 | The short name (maximum of 35 characters) of the currently focused service |
[out] BSTR | *pbstrNamePopular | The popular name of the currently focused service |
[out] double | *pdQuantity | The defined quantity of the currently focused service |
[out] long | *plSessionNumber | The session number of the currently focused service |
[out] DATE | *pdDate | The application date of the currently focused service |
[out] double | *pdTP_MT | The tax point of the medical part (TP_MT) of the currently focused service |
[out] double | *pdTP_TT | The tax point of the technical part (TP_TT) of the currently focused service |
[out] double | *pdInternalFactor_MT | The applied internal scaling factor of the medical part to the currently focused service |
[out] double | *pdInternalFactor_TT | The applied internal scaling factor of the technical part to the currently focused service |
[out] double | *pdUnitFactor_MT | The applied tax point value of the medical part (TPV_MT) of the currently focused service |
[out] double | *pdUnitFactor_TT | The applied tax point value of the technical part (TPV_TT) of the currently focused service |
[out] double | *pdExternalFactor_MT | The applied external scaling factor of the medical part to the currently focused service |
[out] double | *pdExternalFactor_TT | The applied external scaling factor of the technical part to the currently focused service |
[out] double | *pdCharge_MT | The charge of the medical part in CHF of the currently focused service calculated as ( Charge_MT = Quantity * TP_MT * TPV_MT * ExternalFactor_MT ) |
[out] double | *pdCharge_TT | The charge of the technical part in CHF of the currently focused service calculated as ( Charge_TT = Quantity * TP_TT * TPV_TT * ExternalFactor_TT ) |
[out] SideType | *peSide | The defined side type of the currently focused service |
[out] YesNoType | *peIgnoreValidate | The flag indicating whether the currently focused service was ignored in validation (enNo) or not (enYes). |
[out] TreatmentType | *peTreatment | The defined treatment type of the currently focused service |
[out] LawType | *peLawType | The law type applied to the currently focused service |
[out] CantonType | *peCantonType | The canton type applied to the currently focused service |
[out] BSTR | *pbstrEanNumberProvider | The defined GLN of the provider of the currently focused service |
[out] BSTR | *pbstrEanNumberResponsible | The defined GLN of the responsible physician of the currently focused service |
[out] BSTR | *pbstrEanNumberSection | The defined GLN of the section of the currently focused service |
[out] MedicalRoleType | *peMedicalRole | The defined medical role type of the currently focused service |
[out] BillingRoleType | *peBillingRole | The defined billing role type of the currently focused service |
[out] SettlementType | *peSettlement | The defined settlement role type of the currently focused service |
[out] BSTR | *pbstrMechanicCode | The defined mechanic code of the currently focused service |
[out] double | *pdAnaesthesiaMin | The defined minutes of an anaesthesia of the currently focused service |
[out] double | *pdNumAssistants | The number of assistants needed for applying the currently focused service |
[out] double | *pdTP_Assistant | The tax points (TP) for the assistant part of the currently focused service |
[out] long | *plHook | The hook of the currently focused service |
[out] long | *plAbortHook | The abort hook of the currently focused service |
[out,retval] VARIANT_BOOL | *pbStatus | Boolean return status |
space |


  • IValidate
  • Initialize

IValidate::Initialize method |  |  | space
Initializes the validation, clears all the entered records. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IValidate/Initialize
[JSON input data] | pIValidate: | longValue, //interface address
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT Initialize( | VARIANT_BOOL | *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IValidate
  • MoveFirst

IValidate::MoveFirst method |  |  | space
Positions the record pointer at the first record in the result record set. If the action could not be performed false will be returned. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IValidate/MoveFirst
[JSON input data] | pIValidate: | longValue, //interface address
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT MoveFirst( | VARIANT_BOOL | *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IValidate
  • MoveLast

IValidate::MoveLast method |  |  | space
Positions the record pointer at the last record in the result record set. If the action could not be performed false will be returned. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IValidate/MoveLast
[JSON input data] | pIValidate: | longValue, //interface address
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT MoveLast( | VARIANT_BOOL | *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IValidate
  • MoveNext

IValidate::MoveNext method |  |  | space
Positions the record pointer at the next record in the result record set. If the action could not be performed false will be returned. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IValidate/MoveNext
[JSON input data] | pIValidate: | longValue, //interface address
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT MoveNext( | VARIANT_BOOL | *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IValidate
  • MovePrevious

IValidate::MovePrevious method |  |  | space
Positions the record pointer at the previous record in the result record set. If the action could not be performed false will be returned. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IValidate/MovePrevious
[JSON input data] | pIValidate: | longValue, //interface address
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT MovePrevious( | VARIANT_BOOL | *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IValidate
  • AbortHook

IValidate::AbortHook property | space
The hook of the service which generated the abort situation.
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetAbortHook?param
[param] pIValidate= longValue
[JSON result data] plAbortHook: longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | AbortHook( long *plAbortHook );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] long | *plAbortHook | The defined hook of the current service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • long *GetAbortHook(void);
space


  • IValidate
  • AnaesthesiaMin

IValidate::AnaesthesiaMin property | space
The time of an anaesthesia in minutes (including everything).
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetAnaesthesiaMin?param
[param] pIValidate= longValue
[JSON result data] pdAnaesthesiaMin: doubleValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | AnaesthesiaMin( double *pdAnaesthesiaMin );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] double | *pdAnaesthesiaMin | The defined anaesthesia time (in minutes) of the current service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • double *GetAnaesthesiaMin(void);
space


  • IValidate
  • BillingRoleType

IValidate::BillingRoleType property | space
Billing role type.
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetBillingRoleType?param
[param] pIValidate= longValue
[JSON result data] peBillingRoleType: longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | BillingRoleType( BillingRoleType *peBillingRoleType );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BillingRoleType | *peBillingRoleType | The defined billing role of the current service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BillingRoleType *GetBillingRoleType(void);
space


  • IValidate
  • CantonType

IValidate::CantonType property | space
Canton type.
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetCantonType?param
[param] pIValidate= longValue
[JSON result data] peCantonType: longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | CantonType( CantonType *peCantonType );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] CantonType | *peCantonType | The defined canton type of the current service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • CantonType *GetCantonType(void);
space


  • IValidate
  • Charge_MT

IValidate::Charge_MT property | space
The charge for the medical service in CHF.
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetCharge_MT?param
[param] pIValidate= longValue
[JSON result data] pdCharge_MT: doubleValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Charge_MT( double *pdCharge_MT );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] double | *pdCharge_MT | The defined amount of the medical part (in CHF) of the current service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • double *GetCharge_MT(void);
space


  • IValidate
  • Charge_TT

IValidate::Charge_TT property | space
The charge for the technical service in CHF.
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetCharge_TT?param
[param] pIValidate= longValue
[JSON result data] pdCharge_TT: doubleValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Charge_TT( double *pdCharge_TT );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] double | *pdCharge_TT | The defined amount of the technical part (in CHF) of the current service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • double *GetCharge_TT(void);
space


  • IValidate
  • Code

IValidate::Code property | space
Tarmed service code.
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetCode?param
[param] pIValidate= longValue
[JSON result data] pbstrCode: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Code( BSTR *pbstrCode );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrCode | The defined code of the current service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetCode(void);
space


  • IValidate
  • Date

IValidate::Date property | space
Date of the service.
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetDate?param
[param] pIValidate= longValue
[JSON result data] pdDate: "stringISODateValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Date( DATE *pdDate );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] DATE | *pdDate | The defined treatment date of the current service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • DATE *GetDate(void);
space


  • IValidate
  • DestructValidate

IValidate::DestructValidate property |  |  | space
This property has a Restful Webservice representation only! Destructs/invalidates this IValidate interface instance. The counterpart property to generate an IValidate interface instance is ITarmedValidator::GetCreateValidate. |  |  |
space
Restful webservice calling syntax |  |  |
[PUT] | /baseURL/ IValidate/PutDestructValidate
[JSON input data] | pIValidate: | longValue, //interface address
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Remarks |  |  |
This property has a Restful Webservice representation only! |  |  |
space |


  • IValidate
  • EanNumberProvider

IValidate::EanNumberProvider property | space
EAN number of the provider.
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetEanNumberProvider?param
[param] pIValidate= longValue
[JSON result data] pbstrEanNumberProvider: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | EanNumberProvider( BSTR *pbstrEanNumberProvider );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrEanNumberProvider | The definedGLN of the provider of the current service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetEanNumberProvider(void);
space


  • IValidate
  • EanNumberResponsible

IValidate::EanNumberResponsible property | space
EAN number of the responsible physician.
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetEanNumberResponsible?param
[param] pIValidate= longValue
[JSON result data] pbstrEanNumberResponsible: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | EanNumberResponsible( BSTR *pbstrEanNumberResponsible );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrEanNumberResponsible | The defined GLN of the responsible of the current service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetEanNumberResponsible(void);
space


  • IValidate
  • EanNumberSection

IValidate::EanNumberSection property | space
The EAN number of the section.
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetEanNumberSection?param
[param] pIValidate= longValue
[JSON result data] pbstrEanNumberSection: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | EanNumberSection( BSTR *pbstrEanNumberSection );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrEanNumberSection | The defined EAN of the section of the current service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetEanNumberSection(void);
space


  • IValidate
  • ExternalFactor_MT

IValidate::ExternalFactor_MT property | space
The external scaling factor for the MT part of the service.
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetExternalFactor_MT?param
[param] pIValidate= longValue
[JSON result data] pdExternalFactor_MT: doubleValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | ExternalFactor_MT( double *pdExternalFactor_MT );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] double | *pdExternalFactor_MT | The defined external scaling factor of the medical part of the current service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • double *GetExternalFactor_MT(void);
space


  • IValidate
  • ExternalFactor_TT

IValidate::ExternalFactor_TT property | space
The external scaling factor for the TT part of the service.
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetExternalFactor_TT?param
[param] pIValidate= longValue
[JSON result data] pdExternalFactor_TT: doubleValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | ExternalFactor_TT( double *pdExternalFactor_TT );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] double | *pdExternalFactor_TT | The defined external scaling factor of the technical part of the current service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • double *GetExternalFactor_TT(void);
space


  • IValidate
  • Hook

IValidate::Hook property | space
The hook of the service (external ID).
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetHook?param
[param] pIValidate= longValue
[JSON result data] plHook: longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Hook( long *plHook );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] long | *plHook | The defined hook of the current service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • long *GetHook(void);
space


  • IValidate
  • ID

IValidate::ID property | space
The internal ID of the service.
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetID?param
[param] pIValidate= longValue
[JSON result data] plID: longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | ID( long *plID );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] long | *plID | The defined interbal ID of the current service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • long *GetID(void);
space


  • IValidate
  • IgnoreValidate

IValidate::IgnoreValidate property | space
Flag indicating whether the validation was ignored.
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetIgnoreValidate?param
[param] pIValidate= longValue
[JSON result data] peIgnoreValidate: longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | IgnoreValidate( YesNoType *peIgnoreValidate );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] YesNoType | *peIgnoreValidate | Boolean that defines if the current service has a 'ignore validate' status (enYes) or not (enNo)
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • YesNoType *GetIgnoreValidate(void);
space


  • IValidate
  • InternalFactor_MT

IValidate::InternalFactor_MT property | space
Scaling factor for the medical part.
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetInternalFactor_MT?param
[param] pIValidate= longValue
[JSON result data] pdInternalFactor_MT: doubleValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | InternalFactor_MT( double *pdInternalFactor_MT );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] double | *pdInternalFactor_MT | The defined internal scaling factor of the medical part of the current service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • double *GetInternalFactor_MT(void);
space


  • IValidate
  • InternalFactor_TT

IValidate::InternalFactor_TT property | space
Scaling factor for the technical part.
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetInternalFactor_TT?param
[param] pIValidate= longValue
[JSON result data] pdInternalFactor_TT: doubleValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | InternalFactor_TT( double *pdInternalFactor_TT );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] double | *pdInternalFactor_TT | The defined internal scaling factor of the technical part of the current service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • double *GetInternalFactor_TT(void);
space


  • IValidate
  • LawType

IValidate::LawType property | space
Law type.
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetLawType?param
[param] pIValidate= longValue
[JSON result data] peLawType: longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | LawType( LawType *peLawType );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] LawType | *peLawType | The defined law type part of the current service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • LawType *GetLawType(void);
space


  • IValidate
  • MechanicCode

IValidate::MechanicCode property | space
Mechanic code

To translate the mechanic code into a human readable string, use the ICatalog::GetFirstMechanicCode method.
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetMechanicCode?param
[param] pIValidate= longValue
[JSON result data] pbstrMechanicCode: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | MechanicCode( BSTR *pbstrMechanicCode );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrMechanicCode | The defined mechanic code of the current service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetMechanicCode(void);
space


  • IValidate
  • MedicalRoleType

IValidate::MedicalRoleType property | space
Medical role type.
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetMedicalRoleType?param
[param] pIValidate= longValue
[JSON result data] peMedicalRoleType: longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | MedicalRoleType( MedicalRoleType *peMedicalRoleType );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] MedicalRoleType | *peMedicalRoleType | The defined medical role of the current service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • MedicalRoleType *GetMedicalRoleType(void);
space


  • IValidate
  • Name255

IValidate::Name255 property | space
Full service name.
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetName255?param
[param] pIValidate= longValue
[JSON result data] pbstrName255: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Name255( BSTR *pbstrName255 );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrName255 | The defined full name of the current service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetName255(void);
space


  • IValidate
  • Name35

IValidate::Name35 property | space
Short service name.
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetName35?param
[param] pIValidate= longValue
[JSON result data] pbstrName35: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Name35( BSTR *pbstrName35 );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrName35 | The defined short bame (max. 35 characters) of the current service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetName35(void);
space


  • IValidate
  • NamePopular

IValidate::NamePopular property | space
Popular name of the service.
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetNamePopular?param
[param] pIValidate= longValue
[JSON result data] pbstrNamePopular: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | NamePopular( BSTR *pbstrNamePopular );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrNamePopular | The defined popular name of the current service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetNamePopular(void);
space


  • IValidate
  • NumAssistants

IValidate::NumAssistants property | space
Number of assistants needed for performing the service.
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetNumAssistants?param
[param] pIValidate= longValue
[JSON result data] pdNumAssistants: doubleValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | NumAssistants( double *pdNumAssistants );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] double | *pdNumAssistants | The defined number of assistants of the current service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • double *GetNumAssistants(void);
space


  • IValidate
  • Quantity

IValidate::Quantity property | space
Quantity.
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetQuantity?param
[param] pIValidate= longValue
[JSON result data] pdQuantity: doubleValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Quantity( double *pdQuantity );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] double | *pdQuantity | The defined quantity of the current service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • double *GetQuantity(void);
space


  • IValidate
  • ReferenceCode

IValidate::ReferenceCode property | space
Tarmed code of parent service.
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetReferenceCode?param
[param] pIValidate= longValue
[JSON result data] pbstrReferenceCode: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | ReferenceCode( BSTR *pbstrReferenceCode );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrReferenceCode | The defined code of the current service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetReferenceCode(void);
space


  • IValidate
  • SessionNumber

IValidate::SessionNumber property | space
Session number.
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetSessionNumber?param
[param] pIValidate= longValue
[JSON result data] plSessionNumber: longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | SessionNumber( long *plSessionNumber );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] long | *plSessionNumber | The definedsession number of the current service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • long *GetSessionNumber(void);
space


  • IValidate
  • SettlementType

IValidate::SettlementType property | space
Settlement type.
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetSettlementType?param
[param] pIValidate= longValue
[JSON result data] peSettlementType: longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | SettlementType( SettlementType *peSettlementType );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] SettlementType | *peSettlementType | The defined settlement type of the current service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • SettlementType *GetSettlementType(void);
space


  • IValidate
  • Side

IValidate::Side property | space
Side type.
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetSide?param
[param] pIValidate= longValue
[JSON result data] peSide: longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Side( SideType *peSide );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] SideType | *peSide | The defined side type of the current service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • SideType *GetSide(void);
space


  • IValidate
  • TP_Assistant

IValidate::TP_Assistant property | space
Tax points for the assistant part of the service.
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetTP_Assistant?param
[param] pIValidate= longValue
[JSON result data] pdTP_Assistant: doubleValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | TP_Assistant( double *pdTP_Assistant );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] double | *pdTP_Assistant | The defined tax points (TP) for the assistants of the current service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • double *GetTP_Assistant(void);
space


  • IValidate
  • TP_MT

IValidate::TP_MT property | space
Tax points for the medical part of the service.
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetTP_MT?param
[param] pIValidate= longValue
[JSON result data] pdTP_MT: doubleValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | TP_MT( double *pdTP_MT );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] double | *pdTP_MT | The defined tax points (TP) of the medical part of the current service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • double *GetTP_MT(void);
space


  • IValidate
  • TP_TT

IValidate::TP_TT property | space
Tax points for the technical part.
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetTP_TT?param
[param] pIValidate= longValue
[JSON result data] pdTP_TT: doubleValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | TP_TT( double *pdTP_TT );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] double | *pdTP_TT | The defined tax points (TP) of the technical part of the current service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • double *GetTP_TT(void);
space


  • IValidate
  • TreatmentType

IValidate::TreatmentType property | space
Treatment type.
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetTreatmentType?param
[param] pIValidate= longValue
[JSON result data] peTreatmentType: longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | TreatmentType( TreatmentType *peTreatmentType );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] TreatmentType | *peTreatmentType | The defined treatment type of the current service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • TreatmentType *GetTreatmentType(void);
space


  • IValidate
  • UnitFactor_MT

IValidate::UnitFactor_MT property | space
Tax point value for the medical part of the service.
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetUnitFactor_MT?param
[param] pIValidate= longValue
[JSON result data] pdUnitFactor_MT: doubleValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | UnitFactor_MT( double *pdUnitFactor_MT );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] double | *pdUnitFactor_MT | The defined tax points value (TPV) of the medical part of the current service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • double *GetUnitFactor_MT(void);
space


  • IValidate
  • UnitFactor_TT

IValidate::UnitFactor_TT property | space
Tax point value for the technical part.
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate/GetUnitFactor_TT?param
[param] pIValidate= longValue
[JSON result data] pdUnitFactor_TT: doubleValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | UnitFactor_TT( double *pdUnitFactor_TT );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] double | *pdUnitFactor_TT | The defined tax points value (TPV) of the technical part of the current service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • double *GetUnitFactor_TT(void);
space


  • Type definitions

Builtin, composite & enumeration types |  | V1.00/30 Aug 2002
The following list shows ans defines all used data types either basic builtin, composite or enumeration types that are used in the interface of the ATL COM module. |  | space
space
Data types |  | 26 types
[enumeration] AbortValidateType | Enumerates the defined grounds for an aborted validation attempt. |
[enumeration] AnaesthesiaCodeType | Enumerates the defined anesthesia service code categories. |
[enumeration] AnaesthesiaRiskClassType | Enumerates the defined anesthesia risk classes. |
[enumeration] BillingRoleType | Enumerates the defined billing role categories. |
[builtin] BSTR | A BSTR, known as basic string or binary string, is a pointer to a wide character string used by Automation data manipulation functions |
[enumeration] CantonType | Enumerates the defined canton categories. |
[builtin] DATE | A value denoting a date and time was specified |
[builtin] double | An 8-byte IEEE real value. |
[enumeration] EmergencyAdmissionType | Enumerates the defined emergency admission categories. |
[enumeration] EmergencyType | Enumerates the defined emergency service categories. |
[builtin] HRESULT | The HRESULT data type is a 32-bit value that is used to describe an error or warning. |
[builtin] ICatalog | ICatalog interface. |
[builtin] ISearch | ISearch interface. |
[builtin] ITarmedInput | ITarmedInput interface. |
[builtin] IUtility | IUtlity interface. |
[builtin] IValidate | IValidate interface. |
[enumeration] LanguageType | Enumerates all supported languages. |
[enumeration] LawType | Enumerates the supported legal ruleset. |
[builtin] long | A 4-byte integer value. |
[enumeration] MedicalRoleType | Enumerates the defined medical role categories. |
[enumeration] SettlementType | Enumerates the defined settlement categories. |
[enumeration] SexType | Enumerates the defined gender categories. |
[enumeration] SideType | Enumerates the defined side categories. |
[enumeration] TreatmentType | Enumerates the top level treatment categories. |
[builtin] VARIANT_BOOL | A 16 bit Boolean (True/False) value was specified |
[enumeration] YesNoType | Boolean enumerator. |
space |


  • Type definitions
  • AbortValidateType

AbortValidateType enumeration type |  |
Enumerates the defined grounds for an aborted validation attempt. |  | space
space
Set of enumeration values |  | 34 elements
enRejected: -200 | The record was rejected. The service should not be added, but it is not necessary to display an error message to the user.This is the case for example if the user adds first an OP III utilization service and later an OP I utilization service. Only one OP record, namely that with the highest OP utilization service, is allowed. |
enChangedCharge: -110 | Validation of the record would require that an already-defined charge from a previously added record be changed. |
enChangedQuantity: -100 | browse functions MoveFirst and MoveNext, and discard all the records with a Quantity value of zero. Then add all the remaining records again to the AddService method. |
enDatabaseNotOpen: 101 | The database is not open. |
enInvalidCode: 102 | The code is invalid. |
enServiceNotFound: 301 | No service record found. |
enReferenceCodeRequired: 302 | Reference code is required. |
enAddReferenceCode: 303 | Add the specified reference code first. |
enWrongReferenceCode: 304 | Specified reference code is not allowed for this service. |
enSideRequired: 305 | Side i.e body location is required. |
enWrongTreatmentType: 306 | Treatment type restriction not fulfilled. |
enWrongSex: 307 | Gender restriction not fulfilled. |
enSectionRequired: 308 | Section is required. |
enWrongPatientAge: 309 | Patient age restriction not fulfilled. |
enWrongQuantity: 310 | Quantity restriction not fulfilled. |
enWrongBillingMode: 311 | Billing mode restriction not fulfilled. |
enQLDignityRequired: 312 | Qualitative dignity is required. |
enRoleEmployeeOnly: 313 | Wrong billing role must be: Employee (Hospital or Institute). |
enRoleSelfEmployedOnly: 314 | Wrong billing role must be: Self employed. |
enWrongAnaesthesiaRiskClass: 315 | Anaesthesia risk class restriction not fulfilled. |
enPatientDataChanged: 401 | Patient input is not allowed to change. |
enTreatmentDataChanged: 402 | Treatment input is not allowed to change. |
enPhysicianDataChanged: 403 | Physician input is not allowed to change. |
enDuplicateService: 404 | Duplicate service found. |
enExclusiveDignity: 405 | Same exclusive dignity is required for all services. |
enCombinationRestriction: 406 | Combination restriction not fulfilled |
enCurrentLimitationRestriction: 407 | Current service: Limitation restriction not fulfilled. |
enPreviousLimitationRestriction: 408 | Previous service: Limitation restriction not fulfilled. |
enExclusionRestriction: 409 | Exclusion restriction not fulfilled. |
enSingleServiceAddition: 410 | Single service addition restriction not fulfilled. |
enSingleServiceFromChapter: 411 | Single service from chapter restriction not fulfilled. |
enInvalidServiceChain: 501 | Invalid service chain. |
enReductionPraxisOPNotFound: 502 | Service for praxis OP reduction record not found. |
enValidateFailed: 999 | The validation failed - incompatible database parameters - contact the support. |
space


  • Type definitions
  • AnaesthesiaCodeType

AnaesthesiaCodeType enumeration type |  |
Enumerates the defined anesthesia service code categories. |  | space
space
Set of enumeration values |  | 4 elements
enTypeUnknown: 0 | Unknown or no anaesthesia code. |
enTypePeriop: 1 | Perioperative assistance. |
enTypeBeginEnd: 2 | Begin/end of anaesthesia. |
enTypeService: 3 | Anaesthesia service of the physician. |
space


  • Type definitions
  • AnaesthesiaRiskClassType

AnaesthesiaRiskClassType enumeration type |  |
Enumerates the defined anesthesia risk classes. |  | space
space
Set of enumeration values |  | 6 elements
enRiskClassUnknown: -1 | Unknown or no anaesthesia risk class. |
enRiskClass0: 0 | Risk class MAC |
enRiskClass1: 1 | Risk class 1. |
enRiskClass2: 2 | Risk class 2. |
enRiskClass3: 3 | Risk class 3. |
enRiskClass4: 4 | Risk class 4. |
space


  • Type definitions
  • BillingRoleType

BillingRoleType enumeration type |  |
Enumerates the defined billing role categories. |  | space
space
Set of enumeration values |  | 4 elements
enBillingRoleBoth: 0 | Billing of medical and technical part. |
enBillingRoleMT: 1 | Billing of medical part only. |
enBillingRoleTT: 2 | Billing of technical part only. |
enBillingRoleNone: 3 | None |
space


  • Type definitions
  • BSTR

BSTR type |
A BSTR, known as basic string or binary string, is a pointer to a wide character string used by Automation data manipulation functions. BSTRs are wide, double-byte (Unicode) strings on 32-bit Windows platforms. | space
space
space


  • Type definitions
  • CantonType

CantonType enumeration type |  |
Enumerates the defined canton categories. |  | space
space
Set of enumeration values |  | 31 elements
enCantonUndefined: 0 | Undefined or unknown canton. |
enAG: 1 | AG |
enAI: 2 | AI |
enAR: 3 | AR |
enBE: 4 | BE |
enBL: 5 | BL |
enBS: 6 | BS |
enFR: 7 | FR |
enGE: 8 | GE |
enGL: 9 | GL |
enGR: 10 | GR |
enJU: 11 | JU |
enLU: 12 | LU |
enNE: 13 | NE |
enNW: 14 | NW |
enOW: 15 | OW |
enSG: 16 | SG |
enSH: 17 | SH |
enSO: 18 | SO |
enSZ: 19 | SZ |
enTG: 20 | TG |
enTI: 21 | TI |
enUR: 22 | UR |
enVD: 23 | VD |
enVS: 24 | VS |
enZG: 25 | ZG |
enZH: 26 | ZH |
enGermany: 27 | Germany |
enItaly: 28 | Italy |
enFrance: 29 | France |
enLiechtenstein: 30 | Liechtenstein |
space


  • Type definitions
  • DATE

DATE type |
A value denoting a date and time was specified. Dates are represented as double-precision numbers, where midnight, January 1, 1900 is 2.0, January 2, 1900 is 3.0, and so on. The value is passed in date. | space
space
space


  • Type definitions
  • double

double type |
An 8-byte IEEE real value. | space
space
space


  • Type definitions
  • EmergencyAdmissionType

EmergencyAdmissionType enumeration type |  |
Enumerates the defined emergency admission categories. |  | space
space
Set of enumeration values |  | 2 elements
enRecognized: 1 | The emergency admission is recognized. |
enUnrecognized: 2 | The emergency admission is unrecognized. |
space


  • Type definitions
  • EmergencyType

EmergencyType enumeration type |  |
Enumerates the defined emergency service categories. |  | space
space
Set of enumeration values |  | 4 elements
enAutomatic: 0 | Depending on the service code, the emergency type will be automatically chosen. If no service code is provided, enAutomatic will stand for enVisit. |
enVisit: 1 | Emergency visit. |
enPhone: 2 | Emergency phone call. |
enBirth: 3 | Emergency birth services. |
space


  • Type definitions
  • HRESULT

HRESULT type |
The HRESULT data type is a 32-bit value that is used to describe an error or warning. | space
space
space


  • Type definitions
  • ICatalog

ICatalog type |
ICatalog interface. | space
space
space


  • Type definitions
  • ISearch

ISearch type |
ISearch interface. | space
space
space


  • Type definitions
  • ITarmedInput

ITarmedInput type |
ITarmedInput interface. | space
space
space


  • Type definitions
  • IUtility

IUtility type |
IUtlity interface. | space
space
space


  • Type definitions
  • IValidate

IValidate type |
IValidate interface. | space
space
space


  • Type definitions
  • LanguageType

LanguageType enumeration type |  |
Enumerates all supported languages. |  | space
space
Set of enumeration values |  | 4 elements
enGerman: 1 | German |
enFrench: 2 | French. |
enItalian: 3 | Italian |
enEnglish: 4 | English |
space


  • Type definitions
  • LawType

LawType enumeration type |  |
Enumerates the supported legal ruleset. |  | space
space
Set of enumeration values |  | 5 elements
enKVG: 0 | KVG |
enUVG: 1 | UVG |
enMVG: 2 | MVG |
enIVG: 3 | IVG |
enVVG: 4 | VVG |
space


  • Type definitions
  • long

long type |
A 4-byte integer value. | space
space
space


  • Type definitions
  • MedicalRoleType

MedicalRoleType enumeration type |  |
Enumerates the defined medical role categories. |  | space
space
Set of enumeration values |  | 2 elements
enMedicalRoleSelfEmployed: 0 | Employee (Medical practice) |
enMedicalRoleEmployee: 1 | Employee (Hospital or Institute) |
space


  • Type definitions
  • SettlementType

SettlementType enumeration type |  |
Enumerates the defined settlement categories. |  | space
space
Set of enumeration values |  | 2 elements
enSettlementElectronic: 0 | Electronic transmitting of the bill. |
enSettlementPaper: 1 | Print on paper of the bill. |
space


  • Type definitions
  • SexType

SexType enumeration type |  |
Enumerates the defined gender categories. |  | space
space
Set of enumeration values |  | 2 elements
enMale: 0 | Male. |
enFemale: 1 | Female. |
space


  • Type definitions
  • SideType

SideType enumeration type |  |
Enumerates the defined side categories. |  | space
space
Set of enumeration values |  | 3 elements
enSideNone: 0 | None. |
enSideLeft: 1 | Left side. |
enSideRight: 2 | Right side. |
space


  • Type definitions
  • TreatmentType

TreatmentType enumeration type |  |
Enumerates the top level treatment categories. |  | space
space
Set of enumeration values |  | 3 elements
enAmbulatory: 0 | Ambulatory (out-patient) treatment. |
enStationary: 1 | Stationary (in-patient) treatment. |
enSemiStationary: 2 | Semi-Stationary (in and out-patient) treatment. |
space


  • Type definitions
  • VARIANT_BOOL

VARIANT_BOOL type |
A 16 bit Boolean (True/False) value was specified. A value of 0xFFFF (all bits 1) indicates True; a value of 0 (all bits 0) indicates False. No other values are valid. | space
space
space


  • Type definitions
  • YesNoType

YesNoType enumeration type |  |
Boolean enumerator. |  | space
space
Set of enumeration values |  | 2 elements
enNo: 0 | No. |
enYes: 1 | Yes. |
space


 Sumex1 under a 64bit architecture...

All Sumex1 COM modules are written as 32bit managed C++ dll. As a consequence, a 64bit executable cannot load a 32bit COM dll into its process space due to the addressing differences.

Since some necessary underlying sub-modules are not available in a 64bit version, this problem must be addressed differently than by a 64bit compilation. As Microsoft suggests Sumex1 uses the out-of-process proxy approach where a 32bit COM server loads the 32bit COM dll into its process space and delegates each method call to the dll. Since a 32bit COM server exists in its own process space, the main 64bit process can handle the 64/32bit boundary without problems.

As a result, each 32bit Sumex1 COM dll has a 32bit COM server counterpart with the same name and an oopProxy prefix, e.g. oopProxyTarmedValidator100.exe, where the prefix signifies the out-of-process proxy nature of the executable.

Any 64bit software now creates an instance of the 32bit oopProxy server and then calls the same methods and properties as with the 32bit COM dll. However, there is one crucial difference when using the oopProxy mechanism, namely the necessity to forcefully unload to the COM server at the end e.g. by using Marshal.ReleaseComObject() since the automatic garbage collection approach is too error prone.


 Patch: how to retrieve the non-expandable minutes in a code expansion chain

Given a base code and the number of minutes the method IUtility::Expand() allows for the expansion into a set of services. However, if the number of minutes are too large for a full expansion under the current rule regime, the minutes are silently reduced. The new patch described here allows to retrieve the non-expanded minutes.

  • append a '#INFO' to the service code: IUtility::Expand("aCode#INFO",...)
    • after the expansion, the IUtility::GetFirstExpandRecord() method returns a hash separated string with the first code and the non-expandlable minutes.
      E.g. expanding code "00.0010#INFO" with 23 min under paper limits returns "00.0010#INFO3" meaning that the first service is 00.010 and an non-expandable fraction of 3 min due to the applicable paper limites.


 Patch: how to filter inclusion services for law and/or gender relevance

We received a wish request for providing filtering capabilities of law and/or gender relevance in inclusion services. In order to not change the interface structure, the information is retrieved by patching the ISearch::FindInclusion() method.

  • set 'GetLawRestriction' as service code: ISearch::FindInclusion_method("GetLawRestriction",pbstrInclusionCode)
    • the current record set is searched and a semicolon separated string of applicable laws is returned in pbstrInclusionCode.
      If there is no restriction an empty string will be returned!

  • set 'GetSexRestriction' as service code: ISearch::FindInclusion_method("GetSexRestriction",pbstrInclusionCode)
    • the current record set is searched and the applicable gender restriction is returned in pbstrInclusionCode. The result is is as follows:
      • empty string == no sex restriction
      • ( 0 | enMale ) == restricted to males only
      • ( 1 | enFemale ) == restricted to females only


 General use of the tarmedValidator ATL COM module

  • First create an instance of the tarmedValidator COM module.
  • Open the Tarmed database with the Open method from the ITarmedValidator interface. Set the localization language (if it differs from the default setting of German) using the SetLanguage from the ITarmedValidator interface.
  • Fill the necessary combo boxes and other GUI elements using the methods provided by the ICatalog interface.
  • Set the physician-, patient- and treatment-specific input data using the methods and properties from the ITarmedInput interface. The input data are available to other interfaces within the same instance of the module.
  • The following steps may then be performed, until the tarmedValidator module instance is released:
  • If the input data changes, set the new physician, patient and/or treatment input data using the methods and properties from the ITarmedInput interface.
  • Let the user search for a code (see the Search functions from the ISearch interface). Generate a selection list to let the user choose which additional codes he wants (see How to search for a code document...).
  • Add the selected services to the AddService method from the IValidate interface.
  • Release the tarmedValidator COM module instance.


 How to search for a code and find further related child codes

As you will see, the situation after searching for a code can be rather complex. The tarmedValidator module provides several search and utility capabilities. This section describes one way to use the tarmedValidator module to help the user select all the services which belong to a particular code, and which match some criteria set by the user. (How you actually present the data to the user for selection is a user interface issue, and is beyond the scope of this document.)

The following steps are illustrated in the figure.

Before you search for a service code using any of the Search methods of the ISearch interface, you can set a dignity filter (DignityFilter) for the responsible physician to search only for services which match the specified dignity criteria. Then you search for a service code, either by code label SearchCode or service name (SearchName255 or SearchName35), using the ISearch interface.

When you have found a valid code, you call the CanExpand method from the ISearch interface. Depending on the return value, you try to expand the code, selecting records matching the criteria defined by the user, using the Expand method from the IUtility interface.

If the user specifies that the code represents an emergency service, you can use either the EmergencyInconvenience (for the physician) or EmergencyAdmission (hospital) method from the IUtility interface to generate the corresponding emergency records.

If the method CanHaveAnaesthesiaServices from the ISearch interface returns a true value, you can use the Anaesthesia method from the IUtility interface to generate the anaesthesia records corresponding to the selected code, including non-medical care services.

Many codes represent base services with which additional services may be provided, such as OP utilization. The method CanHaveAdditionalServices from the ISearch interface helps you identify such codes. With the method SearchAdditionalServices you can then find the codes corresponding to the allowed additional services.

Besides additional services, a base service can have slave services. These are services which may only be provided in conjunction with the base service. The methods SearchSlave or FindDescendant locate slave codes for a given base code. Whereas FindSlave returns only the direct slaves of the given code, FindDescendant returns the entire descendant tree (including slaves of slaves). In both cases, the result might contain records which have already been retrieved by the Expand method from the IUtility interface. It is therefore necessary to check for duplication before presenting selection lists to the user.

The method FindInclusion from the ISearch interface returns the optional inclusions for a given service.

Finally, with the method FindCombinations from the ISearch interface, possible combinations for a given service can be found. A combination is a special case of inclusion. For example, it may be permitted to combine service A with either service B or with service C, but not with both.

Before you present the search result set to the physician you might want to filter out some services. The following methods and properties can be used for filtering the result set.

Methods

  • GetAgeRestriction: patient age
  • GetMedicalRoleRestiction: medical role of the physician
Properties
  • Chapter: chapter in the tarmed tariff
  • TreatmentType: treatment type (ambulatory or stationary or irrelevant)
  • Section: section code

The tarmedValidator is designed to validate services in one session only. With the methods GetFirstQuantityMultiSessionRestriction and GetNextQuantityMultiSessionRestriction you get the necessary information that you can apply multi session validation by querying the patient service database.


 Patch: how to retrieve a possible gender relevance of a service

We received a wish request for providing information about the gender relevance of a service. In order to not change the interface structure, the information is retrieved by patching the ISearch::SearchCode() method.

  • append a '#SEX' to the service code: ISearch::SearchCode("aCode#SEX",enYes)
    • after searching, the ISearch::MechanicCode() property returns a hash separated string with the mechanic code and a possible gender relevance code, where code 0=not relevant; code 1=male only; code 2=female only
      E.g. searching for "00.0150#SEX" returns "01#SEX0" meaning that service 00.0150 has the mechanic code 01 and the gender relevance code is 0 aka (not relevant)


 Patch: how to retrieve the group/block affiliation of a service

We received a wish request for providing information about the group and/or block affilitation of a service belongs (aka "PKA services"). In order to not change the interface structure, the information is retrieved by patching the ISearch::SearchCode() method.

  • append a '#SB' (service block) to the service code: ISearch::SearchCode("aCode#SB",enYes)
    • after searching, the ISearch::MechanicCode() property returns a hash separated string with the mechanic code and a possible service block affiliation.
      E.g. searching for "00.0150#SB" returns "01#SB01" meaning that service 00.0150 has the mechanic code 01 and is a member of the service block 01.

  • append a '#SG' (service group) to the service code: ISearch::SearchCode("aCode#SG",enYes)
    • after searching, the ISearch::MechanicCode() property returns a hash separated string with the mechanic code and a possible service group affiliation.
      E.g. searching for "00.0150#SB#SG" returns "01#SB01#SG18#SG58" meaning that service 00.0150 has the mechanic code 01 and is a member of the service block 01 and belongs to the service groups 18 and 58.


 Patch: how to retrieve the gender, group and/or block affiliation of an additional service

We received a wish request for providing information about the gender, group and/or block relevance of an additional service. In order to not change the interface structure, the information is retrieved by patching the ISearch::SearchAdditionalService() method.

  • append a '#SB' (service block) to the service code: ISearch::SearchAdditionalService("aCode#SB",...)
    • after searching, position to the first record with ISearch::MoveFirst() and then the ISearch::MechanicCode() property returns a hash separated string with the mechanic code and a possible service block affiliation.
      E.g. searching for "24.6760#SB" returns "25" for the service 00.1420, meaning that service 00.1420 has the mechanic code 25 and is not a member of a service block.

  • append a '#SG' (service group) to the service code: ISearch::SearchAdditionalService("aCode#SG",...)
    • after searching, position to the first record with ISearch::MoveFirst() and then the ISearch::MechanicCode() property returns a hash separated string with the mechanic code and a possible service group affiliation.
      E.g. searching for "24.6760#SB#SG" returns "15#SG18#SG64" for the service 00.1420, meaning that service 00.1420 has the mechanic code 15 and is not a of a service block and belongs to the service groups 18 and 64.

  • append a '#SEX' to the service code: ISearch::SearchAdditionalService("aCode#SEX",...)
    • after searching, position to the first record with ISearch::MoveFirst() and then the ISearch::MechanicCode() property returns a hash separated string with the mechanic code and a possible gender relevance code, where code 0=not relevant; code 1=male only; code 2=female only
      E.g. searching for "24.6760#SEX" returns "15#SEX0" for the service 00.1420, meaning that service 00.1420 has the mechanic code 15 and has a gender relevance code 0 (aka not relevant)


 Patch: how to externally set the validity barrier between Tarmed 1.08BR and Tarmed 1.09 UV/IV/MV

Due to the disagreement between the tariff partners in the social insurance area, Tarmed 1.09 cannot be introduced uniformly as of April 1, 2018. The official date to change from Tarmed 1.08BR to Tarmed 1.09 is removed from the tarmedValidator.

This patch describes how the validity barrier for switching between Tarmed 1.08BR and Tarmed 1.09 can be set externally such as to introduce Tarmed 1.09 UV/IV/MV.

Please note that in case of an invoice generation the validity barrier must be set via the auxilliary interface IGeneralInvoiceRequestManager::ITarmedInput as well in order to delegate the information into the tarmedValidator!

  • append the validity barrier '#VB109=dd.mm.yyyy' to the bstrEanNumberSection variable in: ITarmedInput::SetTreatment(eCanton,eLaw,eType,eSettlemnt,"aEANSection#VB109=01.04.2018")
    where the patch is case-insensitive and applicable for eLaw = UV|IV|MV only.

    By defining the validity barrier, the tarmedValidator automatically switches between the two Tarmed versions UV/IV/MV and its different rule spaces.


 Patch: how to set the TPV for law=KVG|VVG

Since the tax point value (TPV) can not be set with the available interface methods and the TPV table can not be guarateed to be up-to-date, the following patch allows to establish a self declaration system of TPV by setting individual TPV from outside the tarmedValidator.
  • Setting a TPV of the medical part: use ITarmedInput::ExternalFactor_MT(-1*tpv)
  • Setting a TPV of the technical part: use ITarmedInput::ExternalFactor_TT(-1*tpv)


 Patches in tarmedValidator100 build 1.00.125
using tariffs Tarmed 1.09/1.08.2

Below is a list of all patches included to the tarmedValidator100 build 1.00.125, that can be used to change the default runtime behavior of the validator. The patches are mostly for gathering additional and/or advanced information, a few change runtime behavior itself.

Apart from the patches, tarmedValidator100 build 1.00.125 further manages and operates two Tarmed versions in parallel, namely Tarmed 1.08.2 for social insurance cases and Tarmed 1.09 for KV | VV cases. The use of whatever version is based effectively on the supplied law in ITarmedInput::SetTreatment(). It is thus extremely important to set all data of the auxiliary interface ITarmedInput at the very beginning of a Tarmed session.

List of patches of tarmedValidator build 1.00.125:

  • IUtility::Expand("aCode#noTimeLimit", ...): the appended instruction "#noTimeLimit" performs a full expansion without obeying any time restrictions or limits. A suchwise generated expansion of a service chain might of course provoke validation errors and then generates messages about the violation of the quantity limit! The newly built-in time restrictions of Tarmed 1.09 are thus made "visible" and the over time is not silently discarded.
  • ISearch::GetAgeRestriction(dDaysFrom, dDaysTo): with the introduction of Tarmed 1.09, the negation of laying inside an age interval has been introduced ("younger than a certain age or older than another age").
    In a formal notation:
  • age x ∈ [limit_a, limit_b] means that x is inside the interval
  • age x ∈ not [limit_a, limit_b] means that x is outside the interval.
  • For example, the notation not [6a, 75a] logically implies that the patient's age must be less than 6 years or greater than 75 years.

    The negation of the age interval is expressed in GetAgeRestriction(dDaysFrom, dDaysTo) by the fact that dDaysFrom > dDaysTo and thus must be interpreted accordingly!
  • ISearch::FindDescendant("aCode#no123TypeServices",...) / ISearch::FindNextDescendant(...): when appending the instruction "#no123TypeServices" to bstrCode the space of descendent services is qualified, services of the type 123 aka "First-Next-Last" are filtered out from the result space and thus are neglected by the iterator pair.
  • ICatalog::GetFirstChapter("aCode#INFO",...) / ICatalog::GetNextChapter(...): the appended instruction "#INFO" does return chapter interpretations instead of chapter codes and names, where the interpretation title is returned in bstrCode and interpretation text is returned in bstrName.
  • With the introduction of Tarmed 1.09, the qualitative dignities have been supplemented by the aspect/qualification of "is FMH Specialist".
    ICatalog::GetFirstQualitativeDignity("aCode#FMH",...) / ICatalog::GetNextQualitativeDignity(...): the bstrCode appended instruction "#FMH" allows to retrieve a tag either "#FMH0" or "#FMH1" appended to the variable pbstrCode. The meaning of the tags is as follows:
    • #FMH0 == dignity is not a "FMH Specialist" dignity
    • #FMH1 == dignity is a "FMH Specialist" dignity

  • "Practical Physician" vs. "FMH Specialist": The self-declaration of the dignities controls the selection of available services. With the introduction of Tarmed 1.09, the medical TP is also affected, insofar as in the case of the dignity 3000 aka "Practical Physician" a TP reduction is automatically performed by means of the internal scaling factor. Whilst the addition of dignities enlarges to the spectrum of available services, there is a hierarchical approach regarding the TP reduction! The addition of any "FMH Specialist" dignity (cf. above) outdo the "Practical Physician" dignity and turns off the TP reduction!

    ITarmedInput::AddDignity(...,"3000#IMPORTANT", ...): when appending the instruction "#IMPORTANT" to the dignity 3000 aka "Practical Physician" the rather esoteric situation "performance spectrum of a FMH Specialist with TP reduction of a Practical Physician" can be realized. The "3000#IMPORTANT" switch ensures that other dignities of type "FMH Specialist" does not invalidate the TP reduction!


 Introduction, overview and usage of the Restful Webservice Server

The application tarmedValidatorServer100.exe is a Restful Webservice Server, that has the same interface methods/properties as the COM module tarmedValidator100.dll. This allows to create a programming semantically similar to the COM approach but under the Restful Webservice paradigm. Consequently, on the Restful Client side there are no prevailing dependencies on Microsoft platforms and/or on Microsoft resources such as the database technology. Of course, the installation location of the server software is still subject to these restrictions.

In the next section of this document, the installation, configuration and operation of tarmedValidatorServer100.exe will be addressed.

Installation, registration and parameterization:
By installing the installer object tarmedValidator100 the COM module tarmedValidator100.dll as well as the out-of-process proxy component oopTarmedValidator100.exe is automatically installed/registered in the system. However, the tarmedValidatorServer100.exe must be installed manually as a service.
tarmedValidatorServer100.exe -help | Creates a help window with the the name and full version of the application as well as the currently define Webservice Endpoint. Furthermore the complete list of command line switches is shown.
tarmedValidatorServer100.exe -install | Installs/registers the Restful Webservice Server as a service. Please take into account, that the installation must be performed under administrator privileges
tarmedValidatorServer100.exe -uninstall | Uninstalls the service component. Please take into account, that the uninstallation must be performed under administrator privileges
tarmedValidatorServer100.exe -setport X | Sets the port X as part of the Webservice Endpoint
Restful Webservice Endpoint:
Installing tarmedValidatorServer100.exe as a service activates the Restful Webservice Endpoint:
http://localhost:34118/tarmedValidatorServer100
which is subsumed as baseURL in subsequent the API documentation.

To run the webservice under a different URL or under https protocol, a permanent webservice target endpoint mapping is performed on the target system.
For example, under Apache, the following rewrite rule is defined:
<VirtualHost *:*>
    ProxyPreserveHost Off
    Header always set Access-Control-Allow-Origin "*"
    Header always set Access-Control-Max-Age "1000"
    Header always set Access-Control-Allow-Headers "x-requested-with, Content-Type, origin, authorization, accept, client-security-token"

    ProxyPass /tarmedValidator/100/ http://localhost:34118/tarmedValidatorServer100/
    ProxyPassReverse /tarmedValidator/100/ http://localhost:34118/tarmedValidatorServer100/
</VirtualHost>
Restful Webservice Operation:
The service may be modified after installation, for example to start under a different account, to extend the recovery properties or to change the startup type. Finally, this should be set to 'Automatic' or 'Automatic (Delayed start)' so that the service is automatically available after a system restart.
Remarks about programming:
In the rest of this document we will discuss programming of the Restful web service and the differences to the C/C++ programming of the classic COM component.

As already mentioned, Restful programming is analogous to C++ programming with the addition that each instance of an interface (including the main interface) is created via the corresponding GET function. For example, an instance of the main interface is created with:
baseURL/ITarmedValidator/GetCreateTarmedValidator | returns the instance address as JSON out{pITarmedValidator: longValue,...}
In every further call of a method or a property of the main interface this instance address must be included as part of the JSON-In. The termination/deletion of an instance must be done via the corresponding PUT Destruct property:
baseURL/ITarmedValidator/PutDestructTarmedValidator | with JSON-In{pITarmedValidator: longValue}, deletes the corresponding main instance AND all at that moment still active dependent subinstances (subinstances which have been generated by the explicit main instance).
It should be noted that the webserver tarmedValidatorServer100.exe performs an internal management of the generated instances and automatically deletes instances that have no activity for a defined period of 2 hours. no activity over a defined period of 2 hours. If after this action a rest call with such an instance is made, an error (HTTP Status >= 400) is generated and the instance address is marked as unknown.
Code snippet:
Minimal code snippet to query the version of the module and the associated database:
    http://localhost:34118/tarmedValidatorServer100/ITarmedValidator/GetCreateTarmedValidator
        returns JSON-Out{pITarmedValidator: 45467}

    http://localhost:34118/tarmedValidatorServer100/ITarmedValidator/GetModuleVersion?pITarmedValidator=45467
        returns JSON-Out{pbstrModuleVersion: "1.00.010"}

    http://localhost:34118/tarmedValidatorServer100/ITarmedValidator/GetDBVersionText?pITarmedValidator=45467
        returns JSON-Out{pbstrDBVersionText: "3.22"}

    http://localhost:34118/tarmedValidatorServer100/ITarmedValidator/GetDBVersionDate?pITarmedValidator=45467
        returns JSON-Out{pdDBVersionDate: "2021-11-29"}

    http://localhost:34118/tarmedValidatorServer100/ITarmedValidator/GetCreateValidate?pITarmedValidator=45467
        returns JSON-Out{pIValidate: 47008}

    http://localhost:34118/tarmedValidatorServer100/IValidate/PutDestructValidate
        JSON-IN{pIValidate:47008}

    http://localhost:34118/tarmedValidatorServer100/ITarmedValidator/PutDestructTarmedValidator
        JSON-IN{pITarmedValidator:45467}