 API browser of CareCreditResponse450 COM module
Interface version: | 4.50
Interface date: | 6 May 2019

The CareCreditResponseManager is an ATL COM module which provides methods to load and analyze XML infosets of type careCreditResponse_450. These infosets are responses to a previously sent nursing care credit where the topmost object reference defines the target request. The subchapter object reference provides an in-depth description of the concept of "object reference". |  | space
Interfaces |  | 3 interface
IAddress | The utility interface IAddress is available for retrieving structured address data out of the XML response. |
ICareCreditResponse | The interface ICareCreditResponse allows to read back all data that have been loaded with the ICareCreditResponseManager::LoadXML method. |
ICareCreditResponseManager | The main interface ICareCreditResponseManager -creatable in its own right- allows to load and analyze a XML infoset of type careCreditResponse_450. |
Types |  |
type definitions | List of all used builtin, composite and enumeration types |
Important documents about the usage and handling |  |
Document | General usage of the careCreditResponse450 COM module - an overview |
Document | What to do in a 64bit environment - is there a 64bit Sumex1 COM dll? |
Document | Overview of the concept of "Object reference" |
Document | Notes about the signature part of the XML infoset |
Document | Notes about the encryption part of the XML infoset |
Document | Syntax of the printTemplate variable of the Print method |
Document | How to generate a PDF archive file of an care credit response |
Document | VB code snippet for using the careCreditResponse450 COM module |
Document | careCreditResponseManagerServer450: Introduction, overview and usage of the Restful Webservice Server |
Important external documents |  |
CHM File | Schema documentation of careCreditResponse_450 in CHM format |
ZIP Archive | ZIP archive with the careCreditResponse_450.xsd schema and the accompanying auxiliary schema files |
ZIP Archive | ZIP archive with some XML test files of careCreditResponse450 type |

© by sumex1.net - all rights reserved


  • CareCreditResponse450
  • IAddress

IAddress interface |  | V4.50/ 6 May 2019
With the IAddress interface structured address data can be retrieved once loaded with the ICareCreditResponseManager::LoadXML method. The different structured parts of an address like the naming and postal address parts or online information like phone, fax, email and the like are retrieved by calling the appropriate methods e.g. GetPerson or GetPostal. Since there are 2 different address types -an address for a natural person and the address of a legal person- the GetType property can be consulted to retrieve the type. |  | space
space
Methods |  | 16 methods
AddPhone | Adds a structured phone number |
GetAbortInfo | Gets the abort information string with the error coded in the module language |
GetCompany | Retrieves the company's naming part of the address |
GetFax | Retrieves the structured fax number |
GetFirstPhone | Retrieves the first phone number information |
GetNextPhone | Retrieves the next phone number information |
GetOnline | Retrieves the structured online part of the address |
GetPerson | Retrieves the person's naming part of the address |
GetPhones | Method for collecting all phone numbers covered by the address and returned as JSON array |
GetPostal | Retrieves the structured postal address part of the address. |
Initialize | Initializes all address variables |
SetCompany | Sets the company's naming part of the address |
SetFax | Sets a structured fax number |
SetOnline | Sets the structured online part of the address. |
SetPerson | Sets the person's naming part of the address |
SetPostal | Sets the structured postal address part |
space
Properties |  | 2 properties
[put] DestructAddress | Destructs/invalidates this IAddress interface instance. |
[get] Type | GetType returns the type of address either enAddressPerson or enAddressCompany if an address is defined at all |
space |


  • IAddress
  • AddPhone

IAddress::AddPhone method |  |  | space
Adds a structured phone number. The Swiss international calling code +41 is filtered out in the printing. If the main software does not support structured pone numbers then all data is supplied in the bstrNumber variable. However, +41 is then no longer filtered. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IAddress/AddPhone
[JSON input data] | pIAddress: bstrNumber: bstrLocalCode: bstrInternationalCode: bstrExt: | longValue, //interface address "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue"
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT AddPhone( | BSTR BSTR BSTR BSTR VARIANT_BOOL | bstrNumber, bstrLocalCode, bstrInternationalCode, bstrExt, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrNumber | The pure phone number part of the telephone number. It is possible to set the full telephone number in this variable and leave the other parts of the telephone number empty |
[in] BSTR | bstrLocalCode | The local area code part of the telephone number. |
[in] BSTR | bstrInternationalCode | The international calling code part of the telephone number. |
[in] BSTR | bstrExt | The optional extension number part of the telephone number. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IAddress
  • GetAbortInfo

IAddress::GetAbortInfo method |  |  | space
Gets the abort information string with the error coded in the module language. Call this method whenever the returned pbStatus variable of the primarily called method is VARIANT_FALSE and this primarily called method is not an iterator (GetFirst/GetNext methods). In the later case VARIANT_FALSE signals the end of data. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IAddress/GetAbortInfo
[JSON input data] | pIAddress: | longValue, //interface address
[JSON result data] | pbstrAbort: pbStatus: | "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetAbortInfo( | BSTR VARIANT_BOOL | *pbstrAbort, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrAbort | Abort information string coded in the module language. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error-in-error situation occurred. |
space |


  • IAddress
  • GetCompany

IAddress::GetCompany method |  |  | space
Retrieves the company's naming part of the address. Call the property GetType first to test if GetPerson or GetCompany should be called. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IAddress/GetCompany
[JSON input data] | pIAddress: | longValue, //interface address
[JSON result data] | pbstrCompanyName: pbstrDepartment: pbstrSubaddressing: pbStatus: | "utf8StringValue", "utf8StringValue", "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetCompany( | BSTR BSTR BSTR VARIANT_BOOL | *pbstrCompanyName, *pbstrDepartment, *pbstrSubaddressing, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrCompanyName | The company's name. |
[out] BSTR | *pbstrDepartment | The optional department part of the company. |
[out] BSTR | *pbstrSubaddressing | The optional subaddressing information, e.g. a "c/o" like information as defined by the Post |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IAddress
  • GetFax

IAddress::GetFax method |  |  | space
Retrieves the structured fax number. Empty variables are returned if there is no fax number available. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IAddress/GetFax
[JSON input data] | pIAddress: | longValue, //interface address
[JSON result data] | pbstrNumber: pbstrLocalCode: pbstrInternationalCode: pbstrExt: pbStatus: | "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetFax( | BSTR BSTR BSTR BSTR VARIANT_BOOL | *pbstrNumber, *pbstrLocalCode, *pbstrInternationalCode, *pbstrExt, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrNumber | The pure fax number part of the full fax number. It is possible that the full fax number is returned in this variable and the other parts of the fax number left empty. |
[out] BSTR | *pbstrLocalCode | The local area code part of the fax number. |
[out] BSTR | *pbstrInternationalCode | The international calling code part of the fax number. |
[out] BSTR | *pbstrExt | The extension number part of the fax number. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IAddress
  • GetFirstPhone

IAddress::GetFirstPhone method |  |  | space
Retrieves the first phone number information. VARIANT_FALSE is returned if the end of the phone list is reached. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IAddress/GetFirstPhone
[JSON input data] | pIAddress: | longValue, //interface address
[JSON result data] | pbstrNumber: pbstrLocalCode: pbstrInternationalCode: pbstrExt: pbStatus: | "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetFirstPhone( | BSTR BSTR BSTR BSTR VARIANT_BOOL | *pbstrNumber, *pbstrLocalCode, *pbstrInternationalCode, *pbstrExt, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrNumber | The pure phone number part of the full telephone number. It is possible that the full telephone number is returned in this variable and the other parts of the telephone number left empty. |
[out] BSTR | *pbstrLocalCode | The local area code part of the telephone number. |
[out] BSTR | *pbstrInternationalCode | The international calling code part of the telephone number. |
[out] BSTR | *pbstrExt | the extension number part of the telephone number. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
space |


  • IAddress
  • GetNextPhone

IAddress::GetNextPhone method |  |  | space
Retrieves the next phone number information. VARIANT_FALSE is returned if the end of the phone list is reached |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IAddress/GetNextPhone
[JSON input data] | pIAddress: | longValue, //interface address
[JSON result data] | pbstrNumber: pbstrLocalCode: pbstrInternationalCode: pbstrExt: pbStatus: | "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetNextPhone( | BSTR BSTR BSTR BSTR VARIANT_BOOL | *pbstrNumber, *pbstrLocalCode, *pbstrInternationalCode, *pbstrExt, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrNumber | The pure phone number part of the full telephone number. It is possible that the full telephone number is returned in this variable and the other parts of the telephone number left empty. |
[out] BSTR | *pbstrLocalCode | The local area code part of the telephone number. |
[out] BSTR | *pbstrInternationalCode | The international calling code part of the telephone number. |
[out] BSTR | *pbstrExt | the extension number part of the telephone number. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
space |


  • IAddress
  • GetOnline

IAddress::GetOnline method |  |  | space
Retrieves the structured online part of the address. Empty variables are returned if there are no online information available. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IAddress/GetOnline
[JSON input data] | pIAddress: | longValue, //interface address
[JSON result data] | pbstrEMail: pbstrUrl: pbStatus: | "utf8StringValue", "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetOnline( | BSTR BSTR VARIANT_BOOL | *pbstrEMail, *pbstrUrl, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrEMail | A relevant email address. |
[out] BSTR | *pbstrUrl | A relevant URL. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IAddress
  • GetPerson

IAddress::GetPerson method |  |  | space
Retrieves the person's naming part of the address. Call the property GetType first to test if GetPerson or GetCompany should be called. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IAddress/GetPerson
[JSON input data] | pIAddress: | longValue, //interface address
[JSON result data] | pbstrFamilyname: pbstrGivenname: pbstrSalutation: pbstrTitle: pbstrSubaddressing: pbStatus: | "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetPerson( | BSTR BSTR BSTR BSTR BSTR VARIANT_BOOL | *pbstrFamilyname, *pbstrGivenname, *pbstrSalutation, *pbstrTitle, *pbstrSubaddressing, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrFamilyname | The family name (or last name) of the person. |
[out] BSTR | *pbstrGivenname | The given name (or first name) of the person. |
[out] BSTR | *pbstrSalutation | The optional salutation of the person. |
[out] BSTR | *pbstrTitle | The optional title of the person. |
[out] BSTR | *pbstrSubaddressing | The optional subaddressing information, e.g. a "c/o" like information as defined by the Post |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IAddress
  • GetPhones

IAddress::GetPhones method |  |  | space
This method has a Restful Webservice representation only! Method for collecting all phone numbers covered by the address and returned as JSON array. Please note that IAddress::GetPhones takes over the functionality of the iterator pair IAddress::GetFirstPhone / IAddress::GetNextPhone with a single call, making the latter superfluous. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IAddress/GetPhones
[JSON input data] | pIAddress: | longValue, //interface address
[JSON result array] | { pbstrNumber: pbstrLocalCode: pbstrInternationalCode: pbstrExt: pbStatus: | "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", booleanValue },
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrNumber | The pure phone number part of the full telephone number. It is possible that the full telephone number is returned in this variable and the other parts of the telephone number left empty. |
[out] BSTR | *pbstrLocalCode | The local area code part of the telephone number. |
[out] BSTR | *pbstrInternationalCode | The international calling code part of the telephone number. |
[out] BSTR | *pbstrExt | the extension number part of the telephone number. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
space |


  • IAddress
  • GetPostal

IAddress::GetPostal method |  |  | space
Retrieves the structured postal address part of the address. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IAddress/GetPostal
[JSON input data] | pIAddress: | longValue, //interface address
[JSON result data] | pbstrStreet: pbstrPoBox: pbstrZip: pbstrCity: pbstrStateCode: pbstrCountryCode: pbStatus: | "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetPostal( | BSTR BSTR BSTR BSTR BSTR BSTR VARIANT_BOOL | *pbstrStreet, *pbstrPoBox, *pbstrZip, *pbstrCity, *pbstrStateCode, *pbstrCountryCode, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrStreet | The street name part of an address. |
[out] BSTR | *pbstrPoBox | The P.O. box code part of an address. Note that according to the Post the street and poBox parts should be used mutually exclusive. |
[out] BSTR | *pbstrZip | The ZIP code part of an address. |
[out] BSTR | *pbstrCity | The city name of an address. |
[out] BSTR | *pbstrStateCode | The optional state code part of an address. |
[out] BSTR | *pbstrCountryCode | The optional ISO country code part of an address. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IAddress
  • Initialize

IAddress::Initialize method |  |  | space
Initializes all address variables. This method should be called before new data is supplied to reset all internally stored data. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IAddress/Initialize
[JSON input data] | pIAddress: | longValue, //interface address
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT Initialize( | VARIANT_BOOL | *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IAddress
  • SetCompany

IAddress::SetCompany method |  |  | space
Sets the company's naming part of the address. Note that the subaddressing is part of the extended name and is always printed before any postal information. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IAddress/SetCompany
[JSON input data] | pIAddress: bstrCompanyName: bstrDepartment: bstrSubaddressing: | longValue, //interface address "utf8StringValue", "utf8StringValue", "utf8StringValue"
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT SetCompany( | BSTR BSTR BSTR VARIANT_BOOL | bstrCompanyName, bstrDepartment, bstrSubaddressing, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrCompanyName | The company's name. |
[in] BSTR | bstrDepartment | The optional department part of the company. |
[in] BSTR | bstrSubaddressing | The optional subaddressing information, e.g. a "c/o" like information as defined by the Post |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IAddress
  • SetFax

IAddress::SetFax method |  |  | space
Sets a structured fax number. The Swiss international calling code +41 is filtered in the printing. If the main software does not support structured pone numbers then all data is supplied in the bstrNumber variable. However, +41 is then no longer filtered. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IAddress/SetFax
[JSON input data] | pIAddress: bstrNumber: bstrLocalCode: bstrInternationalCode: bstrExt: | longValue, //interface address "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue"
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT SetFax( | BSTR BSTR BSTR BSTR VARIANT_BOOL | bstrNumber, bstrLocalCode, bstrInternationalCode, bstrExt, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrNumber | The pure fax number part of the fax number. It is possible to set the full fax number in this variable and leave the other parts of the fax number empty |
[in] BSTR | bstrLocalCode | The local area code part of the fax number. |
[in] BSTR | bstrInternationalCode | The international calling code part of the fax number. |
[in] BSTR | bstrExt | The extension number part of the fax number. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IAddress
  • SetOnline

IAddress::SetOnline method |  |  | space
Sets the structured online part of the address. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IAddress/SetOnline
[JSON input data] | pIAddress: bstrEMail: bstrUrl: | longValue, //interface address "utf8StringValue", "utf8StringValue"
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT SetOnline( | BSTR BSTR VARIANT_BOOL | bstrEMail, bstrUrl, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrEMail | A relevant email address. |
[in] BSTR | bstrUrl | A relevant URL address. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IAddress
  • SetPerson

IAddress::SetPerson method |  |  | space
Sets the person's naming part of the address. Note that the subaddressing is part of the extended name and is always printed before any postal information. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IAddress/SetPerson
[JSON input data] | pIAddress: bstrFamilyname: bstrGivenname: bstrSalutation: bstrTitle: bstrSubaddressing: | longValue, //interface address "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue"
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT SetPerson( | BSTR BSTR BSTR BSTR BSTR VARIANT_BOOL | bstrFamilyname, bstrGivenname, bstrSalutation, bstrTitle, bstrSubaddressing, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrFamilyname | The family name (or last name) of the person. |
[in] BSTR | bstrGivenname | The given name (or first name) of the person. |
[in] BSTR | bstrSalutation | The optional salutation of the person. |
[in] BSTR | bstrTitle | The optional title of the person. |
[in] BSTR | bstrSubaddressing | The optional subaddressing information, e.g. a "c/o" like information as defined by the Post |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IAddress
  • SetPostal

IAddress::SetPostal method |  |  | space
Sets the structured postal address part. The Swiss ISO county code is the default but is filtered in the printing. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IAddress/SetPostal
[JSON input data] | pIAddress: bstrStreet: bstrPoBox: bstrZip: bstrCity: bstrStateCode: bstrCountryCode: | longValue, //interface address "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue"
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT SetPostal( | BSTR BSTR BSTR BSTR BSTR BSTR VARIANT_BOOL | bstrStreet, bstrPoBox, bstrZip, bstrCity, bstrStateCode, bstrCountryCode, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrStreet | The street name part of an address. |
[in] BSTR | bstrPoBox | The P.O. box code part of an address. Note that according to the Post the street and poBox parts should be used mutually exclusive. |
[in] BSTR | bstrZip | The mandatory ZIP code part of an address. |
[in] BSTR | bstrCity | The mandatory city name of an address. |
[in] BSTR | bstrStateCode | The optional state code part of an address. |
[in] BSTR | bstrCountryCode | The ISO country code of an address. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IAddress
  • DestructAddress

IAddress::DestructAddress property |  |  | space
This property has a Restful Webservice representation only! Destructs/invalidates this IAddress interface instance. |  |  |
space
Restful webservice calling syntax |  |  |
[PUT] | /baseURL/ IAddress/PutDestructAddress
[JSON input data] | pIAddress: | longValue, //interface address
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Remarks |  |  |
This property has a Restful Webservice representation only! |  |  |
space |


  • IAddress
  • Type

IAddress::Type property | space
GetType returns the type of address either enAddressPerson or enAddressCompany if an address is defined at all.

If no address is defined then enAddressUndefined is returned.

space
Restful webservice calling syntax
[GET] | /baseURL/ IAddress/GetType?param
[param] pIAddress= longValue
[JSON result data] peType: longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Type( AddressType *peType );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] AddressType | *peType
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • AddressType *GetType(void);
space


  • ICareCreditResponse

ICareCreditResponse interface |  | V4.50/ 6 May 2019
The ICareCreditResponse interface allows to read back all data that have been loaded with the ICareCreditResponseManager::LoadXML method. |  | space
space
Methods |  | 22 methods
GetAbortInfo | Gets the abort information string with the error coded in the module language |
GetAcceptType | Retrieves detailed information for a response of type Accepted |
GetBiller | Retrieves the biller's GLN of the initial request |
GetContact | Retrieves the structured address and EAN of the main contact |
GetCreditObject | Retrieves the optional care credit object reference parameters |
GetDebitor | Retrieves the structured address and EAN of the debitor of the initial request |
GetDocuments | Method for collecting all document data covered by the ICareCreditResponse interface and returned as JSON array |
GetFirstDocument | Retrieves the first document from the list of documents |
GetFirstNotification | Retrieves the first notification object |
GetGenerator | Retrieves the identification parameters of the sender's XML infoset generator software |
GetInsurance | Retrieves the insurance's EAN of the initial request |
GetNextDocument | Retrieves the next document from the list of documents |
GetNextNotification | Retrieves the next notification object |
GetNotifications | Method for collecting all notification objects covered by the ICareCreditResponse interface and returned as JSON array |
GetPackage | Retrieves the identification parameters of the sender's main software |
GetPatient | Retrieves the primary parameters and structured address of the patient - these data are mirrored from the request |
GetPendingType | Retrieves detailed information for a response of type Pending |
GetProvider | Retrieves the provider's EAN of the initial request |
GetRejectType | Retrieves detailed information for a response of type Rejected |
GetResponse | Returns the primary parameters of the response infoset, namely the operation modus, the language the infoset is formulated, and most important the type of the response |
GetTransport | Returns the transport information that is the routing information going from a sender (from) over at least one intermediate (via) to the receiver (to) |
GetTreatment | Retrieves the basic treatment parameters mirrored of the initial request. |
space
Properties |  | 1 properties
[put] DestructCareCreditResponse | Destructs/invalidates this ICareCreditResponse interface instance. |
space |


  • ICareCreditResponse
  • GetAbortInfo

ICareCreditResponse::GetAbortInfo method |  |  | space
Gets the abort information string with the error coded in the module language. Call this method whenever the returned pbStatus variable of the primarily called method is VARIANT_FALSE and this primarily called method is not an iterator (GetFirst/GetNext methods). In the later case VARIANT_FALSE signals the end of data. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ICareCreditResponse/GetAbortInfo
[JSON input data] | pICareCreditResponse: | longValue, //interface address
[JSON result data] | pbstrAbort: pbStatus: | "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetAbortInfo( | BSTR VARIANT_BOOL | *pbstrAbort, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrAbort | Abort information string coded in the module language. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error-in-error situation occurred. |
space |


  • ICareCreditResponse
  • GetAcceptType

ICareCreditResponse::GetAcceptType method |  |  | space
Retrieves detailed information for a response of type Accepted. Call this method if the GetResponse method returns the type enResponseAccepted. Calling the iterator pair GetFirstNotification / GetNextNotification is unnecessary as there are no notifications and VARIANT_FALSE would be returned. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ICareCreditResponse/GetAcceptType
[JSON input data] | pICareCreditResponse: | longValue, //interface address
[JSON result data] | pbstrExplanation: peStatusIn: peStatusOut: pbStatus: | "utf8StringValue", longValue, longValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetAcceptType( | BSTR StatusType StatusType VARIANT_BOOL | *pbstrExplanation, *peStatusIn, *peStatusOut, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrExplanation | An optional explanation. The explanation is formulated in the data language returned by the GetResponse method |
[out] StatusType | *peStatusIn | The status of the invoice/reminder request (given by the topmost object reference) before this response was generated |
[out] StatusType | *peStatusOut | The status of the invoice/reminder request (given by the topmost object reference) after this response was generated |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • ICareCreditResponse
  • GetBiller

ICareCreditResponse::GetBiller method |  |  | space
Retrieves the biller's GLN of the initial request. Note that this is only a safety measure for a crosscheck. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ICareCreditResponse/GetBiller
[JSON input data] | pICareCreditResponse: | longValue, //interface address
[JSON result data] | pbstrEAN: pbStatus: | "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetBiller( | BSTR VARIANT_BOOL | *pbstrEAN, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrEAN | The EAN number of the biller of the initial request as supplied by Stiftung Refdata |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • ICareCreditResponse
  • GetContact

ICareCreditResponse::GetContact method |  |  | space
Retrieves the structured address and EAN of the main contact. The structured address data is read via the methods of the returned IAddress interface instance. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ICareCreditResponse/GetContact
[JSON input data] | pICareCreditResponse: | longValue, //interface address
[JSON result data] | pbstrEAN: pIAddress: pbStatus: | "utf8StringValue", { pbIsPrivateAddress: true, pbstrCompanyName: "utf8StringValue", pbstrDepartment: "utf8StringValue", pbstrSalutation: "utf8StringValue", pbstrTitle: "utf8StringValue", pbstrFamilyname: "utf8StringValue", pbstrGivenname: "utf8StringValue", pbstrSubaddressing: "utf8StringValue", pbstrStreet: "utf8StringValue", pbstrPoBox: "utf8StringValue", pbstrZip: "utf8StringValue", pbstrCity: "utf8StringValue", pbstrStateCode: "utf8StringValue", pbstrCountryCode: "utf8StringValue", pbstrPhone1: "utf8StringValue", pbstrPhone2: "utf8StringValue", pbstrPhone3: "utf8StringValue", pbstrFax: "utf8StringValue", pbstrEMail: "utf8StringValue", pbstrUrl: "utf8StringValue" }, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetContact( | BSTR IAddress VARIANT_BOOL | *pbstrEAN, **pIAddress, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrEAN | The EAN number of the contact as supplied by Stiftung Refdata |
[out] IAddress | **pIAddress | The pIAddress is an Iaddress interface handle for the primary contact address. The interface handle allows to get the structured address data back. The address is either one of a person, a company, or an employee of an company. In the latter case the employee's full name is coded into the subaddressing field. If no address is defined then the handle is NULL. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • ICareCreditResponse
  • GetCreditObject

ICareCreditResponse::GetCreditObject method |  |  | space
Retrieves the optional care credit object reference parameters. In fact this object reference is mirrored from the corresponding care credit request infoset. The page "object reference" provides an in-depth description of the concepts of "object reference", "object reference chain", and "topmost object reference". |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ICareCreditResponse/GetCreditObject
[JSON input data] | pICareCreditResponse: | longValue, //interface address
[JSON result data] | pbstrRequestCreditID: pdRequestCreditDate: plRequestCreditTimestamp: pbStatus: | "utf8StringValue", "stringISODateValue", longValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetCreditObject( | BSTR DATE long VARIANT_BOOL | *pbstrRequestCreditID, *pdRequestCreditDate, *plRequestCreditTimestamp, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrRequestCreditID | The request ID is the main software's identification of the care credit ("Bedarfsmeldungsnummer") - mirrored from the request. This is one of 3 identifiers that form the credit object reference. |
[out] DATE | *pdRequestCreditDate | The request date is the main software's date of the care credit request ("Bedarfsmeldungsdatum") - mirrored from the request. This is one of 3 identifiers that form the credit object reference. |
[out] long | *plRequestCreditTimestamp | This is a UNIX timestamp defined at the moment of the care credit's infoset generation - mirrored from the request. This is one of 3 identifiers that form the credit object reference. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then no credit object reference was defined |
space |


  • ICareCreditResponse
  • GetDebitor

ICareCreditResponse::GetDebitor method |  |  | space
Retrieves the structured address and EAN of the debitor of the initial request. The structured address data is read via the methods of the returned IAddress interface instance. Note that this is only a safety measure for a crosscheck. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ICareCreditResponse/GetDebitor
[JSON input data] | pICareCreditResponse: | longValue, //interface address
[JSON result data] | pbstrEAN: pIAddress: pbStatus: | "utf8StringValue", { pbIsPrivateAddress: true, pbstrCompanyName: "utf8StringValue", pbstrDepartment: "utf8StringValue", pbstrSalutation: "utf8StringValue", pbstrTitle: "utf8StringValue", pbstrFamilyname: "utf8StringValue", pbstrGivenname: "utf8StringValue", pbstrSubaddressing: "utf8StringValue", pbstrStreet: "utf8StringValue", pbstrPoBox: "utf8StringValue", pbstrZip: "utf8StringValue", pbstrCity: "utf8StringValue", pbstrStateCode: "utf8StringValue", pbstrCountryCode: "utf8StringValue", pbstrPhone1: "utf8StringValue", pbstrPhone2: "utf8StringValue", pbstrPhone3: "utf8StringValue", pbstrFax: "utf8StringValue", pbstrEMail: "utf8StringValue", pbstrUrl: "utf8StringValue" }, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetDebitor( | BSTR IAddress VARIANT_BOOL | *pbstrEAN, **pIAddress, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrEAN | The EAN number of the debitor of the initial request as supplied by Stiftung Refdata |
[out] IAddress | **pIAddress | The instance of a IAddress interface that allows to read back the structured address data. If no address is defined then the handle is NULL. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • ICareCreditResponse
  • GetDocuments

ICareCreditResponse::GetDocuments method | space
This method has a Restful Webservice representation only!
Method for collecting all document data covered by the ICareCreditResponse interface and returned as JSON array.

Please note that ICareCreditResponse::GetDocuments takes over the functionality of the iterator pair ICareCreditResponse::GetFirstDocument / ICareCreditResponse::GetNextDocument with a single call, making the latter superfluous.
space
Restful webservice calling syntax
[POST] | /baseURL/ ICareCreditResponse/GetDocuments
[JSON input data] pICareCreditResponse: longValue, //interface address
[JSON result array] { pbstrFile:
pbstrTitle:
pbstrMimeType:
pbStatus: 		"utf8StringValue",
"utf8StringValue",
"utf8StringValue",
booleanValue
},
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
Calling argument description
[out] BSTR *pbstrFile *pbstrFile supplies the full file name (path + name) of the document in a temporary working directory.

Be sure to copy away the file to a different location as all files in the working directory are deleted before the COM module shuts down!

In Restful webservice output: pbstrFile is a relative URL that subsequently must be downloaded by a GET process.

[out] BSTR | *pbstrTitle | The title of the document on the primary system. It thus describes the document to a certain degree in terms of its semantic content.
[out] BSTR *pbstrMimeType The MIME type of the document.

Since the underlying XSD schema restricts the type of files, the MIME type must be one of

  • application/pdf for PDF files
  • image/jpeg for JPG graphic files
  • image/png for PNG graphic files
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached
space


  • ICareCreditResponse
  • GetFirstDocument

ICareCreditResponse::GetFirstDocument method | space
Retrieves the first document from the list of documents.

VARIANT_FALSE is returned if the end of the document list is reached.

space
Restful webservice calling syntax
[POST] | /baseURL/ ICareCreditResponse/GetFirstDocument
[JSON input data] pICareCreditResponse: longValue, //interface address
[JSON result data] pbstrFile:
pbstrTitle:
pbstrMimeType:
pbStatus: 		"utf8StringValue",
"utf8StringValue",
"utf8StringValue",
booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
HRESULT GetFirstDocument( BSTR
BSTR
BSTR
VARIANT_BOOL 		*pbstrFile,
*pbstrTitle,
*pbstrMimeType,
*pbStatus);
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out] BSTR *pbstrFile *pbstrFile supplies the full file name (path + name) of the document in a temporary working directory.
Be sure to copy away the file to a different location as all files in the working directory are deleted before the COM module shuts down!

In Restful Webservice output: pbstrFile is a relative URL that subsequently must be downloaded by a GET process.

[out] BSTR | *pbstrTitle | The title of the document on the primary system. It thus describes the document to a certain degree in terms of its semantic content.
[out] BSTR *pbstrMimeType The MIME type of the document.

Since the underlying XSD schema restricts the type of files, the MIME type must be one of

  • application/pdf for PDF files
  • image/jpeg for JPG graphic files
  • image/png for PNG graphic files
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached
space


  • ICareCreditResponse
  • GetFirstNotification

ICareCreditResponse::GetFirstNotification method |  |  | space
Retrieves the first notification object. The notification is casted as message if GetResponse= enResponsePending or is casted as error if GetResponse= enResponseRejected. The GetResponse= enResponseAccepted has no notifications per definition. VARIANT_FALSE is returned if the end of the object list is reached. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ICareCreditResponse/GetFirstNotification
[JSON input data] | pICareCreditResponse: | longValue, //interface address
[JSON result data] | pbstrCode: pbstrText: peIsAnError: plRecordID: pbstrErrorValue: pbstrValidValue: pbStatus: | "utf8StringValue", "utf8StringValue", longValue, longValue, "utf8StringValue", "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetFirstNotification( | BSTR BSTR YesNoType long BSTR BSTR VARIANT_BOOL | *pbstrCode, *pbstrText, *peIsAnError, *plRecordID, *pbstrErrorValue, *pbstrValidValue, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrCode | A message or error code dependent on the notification type. Note that this code is defined by the "fromEAN" entity and is not standardized. |
[out] BSTR | *pbstrText | A message or error text dependent on the notification type. Note that this text is defined by the "fromEAN" entity and is not standardized. |
[out] YesNoType | *peIsAnError | A Boolean that defines if it is an error or a message. In the latter case bstrErrorValue and bstrValidValue are empty and lRecordID is set to 0. |
[out] long | *plRecordID | A record sequence number from the request uniquely identifying the target service record. If eIsAnError=enYes or the error is not related to a service record lRecordID is 0. |
[out] BSTR | *pbstrErrorValue | The erroneous/incorrect value if the notification is casted as error (eIsAnError=enYes) otherwise 0 |
[out] BSTR | *pbstrValidValue | The valid/correct value if the notification is casted as error (eIsAnError=enYes) otherwise 0 |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
space |


  • ICareCreditResponse
  • GetGenerator

ICareCreditResponse::GetGenerator method |  |  | space
Retrieves the identification parameters of the sender's XML infoset generator software. This information primarily serves as source of responsibility in cases of technical problems with the underlying XML infoset. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ICareCreditResponse/GetGenerator
[JSON input data] | pICareCreditResponse: | longValue, //interface address
[JSON result data] | pbstrSoftwarePackage: plSoftwareVersion: plSoftwareID: pbstrSoftwareCopyright: pbStatus: | "utf8StringValue", longValue, longValue, "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetGenerator( | BSTR long long BSTR VARIANT_BOOL | *pbstrSoftwarePackage, *plSoftwareVersion, *plSoftwareID, *pbstrSoftwareCopyright, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrSoftwarePackage | Name of the sender's XML infoset generator software |
[out] long | *plSoftwareVersion | Version of the sender's XML infoset generator software coded as 32-bit value where lSoftwareVersion = 100*Major version + Minor version. |
[out] long | *plSoftwareID | Optional ID of the sender's XML infoset generator software |
[out] BSTR | *pbstrSoftwareCopyright | The copyright notice of the sender's XML infoset generator software |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • ICareCreditResponse
  • GetInsurance

ICareCreditResponse::GetInsurance method |  |  | space
Retrieves the insurance's EAN of the initial request. Note that this is only a safety measure for a crosscheck. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ICareCreditResponse/GetInsurance
[JSON input data] | pICareCreditResponse: | longValue, //interface address
[JSON result data] | pbstrEAN: pbStatus: | "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetInsurance( | BSTR VARIANT_BOOL | *pbstrEAN, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrEAN | The EAN number of the insurance as supplied by Stiftung Refdata |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • ICareCreditResponse
  • GetNextDocument

ICareCreditResponse::GetNextDocument method | space
Retrieves the next document from the list of documents.

VARIANT_FALSE is returned if the end of the document list is reached.

space
Restful webservice calling syntax
[POST] | /baseURL/ ICareCreditResponse/GetNextDocument
[JSON input data] pICareCreditResponse: longValue, //interface address
[JSON result data] pbstrFile:
pbstrTitle:
pbstrMimeType:
pbStatus: 		"utf8StringValue",
"utf8StringValue",
"utf8StringValue",
booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
HRESULT GetNextDocument( BSTR
BSTR
BSTR
VARIANT_BOOL 		*pbstrFile,
*pbstrTitle,
*pbstrMimeType,
*pbStatus);
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out] BSTR *pbstrFile *pbstrFile supplies the full file name (path + name) of the document in a temporary working directory.
Be sure to copy away the file to a different location as all files in the working directory are deleted before the COM module shuts down!

In Restful Webservice output: pbstrFile is a relative URL that subsequently must be downloaded by a GET process.

[out] BSTR | *pbstrTitle | The title of the document on the primary system. It thus describes the document to a certain degree in terms of its semantic content.
[out] BSTR *pbstrMimeType The MIME type of the document.

Since the underlying XSD schema restricts the type of files, the MIME type must be one of

  • application/pdf for PDF files
  • image/jpeg for JPG graphic files
  • image/png for PNG graphic files
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached
space


  • ICareCreditResponse
  • GetNextNotification

ICareCreditResponse::GetNextNotification method |  |  | space
Retrieves the next notification object. The notification is casted as message if GetResponse= enResponsePending or is casted as error if GetResponse= enResponseRejected. The GetResponse= enResponseAccepted has no notifications per definition. VARIANT_FALSE is returned if the end of the object list is reached. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ICareCreditResponse/GetNextNotification
[JSON input data] | pICareCreditResponse: | longValue, //interface address
[JSON result data] | pbstrCode: pbstrText: peIsAnError: plRecordID: pbstrErrorValue: pbstrValidValue: pbStatus: | "utf8StringValue", "utf8StringValue", longValue, longValue, "utf8StringValue", "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetNextNotification( | BSTR BSTR YesNoType long BSTR BSTR VARIANT_BOOL | *pbstrCode, *pbstrText, *peIsAnError, *plRecordID, *pbstrErrorValue, *pbstrValidValue, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrCode | A message or error code dependent on the notification type. Note that this code is defined by the "fromEAN" entity and is not standardized. |
[out] BSTR | *pbstrText | A message or error text dependent on the notification type. Note that this text is defined by the "fromEAN" entity and is not standardized. |
[out] YesNoType | *peIsAnError | A Boolean that defines if it is an error or a message. In the latter case bstrErrorValue and bstrValidValue are empty and lRecordID is set to 0. |
[out] long | *plRecordID | A record sequence number from the request uniquely identifying the target service record. If eIsAnError=enYes or the error is not related to a service record lRecordID is 0. |
[out] BSTR | *pbstrErrorValue | The erroneous/incorrect value if the notification is casted as error (eIsAnError=enYes) otherwise 0 |
[out] BSTR | *pbstrValidValue | The valid/correct value if the notification is casted as error (eIsAnError=enYes) otherwise 0 |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
space |


  • ICareCreditResponse
  • GetNotifications

ICareCreditResponse::GetNotifications method |  |  | space
This method has a Restful Webservice representation only! Method for collecting all notification objects covered by the ICareCreditResponse interface and returned as JSON array. Please note that ICareCreditResponse::GetNotifications takes over the functionality of the iterator pair ICareCreditResponse::GetFirstNotification / ICareCreditResponse::GetNextNotification with a single call, making the latter superfluous. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ICareCreditResponse/GetNotifications
[JSON input data] | pICareCreditResponse: | longValue, //interface address
[JSON result array] | { pbstrCode: pbstrText: peIsAnError: plRecordID: pbstrErrorValue: pbstrValidValue: pbStatus: | "utf8StringValue", "utf8StringValue", longValue, longValue, "utf8StringValue", "utf8StringValue", booleanValue },
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrCode | A message or error code dependent on the notification type. Note that this code is defined by the "fromEAN" entity and is not standardized. |
[out] BSTR | *pbstrText | A message or error text dependent on the notification type. Note that this text is defined by the "fromEAN" entity and is not standardized. |
[out] YesNoType | *peIsAnError | A Boolean that defines if it is an error or a message. In the latter case bstrErrorValue and bstrValidValue are empty and lRecordID is set to 0. |
[out] long | *plRecordID | A record sequence number from the request uniquely identifying the target service record. If eIsAnError=enYes or the error is not related to a service record lRecordID is 0. |
[out] BSTR | *pbstrErrorValue | The erroneous/incorrect value if the notification is casted as error (eIsAnError=enYes) otherwise 0 |
[out] BSTR | *pbstrValidValue | The valid/correct value if the notification is casted as error (eIsAnError=enYes) otherwise 0 |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
space |


  • ICareCreditResponse
  • GetPackage

ICareCreditResponse::GetPackage method |  |  | space
Retrieves the identification parameters of the sender's main software. Since the package information is optionally VARIANT_FALSE is returned if the sender's main software is undefined. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ICareCreditResponse/GetPackage
[JSON input data] | pICareCreditResponse: | longValue, //interface address
[JSON result data] | pbstrSoftwarePackage: plSoftwareVersion: plSoftwareID: pbstrSoftwareCopyright: pbStatus: | "utf8StringValue", longValue, longValue, "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetPackage( | BSTR long long BSTR VARIANT_BOOL | *pbstrSoftwarePackage, *plSoftwareVersion, *plSoftwareID, *pbstrSoftwareCopyright, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrSoftwarePackage | Name of the main software . |
[out] long | *plSoftwareVersion | Version of the main software coded as 32-bit value where lSoftwareVersion = 100*Major version + Minor version. |
[out] long | *plSoftwareID | Optional ID of the main software |
[out] BSTR | *pbstrSoftwareCopyright | The copyright notice of the main software. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then no package data is available |
space |


  • ICareCreditResponse
  • GetPatient

ICareCreditResponse::GetPatient method | space
Retrieves the primary parameters and structured address of the patient - these data are mirrored from the request.

The address is defined via an IAddress interface pointer and the address data must be retrieved using the methods of IAddress.

space
Restful webservice calling syntax
[POST] | /baseURL/ ICareCreditResponse/GetPatient
[JSON input data] pICareCreditResponse: longValue, //interface address
[JSON result data] peSexType:
pdBirthdate:
pbstrSSN:
pIAddress:

pbStatus: 		longValue,
"stringISODateValue",
"utf8StringValue",
{
pbIsPrivateAddress: true,
pbstrCompanyName: "utf8StringValue",
pbstrDepartment: "utf8StringValue",
pbstrSalutation: "utf8StringValue",
pbstrTitle: "utf8StringValue",
pbstrFamilyname: "utf8StringValue",
pbstrGivenname: "utf8StringValue",
pbstrSubaddressing: "utf8StringValue",
pbstrStreet: "utf8StringValue",
pbstrPoBox: "utf8StringValue",
pbstrZip: "utf8StringValue",
pbstrCity: "utf8StringValue",
pbstrStateCode: "utf8StringValue",
pbstrCountryCode: "utf8StringValue",
pbstrPhone1: "utf8StringValue",
pbstrPhone2: "utf8StringValue",
pbstrPhone3: "utf8StringValue",
pbstrFax: "utf8StringValue",
pbstrEMail: "utf8StringValue",
pbstrUrl: "utf8StringValue"
},
booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
HRESULT GetPatient( SexType
DATE
BSTR
IAddress
VARIANT_BOOL 		*peSexType,
*pdBirthdate,
*pbstrSSN,
**pIAddress,
*pbStatus);
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out] SexType | *peSexType | The patient's gender.
[out] DATE | *pdBirthdate | The patient's birthdate.
[out] BSTR *pbstrSSN The social security number (SSN) of the patient in its printed form whereupon 3 distinguished types are possible:
  • the old 11 digit Swiss SSN ("AHV-Nummer") as defined by Federal Social Insurance Office
  • the new 13 digit Swiss SSN ("SV-Nummer") beginning with 756 as defined by Federal Social Insurance Office
  • the new 4-10 digit SSN of Liechtenstein ("AHV-Nummer") as defined by Liechtensteinische AHV-IV-FAK
[out] IAddress **pIAddress The instance of a IAddress interface that allows to read back the structured address data.
If no address is defined then the handle is NULL.
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
space


  • ICareCreditResponse
  • GetPendingType

ICareCreditResponse::GetPendingType method |  |  | space
Retrieves detailed information for a response of type Pending. Call this method if the GetResponse method returns the type enResponsePending. Calling the iterator pair GetFirstNotification / GetNextNotification is only necessary if eHasMessage=enYes. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ICareCreditResponse/GetPendingType
[JSON input data] | pICareCreditResponse: | longValue, //interface address
[JSON result data] | pbstrExplanation: peStatusIn: peStatusOut: peHasMessage: pbStatus: | "utf8StringValue", longValue, longValue, longValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetPendingType( | BSTR StatusType StatusType YesNoType VARIANT_BOOL | *pbstrExplanation, *peStatusIn, *peStatusOut, *peHasMessage, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrExplanation | An optional explanation. The explanation is formulated in the data language returned by the GetResponse method |
[out] StatusType | *peStatusIn | The status of the invoice/reminder request (given by the topmost object reference) before this response was generated |
[out] StatusType | *peStatusOut | The status of the invoice/reminder request (given by the topmost object reference) after this response was generated |
[out] YesNoType | *peHasMessage | A Boolean that defines if messages are available in which case the iterator pair GetFirstNotification / GetNextNotification should be called. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • ICareCreditResponse
  • GetProvider

ICareCreditResponse::GetProvider method |  |  | space
Retrieves the provider's EAN of the initial request. Note that this is only a safety measure for a crosscheck. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ICareCreditResponse/GetProvider
[JSON input data] | pICareCreditResponse: | longValue, //interface address
[JSON result data] | pbstrEAN: pbStatus: | "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetProvider( | BSTR VARIANT_BOOL | *pbstrEAN, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrEAN | The EAN number of the provider of the initial request as supplied by Stiftung Refdata |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • ICareCreditResponse
  • GetRejectType

ICareCreditResponse::GetRejectType method |  |  | space
Retrieves detailed information for a response of type Rejected. Call this method if the GetResponse method returns the type enResponseRejected. Calling the iterator pair GetFirstNotification / GetNextNotification is only necessary if eHasError=enYes. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ICareCreditResponse/GetRejectType
[JSON input data] | pICareCreditResponse: | longValue, //interface address
[JSON result data] | pbstrExplanation: peStatusIn: peStatusOut: peHasError: pbStatus: | "utf8StringValue", longValue, longValue, longValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetRejectType( | BSTR StatusType StatusType YesNoType VARIANT_BOOL | *pbstrExplanation, *peStatusIn, *peStatusOut, *peHasError, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrExplanation | An optional explanation. The explanation is formulated in the data language returned by the GetResponse method |
[out] StatusType | *peStatusIn | The status of the invoice/reminder request (given by the topmost object reference) before this response was generated |
[out] StatusType | *peStatusOut | The status of the invoice/reminder request (given by the topmost object reference) after this response was generated |
[out] YesNoType | *peHasError | A Boolean that defines if errors are available in which case the iterator pair GetFirstNotification / GetNextNotification should be called. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • ICareCreditResponse
  • GetResponse

ICareCreditResponse::GetResponse method | space
Returns the primary parameters of the response infoset, namely the operation modus, the language the infoset is formulated, and most important the type of the response.

Based on the response type one of the following methods should be called:

GetAcceptType | Per definition this means that the corresponding request is fully accepted and will be processed to a final stage. An optional explanation might be supplied but no messages.
GetPendingType | Per definition this means that the corresponding request can not be processed to a final stage as some data are missing. An optional explanation and [0,n] messages (instructions) are supplied to "unfreeze" the request.
GetRejectType | Per definition this means that the corresponding request is rejected and as a consequence the status of the request goes to the "canceled" state. An optional explanation and [0,n] errors are supplied to justify the decision.
space
Restful webservice calling syntax
[POST] | /baseURL/ ICareCreditResponse/GetResponse
[JSON input data] pICareCreditResponse: longValue, //interface address
[JSON result data] peDataLanguage:
plResponseTimestamp:
peIsStorno:
peIsCopy:
peResponseType:
peModusType:
pbStatus: 		longValue,
longValue,
longValue,
longValue,
longValue,
longValue,
booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
HRESULT GetResponse( LanguageType
long
YesNoType
YesNoType
ResponseType
ModusType
VARIANT_BOOL 		*peDataLanguage,
*plResponseTimestamp,
*peIsStorno,
*peIsCopy,
*peResponseType,
*peModusType,
*pbStatus);
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out] LanguageType *peDataLanguage The language in which the response is formulated.

Note, that the data language and the module language (given by IGeneralInvoiceResponseManager::SetModuleLanguage) are independent and can be different!

[out] long | *plResponseTimestamp | This is a UNIX timestamp defined at the moment of the care credit's infoset generation.
[out] YesNoType *peIsStorno Boolean value that defines the "storno" status of the sent request.

Note that this is the initial value of the request mirrored in the response

[out] YesNoType *peIsCopy Boolean value that defines the "copy" status of the sent request.

Note that this is the initial value of the request mirrored in the response

[out] ResponseType | *peResponseType | The main response type.
[out] ModusType *peModusType The operation modus.

The default modus is enProduction whereas for developing/debugging purposes enTest has to be set.

[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
space


  • ICareCreditResponse
  • GetTransport

ICareCreditResponse::GetTransport method | space
Returns the transport information that is the routing information going from a sender (from) over at least one intermediate (via) to the receiver (to). All the involved parties are defined by EAN numbers as defined by Stiftung Refdata.

In fact the meaning and the data is mirrored from the corresponding request thus the initial sender becomes the recipient and the initial recipient becomes the sender. Furthermore the chain of intermediates from the request is reversed and the infoset is sent to the first intermediate of the reversed list. The given intermediate here is therefore the last one before reaching the receiver.

If the parameters for the signature and encryption were set then these data are returned as well otherwise the corresponding variables are empty.

space
Restful webservice calling syntax
[POST] | /baseURL/ ICareCreditResponse/GetTransport
[JSON input data] pICareCreditResponse: longValue, //interface address
[JSON result data] pbstrFromEAN:
pbstrViaEAN:
pbstrToEAN:
pbstrToBinDERFile:
pbStatus: 		"utf8StringValue",
"utf8StringValue",
"utf8StringValue",
"utf8StringValue",
booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
HRESULT GetTransport( BSTR
BSTR
BSTR
BSTR
VARIANT_BOOL 		*pbstrFromEAN,
*pbstrViaEAN,
*pbstrToEAN,
*pbstrToBinDERFile,
*pbStatus);
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out] BSTR *pbstrFromEAN The EAN number of the sender as supplied by Stiftung Refdata

Note that this is the initial receiver of the request since the transport information from the request is mirrored in the response

[out] BSTR *pbstrViaEAN The EAN number of the last intermediate as supplied by Stiftung Refdata

Note that this is the initial (first) intermediate of the request since the transport information from the request is mirrored in the response

[out] BSTR *pbstrToEAN The EAN number of the receiver as supplied by Stiftung Refdata

Note that this is the initial sender of the request since the transport information from the request is mirrored in the response

[out] BSTR *pbstrToBinDERFile If the XML infoset was signed then bstrToBinDERFile is a full file name (path + name) to the extracted binary DER certificate that is the public certificate of the "from" entity. The certificate file is named X509DER_FromEAN.cer and must be copied away since the used temporary directory is emptied when the module shuts down.

Note that this certificate can be used to encrypt a request XML infoset for the "from" entity.

[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
space


  • ICareCreditResponse
  • GetTreatment

ICareCreditResponse::GetTreatment method |  |  | space
Retrieves the basic treatment parameters mirrored of the initial request. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ICareCreditResponse/GetTreatment
[JSON input data] | pICareCreditResponse: | longValue, //interface address
[JSON result data] | pdDateBegin: pdDateEnd: peTreatmentCanton: peTreatmentType: peTreatmentReason: pbStatus: | "stringISODateValue", "stringISODateValue", longValue, longValue, longValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetTreatment( | DATE DATE CantonType TreatmentType TreatmentReasonType VARIANT_BOOL | *pdDateBegin, *pdDateEnd, *peTreatmentCanton, *peTreatmentType, *peTreatmentReason, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] DATE | *pdDateBegin | dDateBegin is the start of the treatment Note, that the date of every service must be greater or equal dDateBegin otherwise it is a content error |
[out] DATE | *pdDateEnd | dDateEnd is the end of the treatment Note, that the date of every service must be less or equal dDateEnd otherwise it is a content error |
[out] CantonType | *peTreatmentCanton | The treatment canton given by the CantonType enumeration |
[out] TreatmentType | *peTreatmentType | The treatment type given by the TreatmentType enumeration |
[out] TreatmentReasonType | *peTreatmentReason | The treatment reason given by the TreatmentReasonType enumeration |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • ICareCreditResponse
  • DestructCareCreditResponse

ICareCreditResponse::DestructCareCreditResponse property |  |  | space
This property has a Restful Webservice representation only! Destructs/invalidates this ICareCreditResponse interface instance. |  |  |
space
Restful webservice calling syntax |  |  |
[PUT] | /baseURL/ ICareCreditResponse/PutDestructCareCreditResponse
[JSON input data] | pICareCreditResponse: | longValue, //interface address
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Remarks |  |  |
This property has a Restful Webservice representation only! |  |  |
space |


  • ICareCreditResponseManager

ICareCreditResponseManager interface |  | V4.50/ 6 May 2019
The ICareCreditResponseManager provides methods to load and analyze XML infosets of type careCreditResponse_450. These infosets are responses to a previously sent "nursing care credit" requests where the topmost object reference defines the target request. The loaded data can be printed out and/or retrieved with the returned ICareCreditResponse interface. The subchapter object reference provides an in-depth description of the concept of "object reference". |  | space
space
Methods |  | 8 methods
GetAbortInfo | Gets the abort information string with the error coded in the module language |
GetLogSettings | Get the log settings for the module. |
GetXMLInfo | Preloads and analyzes a XML infoset regarding the accepted schema versions and other important information like the encryption status |
LoadXML | Loads a received XML infoset back into memory for further processing via the returned interface instance |
Print | The Print method is a visualization aid to preview/print the currently loaded data on screen or onto the local printer |
PrintAdjust | Shows the print object adjustment dialog that allows to move print objects of a .vps report generator file |
PrintSetup | Shows the printer setup dialog that allows to define the printer and its settings |
SetLogSettings | Sets the log settings for the module |
space
Properties |  | 6 properties
[get] CreateCareCreditResponseManager | Creates an instance of the main ICareCreditResponseManager interface |
[put] DestructCareCreditResponse | Destructs/invalidates this ICareCreditResponse interface instance. |
[put] DestructCareCreditResponseManager | Destructs/invalidates a main instance of the ICareCreditResponseManager interface |
[get/put] ModuleLanguage | Gets/Sets the language for the module i.e |
[get] ModuleVersion | Gets the version of the CareCreditResponseManager module. |
[get] ModuleVersionText | Gets the version of the CareCreditResponseManager module in textual form. |
space |


  • ICareCreditResponseManager
  • GetAbortInfo

ICareCreditResponseManager::GetAbortInfo method |  |  | space
Gets the abort information string with the error coded in the module language. Call this method whenever the returned pbStatus variable of the primarily called method is VARIANT_FALSE and this primarily called method is not an iterator (GetFirst/GetNext methods). In the later case VARIANT_FALSE signals the end of data. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ICareCreditResponseManager/GetAbortInfo
[JSON input data] | pICareCreditResponseManager: | longValue, //interface address
[JSON result data] | pbstrAbort: pbStatus: | "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetAbortInfo( | BSTR VARIANT_BOOL | *pbstrAbort, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrAbort | Abort information string coded in the module language. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error-in-error situation occurred. |
space |


  • ICareCreditResponseManager
  • GetLogSettings

ICareCreditResponseManager::GetLogSettings method | space
Get the log settings for the module.
space
Restful webservice calling syntax
[POST] | /baseURL/ ICareCreditResponseManager/GetLogSettings
[JSON input data] pICareCreditResponseManager: longValue, //interface address
[JSON result data] plLogLevel:
plMaxSizeKB:
peDoArchive:
pbstrArchiveDir:
pbStatus: 		longValue,
longValue,
longValue,
"utf8StringValue",
booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
HRESULT GetLogSettings( long
long
YesNoType
BSTR
VARIANT_BOOL 		*plLogLevel,
*plMaxSizeKB,
*peDoArchive,
*pbstrArchiveDir,
*pbStatus);
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out] long *plLogLevel The log activity level where
lLogLevel = 0 | Logging is turned off
lLogLevel = 1 | Normal log activity
lLogLevel > 1 | Debug log activity. Use this level only for debugging purposes
[out] long | *plMaxSizeKB | The maximum size in KB of the log file.
[out] YesNoType | *peDoArchive | eDoArchive defines if the log file is recycled if the maximum size is reached (enNo) or if the log file is archived (enYes).
[out] BSTR | *pbstrArchiveDir | The base directory where log files are archived. bstrArchiveDir is only defined if eDoArchive=enYes otherwise bstrArchiveDir is empty.
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
space


  • ICareCreditResponseManager
  • GetXMLInfo

ICareCreditResponseManager::GetXMLInfo method |  |  | space
Preloads and analyzes a XML infoset regarding the accepted schema versions and other important information like the encryption status. The careCreditResponse450 COM module understands and processes the careCreditResponse_450 XSD standard. Infosets of another XSD standard will return an error. This method should be called before calling LoadXML since the infoset is possibly encrypted. In this situation the corresponding PFX certificate and password must be supplied in the LoadXML method. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ICareCreditResponseManager/GetXMLInfo
[JSON input data] | pICareCreditResponseManager: bstrInputFile: | longValue, //interface address "utf8StringValue"
[JSON result data] | pbstrUsedSchema: pbstrFromEAN: pbstrToEAN: peIsEncrypted: pbStatus: | "utf8StringValue", "utf8StringValue", "utf8StringValue", longValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetXMLInfo( | BSTR BSTR BSTR BSTR YesNoType VARIANT_BOOL | bstrInputFile, *pbstrUsedSchema, *pbstrFromEAN, *pbstrToEAN, *peIsEncrypted, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrInputFile | The input XML infoset (full file name) that must be loaded and analyzed. |
[out] BSTR | *pbstrUsedSchema | The name of the corresponding XSD schema is connected with that loaded the XML infoset. |
[out] BSTR | *pbstrFromEAN | The transport EAN number of the sender as supplied by Stiftung Refdata Note that this is the initial receiver of the request since the transport information from the request is mirrored in the response |
[out] BSTR | *pbstrToEAN | The transport EAN number of the receiver as supplied by Stiftung Refdata Note that this is the initial sender of the request since the transport information from the request is mirrored in the response |
[out] YesNoType | *peIsEncrypted | A Boolean that defines if the XML infoset is encrypted. If true the private PFX certificate/password of the "to" entity must be given in the LoadXML method otherwise the infoset can not be decrypted. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • ICareCreditResponseManager
  • LoadXML

ICareCreditResponseManager::LoadXML method | space
Loads a received XML infoset back into memory for further processing via the returned interface instance. The careCreditResponse450 COM module understands and processes the careCreditResponse_450 XSD standard.

To analyze and retrieve the received data use the returned instance of the ICareCreditResponse interface and/or preview/print the data.

Since the infoset is possibly encrypted, call GetXMLInfo to decide if and which PFX certificate to supply for the decryption process.

space
Restful webservice calling syntax
[POST] | /baseURL/ ICareCreditResponseManager/LoadXML?param
[param] pICareCreditResponseManager=longValue&
bstrInputFile=urlEncodedString&
bstrToPFXFile=urlEncodedString&
bstrToPFXPassword=urlEncodedString
+
<application/octet-stream> input_file_upload_stream
[JSON result data] pICareCreditResponse:
pbStatus: 		longValue,
booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
HRESULT LoadXML( BSTR
BSTR
BSTR
ICareCreditResponse
VARIANT_BOOL 		bstrInputFile,
bstrToPFXFile,
bstrToPFXPassword,
**pICareCreditResponse,
*pbStatus);
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[in] BSTR | bstrInputFile | The input XML infoset (full file name) that must be loaded and analyzed.
[in] BSTR bstrToPFXFile The file name of the PFX certificate that is the private certificate of the "toEAN" entity.

This variable is not used if the XML infoset is not encrypted.

[in] BSTR bstrToPFXPassword The password to open the PFX certificate.

This variable is not used if the XML infoset is not encrypted.

[out] ICareCreditResponse **pICareCreditResponse The instance of a ICareCreditResponse interface allows to read back all currently loaded data.

The handle is NULL if an error occurred.

[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
space


  • ICareCreditResponseManager
  • Print

ICareCreditResponseManager::Print method | space
The Print method is a visualization aid to preview/print the currently loaded data on screen or onto the local printer. The printer selection is done via the used report generator template file. If the template file was not connected to a printer with the PrintSetup method then the default printer with its default settings is used.

The bstrPrintTemplate variable obeys a special syntax and can be used to set special print commands like producing PDFs or changing print objects dynamically.

  • "How to generate PDF archive file" is a description about PDF archive files
  • "Syntax of the printTemplate variable"

IMPORTANT LICENSE NOTE The report engine used is Hexatech's ViewPro (www.hexatech.com). If you supply your own template files then you must have your own ViewPro license. By using this COM module, you implicitly agree upon this restriction!
space
Restful webservice calling syntax
[POST] | /baseURL/ ICareCreditResponseManager/Print
[JSON input data] pICareCreditResponseManager:
bstrPrintTemplate:
ePrintPreview: 		longValue, //interface address
"utf8StringValue",
longValue
[JSON result data] pbstrPDFFile:
pbStatus: 		"utf8StringValue",
booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
HRESULT Print( BSTR
YesNoType
VARIANT_BOOL 		bstrPrintTemplate,
ePrintPreview,
*pbStatus);
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[in] BSTR bstrPrintTemplate The bstrPrintTemplate variable is used to explicitly change print template reports and/or print objects as defined in "Syntax of the printTemplate variable".

If bstrPrintTemplate is empty then the default print template of the defined data language (IGeneralInvoiceResponse::GetResponse method) is used.

[in] YesNoType ePrintPreview A Boolean that defines if print preview is used (enYes) or printing is done (enNo)

In Restful Webservice system: ePrintPreview is automatically set to enNo no matter what the input value is. Furthermore, printing is automatically redirected to a PDF output file since there are no printers available.

[out] BSTR *pbstrPDFFile In Restful webservice output:

pbstrPDFFile is a relative URL to a PDF file holding the result of the Print method. Therefore, after receiving the JSON result data do GET pbstrPDFile such as to have the produced printout.
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
space


  • ICareCreditResponseManager
  • PrintAdjust

ICareCreditResponseManager::PrintAdjust method | space
Shows the print object adjustment dialog that allows to move print objects of a .vps report generator file.

Besides the position adjustment of any available print object, there exists the possibility of move all print objects globally.

space
Restful webservice calling syntax
This method has no Restful Webservice representation!
space
C/C++ calling syntax
HRESULT PrintAdjust( BSTR
BSTR
VARIANT_BOOL 		bstrPrintTemplate,
bstrINIPath,
*pbStatus);
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[in] BSTR bstrPrintTemplate Either a full file name (path + name) or a logical name of a target .vps report generator file for which the settings will be defined.

There are predefined .vps files that can be accessed via one of the following case insensitive logical names:

Detail[_version]_language

where
  • version is one of {_450, _440}, the absence of a version identifier defaults to _450
  • language is one of {dt, fr, it}.
For example the logical name "Detail_fr" is the French print template of version 450.
[in] BSTR bstrINIPath Optional path to a directory where the .vpd printer setting file is stored. The name of the printer setting file is the same name as the .vps file but with a .vpd extension.

If bstrINIPath is left empty then the standard directory (the directory of the dll) is used.

[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
space


  • ICareCreditResponseManager
  • PrintSetup

ICareCreditResponseManager::PrintSetup method | space
Shows the printer setup dialog that allows to define the printer and its settings. When saving the data the selected print and the currently used computer is connected with the given .vps report generator file.
space
Restful webservice calling syntax
This method has no Restful Webservice representation!
space
C/C++ calling syntax
HRESULT PrintSetup( BSTR
BSTR
VARIANT_BOOL 		bstrPrintTemplate,
bstrINIPath,
*pbStatus);
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[in] BSTR bstrPrintTemplate Either a full file name (path + name) or a logical name of a target .vps report generator file for which the settings will be defined.

There are predefined .vps files that can be accessed via one of the following case insensitive logical names:

Detail[_version]_language

where
  • version is one of {_450, _440}, the absence of a version identifier defaults to _450
  • language is one of {dt, fr, it}.
For example the logical name "Detail_fr" is the French print template of version 450.
[in] BSTR bstrINIPath Optional path to a directory where the .vpd printer setting file is stored. The name of the printer setting file is the same name as the .vps file but with a .vpd extension.

If bstrINIPath is left empty then the standard directory (the directory of the dll) is used.

[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
space


  • ICareCreditResponseManager
  • SetLogSettings

ICareCreditResponseManager::SetLogSettings method | space
Sets the log settings for the module.

The defaults for the log activity are: level=1, lMaxSizeKB=1000,eDoArchive=enNo,
and the log settings are persistent via the log file itself.

Note, that the log facility is a best effort system. If there is an error e.g. due to insufficient privileges to write the log entries then nothing is logged.

space
Restful webservice calling syntax
[POST] | /baseURL/ ICareCreditResponseManager/SetLogSettings
[JSON input data] pICareCreditResponseManager:
lLogLevel:
lMaxSizeKB:
eDoArchive:
bstrArchiveDir: 		longValue, //interface address
longValue,
longValue,
longValue,
"utf8StringValue"
[JSON result data] pbStatus: booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
HRESULT SetLogSettings( long
long
YesNoType
BSTR
VARIANT_BOOL 		lLogLevel,
lMaxSizeKB,
eDoArchive,
bstrArchiveDir,
*pbStatus);
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[in] long lLogLevel The log activity level where
lLogLevel = 0 | Logging is turned off
lLogLevel = 1 | Normal log activity
lLogLevel > 1 | Debug log activity. Use this level only for debugging purposes

Any log level below 0 is corrected to 0.

[in] long lMaxSizeKB The maximum size in KB of the log file.
Any size below 1000 KB (= the default value) is corrected to the default value
[in] YesNoType | eDoArchive | eDoArchive defines if the log file is recycled once the maximum size is reached (enNo) or if the log file is archived (enYes) into the archive directory.
[in] BSTR bstrArchiveDir Defines the base directory where log files are archived. bstrArchiveDir is only used if eDoArchive=enYes. If bstrArchiveDir is empty and eDoArchive=enYes then the place of the module is used as the base archive directory.

If the base archive directory or directories below have insufficient privileges to create directories or write files archiving is not done!

[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
space


  • ICareCreditResponseManager
  • CreateCareCreditResponseManager

ICareCreditResponseManager::CreateCareCreditResponseManager property |  |  | space
This property has a Restful Webservice representation only! Creates an instance of the main ICareCreditResponseManager interface. To delete/invalidate this interface instance, the counterpart property PutDestructCareCreditResponseManager must be explicitly called, since the pICarelCreditResponseManager address has a global scope and is not automatically destructed. |  |  |
space
Restful webservice calling syntax |  |  |
[GET] | /baseURL/ ICareCreditResponseManager/GetCreateCareCreditResponseManager?param
[param] | pICareCreditResponseManager= | longValue
[JSON result data] | pICareCreditResponseManager: | longValue //interface address
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Remarks |  |  |
This property has a Restful Webservice representation only! |  |  |
space |


  • ICareCreditResponseManager
  • DestructCareCreditResponse

ICareCreditResponseManager::DestructCareCreditResponse property |  |  | space
This property has a Restful Webservice representation only! Destructs/invalidates this ICareCreditResponse interface instance. |  |  |
space
Restful webservice calling syntax |  |  |
[PUT] | /baseURL/ ICareCreditResponseManager/PutDestructCareCreditResponse
[JSON input data] | pICareCreditResponseManager: pICareCreditResponse: | longValue, //interface address longValue, //interface address
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Remarks |  |  |
This property has a Restful Webservice representation only! |  |  |
space |


  • ICareCreditResponseManager
  • DestructCareCreditResponseManager

ICareCreditResponseManager::DestructCareCreditResponseManager property |  |  | space
This property has a Restful Webservice representation only! Destructs/invalidates a main instance of the ICareCreditResponseManager interface. Please note, that all dependent, active interface instances generated with ICareCreditResponseManager::LoadXML under this main instance are automatically destructed as well. The counterpart property to generate a main interface instance is ICareCreditResponseManager::GetCreateCareCreditResponseManager. |  |  |
space
Restful webservice calling syntax |  |  |
[PUT] | /baseURL/ ICareCreditResponseManager/PutDestructCareCreditResponseManager
[JSON input data] | pICareCreditResponseManager: | longValue, //interface address
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Remarks |  |  |
This property has a Restful Webservice representation only! |  |  |
space |


  • ICareCreditResponseManager
  • ModuleLanguage

ICareCreditResponseManager::ModuleLanguage property | space
Gets/Sets the language for the module i.e. the language in which the error strings are coded.

Note, that the module language and the data language (given by ICareCreditResponse::GetResponse) are independent and can be different!

space
Restful webservice calling syntax
[GET] | /baseURL/ ICareCreditResponseManager/GetModuleLanguage?param
[param] pICareCreditResponseManager= longValue
[JSON result data] peModuleLanguage: longValue
[PUT] | /baseURL/ ICareCreditResponseManager/PutModuleLanguage
[JSON input data] pICareCreditResponseManager:
eModuleLanguage: 		longValue, //interface address
longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | ModuleLanguage( LanguageType *peModuleLanguage );
[put] HRESULT | ModuleLanguage( LanguageType eModuleLanguage );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] LanguageType | *peModuleLanguage
[in] LanguageType | eModuleLanguage
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • LanguageType *GetModuleLanguage(void);
  • void PutModuleLanguage( LanguageType lModuleLanguage);
space


  • ICareCreditResponseManager
  • ModuleVersion

ICareCreditResponseManager::ModuleVersion property | space
Gets the version of the CareCreditResponseManager module.
space
Restful webservice calling syntax
[GET] | /baseURL/ ICareCreditResponseManager/GetModuleVersion?param
[param] pICareCreditResponseManager= longValue
[JSON result data] pbstrModuleVersion: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | ModuleVersion( BSTR *pbstrModuleVersion );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrModuleVersion
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetModuleVersion(void);
space


  • ICareCreditResponseManager
  • ModuleVersionText

ICareCreditResponseManager::ModuleVersionText property | space
Gets the version of the CareCreditResponseManager module in textual form.
space
Restful webservice calling syntax
[GET] | /baseURL/ ICareCreditResponseManager/GetModuleVersionText?param
[param] pICareCreditResponseManager= longValue
[JSON result data] pbstrModuleVersionText: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | ModuleVersionText( BSTR *pbstrModuleVersionText );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrModuleVersionText
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetModuleVersionText(void);
space


  • Type definitions

Builtin, composite & enumeration types |  | V4.50/ 6 May 2019
The following list shows ans defines all used data types either basic builtin, composite or enumeration types that are used in the interface of the ATL COM module. |  | space
space
Data types |  | 17 types
[enumeration] AddressType | Enumerates the defined types of addresses. |
[builtin] BSTR | A BSTR, known as basic string or binary string, is a pointer to a wide character string used by Automation data manipulation functions |
[enumeration] CantonType | Enumerates the defined Swiss cantons as well as countries close to the border. |
[builtin] DATE | DATE is denoting a date and time represented by a double-precision number, where midnight, January 1st, 1900 has the value 2.0, January 2nd, 1900 is 3.0, and so on. |
[builtin] HRESULT | The HRESULT data type is a 32-bit value that is used to describe an error or warning. |
[builtin] IAddress | IAddress interface object. |
[builtin] ICareCreditResponse | ICareCreditResponset interface object. |
[enumeration] LanguageType | Enumerates all supported languages. |
[builtin] long | A 4-byte integer value. |
[enumeration] ModusType | Enumerates the defined operation modus types |
[enumeration] ResponseType | Enumerates the defined main response types. |
[enumeration] SexType | Enumerates the defined basic gender types. |
[enumeration] StatusType | Enumerates the defined status types that a request object at the insurance's site can posses |
[enumeration] TreatmentReasonType | Enumerates the list of defined treatment reasons |
[enumeration] TreatmentType | Enumerates the top level treatment types. |
[builtin] VARIANT_BOOL | A 16 bit Boolean (True/False) value was specified |
[enumeration] YesNoType | Boolean enumerator. |
space |


  • Type definitions
  • AddressType

AddressType enumeration type |  |
Enumerates the defined types of addresses. |  | space
space
Set of enumeration values |  | 3 elements
enAddressUndefined: 0 | Undefined or unknown address. |
enAddressPerson: 1 | Person address. |
enAddressCompany: 2 | Company address. |
space


  • Type definitions
  • BSTR

BSTR type |
A BSTR, known as basic string or binary string, is a pointer to a wide character string used by Automation data manipulation functions. BSTRs are wide, double-byte (Unicode) strings on 32-bit Windows platforms. | space
space
space


  • Type definitions
  • CantonType

CantonType enumeration type |  |
Enumerates the defined Swiss cantons as well as countries close to the border. |  | space
space
Set of enumeration values |  | 32 elements
enCantonUndefined: 0 | Undefined or unknown canton. |
enAG: 1 | The Swiss canton is AG |
enAI: 2 | The Swiss canton is AI |
enAR: 3 | The Swiss canton is AR |
enBE: 4 | The Swiss canton is BE |
enBL: 5 | The Swiss canton is BL |
enBS: 6 | The Swiss canton is BS |
enFR: 7 | The Swiss canton is FR |
enGE: 8 | The Swiss canton is GE |
enGL: 9 | The Swiss canton is GL |
enGR: 10 | The Swiss canton is GR |
enJU: 11 | The Swiss canton is JU |
enLU: 12 | The Swiss canton is LU |
enNE: 13 | The Swiss canton is NE |
enNW: 14 | The Swiss canton is NW |
enOW: 15 | The Swiss canton is OW |
enSG: 16 | The Swiss canton is SG |
enSH: 17 | The Swiss canton is SH |
enSO: 18 | The Swiss canton is SO |
enSZ: 19 | The Swiss canton is SZ |
enTG: 20 | The Swiss canton is TG |
enTI: 21 | The Swiss canton is TI |
enUR: 22 | The Swiss canton is UR |
enVD: 23 | The Swiss canton is VD |
enVS: 24 | The Swiss canton is VS |
enZG: 25 | The Swiss canton is ZG |
enZH: 26 | The Swiss canton is ZH |
enLiechtenstein: 27 | The country is Liechtenstein |
enAustria: 28 | The country is Austria |
enGermany: 29 | The country is Germany |
enItaly: 30 | The country is Italy |
enFrance: 31 | The country is France |
space


  • Type definitions
  • DATE

DATE type |
DATE is denoting a date and time represented by a double-precision number, where midnight, January 1st, 1900 has the value 2.0, January 2nd, 1900 is 3.0, and so on. | space
space
space


  • Type definitions
  • HRESULT

HRESULT type |
The HRESULT data type is a 32-bit value that is used to describe an error or warning. | space
space
space


  • Type definitions
  • IAddress

IAddress type |
IAddress interface object. | space
space
space


  • Type definitions
  • ICareCreditResponse

ICareCreditResponse type |
ICareCreditResponset interface object. | space
space
space


  • Type definitions
  • LanguageType

LanguageType enumeration type |  |
Enumerates all supported languages. |  | space
space
Set of enumeration values |  | 3 elements
enGerman: 1 | German |
enFrench: 2 | French |
enItalian: 3 | Italian |
space


  • Type definitions
  • long

long type |
A 4-byte integer value. | space
space
space


  • Type definitions
  • ModusType

ModusType enumeration type |  |
Enumerates the defined operation modus types |  | space
space
Set of enumeration values |  | 2 elements
enProduction: 0 | Production modus. |
enTest: 1 | Test modus - the data should not be forwarded to the receiver. |
space


  • Type definitions
  • ResponseType

ResponseType enumeration type |  |
Enumerates the defined main response types. |  | space
space
Set of enumeration values |  | 3 elements
enResponsePending: 1 | The response is of type pending - the corresponding request can not be processed to a final stage as some data are missing. |
enResponseRejected: 2 | The response is of type rejected - the corresponding request is rejected and as a consequence the status of the request goes to the "canceled" state |
enResponseAccepted: 3 | The response is of type accepted - the corresponding request is fully accepted and will be processed to a final stage. |
space


  • Type definitions
  • SexType

SexType enumeration type |  |
Enumerates the defined basic gender types. |  | space
space
Set of enumeration values |  | 2 elements
enMale: 0 | Male |
enFemale: 1 | Female |
space


  • Type definitions
  • StatusType

StatusType enumeration type |  |
Enumerates the defined status types that a request object at the insurance's site can posses |  | space
space
Set of enumeration values |  | 7 elements
enStatusUnknown: 2 | The status is unknown meaning that the given object reference is unknown. |
enStatusAmbiguous: 3 | The status is ambiguous meaning that the given object reference delivers more than one result. |
enStatusReceived: 4 | The status is received meaning that nothing has been done so far except receiving the request. |
enStatusFrozen: 5 | The status is frozen meaning that the request is not processed until further data is provided - an appropriate response of that type was sent. |
enStatusProcessed: 6 | The status is processed meaning that the request has passed all processing and analysis but has not reached the granted or canceled state. |
enStatusGranted: 7 | The status is granted meaning that the request is accepted and archived as well as the requested amount was paid to the biller. |
enStatusCanceled: 8 | The status is canceled meaning that the request is canceled and archived with reject status - an appropriate response of that type was sent |
space


  • Type definitions
  • TreatmentReasonType

TreatmentReasonType enumeration type |  |
Enumerates the list of defined treatment reasons |  | space
space
Set of enumeration values |  | 6 elements
enDisease: 0 | The treatment reason is due to a disease. |
enAccident: 1 | The treatment reason is due to an accident |
enMaternity: 2 | The treatment reason is due to maternity |
enPrevention: 3 | The treatment reason is due to a prevention. |
enBirthdefect: 4 | The treatment reason is due to a birth defect |
enUnknown: 5 | The treatment reason is unknown |
space


  • Type definitions
  • TreatmentType

TreatmentType enumeration type |  |
Enumerates the top level treatment types. |  | space
space
Set of enumeration values |  | 2 elements
enAmbulatory: 0 | Ambulatory (out-patient) treatment. |
enStationary: 1 | Stationary (in-patient) treatment. |
space


  • Type definitions
  • VARIANT_BOOL

VARIANT_BOOL type |
A 16 bit Boolean (True/False) value was specified. A value of 0xFFFF (all bits 1) indicates True; a value of 0 (all bits 0) indicates False. No other values are valid. | space
space
space


  • Type definitions
  • YesNoType

YesNoType enumeration type |  |
Boolean enumerator. |  | space
space
Set of enumeration values |  | 2 elements
enNo: 0 | No. |
enYes: 1 | Yes. |
space


 Sumex1 under a 64bit architecture...

All Sumex1 COM modules are written as 32bit managed C++ dll. As a consequence, a 64bit executable cannot load a 32bit COM dll into its process space due to the addressing differences.

Since some necessary underlying sub-modules are not available in a 64bit version, this problem must be addressed differently than by a 64bit compilation. As Microsoft suggests Sumex1 uses the out-of-process proxy approach where a 32bit COM server loads the 32bit COM dll into its process space and delegates each method call to the dll. Since a 32bit COM server exists in its own process space, the main 64bit process can handle the 64/32bit boundary without problems.

As a result, each 32bit Sumex1 COM dll has a 32bit COM server counterpart with the same name and an oopProxy prefix, e.g. oopProxyCareCreditResponseManager450.exe, where the prefix signifies the out-of-process proxy nature of the executable.

Any 64bit software now creates an instance of the 32bit oopProxy server and then calls the same methods and properties as with the 32bit COM dll. However, there is one crucial difference when using the oopProxy mechanism, namely the necessity to forcefully unload to the COM server at the end e.g. by using Marshal.ReleaseComObject() since the automatic garbage collection approach is too error prone.


 Notes about the encryption

XML Encryption is a specification, governed by a W3C recommendation, that defines how to encrypt the contents of an XML element. Although XML Encryption can be used to encrypt any kind of data, it is nonetheless known as "XML Encryption" because an XML element (either an EncryptedData or EncryptedKey element) contains or refers to the cipher text, keying information, and algorithms.

However, it is beyond the scope of this documentation to explain all details of a encryption or the encryption process. Detailed information about all aspects of encryption can be found at W3C.

Boundary conditions and critical aspects

  • the encryption is optional!
  • if an infoset is encrypted then the public certificate of the recipient must be used and this certificate is applied to the body element.

    Here recipient is used in terms of the communication and therefore is defined as the EAN entity given in the transport@to attribute which is the mirrored transport@from attribute of the request
  • the namespace v1 of W3C http://www.w3.org/2001/04/xmlenc must be used- cf. XML Encryption Syntax and Processing
  • The encryption algorithm is fixed to PKCS1 (RSA-SHA1) (RFC 2437: RSA Cryptography Specifications)
  • The block encryption algorithm is fixed to Triple DES

The careCreditResponse module does understand these boundary conditions. If the response XML is encrypted (cf. ICareCreditResponseManager::GetXMLInfo) then decryption is done by loading the private PFX certificate and password of the "toEAN" (with is the mirrored "fromEAN" of the request).


 VB code snippet for using the careCreditResponseManager

Private Sub CareCreditResponseExampleButton_Click()

On Error GoTo Err_Trap

Dim bStatus As Boolean

'### CareCreditResponseManager interface
Dim careCreditRequestManagerEx As CARECREDITRESPONSEMANAGER450Lib.CareCreditResponseManager
Set careCreditRequestManagerEx = New CareCreditResponseManager

'### CareCreditResponse interface
Dim careCreditResponseEx As CareCreditResponse

Dim strXML As String
Dim strXSD As String
Dim lVersion As Long
Dim strFromEAN As String
Dim strToEAN As String
Dim bIsEncrypted As YesNoType

strXML = "Response450_Accepted01.xml"

bStatus = careCreditRequestManagerEx.GetXMLInfo(strXML,strXSD,strFromEAN,strToEAN,bIsEncrypted)
If bStatus And Not bIsEncrypted Then

    bStatus = careCreditRequestManagerEx.LoadXML(strXML, "", "", careCreditResponseEx)
    If bStatus Then
        Dim strCode As String
        Dim strText As String
        Dim bIsAnError As YesNoType
        Dim lRecordID As Long
        Dim strErrorValue As String
        Dim strValidValue As String
        Dim strOutput As String
        strOutput = ""
        bStatus = careCreditResponseEx.GetFirstNotification(strCode, strText, bIsAnError, lRecordID,  _
                                                                strErrorValue, strValidValue)
        If bStatus Then
            strOutput = strOutput + "strCode=[" + strCode + "]strText=[" + strText + "]recordID=[" +  _
                        lRecordID + "]strErrorValue=[" + strErrorValue + "]strValidValue=[" +  _
                        strValidValue + "]" + vbCrLf
            Do While careCreditResponseEx.GetNextNotification(strCode, strText, bIsAnError,  _
                                                                  lRecordID, strErrorValue, strValidValue)
                strOutput = strOutput + "strCode=[" + strCode + "]strText=[" + strText + "]recordID=[" +  _
                            lRecordID + "]strErrorValue=[" + strErrorValue + "]strValidValue=[" +  _
                            strValidValue + "]" + vbCrLf
            Loop
            MsgBox (strOutput)
        End If
    End If

End If

'### relase resources
Set careCreditResponseEx = Nothing
Set careCreditRequestManagerEx = Nothing

Exit Sub

Err_Trap:
    MsgBox "Error: " & Err.Description, vbCritical, _
           "Opps! Error" & Str$(Err.Number)

'### relase resources
Set careCreditResponseEx = Nothing
Set careCreditRequestManagerEx = Nothing

End Sub


 General use of the careCreditResponse ATL COM module

The careCreditResponse provides all the necessary tools for loading and thereafter analyzing XML infosets of type careCreditResponse_450. These infosets are responses to a previously sent nursing care credit request where the topmost object reference defines target request/response. The careCreditResponse can handle all roles and places.

The subchapter object reference provides an in-depth description of the concept of "object reference".

To get the results of such an infoset, firstly the XML file is loaded into the module by the ICareCreditResponseManager::LoadXML method. Upon successful analyzing the file the method returns a ICareCreditResponse interface. All response data and parameters of one care credit response can be retrieved by the supplied interface methods as e.g. ICareCreditResponse:GetPatient,...

The ICareCreditResponseManager::Print method can be used to visualize the whole response content.

An auxiliary interface IAddress is available for getting the address related data in a structured way.

To get a staring point there is a Visual Basic code snippet provided that can be used for using the careCreditResponse module.


 How to generate PDF archive files of a care credit response

To generate PDF archive files of a care credit response in the carecreditResponseManager use a special print object name (cf. Syntax of the printTemplate variable for an overview).

(PDF=PDF_file_to_generate;)
or
(PDF_NOPRINT=PDF_file_to_generate;)
is used as a print object name on the printTemplate variable of the Print method.

The "PDF" token means to print the response and generate the PDF files, whereas the "PDF_NOPRINT" token only generates the PDF file without physical printing.
This object definition is only used while printing and is ignored in the preview mode!

In its simplest form this means

     BSTR bstrPrintTemplate = "(PDF="+bstrPDFFile+";)";

     ICareCreditResponseManager::Print(bstrPrintTemplate,...);
in order to generate a PDF archive file of response.

Since the PDF generation is not the main purpose of the Print method this PDF feature has NO error propagation. The generation is done on a best effort basis, errors are only dumped to the log file!

Boundary conditions:

  • Only active in printing mode
  • No error propagation
  • The supplied PDF archive name must not exist
  • The directory where the PDF is stored must be writable


 Syntax of the printTemplate variable of the Print method

bstrPrintTemplate argument of the ICareCreditResponseManager::Print is either empty or of the general form given below.

If the bstrPrintTemplate variable is empty then the default print template (using the data language as language switch) is used.
However, bstrPrintTemplate can be used to change the normal printing behavior or changing printing objects dynamically. The following syntax is used as content of the bstrPrintTemplate variable:

[logTpl][(objectName1=text;...)][=printTemplateFile][#INIPATH=inipath]

where a [] pair defines an optional part. The commands are case insensitive.
  • logTpl: is the logical template name. Currently only logTpl=Detail is allowed.
  • objectName1=text; does a substitution of the content of the print object objectName1 by text. A print object is terminated by a semicolon and all print objects are enclosed in a () pair.

    There is a predefined pseudo print object with a special meaning:

    • PDF for generating PDF files

  • printTemplateFile is an external print template file name (full path + name!). If an external print template is supplied it must be mapped against a logical template. Therefore detail=full_vps_file must be used!
  • #INIPATH=inipath defines a fully qualified path to a directory where the report engine searches the corresponding .vpd print template INI files. This allows for global settings of a print template in a LAN. The default inipath is the install directory of the Dll

Here are some usage examples:
  • bstrPrintTemplate: "" or bstrPrintTemplate: Detail
    denotes a standard printing situation
  • bstrPrintTemplate: (DOCUMENT_TITLE=Alternate title for the careCredit;) prints a substituted title as given above.
  • bstrPrintTemplate: detail=C:\myForms\myPrintForm.vps
    uses the print template "C:\myForms\myPrintForm.vps". An optional INI file with the name "C:\myForms\myPrintForm.vpd" is searched under this condition.
  • bstrPrintTemplate: #INIPATH=\\host1\\myForms\
    the default path for the ini files (place of the installed component) is changed to "\\host1\\myForms\". If "\\host1\\myForms\" is accessible by all hosts of the LAN then the same INI settings can be used.


 Object reference...

The following paragraphs defines the concepts of object reference, object reference chain, and topmost object reference. These concepts are of high importance within the XML request/response system.

The description is made from the request point of view. But keep in mind that all defined object references of the request must be copied unaltered into the response.

object reference

An object reference is an identification of an individual XML request defined by a unique triple of data, namely
  • timestamp (UNIX time) defined at the moment of generation
  • date of the object defined by the provider
  • id of the object defined by the provider
Each and every XML request of version 4.5 is defined by such an object reference. All XML responses are replies to the object reference of the corresponding request.

Thus the object reference is a clustered primary key of the request/response system!

object reference chain

As a consequence of the XML schema coded business logic most XML request schemas define more than just 1 object reference, e.g. a "CareCreditRequest" can hold a maximum of 2 object references, namely
  • an optional credit_ref object reference from a previous "Care Credit Request" process
  • a mandatory credit object reference from the "Care Credit Request" process
This set of object references by itself defines an ordered object reference chain (e.g. credit_ref -> credit) with the topmost object reference as unique identification of the XML request. Therefore the object reference chain defines -on business logic point of view- dependencies among different XML requests.

topmost object reference

The end node of an object reference chain is defined as topmost object reference, that is by definition the object reference of the XML request itself. Each request/response communication is always done for this topmost object reference and only for that.


 Introduction, overview and usage of the Restful Webservice Server

The application careCreditResponseManagerServer450.exe is a Restful Webservice Server, that has the same interface methods/properties as the COM module careCreditResponseManager450.dll.
This allows to create a programming semantically similar to the COM approach but under the Restful Webservice paradigm. Consequently, on the Restful Client side there are no prevailing dependencies on Microsoft platforms and/or on Microsoft resources such as the database technology. Of course, the installation location of the server software is still subject to these restrictions.

In the next section of this document, the installation, configuration and operation of careCreditResponseManagerServer450.exe will be addressed.

Installation, registration and parameterization:
By installing the installer object careCreditResponseManager450 the COM module careCreditResponseManager450.dll as well as the out-of-process proxy component oopCareCreditResponseManager450.exe is automatically installed/registered in the system. However, the careCreditResponseManagerServer450.exe must be installed manually as a system service.
careCreditResponseManagerServer450.exe -help | Creates a help window with the the name and full version of the applicationb as well as the currently define Webservice Endpoint. Furthermore the complete list of command line switches is shown.
careCreditResponseManagerServer450.exe -install | Installs/registers the Restful Webservice Server as a system service. Please take into account, that the installation must be performed under administrator privileges
careCreditResponseManagerServer450.exe -uninstall | Uninstalls the system service component. Please take into account, that the uninstallation must be performed under administrator privileges
careCreditResponseManagerServer450.exe -setport X | Sets the port X as part of the Webservice Endpoint
Restful Webservice Endpoint:
Installing careCreditResponseManagerServer450.exe as a service activates the Restful Webservice Endpoint:
http://localhost:35339/careCreditResponseManagerServer450
which is subsumed as baseURL in the subsequent API documentation.

To run the webservice under a different URL or under https protocol, a permanent webservice target endpoint mapping is performed on the target system.
For example, under Apache, the following rewrite rule is defined:
<VirtualHost *:*>
    ProxyPreserveHost Off
    Header always set Access-Control-Allow-Origin "*"
    Header always set Access-Control-Max-Age "1000"
    Header always set Access-Control-Allow-Headers "x-requested-with, Content-Type, origin, authorization, accept, client-security-token"

    ProxyPass /careCreditResponseManager/450/ http://localhost:35339/careCreditResponseManagerServer450/
    ProxyPassReverse /careCreditResponseManager/450/ http://localhost:35339/careCreditResponseManagerServer450/
</VirtualHost>
Restful Webservice Operation:
The service might be modified after installation, for example to start under a different account, to extend the recovery properties or to change the startup type. Finally, this should be set to 'Automatic' or 'Automatic (Delayed start)' so that the service is automatically available after a system restart.
Remarks about programming:
In the rest of this document we will discuss programming of the Restful web service and the differences to the C/C++ programming of the classic COM component.

As already mentioned, Restful programming is analogous to C++ programming with the addition that each instance of an interface (including the main interface) is created via the corresponding GET function. For example, an instance of the main interface is created with:
baseURL/ICareCreditResponseManager/GetCreateCareCreditResponseManager | returns the instance address as JSON out{pICareCreditResponseManager: longValue,...}
In every further call of a method or a property of the main interface this instance address must be included as part of the JSON-In. The termination/deletion of an instance must be done via the corresponding PUT Destruct property:
baseURL/ICareCreditResponseManager/PutDestructCareCreditResponseManager | with JSON-In{pICareCreditResponseManager: longValue}, deletes the corresponding main instance AND all at that moment still active dependent subinstances (subinstances which have been generated by the explicit main instance).
It should be noted that the webserver careCreditResponseManagerServer450.exe performs an internal management of the generated instances and automatically deletes instances that have no activity for a defined period of 1 hour. If after the deletion a rest call with such an instance is made, an error (HTTP Status >= 400) is generated and the instance address is marked as unknown.
Code snippet:
Minimal code snippet to load an XML and produce a PDF representation of that input data:

    http://localhost:35339/careCreditResponseManagerServer450/ICareCreditResponseManager/GetModuleVersion?pICareCreditResponseManager=45467
        returns JSON-Out{pbstrModuleVersion: "1.00.010"}

    http://localhost:35339/careCreditResponseManagerServer450/ICareCreditResponseManager/GetModuleLanguage?pICareCreditResponseManager=45467
        returns JSON-Out{peLanguage: "1"}

    http://localhost:35339/careCreditResponseManagerServer450/ICareCreditResponseManager/LoadXML?pICareCreditResponseManager=45467&bstrInputFile=C%3A%5Ctest.xml&bstrToPFXFile=&bstrToPFXPassword=
        +  C:\test.xml
        returns JSON-Out{pICareCreditResponse: 5788991}

    http://localhost:35339/careCreditResponseManagerServer450/ICareCreditResponse/PutDestructCareCreditResponse
        JSON-IN(pICareCreditResponse: 5788991}

    http://localhost:35339/careCreditResponseManagerServer450/ICareCreditResponseManager/PutDestructCareCreditResponseManager
        JSON-IN{pICareCreditResponseManager:45467}


 Notes about the signature

XML signatures are digital signatures designed for use in XML transactions. The W3C standard defines a schema for capturing the result of a digital signature operation applied to an infoset. XML signatures add authentication, data integrity, and support for non-repudiation to the data that they sign.
However, it is beyond the scope of this documentation to explain all details of a signature or the signing process. Detailed information about all aspects of signatures can be found at W3C.

Boundary conditions and critical aspects

  • the signature is optional!
  • if an infoset is signed then the private certificate of the sender must be used and this certificate is applied to the payload element. This inherently qualifies for a detached signature.

    In this context sender is used in terms of the communication and therefore is defined as the EAN entity given in the transport@from attribute which is the mirrored transport@to attribute of the request

  • the URI attribute of the reference element must use a XPointer syntax of the payload element, e.g. <ds:Reference URI="#xpointer(/ccr:response/ccr:payload)">
  • it is recommended to add the public key via a X509Data element such that a key store can be built at the recipient's site
  • The signature algorithm is fixed to PKCS1 (RSA-SHA1) (RFC 2437: RSA Cryptography Specifications)
  • The digest algorithm is fixed to SHA-1
  • the used canonicalization algorithm must be http://www.w3.org/2001/10/xml-exc-c14n#, the exclusive XML Canonicalization

The careCreditResponse module does understand these boundary conditions. If the response XML is signed then the module extracts the X509Data element and transforms it to a binary DER format. Using the certificate the signature chain is checked. The ICareCreditResponse::GetTransport method returns a binary DER file named X509DER_from_EAN.cer. This is exactly the certificate to use for encrypting an care credit request XML infosets!