 API browser of generalCreditRequest430 COM module
Interface version: | 4.30
Interface date: | 3 Feb 2011

The GeneralCreditRequestManager is an ATL COM module which provides methods to generate a credit request for all roles and places. Such a request is printed or a XML infoset is produced which can be transported electronically to the recipient. In the latter case the request optionally can be signed and/or encrypted . Due to the processing attributes "storno" and "copy" a previously generated request object can be canceled or a copy can be produced. |  | space
Interfaces |  | 4 interface
IAddress | The utility interface IAddress is available for setting and retrieving structured address data. |
IGeneralCreditRequest | With the IGeneralCreditRequest interface all the credit related data and parameters can be set by the available interface methods |
IGeneralCreditRequestManager | The main interface IGeneralCreditRequestManager -creatable in its own right- provides all the necessary tools to produce a credit request for all roles and places. |
IGeneralCreditResult | The interface IGeneralCreditResultt allows to read back all data that have been defined with the IGeneralCreditRequest interface or by loading a previously generated XML infoset. |
Types |  |
type definitions | List of all used builtin, composite and enumeration types |
Important information about the usage and handling of the module |  |
Document | General usage of the generalCreditRequest430 COM module - an overview |
Document | Overview of the concept of "Object reference" |
Document | Notes about the processing attributes |
Document | Notes about the signature part of the XML infoset |
Document | Notes about the encryption part of the XML infoset |
Document | How to set the default printer for a certain creditRequest |
Document | Syntax of the printTemplate variable of the Print method |
Document | How to generate a PDF archive file of a MCDRequest |
Document | How to print electronic stamps onto a creditRequest |
Document | VB code snippet for using the generalCreditRequest430 COM module |

© by sumex1.net - all rights reserved


  • generalCreditRequest430
  • IAddress

IAddress interface |  | V4.30/ 3 Feb 2011
With the IAddress interface address data can be set and retrieved. The address of a person is set by the method SetPerson and a company address is entered by the method SetCompany. Before setting a new address the address data has to be initialized by the method Initialize. |  | space
Methods |  | 15 methods
AddPhone | Adds a structured phone number. |
GetAbortInfo | Get the abort information string with the error coded in the module language. |
GetCompany | Retrieves the company's naming part of the address. |
GetFax | Retrieves the structured fax number. |
GetFirstPhone | Retrieves the first phone number information. |
GetNextPhone | Retrieves the next phone number information. |
GetOnline | Retrieves the structured online part of the address. |
GetPerson | Retrieves the person's naming part of the address. |
GetPostal | Retrieves the structured postal address part of the address |
Initialize | Initializes all address variables. |
SetCompany | Sets the company's naming part of the address. |
SetFax | Sets a structured fax number. |
SetOnline | Sets the structured online part of the address. |
SetPerson | Sets the person's naming part of the address. |
SetPostal | Sets the structured postal address part. |
Properties |  | 1 properties
[get] Type | GetType returns the type of address either enAddressPerson or enAddressCompany if a address is defined at all. |


  • IAddress
  • AddPhone

IAddress::AddPhone method |  |  |
Adds a structured phone number. The Swiss international calling code +41 is filtered in the printing. If the main software does not support structured phone numbers then all data is supplied in the bstrNumber variable. However, +41 is then no longer filtered. |  |  | space
C/C++ calling syntax |  |  |
HRESULT AddPhone( | BSTR BSTR BSTR BSTR VARIANT_BOOL | bstrNumber, bstrLocalCode, bstrInternationalCode, bstrExt, *pbStatus); |
Calling argument description |  |  |
[in] BSTR | bstrNumber | Phone number. |
[in] BSTR | bstrLocalCode | Local area code. |
[in] BSTR | bstrInternationalCode | International calling code. |
[in] BSTR | bstrExt | Extension number. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IAddress
  • GetAbortInfo

IAddress::GetAbortInfo method |  |  |
Get the abort information string with the error coded in the module language. Call this method whenever the returned pbStatus variable of the primarily called method is VARIANT_FALSE and the primarily called method is not an iterator (GetFirst/GetNext). In the later case VARIANT_FALSE signals the end of data. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetAbortInfo( | BSTR VARIANT_BOOL | *pbstrAbort, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrAbort | Abort information string coded in the module language. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error-in-error situation occurred. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IAddress
  • GetCompany

IAddress::GetCompany method |  |  |
Retrieves the company's naming part of the address. Call the property GetType first to test if GetPerson or GetCompany should be called. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetCompany( | BSTR BSTR BSTR VARIANT_BOOL | *pbstrCompanyName, *pbstrDepartment, *pbstrSubaddressing, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrCompanyName | Company name. |
[out] BSTR | *pbstrDepartment | Department. |
[out] BSTR | *pbstrSubaddressing | Optional subaddressing information, e.g. c/o, P.O. box and the like |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IAddress
  • GetFax

IAddress::GetFax method |  |  |
Retrieves the structured fax number. Empty variables are returned if there is no fax number available. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetFax( | BSTR BSTR BSTR BSTR VARIANT_BOOL | *pbstrNumber, *pbstrLocalCode, *pbstrInternationalCode, *pbstrExt, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrNumber | Fax number. |
[out] BSTR | *pbstrLocalCode | Local area code. |
[out] BSTR | *pbstrInternationalCode | International calling code. |
[out] BSTR | *pbstrExt | Extension number. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IAddress
  • GetFirstPhone

IAddress::GetFirstPhone method |  |  |
Retrieves the first phone number information. VARIANT_FALSE is returned if the end of the phone list is reached. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetFirstPhone( | BSTR BSTR BSTR BSTR VARIANT_BOOL | *pbstrNumber, *pbstrLocalCode, *pbstrInternationalCode, *pbstrExt, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrNumber | Phone number. |
[out] BSTR | *pbstrLocalCode | Local area code. |
[out] BSTR | *pbstrInternationalCode | International calling code. |
[out] BSTR | *pbstrExt | Extension number. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IAddress
  • GetNextPhone

IAddress::GetNextPhone method |  |  |
Retrieves the next phone number information. VARIANT_FALSE is returned if the end of the phone list is reached |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetNextPhone( | BSTR BSTR BSTR BSTR VARIANT_BOOL | *pbstrNumber, *pbstrLocalCode, *pbstrInternationalCode, *pbstrExt, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrNumber | Phone number. |
[out] BSTR | *pbstrLocalCode | Local area code. |
[out] BSTR | *pbstrInternationalCode | International calling code. |
[out] BSTR | *pbstrExt | Extension number. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IAddress
  • GetOnline

IAddress::GetOnline method |  |  |
Retrieves the structured online part of the address. Empty variables are returned if there is no online information available. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetOnline( | BSTR BSTR VARIANT_BOOL | *pbstrEMail, *pbstrUrl, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrEMail | Email address. |
[out] BSTR | *pbstrUrl | URL. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IAddress
  • GetPerson

IAddress::GetPerson method |  |  |
Retrieves the person's naming part of the address. Call the property GetType first to test if GetPerson or GetCompany should be called. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetPerson( | BSTR BSTR BSTR BSTR BSTR VARIANT_BOOL | *pbstrFamilyname, *pbstrGivenname, *pbstrSalutation, *pbstrTitle, *pbstrSubaddressing, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrFamilyname | Family name. |
[out] BSTR | *pbstrGivenname | Given name. |
[out] BSTR | *pbstrSalutation | Salutation. |
[out] BSTR | *pbstrTitle | Title. |
[out] BSTR | *pbstrSubaddressing | Optional subaddressing information, e.g. c/o, P.O. box and the like |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IAddress
  • GetPostal

IAddress::GetPostal method |  |  |
Retrieves the structured postal address part of the address |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetPostal( | BSTR BSTR BSTR BSTR BSTR BSTR VARIANT_BOOL | *pbstrStreet, *pbstrPoBox, *pbstrZip, *pbstrCity, *pbstrStateCode, *pbstrCountryCode, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrStreet | Street. |
[out] BSTR | *pbstrPoBox | P.O. Box. |
[out] BSTR | *pbstrZip | ZIP code |
[out] BSTR | *pbstrCity | City. |
[out] BSTR | *pbstrStateCode | State code. |
[out] BSTR | *pbstrCountryCode | ISO country code. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IAddress
  • Initialize

IAddress::Initialize method |  |  |
Initializes all address variables. This method should be called before any data are supplied. |  |  | space
C/C++ calling syntax |  |  |
HRESULT Initialize( | VARIANT_BOOL | *pbStatus); |
Calling argument description |  |  |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IAddress
  • SetCompany

IAddress::SetCompany method |  |  |
Sets the company's naming part of the address. Note that the subaddressing is part of the extended name and is always printed before any postal information. |  |  | space
C/C++ calling syntax |  |  |
HRESULT SetCompany( | BSTR BSTR BSTR VARIANT_BOOL | bstrCompanyName, bstrDepartment, bstrSubaddressing, *pbStatus); |
Calling argument description |  |  |
[in] BSTR | bstrCompanyName | Company name. |
[in] BSTR | bstrDepartment | Department. |
[in] BSTR | bstrSubaddressing | Optional subaddressing information, e.g. c/o, P.O. box and the like |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IAddress
  • SetFax

IAddress::SetFax method |  |  |
Sets a structured fax number. The Swiss international calling code +41 is filtered in the printing. If the main software does not support structured pone numbers then all data is supplied in the bstrNumber variable. However, +41 is then no longer filtered. |  |  | space
C/C++ calling syntax |  |  |
HRESULT SetFax( | BSTR BSTR BSTR BSTR VARIANT_BOOL | bstrNumber, bstrLocalCode, bstrInternationalCode, bstrExt, *pbStatus); |
Calling argument description |  |  |
[in] BSTR | bstrNumber | Fax number. |
[in] BSTR | bstrLocalCode | Local area code. |
[in] BSTR | bstrInternationalCode | International calling code. |
[in] BSTR | bstrExt | Extension number. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IAddress
  • SetOnline

IAddress::SetOnline method |  |  |
Sets the structured online part of the address. |  |  | space
C/C++ calling syntax |  |  |
HRESULT SetOnline( | BSTR BSTR VARIANT_BOOL | bstrEMail, bstrUrl, *pbStatus); |
Calling argument description |  |  |
[in] BSTR | bstrEMail | Email address. |
[in] BSTR | bstrUrl | URL. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IAddress
  • SetPerson

IAddress::SetPerson method |  |  |
Sets the person's naming part of the address. Note that the subaddressing is part of the extended name and is always printed before any postal information. |  |  | space
C/C++ calling syntax |  |  |
HRESULT SetPerson( | BSTR BSTR BSTR BSTR BSTR VARIANT_BOOL | bstrFamilyname, bstrGivenname, bstrSalutation, bstrTitle, bstrSubaddressing, *pbStatus); |
Calling argument description |  |  |
[in] BSTR | bstrFamilyname | Family name. |
[in] BSTR | bstrGivenname | Given name. |
[in] BSTR | bstrSalutation | Salutation. |
[in] BSTR | bstrTitle | Title. |
[in] BSTR | bstrSubaddressing | Optional subaddressing information, e.g. "c/o" and the like |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IAddress
  • SetPostal

IAddress::SetPostal method |  |  |
Sets the structured postal address part. The Swiss ISO county code is the default but is filtered in the printing. |  |  | space
C/C++ calling syntax |  |  |
HRESULT SetPostal( | BSTR BSTR BSTR BSTR BSTR BSTR VARIANT_BOOL | bstrStreet, bstrPoBox, bstrZip, bstrCity, bstrStateCode, bstrCountryCode, *pbStatus); |
Calling argument description |  |  |
[in] BSTR | bstrStreet | Street |
[in] BSTR | bstrPoBox | P.O. Box. |
[in] BSTR | bstrZip | ZIP code |
[in] BSTR | bstrCity | City. |
[in] BSTR | bstrStateCode | State code like the codes of the US states. Such a state code should only be supplied if it is part of the address because the state code is printed before the zip code. |
[in] BSTR | bstrCountryCode | ISO country code |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IAddress
  • Type

IAddress::Type property
GetType returns the type of address either enAddressPerson or enAddressCompany if a address is defined at all. If no address is set then enAddressUndefined is returned. | space
C/C++ calling syntax
[get] HRESULT | Type( AddressType *aAddressType);
space
Calling argument description
[out, retval] AddressType | *aAddressType
C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • AddressType *GetType(void);
space


  • IGeneralCreditRequest

IGeneralCreditRequest interface |  | V4.30/ 3 Feb 2011
With the IGeneralCreditRequest interface all the credit related data and parameters can be set by the available interface methods like SetPatient, SetTreatment,... Alternatively to produce the data from scratch the data of a previously generated XML infoset can be loaded with the IGeneralCreditRequestManger::LoadXML method and thereafter changed appropriately. |  | space
Methods |  | 27 methods
AddDiagnosis | Adds a diagnosis to the list of diagnoses. |
AddDocument | Adds one document -either inline or online- to the list of documents. |
AddService | Adds one service record to the list of services. |
Finalize | Finalizes and validates all data set so far in the GeneralCreditRequest interface. |
GetAbortInfo | Get the abort information string with the error coded in the module language. |
Initialize | Initializes all input data in the IGeneralCreditRequest interface. |
SetBasicInsurance | Sets the various identifiers (EAN,. |
SetCard | Sets the patient's insurance card information (might be the patient card later on) - this information is optional. |
SetContact | Sets the various identifiers (EAN, ZSR,. |
SetCostBearer | Sets the various identifiers (EAN,. |
SetCredit | Sets the credit object reference. |
SetCreditRef | Sets the optional credit_ref object reference parameters. |
SetEmployer | Sets the various identifiers (EAN, RegNumber,. |
SetFamilyDoctor | Sets the various identifiers (EAN, ZSR,. |
SetLaw | Sets the law and its dependent information |
SetOuterCantonal | Sets the "outer cantonal" input data. |
SetPackage | Defines the identification parameters of the main software that uses this DLL. |
SetPatient | Sets the primary parameters and structured address of the patient. |
SetProvider | Sets the various identifiers (EAN, ZSR,. |
SetReferrer | Sets the various identifiers (EAN, ZSR,. |
SetRequest | Sets the role and place information, the processing parameters "storno" and "copy" besides data language. |
SetRequestor | Sets the various identifiers (EAN, ZSR,. |
SetStationary | Sets additional stationary treatment input data if it is such a stationary treatment. |
SetSubstantiation | Sets the substantiation (motives and reasons) for the treatment. |
SetSurgeon | Sets the various identifiers (EAN, ZSR,. |
SetTransport | Sets transport information that is the routing information going from a sender (from) over the first intermediate (via) to the receiver (to). |
SetTreatment | Sets the primary treatment input data. |
Properties |  | 1 properties
[get] CreateAddress | Create an instance of the IAddress interface. |


  • IGeneralCreditRequest
  • AddDiagnosis

IGeneralCreditRequest::AddDiagnosis method |  |  |
Adds a diagnosis to the list of diagnoses. |  |  | space
C/C++ calling syntax |  |  |
HRESULT AddDiagnosis( | DiagnosisType BSTR BSTR SideType BSTR VARIANT_BOOL | eDiagnosisType, bstrCode, bstrText, eSideType, bstrRemark, *pbStatus); |
Calling argument description |  |  |
[in] DiagnosisType | eDiagnosisType | The type of the diagnosis |
[in] BSTR | bstrCode | The code of the diagnosis as given in the corresponding diagnosis catalog defined by eDiagnosisType . |
[in] BSTR | bstrText | Textual description of the code as given in the corresponding diagnosis catalog defined by eDiagnosisType . |
[in] SideType | eSideType | The side dependency of the diagnosis |
[in] BSTR | bstrRemark | An optional remark for the given diagnosis |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditRequest
  • AddDocument

IGeneralCreditRequest::AddDocument method |  |  |
Adds one document -either inline or online- to the list of documents. |  |  | space
C/C++ calling syntax |  |  |
HRESULT AddDocument( | YesNoType BSTR BSTR BSTR BSTR VARIANT_BOOL | eIsURL, bstrSource, bstrFilename, bstrMimeType, bstrViewer, *pbStatus); |
Calling argument description |  |  |
[in] YesNoType | eIsURL | Boolean that defines if the document is added online using a URL (enYes) or inline as Base64 coded stream (enNo). |
[in] BSTR | bstrSource | If eIsURL = enYes then bstrSource is a URL for accessing the file online. If eIsURL = enNo then bstrSource is a full file name (path + name) that is Base64 coded. Note that the file must exist and having READ access. |
[in] BSTR | bstrFilename | The name of the file (without path) in the local file system. This information is an aid for saving the file at the target location. |
[in] BSTR | bstrMimeType | The MIME type of the document. The MIME type enables applications to read the file. RFC 2046 standardizes and names the commonly used MIME types. |
[in] BSTR | bstrViewer | An optional URL where a viewer for the file can be downloaded. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditRequest
  • AddService

IGeneralCreditRequest::AddService method
Adds one service record to the list of services. If the return status is VARIANT_FALSE then the service record is not added!

Note, that the notation of service here is much simpler than that in an invoice as the service is basically defined by a
tariff number, code and name, and a quantity, scale factor and base amount. The latter three form the amount as quantity * scale factor * base amount. Both the base amount and the amount are in CHF.
If a Tarmed service should be included then sum the medical and technical part to form the base amount.

Note as well, that the base amount includes any VAT portion and therefore the amount includes that portion as well.

space
C/C++ calling syntax
HRESULT AddService( BSTR
BSTR
BSTR
double
double
double
BSTR
VARIANT_BOOL 		bstrTariffType,
bstrCode,
bstrText,
dQuantity,
dBaseAmount,
dScaleFactor,
bstrRemark,
*pbStatus);
Calling argument description
[in] BSTR bstrTariffType The official tariff type as defined by Forum Datenaustausch
bstrTariffType might be empty in special cases where the service is not covered by a official tariff catalog
[in] BSTR bstrCode Service code as given by the used tariff catalog.
bstrCode might be empty in special cases where the service is not covered by an official tariff catalog.
[in] BSTR bstrText The service name is the official service name as given by the used tariff catalog. If it is not a
service in the narrow sense (not covered by an official tariff catalog) then it describes that service with best effort.
[in] double dQuantity The floating point quantity.

Note, that dQuantity is defined as double spanning negative, zero and positive fractional values!

  • negative quantities are used for service records in a storno (cf. attribute SetRequest::eIsStorno)
  • a zero quantity is used for "pro memoria" services
  • positive quantities are used for "normal" services
  • fractional values are used whenever a part of the "full" service is used (e.g. quantity=0.5 for 500ml of a 1000ml infusion solution)

Note that quantity changes the sign if a storno request is produced.
[in] double dBaseAmount The base amount of one service in CHF.

Note, that the base amount includes any VAT portion

[in] double dScaleFactor The applied scale factor for the given service. In principle the scale factor is used for defining discounts or surchages.
However, it can be used as well for defining cost fractions e.g. in a DRG service.
[in] BSTR | bstrRemark | An optional remark for the given service.
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


  • IGeneralCreditRequest
  • Finalize

IGeneralCreditRequest::Finalize method |  |  |
Finalizes and validates all data set so far in the GeneralCreditRequest interface. This method is the counterpart to the Initialize method. This method should be called after all data have been set in the IGeneralCreditRequest interface. |  |  | space
C/C++ calling syntax |  |  |
HRESULT Finalize( | VARIANT_BOOL | *pbStatus); |
Calling argument description |  |  |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditRequest
  • GetAbortInfo

IGeneralCreditRequest::GetAbortInfo method |  |  |
Get the abort information string with the error coded in the module language. Call this method whenever the returned pbStatus variable of the primarily called method is VARIANT_FALSE and the primarily called method is not an iterator (GetFirst/GetNext). In the later case VARIANT_FALSE signals the end of data. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetAbortInfo( | BSTR VARIANT_BOOL | *pbstrAbort, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrAbort | Abort information string coded in the module language. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error-in-error situation occurred. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditRequest
  • Initialize

IGeneralCreditRequest::Initialize method |  |  |
Initializes all input data in the IGeneralCreditRequest interface. This method is the counterpart to the Finalize method. This method should be called before any input is set in the IGeneralCreditRequest interface. |  |  | space
C/C++ calling syntax |  |  |
HRESULT Initialize( | LanguageType VARIANT_BOOL | eDataLanguage, *pbStatus); |
Calling argument description |  |  |
[in] LanguageType | eDataLanguage | Sets the language in which the data part is coded. It is exactly the language in which the response is formulated. Note, that the data language and the module language (given by IGeneralCreditRequestManager::SetModuleLanguage property) are independent and can be different! |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditRequest
  • SetBasicInsurance

IGeneralCreditRequest::SetBasicInsurance method
Sets the various identifiers (EAN,...) and the structured address of the patient's basic insurance.

The address is defined via an IAddress interface pointer and the address data must be defined prior to call this method.

The basic insurance must be supplied for an outer-cantonal stationary treatment since a credit request for the cantonal surgeon must be generated/sent besides one for the target insurance (given by the SetLaw method).

space
C/C++ calling syntax
HRESULT SetBasicInsurance( LawType
BSTR
IAddress
VARIANT_BOOL 		eLawType,
bstrEAN,
*pIAddress,
*pbStatus);
Calling argument description
[in] LawType | eLawType | The type of basic insurance defined by the applicable type of law from the LawType enumeration.
[in] BSTR | bstrEAN | EAN number of the basic insurance as supplied by medwin.ch
[in] IAddress *pIAddress Pointer to an IAddress interface instance that holds the structured address parts.
A NULL pointer is supplied if no address should be set.
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


  • IGeneralCreditRequest
  • SetCard

IGeneralCreditRequest::SetCard method |  |  |
Sets the patient's insurance card information (might be the patient card later on) - this information is optional. |  |  | space
C/C++ calling syntax |  |  |
HRESULT SetCard( | BSTR DATE DATE BSTR BSTR VARIANT_BOOL | bstrCardID, dExpiryDate, dValidationDate, bstrValidationID, bstrValidationServer, *pbStatus); |
Calling argument description |  |  |
[in] BSTR | bstrCardID | The mandatory unique 20 digits card identifier |
[in] DATE | dExpiryDate | The mandatory expiry date of the card |
[in] DATE | dValidationDate | The optional date of the last validation of the card's data |
[in] BSTR | bstrValidationID | The optional replied ID when the last validation of the card's data was performed |
[in] BSTR | bstrValidationServer | The optional server for the last validation process |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditRequest
  • SetContact

IGeneralCreditRequest::SetContact method |  |  |
Sets the various identifiers (EAN, ZSR,...) and the structured address of the primary contact. The address is defined via a IAddress interface pointer and the address data must be defined prior to call this method. |  |  | space
C/C++ calling syntax |  |  |
HRESULT SetContact( | BSTR IAddress VARIANT_BOOL | bstrEAN, *pIAddress, *pbStatus); |
Calling argument description |  |  |
[in] BSTR | bstrEAN | EAN number of the primary contact as supplied by medwin.ch |
[in] IAddress | *pIAddress | Pointer to an IAddress interface instance that holds the structured address parts. The address is either one of a person, a company, or an employee of an company. In the latter case the employee's full name is coded into the subaddress field. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditRequest
  • SetCostBearer

IGeneralCreditRequest::SetCostBearer method |  |  |
Sets the various identifiers (EAN,...) and the structured address of the cost bearer. The cost bearer might either be an insurance or a cantonal surgeon. The latter must be addressed in an outer-cantonal stationary treatment only. The address is defined via a IAddress interface pointer and the address data must be defined prior to call this method. |  |  | space
C/C++ calling syntax |  |  |
HRESULT SetCostBearer( | BSTR IAddress VARIANT_BOOL | bstrEAN, *pIAddress, *pbStatus); |
Calling argument description |  |  |
[in] BSTR | bstrEAN | EAN number of the cost bearer as supplied by medwin.ch |
[in] IAddress | *pIAddress | Pointer to an IAddress interface instance that holds the structured address parts. A NULL pointer is supplied if no address should be set. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditRequest
  • SetCredit

IGeneralCreditRequest::SetCredit method |  |  |
Sets the credit object reference. The credit_ref (if supplied in the request) and credit object references form a object reference chain (credit_ref -> credit) with the credit as topmost object reference. The page "object reference" provides an in-depth description of the concepts of "object reference", "object reference chain", and "topmost object reference". |  |  | space
C/C++ calling syntax |  |  |
HRESULT SetCredit( | CreditType BSTR DATE long YesNoType VARIANT_BOOL | eCreditType, bstrRequestCreditID, dRequestCreditDate, lRequestCreditTimestamp, eIsCostEstimate, *pbStatus); |
Calling argument description |  |  |
[in] CreditType | eCreditType | The type of credit that is generated. If the credit type is not "new" than a credit_ref object must be defined for the "older" reference object. |
[in] BSTR | bstrRequestCreditID | The request ID is the main software's identification of the credit ("Kostengutsprachenummer"). This is one of 3 identifiers that form the credit object reference. |
[in] DATE | dRequestCreditDate | The request date is the main software's date of the credit request ("Kostengutsprachedatum"). This is one of 3 identifiers that form the credit object reference. |
[in] long | lRequestCreditTimestamp | This is a UNIX timestamp defined at the moment of the credit's infoset generation. This is one of 3 identifiers that form the credit object reference. |
[in] YesNoType | eIsCostEstimate | Boolean value that defines the credit as "cost estimate" instead of "credit". From a semantical point of view cost estimates ("Kostenvoranschlag") and credits ("Kostengutsprache") are the same. It is more of a legal question as 'cost estimate' has a narrower cost interval than a credit. If you don't know what to set then check with the cost bearer. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditRequest
  • SetCreditRef

IGeneralCreditRequest::SetCreditRef method |  |  |
Sets the optional credit_ref object reference parameters. This object reference is only defined if the credit type (GetCredit@creditType) is 'prologation' or 're-considersation'. In the first case credit_ref defines the last accepted credit reference object whereas the the latter case it is the rejected credit reference object. The credit_ref, and credit object references form a object reference chain (credit_ref -> credit) with the credit as topmost object reference. The page "object reference" provides an in-depth description of the concepts of "object reference", "object reference chain", and "topmost object reference". |  |  | space
C/C++ calling syntax |  |  |
HRESULT SetCreditRef( | BSTR DATE long VARIANT_BOOL | bstrRequestCreditID, dRequestCreditDate, lRequestCreditTimestamp, *pbStatus); |
Calling argument description |  |  |
[in] BSTR | bstrRequestCreditID | The request ID is the main software's identification of the credit ("Kostengutsprachenummer"). This is one of 3 identifiers that form the credit object reference. |
[in] DATE | dRequestCreditDate | The request date is the main software's date of the credit request ("Kostengutsprachedatum"). This is one of 3 identifiers that form the credit object reference. |
[in] long | lRequestCreditTimestamp | This is a UNIX timestamp defined at the moment of the credit's infoset generation. This is one of 3 identifiers that form the credit object reference. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditRequest
  • SetEmployer

IGeneralCreditRequest::SetEmployer method |  |  |
Sets the various identifiers (EAN, RegNumber,...) and the structured address of the employer of the patient. The address is defined via a IAddress interface pointer and the address data must be defined prior to call this method. |  |  | space
C/C++ calling syntax |  |  |
HRESULT SetEmployer( | BSTR BSTR IAddress VARIANT_BOOL | bstrEAN, bstrRegNumber, *pIAddress, *pbStatus); |
Calling argument description |  |  |
[in] BSTR | bstrEAN | EAN number of the employer as supplied by medwin.ch |
[in] BSTR | bstrRegNumber | The employer's national BER number as defined by Swiss Federal Statistical Office |
[in] IAddress | *pIAddress | Pointer to an IAddress interface instance that holds the structured address parts. A NULL pointer is supplied if no address should be set. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditRequest
  • SetFamilyDoctor

IGeneralCreditRequest::SetFamilyDoctor method |  |  |
Sets the various identifiers (EAN, ZSR,...) and the structured address of the patient's family doctor - this is an optional part. The address is defined via a IAddress interface pointer and the address data must be defined prior to call this method. |  |  | space
C/C++ calling syntax |  |  |
HRESULT SetFamilyDoctor( | BSTR BSTR BSTR BSTR IAddress VARIANT_BOOL | bstrEAN, bstrZSR, bstrNIF, bstrSpecialty, *pIAddress, *pbStatus); |
Calling argument description |  |  |
[in] BSTR | bstrEAN | EAN number of the family doctor as supplied by medwin.ch |
[in] BSTR | bstrZSR | ZSR number of the family doctor as supplied by santésuisse |
[in] BSTR | bstrNIF | The IV specific identification number NIF of the family doctor. |
[in] BSTR | bstrSpecialty | Specialty, i.e. FMH title of the physician. |
[in] IAddress | *pIAddress | Pointer to an IAddress interface instance that holds the structured address parts. A NULL pointer is supplied if no address should be set. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditRequest
  • SetLaw

IGeneralCreditRequest::SetLaw method |  |  |
Sets the law and its dependent information |  |  | space
C/C++ calling syntax |  |  |
HRESULT SetLaw( | LawType DATE BSTR BSTR BSTR VARIANT_BOOL | eLawType, dCaseDate, bstrCaseID, bstrInsuredID, bstrContractNumber, *pbStatus); |
Calling argument description |  |  |
[in] LawType | eLawType | The type of law to set from the LawType enumeration |
[in] DATE | dCaseDate | The case date of the insurance (e.g. date of accident in UVG) This date might be undefined for certain laws and therefore left empty |
[in] BSTR | bstrCaseID | The case ID of the insurance (e.g. accident number in UVG) This ID might be undefined for certain laws and therefore left empty |
[in] BSTR | bstrInsuredID | The patient's ID at the insurance This ID might undefined for certain laws and therefore left empty |
[in] BSTR | bstrContractNumber | Contract number if such a special contract exists between provider and insurance |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditRequest
  • SetOuterCantonal

IGeneralCreditRequest::SetOuterCantonal method |  |  |
Sets the "outer cantonal" input data. The "outer cantonal" data is defined for a stationary treatment where the patient's tax canton differs from the treatment canton. |  |  | space
C/C++ calling syntax |  |  |
HRESULT SetOuterCantonal( | CantonType BSTR BSTR DATE DATE VARIANT_BOOL | eTaxCanton, bstrTaxCity, bstrEmergencyCity, dEmergencyDate, dRetransferDate, *pbStatus); |
Calling argument description |  |  |
[in] CantonType | eTaxCanton | The tax canton given by the CantonType enumeration |
[in] BSTR | bstrTaxCity | The city where the patient is living and paying taxes. |
[in] BSTR | bstrEmergencyCity | If an emergency (SetStationary@eHospitalizationType = enEmergency) is the type/reason for the hospitalization then set the city where emergency happened. If this place is unknown or it is not an emergency set an empty variable. |
[in] DATE | dEmergencyDate | If an emergency (SetStationary@eHospitalizationType = enEmergency) is the type/reason for the hospitalization then set the date and time of the emergency. If this date is unknown or it is not an emergency set 0 as date. |
[in] DATE | dRetransferDate | If an emergency (SetStationary@eHospitalizationType = enEmergency) is the type/reason for the hospitalization then set the date of the earliest transfer to a hospital of the tax canton. If this date is unknown or it is not an emergency set 0 as date. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditRequest
  • SetPackage

IGeneralCreditRequest::SetPackage method |  |  |
Defines the identification parameters of the main software that uses this DLL. |  |  | space
C/C++ calling syntax |  |  |
HRESULT SetPackage( | BSTR long long BSTR VARIANT_BOOL | bstrSoftwarePackage, lSoftwareVersion, lSoftwareID, bstrSoftwareCopyright, *pbStatus); |
Calling argument description |  |  |
[in] BSTR | bstrSoftwarePackage | Name of the main software that uses this DLL |
[in] long | lSoftwareVersion | Version of the main software codes as 32-bit value where lSoftwareVersion = 100*Major version + Minor version. |
[in] long | lSoftwareID | Optional ID of the main software that uses this DLL |
[in] BSTR | bstrSoftwareCopyright | The copyright notice of the developer of the main software. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditRequest
  • SetPatient

IGeneralCreditRequest::SetPatient method
Sets the primary parameters and structured address of the patient.

The address is defined via a IAddress interface pointer and the address data must be defined prior to call this method.

space
C/C++ calling syntax
HRESULT SetPatient( SexType
DATE
BSTR
IAddress
VARIANT_BOOL 		eSexType,
dBirthdate,
bstrSSN,
*pIAddress,
*pbStatus);
Calling argument description
[in] SexType | eSexType | The patient's gender.
[in] DATE | dBirthdate | The patient's birthdate.
[in] BSTR bstrSSN Defines the social security number (SSN) of the patient whereupon 3 distinguished forms are allowed:
  • the old 11 digit Swiss SSN ("AHV-Nummer") as defined by Federal Social Insurance Office
  • the new 13 digit Swiss SSN ("SV-Nummer") beginning with 756 as defined by Federal Social Insurance Office
  • the new 4-10 digit SSN of Liechtenstein ("AHV-Nummer") as defined by Liechtensteinische AHV-IV-FAK
The SSN can be supplied in its printed (with dots) or electronic (only digits) form.
[in] IAddress | *pIAddress | Pointer to an IAddress interface instance that holds the structured address parts.
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


  • IGeneralCreditRequest
  • SetProvider

IGeneralCreditRequest::SetProvider method |  |  |
Sets the various identifiers (EAN, ZSR,...) and the structured address of the main provider. The address is defined via a IAddress interface pointer and the address data must be defined prior to call this method. |  |  | space
C/C++ calling syntax |  |  |
HRESULT SetProvider( | BSTR BSTR BSTR BSTR IAddress VARIANT_BOOL | bstrEAN, bstrZSR, bstrNIF, bstrSpecialty, *pIAddress, *pbStatus); |
Calling argument description |  |  |
[in] BSTR | bstrEAN | EAN number of the provider as supplied by medwin.ch |
[in] BSTR | bstrZSR | ZSR number of the provider as supplied by santésuisse |
[in] BSTR | bstrNIF | The IV specific identification number NIF of the provider. |
[in] BSTR | bstrSpecialty | An optional specialty, i.e. FMH title of a physician. |
[in] IAddress | *pIAddress | Pointer to an IAddress interface instance that holds the structured address parts. A NULL pointer is supplied if no address should be set. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditRequest
  • SetReferrer

IGeneralCreditRequest::SetReferrer method |  |  |
Sets the various identifiers (EAN, ZSR,...) and the structured address of the referrer - this is an optional part. The address is defined via a IAddress interface pointer and the address data must be defined prior to call this method. |  |  | space
C/C++ calling syntax |  |  |
HRESULT SetReferrer( | BSTR BSTR BSTR BSTR IAddress VARIANT_BOOL | bstrEAN, bstrZSR, bstrNIF, bstrSpecialty, *pIAddress, *pbStatus); |
Calling argument description |  |  |
[in] BSTR | bstrEAN | EAN number of the referrer as supplied by medwin.ch |
[in] BSTR | bstrZSR | ZSR number of the referrer as supplied by santésuisse |
[in] BSTR | bstrNIF | The IV specific identification number NIF of the referrer. |
[in] BSTR | bstrSpecialty | Specialty, i.e. FMH title of the physician. |
[in] IAddress | *pIAddress | Pointer to an IAddress interface instance that holds the structured address parts. A NULL pointer is supplied if no address should be set. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditRequest
  • SetRequest

IGeneralCreditRequest::SetRequest method |  |  |
Sets the role and place information, the processing parameters "storno" and "copy" besides data language. Note, that whenever the "storno" and/or "copy" parameters are set then the timestamp of the topmost object reference (SetCredit) must be defined that is > 0 otherwise an error will result in the Finalize method. |  |  | space
C/C++ calling syntax |  |  |
HRESULT SetRequest( | RoleType PlaceType BSTR YesNoType YesNoType VARIANT_BOOL | eRoleType, ePlaceType, bstrRoleTitle, eIsStorno, eIsCopy, *pbStatus); |
Calling argument description |  |  |
[in] RoleType | eRoleType | Defines the role categories that the main provider is best categorized. If the main provider has an other role than defined then use enRoleOther and additionally supply a role title with a description of the role |
[in] PlaceType | ePlaceType | Defines the principle place where the main provider is applying the treatment |
[in] BSTR | bstrRoleTitle | Optional role title/description of the main provider. If a suitable predefined role can not be set then bstrRoleTitle is mandatory (use enRoleOther as role in that case) |
[in] YesNoType | eIsStorno | Boolean value that defines the "storno" status of the credit. eIsStorno should be false when the initial invoice or reminder is produced. At this step the timestamp is generated and returned in the GeneralCreditRequestManager::Print and/or GeneralCreditRequestManager::GetXML method. Whenever eIsStorno is true then the invoice or reminder timestamp must be set otherwise an error will result. |
[in] YesNoType | eIsCopy | Boolean value that defines the "copy" status of the credit. eIsCopy should be false when the initial invoice or reminder is produced. At this step the timestamp is generated and returned in the IGeneralCreditRequestManager::Print and/or IGeneralCreditRequestRequestManager::GetXML method. Whenever eIsCopy is true then the invoice or reminder timestamp must be set otherwise an error will result. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditRequest
  • SetRequestor

IGeneralCreditRequest::SetRequestor method |  |  |
Sets the various identifiers (EAN, ZSR,...) and the structured address of the requestor of the credit. The address is defined via a IAddress interface pointer and the address data must be defined prior to call this method. |  |  | space
C/C++ calling syntax |  |  |
HRESULT SetRequestor( | BSTR BSTR BSTR BSTR IAddress VARIANT_BOOL | bstrEAN, bstrZSR, bstrNIF, bstrSpecialty, *pIAddress, *pbStatus); |
Calling argument description |  |  |
[in] BSTR | bstrEAN | EAN number of the requestor as supplied by medwin.ch |
[in] BSTR | bstrZSR | ZSR number of the requestor as supplied by santésuisse |
[in] BSTR | bstrNIF | The IV specific identification number NIF of the requestor. |
[in] BSTR | bstrSpecialty | An optional specialty, i.e. FMH title of a physician. |
[in] IAddress | *pIAddress | Pointer to an IAddress interface instance that holds the structured address parts. A NULL pointer is supplied if no address should be set. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditRequest
  • SetStationary

IGeneralCreditRequest::SetStationary method |  |  |
Sets additional stationary treatment input data if it is such a stationary treatment. To set these data does implicitly mean that the "hospital" form is used in printing the detail credit. |  |  | space
C/C++ calling syntax |  |  |
HRESULT SetStationary( | HospitalizationType HospitalizationMode InsuranceClass InsuranceModel BSTR VARIANT_BOOL | eHospitalizationType, eHospitalizationMode, eInsuranceClass, eInsuranceModel, bstrSectionMajor, *pbStatus); |
Calling argument description |  |  |
[in] HospitalizationType | eHospitalizationType | The type/reason of hospitalization given by the HospitalizationType enumeration |
[in] HospitalizationMode | eHospitalizationMode | The mode/indication of hospitalization given by the HospitalizationMode enumeration |
[in] InsuranceClass | eInsuranceClass | The insurance class given by the InsuranceClass enumeration |
[in] InsuranceModel | eInsuranceModel | The insurance model given by the InsuranceModel enumeration. The insurance model is a possible refinement of the supplied insurance class. |
[in] BSTR | bstrSectionMajor | The major BfS section code as defined by Swiss Federal Statistical Office |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditRequest
  • SetSubstantiation

IGeneralCreditRequest::SetSubstantiation method |  |  |
Sets the substantiation (motives and reasons) for the treatment. |  |  | space
C/C++ calling syntax |  |  |
HRESULT SetSubstantiation( | BSTR BSTR VARIANT_BOOL | bstrMeasures, bstrRemark, *pbStatus); |
Calling argument description |  |  |
[in] BSTR | bstrMeasures | The intended measures for the treatment |
[in] BSTR | bstrRemark | An optional remark regarding the treatment |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditRequest
  • SetSurgeon

IGeneralCreditRequest::SetSurgeon method |  |  |
Sets the various identifiers (EAN, ZSR,...) and the structured address of the surgeon. Of course, the surgeon's address is set only if it is a stationary treatment with surgery and if known. The address is defined via a IAddress interface pointer and the address data must be defined prior to call this method. |  |  | space
C/C++ calling syntax |  |  |
HRESULT SetSurgeon( | BSTR BSTR BSTR BSTR IAddress VARIANT_BOOL | bstrEAN, bstrZSR, bstrNIF, bstrSpecialty, *pIAddress, *pbStatus); |
Calling argument description |  |  |
[in] BSTR | bstrEAN | EAN number of the surgeon as supplied by medwin.ch |
[in] BSTR | bstrZSR | ZSR number of the surgeon as supplied by santésuisse |
[in] BSTR | bstrNIF | The IV specific identification number NIF of the surgeonr. |
[in] BSTR | bstrSpecialty | Specialty, i.e. FMH title of the physician. |
[in] IAddress | *pIAddress | Pointer to an IAddress interface instance that holds the structured address parts. A NULL pointer is supplied if no address should be set. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditRequest
  • SetTransport

IGeneralCreditRequest::SetTransport method |  |  |
Sets transport information that is the routing information going from a sender (from) over the first intermediate (via) to the receiver (to). All the involved parties are defined by EAN numbers as defined by www.medwin.ch. This method allows to sign and/or encrypt the resulting XML infoset. Therefore, read the notes about signature and encryption to get familiar with these concepts. |  |  | space
C/C++ calling syntax |  |  |
HRESULT SetTransport( | BSTR BSTR BSTR BSTR BSTR BSTR VARIANT_BOOL | bstrFromEAN, bstrFromPFXFile, bstrFromPFXPassword, bstrViaEAN, bstrToEAN, bstrToBinDERFile, *pbStatus); |
Calling argument description |  |  |
[in] BSTR | bstrFromEAN | The EAN number of the sender as supplied by medwin.ch |
[in] BSTR | bstrFromPFXFile | The file name of the PFX certificate that is the private certificate of the "from" entity. If the variable is empty or NULL then no signature is applied otherwise a signature might be applied depending on the lXMLGenerationAttributes of the GetXML method. |
[in] BSTR | bstrFromPFXPassword | The password to open the PFX certificate. The password is only used if a PFX certificate is supplied. |
[in] BSTR | bstrViaEAN | The EAN number of the first intermediate as supplied by medwin.ch |
[in] BSTR | bstrToEAN | The EAN number of the recipient as supplied by medwin.ch |
[in] BSTR | bstrToBinDERFile | The file name of the binary DER certificate that is the public certificate of the "to" entity. If the variable is empty or NULL then no encryption is applied otherwise encryption might be applied depending on the lXMLGenerationAttributes of the GetXML |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditRequest
  • SetTreatment

IGeneralCreditRequest::SetTreatment method
Sets the primary treatment input data. | space
C/C++ calling syntax
HRESULT SetTreatment( DATE
BSTR
CantonType
TreatmentReasonType
BSTR
BSTR
VARIANT_BOOL 		dDateBegin,
bstrTreatmentUnits,
eTreatmentCanton,
eTreatmentReason,
bstrPatientID,
bstrCaseID,
*pbStatus);
Calling argument description
[in] DATE | dDateBegin | dDateBegin is the (intended) start of the treatment
[in] BSTR bstrTreatmentUnits The optional number/length and units of the suggested treatment.

The treatment units are in fact context sensitive in their semantical meaning and therefore they are encoded by a string
due to the variety of possibilities.

Treatment units for stationary treatment are e.g. "4 days" whereas for a physio therapy it could be "6 physio sessions" or
"10 physio sessions - 1 per week".

[in] CantonType | eTreatmentCanton | The treatment canton given by the CantonType enumeration
[in] TreatmentReasonType | eTreatmentReason | The treatment reason given by the TreatmentReasonType enumeration
[in] BSTR | bstrPatientID | This is an optional patient identification of the main software ("Patientennummer").
[in] BSTR | bstrCaseID | This is an optional case identification of the main software ("Fallnummer"). In fact it is an ID used in the main software to identify this request and probably it is the same as the request credit ID (SetCredit@bstrRequestCreditID).
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


  • IGeneralCreditRequest
  • CreateAddress

IGeneralCreditRequest::CreateAddress property
Create an instance of the IAddress interface.

Any address is specified using properties and methods of this interface.

space
C/C++ calling syntax
[get] HRESULT | CreateAddress( IAddress **aIAddress);
space
Calling argument description
[out, retval] IAddress | **aIAddress
C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • IAddress **GetCreateAddress(void);
space


  • IGeneralCreditRequestManager

IGeneralCreditRequestManager interface | V4.30/ 3 Feb 2011
The IGeneralCreditRequestManager interface provides all the necessary tools to produce a credit request for all roles and places.

Firstly, an instance of the IGeneralCreditRequest interface is created by the GetGeneralCreditRequest property. All the credit related data and parameters can be set by the supplied interface methods like SetPatient, SetTreatment,...

After all information is defined the credit is printed or a XML infoset is produced which can be electronically transported to the recipient. In the latter case the credit optionally can be signed and/or encrypted .

Due to he processing attributes "storno" and "copy" a previously generated credit can be canceled or a copy can be produced (cf. Notes about processing attributes).

space
Methods | 8 methods
GetAbortInfo | Get the abort information string with the error coded in the module language.
GetLogSettings | Get the log settings for the module.
GetXML | The GetXML method generates the XML infoset based on the data of the IGeneralCreditRequest interface and the XML generation attributes, validates the XML against the XSD schema, and stores the XML content as UTF8 file in the internal working directory.
LoadXML | Loads a previously generated XML infoset of type 'generalCreditRequest_430.
Print | Validates the credit request data and prints the credit request on the local printer.
PrintAdjust | Shows the print object adjustment dialog that allows to move print objects of a .
PrintSetup | Shows the printer setup dialog that allows to define printer settings connected with a .
SetLogSettings | Set the log settings for the module.
Properties | 6 properties
[get] GeneralCreditRequest | The property GetGeneralCreditRequest supplies a pointer to the IGeneralCreditRequest interface.
[get/put] ModuleLanguage | Get/Set the language for the module i.
[get] ModuleVersion | Get the version of the GeneralCreditRequestManager module
[get] ModuleVersionText | Get the textual version of the GeneralCreditRequestManager module
[get/put] Modus | Get the operation modus.
[get/put] PrintCopies | Get/Set the number of copies to print.


  • IGeneralCreditRequestManager
  • GetAbortInfo

IGeneralCreditRequestManager::GetAbortInfo method |  |  |
Get the abort information string with the error coded in the module language. Call this method whenever the returned pbStatus variable of the primarily called method is VARIANT_FALSE and the primarily called method is not an iterator (GetFirst/GetNext). In the later case VARIANT_FALSE signals the end of data. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetAbortInfo( | BSTR VARIANT_BOOL | *pbstrAbort, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrAbort | Abort information string coded in the module language. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error-in-error situation occurred. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditRequestManager
  • GetLogSettings

IGeneralCreditRequestManager::GetLogSettings method
Get the log settings for the module. | space
C/C++ calling syntax
HRESULT GetLogSettings( long
long
YesNoType
BSTR
VARIANT_BOOL 		*plLogLevel,
*plMaxSizeKB,
*peDoArchive,
*pbstrArchiveDir,
*pbStatus);
Calling argument description
[out] long | *plLogLevel | eDoArchive defines if the log file is recycled if the maximum size is reached (enNo) or if the log file is archived (enYes).
[out] long *plMaxSizeKB The log activity level where
lLogLevel = 0 | Logging is turned off
lLogLevel = 1 | Normal log activity
lLogLevel > 1 | Debug log activity. Use this level only for debugging purposes
[out] YesNoType | *peDoArchive | The base directory where log files are archived. bstrArchiveDir is only defined if eDoArchive=enYes otherwise bstrArchiveDir is empty.
[out] BSTR | *pbstrArchiveDir | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


  • IGeneralCreditRequestManager
  • GetXML

IGeneralCreditRequestManager::GetXML method
The GetXML method generates the XML infoset based on the data of the IGeneralCreditRequest interface and the XML generation attributes, validates the XML against the XSD schema, and stores the XML content as UTF8 file in the internal working directory. The full file name to this XML document is replied in the pbstrOutputFile output variable.

The XML file must be saved to a different location as all temporary XML files in the working directory are deleted before the COM module shuts down!

Note about encryption: an encrypted XML infoset cannot be loaded successfully by LoadXML. Therefore, to build a local archive besides encrypted XML infoset call GetXML twice once with the lXMLGenerationAttributes = enGenerateWithoutEncryption

space
C/C++ calling syntax
HRESULT GetXML( long
BSTR
long
long
BSTR
IGeneralCreditResult
VARIANT_BOOL 		lXMLGenerationAttributes,
*pbstrOutputFile,
*plValidationError,
*plTimestamp,
*pbstrUsedSchema,
**ppIGeneralCreditResult,
*pbStatus);
Calling argument description
[in] long lXMLGenerationAttributes This variable defines which principal parts of the XML generation should not be carried out even if the data for that part are defined. lXMLGenerationAttributes is a 32-bit integer where the possible excludes are values from the XMLGenerationAttributes data type and are ORed together to form the overall command.

This feature is necessary to generate different "flavors" of XML infosets without re-setting input data. For instance, an encrypted XML infoset for the "toEan" entity can be produced and in a second call the XML infoset without encryption and documents (lXMLGenerationAttributes = enGenerateWithoutEncryption | enGenerateWithoutDocuments) is requested for a local archive (that can be loaded back later!).

[out] BSTR *pbstrOutputFile The full file name (path + name) where the XML infoset is stored in UTF-8 mode.

The XML file must be saved to a different location as all temporary XML files in the working directory are deleted before the COM module shuts down!

[out] long | *plValidationError | lValidationError is filled with the validation error code returned by the MSXML-4 parser. A zero value indicates that the validation was successful.
[out] long *plTimestamp The timestamp of the XML document as epoch time (seconds elapsed since 1.1.1970) that is used as timestamp of the topmost object reference from that point on.

If the timestamp for the topmost object reference was already set (e.g. to produce a copy) then this same timestamp is returned.

[out] BSTR *pbstrUsedSchema The full XSD name that was used to print the data.

Currently, this is generaCreditRequest_430.xsd.

[out] IGeneralCreditResult **ppIGeneralCreditResult The IGeneralCreditResult interface handle that allows to get all loaded data back.
The handle is NULL if an error occurred.
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


  • IGeneralCreditRequestManager
  • LoadXML

IGeneralCreditRequestManager::LoadXML method
Loads a previously generated XML infoset of type 'generalCreditRequest_430.xsd' back into memory for further processing via the returned interface handles.

This method serves as dashboard e.g. to produce a "storno" or "copy" XML infoset.

  • Load the initial XML infoset with LoadXML
  • set the appropriate storno and/or copy values with the IGeneralCreditRequest::SetRequest method
  • produce the XML infoset again with the GetXML method or print the credit with the Print method.
space
C/C++ calling syntax
HRESULT LoadXML( BSTR
BSTR
IGeneralCreditRequest
IGeneralCreditResult
VARIANT_BOOL 		bstrInputFile,
*pbstrUsedSchema,
**ppIGeneralCreditRequest,
**ppIGeneralCreditResult,
*pbStatus);
Calling argument description
[in] BSTR | bstrInputFile | The full file name (path + name) of a XML infoset of type generalCreditRequest_430.xsd.
[out] BSTR | *pbstrUsedSchema | The full XSD name of the loaded XML file.
[out] IGeneralCreditRequest **ppIGeneralCreditRequest The IGeneralCreditRequest interface handle that allows to add further data.
The handle is NULL if an error occurred.
[out] IGeneralCreditResult **ppIGeneralCreditResult The IGeneralCreditResult interface handle that allows to get all loaded data back.
The handle is NULL if an error occurred.
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


  • IGeneralCreditRequestManager
  • Print

IGeneralCreditRequestManager::Print method
Validates the credit request data and prints the credit request on the local printer.
  • For a description about webstamps see the document "How to print webstamps onto an credit form"
  • For a description about generating PDF archive files see the document "How to generate PDF archive files of a credit form"
IMPORTANT LICENSE NOTE The report engine used is Hexatech's ViewPro (www.hexatech.com). If you supply your own template files then you must have your own ViewPro license. By using the module you implicitly agree upon this restriction!! 		space
C/C++ calling syntax
HRESULT Print( BSTR
YesNoType
YesNoType
BSTR
IAddress
long
BSTR
IGeneralCreditResult
VARIANT_BOOL 		bstrPrintTemplate,
ePrintPreview,
eAddressRight,
bstrSenderID,
*pIReceiverAddress,
*plTimestamp,
*pbstrUsedSchema,
**ppIGeneralCreditResult,
*pbStatus);
Calling argument description
[in] BSTR bstrPrintTemplate The bstrPrintTemplate is either empty or built as defined in "Syntax of the printTemplate variable".

If bstrPrintTemplate is empty then the default print template of the supplied data language (IGeneralCreditRequest::Initialize method) is used.

[in] YesNoType | ePrintPreview | A Boolean that defines if print preview is used (enYes) or printing is done (enNo)
[in] YesNoType eAddressRight A Boolean that defines on which side -left or right- the receiver address should be printed.

Note that currently only right-sided addressing is allowed. Therefore eAddressRight is internally always set to enYes.

[in] BSTR bstrSenderID Short sender address identification or empty.

If set then the sender identification is printed atop of the receiver address as an alternative to the sender address on the envelope.

[in] IAddress *pIReceiverAddress An optional receiver address given via an IAddress interface.

This is used whenever the supplied cost bearer should be overridden as receiver by the supplied address. Note that the "inner" data is not affected or changed by this override.

[out] long *plTimestamp The timestamp of the XML document as epoch time (seconds elapsed since 1.1.1970) that is used as timestamp of the topmost object reference from that point on.

If the timestamp for the topmost object reference was already set (e.g. to produce a copy) then this same timestamp is returned.

[out] BSTR *pbstrUsedSchema The full XSD name that was used to print the data.

Currently, this is generalCreditRequest_430.xsd.

[out] IGeneralCreditResult **ppIGeneralCreditResult The IGeneralCreditResult interface handle that allows to get all loaded data back.
The handle is NULL if an error occurred.
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


  • IGeneralCreditRequestManager
  • PrintAdjust

IGeneralCreditRequestManager::PrintAdjust method
Shows the print object adjustment dialog that allows to move print objects of a .vps report generator file. | space
C/C++ calling syntax
HRESULT PrintAdjust( BSTR
BSTR
VARIANT_BOOL 		bstrPrintTemplate,
bstrINIPath,
*pbStatus);
Calling argument description
[in] BSTR bstrPrintTemplate Either the full file name (path + name) or a logical name of a target .vps report generator file for which the settings will be defined.

There are predefined .vps files in the installation directory that can be accessed via the following case insensitive logical name:

Detail_typeaddress_side_language

where
  • type is the type of form to use with G ist for the general (ambulatory) case and S is for the stationary case.
  • address_side is R for right sided addressing or L for left sided addressing of the recipient.
    This is currently fixed to R for all forms
  • language is one of {dt, fr, it}.
For example the logical name "Detail_SR_fr" is the French print template with right sided addressing for a stationary case.
[in] BSTR bstrINIPath Optional path to a directory where the .vpd printer setting file is stored. The name of the printer setting file is the same name as the .vps file but with a .vpd extension.

If bstrINIPath is left empty then the standard directory (the directory of the dll) is used.

[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


  • IGeneralCreditRequestManager
  • PrintSetup

IGeneralCreditRequestManager::PrintSetup method
Shows the printer setup dialog that allows to define printer settings connected with a .vps report generator file. | space
C/C++ calling syntax
HRESULT PrintSetup( BSTR
BSTR
VARIANT_BOOL 		bstrPrintTemplate,
bstrINIPath,
*pbStatus);
Calling argument description
[in] BSTR bstrPrintTemplate Either the full file name (path + name) or a logical name of a target .vps report generator file for which the settings will be defined.

There are predefined .vps files in the installation directory that can be accessed via the following case insensitive logical name:

Detail_typeaddress_side_language

where
  • type is the type of form to use with G ist for the general (ambulatory) case and S is for the stationary case.
  • address_side is R for right sided addressing or L for left sided addressing of the recipient.
    This is currently fixed to R for all forms
  • language is one of {dt, fr, it}.
For example the logical name "Detail_SR_fr" is the French print template with right sided addressing for a stationary case.
[in] BSTR bstrINIPath Optional path to a directory where the .vpd printer setting file is stored. The name of the printer setting file is the same name as the .vps file but with a .vpd extension.

If bstrINIPath is left empty then the standard directory (the directory of the dll) is used.

[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


  • IGeneralCreditRequestManager
  • SetLogSettings

IGeneralCreditRequestManager::SetLogSettings method
Set the log settings for the module.

The defaults for the log activity are: level=1, lMaxSizeKB=1000,eDoArchive=enNo,
and the log settings are persistent via the log file itself.

Note, that the log facility is a best effort system. If there is an error e.g. due to insufficient privileges to write the log entries then nothing is logged.

space
C/C++ calling syntax
HRESULT SetLogSettings( long
long
YesNoType
BSTR
VARIANT_BOOL 		lLogLevel,
lMaxSizeKB,
eDoArchive,
bstrArchiveDir,
*pbStatus);
Calling argument description
[in] long lLogLevel The log activity level where
lLogLevel = 0 | Logging is turned off
lLogLevel = 1 | Normal log activity
lLogLevel > 1 | Debug log activity. Use this level only for debugging purposes

Any log level below 0 is corrected to 0.

[in] long lMaxSizeKB The maximum size in KB of the log file.
Any size below 1000 KB (= the default value) is corrected to the default value
[in] YesNoType | eDoArchive | eDoArchive defines if the log file is recycled once the maximum size is reached (enNo) or if the log file is archived (enYes) into the archive directory.
[in] BSTR bstrArchiveDir Defines the base directory where log files are archived. bstrArchiveDir is only used if eDoArchive=enYes. If bstrArchiveDir is empty and eDoArchive=enYes then the place of the module is used as the base archive directory.

If the base archive directory or directories below have insufficient privileges to create directories or write files archiving is not done!

[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


  • IGeneralCreditRequestManager
  • GeneralCreditRequest

IGeneralCreditRequestManager::GeneralCreditRequest property
The property GetGeneralCreditRequest supplies a pointer to the IGeneralCreditRequest interface.

This interface pointer is needed to set all the data.

space
C/C++ calling syntax
[get] HRESULT | GeneralCreditRequest( IGeneralCreditRequest **aIGeneralCreditRequest);
space
Calling argument description
[out, retval] IGeneralCreditRequest | **aIGeneralCreditRequest
C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • IGeneralCreditRequest **GetGeneralCreditRequest(void);
space


  • IGeneralCreditRequestManager
  • ModuleLanguage

IGeneralCreditRequestManager::ModuleLanguage property
Get/Set the language for the module i.e. the language in which the error strings are coded.

Note, that the module language and the data language (given by IGeneralCreditRequest::Initialize) are independent and can be different!

space
C/C++ calling syntax
[get] HRESULT | ModuleLanguage( LanguageType *aLanguageType);
[put] HRESULT | ModuleLanguage( LanguageType aLanguageType);
space
Calling argument description
[out,retval] LanguageType | *aLanguageType
[in] LanguageType | aLanguageType
C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • LanguageType *GetModuleLanguage(void);
  • void PutModuleLanguage( LanguageType aLanguageType);
space


  • IGeneralCreditRequestManager
  • ModuleVersion

IGeneralCreditRequestManager::ModuleVersion property
Get the version of the GeneralCreditRequestManager module | space
C/C++ calling syntax
[get] HRESULT | ModuleVersion( BSTR *aBSTR);
space
Calling argument description
[out, retval] BSTR | *aBSTR
C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetModuleVersion(void);
space


  • IGeneralCreditRequestManager
  • ModuleVersionText

IGeneralCreditRequestManager::ModuleVersionText property
Get the textual version of the GeneralCreditRequestManager module | space
C/C++ calling syntax
[get] HRESULT | ModuleVersionText( BSTR *aBSTR);
space
Calling argument description
[out, retval] BSTR | *aBSTR
C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetModuleVersionText(void);
space


  • IGeneralCreditRequestManager
  • Modus

IGeneralCreditRequestManager::Modus property
Get the operation modus.

The default modus is enProduction whereas for developing/debugging purposes enTest can be set.

space
C/C++ calling syntax
[get] HRESULT | Modus( ModusType *aModusType);
[put] HRESULT | Modus( ModusType aModusType);
space
Calling argument description
[out,retval] ModusType | *aModusType
[in] ModusType | aModusType
C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • ModusType *GetModus(void);
  • void PutModus( ModusType aModusType);
space


  • IGeneralCreditRequestManager
  • PrintCopies

IGeneralCreditRequestManager::PrintCopies property
Get/Set the number of copies to print. | space
C/C++ calling syntax
[get] HRESULT | PrintCopies( long *along);
[put] HRESULT | PrintCopies( long along);
space
Calling argument description
[out,retval] long | *along
[in] long | along
C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • long *GetPrintCopies(void);
  • void PutPrintCopies( long along);
space


  • IGeneralCreditResult

IGeneralCreditResult interface |  | V4.30/ 3 Feb 2011
The IGeneralCreditResult interface allows to read back all data that have been set by the IGeneralCreditRequest interface or by loading a previously generated XML infoset with the IGeneralCreditRequestManger::LoadXML method. |  | space
Methods |  | 28 methods
GetAbortInfo | Get the abort information string with the error coded in the module language. |
GetBasicInsurance | Retrieves the various identifiers (EAN, law type,. |
GetCard | Retrieves the patient's insurance card information (might be the patient card later on). |
GetContact | Retrieves the EAN number and the structured address of the main contact. |
GetCostBearer | Retrieves the various identifiers (EAN,. |
GetCredit | Retrieves the credit object reference parameters. |
GetCreditRef | Retrieves the optional credit_ref object reference parameters. |
GetEmployer | Retrieves the various identifiers (EAN, Reg number,. |
GetFamilyDoctor | Retrieves the various identifiers (EAN, ZSR,. |
GetFirstDiagnosis | Retrieves the first diagnosis. |
GetFirstDocument | Retrieves the first document. |
GetFirstService | Retrieves the first service record. |
GetLaw | Retrieves the data about the applied and its dependent information |
GetNextDiagnosis | Retrieves the next diagnosis. |
GetNextDocument | Retrieves the next document |
GetNextService | Retrieves the next service record |
GetOuterCantonal | Retrieves the "outer cantonal" input data. |
GetPackage | Retrieves the identification parameters of the main software that used this DLL. |
GetPatient | Retrieves the primary parameters and structured address of the patient. |
GetProvider | Retrieves the various identifiers (EAN, ZSR,. |
GetReferrer | Retrieves the various identifiers (EAN, ZSR,. |
GetRequest | Retrieves the role and place information, the processing parameters "storno" and "copy" besides data language. |
GetRequestor | Retrieves the various identifiers (EAN, ZSR,. |
GetStationary | Retrieves the additional stationary treatment data if such a stationary treatment is defined. |
GetSubstantiation | Retrieves the substantiation (motives and reasons) for the treatment. |
GetSurgeon | Retrieves the various identifiers (EAN, ZSR,. |
GetTransport | Returns the transport information that is the routing information going from a sender (from) over the first intermediate (via) to the receiver (to). |
GetTreatment | Retrieves the primary treatment input data. |
Properties |  | 0 properties


  • IGeneralCreditResult
  • GetAbortInfo

IGeneralCreditResult::GetAbortInfo method |  |  |
Get the abort information string with the error coded in the module language. Call this method whenever the returned pbStatus variable of the primarily called method is VARIANT_FALSE and the primarily called method is not an iterator (GetFirst/GetNext). In the later case VARIANT_FALSE signals the end of data. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetAbortInfo( | BSTR VARIANT_BOOL | *pbstrAbort, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrAbort | Abort information string coded in the module language. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error-in-error situation occurred. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditResult
  • GetBasicInsurance

IGeneralCreditResult::GetBasicInsurance method |  |  |
Retrieves the various identifiers (EAN, law type,...) and the structured address of the patient's basic insurance. The basic insurance is supplied for an outer-cantonal stationary treatment since a credit request for the cantonal surgeon must be generated/sent besides one for the target insurance (given by the IGeneralCreditRequest::SetLaw method). VARIANT_FALSE is returned if the data are not defined. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetBasicInsurance( | LawType BSTR IAddress VARIANT_BOOL | *peLawType, *pbstrEAN, **ppIAddress, *pbStatus); |
Calling argument description |  |  |
[out] LawType | *peLawType | The type of basic insurance defined by the applicable type of law from the LawType enumeration. |
[out] BSTR | *pbstrEAN | EAN number of the basic insurance as supplied by medwin.ch |
[out] IAddress | **ppIAddress | The IAddress interface handle that allows to get the structured address data back. If no address is defined then the handle is NULL. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the data are not defined. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditResult
  • GetCard

IGeneralCreditResult::GetCard method |  |  |
Retrieves the patient's insurance card information (might be the patient card later on). VARIANT_FALSE is returned if the data are not defined. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetCard( | BSTR DATE DATE BSTR BSTR VARIANT_BOOL | *pbstrCardID, *pdExpiryDate, *pdValidationDate, *pbstrValidationID, *pbstrValidationServer, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrCardID | The mandatory unique 20 digits card identifier |
[out] DATE | *pdExpiryDate | The mandatory expiry date of the card |
[out] DATE | *pdValidationDate | The optional date of the last validation of the card's data |
[out] BSTR | *pbstrValidationID | The optional replied ID when the last validation of the card's data was performed |
[out] BSTR | *pbstrValidationServer | The optional server for the last validation process |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the data are undefined |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditResult
  • GetContact

IGeneralCreditResult::GetContact method |  |  |
Retrieves the EAN number and the structured address of the main contact. The structured address data is read via the methods of the returned IAddress interface. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetContact( | BSTR IAddress VARIANT_BOOL | *pbstrEAN, **ppIAddress, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrEAN | EAN number of the primary contact as supplied by medwin.ch |
[out] IAddress | **ppIAddress | The ppIAddress is an IAddress interface handle for the primary contact address. The interface handle allows to get the structured address data back. The address is either one of a person, a company, or an employee of an company. In the latter case the employee's full name is coded into the subaddress field. If no address is defined then the handle is NULL. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditResult
  • GetCostBearer

IGeneralCreditResult::GetCostBearer method |  |  |
Retrieves the various identifiers (EAN,...) and the structured address of the cost bearer of the credit request. The cost bearer might either be an insurance or a cantonal surgeon. The latter must be addressed in an outer-cantonal stationary treatment only. The IAddress interface might be NULL if no address was defined. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetCostBearer( | BSTR IAddress VARIANT_BOOL | *pbstrEAN, **ppIAddress, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrEAN | EAN number of the cost bearer as supplied by medwin.ch |
[out] IAddress | **ppIAddress | The IAddress interface handle that allows to get the structured address data back. If no address is defined then the handle is NULL. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditResult
  • GetCredit

IGeneralCreditResult::GetCredit method |  |  |
Retrieves the credit object reference parameters. The credit_ref (if supplied in the request), and credit object references form a object reference chain (credit_ref -> credit) with the credit as topmost object reference. The page "object reference" provides an in-depth description of the concepts of "object reference", "object reference chain", and "topmost object reference". |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetCredit( | CreditType BSTR DATE long YesNoType VARIANT_BOOL | *peCreditType, *pbstrRequestCreditID, *pdRequestCreditDate, *plRequestCreditTimestamp, *peIsCostEstimate, *pbStatus); |
Calling argument description |  |  |
[out] CreditType | *peCreditType | The type of credit that was generated. If the credit type is not "new" than a credit_ref object must be defined for the "older" reference object. |
[out] BSTR | *pbstrRequestCreditID | The request ID is the main software's identification of the credit ("Kostengutsprachenummer"). This is one of 3 identifiers that form the credit object reference. |
[out] DATE | *pdRequestCreditDate | The request date is the main software's date of the credit request ("Kostengutsprachedatum"). This is one of 3 identifiers that form the credit object reference. |
[out] long | *plRequestCreditTimestamp | This is a UNIX timestamp defined at the moment of the credit's infoset generation. This is one of 3 identifiers that form the credit object reference. |
[out] YesNoType | *peIsCostEstimate | Boolean value that defines the credit as "cost estimate" instead of "credit". From a semantical point of view cost estimates ("Kostenvoranschlag") and credits ("Kostengutsprache") are the same. It is more of a legal question as 'cost estimate' has a narrower cost interval than a credit. If you don't know what to set then check with then cost bearer. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditResult
  • GetCreditRef

IGeneralCreditResult::GetCreditRef method |  |  |
Retrieves the optional credit_ref object reference parameters. This object reference is only defined if the credit type (GetCredit@creditType) is 'prologation' or 're-considersation'. The credit_ref, and credit object references form a object reference chain (credit_ref -> credit) with the credit as topmost object reference. The page "object reference" provides an in-depth description of the concepts of "object reference", "object reference chain", and "topmost object reference". |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetCreditRef( | BSTR DATE long VARIANT_BOOL | *pbstrRequestCreditID, *pdRequestCreditDate, *plRequestCreditTimestamp, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrRequestCreditID | The request ID is the main software's identification of the credit ("Kostengutsprachenummer"). This is one of 3 identifiers that form the credit object reference. |
[out] DATE | *pdRequestCreditDate | The request date is the main software's date of the credit request ("Kostengutsprachedatum"). This is one of 3 identifiers that form the credit object reference. |
[out] long | *plRequestCreditTimestamp | This is a UNIX timestamp defined at the moment of the credit's infoset generation. This is one of 3 identifiers that form the credit object reference. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditResult
  • GetEmployer

IGeneralCreditResult::GetEmployer method |  |  |
Retrieves the various identifiers (EAN, Reg number,...) and the structured address of the employer of the patient. The IAddress interface might be NULL if no address was defined. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetEmployer( | BSTR BSTR IAddress VARIANT_BOOL | *pbstrEAN, *pbstrRegNumber, **ppIAddress, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrEAN | EAN number of the employer as supplied by medwin.ch |
[out] BSTR | *pbstrRegNumber | The employer's national BER number as defined by Swiss Federal Statistical Office |
[out] IAddress | **ppIAddress | The IAddress interface handle that allows to get the structured address data back. If no address is defined then the handle is NULL. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditResult
  • GetFamilyDoctor

IGeneralCreditResult::GetFamilyDoctor method |  |  |
Retrieves the various identifiers (EAN, ZSR,...) and the structured address of the patient's family doctor. The IAddress interface might be NULL if no address was defined. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetFamilyDoctor( | BSTR BSTR BSTR BSTR IAddress VARIANT_BOOL | *pbstrEAN, *pbstrZSR, *pbstrNIF, *pbstrSpecialty, **ppIAddress, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrEAN | EAN number of the family doctor as supplied by medwin.ch |
[out] BSTR | *pbstrZSR | ZSR number of the family doctor as supplied by santésuisse |
[out] BSTR | *pbstrNIF | The IV specific identification number NIF of the family doctor. |
[out] BSTR | *pbstrSpecialty | The specialty, i.e. FMH title of a physician. |
[out] IAddress | **ppIAddress | The IAddress interface handle that allows to get the structured address data back. If no address is defined then the handle is NULL. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditResult
  • GetFirstDiagnosis

IGeneralCreditResult::GetFirstDiagnosis method |  |  |
Retrieves the first diagnosis. VARIANT_FALSE is returned if the end of the diagnosis list is reached. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetFirstDiagnosis( | DiagnosisType BSTR BSTR SideType BSTR VARIANT_BOOL | *peDiagnosisType, *pbstrCode, *pbstrText, *peSideType, *pbstrRemark, *pbStatus); |
Calling argument description |  |  |
[out] DiagnosisType | *peDiagnosisType | The type of the diagnosis |
[out] BSTR | *pbstrCode | The code of the diagnosis as given in the corresponding diagnosis catalog defined by eDiagnosisType . |
[out] BSTR | *pbstrText | Textual description of the code as given in the corresponding diagnosis catalog defined by eDiagnosisType . |
[out] SideType | *peSideType | The side dependency of the diagnosis |
[out] BSTR | *pbstrRemark | An optional remark for the given diagnosis |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditResult
  • GetFirstDocument

IGeneralCreditResult::GetFirstDocument method |  |  |
Retrieves the first document. VARIANT_FALSE is returned if the end of the document list is reached. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetFirstDocument( | YesNoType BSTR BSTR BSTR BSTR VARIANT_BOOL | *peIsURL, *pbstrSource, *pbstrFilename, *pbstrMimeType, *pbstrViewer, *pbStatus); |
Calling argument description |  |  |
[out] YesNoType | *peIsURL | Boolean that defines if the document is defined online using a URL (enYes) or inline as Base64 coded stream (enNo). |
[out] BSTR | *pbstrSource | If eIsURL = enYes then bstrSource is a URL for accessing the file online. If eIsURL = enNo then bstrSource is a full file name (path + name). |
[out] BSTR | *pbstrFilename | The name of the file (without path) in the local file system. |
[out] BSTR | *pbstrMimeType | The MIME type of the document. |
[out] BSTR | *pbstrViewer | The optional URL where a viewer for the file can be downloaded. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditResult
  • GetFirstService

IGeneralCreditResult::GetFirstService method |  |  |
Retrieves the first service record. VARIANT_FALSE is returned if the end of the service list is reached. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetFirstService( | BSTR BSTR BSTR double double double double BSTR VARIANT_BOOL | *pbstrTariffType, *pbstrCode, *pbstrText, *pdQuantity, *pdBaseAmount, *pdScaleFactor, *pdAmount, *pbstrRemark, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrTariffType | The official tariff type as defined by Forum Datenaustausch bstrTariffType might be empty if the service is not covered by a official tariff catalog |
[out] BSTR | *pbstrCode | The service code as given by the used tariff catalog. bstrCode might be empty if the service is not covered by an official tariff catalog. |
[out] BSTR | *pbstrText | The service name is the official service name as given by the used tariff catalog. If it is not a service in the narrow sense (not covered by an official tariff catalog) then it describes that service with best effort. |
[out] double | *pdQuantity | The floating point quantity. Note that quantity changes the sign if a storno request is produced. |
[out] double | *pdBaseAmount | The base amount is the cost in CHF of one unit (service) including any VAT portion. |
[out] double | *pdScaleFactor | The applied scale factor for the given service. In principle the scale factor is used for defining discounts or surchages. However, it can be used as well for defining cost fractions e.g. in a DRG service. |
[out] double | *pdAmount | The amount in CHF of the service supplied in 2-digit precision calculated as quantity*scale factor*base amount. Note, that the base amount includes any VAT portion, therefore amount does as well. Note that amount changes the sign if a storno request is produced. |
[out] BSTR | *pbstrRemark | An optional remark for the given service |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditResult
  • GetLaw

IGeneralCreditResult::GetLaw method |  |  |
Retrieves the data about the applied and its dependent information |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetLaw( | LawType DATE BSTR BSTR BSTR VARIANT_BOOL | *peLawType, *pdCaseDate, *pbstrCaseID, *pbstrInsuredID, *pbstrContractNumber, *pbStatus); |
Calling argument description |  |  |
[out] LawType | *peLawType | The type of law to set from the LawType enumeration |
[out] DATE | *pdCaseDate | The case date of the insurance (e.g. date of accident in UVG) This date might be undefined for certain laws and therefore left empty |
[out] BSTR | *pbstrCaseID | The case ID of the insurance (e.g. accident number in UVG) This ID might be undefined for certain laws and therefore left empty |
[out] BSTR | *pbstrInsuredID | The patient's ID at the insurance This ID might undefined for certain laws and therefore left empty |
[out] BSTR | *pbstrContractNumber | Contract number if such a special contract exists between provider and insurance |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditResult
  • GetNextDiagnosis

IGeneralCreditResult::GetNextDiagnosis method |  |  |
Retrieves the next diagnosis. VARIANT_FALSE is returned if the end of the diagnosis list is reached. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetNextDiagnosis( | DiagnosisType BSTR BSTR SideType BSTR VARIANT_BOOL | *peDiagnosisType, *pbstrCode, *pbstrText, *peSideType, *pbstrRemark, *pbStatus); |
Calling argument description |  |  |
[out] DiagnosisType | *peDiagnosisType | The type of the diagnosis |
[out] BSTR | *pbstrCode | The code of the diagnosis as given in the corresponding diagnosis catalog defined by eDiagnosisType . |
[out] BSTR | *pbstrText | Textual description of the code as given in the corresponding diagnosis catalog defined by eDiagnosisType . |
[out] SideType | *peSideType | The side dependency of the diagnosis |
[out] BSTR | *pbstrRemark | An optional remark for the given diagnosis |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditResult
  • GetNextDocument

IGeneralCreditResult::GetNextDocument method |  |  |
Retrieves the next document VARIANT_FALSE is returned if the end of the document list is reached. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetNextDocument( | YesNoType BSTR BSTR BSTR BSTR VARIANT_BOOL | *peIsURL, *pbstrSource, *pbstrFilename, *pbstrMimeType, *pbstrViewer, *pbStatus); |
Calling argument description |  |  |
[out] YesNoType | *peIsURL | Boolean that defines if the document is defined online using a URL (enYes) or inline as Base64 coded stream (enNo). |
[out] BSTR | *pbstrSource | If eIsURL = enYes then bstrSource is a URL for accessing the file online. If eIsURL = enNo then bstrSource is a full file name (path + name). |
[out] BSTR | *pbstrFilename | The name of the file (without path) in the local file system. |
[out] BSTR | *pbstrMimeType | The MIME type of the document. |
[out] BSTR | *pbstrViewer | The optional URL where a viewer for the file can be downloaded. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditResult
  • GetNextService

IGeneralCreditResult::GetNextService method |  |  |
Retrieves the next service record VARIANT_FALSE is returned if the end of the service list is reached. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetNextService( | BSTR BSTR BSTR double double double double BSTR VARIANT_BOOL | *pbstrTariffType, *pbstrCode, *pbstrText, *pdQuantity, *pdBaseAmount, *pdScaleFactor, *pdAmount, *pbstrRemark, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrTariffType | The official tariff type as defined by Forum Datenaustausch bstrTariffType might be empty if the service is not covered by a official tariff catalog |
[out] BSTR | *pbstrCode | The service code as given by the used tariff catalog. bstrCode might be empty if the service is not covered by an official tariff catalog. |
[out] BSTR | *pbstrText | The service name is the official service name as given by the used tariff catalog. If it is not a service in the narrow sense (not covered by an official tariff catalog) then it describes that service with best effort. |
[out] double | *pdQuantity | The floating point quantity. Note that quantity changes the sign if a storno request is produced. |
[out] double | *pdBaseAmount | The base amount is the cost in CHF of one unit (service) including any VAT portion. |
[out] double | *pdScaleFactor | The applied scale factor for the given service. In principle the scale factor is used for defining discounts or surchages. However, it can be used as well for defining cost fractions e.g. in a DRG service. |
[out] double | *pdAmount | The amount in CHF of the service supplied in 2-digit precision calculated as quantity*scale factor*base amount. Note, that the base amount includes any VAT portion, therefore amount does as well. Note that amount changes the sign if a storno request is produced. |
[out] BSTR | *pbstrRemark | An optional remark for the given service. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditResult
  • GetOuterCantonal

IGeneralCreditResult::GetOuterCantonal method |  |  |
Retrieves the "outer cantonal" input data. The "outer cantonal" data is defined only for a stationary treatment where the patient's tax canton differs from the treatment canton. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetOuterCantonal( | CantonType BSTR BSTR DATE DATE VARIANT_BOOL | *peTaxCanton, *pbstrTaxCity, *pbstrEmergencyCity, *pdEmergencyDate, *pdRetransferDate, *pbStatus); |
Calling argument description |  |  |
[out] CantonType | *peTaxCanton | The tax canton given by the CantonType enumeration |
[out] BSTR | *pbstrTaxCity | The city where the patient is living and paying taxes. |
[out] BSTR | *pbstrEmergencyCity | If an emergency (IGeneralCreditRequest::SetStationary@eHospitalizationType = enEmergency) is the type/reason for the hospitalization then bstrEmergencyCity defines where the emergency happened. If the location is unknown or if it is not an emergency than an empty string is returned. |
[out] DATE | *pdEmergencyDate | If an emergency (IGeneralCreditRequest::SetStationary@eHospitalizationType = enEmergency) is the type/reason for the hospitalization then dEmergencyDate defines the date and time of the emergency. If this date is unknown or it is not an emergency than 0 is returned as date. |
[out] DATE | *pdRetransferDate | If an emergency (IGeneralCreditRequest::SetStationary@eHospitalizationType = enEmergency) is the type/reason for the hospitalization then dRetransferDate is the date of the earliest transfer to a hospital of the tax canton. If this date is unknown or it is not an emergency than 0 is returned as date. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. VARIANT_FALSE is returned if the outer cantonal data is undefined. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditResult
  • GetPackage

IGeneralCreditResult::GetPackage method |  |  |
Retrieves the identification parameters of the main software that used this DLL. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetPackage( | BSTR long long BSTR VARIANT_BOOL | *pbstrSoftwarePackage, *plSoftwareVersion, *plSoftwareID, *pbstrSoftwareCopyright, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrSoftwarePackage | Name of the main software that uses this DLL |
[out] long | *plSoftwareVersion | Version of the main software codes as 32-bit value where lSoftwareVersion = 100*Major version + Minor version. |
[out] long | *plSoftwareID | Optional ID of the main software that uses this DLL |
[out] BSTR | *pbstrSoftwareCopyright | The copyright notice of the developer of the main software. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditResult
  • GetPatient

IGeneralCreditResult::GetPatient method
Retrieves the primary parameters and structured address of the patient.

The address is defined via a IAddress interface pointer and the address data must be defined prior to calling this method.

space
C/C++ calling syntax
HRESULT GetPatient( SexType
DATE
BSTR
IAddress
VARIANT_BOOL 		*peSexType,
*pdBirthdate,
*pbstrSSN,
**ppIAddress,
*pbStatus);
Calling argument description
[out] SexType | *peSexType | The patient's gender.
[out] DATE | *pdBirthdate | The patient's birthdate.
[out] BSTR *pbstrSSN The social security number (SSN) of the patient in its printed form whereupon 3 distinguished forms are possible:
  • the old 11 digit Swiss SSN ("AHV-Nummer") as defined by Federal Social Insurance Office
  • the new 13 digit Swiss SSN ("SV-Nummer") beginning with 756 as defined by Federal Social Insurance Office
  • the new 4-10 digit SSN of Liechtenstein ("AHV-Nummer") as defined by Liechtensteinische AHV-IV-FAK
[out] IAddress **ppIAddress The IAddress interface handle that allows to get the structured address data back.
If no address is defined then the handle is NULL.
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


  • IGeneralCreditResult
  • GetProvider

IGeneralCreditResult::GetProvider method |  |  |
Retrieves the various identifiers (EAN, ZSR,...) and the structured address of the main provider. The IAddress interface might be NULL if no address was defined. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetProvider( | BSTR BSTR BSTR BSTR IAddress VARIANT_BOOL | *pbstrEAN, *pbstrZSR, *pbstrNIF, *pbstrSpecialty, **ppIAddress, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrEAN | EAN number of the provider as supplied by medwin.ch |
[out] BSTR | *pbstrZSR | ZSR number of the provider as supplied by santésuisse |
[out] BSTR | *pbstrNIF | The IV specific identification number NIF of the provider. |
[out] BSTR | *pbstrSpecialty | The specialty, i.e. FMH title of a physician. |
[out] IAddress | **ppIAddress | The IAddress interface handle that allows to get the structured address data back. If no address is defined then the handle is NULL. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditResult
  • GetReferrer

IGeneralCreditResult::GetReferrer method |  |  |
Retrieves the various identifiers (EAN, ZSR,...) and the structured address of the referrer. The IAddress interface might be NULL if no address was defined. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetReferrer( | BSTR BSTR BSTR BSTR IAddress VARIANT_BOOL | *pbstrEAN, *pbstrZSR, *pbstrNIF, *pbstrSpecialty, **ppIAddress, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrEAN | EAN number of the referrer as supplied by medwin.ch |
[out] BSTR | *pbstrZSR | ZSR number of the referrer as supplied by santésuisse |
[out] BSTR | *pbstrNIF | The IV specific identification number NIF of the referrer. |
[out] BSTR | *pbstrSpecialty | The specialty, i.e. FMH title of a physician. |
[out] IAddress | **ppIAddress | The IAddress interface handle that allows to get the structured address data back. If no address is defined then the handle is NULL. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditResult
  • GetRequest

IGeneralCreditResult::GetRequest method |  |  |
Retrieves the role and place information, the processing parameters "storno" and "copy" besides data language. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetRequest( | LanguageType RoleType PlaceType BSTR YesNoType YesNoType VARIANT_BOOL | *peDataLanguage, *peRoleType, *pePlaceType, *pbstrRoleTitle, *peIsStorno, *peIsCopy, *pbStatus); |
Calling argument description |  |  |
[out] LanguageType | *peDataLanguage | Sets the language in which the data part is coded. It is exactly the language in which the response is formulated. Note, that the data language and the module language (given by IGeneralCreditRequestManager::SetModuleLanguage) are independent and can be different! |
[out] RoleType | *peRoleType | Defines the role categories that the main provider is best categorized. If the main provider has an other role than defined then use enRoleOther and additionally supply a role title with a description of the role |
[out] PlaceType | *pePlaceType | Defines the principle place where the main provider is applying the treatment |
[out] BSTR | *pbstrRoleTitle | Optional role title/description of the main provider. If a suitable predefined role can not be set then bstrRoleTitle is mandatory (use enRoleOther as role in that case) |
[out] YesNoType | *peIsStorno | Boolean value that defines the "storno" status of the credit. eIsStorno should be false when the initial invoice or reminder is produced. At this step the timestamp is generated and returned in the GeneralCreditRequestManager::Print and/or GeneralCreditRequestManager::GetXML method. Whenever eIsStorno is true then the invoice or reminder timestamp must be set otherwise an error will result. |
[out] YesNoType | *peIsCopy | Boolean value that defines the "copy" status of the icredit. eIsCopy should be false when the initial invoice or reminder is produced. At this step the timestamp is generated and returned in the IGeneralCreditRequestManager::Print and/or IGeneralCreditRequestRequestManager::GetXML method. Whenever eIsCopy is true then the invoice or reminder timestamp must be set otherwise an error will result. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditResult
  • GetRequestor

IGeneralCreditResult::GetRequestor method |  |  |
Retrieves the various identifiers (EAN, ZSR,...) and the structured address of the requestor of the credit. The IAddress interface might be NULL if no address was defined. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetRequestor( | BSTR BSTR BSTR BSTR IAddress VARIANT_BOOL | *pbstrEAN, *pbstrZSR, *pbstrNIF, *pbstrSpecialty, **ppIAddress, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrEAN | EAN number of the requestor as supplied by medwin.ch |
[out] BSTR | *pbstrZSR | ZSR number of the requestor as supplied by santésuisse |
[out] BSTR | *pbstrNIF | The IV specific identification number NIF of the requestor. |
[out] BSTR | *pbstrSpecialty | The specialty, i.e. FMH title of a physician. |
[out] IAddress | **ppIAddress | The IAddress interface handle that allows to get the structured address data back. If no address is defined then the handle is NULL. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditResult
  • GetStationary

IGeneralCreditResult::GetStationary method |  |  |
Retrieves the additional stationary treatment data if such a stationary treatment is defined. VARIANT_FALSE is returned if the data are not defined. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetStationary( | HospitalizationType HospitalizationMode InsuranceClass InsuranceModel BSTR VARIANT_BOOL | *peHospitalizationType, *peHospitalizationMode, *peInsuranceClass, *peInsuranceModel, *pbstrSectionMajor, *pbStatus); |
Calling argument description |  |  |
[out] HospitalizationType | *peHospitalizationType | The type/reason of hospitalization given by the HospitalizationType enumeration |
[out] HospitalizationMode | *peHospitalizationMode | The mode/indication of hospitalization given by the HospitalizationMode enumeration |
[out] InsuranceClass | *peInsuranceClass | The insurance class given by the InsuranceClass enumeration |
[out] InsuranceModel | *peInsuranceModel | The insurance model given by the InsuranceModel enumeration. The insurance model is a possible refinement of the supplied insurance class. |
[out] BSTR | *pbstrSectionMajor | The major BfS section code as defined by Swiss Federal Statistical Office |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditResult
  • GetSubstantiation

IGeneralCreditResult::GetSubstantiation method |  |  |
Retrieves the substantiation (motives and reasons) for the treatment. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetSubstantiation( | BSTR BSTR VARIANT_BOOL | *pbstrMeasures, *pbstrRemark, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrMeasures | The intended measures for the treatment |
[out] BSTR | *pbstrRemark | An optional remark regarding the treatment |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditResult
  • GetSurgeon

IGeneralCreditResult::GetSurgeon method |  |  |
Retrieves the various identifiers (EAN, ZSR,...) and the structured address of the surgeon. Of course, the surgeon's address is set only if it is a stationary treatment with surgery and if known. The IAddress interface might be NULL if no address was defined. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetSurgeon( | BSTR BSTR BSTR BSTR IAddress VARIANT_BOOL | *pbstrEAN, *pbstrZSR, *pbstrNIF, *pbstrSpecialty, **ppIAddress, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrEAN | EAN number of the surgeon as supplied by medwin.ch |
[out] BSTR | *pbstrZSR | ZSR number of the surgeon as supplied by santésuisse |
[out] BSTR | *pbstrNIF | The IV specific identification number NIF of the surgeon. |
[out] BSTR | *pbstrSpecialty | The specialty, i.e. FMH title of a physician. |
[out] IAddress | **ppIAddress | The IAddress interface handle that allows to get the structured address data back. If no address is defined then the handle is NULL. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditResult
  • GetTransport

IGeneralCreditResult::GetTransport method |  |  |
Returns the transport information that is the routing information going from a sender (from) over the first intermediate (via) to the receiver (to). All the involved parties are defined by EAN numbers as defined by www.medwin.ch. If the parameters for the signature and encryption were set then these data are returned as well otherwise the corresponding variables are empty. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetTransport( | BSTR BSTR BSTR BSTR VARIANT_BOOL | *pbstrFromEAN, *pbstrViaEAN, *pbstrToEAN, *pbstrToBinDERFile, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrFromEAN | The EAN number of the sender as supplied by medwin.ch |
[out] BSTR | *pbstrViaEAN | The EAN number of the first intermediate as supplied by medwin.ch |
[out] BSTR | *pbstrToEAN | The EAN number of the receiver as supplied by medwin.ch |
[out] BSTR | *pbstrToBinDERFile | The file name of the binary DER certificate that is the public certificate of the "to" entity. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditResult
  • GetTreatment

IGeneralCreditResult::GetTreatment method
Retrieves the primary treatment input data. | space
C/C++ calling syntax
HRESULT GetTreatment( DATE
BSTR
CantonType
TreatmentReasonType
BSTR
BSTR
VARIANT_BOOL 		*pdDateBegin,
*pbstrTreatmentUnits,
*peTreatmentCanton,
*peTreatmentReason,
*pbstrPatientID,
*pbstrCaseID,
*pbStatus);
Calling argument description
[out] DATE | *pdDateBegin | dDateBegin is the (intended) start of the treatment
[out] BSTR *pbstrTreatmentUnits The optional number/length and units of the suggested treatment.

The treatment units are in fact context sensitive in their semantical meaning and therefore they are encoded by a string
due to the variety of possibilities.

Treatment units for stationary treatment are e.g. "4 days" whereas for a physio therapy it could be "6 physio sessions" or
"10 physio sessions - 1 per week"

[out] CantonType | *peTreatmentCanton | The treatment canton given by the CantonType enumeration
[out] TreatmentReasonType | *peTreatmentReason | The treatment reason given by the TreatmentReasonType enumeration
[out] BSTR | *pbstrPatientID | This is an optional patient identification of the main software ("Patientennummer").
[out] BSTR | *pbstrCaseID | This is an optional case identification of the main software ("Fallnummer"). In fact it is an ID used in the main software to identify this request and probably it is the same as the request credit ID (SetCredit@bstrRequestCreditID).
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


  • Type definitions

Builtin, composite & enumeration types |  | V4.30/ 3 Feb 2011
The following list shows ans defines all used data types either basic builtin, composite or enumeration types that are used in the interface of the ATL COM module. |  | space
Data types |  | 27 types
[enumeration] AddressType | Enumerates the defined address categories. |
[builtin] BSTR | A BSTR, known as basic string or binary string, is a pointer to a wide character string used by Automation data manipulation functions. |
[enumeration] CantonType | Enumerates the defined Swiss cantons or countries close to the border. |
[enumeration] CreditType | Enumerates the defined types of credits |
[builtin] DATE | A value denoting a date and time was specified. |
[enumeration] DiagnosisType | Enumerates the defined diagnosis coding systems. |
[builtin] double | An 8-byte IEEE real value. |
[enumeration] HospitalizationMode | Enumerates the defined modes/indications of the hospitalization |
[enumeration] HospitalizationType | Enumerates the defined types/reasons of the hospitalization |
[builtin] HRESULT | The HRESULT data type is a 32-bit value that is used to describe an error or warning. |
[builtin] IAddress | IAddress interface. |
[builtin] IGeneralCreditRequest | IGeneralCreditRequest interface. |
[builtin] IGeneralCreditResult | IGeneralCreditResponse interface. |
[enumeration] InsuranceClass | Enumerates the defined insurance classes |
[enumeration] InsuranceModel | The insurance model is a possible refinement of the insurance class |
[enumeration] LanguageType | Enumerates all supported languages. |
[enumeration] LawType | Enumerates the supported legal law set. |
[builtin] long | A 4-byte integer value. |
[enumeration] ModusType | Enumerates the defined operation modus types |
[enumeration] PlaceType | Enumerates the defined places where the main provider is located |
[enumeration] RoleType | Enumerates the defined role categories that the main provider is best categorized |
[enumeration] SexType | Enumerates the defined gender categories. |
[enumeration] SideType | Enumerates the defined side categories. |
[enumeration] TreatmentReasonType | Enumerates the defined treatment reasons. |
[builtin] VARIANT_BOOL | A 16 bit Boolean (True/False) value was specified. |
[enumeration] XMLGenerationAttributes | Enumerates defined types of XML generation attributes |
[enumeration] YesNoType | Boolean enumerator. |


  • Type definitions
  • AddressType

AddressType enumeration type |  |
Enumerates the defined address categories. |  | space
Set of enumeration values |  | 3 elements
enAddressUndefined: 0 | Undefined or unknown address. |
enAddressPerson: 1 | Person address. |
enAddressCompany: 2 | Company address. |


  • Type definitions
  • BSTR

BSTR type |
A BSTR, known as basic string or binary string, is a pointer to a wide character string used by Automation data manipulation functions. BSTRs are wide, double-byte (Unicode) strings on 32-bit Windows platforms. | space


  • Type definitions
  • CantonType

CantonType enumeration type |  |
Enumerates the defined Swiss cantons or countries close to the border. |  | space
Set of enumeration values |  | 32 elements
enCantonUndefined: 0 | Undefined or unknown canton. |
enAG: 1 | The Swiss canton is AG |
enAI: 2 | The Swiss canton is AI |
enAR: 3 | The Swiss canton is AR |
enBE: 4 | The Swiss canton is BE |
enBL: 5 | The Swiss canton is BL |
enBS: 6 | The Swiss canton is BS |
enFR: 7 | The Swiss canton is FR |
enGE: 8 | The Swiss canton is GE |
enGL: 9 | The Swiss canton is GL |
enGR: 10 | The Swiss canton is GR |
enJU: 11 | The Swiss canton is JU |
enLU: 12 | The Swiss canton is LU |
enNE: 13 | The Swiss canton is NE |
enNW: 14 | The Swiss canton is NW |
enOW: 15 | The Swiss canton is OW |
enSG: 16 | The Swiss canton is SG |
enSH: 17 | The Swiss canton is SH |
enSO: 18 | The Swiss canton is SO |
enSZ: 19 | The Swiss canton is SZ |
enTG: 20 | The Swiss canton is TG |
enTI: 21 | The Swiss canton is TI |
enUR: 22 | The Swiss canton is UR |
enVD: 23 | The Swiss canton is VD |
enVS: 24 | The Swiss canton is VS |
enZG: 25 | The Swiss canton is ZG |
enZH: 26 | The Swiss canton is ZH |
enLiechtenstein: 27 | The country is Liechtenstein |
enAustria: 28 | The country is Austria |
enGermany: 29 | The country is Germany |
enItaly: 30 | The country is Italy |
enFrance: 31 | The country is France |


  • Type definitions
  • CreditType

CreditType enumeration type |  |
Enumerates the defined types of credits |  | space
Set of enumeration values |  | 3 elements
enCreditNew: 1 | New credit request |
enCreditReconsideration: 2 | Re-consideration of a previously sent and rejected credit request |
enCreditProlongation: 3 | Prolongation of a previously accepted credit request |


  • Type definitions
  • DATE

DATE type |
A value denoting a date and time was specified. Dates are represented as double-precision numbers, where midnight, January 1, 1900 is 2.0, January 2, 1900 is 3.0, and so on. The value is passed in date. | space


  • Type definitions
  • DiagnosisType

DiagnosisType enumeration type |  |
Enumerates the defined diagnosis coding systems. |  | space
Set of enumeration values |  | 7 elements
enDiagnosisICD: 0 | ICD 10 diagnosis |
enDiagnosisCantonal: 1 | Cantonal diagnosis code. |
enDiagnosisByContract: 2 | Diagnosis coded according to contract. |
enDiagnosisFreeText: 3 | Free text diagnosis. |
enDiagnosisBirthdefect: 4 | Birth defect diagnosis |
enDiagnosisICPC: 5 | ICPC diagnosis (International Classification of Primary Care) |
enDiagnosisDRG: 6 | DRG diagnosis that is the DRG service code |


  • Type definitions
  • double

double type |
An 8-byte IEEE real value. | space


  • Type definitions
  • HospitalizationMode

HospitalizationMode enumeration type |  |
Enumerates the defined modes/indications of the hospitalization |  | space
Set of enumeration values |  | 3 elements
enCantonal: 0 | Mode of hospitalization is cantonal |
enIndicated: 1 | Mode of hospitalization is non-cantonal (person living in another canton then treated) but indicated. This implicitly qualifies to define "outer cantonal" data and to send a credit request to the cantonal surgeon. |
enNonIndicated: 2 | Mode of hospitalization is non-cantonal (person living in another canton then treated) and not indicated. This implicitly qualifies to define "outer cantonal" data and to send a credit request to the cantonal surgeon. |


  • Type definitions
  • HospitalizationType

HospitalizationType enumeration type |  |
Enumerates the defined types/reasons of the hospitalization |  | space
Set of enumeration values |  | 3 elements
enRegular: 0 | The reason of the hospitalization is regular |
enEmergency: 1 | The reason of the hospitalization is an emergency |
enWelfare: 2 | The reason of the hospitalization is due to welfare ("Freiheitsenzug") |


  • Type definitions
  • HRESULT

HRESULT type |
The HRESULT data type is a 32-bit value that is used to describe an error or warning. | space


  • Type definitions
  • IAddress

IAddress type |
IAddress interface. | space


  • Type definitions
  • IGeneralCreditRequest

IGeneralCreditRequest type |
IGeneralCreditRequest interface. | space


  • Type definitions
  • IGeneralCreditResult

IGeneralCreditResult type |
IGeneralCreditResponse interface. | space


  • Type definitions
  • InsuranceClass

InsuranceClass enumeration type |  |
Enumerates the defined insurance classes |  | space
Set of enumeration values |  | 3 elements
enClassGeneral: 0 | General insurance class (3rd class insurance coverage) |
enClassSemiPrivate: 1 | Semi-private insurance class (2nd class insurance coverage) |
enClassPrivate: 2 | Private insurance class (1st class insurance coverage) |


  • Type definitions
  • InsuranceModel

InsuranceModel enumeration type |  |
The insurance model is a possible refinement of the insurance class |  | space
Set of enumeration values |  | 4 elements
enModelStandard: 1 | Defines the given insurance class without further refinements |
enModelHospitalComfort: 2 | Defines the hospitalization comfort refinement above the given insurance class |
enModelFreeMDChoice: 3 | Defines the free choice of the physician refinement ("Freie Arztwahl") above the given insurance class |
enModelOther: 4 | Defines a refinement to the insurance class not given explicitly |


  • Type definitions
  • LanguageType

LanguageType enumeration type |  |
Enumerates all supported languages. |  | space
Set of enumeration values |  | 3 elements
enGerman: 1 | German |
enFrench: 2 | French. |
enItalian: 3 | Italian |


  • Type definitions
  • LawType

LawType enumeration type |  |
Enumerates the supported legal law set. |  | space
Set of enumeration values |  | 6 elements
enKVG: 0 | KVG - "Krankenversicherungsgesetz" |
enUVG: 1 | UVG - "Unfallversicherungsgesetz" |
enMVG: 2 | MVG - "Militäversicherungsgesetz" |
enIVG: 3 | IVG - "Invalidenversicherungsgesetz" |
enVVG: 4 | VVG - "Versicherungsvertragsgesetz" |
enORG: 5 | ORG - "Obligationenrecht" This is primarely for e.g. of dentists to produce cost estimates. |


  • Type definitions
  • long

long type |
A 4-byte integer value. | space


  • Type definitions
  • ModusType

ModusType enumeration type |  |
Enumerates the defined operation modus types |  | space
Set of enumeration values |  | 2 elements
enProduction: 0 | Production modus. |
enTest: 1 | Test modus - the data should not be forwarded to the receiver. |


  • Type definitions
  • PlaceType

PlaceType enumeration type |  |
Enumerates the defined places where the main provider is located |  | space
Set of enumeration values |  | 5 elements
enPlacePractice: 1 | The service location is the practice |
enPlaceHospital: 2 | The service location is the hospital |
enPlaceLab: 4 | The service location is in a laboratory |
enPlaceAssociation: 8 | The service location is in an association (like "Spitex") |
enPlaceCompany: 16 | The service location is in a company |


  • Type definitions
  • RoleType

RoleType enumeration type |  |
Enumerates the defined role categories that the main provider is best categorized |  | space
Set of enumeration values |  | 21 elements
enRolePhysician: 1 | The main provider is a physician |
enRolePhysiotherapist: 2 | The main provider is a physiotherapist This role includes therapeutic masseurs as well. |
enRoleChiropractor: 4 | The main provider is a chiropractor |
enRoleErgotherapist: 8 | The main provider is an ergotherapist |
enRoleNutritionist: 16 | The main provider is a nutritionist This role includes diet advisors, diabetic dietitian and diabetic advisors as well |
enRoleMidwife: 32 | The main provider is a midwife |
enRoleLogotherapist: 64 | The main provideris a logotherapist |
enRoleHospital: 128 | The main provider's address is that of a hospital. Therefore the "virtual" role is enRoleHospital and it qualifies the invoice/reminder as one from a hospital |
enRolePharmacist: 256 | The main provider is a pharmacist |
enRoleDentist: 512 | The main provider is a dentist This role includes dental hygienists as well. |
enRoleLabTechnician: 1024 | The main provider is a lab technician |
enRoleDentalTechnician: 2048 | The main provider is a dental technician |
enRoleOtherTechnician: 4096 | The main provider The main provider is a technician but neither a dental nor a lab technician This role includes (orthopedic) shoemakers as well |
enRolePsychologist: 16384 | The main provider a psychologist Note that psychiatrists would count as enRolePhysician |
enRoleWholesaler: 65536 | The main provider is a wholesaler |
enRoleNursingStaff: 131072 | The main provider is belonging to the nursing staff including nursing auxiliaries |
enRoleTransport: 262144 | The main provider accomplishes transports or carrier services This role includes ambulance transport as well. |
enRoleDruggist: 524288 | The main provider is a druggist |
enRoleNaturopathicDoctor: 1048576 | The main provider is a is naturopathic doctor. As per definition this is a doctor of non-conventional Western medicine/none-biomedicine. |
enRoleNaturopathicTherapist: 2097152 | The main provider is a is naturopathic therapist. As per definition this is a therapist of non-conventional Western medicine/non-biomedicine. This role includes wellness therapists as well. |
enRoleOther: 4194304 | The main provider has an other role than defined here. Supply a role title in this case with a description of the role |


  • Type definitions
  • SexType

SexType enumeration type |  |
Enumerates the defined gender categories. |  | space
Set of enumeration values |  | 2 elements
enMale: 0 | Male. |
enFemale: 1 | Female. |


  • Type definitions
  • SideType

SideType enumeration type |  |
Enumerates the defined side categories. |  | space
Set of enumeration values |  | 5 elements
enSideNone: 0 | No side dependency |
enSideLeft: 1 | Left body side is affected |
enSideRight: 2 | Right body side is affected |
enSideBoth: 3 | Both body sides are affected |
enSideUnknown: 4 | The side dependency is unknown |


  • Type definitions
  • TreatmentReasonType

TreatmentReasonType enumeration type |  |
Enumerates the defined treatment reasons. |  | space
Set of enumeration values |  | 6 elements
enDisease: 0 | The treatment reason is due to a disease. |
enAccident: 1 | The treatment reason is due to an accident |
enMaternity: 2 | The treatment reason is due to maternity |
enPrevention: 3 | The treatment reason is due to a prevention. |
enBirthdefect: 4 | The treatment reason is due to a birth defect |
enUnknown: 5 | The treatment reason is unknown |


  • Type definitions
  • VARIANT_BOOL

VARIANT_BOOL type |
A 16 bit Boolean (True/False) value was specified. A value of 0xFFFF (all bits 1) indicates True; a value of 0 (all bits 0) indicates False. No other values are valid. | space


  • Type definitions
  • XMLGenerationAttributes

XMLGenerationAttributes enumeration type |  |
Enumerates defined types of XML generation attributes |  | space
Set of enumeration values |  | 3 elements
enGenerateWithoutDocuments: 1 | The XML infoset is generated without documents even if such documents have been added in the IGeneralCreditRequest::AddDocument method. |
enGenerateWithoutSignature: 2 | The XML infoset is generated without applying a signature even if the signature parameters have been set in the IGeneralCreditRequest::SetTransport method. |
enGenerateWithoutEncryption: 4 | The XML infoset is generated without applying encryption even if the encryption parameters have been set in the IGeneralCreditRequest::SetTransport method. |


  • Type definitions
  • YesNoType

YesNoType enumeration type |  |
Boolean enumerator. |  | space
Set of enumeration values |  | 2 elements
enNo: 0 | No. |
enYes: 1 | Yes. |


 Notes about the encryption

XML Encryption is a specification, governed by a W3C recommendation, that defines how to encrypt the contents of an XML element. Although XML Encryption can be used to encrypt any kind of data, it is nonetheless known as "XML Encryption" because an XML element (either an EncryptedData or EncryptedKey element) contains or refers to the cipher text, keying information, and algorithms.

However, it is beyond the scope of this documentation to explain all details of a encryption or the encryption process. Detailed information about all aspects of encryption can be found at W3C.

Boundary conditions and critical aspects

  • the encryption is optional!
  • if an infoset is encrypted then the public certificate of the recipient must be used and this certificate is applied to the body element.

    Here recipient is used in terms of the communication and therefore is defined as the EAN entity given in the transport@to attribute
  • the namespace v1 of W3C http://www.w3.org/2001/04/xmlenc must be used- cf. XML Encryption Syntax and Processing
  • The encryption algorithm is fixed to PKCS1 (RSA-SHA1) (RFC 2437: RSA Cryptography Specifications)
  • The block encryption algorithm is fixed to Triple DES

The generalCreditRequest module does obey all these conditions whenever encryption is "turned on" by setting a public certificate of the "toEAN" entity (cf. IGeneralCreditRequest::SetTransport). This certificate must be in the format "binary DER".

Where do I get this certificate?
The request/response system is self-contained insofar as the generalCreditResponse module (or any other V4.3 module!) extracts the public certificate of a signed response XML infoset and generates a binary DER file named X509DER_from_EAN.cer. This is exactly the certificate to use for encrypting a credit (or all other V4.3) request XML infosets!


 VB code snippet for using the generalCreditRequestManager

Private Sub DoPhysio_Click()

On Error GoTo Err_Trap

'### Note: if you encounter a namespace problem with a variable declaration you have to
'###       put GENERALCREDITREQUESTMANAGER430Lib in front of the variable declaration
'###       for example instead of declaring:
'###           Dim address As IAddress
'###       you write:
'###           Dim address As GENERALCREDITREQUESTMANAGER430Lib.IAddress

Dim bStatus As Boolean

Dim today As Date
today = DateTime.Now

'### GeneralCreditRequestManager interface
Dim generalCreditManager As GENERALCREDITREQUESTMANAGER430Lib.GeneralCreditRequestManager
Set generalCreditManager = New GeneralCreditRequestManager

'### GeneralCreditRequestManager interface
Dim generalCreditRequest As GENERALCREDITREQUESTMANAGER430Lib.IGeneralCreditRequest
Set generalCreditRequest = generalCreditManager.generalCreditRequest

'### initialize the credit request
bStatus = generalCreditRequest.Initialize(enGerman)

'### set request
bStatus = generalCreditRequest.SetRequest(enRolePhysiotherapist, enPlacePractice, "Physio Knetzentrum", enNo, enNo)

'### set modus type
generalCreditManager.Modus = enTest

'### set package
bStatus = generalCreditRequest.SetPackage("GeneralCreditRequest430Ex", 10001, 4, "sumex1")

'### set transport
bStatus = generalCreditRequest.SetTransport("2012345678901", "", "", "", "7612345678901", "")

'### Address interface
Dim address As GENERALCREDITREQUESTMANAGER430Lib.IAddress
Set address = generalCreditRequest.CreateAddress()

'### credit parameters
Dim creditID As String
creditID = "200001001"
Dim lRequestCreditTimestamp As Long
lRequestCreditTimestamp = 1304495926
Dim requestCreditDate As Date
requestCreditDate = DateValue("2011-05-04")
bStatus = generalCreditRequest.SetCredit(enCreditNew, creditID, requestCreditDate, lRequestCreditTimestamp, enNo)

'### requestor
bStatus = address.Initialize()
bStatus = address.SetCompany("Physio Knetzentrum", "", "")
bStatus = address.SetPostal("Mustermusterstrasse 128", "", "4410", "Liestal", "", "")
bStatus = address.AddPhone("956 99 00", "061", "", "")
bStatus = address.SetFax("956 99 10", "061", "", "")
bStatus = address.SetOnline("info@company.ch", "")
bStatus = generalCreditRequest.SetRequestor("2011234567890", "H-1211-11", "", "", address)

'### contact
bStatus = address.SetPerson("Meier", "Anna", "Frau", "", "")
bStatus = address.AddPhone("956 99 23", "061", "", "")
bStatus = address.SetFax("956 99 10", "061", "", "")
bStatus = address.SetOnline("anna.meier@company.ch", "")
bStatus = generalCreditRequest.SetContact("2011234567890", address)

'### provider
bStatus = address.Initialize()
bStatus = address.SetPerson("Gerber", "Stefan", "Herr", "", "")
bStatus = address.SetPostal("Ribigasse 3-5", "", "4434", "Hoelstein", "", "")
bStatus = address.AddPhone("956 99 00", "061", "", "")
bStatus = address.SetFax("956 99 10", "061", "", "")
Dim eanProvider As String
eanProvider = "2034567890111"
bStatus = generalCreditRequest.SetProvider(eanProvider, "P-1234-56", "", "Dipl. Physio", address)

'### cost bearer
bStatus = address.Initialize()
bStatus = address.SetCompany("Krankenkasse Basel", "", "")
bStatus = address.SetPostal("Kassenallee 128", "", "4000", "Basel", "", "")
bStatus = address.AddPhone("810 00 00", "061", "", "")
bStatus = address.SetFax("810 00 99", "061", "", "")
bStatus = address.SetOnline("info@krankenkasse.ch", "")
bStatus = generalCreditRequest.SetCostBearer("7600000000000", address)

'### patient
bStatus = address.Initialize()
bStatus = address.SetPerson("Eggenberger", "Rolf", "Herr", "Dr.", "")
bStatus = address.SetPostal("Ribigasse 3-5", "", "4434", "Hoelstein", "", "")
Dim birthdate As Date
birthdate = DateTime.DateValue("28.2.1964")
Dim eSex As SexType
eSex = enMale
Dim ssn As String
ssn = ""
bStatus = generalCreditRequest.SetPatient(enMale, birthdate, ssn, address)

'### no referrer here

'### no employer here

'### treatment
Dim caseID As String
caseID = "2005.01001-1"
Dim eCanton As CantonType
eCanton = enBL
Dim strTreatmentUnits, strPatientID As String
strPatientID = "123456"
strTreatmentUnits = "4 Sitzungen insgesamt - 1 pro Woche"
bStatus = generalCreditRequest.SetTreatment(today + 10, strTreatmentUnits, eCanton, _
                                            enDisease, strPatientID, caseID)

'### intended therapy (service part)
Dim tariffCode, tariffText, tariffType As String
tariffType = "311"
tariffCode = "7301"
tariffText = "Sitzungspauschale und weitere Therapie"
Dim dTaxPoints7301 As Double
dTaxPoints7301 = 48
Dim dTaxPointValueBL As Double
dTaxPointValueBL = 0.95
Dim dBaseAmount As Double
dBaseAmout = dTaxPointValueBL * dTaxPoints7301
Dim dScaleFactor As Double
dScaleFactor = 1
bStatus = generalCreditRequest.AddService(tariffType, tariffCode, tariffText, 4, dBaseAmout, _
                                          dScaleFactor, strRemark)

'### Substantiation
Dim substantiation As String
substantiation = "Lorem ipsum per nostra mi fune torectum mi konstradiloru si limus mer fin"
bStatus = generalCreditRequest.SetSubstantiation(substantiation, "")

'### law
bStatus = generalCreditRequest.SetLaw(enKVG, DateTime.DateValue("2011-05-01"), caseID, _
                                      "Insured ID", "")

'### diagnosis
bStatus = generalCreditRequest.AddDiagnosis(enDiagnosisByContract, "A1", "A1 Text", enSideBoth, "")
bStatus = generalCreditRequest.AddDiagnosis(enDiagnosisByContract, "B2", "", enSideBoth, "")

'### produce xml
Dim lXMLGenerationAttribute As Long
lXMLGenerationAttribute = 0
Dim lValidationError As Long
Dim lTimestamp As Long
Dim generalCreditResult As GENERALCREDITREQUESTMANAGER430Lib.generalCreditResult
Dim strXmlFile As String
Dim strUsedSchema As String

bStatus = generalCreditManager.GetXML(lXMLGenerationAttribute, strXmlFile, lValidationError,  _
                                      lTimestamp, strUsedSchema, generalCreditResult)
'### GetXML produces a tmp file that needs to be copied
Dim strTargetFile As String
strTargetFile = "GeneralCreditRequestExample430.xml"
FileCopy strXmlFile, strTargetFile
Set generalCreditResult = Nothing

'### print
bStatus = generalCreditManager.Print("", enYes, enYes, "", Nothing, lTimestamp, strUsedSchema, _
                                     generalCreditResult)
Set generalCreditResult = Nothing

'### relase resources
Set address = Nothing
Set generalCreditRequest = Nothing
Set generalCreditManager = Nothing

Exit Sub

Err_Trap:
    MsgBox "Error: " & Err.Description, vbCritical, _
           "Opps! Error" & Str$(Err.Number)
'### relase resources
Set address = Nothing
Set generalCreditRequest = Nothing
Set generalCreditManager = Nothing

End Sub


 General use of the generalCreditRequest ATL COM module

The IGeneralCreditRequestManager interface provides all the necessary methods to produce a credit for all roles and places.

Firstly, an instance of the IGeneralCreditRequest interface is created by the GeneralCreditRequest property. All the credit related data and parameters can be set by the supplied interface methods like SetPatient, SetTreatment,...

The auxiliary interface IAddress is available for setting/getting structured addresses.

After all information is defined the credit is printed or a XML infoset is produced which can be electronically transported to the recipient. In the latter case the credit optionally can be signed and/or encrypted .

Due to he processing attributes "storno" and "copy" a previously generated credit can be canceled or a copy can be produced (cf. Notes about processing attributes).

To get a staring point there is a Visual Basic code snippet provided that can be used for using the generalCreditRequest module.


 How to generate PDF archive files of a credit

To generate PDF archive files of a credit in the generalCreditRequestManager use
(PDF=PDF_file_to_generate;)
or
(PDF_NOPRINT=PDF_file_to_generate;)
as an object name in the Print method. The "PDF" token means to print the credit and generate the PDF files, whereas the "PDF_NOPRINT" token only generates the PDF files without physical printing.
This object definition is only used while printing and is ignored in the preview mode!

In its simplest form e.g. in the generalCreditRequestManager code this means

     BSTR bstrPrintTemplate = "(PDF="+bstrPDFFile+";)";

     IGeneralCreditRequestManager::Print(bstrPrintTemplate,...);
to generate a PDF archive file of the credit request.

Since the PDF generation is not the main purpose of the Print method this PDF feature has NO error propagation. The generation is done on a best effort basis, errors are only dumped to the log file!
Boundary conditions:

  • Only active in printing mode
  • No error propagation
  • The supplied PDF archive name(s) must not exist
  • The directory where the PDF is stored must be writable (EMF files are temporarily generated and delete there.)


 How to print webstamps onto a credit request

To print a webstamp onto a credit request in the generalCreditRequestManager module use a special print object name (cf. Syntax of the printTemplate variable for an overview).
(WEBSTAMP=file_path_of_BMP_file;)
as a print object name on the printTemplate variable of the Print method.

In its simplest form e.g. in the GeneralCreditRequestManager code this means

     BSTR bstrPrintTemplate = "(WEBSTAMP="+bstrBMPFile+";)";

     IGeneralCreditRequestManager::Print(bstrPrintTemplate,...);
to print a webstamp onto the first page of the credit request.

Since the webstamp printing is not the main purpose of the Print method this feature has NO error propagation. The generation is done on a best effort basis, errors are only dumped to the log file!

Boundary conditions:

  • No error propagation
  • The supplied BMP webstamp must exist


 How to set the default printer for a certain request

The report generator included in the module allows to map a printer with its print settings against a print template.

The interface IGeneralCreditRequestManager includes the IGeneralCreditRequestManager::PrintSetup method which displays the Microsoft's standard print setup dialog. The defined printer and its settings are then stored persistently in a INI file of the same name as the print template but with an extension .vpd (whereas the print template has an extension .vps).


 Syntax of the printTemplate variable of the Print method

bstrPrintTemplate argument of the IGeneralCreditRequestManager::Print is either empty or of the general form given below.

If the bstrPrintTemplate variable is empty then the default print template (using the data language as language switch - see below) is used.
However, bstrPrintTemplate can be used to change the normal printing behavior or changing printing objects dynamically. The following syntax is used as content of the bstrPrintTemplate variable:

[logTpl][(objectName1=text;...)][=printTemplateFile][#INIPATH=inipath]

where a [] pair defines an optional part. The commands are case insensitive.
  • logTpl: is the logical template name where just one template name is defined: detail.
  • objectName1=text; does a substitution of the content of the print object objectName1 by the given text. A print object is terminated by a semicolon and all print objects together are enclosed in a () pair.

    There are 2 predefined pseudo print objects with a special meaning:

    • PDF for generating PDF files
    • WEBSTAMP for printing electronic stamps

  • printTemplateFile is an external print template file name (full path + name!). If an external print template is supplied it must be mapped against a logical template. Therefore detail=full_vps_file must be used!
  • #INIPATH=inipath defines a fully qualified path to a directory where the report engine searches the corresponding .vpd print template INI file. This allows for global settings of a print template in a LAN. The default inipath is the install directory of the Dll

Here are some usage examples:
  • bstrPrintTemplate: "" or bstrPrintTemplate: Detail
    denotes a standard printing situation.
  • bstrPrintTemplate: (DOCUMENT_TITLE=Alternate title for the credit;) prints a substituted title as given above.
  • bstrPrintTemplate: detail=C:\myForms\myPrintForm.vps
    uses the print template "C:\myForms\myPrintForm.vps". An optional INI file with the name "C:\myForms\myPrintForm.vpd" is searched under this condition.
  • bstrPrintTemplate: #INIPATH=\\host1\\myForms\
    the default path for the ini files (place of the installed component) is changed to "\\host1\\myForms\". If "\\host1\\myForms\" is accessible by all hosts of the LAN then the same INI settings can be used.


generalCreditRequest: /en

 Process attributes...

An XML request is primarily defined by its topmost object reference (cf. "Overview over "Object reference"). However, the XML request is further characterized by a state that is formed by a set of Boolean process attributes, namely

"copy" attribute

The copy attribute defines the XML request as an identical copy of an initial request.
The absence of the copy attribute in reverse defines the XML request as "normal" (initial) request.

It is considered an error to send a XML request with turned on copy attribute without having prior sent a "normal" request.

"storno" attribute

The storno attribute cancels the XML request defined by the topmost reference object.
The absence of the storno attribute in reverse defines the XML request as "normal" request.

It is considered an error to send a XML request with turned on storno attribute without having prior sent a "normal" request.

The copy and storno attributes can be combined to form a total of 4 different combinations.


generalCreditRequest: /en

 Object reference...

The following paragraphs defines the concepts of object reference, object reference chain, and topmost object reference. These concepts are of high importance within the XML request/response system.

object reference

An object reference is an identification of an individual XML request defined by a unique triple of data, namely
  • timestamp (UNIX time) defined at the moment of generation
  • date of the object defined by the provider
  • id of the object defined by the provider
Each and every XML request of version 4.3 is defined by such an object reference. All XML responses are replies to the object reference of the corresponding request.

Thus the object reference is a clustered primary key of the request/response system!

object reference chain

As a consequence of the XML schema coded business logic most XML request schemas define more than just 1 object reference, e.g. a "GeneralCreditRequest" can hold a maximum of 2 object references, namely
  • an optional credit_ref object reference from a previous "General Credit Request" process
  • an mandatory credit object reference from the "General Credit Request" process
This set of object references by itself defines an ordered object reference chain (e.g. credit_ref -> credit) with the topmost object reference as unique identification of the XML request. Therefore the object reference chain defines -on business logic point of view- dependencies among different XML requests.

topmost object reference

The end node of an object reference chain is defined as topmost object reference, that is by definition the object reference of the XML request itself. Each request/response communication is always done for this topmost object reference and only for that.


 Notes about the signature

XML signatures are digital signatures designed for use in XML transactions. The W3C standard defines a schema for capturing the result of a digital signature operation applied to an infoset. XML signatures add authentication, data integrity, and support for non-repudiation to the data that they sign.
However, it is beyond the scope of this documentation to explain all details of a signature or the signing process. Detailed information about all aspects of signatures can be found at W3C.

Boundary conditions and critical aspects

  • the signature is optional!
  • if an infoset is signed then the private certificate of the sender must be used and this certificate is applied to the payload element. This inherently qualifies for a detached signature.

    In this context sender is used in terms of the communication and therefore is defined as the EAN entity given in the transport@from attribute

  • the URI attribute of the reference element must use a XPointer syntax of the payload element, e.g. <ds:Reference URI="#xpointer(/credit:request/credit:payload)">
  • it is recommended to add the public key via a X509Data element such that a key store can be built at the recipient's site
  • The signature algorithm is fixed to PKCS1 (RSA-SHA1) (RFC 2437: RSA Cryptography Specifications)
  • The digest algorithm is fixed to SHA-1
  • the used canonicalization algorithm must be http://www.w3.org/2001/10/xml-exc-c14n#, the exclusive XML Canonicalization

The generalCreditRequest module does obey all these conditions whenever signature is "turned on" by setting the private certificate and password of the "fromEAN" entity (cf. IGeneralCreditRequest::SetTransport). This certificate must be in the PFX format.