 API browser of generalCreditResponse430 COM module
Interface version: | 4.30
Interface date: | 3 Feb 2011

The GeneralCreditResponseManager is an ATL COM module which provides methods to load and analyze XML infosets of type generalCreditResponse_430. These infosets are responses to a previously sent credit requests where the topmost object reference defines the target request. The subchapter object reference provides an in-depth description of the concept of "object reference". |  | space
Interfaces |  | 3 interface
IAddress | Address functionality |
IGeneralCreditResponse | Output of credit response results |
IGeneralCreditResponseManager | Main invoice response handling |
Types |  |
type definitions | List of all used builtin, composite and enumeration types |
Important information about the usage and handling of the module |  |
Document | General usage of the generalCreditResponse430 COM module - an overview |
Document | Overview of the concept of "Object reference" |
Document | Notes about the signature part of the XML infoset |
Document | Notes about the encryption part of the XML infoset |
Document | How to generate a PDF archive file of a generalCredit |
Document | VB code snippet for using the generalCreditResponse430 COM module |

© by sumex1.net - all rights reserved


  • generalCreditResponse430
  • IAddress

IAddress interface |  | V4.30/ 3 Feb 2011
With the IAddress interface structured address data can be set and retrieved. The address of a person is set by the method SetPerson and a company address is entered by the method SetCompany. Before setting a new address the address data has to be initialized by the method Initialize. |  | space
Methods |  | 15 methods
AddPhone | Adds a structured phone number |
GetAbortInfo | Get the abort information string with the error coded in the module language |
GetCompany | Retrieves the company's naming part of the address |
GetFax | Retrieves the structured fax number |
GetFirstPhone | Retrieves the first phone number information |
GetNextPhone | Retrieves the next phone number information |
GetOnline | Retrieves the structured online part of the address |
GetPerson | Retrieves the person's naming part of the address |
GetPostal | Retrieves the structured postal address part of the address |
Initialize | Initializes all address variables |
SetCompany | Sets the company's naming part of the address |
SetFax | Sets a structured fax number |
SetOnline | Sets the structured online part of the address. |
SetPerson | Sets the person's naming part of the address |
SetPostal | Sets the structured postal address part |
Properties |  | 1 properties
[get] Type | GetType returns the type of address either enAddressPerson or enAddressCompany if a address is defined at all |


  • IAddress
  • AddPhone

IAddress::AddPhone method |  |  |
Adds a structured phone number. The Swiss international calling code +41 is filtered in the printing. If the main software does not support structured phone numbers then all data is supplied in the bstrNumber variable. However, +41 is then no longer filtered. |  |  | space
C/C++ calling syntax |  |  |
HRESULT AddPhone( | BSTR BSTR BSTR BSTR VARIANT_BOOL | bstrNumber, bstrLocalCode, bstrInternationalCode, bstrExt, *pbStatus); |
Calling argument description |  |  |
[in] BSTR | bstrNumber | Phone number. |
[in] BSTR | bstrLocalCode | Local area code. |
[in] BSTR | bstrInternationalCode | International calling code. |
[in] BSTR | bstrExt | Extension number. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IAddress
  • GetAbortInfo

IAddress::GetAbortInfo method |  |  |
Get the abort information string with the error coded in the module language. Call this method whenever the returned pbStatus variable of the primarily called method is VARIANT_FALSE and the primarily called method is not an iterator (GetFirst/GetNext). In the later case VARIANT_FALSE signals the end of data. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetAbortInfo( | BSTR VARIANT_BOOL | *pbstrAbort, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrAbort | Abort information string coded in the module language. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IAddress
  • GetCompany

IAddress::GetCompany method |  |  |
Retrieves the company's naming part of the address. Call the property GetType first to test if GetPerson or GetCompany should be called. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetCompany( | BSTR BSTR BSTR VARIANT_BOOL | *pbstrCompanyName, *pbstrDepartment, *pbstrSubaddressing, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrCompanyName | Company name. |
[out] BSTR | *pbstrDepartment | Department. |
[out] BSTR | *pbstrSubaddressing | Optional subaddressing information, e.g. c/o, P.O. box and the like |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IAddress
  • GetFax

IAddress::GetFax method |  |  |
Retrieves the structured fax number. Empty variables are returned if there is no fax number available. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetFax( | BSTR BSTR BSTR BSTR VARIANT_BOOL | *pbstrNumber, *pbstrLocalCode, *pbstrInternationalCode, *pbstrExt, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrNumber | Fax number. |
[out] BSTR | *pbstrLocalCode | Local area code. |
[out] BSTR | *pbstrInternationalCode | International calling code. |
[out] BSTR | *pbstrExt | Extension number. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IAddress
  • GetFirstPhone

IAddress::GetFirstPhone method |  |  |
Retrieves the first phone number information. VARIANT_FALSE is returned if the end of the phone list is reached. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetFirstPhone( | BSTR BSTR BSTR BSTR VARIANT_BOOL | *pbstrNumber, *pbstrLocalCode, *pbstrInternationalCode, *pbstrExt, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrNumber | Phone number. |
[out] BSTR | *pbstrLocalCode | Local area code. |
[out] BSTR | *pbstrInternationalCode | International calling code. |
[out] BSTR | *pbstrExt | Extension number. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IAddress
  • GetNextPhone

IAddress::GetNextPhone method |  |  |
Retrieves the next phone number information. VARIANT_FALSE is returned if the end of the phone list is reached |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetNextPhone( | BSTR BSTR BSTR BSTR VARIANT_BOOL | *pbstrNumber, *pbstrLocalCode, *pbstrInternationalCode, *pbstrExt, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrNumber | Phone number. |
[out] BSTR | *pbstrLocalCode | Local area code. |
[out] BSTR | *pbstrInternationalCode | International calling code. |
[out] BSTR | *pbstrExt | Extension number. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IAddress
  • GetOnline

IAddress::GetOnline method |  |  |
Retrieves the structured online part of the address. Empty variables are returned if there are no online information available. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetOnline( | BSTR BSTR VARIANT_BOOL | *pbstrEMail, *pbstrUrl, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrEMail | Email address. |
[out] BSTR | *pbstrUrl | URL. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IAddress
  • GetPerson

IAddress::GetPerson method |  |  |
Retrieves the person's naming part of the address. Call the property GetType first to test if GetPerson or GetCompany should be called. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetPerson( | BSTR BSTR BSTR BSTR BSTR VARIANT_BOOL | *pbstrFamilyname, *pbstrGivenname, *pbstrSalutation, *pbstrTitle, *pbstrSubaddressing, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrFamilyname | Family name. |
[out] BSTR | *pbstrGivenname | Given name. |
[out] BSTR | *pbstrSalutation | Salutation. |
[out] BSTR | *pbstrTitle | Title. |
[out] BSTR | *pbstrSubaddressing | Optional subaddressing information, e.g. c/o, P.O. box and the like |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IAddress
  • GetPostal

IAddress::GetPostal method |  |  |
Retrieves the structured postal address part of the address |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetPostal( | BSTR BSTR BSTR BSTR BSTR BSTR VARIANT_BOOL | *pbstrStreet, *pbstrPoBox, *pbstrZip, *pbstrCity, *pbstrStateCode, *pbstrCountryCode, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrStreet | Street. |
[out] BSTR | *pbstrPoBox | P.O. Box. |
[out] BSTR | *pbstrZip | ZIP code |
[out] BSTR | *pbstrCity | City. |
[out] BSTR | *pbstrStateCode | State code. |
[out] BSTR | *pbstrCountryCode | ISO country code. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IAddress
  • Initialize

IAddress::Initialize method |  |  |
Initializes all address variables. This method should be called before any data are supplied. |  |  | space
C/C++ calling syntax |  |  |
HRESULT Initialize( | VARIANT_BOOL | *pbStatus); |
Calling argument description |  |  |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IAddress
  • SetCompany

IAddress::SetCompany method |  |  |
Sets the company's naming part of the address. Note that the subaddressing is part of the extended name and is always printed before any postal information. |  |  | space
C/C++ calling syntax |  |  |
HRESULT SetCompany( | BSTR BSTR BSTR VARIANT_BOOL | bstrCompanyName, bstrDepartment, bstrSubaddressing, *pbStatus); |
Calling argument description |  |  |
[in] BSTR | bstrCompanyName | Company name. |
[in] BSTR | bstrDepartment | Department. |
[in] BSTR | bstrSubaddressing | Optional subaddressing information, e.g. c/o, P.O. box and the like |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IAddress
  • SetFax

IAddress::SetFax method |  |  |
Sets a structured fax number. The Swiss international calling code +41 is filtered in the printing. If the main software does not support structured pone numbers then all data is supplied in the bstrNumber variable. However, +41 is then no longer filtered. |  |  | space
C/C++ calling syntax |  |  |
HRESULT SetFax( | BSTR BSTR BSTR BSTR VARIANT_BOOL | bstrNumber, bstrLocalCode, bstrInternationalCode, bstrExt, *pbStatus); |
Calling argument description |  |  |
[in] BSTR | bstrNumber | Fax number. |
[in] BSTR | bstrLocalCode | Local area code. |
[in] BSTR | bstrInternationalCode | International calling code. |
[in] BSTR | bstrExt | Extension number. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IAddress
  • SetOnline

IAddress::SetOnline method |  |  |
Sets the structured online part of the address. |  |  | space
C/C++ calling syntax |  |  |
HRESULT SetOnline( | BSTR BSTR VARIANT_BOOL | bstrEMail, bstrUrl, *pbStatus); |
Calling argument description |  |  |
[in] BSTR | bstrEMail | Email address. |
[in] BSTR | bstrUrl | URL. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IAddress
  • SetPerson

IAddress::SetPerson method |  |  |
Sets the person's naming part of the address. Note that the subaddressing is part of the extended name and is always printed before any postal information. |  |  | space
C/C++ calling syntax |  |  |
HRESULT SetPerson( | BSTR BSTR BSTR BSTR BSTR VARIANT_BOOL | bstrFamilyname, bstrGivenname, bstrSalutation, bstrTitle, bstrSubaddressing, *pbStatus); |
Calling argument description |  |  |
[in] BSTR | bstrFamilyname | Family name. |
[in] BSTR | bstrGivenname | Given name. |
[in] BSTR | bstrSalutation | Salutation. |
[in] BSTR | bstrTitle | Title. |
[in] BSTR | bstrSubaddressing | Optional subaddressing information, e.g. c/o, P.O. box and the like |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IAddress
  • SetPostal

IAddress::SetPostal method |  |  |
Sets the structured postal address part. The Swiss ISO county code is the default but is filtered in the printing. |  |  | space
C/C++ calling syntax |  |  |
HRESULT SetPostal( | BSTR BSTR BSTR BSTR BSTR BSTR VARIANT_BOOL | bstrStreet, bstrPoBox, bstrZip, bstrCity, bstrStateCode, bstrCountryCode, *pbStatus); |
Calling argument description |  |  |
[in] BSTR | bstrStreet | Street. |
[in] BSTR | bstrPoBox | P.O. Box. |
[in] BSTR | bstrZip | ZIP code |
[in] BSTR | bstrCity | City. |
[in] BSTR | bstrStateCode | State code like the codes of the US states. Such state code should only be supplied if it is part of the address because the state code is printed before the zip code. |
[in] BSTR | bstrCountryCode | ISO country code. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IAddress
  • Type

IAddress::Type property
GetType returns the type of address either enAddressPerson or enAddressCompany if a address is defined at all. If no address is set then enAddressUndefined is returned. | space
C/C++ calling syntax
[get] HRESULT | Type( AddressType *aAddressType);
space
Calling argument description
[out, retval] AddressType | *aAddressType
C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • AddressType *GetType(void);
space


  • IGeneralCreditResponse

IGeneralCreditResponse interface |  | V4.30/ 3 Feb 2011
The IGeneralCreditResponse interface allows to read back all data that have been loaded with the IGeneralCreditResponseManager::LoadXML method. |  | space
Methods |  | 34 methods
GetAbortInfo | Get the abort information string with the error coded in the module language |
GetAcceptType | This method is called if the main response type returned by the GetResponse method is enResponseAccepted |
GetBasicInsurance | Retrieves the various identifiers (EAN, law type,...) and the structured address of the patient's basic insurance |
GetCard | Retrieves the patient's insurance card information (might be the patient card later on) |
GetContact | Retrieves the EAN number and the structured address of the main contact |
GetCostBearer | Retrieves the various identifiers (EAN,...) and the structured address of the cost bearer of the credit request |
GetCredit | Retrieves the credit object reference parameters |
GetCreditRef | Retrieves the optional credit_ref object reference parameters |
GetEmployer | Retrieves the various identifiers (EAN, Reg number,...) and the structured address of the employer of the patient |
GetFamilyDoctor | Retrieves the various identifiers (EAN, ZSR,...) and the structured address of the patient's family doctor |
GetFirstDiagnosis | Retrieves the first diagnosis |
GetFirstDocument | Retrieves the first document sent by the cost bearer |
GetFirstNotification | Retrieves the first notification object |
GetFirstService | Retrieves the first service record |
GetGenerator | Retrieves the identification parameters of the senders XML infoset generator software. |
GetLaw | Retrieves the data about the applied and its dependent information |
GetNextDiagnosis | Retrieves the next diagnosis |
GetNextDocument | Retrieves the next document sent by the cost bearer |
GetNextNotification | Retrieves the next notification object |
GetNextService | Retrieves the next service record |
GetOuterCantonal | Retrieves the "outer cantonal" input data |
GetPackage | Retrieves the identification parameters of the senders main software |
GetPatient | Retrieves the primary parameters and structured address of the patient |
GetPendingType | This method is called if the main response type returned by the GetResponse method is enResponsePending |
GetProvider | Retrieves the various identifiers (EAN, ZSR,...) and the structured address of the main provider |
GetReferrer | Retrieves the various identifiers (EAN, ZSR,...) and the structured address of the referrer |
GetRejectType | This method is called if the main response type returned by the GetResponse method is enResponseRejected |
GetRequestor | Retrieves the various identifiers (EAN, ZSR,...) and the structured address of the requestor of the credit |
GetResponse | Returns the primary parameters of the response infoset, namely the operation modus, the language the infoset is formulated, and most important the type of the response |
GetStationary | Retrieves the additional stationary treatment data if such a stationary treatment is defined |
GetSubstantiation | Retrieves the substantiation (motives and reasons) for the treatment. |
GetSurgeon | Retrieves the various identifiers (EAN, ZSR,...) and the structured address of the surgeon |
GetTransport | Returns the transport information that defines the routing of the infoset |
GetTreatment | Retrieves the primary treatment input data. |
Properties |  | 0 properties


  • IGeneralCreditResponse
  • GetAbortInfo

IGeneralCreditResponse::GetAbortInfo method |  |  |
Get the abort information string with the error coded in the module language. Call this method whenever the returned pbStatus variable of the primarily called method is VARIANT_FALSE and the primarily called method is not an iterator (GetFirst/GetNext). In the later case VARIANT_FALSE signals the end of data. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetAbortInfo( | BSTR VARIANT_BOOL | *pbstrAbort, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrAbort | Abort information string coded in the module language. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditResponse
  • GetAcceptType

IGeneralCreditResponse::GetAcceptType method
This method is called if the main response type returned by the GetResponse method is enResponseAccepted.

Calling the iterator pair GetFirstNotification / GetNextNotification is unnecessary as there are no notifications and VARIANT_FALSE would be returned.

space
C/C++ calling syntax
HRESULT GetAcceptType( BSTR
BSTR
StatusType
StatusType
CoverageType
DATE
DATE
BSTR
VARIANT_BOOL 		*pbstrJustification,
*pbstrAddendum,
*peStatusIn,
*peStatusOut,
*peCoverageType,
*pdCoverageBeginDate,
*pdCoverageEndDate,
*pbstrCoverageUnits,
*pbStatus);
Calling argument description
[out] BSTR *pbstrJustification An optional justification.
The justification is formulated in the data language returned by the GetResponse method
[out] BSTR *pbstrAddendum An optional addendum to the justification.
The addendum is formulated in the data language returned by the GetResponse method
[out] StatusType | *peStatusIn | The status of the credit request (given by the topmost object reference) before this response was generated
[out] StatusType | *peStatusOut | The status of the credit request (given by the topmost object reference) after this response was generated
[out] CoverageType *peCoverageType The principle type of coverage.

If none of the services have been modified in terms of cost and none are appended then there is a full coverage. In all other cases the coverage is limited.

[out] DATE | *pdCoverageBeginDate | The date when the coverage of the cost bearer begins
[out] DATE *pdCoverageEndDate The optional date when the coverage of the cost bearer ends.

If the end date is not defined then 0 is returned. This implicitly means that there is no upper date boundary for the coverage.

[out] BSTR *pbstrCoverageUnits The optional number/length and units of the covered treatment. This is the cost bearer's counterpart to the bstrTreatmentUnits

The coverage units (as well as the treatment units) are in fact context sensitive in their semantical meaning and therefore they are encoded by a string due to the variety of possibilities.

Coverage units for stationary treatment are e.g. "4 days" whereas for a physio therapy it could be "6 physio sessions" or "10 physio sessions - 1 per week"

[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


  • IGeneralCreditResponse
  • GetBasicInsurance

IGeneralCreditResponse::GetBasicInsurance method |  |  |
Retrieves the various identifiers (EAN, law type,...) and the structured address of the patient's basic insurance. The basic insurance is supplied for an outer-cantonal stationary treatment since a credit request for the cantonal surgon must be generated/sent besides one for the target insurance (given by the GetLaw method). VARIANT_FALSE is returned if the data are not defined. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetBasicInsurance( | LawType BSTR IAddress VARIANT_BOOL | *peLawType, *pbstrEAN, **ppIAddress, *pbStatus); |
Calling argument description |  |  |
[out] LawType | *peLawType | The type of basic insurance defined by the applicable type of law from the LawType enumeration. |
[out] BSTR | *pbstrEAN | EAN number of the basic insurance as supplied by medwin.ch |
[out] IAddress | **ppIAddress | The IAddress interface handle that allows to get the structured address data back. If no address is defined then the handle is NULL. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the data are not defined. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditResponse
  • GetCard

IGeneralCreditResponse::GetCard method |  |  |
Retrieves the patient's insurance card information (might be the patient card later on). VARIANT_FALSE is returned if the data are not defined. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetCard( | BSTR DATE DATE BSTR BSTR VARIANT_BOOL | *pbstrCardID, *pdExpiryDate, *pdValidationDate, *pbstrValidationID, *pbstrValidationServer, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrCardID | The mandatory unique 20 digits card identifier |
[out] DATE | *pdExpiryDate | The mandatory expiry date of the card |
[out] DATE | *pdValidationDate | The optional date of the last validation of the card's data |
[out] BSTR | *pbstrValidationID | The optional replied ID when the last validation of the card's data was performed |
[out] BSTR | *pbstrValidationServer | The optional server for the last validation process |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the data are undefined |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditResponse
  • GetContact

IGeneralCreditResponse::GetContact method |  |  |
Retrieves the EAN number and the structured address of the main contact. The structured address data is read via the methods of the returned IAddress interface. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetContact( | BSTR IAddress VARIANT_BOOL | *pbstrEAN, **ppIAddress, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrEAN | EAN number of the primary contact as supplied by medwin.ch |
[out] IAddress | **ppIAddress | The ppIAddress is an IAddress interface handle for the primary contact address. The interface handle allows to get the structured address data back. The address is either one of a person, a company, or an employee of an company. In the latter case the employee's full name is coded into the subaddress field. If no address is defined then the handle is NULL. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditResponse
  • GetCostBearer

IGeneralCreditResponse::GetCostBearer method |  |  |
Retrieves the various identifiers (EAN,...) and the structured address of the cost bearer of the credit request. The cost bearer might either be an insurance or a cantonal surgeon. The latter must be addressed in an outer-cantonal stationary treatment only. The IAddress interface might be NULL if no address was defined. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetCostBearer( | BSTR IAddress VARIANT_BOOL | *pbstrEAN, **ppIAddress, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrEAN | EAN number of the cost bearer as supplied by medwin.ch |
[out] IAddress | **ppIAddress | The IAddress interface handle that allows to get the structured address data back. If no address is defined then the handle is NULL. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditResponse
  • GetCredit

IGeneralCreditResponse::GetCredit method |  |  |
Retrieves the credit object reference parameters. The credit_ref (if supplied in the request), and credit object references form a object reference chain (credit_ref -> credit) with the credit as topmost object reference. The page "object reference" provides an in-depth description of the concepts of "object reference", "object reference chain", and "topmost object reference". |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetCredit( | CreditType BSTR DATE long YesNoType VARIANT_BOOL | *peCreditType, *pbstrRequestCreditID, *pdRequestCreditDate, *plRequestCreditTimestamp, *peIsCostEstimate, *pbStatus); |
Calling argument description |  |  |
[out] CreditType | *peCreditType | The type of credit that was generated. If the credit type is not "new" than a credit_ref object must be defined for the "older" reference object. |
[out] BSTR | *pbstrRequestCreditID | The request ID is the main software's identification of the credit ("Kostengutsprachenummer"). This is one of 3 identifiers that form the credit object reference. |
[out] DATE | *pdRequestCreditDate | The request date is the main software's date of the credit request ("Kostengutsprachedatum"). This is one of 3 identifiers that form the credit object reference. |
[out] long | *plRequestCreditTimestamp | This is a UNIX timestamp defined at the moment of the credit's infoset generation. This is one of 3 identifiers that form the credit object reference. |
[out] YesNoType | *peIsCostEstimate | Boolean value that defines the credit as "cost estimate" instead of "credit". From a semantical point of view cost estimates ("Kostenvoranschlag") and credits ("Kostengutsprache") are the same. It is more of a legal question as 'cost estimate' has a narrower cost interval than a credit. If you don't know what to set the check with then cost bearer. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditResponse
  • GetCreditRef

IGeneralCreditResponse::GetCreditRef method |  |  |
Retrieves the optional credit_ref object reference parameters. This object reference is only defined if the credit type (GetCredit@creditType) is 'prologation' or 're-considersation'. The credit_ref, and credit object references form a object reference chain (credit_ref -> credit) with the credit as topmost object reference. The page "object reference" provides an in-depth description of the concepts of "object reference", "object reference chain", and "topmost object reference". |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetCreditRef( | BSTR DATE long VARIANT_BOOL | *pbstrRequestCreditID, *pdRequestCreditDate, *plRequestCreditTimestamp, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrRequestCreditID | The request ID is the main software's identification of the credit ("Kostengutsprachenummer"). This is one of 3 identifiers that form the credit object reference. |
[out] DATE | *pdRequestCreditDate | The request date is the main software's date of the credit request ("Kostengutsprachedatum"). This is one of 3 identifiers that form the credit object reference. |
[out] long | *plRequestCreditTimestamp | This is a UNIX timestamp defined at the moment of the credit's infoset generation. This is one of 3 identifiers that form the credit object reference. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditResponse
  • GetEmployer

IGeneralCreditResponse::GetEmployer method |  |  |
Retrieves the various identifiers (EAN, Reg number,...) and the structured address of the employer of the patient. The IAddress interface might be NULL if no address was defined. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetEmployer( | BSTR BSTR IAddress VARIANT_BOOL | *pbstrEAN, *pbstrRegNumber, **ppIAddress, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrEAN | EAN number of the employer as supplied by medwin.ch |
[out] BSTR | *pbstrRegNumber | The employer's national BER number as defined by Swiss Federal Statistical Office |
[out] IAddress | **ppIAddress | The IAddress interface handle that allows to get the structured address data back. If no address is defined then the handle is NULL. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditResponse
  • GetFamilyDoctor

IGeneralCreditResponse::GetFamilyDoctor method |  |  |
Retrieves the various identifiers (EAN, ZSR,...) and the structured address of the patient's family doctor. The IAddress interface might be NULL if no address was defined. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetFamilyDoctor( | BSTR BSTR BSTR BSTR IAddress VARIANT_BOOL | *pbstrEAN, *pbstrZSR, *pbstrNIF, *pbstrSpecialty, **ppIAddress, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrEAN | EAN number of the family doctor as supplied by medwin.ch |
[out] BSTR | *pbstrZSR | ZSR number of the family doctor as supplied by santésuisse |
[out] BSTR | *pbstrNIF | The IV specific identification number NIF of the family doctor. |
[out] BSTR | *pbstrSpecialty | The specialty, i.e. FMH title of a physician. |
[out] IAddress | **ppIAddress | The IAddress interface handle that allows to get the structured address data back. If no address is defined then the handle is NULL. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditResponse
  • GetFirstDiagnosis

IGeneralCreditResponse::GetFirstDiagnosis method |  |  |
Retrieves the first diagnosis. VARIANT_FALSE is returned if the end of the diagnosis list is reached. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetFirstDiagnosis( | DiagnosisType BSTR BSTR SideType BSTR VARIANT_BOOL | *peDiagnosisType, *pbstrCode, *pbstrText, *peSideType, *pbstrRemark, *pbStatus); |
Calling argument description |  |  |
[out] DiagnosisType | *peDiagnosisType | The type of the diagnosis |
[out] BSTR | *pbstrCode | The code of the diagnosis as given in the corresponding diagnosis catalog defined by eDiagnosisType . |
[out] BSTR | *pbstrText | Textual description of the code as given in the corresponding diagnosis catalog defined by eDiagnosisType . |
[out] SideType | *peSideType | The side dependency of the diagnosis |
[out] BSTR | *pbstrRemark | An optional remark for the given diagnosis |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditResponse
  • GetFirstDocument

IGeneralCreditResponse::GetFirstDocument method |  |  |
Retrieves the first document sent by the cost bearer. VARIANT_FALSE is returned if the end of the document list is reached. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetFirstDocument( | YesNoType BSTR BSTR BSTR BSTR VARIANT_BOOL | *peIsURL, *pbstrSource, *pbstrFilename, *pbstrMimeType, *pbstrViewer, *pbStatus); |
Calling argument description |  |  |
[out] YesNoType | *peIsURL | Boolean that defines if the document is defined online using a URL (enYes) or inline as Base64 coded stream (enNo). |
[out] BSTR | *pbstrSource | If eIsURL = enYes then bstrSource is a URL for accessing the file online. If eIsURL = enNo then bstrSource is a full file name (path + name). |
[out] BSTR | *pbstrFilename | The name of the file (without path) in the local file system. |
[out] BSTR | *pbstrMimeType | The MIME type of the document. |
[out] BSTR | *pbstrViewer | The optional URL where a viewer for the file can be downloaded. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditResponse
  • GetFirstNotification

IGeneralCreditResponse::GetFirstNotification method |  |  |
Retrieves the first notification object. The notification is typed as message if the reponseType= enResponsePending or is typed as error if reponseType= enResponseRejected. The reponseType= enResponseAccepted has no notifications per definition. The responseType is returned in the GetResponse method. VARIANT_FALSE is returned if the end of the object list is reached. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetFirstNotification( | BSTR BSTR YesNoType long BSTR BSTR VARIANT_BOOL | *pbstrCode, *pbstrText, *peIsAnError, *plRecordID, *pbstrErrorValue, *pbstrValidValue, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrCode | A message or error code dependent on the notification type. Note that this code is defined by the "fromEAN" entity and is not standardized. |
[out] BSTR | *pbstrText | A message or error text dependent on the notification type. Note that this text is defined by the "fromEAN" entity and is not standardized. |
[out] YesNoType | *peIsAnError | A Boolean that defines if it is an error or a message. In the latter case bstrErrorValue and bstrValidValue are empty and lRecordID is set to 0. |
[out] long | *plRecordID | A record sequence number from the request uniquely identifying the target service record. If eIsAnError=enYes or the error is not related to a service record lRecordID is 0. |
[out] BSTR | *pbstrErrorValue | The erroneous/incorrect value if the notification is typed as error (eIsAnError=enYes) otherwise 0 |
[out] BSTR | *pbstrValidValue | The valid/correct value if the notification is typed as error (eIsAnError=enYes) otherwise 0 |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditResponse
  • GetFirstService

IGeneralCreditResponse::GetFirstService method |  |  |
Retrieves the first service record. This is an exact copy from the request supplemented by a response cost block (quantity, base amount, amount, remark). The response cost block is valid only for an accepted response whereas in the other cases it is undefined. VARIANT_FALSE is returned if the end of the service list is reached. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetFirstService( | BSTR BSTR BSTR double double double double BSTR double double double double BSTR VARIANT_BOOL | *pbstrTariffType, *pbstrCode, *pbstrText, *pdQuantityRequest, *pdBaseAmountRequest, *pdScaleFactorRequest, *pdAmountRequest, *pbstrRemarkRequest, *pdQuantityResponse, *pdBaseAmountResponse, *pdScaleFactorResponse, *pdAmountResponse, *pbstrRemarkResponse, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrTariffType | The official tariff type as defined by Forum Datenaustausch bstrTariffType might be empty if the service is not covered by a official tariff catalog |
[out] BSTR | *pbstrCode | The service code as given by the used tariff catalog. bstrCode might be empty if the service is not covered by an official tariff catalog. |
[out] BSTR | *pbstrText | The service name is the official service name as given by the used tariff catalog. If it is not a service in the narrow sense (not covered by an official tariff catalog) then it describes that service with best effort. |
[out] double | *pdQuantityRequest | The floating point quantity defined by the request cost block. Note that quantity changes the sign if the storno bit is set. |
[out] double | *pdBaseAmountRequest | The base amount is the cost in CHF of one unit (service) including any VAT portion defined by the request cost block. Note, that the base amount includes any VAT portion |
[out] double | *pdScaleFactorRequest | The applied scale factor for the given service defined by the request cost block. In principle the scale factor is used for defining discounts or surchages. However, it can be used as well for defining cost fractions e.g. in a DRG service. |
[out] double | *pdAmountRequest | The amount in CHF of the service supplied in 2-digit precision calculated as quantity*scale factor*base amount defined by the request cost block. Note, that the base amount includes any VAT portion, therefore amount does as well. Furthermore, note as well that amount changes the sign if the storno bit is set. |
[out] BSTR | *pbstrRemarkRequest | The optional remark for the given service defined by the request cost block. |
[out] double | *pdQuantityResponse | The floating point quantity defined by the response cost block. The quantity is valid for accepted responses only otherwise it is 0. Note that quantity changes the sign if a storno request is produced. |
[out] double | *pdBaseAmountResponse | The base amount is the cost in CHF of one unit (service) including any VAT portion defined by the response cost block. The base amount is valid for accepted responses only otherwise it is 0. Note, that the base amount includes any VAT portion |
[out] double | *pdScaleFactorResponse | The applied scale factor for the given service defined by the response cost block. In principle the scale factor is used for defining discounts or surchages. However, it can be used as well for defining cost fractions e.g. in a DRG service. |
[out] double | *pdAmountResponse | The amount in CHF of the service supplied in 2-digit precision calculated as quantity*scale factor*base amount defined by the response cost block. Note, that the base amount includes any VAT portion, therefore amount does as well. Furthermore, note as well that amount changes the sign if the storno bit is set. |
[out] BSTR | *pbstrRemarkResponse | The optional remark for the given service defined by the response cost block. The remark is valid for accepted responses only otherwise it is empty. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditResponse
  • GetGenerator

IGeneralCreditResponse::GetGenerator method |  |  |
Retrieves the identification parameters of the senders XML infoset generator software. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetGenerator( | BSTR long long BSTR VARIANT_BOOL | *pbstrSoftwarePackage, *plSoftwareVersion, *plSoftwareID, *pbstrSoftwareCopyright, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrSoftwarePackage | Name of the generator software that uses this DLL |
[out] long | *plSoftwareVersion | Version of the generator software codes as 32-bit value where lSoftwareVersion = 100*Major version + Minor version. |
[out] long | *plSoftwareID | Optional ID of the generator software that uses this DLL |
[out] BSTR | *pbstrSoftwareCopyright | The copyright notice of the developer of generator software. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditResponse
  • GetLaw

IGeneralCreditResponse::GetLaw method |  |  |
Retrieves the data about the applied and its dependent information |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetLaw( | LawType DATE BSTR BSTR BSTR VARIANT_BOOL | *peLawType, *pdCaseDate, *pbstrCaseID, *pbstrInsuredID, *pbstrContractNumber, *pbStatus); |
Calling argument description |  |  |
[out] LawType | *peLawType | The type of law to set from the LawType enumeration |
[out] DATE | *pdCaseDate | The case date of the insurance (e.g. date of accident in UVG) This date might undefined for certain laws and therefore left empty |
[out] BSTR | *pbstrCaseID | The case ID of the insurance (e.g. accident number in UVG) This ID might undefined for certain laws and therefore left empty |
[out] BSTR | *pbstrInsuredID | The patient's ID at the insurance This ID might undefined for certain laws and therefore left empty |
[out] BSTR | *pbstrContractNumber | Contract number if such a special contract exists between provider and insurance |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditResponse
  • GetNextDiagnosis

IGeneralCreditResponse::GetNextDiagnosis method |  |  |
Retrieves the next diagnosis. VARIANT_FALSE is returned if the end of the diagnosis list is reached. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetNextDiagnosis( | DiagnosisType BSTR BSTR SideType BSTR VARIANT_BOOL | *peDiagnosisType, *pbstrCode, *pbstrText, *peSideType, *pbstrRemark, *pbStatus); |
Calling argument description |  |  |
[out] DiagnosisType | *peDiagnosisType | The type of the diagnosis |
[out] BSTR | *pbstrCode | The code of the diagnosis as given in the corresponding diagnosis catalog defined by eDiagnosisType . |
[out] BSTR | *pbstrText | Textual description of the code as given in the corresponding diagnosis catalog defined by eDiagnosisType . |
[out] SideType | *peSideType | The side dependency of the diagnosis |
[out] BSTR | *pbstrRemark | An optional remark for the given diagnosis |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditResponse
  • GetNextDocument

IGeneralCreditResponse::GetNextDocument method |  |  |
Retrieves the next document sent by the cost bearer. VARIANT_FALSE is returned if the end of the document list is reached. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetNextDocument( | YesNoType BSTR BSTR BSTR BSTR VARIANT_BOOL | *peIsURL, *pbstrSource, *pbstrFilename, *pbstrMimeType, *pbstrViewer, *pbStatus); |
Calling argument description |  |  |
[out] YesNoType | *peIsURL | Boolean that defines if the document is defined online using a URL (enYes) or inline as Base64 coded stream (enNo). |
[out] BSTR | *pbstrSource | If eIsURL = enYes then bstrSource is a URL for accessing the file online. If eIsURL = enNo then bstrSource is a full file name (path + name). |
[out] BSTR | *pbstrFilename | The name of the file (without path) in the local file system. |
[out] BSTR | *pbstrMimeType | The MIME type of the document. |
[out] BSTR | *pbstrViewer | The optional URL where a viewer for the file can be downloaded. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditResponse
  • GetNextNotification

IGeneralCreditResponse::GetNextNotification method |  |  |
Retrieves the next notification object. The notification is typed as message if the reponseType= enResponsePending or is typed as error if reponseType= enResponseRejected. The reponseType= enResponseAccepted has no notifications per definition. The responseType is returned in the GetResponse method. VARIANT_FALSE is returned if the end of the object list is reached. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetNextNotification( | BSTR BSTR YesNoType long BSTR BSTR VARIANT_BOOL | *pbstrCode, *pbstrText, *peIsAnError, *plRecordID, *pbstrErrorValue, *pbstrValidValue, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrCode | A message or error code dependent on the notification type. Note that this code is defined by the "fromEAN" entity and is not standardized. |
[out] BSTR | *pbstrText | A message or error text dependent on the notification type. Note that this text is defined by the "fromEAN" entity and is not standardized. |
[out] YesNoType | *peIsAnError | A Boolean that defines if it is an error or a message. In the latter case bstrErrorValue and bstrValidValue are empty and lRecordID is set to 0. |
[out] long | *plRecordID | A record sequence number from the request uniquely identifying the target service record. If eIsAnError=enYes or the error is not related to a service record lRecordID is 0. |
[out] BSTR | *pbstrErrorValue | The erroneous/incorrect value if the notification is typed as error (eIsAnError=enYes) otherwise 0 |
[out] BSTR | *pbstrValidValue | The valid/correct value if the notification is typed as error (eIsAnError=enYes) otherwise 0 |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditResponse
  • GetNextService

IGeneralCreditResponse::GetNextService method |  |  |
Retrieves the next service record. This is an exact copy from the request supplemented by a response cost block (quantity, base amount, amount, remark). The response cost block is valid only for an accepted response whereas in the other cases it is undefined. VARIANT_FALSE is returned if the end of the service list is reached. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetNextService( | BSTR BSTR BSTR double double double double BSTR double double double double BSTR VARIANT_BOOL | *pbstrTariffType, *pbstrCode, *pbstrText, *pdQuantityRequest, *pdBaseAmountRequest, *pdScaleFactorRequest, *pdAmountRequest, *pbstrRemarkRequest, *pdQuantityResponse, *pdBaseAmountResponse, *pdScaleFactorResponse, *pdAmountResponse, *pbstrRemarkResponse, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrTariffType | The official tariff type as defined by Forum Datenaustausch bstrTariffType might be empty if the service is not covered by a official tariff catalog |
[out] BSTR | *pbstrCode | The service code as given by the used tariff catalog. bstrCode might be empty if the service is not covered by an official tariff catalog. |
[out] BSTR | *pbstrText | The service name is the official service name as given by the used tariff catalog. If it is not a service in the narrow sense (not covered by an official tariff catalog) then it describes that service with best effort. |
[out] double | *pdQuantityRequest | The floating point quantity defined by the request cost block. Note that quantity changes the sign if the storno bit is set. |
[out] double | *pdBaseAmountRequest | The base amount is the cost in CHF of one unit (service) including any VAT portion defined by the request cost block. Note, that the base amount includes any VAT portion |
[out] double | *pdScaleFactorRequest | The applied scale factor for the given service defined by the request cost block. In principle the scale factor is used for defining discounts or surchages. However, it can be used as well for defining cost fractions e.g. in a DRG service. |
[out] double | *pdAmountRequest | The amount in CHF of the service supplied in 2-digit precision calculated as quantity*scale factor*base amount defined by the request cost block. Note, that the base amount includes any VAT portion, therefore amount does as well. Furthermore, note as well that amount changes the sign if the storno bit is set. |
[out] BSTR | *pbstrRemarkRequest | The optional remark for the given service defined by the request cost block. |
[out] double | *pdQuantityResponse | The floating point quantity defined by the response cost block. The quantity is valid for accepted responses only otherwise it is 0. Note that quantity changes the sign if a storno request is produced. |
[out] double | *pdBaseAmountResponse | The base amount is the cost in CHF of one unit (service) including any VAT portion defined by the response cost block. The base amount is valid for accepted responses only otherwise it is 0. Note, that the base amount includes any VAT portion |
[out] double | *pdScaleFactorResponse | The applied scale factor for the given service defined by the response cost block. In principle the scale factor is used for defining discounts or surchages. However, it can be used as well for defining cost fractions e.g. in a DRG service. |
[out] double | *pdAmountResponse | The amount in CHF of the service supplied in 2-digit precision calculated as quantity*scale factor*base amount defined by the response cost block. Note, that the base amount includes any VAT portion, therefore amount does as well. Furthermore, note as well that amount changes the sign if the storno bit is set. |
[out] BSTR | *pbstrRemarkResponse | The optional remark for the given service defined by the response cost block. The remark is valid for accepted responses only otherwise it is empty. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditResponse
  • GetOuterCantonal

IGeneralCreditResponse::GetOuterCantonal method |  |  |
Retrieves the "outer cantonal" input data. The "outer cantonal" data is defined only for a stationary treatment where the patient's tax canton differs from the treatment canton. VARIANT_FALSE is returned if the data are not defined. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetOuterCantonal( | CantonType BSTR BSTR DATE DATE VARIANT_BOOL | *peTaxCanton, *pbstrTaxCity, *pbstrEmergencyCity, *pdEmergencyDate, *pdRetransferDate, *pbStatus); |
Calling argument description |  |  |
[out] CantonType | *peTaxCanton | The tax canton given by the CantonType enumeration |
[out] BSTR | *pbstrTaxCity | The city where the patient is living and paying taxes. |
[out] BSTR | *pbstrEmergencyCity | If an emergency (GetStationary@eHospitalizationType = enEmergency) is the type/reason for the hospitalization then bstrEmergencyCity defines where the emergency happened. If the location is unknown or if it is not an emergency an empty string is returned. |
[out] DATE | *pdEmergencyDate | If an emergency (GetStationary@eHospitalizationType = enEmergency) is the type/reason for the hospitalization then dEmergencyDate defines the date and time of the emergency. If this date is unknown or it is not an emergency than 0 is returned as date. |
[out] DATE | *pdRetransferDate | If an emergency (GetStationary@eHospitalizationType = enEmergency) is the type/reason for the hospitalization then dRetransferDate is the date of the earliest transfer to a hospital of the tax canton. If this date is unknown or it is not an emergency than 0 is returned as date. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. VARIANT_FALSE is returned if the outer cantonal data is undefined. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditResponse
  • GetPackage

IGeneralCreditResponse::GetPackage method
Retrieves the identification parameters of the senders main software.

Since the package information is optionally VARIANT_FALSE is returned if the senders main software is undefined.

If the data stem from loading a lower version XML file, then a compatibility error is issued! If full support is needed for a lower version then there is no resort than using the native COM versions directly.

space
C/C++ calling syntax
HRESULT GetPackage( BSTR
long
long
BSTR
VARIANT_BOOL 		*pbstrSoftwarePackage,
*plSoftwareVersion,
*plSoftwareID,
*pbstrSoftwareCopyright,
*pbStatus);
Calling argument description
[out] BSTR | *pbstrSoftwarePackage | Name of the main software that uses this DLL
[out] long | *plSoftwareVersion | Version of the main software codes as 32-bit value where lSoftwareVersion = 100*Major version + Minor version.
[out] long | *plSoftwareID | Optional ID of the main software that uses this DLL
[out] BSTR | *pbstrSoftwareCopyright | The copyright notice of the developer of the main software.
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then no package data is available
C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


  • IGeneralCreditResponse
  • GetPatient

IGeneralCreditResponse::GetPatient method
Retrieves the primary parameters and structured address of the patient.

The address is defined via a IAddress interface pointer and the address data must be defined prior to call this method.

space
C/C++ calling syntax
HRESULT GetPatient( SexType
DATE
BSTR
IAddress
VARIANT_BOOL 		*peSexType,
*pdBirthdate,
*pbstrSSN,
**ppIAddress,
*pbStatus);
Calling argument description
[out] SexType | *peSexType | The patient's gender.
[out] DATE | *pdBirthdate | The patient's birthdate.
[out] BSTR *pbstrSSN The social security number (SSN) of the patient in its printed form whereupon 3 distinguished form are possible:
  • the old 11 digit Swiss SSN ("AHV-Nummer") as defined by Federal Social Insurance Office
  • the new 13 digit Swiss SSN ("SV-Nummer") beginning with 756 as defined by Federal Social Insurance Office
  • the new 4-10 digit SSN of Liechtenstein ("AHV-Nummer") as defined by Liechtensteinische AHV-IV-FAK
[out] IAddress **ppIAddress The IAddress interface handle that allows to get the structured address data back.
If no address is defined then the handle is NULL.
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


  • IGeneralCreditResponse
  • GetPendingType

IGeneralCreditResponse::GetPendingType method |  |  |
This method is called if the main response type returned by the GetResponse method is enResponsePending. Calling the iterator pair GetFirstNotification / GetNextNotification is only necessary if eHasMessage=enYes. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetPendingType( | BSTR StatusType StatusType YesNoType VARIANT_BOOL | *pbstrJustification, *peStatusIn, *peStatusOut, *peHasMessage, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrJustification | An optional justification. The justification is formulated in the data language returned by the GetResponse method |
[out] StatusType | *peStatusIn | The status of the credit request (given by the topmost object reference) before this response was generated |
[out] StatusType | *peStatusOut | The status of the credit request (given by the topmost object reference) after this response was generated |
[out] YesNoType | *peHasMessage | A Boolean that defines if messages are available in which case the iterator pair GetFirstNotification / GetNextNotification should be called. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditResponse
  • GetProvider

IGeneralCreditResponse::GetProvider method |  |  |
Retrieves the various identifiers (EAN, ZSR,...) and the structured address of the main provider. The IAddress interface might be NULL if no address was defined. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetProvider( | BSTR BSTR BSTR BSTR IAddress VARIANT_BOOL | *pbstrEAN, *pbstrZSR, *pbstrNIF, *pbstrSpecialty, **ppIAddress, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrEAN | EAN number of the provider as supplied by medwin.ch |
[out] BSTR | *pbstrZSR | ZSR number of the provider as supplied by santésuisse |
[out] BSTR | *pbstrNIF | The IV specific identification number NIF of the provider. |
[out] BSTR | *pbstrSpecialty | The specialty, i.e. FMH title of a physician. |
[out] IAddress | **ppIAddress | The IAddress interface handle that allows to get the structured address data back. If no address is defined then the handle is NULL. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditResponse
  • GetReferrer

IGeneralCreditResponse::GetReferrer method |  |  |
Retrieves the various identifiers (EAN, ZSR,...) and the structured address of the referrer. The IAddress interface might be NULL if no address was defined. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetReferrer( | BSTR BSTR BSTR BSTR IAddress VARIANT_BOOL | *pbstrEAN, *pbstrZSR, *pbstrNIF, *pbstrSpecialty, **ppIAddress, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrEAN | EAN number of the referrer as supplied by medwin.ch |
[out] BSTR | *pbstrZSR | ZSR number of the referrer as supplied by santésuisse |
[out] BSTR | *pbstrNIF | The IV specific identification number NIF of the referrer. |
[out] BSTR | *pbstrSpecialty | The specialty, i.e. FMH title of a physician. |
[out] IAddress | **ppIAddress | The IAddress interface handle that allows to get the structured address data back. If no address is defined then the handle is NULL. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditResponse
  • GetRejectType

IGeneralCreditResponse::GetRejectType method |  |  |
This method is called if the main response type returned by the GetResponse method is enResponseRejected. Calling the iterator pair GetFirstNotification / GetNextNotification is only necessary if eHasError=enYes. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetRejectType( | BSTR StatusType StatusType YesNoType VARIANT_BOOL | *pbstrJustification, *peStatusIn, *peStatusOut, *peHasError, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrJustification | An optional justification. The justification is formulated in the data language returned by the GetResponse method |
[out] StatusType | *peStatusIn | The status of the credit request (given by the topmost object reference) before this response was generated |
[out] StatusType | *peStatusOut | The status of the credit request (given by the topmost object reference) after this response was generated |
[out] YesNoType | *peHasError | A Boolean that defines if errors are available in which case the iterator pair GetFirstNotification / GetNextNotification should be called. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditResponse
  • GetRequestor

IGeneralCreditResponse::GetRequestor method |  |  |
Retrieves the various identifiers (EAN, ZSR,...) and the structured address of the requestor of the credit. The IAddress interface might be NULL if no address was defined. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetRequestor( | BSTR BSTR BSTR BSTR IAddress VARIANT_BOOL | *pbstrEAN, *pbstrZSR, *pbstrNIF, *pbstrSpecialty, **ppIAddress, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrEAN | EAN number of the requestor as supplied by medwin.ch |
[out] BSTR | *pbstrZSR | ZSR number of the requestor as supplied by santésuisse |
[out] BSTR | *pbstrNIF | The IV specific identification number NIF of the requestor. |
[out] BSTR | *pbstrSpecialty | The specialty, i.e. FMH title of a physician. |
[out] IAddress | **ppIAddress | The IAddress interface handle that allows to get the structured address data back. If no address is defined then the handle is NULL. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditResponse
  • GetResponse

IGeneralCreditResponse::GetResponse method
Returns the primary parameters of the response infoset, namely the operation modus, the language the infoset is formulated, and most important the type of the response.

Based on the response type one of the following methods should be called:

GetAcceptType | Per definition this means that the corresponding request is accepted and will be processed to a final stage. The coverage data and the optional justification and addendum are supplied but no messages.
GetPendingType | Per definition this means that the corresponding request can not be processed to a final stage as some data are missing. An optional justification and addendum and [0,n] messages (instructions) are supplied to "unfreeze" the request.
GetRejectType | Per definition this means that the corresponding request is rejected and as a consequence the status of the request goes to the "canceled" state. An optional justification and addendum and [0,n] errors are supplied to justify the decision.
 space
C/C++ calling syntax
HRESULT GetResponse( LanguageType
RoleType
PlaceType
BSTR
YesNoType
YesNoType
ResponseType
ModusType
VARIANT_BOOL 		*peDataLanguage,
*peRoleType,
*pePlaceType,
*pbstrRoleTitle,
*peIsStorno,
*peIsCopy,
*peResponseType,
*peModusType,
*pbStatus);
Calling argument description
[out] LanguageType *peDataLanguage The language in which the response is formulated.

Note, that the data language and the module language (given by IGeneralCreditResponseManager::SetModuleLanguage) are independent and can be different!

[out] RoleType *peRoleType Defines the role categories that the main provider is best categorized.

If the main provider has an other role than defined then use enRoleOther and additionally supply a role title with a description of the role

[out] PlaceType | *pePlaceType | Defines the principle place where the main provider is applying the treatment
[out] BSTR *pbstrRoleTitle Optional role title/description of the main provider.

If a suitable predefined role can not be set then bstrRoleTitle is mandatory (use enRoleOther as role in that case)

[out] YesNoType *peIsStorno Boolean value that defines the "storno" status of the sent request.

Note that this is the initial value of the request mirrored in the response

[out] YesNoType *peIsCopy Boolean value that defines the "copy" status of the sent request.

Note that this is the initial value of the request mirrored in the response

[out] ResponseType | *peResponseType | The main response type.
[out] ModusType *peModusType The operation modus.

The default modus is enProduction whereas for developing/debugging purposes enTest has to be set.

[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


  • IGeneralCreditResponse
  • GetStationary

IGeneralCreditResponse::GetStationary method |  |  |
Retrieves the additional stationary treatment data if such a stationary treatment is defined. VARIANT_FALSE is returned if the data are not defined. In reverse this means that the case is an ambulatory case |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetStationary( | HospitalizationType HospitalizationMode InsuranceClass InsuranceModel BSTR VARIANT_BOOL | *peHospitalizationType, *peHospitalizationMode, *peInsuranceClass, *peInsuranceModel, *pbstrSectionMajor, *pbStatus); |
Calling argument description |  |  |
[out] HospitalizationType | *peHospitalizationType | The type/reason of hospitalization given by the HospitalizationType enumeration |
[out] HospitalizationMode | *peHospitalizationMode | The mode/indication of hospitalization given by the HospitalizationMode enumeration |
[out] InsuranceClass | *peInsuranceClass | The insurance class given by the InsuranceClass enumeration |
[out] InsuranceModel | *peInsuranceModel | The insurance model given by the InsuranceModel enumeration. The insurance model is a possible refinement of the supplied insurance class. |
[out] BSTR | *pbstrSectionMajor | The major BfS section code as defined by Swiss Federal Statistical Office |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditResponse
  • GetSubstantiation

IGeneralCreditResponse::GetSubstantiation method |  |  |
Retrieves the substantiation (motives and reasons) for the treatment. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetSubstantiation( | BSTR BSTR VARIANT_BOOL | *pbstrMeasures, *pbstrRemark, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrMeasures | The intended measures for the treatment |
[out] BSTR | *pbstrRemark | An optional remark regarding the treatment |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditResponse
  • GetSurgeon

IGeneralCreditResponse::GetSurgeon method |  |  |
Retrieves the various identifiers (EAN, ZSR,...) and the structured address of the surgeon. Of course, the surgeon's address is set only if it is a stationary treatment with surgery and if known. The IAddress interface might be NULL if no address was defined. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetSurgeon( | BSTR BSTR BSTR BSTR IAddress VARIANT_BOOL | *pbstrEAN, *pbstrZSR, *pbstrNIF, *pbstrSpecialty, **ppIAddress, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrEAN | EAN number of the surgeon as supplied by medwin.ch |
[out] BSTR | *pbstrZSR | ZSR number of the surgeon as supplied by santésuisse |
[out] BSTR | *pbstrNIF | The IV specific identification number NIF of the surgeon. |
[out] BSTR | *pbstrSpecialty | The specialty, i.e. FMH title of a physician. |
[out] IAddress | **ppIAddress | The IAddress interface handle that allows to get the structured address data back. If no address is defined then the handle is NULL. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditResponse
  • GetTransport

IGeneralCreditResponse::GetTransport method |  |  |
Returns the transport information that defines the routing of the infoset. In fact the meaning and the data is mirrored from the corresponding request thus the initial sender becomes the recipient and the initial recipient becomes the sender. Furthermore the chain of intermediates from the request is reversed and the infoset is sent to the first intermediate of the reversed list. The given intermediate here is therefore the last one before reaching the receiver. All the involved parties are defined by EAN numbers as defined by www.medwin.ch. If the data stem from loading a lower version XML file, then a compatibility error is issued! If full support is needed for a lower version then there is not resort than using the native COM versions directly. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetTransport( | BSTR BSTR BSTR BSTR VARIANT_BOOL | *pbstrFromEAN, *pbstrViaEAN, *pbstrToEAN, *pbstrToBinDERFile, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrFromEAN | The EAN number of the sender as supplied by medwin.ch Note that this is the initial receiver of the request since the transport information from the request is mirrored in the response |
[out] BSTR | *pbstrViaEAN | The EAN number of the last intermediate as supplied by medwin.ch Note that this is the initial (first) intermediate of the request since the transport information from the request is mirrored in the response |
[out] BSTR | *pbstrToEAN | The EAN number of the receiver as supplied by medwin.ch Note that this is the initial sender of the request since the transport information from the request is mirrored in the response |
[out] BSTR | *pbstrToBinDERFile | If the XML infoset was signed then bstrToBinDERFile is a full file name (path + name) to the extracted binary DER certificate that is the public certificate of the "from" entity. The certificate file named X509DER_FromEAN.cer must be copied to a save place since the used temporary directory is emptied when the module shuts down. Note that this certificate can be used to encrypt a request XML infoset for the "from" entity. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditResponse
  • GetTreatment

IGeneralCreditResponse::GetTreatment method
Retrieves the primary treatment input data. | space
C/C++ calling syntax
HRESULT GetTreatment( DATE
BSTR
CantonType
TreatmentReasonType
BSTR
BSTR
VARIANT_BOOL 		*pdDateBegin,
*pbstrTreatmentUnits,
*peTreatmentCanton,
*peTreatmentReason,
*pbstrPatientID,
*pbstrCaseID,
*pbStatus);
Calling argument description
[out] DATE | *pdDateBegin | dDateBegin is the (intended) start of the treatment
[out] BSTR *pbstrTreatmentUnits The optional number/length and units of the suggested treatment.

The treatment units are in fact context sensitive in their semantical meaning and therefore they are encoded by a string
due to the variety of possibilities.

Treatment units for stationary treatment are e.g. "4 days" whereas for a physio therapy it could be "6 physio sessions" or
"10 physio sessions - 1 per week"

[out] CantonType | *peTreatmentCanton | The treatment canton given by the CantonType enumeration
[out] TreatmentReasonType | *peTreatmentReason | The treatment reason given by the TreatmentReasonType enumeration
[out] BSTR | *pbstrPatientID | This is an optional patient identification of the main software ("Patientennummer").
[out] BSTR | *pbstrCaseID | This is an optional case identification of the main software ("Fallnummer"). In fact it is an ID used in the main software to identify this request and probably it is the same as the request credit ID (GetCredit@bstrRequestCreditID).
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


  • IGeneralCreditResponseManager

IGeneralCreditResponseManager interface |  | V4.30/ 3 Feb 2011
The IGeneralCreditResponseManager provides methods to load and analyze XML infosets of type generalCreditResponse_430. These infosets are responses to a previously sent credit request where the topmost object reference defines target request. The subchapter object reference provides an in-depth description of the concept of "object reference". |  | space
Methods |  | 8 methods
GetAbortInfo | Get the abort information string with the error coded in the module language |
GetLogSettings | Get the log settings for the module. |
GetXMLInfo | Preloads and analyzes a XML infoset regarding the accepted schema and other important information |
LoadXML | Loads a received XML infoset of type generalCreditResponse_430.xsd into memory for further processing via the returned interface handle |
Print | The Print method prints the response on the local printer or displays the response as a preview |
PrintAdjust | Shows the print object adjustment dialog that allows to move print objects of a .vps report generator file. |
PrintSetup | Shows the printer setup dialog that allows to define printer settings connected with a .vps report generator file. |
SetLogSettings | Set the log settings for the module |
Properties |  | 4 properties
[get/put] ModuleLanguage | Get/Set the language for the module i.e |
[get] ModuleVersion | Gets the version of the GeneralCreditResponseManager module. |
[get] ModuleVersionText | Get the textual version of the GeneralCreditResponseManager module. |
[get/put] PrintCopies | Get/Set the number of copies to print. |


  • IGeneralCreditResponseManager
  • GetAbortInfo

IGeneralCreditResponseManager::GetAbortInfo method |  |  |
Get the abort information string with the error coded in the module language. Call this method whenever the returned pbStatus variable of the primarily called method is VARIANT_FALSE and the primarily called method is not an iterator (GetFirst/GetNext). In the later case VARIANT_FALSE signals the end of data. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetAbortInfo( | BSTR VARIANT_BOOL | *pbstrAbort, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrAbort | Abort information string coded in the module language. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditResponseManager
  • GetLogSettings

IGeneralCreditResponseManager::GetLogSettings method
Get the log settings for the module. | space
C/C++ calling syntax
HRESULT GetLogSettings( long
long
YesNoType
BSTR
VARIANT_BOOL 		*plLogLevel,
*plMaxSizeKB,
*peDoArchive,
*pbstrArchiveDir,
*pbStatus);
Calling argument description
[out] long | *plLogLevel | eDoArchive defines if the log file is recycled if the maximum size is reached (enNo) or if the log file is archived (enYes).
[out] long *plMaxSizeKB The log activity level where
lLogLevel = 0 | Logging is turned off
lLogLevel = 1 | Normal log activity
lLogLevel > 1 | Debug log activity. Use this level only for debugging purposes
[out] YesNoType | *peDoArchive | The base directory where log files are archived. bstrArchiveDir is only defined if eDoArchive=enYes otherwise bstrArchiveDir is empty.
[out] BSTR | *pbstrArchiveDir | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


  • IGeneralCreditResponseManager
  • GetXMLInfo

IGeneralCreditResponseManager::GetXMLInfo method
Preloads and analyzes a XML infoset regarding the accepted schema and other important information.

If the XML infoset is of an accepted type then the fromEAN, toEAN as well as the encryption status are additionally extracted. The accepted XML type is

  • generalCreditResponse_430.xsd
The XSD name is set even if an error is generated.

This method should be called before calling the full XML loader LoadXML since the infoset is possibly encrypted. In this situation the corresponding PFX certificate and password must be supplied in the XML loader.

space
C/C++ calling syntax
HRESULT GetXMLInfo( BSTR
BSTR
BSTR
BSTR
YesNoType
VARIANT_BOOL 		bstrInputFile,
*pbstrUsedSchema,
*pbstrFromEAN,
*pbstrToEAN,
*peIsEncrypted,
*pbStatus);
Calling argument description
[in] BSTR | bstrInputFile | The full file name (path + name) of a XML infoset of type generalCreditResponse_430.xsd.
[out] BSTR | *pbstrUsedSchema | The full XSD name of the loaded XML file.
[out] BSTR *pbstrFromEAN The EAN number of the sender as supplied by medwin.ch
Note that this is the initial receiver of the request since the transport information from the request is mirrored in the response
[out] BSTR *pbstrToEAN The EAN number of the receiver as supplied by medwin.ch
Note that this is the initial sender of the request since the transport information from the request is mirrored in the response
[out] YesNoType *peIsEncrypted A Boolean that defines if the XML infoset is encrypted.

If true the private PFX certificate/password of the "toEAN" entity must be given in the LoadXML method otherwise the infoset can not be decrypted.

[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


  • IGeneralCreditResponseManager
  • LoadXML

IGeneralCreditResponseManager::LoadXML method |  |  |
Loads a received XML infoset of type generalCreditResponse_430.xsd into memory for further processing via the returned interface handle. Since the infoset is possibly encrypted, call GetXMLInfo to decide if and which PFX certificate to supply. |  |  | space
C/C++ calling syntax |  |  |
HRESULT LoadXML( | BSTR BSTR BSTR IGeneralCreditResponse VARIANT_BOOL | bstrInputFile, bstrToPFXFile, bstrToPFXPassword, **ppIGeneralCreditResponse, *pbStatus); |
Calling argument description |  |  |
[in] BSTR | bstrInputFile | The full file name (path + name) of a XML infoset of type generalCreditResponse_430.xsd. |
[in] BSTR | bstrToPFXFile | The file name of the PFX certificate that is the private certificate of the "toEAN" entity. This variable is not used if the XML infoset is not encrypted. |
[in] BSTR | bstrToPFXPassword | The password to open the PFX certificate. This variable is not used if the XML infoset is not encrypted. |
[out] IGeneralCreditResponse | **ppIGeneralCreditResponse | The IGeneralCreditResponse interface handle that allows to get all loaded data back. The handle is NULL if an error occurred. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralCreditResponseManager
  • Print

IGeneralCreditResponseManager::Print method
The Print method prints the response on the local printer or displays the response as a preview. The printer selection is done via the used report generator template file. If the template file was not connected to a printer with the PrintSetup method then the default printer with its default settings is used.

The bstrPrintTemplate variable obeys a special syntax and can optionally be used to set special print commands like producing PDFs or changing print objects dynamically.
IMPORTANT LICENSE NOTE The report engine used is Hexatech's ViewPro (www.hexatech.com). If you supply your own template files then you must have your own ViewPro license. By using this COM module you implicitly agree upon this restriction!!

space
C/C++ calling syntax
HRESULT Print( BSTR
YesNoType
VARIANT_BOOL 		bstrPrintTemplate,
ePrintPreview,
*pbStatus);
Calling argument description
[in] BSTR bstrPrintTemplate bstrPrintTemplate is either empty or of the general form given below.

If the bstrPrintTemplate variable is empty then the default print template (using the data language as language switch - see below) is used.
However, bstrPrintTemplate can be used to change the normal printing behavior or changing printing objects dynamically.
The following syntax is used as content of the bstrPrintTemplate variable:

[logTpl][(objectName1=text;...)][=printTemplateFile][#INIPATH=inipath]

where a [] pair defines an optional part. The commands are case insensitive.
  • logTpl: is the logical template name where just one template name is defined: detail.
  • objectName1=text; does a substitution of the content of the print object objectName1 by the given text. A print object is terminated by a semicolon and all
    print objects together are enclosed in a () pair.

    There is a predefined pseudo print object with a special meaning:

    • PDF for generating PDF files

  • printTemplateFile is an external print template file name (full path + name!). If an external print template is supplied it must be mapped
    against a logical template. Therefore detail=full_vps_file must be used!
  • #INIPATH=inipath defines a fully qualified path to a directory where the report engine searches the corresponding .vpd
    print template INI file. This allows for global settings of a print template in a LAN. The default inipath is the install directory
    of the Dll
[in] YesNoType | ePrintPreview | A Boolean that defines if print preview is used (enYes) or printing is done (enNo)
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


  • IGeneralCreditResponseManager
  • PrintAdjust

IGeneralCreditResponseManager::PrintAdjust method
Shows the print object adjustment dialog that allows to move print objects of a .vps report generator file. | space
C/C++ calling syntax
HRESULT PrintAdjust( BSTR
BSTR
VARIANT_BOOL 		bstrPrintTemplate,
bstrINIPath,
*pbStatus);
Calling argument description
[in] BSTR bstrPrintTemplate Either the full file name (path + name) or a logical name of a target .vps report generator file for which the settings will be defined.

There are predefined .vps files in the installation directory that can be accessed via the following case insensitive logical name:

Detail_typeaddress_side_language

where
  • type is the type of form to use with G ist for the general (ambulatory) case and S is for the stationary case.
  • address_side is R for right sided addressing or L for left sided addressing of the recipient.
    This is currently fixed to R for all forms
  • language is one of {dt, fr, it}.
For example the logical name "Detail_SR_fr" is the French print template with right sided addressing for a stationary case.
[in] BSTR bstrINIPath Optional path to a directory where the .vpd printer setting file is stored. The name of the printer setting file is the same name as the .vps file but with a .vpd extension.

If bstrINIPath is left empty then the standard directory (the directory of the dll) is used.

[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


  • IGeneralCreditResponseManager
  • PrintSetup

IGeneralCreditResponseManager::PrintSetup method
Shows the printer setup dialog that allows to define printer settings connected with a .vps report generator file. | space
C/C++ calling syntax
HRESULT PrintSetup( BSTR
BSTR
VARIANT_BOOL 		bstrPrintTemplate,
bstrINIPath,
*pbStatus);
Calling argument description
[in] BSTR bstrPrintTemplate Either the full file name (path + name) or a logical name of a target .vps report generator file for which the settings will be defined.

There are predefined .vps files in the installation directory that can be accessed via the following case insensitive logical name:

Detail_typeaddress_side_language

where
  • type is the type of form to use with G ist for the general (ambulatory) case and S is for the stationary case.
  • address_side is R for right sided addressing or L for left sided addressing of the recipient.
    This is currently fixed to R for all forms
  • language is one of {dt, fr, it}.
For example the logical name "Detail_SR_fr" is the French print template with right sided addressing for a stationary case.
[in] BSTR bstrINIPath Optional path to a directory where the .vpd printer setting file is stored. The name of the printer setting file is the same name as the .vps file but with a .vpd extension.

If bstrINIPath is left empty then the standard directory (the directory of the dll) is used.

[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


  • IGeneralCreditResponseManager
  • SetLogSettings

IGeneralCreditResponseManager::SetLogSettings method
Set the log settings for the module.

The defaults for the log activity are: level=1, lMaxSizeKB=1000,eDoArchive=enNo,
and the log settings are persistent via the log file itself.

Note, that the log facility is a best effort system. If there is an error e.g. due to insufficient privileges to write the log entries then nothing is logged.

space
C/C++ calling syntax
HRESULT SetLogSettings( long
long
YesNoType
BSTR
VARIANT_BOOL 		lLogLevel,
lMaxSizeKB,
eDoArchive,
bstrArchiveDir,
*pbStatus);
Calling argument description
[in] long lLogLevel The log activity level where
lLogLevel = 0 | Logging is turned off
lLogLevel = 1 | Normal log activity
lLogLevel > 1 | Debug log activity. Use this level only for debugging purposes

Any log level below 0 is corrected to 0.

[in] long lMaxSizeKB The maximum size in KB of the log file.
Any size below 1000 KB (= the default value) is corrected to the default value
[in] YesNoType | eDoArchive | eDoArchive defines if the log file is recycled once the maximum size is reached (enNo) or if the log file is archived (enYes) into the archive directory.
[in] BSTR bstrArchiveDir Defines the base directory where log files are archived. bstrArchiveDir is only used if eDoArchive=enYes. If bstrArchiveDir is empty and eDoArchive=enYes then the place of the module is used as the base archive directory.

If the base archive directory or directories below have insufficient privileges to create directories or write files archiving is not done!

[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


  • IGeneralCreditResponseManager
  • ModuleLanguage

IGeneralCreditResponseManager::ModuleLanguage property
Get/Set the language for the module i.e. the language in which the error strings are coded.

Note, that the module language and the data language (given by IGeneralCreditResponse::GetResponse) are independent and can be different!

space
C/C++ calling syntax
[get] HRESULT | ModuleLanguage( LanguageType *aLanguageType);
[put] HRESULT | ModuleLanguage( LanguageType aLanguageType);
space
Calling argument description
[out,retval] LanguageType | *aLanguageType
[in] LanguageType | aLanguageType
C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • LanguageType *GetModuleLanguage(void);
  • void PutModuleLanguage( LanguageType aLanguageType);
space


  • IGeneralCreditResponseManager
  • ModuleVersion

IGeneralCreditResponseManager::ModuleVersion property
Gets the version of the GeneralCreditResponseManager module. | space
C/C++ calling syntax
[get] HRESULT | ModuleVersion( BSTR *aBSTR);
space
Calling argument description
[out, retval] BSTR | *aBSTR
C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetModuleVersion(void);
space


  • IGeneralCreditResponseManager
  • ModuleVersionText

IGeneralCreditResponseManager::ModuleVersionText property
Get the textual version of the GeneralCreditResponseManager module. | space
C/C++ calling syntax
[get] HRESULT | ModuleVersionText( BSTR *aBSTR);
space
Calling argument description
[out, retval] BSTR | *aBSTR
C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetModuleVersionText(void);
space


  • IGeneralCreditResponseManager
  • PrintCopies

IGeneralCreditResponseManager::PrintCopies property
Get/Set the number of copies to print. | space
C/C++ calling syntax
[get] HRESULT | PrintCopies( long *along);
[put] HRESULT | PrintCopies( long along);
space
Calling argument description
[out,retval] long | *along
[in] long | along
C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • long *GetPrintCopies(void);
  • void PutPrintCopies( long along);
space


  • Type definitions

Builtin, composite & enumeration types |  | V4.30/ 3 Feb 2011
The following list shows ans defines all used data types either basic builtin, composite or enumeration types that are used in the interface of the ATL COM module. |  | space
Data types |  | 28 types
[enumeration] AddressType | Enumerates the defined address categories. |
[builtin] BSTR | A BSTR, known as basic string or binary string, is a pointer to a wide character string used by Automation data manipulation functions |
[enumeration] CantonType | Enumerates the defined Swiss cantons or countries close to the border. |
[enumeration] CoverageType | Enumerates the defined types of coverage. |
[enumeration] CreditType | Enumerates the defined types of credits |
[builtin] DATE | A value denoting a date and time was specified |
[enumeration] DiagnosisType | Enumerates the defined diagnosis coding systems. |
[builtin] double | An 8-byte IEEE real value. |
[enumeration] HospitalizationMode | Enumerates the defined modes/indications of the hospitalization |
[enumeration] HospitalizationType | Enumerates the defined types/reasons of the hospitalization |
[builtin] HRESULT | The HRESULT data type is a 32-bit value that is used to describe an error or warning. |
[builtin] IAddress | IAddress interface. |
[builtin] IGeneralCreditResponse | IGeneralCreditResponse interface |
[enumeration] InsuranceClass | Enumerates the defined insurance classes |
[enumeration] InsuranceModel | The insurance model is a possible refinement of the insurance class |
[enumeration] LanguageType | Enumerates all supported languages. |
[enumeration] LawType | Enumerates the supported legal law set |
[builtin] long | A 4-byte integer value. |
[enumeration] ModusType | Enumerates the defined operation modus types |
[enumeration] PlaceType | Enumerates the defined places where the main provider is located |
[enumeration] ResponseType | Enumerates the defined response types. |
[enumeration] RoleType | Enumerates the defined role categories that the main provider is best categorized |
[enumeration] SexType | Enumerates the defined gender categories. |
[enumeration] SideType | Enumerates the defined side categories. |
[enumeration] StatusType | Enumerates the defined status types that request object can posses |
[enumeration] TreatmentReasonType | Enumerates the defined treatment reasons. |
[builtin] VARIANT_BOOL | Enumerates defined types of XML generation attributes |
[enumeration] YesNoType | Boolean enumerator. |


  • Type definitions
  • AddressType

AddressType enumeration type |  |
Enumerates the defined address categories. |  | space
Set of enumeration values |  | 3 elements
enAddressUndefined: 0 | Undefined or unknown address. |
enAddressPerson: 1 | Person address. |
enAddressCompany: 2 | Company address. |


  • Type definitions
  • BSTR

BSTR type |
A BSTR, known as basic string or binary string, is a pointer to a wide character string used by Automation data manipulation functions. BSTRs are wide, double-byte (Unicode) strings on 32-bit Windows platforms. | space


  • Type definitions
  • CantonType

CantonType enumeration type |  |
Enumerates the defined Swiss cantons or countries close to the border. |  | space
Set of enumeration values |  | 32 elements
enCantonUndefined: 0 | Undefined or unknown canton. |
enAG: 1 | The Swiss canton is AG |
enAI: 2 | The Swiss canton is AI |
enAR: 3 | The Swiss canton is AR |
enBE: 4 | The Swiss canton is BE |
enBL: 5 | The Swiss canton is BL |
enBS: 6 | The Swiss canton is BS |
enFR: 7 | The Swiss canton is FR |
enGE: 8 | The Swiss canton is GE |
enGL: 9 | The Swiss canton is GL |
enGR: 10 | The Swiss canton is GR |
enJU: 11 | The Swiss canton is JU |
enLU: 12 | The Swiss canton is LU |
enNE: 13 | The Swiss canton is NE |
enNW: 14 | The Swiss canton is NW |
enOW: 15 | The Swiss canton is OW |
enSG: 16 | The Swiss canton is SG |
enSH: 17 | The Swiss canton is SH |
enSO: 18 | The Swiss canton is SO |
enSZ: 19 | The Swiss canton is SZ |
enTG: 20 | The Swiss canton is TG |
enTI: 21 | The Swiss canton is TI |
enUR: 22 | The Swiss canton is UR |
enVD: 23 | The Swiss canton is VD |
enVS: 24 | The Swiss canton is VS |
enZG: 25 | The Swiss canton is ZG |
enZH: 26 | The Swiss canton is ZH |
enLiechtenstein: 27 | The country is Liechtenstein |
enAustria: 28 | The country is Austria |
enGermany: 29 | The country is Germany |
enItaly: 30 | The country is Italy |
enFrance: 31 | The country is France |


  • Type definitions
  • CoverageType

CoverageType enumeration type |  |
Enumerates the defined types of coverage. |  | space
Set of enumeration values |  | 2 elements
enCoverageLimited: 1 | Limited coverage of the requested costs. This implicitly means that at least a service was modified regarding the costs. |
enCoverageFull: 2 | Full coverage of all requested costs |


  • Type definitions
  • CreditType

CreditType enumeration type |  |
Enumerates the defined types of credits |  | space
Set of enumeration values |  | 3 elements
enCreditNew: 1 | New credit request |
enCreditReconsideration: 2 | Re-consideration of a previously sent and rejected credit request |
enCreditProlongation: 3 | Prolongation of a previously accepted credit request |


  • Type definitions
  • DATE

DATE type |
A value denoting a date and time was specified. Dates are represented as double-precision numbers, where midnight, January 1, 1900 is 2.0, January 2, 1900 is 3.0, and so on. The value is passed in date. | space


  • Type definitions
  • DiagnosisType

DiagnosisType enumeration type |  |
Enumerates the defined diagnosis coding systems. |  | space
Set of enumeration values |  | 7 elements
enDiagnosisICD: 0 | ICD 10 diagnosis |
enDiagnosisCantonal: 1 | Cantonal diagnosis code. |
enDiagnosisByContract: 2 | Diagnosis coded according to contract. |
enDiagnosisFreeText: 3 | Free text diagnosis. |
enDiagnosisBirthdefect: 4 | Birth defect diagnosis |
enDiagnosisICPC: 5 | ICPC diagnosis (International Classification of Primary Care) |
enDiagnosisDRG: 6 | DRG diagnosis that is the DRG service code |


  • Type definitions
  • double

double type |
An 8-byte IEEE real value. | space


  • Type definitions
  • HospitalizationMode

HospitalizationMode enumeration type |  |
Enumerates the defined modes/indications of the hospitalization |  | space
Set of enumeration values |  | 3 elements
enCantonal: 0 | Mode of hospitalization is cantonal |
enIndicated: 1 | Mode of hospitalization is non-cantonal (person living in another canton then treated) but indicated. This implicitly qualifies to define "outer cantonal" data and to send a credit request to the cantonal surgeon. |
enNonIndicated: 2 | Mode of hospitalization is non-cantonal (person living in another canton then treated) and not indicated. This implicitly qualifies to define "outer cantonal" data and to send a credit request to the cantonal surgeon. |


  • Type definitions
  • HospitalizationType

HospitalizationType enumeration type |  |
Enumerates the defined types/reasons of the hospitalization |  | space
Set of enumeration values |  | 3 elements
enRegular: 0 | The reason of the hospitalization is regular |
enEmergency: 1 | The reason of the hospitalization is an emergency |
enWelfare: 2 | The reason of the hospitalization is due to welfare ("Freiheitsenzug") |


  • Type definitions
  • HRESULT

HRESULT type |
The HRESULT data type is a 32-bit value that is used to describe an error or warning. | space


  • Type definitions
  • IAddress

IAddress type |
IAddress interface. | space


  • Type definitions
  • IGeneralCreditResponse

IGeneralCreditResponse type |
IGeneralCreditResponse interface | space


  • Type definitions
  • InsuranceClass

InsuranceClass enumeration type |  |
Enumerates the defined insurance classes |  | space
Set of enumeration values |  | 3 elements
enClassGeneral: 0 | General insurance class (3rd class insurance coverage) |
enClassSemiPrivate: 1 | Semi-private insurance class (2nd class insurance coverage) |
enClassPrivate: 2 | Private insurance class (1st class insurance coverage) |


  • Type definitions
  • InsuranceModel

InsuranceModel enumeration type |  |
The insurance model is a possible refinement of the insurance class |  | space
Set of enumeration values |  | 4 elements
enModelStandard: 1 | Defines the given insurance class without further refinements |
enModelHospitalComfort: 2 | Defines the hospitalization comfort refinement above the given insurance class |
enModelFreeMDChoice: 3 | Defines the free choice of the physician refinement ("Freie Arztwahl") above the given insurance class |
enModelOther: 4 | Defines a refinement to the insurance class not given explicitly |


  • Type definitions
  • LanguageType

LanguageType enumeration type |  |
Enumerates all supported languages. |  | space
Set of enumeration values |  | 3 elements
enGerman: 1 | German |
enFrench: 2 | French. |
enItalian: 3 | Italian |


  • Type definitions
  • LawType

LawType enumeration type |  |
Enumerates the supported legal law set |  | space
Set of enumeration values |  | 6 elements
enKVG: 0 | KVG - "Krankenversicherungsgesetz" |
enUVG: 1 | UVG - "Unfallversicherungsgesetz" |
enMVG: 2 | MVG - "Militäversicherungsgesetz" |
enIVG: 3 | IVG - "Invalidenversicherungsgesetz" |
enVVG: 4 | VVG - "Versicherungsvertragsgesetz" |
enORG: 5 | ORG - "Obligationenrecht" This is primarely for e.g. of dentists to produce cost estimates. |


  • Type definitions
  • long

long type |
A 4-byte integer value. | space


  • Type definitions
  • ModusType

ModusType enumeration type |  |
Enumerates the defined operation modus types |  | space
Set of enumeration values |  | 2 elements
enProduction: 0 | Production modus. |
enTest: 1 | Test modus - the data should not be forwarded to the receiver. |


  • Type definitions
  • PlaceType

PlaceType enumeration type |  |
Enumerates the defined places where the main provider is located |  | space
Set of enumeration values |  | 5 elements
enPlacePractice: 1 | The service location is the practice |
enPlaceHospital: 2 | The service location is the hospital |
enPlaceLab: 4 | The service location is in a laboratory |
enPlaceAssociation: 8 | The service location is in an association (like "Spitex") |
enPlaceCompany: 16 | The service location is in a company |


  • Type definitions
  • ResponseType

ResponseType enumeration type |  |
Enumerates the defined response types. |  | space
Set of enumeration values |  | 3 elements
enResponsePending: 1 | The response is of type pending - the corresponding request can not be processed to a final stage as some data are missing. |
enResponseRejected: 2 | The response is of type rejected - the corresponding request is rejected and as a consequence the status of the request goes to the "canceled" state |
enResponseAccepted: 3 | The response is of type accepted - the corresponding request is fully accepted and will be processed to a final stage. |


  • Type definitions
  • RoleType

RoleType enumeration type |  |
Enumerates the defined role categories that the main provider is best categorized |  | space
Set of enumeration values |  | 21 elements
enRolePhysician: 1 | The main provider is a physician |
enRolePhysiotherapist: 2 | The main provider is a physiotherapist This role includes therapeutic masseurs as well. |
enRoleChiropractor: 4 | The main provider is a chiropractor |
enRoleErgotherapist: 8 | The main provider is an ergotherapist |
enRoleNutritionist: 16 | The main provider is a nutritionist This role includes diet advisors, diabetic dietitian and diabetic advisors as well |
enRoleMidwife: 32 | The main provider is a midwife |
enRoleLogotherapist: 64 | The main provideris a logotherapist |
enRoleHospital: 128 | The main provider's address is that of a hospital. Therefore the "virtual" role is enRoleHospital and it qualifies the invoice/reminder as one from a hospital |
enRolePharmacist: 256 | The main provider is a pharmacist |
enRoleDentist: 512 | The main provider is a dentist This role includes dental hygienists as well. |
enRoleLabTechnician: 1024 | The main provider is a lab technician |
enRoleDentalTechnician: 2048 | The main provider is a dental technician |
enRoleOtherTechnician: 4096 | The main provider The main provider is a technician but neither a dental nor a lab technician This role includes (orthopedic) shoemakers as well |
enRolePsychologist: 16384 | The main provider a psychologist Note that psychiatrists would count as enRolePhysician |
enRoleWholesaler: 65536 | The main provider is a wholesaler |
enRoleNursingStaff: 131072 | The main provider is beloning to the nursing staff including nursing auxiliaries |
enRoleTransport: 262144 | The main provider accomplishes transports or carrier services This role includes ambulance transport as well. |
enRoleDruggist: 524288 | The main provider is a druggist |
enRoleNaturopathicDoctor: 1048576 | The main provider is a is naturopathic doctor. As per definition this is a doctor of non-conventional Western medicine/non-biomedicine. |
enRoleNaturopathicTherapist: 2097152 | The main provider is a is naturopathic therapist. As per definition this is a therapist of non-conventional Western medicine/non-biomedicine. This role includes wellness therapists as well. |
enRoleOther: 4194304 | The main provider has an other role than defined here. Supply a role title in this case with a description of the role |


  • Type definitions
  • SexType

SexType enumeration type |  |
Enumerates the defined gender categories. |  | space
Set of enumeration values |  | 2 elements
enMale: 0 | Male |
enFemale: 1 | Female |


  • Type definitions
  • SideType

SideType enumeration type |  |
Enumerates the defined side categories. |  | space
Set of enumeration values |  | 5 elements
enSideNone: 0 | No side dependency |
enSideLeft: 1 | Left body side is affected |
enSideRight: 2 | Right body side is affected |
enSideBoth: 3 | Both body sides are affected |
enSideUnknown: 4 | The side dependency is unknown |


  • Type definitions
  • StatusType

StatusType enumeration type |  |
Enumerates the defined status types that request object can posses |  | space
Set of enumeration values |  | 7 elements
enStatusUnknown: 2 | The status is unknown meaning that the given object reference is unknown. |
enStatusAmbiguous: 3 | The status is ambiguous meaning that the given object reference delivers more than one result. |
enStatusReceived: 4 | The status is received meaning that nothing has been done so far except receiving the request. |
enStatusFrozen: 5 | The status is frozen meaning that the request is not processed until further data is provided - an appropriate response of that type was sent. |
enStatusProcessed: 6 | The status is processed meaning that the request has passed all processing and analysis but has not reached the granted or canceled state. |
enStatusGranted: 7 | The status is granted meaning that the request is accepted and archived as well as the requested amount was paid to the biller. |
enStatusCanceled: 8 | The status is canceled meaning that the request is canceled and archived with reject status - an appropriate response of that type was sent |


  • Type definitions
  • TreatmentReasonType

TreatmentReasonType enumeration type |  |
Enumerates the defined treatment reasons. |  | space
Set of enumeration values |  | 6 elements
enDisease: 0 | The treatment reason is due to a disease. |
enAccident: 1 | The treatment reason is due to an accident |
enMaternity: 2 | The treatment reason is due to maternity |
enPrevention: 3 | The treatment reason is due to a prevention. |
enBirthdefect: 4 | The treatment reason is due to a birth defect |
enUnknown: 5 | The treatment reason is unknown |


  • Type definitions
  • VARIANT_BOOL

VARIANT_BOOL type |
Enumerates defined types of XML generation attributes | space


  • Type definitions
  • YesNoType

YesNoType enumeration type |  |
Boolean enumerator. |  | space
Set of enumeration values |  | 2 elements
enNo: 0 | No. |
enYes: 1 | Yes. |


 Notes about the encryption

XML Encryption is a specification, governed by a W3C recommendation, that defines how to encrypt the contents of an XML element. Although XML Encryption can be used to encrypt any kind of data, it is nonetheless known as "XML Encryption" because an XML element (either an EncryptedData or EncryptedKey element) contains or refers to the cipher text, keying information, and algorithms.

However, it is beyond the scope of this documentation to explain all details of a encryption or the encryption process. Detailed information about all aspects of encryption can be found at W3C.

Boundary conditions and critical aspects

  • the encryption is optional!
  • if an infoset is encrypted then the public certificate of the recipient must be used and this certificate is applied to the body element.

    Here recipient is used in terms of the communication and therefore is defined as the EAN entity given in the transport@to attribute
  • the namespace v1 of W3C http://www.w3.org/2001/04/xmlenc must be used- cf. XML Encryption Syntax and Processing
  • The encryption algorithm is fixed to PKCS1 (RSA-SHA1) (RFC 2437: RSA Cryptography Specifications)
  • The block encryption algorithm is fixed to Triple DES

The generalCreditRequest module does obey all these conditions whenever encryption is "turned on" by setting a public certificate of the "toEAN" entity (cf. IGeneralCreditResponse::GetTransport). This certificate must be in the format "binary DER".

Where do I get this certificate?
The request/response system is self-contained insofar as the generalCreditResponse module (or any other V4.3 module!) extracts the public certificate of a signed response XML infoset and generates a binary DER file named X509DER_from_EAN.cer. This is exactly the certificate to use for encrypting a credit (or all other V4.3) request XML infosets!


 VB code snippet for using the generalCreditResponseManager

Private Sub doPrint_Click()

On Error GoTo Err_Trap

Dim bStatus As Boolean

'### GeneralCreditResponseManager interface
Dim generalCreditResponseManagerEx As GENERALCREDITRESPONSEMANAGER430Lib.GeneralCreditResponseManager
Set generalCreditResponseManagerEx = New GeneralCreditResponseManager

'### GeneralCreditResponse interface
Dim generalCreditResponseEx As GeneralCreditResponse

Dim strXML As String
Dim strXSD As String
Dim lVersion As Long
Dim strFromEAN As String
Dim strToEAN As String
Dim bIsEncrypted As YesNoType

'### input xml
strXML = "PhysioAcceptedTest.xml"

'### get info about the xml file
bStatus = generalCreditResponseManagerEx.GetXMLInfo(strXML, strXSD, strFromEAN, strToEAN, bIsEncrypted)
'### This is a demo so we don't care about encryption
If bStatus And Not bIsEncrypted Then
    '### load the xml file
    bStatus = generalCreditResponseManagerEx.LoadXML(strXML, "", "", generalCreditResponseEx)
    If bStatus Then
            Dim strUsedSchema As String
            Dim lTimestamp As Long
            '### print the response
           bStatus = generalCreditResponseManagerEx.Print("", enYes)
    End If

End If

'### relase resources
Set generalCreditResponseEx = Nothing
Set generalCreditResponseManagerEx = Nothing

Exit Sub

Err_Trap:
    MsgBox "Error: " & Err.Description, vbCritical, _
           "Opps! Error" & Str$(Err.Number)

'### relase resources
Set generalCreditResponseEx = Nothing
Set generalCreditResponseManagerEx = Nothing

End Sub
Private Sub doPrint_Click()

On Error GoTo Err_Trap

Dim bStatus As Boolean

'### GeneralCreditResponseManager interface
Dim generalCreditResponseManagerEx As GENERALCREDITRESPONSEMANAGER430Lib.GeneralCreditResponseManager
Set generalCreditResponseManagerEx = New GeneralCreditResponseManager

'### GeneralCreditResponse interface
Dim generalCreditResponseEx As GeneralCreditResponse

Dim strXML As String
Dim strXSD As String
Dim lVersion As Long
Dim strFromEAN As String
Dim strToEAN As String
Dim bIsEncrypted As YesNoType

'### input xml
strXML = "PhysioAcceptedTest.xml"

'### get info about the xml file
bStatus = generalCreditResponseManagerEx.GetXMLInfo(strXML, strXSD, strFromEAN, strToEAN, bIsEncrypted)
'### This is a demo so we don't care about encryption
If bStatus And Not bIsEncrypted Then
    '### load the xml file
    bStatus = generalCreditResponseManagerEx.LoadXML(strXML, "", "", generalCreditResponseEx)
    If bStatus Then
            Dim strUsedSchema As String
            Dim lTimestamp As Long
            '### print the response
           bStatus = generalCreditResponseManagerEx.Print("", enYes)
    End If

End If

'### relase resources
Set generalCreditResponseEx = Nothing
Set generalCreditResponseManagerEx = Nothing

Exit Sub

Err_Trap:
    MsgBox "Error: " & Err.Description, vbCritical, _
           "Opps! Error" & Str$(Err.Number)

'### relase resources
Set generalCreditResponseEx = Nothing
Set generalCreditResponseManagerEx = Nothing

End Sub


 General use of the generalCreditRequest ATL COM module

The generalCreditResponse provides all the necessary tools for loading and thereafter analyzing XML infosets of type generalCreditResponse_430. These infosets are responses to a previously sent credit requests where the topmost object reference defines target request/response. The generalCreditResponse handles all roles and places.

The subchapter object reference provides an in-depth description of the concept of "object reference".

To get the results of such an infoset, firstly the XML file is loaded into the module by the IGeneralCreditResponseManager::LoadXML method. Upon successful analyzing the file the method returns a IGeneralCreditResponse interface. All response data and parameters of one credit can be retrieved by the supplied interface methods as e.g. IGeneralCreditResponse:GetPatient,...

The IGeneralCreditResponseManager::Print method can be used to visualize the whole response content.

An auxiliary interface IAddress is available for getting the address related data in a structured way.

To get a staring point there is a Visual Basic code snippet provided that can be used for using the generalCreditResponse module.


 How to generate PDF archive files of a credit response

To generate PDF archive files of a credit response in the generalCreditResponseManager use the special print object name
(PDF=PDF_file_to_generate;)
or
(PDF_NOPRINT=PDF_file_to_generate;)
as a print object name on the printTemplate variable of the Print method.

The "PDF" token means to print the response and generate the PDF files, whereas the "PDF_NOPRINT" token only generates the PDF file without physical printing.
This object definition is only used while printing and is ignored in the preview mode!

In its simplest form this means

     BSTR bstrPrintTemplate = "(PDF="+bstrPDFFile+";)";

     IGeneralInvoiceResponseManager::Print(bstrPrintTemplate,...);
in order to generate a PDF archive file of response.

Since the PDF generation is not the main purpose of the Print method this PDF feature has NO error propagation. The generation is done on a best effort basis, errors are only dumped to the log file!

Boundary conditions:

  • Only active in printing mode
  • No error propagation
  • The supplied PDF archive name must not exist
  • The directory where the PDF is stored must be writable


 Object reference...

The following paragraphs defines the concepts of object reference, object reference chain, and topmost object reference. These concepts are of high importance within the XML request/response system.

object reference

An object reference is an identification of an individual XML request defined by a unique triple of data, namely
  • timestamp (UNIX time) defined at the moment of generation
  • date of the object defined by the provider
  • id of the object defined by the provider
Each and every XML request of version 4.3 is defined by such an object reference. Thus the object reference serves as a clustered primary key of the request/response system!
All XML responses are replies to the object reference of the corresponding request.

object reference chain

As a consequence of the XML schema coded business logic most XML request schemas define more than just 1 object reference, e.g. a "GeneralCreditRequest" (the "GeneralCreditResponse" does as well due to the above) can hold a maximum of 2 object references, namely
  • an optional credit_ref object reference from a previous "General Credit Request" process
  • an mandatory credit object reference from the "General Credit Request" process
This set of object references by itself defines an ordered object reference chain (e.g. credit_ref -> credit) with the topmost object reference as unique identification of the XML request. Therefore the object reference chain defines -on business logic point of view- dependencies among different XML requests.

topmost object reference

The end node of an object reference chain is defined as topmost object reference, that is by definition the object reference of the XML request itself. Each request/response communication is always done for this topmost object reference and only for that.


 Notes about the signature

XML signatures are digital signatures designed for use in XML transactions. The W3C standard defines a schema for capturing the result of a digital signature operation applied to an infoset. XML signatures add authentication, data integrity, and support for non-repudiation to the data that they sign.
However, it is beyond the scope of this documentation to explain all details of a signature or the signing process. Detailed information about all aspects of signatures can be found at W3C.

Boundary conditions and critical aspects

  • the signature is optional!
  • if an infoset is signed then the private certificate of the sender must be used and this certificate is applied to the payload element. This inherently qualifies for a detached signature.

    In this context sender is used in terms of the communication and therefore is defined as the EAN entity given in the transport@from attribute

  • the URI attribute of the reference element must use a XPointer syntax of the payload element, e.g. <ds:Reference URI="#xpointer(/credit:response/credit:payload)">
  • it is recommended to add the public key via a X509Data element such that a key store can be built at the recipient's site
  • The signature algorithm is fixed to PKCS1 (RSA-SHA1) (RFC 2437: RSA Cryptography Specifications)
  • The digest algorithm is fixed to SHA-1
  • the used canonicalization algorithm must be http://www.w3.org/2001/10/xml-exc-c14n#, the exclusive XML Canonicalization

The generalCreditResponse module does understand these boundary conditions. If the response XML is signed then the module extracts the X509Data element and transforms it to a binary DER format. Using the certificate the signature chain is checked. The IGeneralCreditResponse::GetTransport method returns a binary DER file named X509DER_from_EAN.cer. This is exactly the certificate to use for encrypting a credit (or all other V4.3) request XML infosets!