 API browser of generalnotification440 COM module
Interface version: | 4.40
Interface date: | 15 Nov 2013

The GeneralNotificationManager is an ATL COM module which provides methods to generate an email like structured message exchange between two partners. The produced XML infoset is transported electronically to the recipient and optionally can be signed and/or encrypted.

Structured message exchange means that the message thread is uniquely identified by the notification object reference and optionally the target of the message exchange can be defined by a dependent object reference of type credit, invoice, reminder, MCD, or form.

Furthermore, by using the formOID attribute of the message a form process can be initiated at any point of the message exchange. Additionally, a PDF document can be attached in each step of the communication.

space
Interfaces | 4 interface
IAddress | The utility interface IAddress is available for setting and retrieving structured address data.
IGeneralNotificationManager | The main interface IGeneralNotificationManager -creatable in its own right- all necessary tools to produce a new message thread or reply to a received one.
IGeneralNotificationRequest | The IGeneralNotificationRequest is used whenever a new message thread is started and such a thread is generated from scratch.
IGeneralNotificationResponse | The interface IGeneralNotificationResponse allows to read back all data that have been defined with the IGeneralInvoiceRequest interface or by loading a previously generated XML infoset.
Types
type definitions | List of all used builtin, composite and enumeration types
Important information about the usage and handling of the module
Document | General usage of the generalNotification440 COM module - an overview
Document | What to do in a 64bit environment - is there a 64bit Sumex1 COM dll?
Document | Overview of the concept of "Object reference"
Document | Notes about the signature part of the XML infoset
Document | Notes about the encryption part of the XML infoset
Document | Syntax of the printTemplate variable of the Print method
Document | How to generate a PDF archive file of a generalNotification
Document | VB code snippet for using the generalNotification440 COM module

© by sumex1.net - all rights reserved


  • generalnotification440
  • IAddress

IAddress interface |  | V4.40/15 Nov 2013
With the IAddress interface address data can be set and retrieved. The address of a person is set by the method SetPerson whereas a company address is entered by the method SetCompany. Before setting a new address the interface has to be initialized by the method Initialize. |  | space
Methods |  | 15 methods
AddPhone | Adds a structured phone number |
GetAbortInfo | Get the abort information string with the error coded in the module language |
GetCompany | Retrieves the company's naming part of the address |
GetFax | Retrieves the structured fax number |
GetFirstPhone | Retrieves the first phone number information |
GetNextPhone | Retrieves the next phone number information |
GetOnline | Retrieves the structured online part of the address |
GetPerson | Retrieves the person's naming part of the address |
GetPostal | Retrieves the structured postal address part of the address |
Initialize | Initializes all address variables |
SetCompany | Sets the company's naming part of the address |
SetFax | Sets a structured fax number |
SetOnline | Sets the structured online part of the address. |
SetPerson | Sets the person's naming part of the address |
SetPostal | Sets the structured postal address part |
Properties |  | 1 properties
[get] Type | GetType returns the type of address either enAddressPerson or enAddressCompany if an address is defined at all |


  • IAddress
  • AddPhone

IAddress::AddPhone method |  |  |
Adds a structured phone number. The Swiss international calling code +41 is filtered in the printing. If the main software does not support structured pone numbers then all data is supplied in the bstrNumber variable. However, +41 is then no longer filtered. |  |  | space
C/C++ calling syntax |  |  |
HRESULT AddPhone( | BSTR BSTR BSTR BSTR VARIANT_BOOL | bstrNumber, bstrLocalCode, bstrInternationalCode, bstrExt, *pbStatus); |
Calling argument description |  |  |
[in] BSTR | bstrNumber | Phone number. |
[in] BSTR | bstrLocalCode | Local area code. |
[in] BSTR | bstrInternationalCode | International calling code. |
[in] BSTR | bstrExt | Extension number. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IAddress
  • GetAbortInfo

IAddress::GetAbortInfo method |  |  |
Get the abort information string with the error coded in the module language. Call this method whenever the returned pbStatus variable of the primarily called method is VARIANT_FALSE and the primarily called method is not an iterator (GetFirst/GetNext). In the later case VARIANT_FALSE signals the end of data. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetAbortInfo( | BSTR VARIANT_BOOL | *pbstrAbort, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrAbort | Abort information string coded in the module language. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error-in-error situation occurred. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IAddress
  • GetCompany

IAddress::GetCompany method |  |  |
Retrieves the company's naming part of the address. Call the property GetType first to test if GetPerson or GetCompany should be called. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetCompany( | BSTR BSTR BSTR VARIANT_BOOL | *pbstrCompanyName, *pbstrDepartment, *pbstrSubaddressing, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrCompanyName | Company name. |
[out] BSTR | *pbstrDepartment | Department. |
[out] BSTR | *pbstrSubaddressing | Optional subaddressing information, e.g. c/o, P.O. box and the like |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IAddress
  • GetFax

IAddress::GetFax method |  |  |
Retrieves the structured fax number. Empty variables are returned if there is no fax number available. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetFax( | BSTR BSTR BSTR BSTR VARIANT_BOOL | *pbstrNumber, *pbstrLocalCode, *pbstrInternationalCode, *pbstrExt, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrNumber | Fax number. |
[out] BSTR | *pbstrLocalCode | Local area code. |
[out] BSTR | *pbstrInternationalCode | International calling code. |
[out] BSTR | *pbstrExt | Extension number. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IAddress
  • GetFirstPhone

IAddress::GetFirstPhone method |  |  |
Retrieves the first phone number information. VARIANT_FALSE is returned if the end of the phone list is reached. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetFirstPhone( | BSTR BSTR BSTR BSTR VARIANT_BOOL | *pbstrNumber, *pbstrLocalCode, *pbstrInternationalCode, *pbstrExt, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrNumber | Phone number. |
[out] BSTR | *pbstrLocalCode | Local area code. |
[out] BSTR | *pbstrInternationalCode | International calling code. |
[out] BSTR | *pbstrExt | Extension number. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IAddress
  • GetNextPhone

IAddress::GetNextPhone method |  |  |
Retrieves the next phone number information. VARIANT_FALSE is returned if the end of the phone list is reached |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetNextPhone( | BSTR BSTR BSTR BSTR VARIANT_BOOL | *pbstrNumber, *pbstrLocalCode, *pbstrInternationalCode, *pbstrExt, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrNumber | Phone number. |
[out] BSTR | *pbstrLocalCode | Local area code. |
[out] BSTR | *pbstrInternationalCode | International calling code. |
[out] BSTR | *pbstrExt | Extension number. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IAddress
  • GetOnline

IAddress::GetOnline method |  |  |
Retrieves the structured online part of the address. Empty variables are returned if there is no online information available. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetOnline( | BSTR BSTR VARIANT_BOOL | *pbstrEMail, *pbstrUrl, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrEMail | Email address. |
[out] BSTR | *pbstrUrl | URL. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IAddress
  • GetPerson

IAddress::GetPerson method |  |  |
Retrieves the person's naming part of the address. Call the property GetType first to test if GetPerson or GetCompany should be called. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetPerson( | BSTR BSTR BSTR BSTR BSTR VARIANT_BOOL | *pbstrFamilyname, *pbstrGivenname, *pbstrSalutation, *pbstrTitle, *pbstrSubaddressing, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrFamilyname | Family name. |
[out] BSTR | *pbstrGivenname | Given name. |
[out] BSTR | *pbstrSalutation | Salutation. |
[out] BSTR | *pbstrTitle | Title. |
[out] BSTR | *pbstrSubaddressing | Optional subaddressing information, e.g. c/o, P.O. box and the like |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IAddress
  • GetPostal

IAddress::GetPostal method |  |  |
Retrieves the structured postal address part of the address |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetPostal( | BSTR BSTR BSTR BSTR BSTR BSTR VARIANT_BOOL | *pbstrStreet, *pbstrPoBox, *pbstrZip, *pbstrCity, *pbstrStateCode, *pbstrCountryCode, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrStreet | Street. |
[out] BSTR | *pbstrPoBox | P.O. Box. |
[out] BSTR | *pbstrZip | ZIP code |
[out] BSTR | *pbstrCity | City. |
[out] BSTR | *pbstrStateCode | State code. |
[out] BSTR | *pbstrCountryCode | ISO country code. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IAddress
  • Initialize

IAddress::Initialize method |  |  |
Initializes all address variables. This method should be called before any data are supplied. |  |  | space
C/C++ calling syntax |  |  |
HRESULT Initialize( | VARIANT_BOOL | *pbStatus); |
Calling argument description |  |  |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IAddress
  • SetCompany

IAddress::SetCompany method |  |  |
Sets the company's naming part of the address. Note that the subaddressing is part of the extended name and is always printed before any postal information. |  |  | space
C/C++ calling syntax |  |  |
HRESULT SetCompany( | BSTR BSTR BSTR VARIANT_BOOL | bstrCompanyName, bstrDepartment, bstrSubaddressing, *pbStatus); |
Calling argument description |  |  |
[in] BSTR | bstrCompanyName | Company name. |
[in] BSTR | bstrDepartment | Department. |
[in] BSTR | bstrSubaddressing | Optional subaddressing information, e.g. c/o, P.O. box and the like |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IAddress
  • SetFax

IAddress::SetFax method |  |  |
Sets a structured fax number. The Swiss international calling code +41 is filtered in the printing. If the main software does not support structured pone numbers then all data is supplied in the bstrNumber variable. However, +41 is then no longer filtered. |  |  | space
C/C++ calling syntax |  |  |
HRESULT SetFax( | BSTR BSTR BSTR BSTR VARIANT_BOOL | bstrNumber, bstrLocalCode, bstrInternationalCode, bstrExt, *pbStatus); |
Calling argument description |  |  |
[in] BSTR | bstrNumber | Fax number. |
[in] BSTR | bstrLocalCode | Local area code. |
[in] BSTR | bstrInternationalCode | International calling code. |
[in] BSTR | bstrExt | Extension number. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IAddress
  • SetOnline

IAddress::SetOnline method |  |  |
Sets the structured online part of the address. |  |  | space
C/C++ calling syntax |  |  |
HRESULT SetOnline( | BSTR BSTR VARIANT_BOOL | bstrEMail, bstrUrl, *pbStatus); |
Calling argument description |  |  |
[in] BSTR | bstrEMail | Email address. |
[in] BSTR | bstrUrl | URL. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IAddress
  • SetPerson

IAddress::SetPerson method |  |  |
Sets the person's naming part of the address. Note that the subaddressing is part of the extended name and is always printed before any postal information. |  |  | space
C/C++ calling syntax |  |  |
HRESULT SetPerson( | BSTR BSTR BSTR BSTR BSTR VARIANT_BOOL | bstrFamilyname, bstrGivenname, bstrSalutation, bstrTitle, bstrSubaddressing, *pbStatus); |
Calling argument description |  |  |
[in] BSTR | bstrFamilyname | Family name. |
[in] BSTR | bstrGivenname | Given name. |
[in] BSTR | bstrSalutation | Salutation. |
[in] BSTR | bstrTitle | Title. |
[in] BSTR | bstrSubaddressing | Optional subaddressing information, e.g. "c/o" and the like |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IAddress
  • SetPostal

IAddress::SetPostal method |  |  |
Sets the structured postal address part. The Swiss ISO county code is the default but is filtered in the printing. |  |  | space
C/C++ calling syntax |  |  |
HRESULT SetPostal( | BSTR BSTR BSTR BSTR BSTR BSTR VARIANT_BOOL | bstrStreet, bstrPoBox, bstrZip, bstrCity, bstrStateCode, bstrCountryCode, *pbStatus); |
Calling argument description |  |  |
[in] BSTR | bstrStreet | Street |
[in] BSTR | bstrPoBox | P.O. Box |
[in] BSTR | bstrZip | ZIP code |
[in] BSTR | bstrCity | City |
[in] BSTR | bstrStateCode | State code like the codes of the US states. Such state codes should only be supplied if it is part of the address because the state code is printed before the zip code. |
[in] BSTR | bstrCountryCode | ISO country code |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IAddress
  • Type

IAddress::Type property
GetType returns the type of address either enAddressPerson or enAddressCompany if an address is defined at all. If no address is set then enAddressUndefined is returned. | space
C/C++ calling syntax
[get] HRESULT | Type( AddressType *aAddressType);
space
Calling argument description
[out, retval] AddressType | *aAddressType
C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • AddressType *GetType(void);
space


  • IGeneralNotificationManager

IGeneralNotificationManager interface | V4.40/15 Nov 2013
The IGeneralNotificationManager interface provides all necessary tools to produce a new message thread or reply to a received one.
  • To produce a new message thread an instance of the IGeneralNotificationRequest interface is created by the GetGeneralNotificationRequest property. All data and parameters can be set by the supplied interface methods like SetPatient, SetSender,...
  • To reply to an received notification infoset the SetReply method is sufficient since all other data is already available.
After all information is defined the notification XML infoset is produced optionally with signature and/or encryption using the GetXML method and the such generated XML file is then transported electronically to the recipient. 		space
Methods | 11 methods
AddInstruction | Adds an automation instruction to the list of instructions
GetAbortInfo | Get the abort information string with the error coded in the module language
GetLogSettings | Get the log settings for the module.
GetXML | The GetXML method generates the XML infoset based either on the data of a new notification using the IGeneralNotificationRequest interface or based on the received and replied XML infoset
GetXMLInfo | Preloads and analyzes a XML infoset regarding the accepted schema and other important information
LoadXML | Loads a received XML infoset of type generalNotification_430 back into memory for further processing via the returned interface handle
Print | The Print method is a visualization aid to preview/print the currently loaded data on screen or the local printer
PrintAdjust | Shows the print object adjustment dialog that allows to move print objects of a .vps report generator file.
PrintSetup | Shows the printer setup dialog that allows to define printer settings connected with a .vps report generator file.
SetLogSettings | Set the log settings for the module
SetReply | The SetReply method allows making a reply to an already received and loaded notification
Properties | 6 properties
[get] GeneralNotificationRequest | The property GetGeneralNotificationRequest supplies a pointer to the IGeneralNotificationRequest interface
[get/put] ModuleLanguage | Get/Set the language for the module i.e
[get] ModuleVersion | Get the version of the GeneralNotificationManager module.
[get] ModuleVersionText | Get the textual version of the GeneralNotificationManager module.
[get/put] Modus | Get the operation modus
[get/put] PrintCopies | Get/Set the number of copies to print.


  • IGeneralNotificationManager
  • AddInstruction

IGeneralNotificationManager::AddInstruction method |  |  |
Adds an automation instruction to the list of instructions. The instruction is formatted as a token/value pair Note that these instructions are defined purely between sender and receiver regarding the semantic meaning. The infoset is just the transport container. Note also that even if the notification deals only with such instructions, a meaningful message is still required as forced by the underlying XSD schema. |  |  | space
C/C++ calling syntax |  |  |
HRESULT AddInstruction( | long BSTR BSTR VARIANT_BOOL | lGroupNumber, bstrToken, bstrValue, *pbStatus); |
Calling argument description |  |  |
[in] long | lGroupNumber | The lGroupNumber allows to further group the instruction set by a group numbering scheme. |
[in] BSTR | bstrToken | The token part of the token/value formatted instruction |
[in] BSTR | bstrValue | The value part of the token/value formatted instruction |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralNotificationManager
  • GetAbortInfo

IGeneralNotificationManager::GetAbortInfo method |  |  |
Get the abort information string with the error coded in the module language. Call this method whenever the returned pbStatus variable of the primarily called method is VARIANT_FALSE and the primarily called method is not an iterator (GetFirst/GetNext). In the later case VARIANT_FALSE signals the end of data. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetAbortInfo( | BSTR VARIANT_BOOL | *pbstrAbort, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrAbort | Abort information string coded in the module language. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error-in-error situation occurred. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralNotificationManager
  • GetLogSettings

IGeneralNotificationManager::GetLogSettings method
Get the log settings for the module. | space
C/C++ calling syntax
HRESULT GetLogSettings( long
long
YesNoType
BSTR
VARIANT_BOOL 		*plLogLevel,
*plMaxSizeKB,
*peDoArchive,
*pbstrArchiveDir,
*pbStatus);
Calling argument description
[out] long *plLogLevel The log activity level where
lLogLevel = 0 | Logging is turned off
lLogLevel = 1 | Normal log activity
lLogLevel > 1 | Debug log activity. Use this level only for debugging purposes
[out] long | *plMaxSizeKB | The maximum size in KB of the log file.
[out] YesNoType | *peDoArchive | eDoArchive defines if the log file is recycled if the maximum size is reached (enNo) or if the log file is archived (enYes).
[out] BSTR | *pbstrArchiveDir | The base directory where log files are archived. bstrArchiveDir is only defined if eDoArchive=enYes otherwise bstrArchiveDir is empty.
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


  • IGeneralNotificationManager
  • GetXML

IGeneralNotificationManager::GetXML method
The GetXML method generates the XML infoset based either on the data of a new notification using the IGeneralNotificationRequest interface or based on the received and replied XML infoset. In both cases the XML generation attributes are applied on the infoset generation, the XML is then validated against the XSD schema, and finally stored as UTF8 file in the internal working directory. The full file name to this XML document is returned in the pbstrOutputFile output variable.

The XML file must be saved to a different location as all temporary XML files in the working directory are deleted before the COM module shuts down!

Note about encryption: an encrypted XML infoset can not be loaded successfully by LoadXML. Therefore, to build a local archive besides encrypted XML infoset call GetXML twice once with the lXMLGenerationAttributes = enGenerateWithoutEncryption

space
C/C++ calling syntax
HRESULT GetXML( long
BSTR
long
long
IGeneralNotificationResponse
VARIANT_BOOL 		lXMLGenerationAttributes,
*pbstrOutputFile,
*plValidationError,
*plTimestamp,
**ppIGeneralNotificationResponse,
*pbStatus);
Calling argument description
[in] long lXMLGenerationAttributes This variable defines which principal parts of the XML generation should not be carried out even if the data for that part are defined. lXMLGenerationAttributes is a 32-bit integer where the possible excludes are values from the XMLGenerationAttributes data type and are ORed together to form the overall command.

This feature is necessary to generate different "flavors" of XML infosets without re-setting input data. For instance, an encrypted XML infoset for the "toEAN" entity can be produced and in a second call the XML infoset without encryption (lXMLGenerationAttributes = enGenerateWithoutEncryption) is requested for a local archive (that can be loaded back later!).

[out] BSTR *pbstrOutputFile The full file name (path + name) where the XML infoset is stored in UTF-8 mode.

The XML file must be saved to a different location as all temporary XML files in the working directory are deleted before the COM module shuts down!

[out] long | *plValidationError | lValidationError is filled with the validation error code returned by the MSXML-4 parser. A zero value indicates that the validation was successful.
[in, out] long *plTimestamp The timestamp of the XML document as epoch time (seconds elapsed since 1.1.1970) that is used as timestamp of the notification object reference from that point on.

In a reply situation the "old" timestamp of the received XML infoset is returned.

[out] IGeneralNotificationResponse **ppIGeneralNotificationResponse The IGeneralNotificationResponse interface allows to read back all currently loaded data.
The handle is NULL if an error occurred.
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


  • IGeneralNotificationManager
  • GetXMLInfo

IGeneralNotificationManager::GetXMLInfo method
Preloads and analyzes a XML infoset regarding the accepted schema and other important information.

If the XML infoset is of type generalNotification_430 then the fromEAN, toEAN as well as the encryption status are additionally extracted. The XSD name is set even if an error is generated.

This method should be called before calling the full XML loader LoadXML since the infoset is possibly encrypted. In this situation the corresponding PFX certificate and password must be supplied in the XML loader.

space
C/C++ calling syntax
HRESULT GetXMLInfo( BSTR
BSTR
BSTR
BSTR
YesNoType
VARIANT_BOOL 		bstrInputFile,
*pbstrUsedSchema,
*pbstrFromEAN,
*pbstrToEAN,
*peIsEncrypted,
*pbStatus);
Calling argument description
[in] BSTR | bstrInputFile | The full file name (path + name) of a XML infoset of type generalNotification_430.
[out] BSTR *pbstrUsedSchema The full XSD name of the loaded XML file.

The only accepted schema is generalNotification_430.xsd otherwise an error is generated.

[out] BSTR | *pbstrFromEAN | The transport EAN number of the sender as supplied by medwin.ch
[out] BSTR | *pbstrToEAN | The transport EAN number of the receiver as supplied by medwin.ch
[out] YesNoType *peIsEncrypted A Boolean that defines if the XML infoset is encrypted.

If true the private PFX certificate/password of the "toEAN" entity must be given in the LoadXML method otherwise the infoset can not be decrypted.

[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


  • IGeneralNotificationManager
  • LoadXML

IGeneralNotificationManager::LoadXML method |  |  |
Loads a received XML infoset of type generalNotification_430 back into memory for further processing via the returned interface handle. To analyze the received data use the IGeneralNotificationResponse interface and/or preview/print the data. To generate a reply call the SetReply method followed by the GetXML method. The latter one generates the new XML infoset ready to send back. Note that the data represented by the IGeneralNotificationResponse interface then changed. |  |  | space
C/C++ calling syntax |  |  |
HRESULT LoadXML( | BSTR BSTR BSTR IGeneralNotificationResponse VARIANT_BOOL | bstrInputFile, bstrToPFXFile, bstrToPFXPassword, **ppIGeneralNotificationResponse, *pbStatus); |
Calling argument description |  |  |
[in] BSTR | bstrInputFile | The full file name (path + name) of a XML infoset of type generalNotification_430.xsd. |
[in] BSTR | bstrToPFXFile | The file name of the PFX certificate that is the private certificate of the "toEAN" entity. This variable is not used if the XML infoset is not encrypted. |
[in] BSTR | bstrToPFXPassword | The password to open the PFX certificate. This variable is not used if the XML infoset is not encrypted. |
[out] IGeneralNotificationResponse | **ppIGeneralNotificationResponse | The IGeneralNotificationResponse interface allows to read back all currently loaded data. The handle is NULL if an error occurred. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralNotificationManager
  • Print

IGeneralNotificationManager::Print method
The Print method is a visualization aid to preview/print the currently loaded data on screen or the local printer. However, the generalNotification paradigm in its core is an electronic message exchange system. Thus, at the very end an XML infoset must be generated and sent to the recipient.

Note: the usage of the SetReply method defines a singularity in the data space and the semantic interpretation of the data. As a consequence the print output differs before and after SetReply!

IMPORTANT LICENSE NOTE The report engine used is Hexatech's ViewPro (www.hexatech.com). If you supply your own template files then you must have your own ViewPro license. By using this COM module you implicitly agree upon this restriction!

space
C/C++ calling syntax
HRESULT Print( BSTR
YesNoType
VARIANT_BOOL 		bstrPrintTemplate,
ePrintPreview,
*pbStatus);
Calling argument description
[in] BSTR bstrPrintTemplate The bstrPrintTemplate is either empty or built as defined in "Syntax of the printTemplate variable".

If bstrPrintTemplate is empty then the default print template of the supplied data language (IGeneralNotificationRequest::Initialize method) is used.

[in] YesNoType | ePrintPreview | A Boolean that defines if print preview is used (enYes) or printing is done (enNo)
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


  • IGeneralNotificationManager
  • PrintAdjust

IGeneralNotificationManager::PrintAdjust method
Shows the print object adjustment dialog that allows to move print objects of a .vps report generator file. | space
C/C++ calling syntax
HRESULT PrintAdjust( BSTR
BSTR
VARIANT_BOOL 		bstrPrintTemplate,
bstrINIPath,
*pbStatus);
Calling argument description
[in] BSTR bstrPrintTemplate Either the full file name (path + name) or a logical name of a target .vps report generator file for which the settings will be defined.

There are predefined .vps files in the installation directory that can be accessed via one of the following case insensitive logical names:

Detail_language

where
  • language is one of {dt, fr, it}.
For example the logical name "Detail_fr" is the French print template.
[in] BSTR bstrINIPath Optional path to a directory where the .vpd printer setting file is stored. The name of the printer setting file is the same name as the .vps file but with a .vpd extension.

If bstrINIPath is left empty then the standard directory (the directory of the dll) is used.

[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


  • IGeneralNotificationManager
  • PrintSetup

IGeneralNotificationManager::PrintSetup method
Shows the printer setup dialog that allows to define printer settings connected with a .vps report generator file. | space
C/C++ calling syntax
HRESULT PrintSetup( BSTR
BSTR
VARIANT_BOOL 		bstrPrintTemplate,
bstrINIPath,
*pbStatus);
Calling argument description
[in] BSTR bstrPrintTemplate Either the full file name (path + name) or a logical name of a target .vps report generator file for which the settings will be defined.

There are predefined .vps files in the installation directory that can be accessed via one of the following case insensitive logical names:

Detail_language

where
  • language is one of {dt, fr, it}.
For example the logical name "Detail_fr" is the French print template.
[in] BSTR bstrINIPath Optional path to a directory where the .vpd printer setting file is stored. The name of the printer setting file is the same name as the .vps file but with a .vpd extension.

If bstrINIPath is left empty then the standard directory (the directory of the dll) is used.

[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


  • IGeneralNotificationManager
  • SetLogSettings

IGeneralNotificationManager::SetLogSettings method
Set the log settings for the module.

The defaults for the log activity are: level=1, lMaxSizeKB=1000,eDoArchive=enNo,
and the log settings are persistent via the log file itself.

Note, that the log facility is a best effort system. If there is an error e.g. due to insufficient privileges to write the log entries then nothing is logged.

space
C/C++ calling syntax
HRESULT SetLogSettings( long
long
YesNoType
BSTR
VARIANT_BOOL 		lLogLevel,
lMaxSizeKB,
eDoArchive,
bstrArchiveDir,
*pbStatus);
Calling argument description
[in] long lLogLevel The log activity level where
lLogLevel = 0 | Logging is turned off
lLogLevel = 1 | Normal log activity
lLogLevel > 1 | Debug log activity. Use this level only for debugging purposes

Any log level below 0 is corrected to 0.

[in] long lMaxSizeKB The maximum size in KB of the log file.
Any size below 1000 KB (= the default value) is corrected to the default value
[in] YesNoType | eDoArchive | eDoArchive defines if the log file is recycled once the maximum size is reached (enNo) or if the log file is archived (enYes) into the archive directory.
[in] BSTR bstrArchiveDir Defines the base directory where log files are archived. bstrArchiveDir is only used if eDoArchive=enYes. If bstrArchiveDir is empty and eDoArchive=enYes then the place of the module is used as the base archive directory.

If the base archive directory or directories below have insufficient privileges to create directories or write files archiving is not done!

[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


  • IGeneralNotificationManager
  • SetReply

IGeneralNotificationManager::SetReply method
The SetReply method allows making a reply to an already received and loaded notification.

The successful usage of the SetReply method defines a singularity in the data space as the returned data of all IGeneralNotificationResponse methods is changed. Before the call to SetReply all IGeneralNotificationResponse methods return the received data and its semantic whereas after the call the addresses are mirrored and the message list is further added with the reply.

Note that if a new notification thread should be started then use the IGeneralNotificationRequest interface whose handle is generated with the GetGeneralNotificationRequest property.

Note that the form OID mechanism is a signal for the receiver to start a form process. In the Sumex1 environment the form OID is one from the medforms.ch space.

space
C/C++ calling syntax
HRESULT SetReply( BSTR
BSTR
BSTR
VARIANT_BOOL 		bstrMessage,
bstrFormOID,
bstrPDFFile,
*pbStatus);
Calling argument description
[in] BSTR | bstrMessage | The notification message
[in] BSTR bstrFormOID An optional form OID.

The definition of such a form OID signals the receiver to start a form process using the given OID as form template and using the reference object and the sender, receiver data as additional input. The resulting XML infoset of type generalFormRequest_430 must then be transmitted to receiver (the mirrored sender of this XML infoset).

[in] BSTR bstrPDFFile An optional PDF document that can be attached. The PDF is included inline coded as a Base64 stream.

Note that the PDF document transferred to the recipient is thereafter not included in the reply message stream anymore.

[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


  • IGeneralNotificationManager
  • GeneralNotificationRequest

IGeneralNotificationManager::GeneralNotificationRequest property
The property GetGeneralNotificationRequest supplies a pointer to the IGeneralNotificationRequest interface.

This interface pointer is needed to set the data of a new notification message/thread. If a reply to a received message is needed than just call the SetReply method.

space
C/C++ calling syntax
[get] HRESULT | GeneralNotificationRequest( IGeneralNotificationRequest **aIGeneralNotificationRequest);
space
Calling argument description
[out, retval] IGeneralNotificationRequest | **aIGeneralNotificationRequest
C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • IGeneralNotificationRequest **GetGeneralNotificationRequest(void);
space


  • IGeneralNotificationManager
  • ModuleLanguage

IGeneralNotificationManager::ModuleLanguage property
Get/Set the language for the module i.e. the language in which the error strings are coded.

Note, that the module language and the data language (given by IGeneralNotificationRequest::Initialize) are independent and can be different!

space
C/C++ calling syntax
[get] HRESULT | ModuleLanguage( LanguageType *aLanguageType);
[put] HRESULT | ModuleLanguage( LanguageType aLanguageType);
space
Calling argument description
[out,retval] LanguageType | *aLanguageType
[in] LanguageType | aLanguageType
C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • LanguageType *GetModuleLanguage(void);
  • void PutModuleLanguage( LanguageType aLanguageType);
space


  • IGeneralNotificationManager
  • ModuleVersion

IGeneralNotificationManager::ModuleVersion property
Get the version of the GeneralNotificationManager module. | space
C/C++ calling syntax
[get] HRESULT | ModuleVersion( BSTR *aBSTR);
space
Calling argument description
[out, retval] BSTR | *aBSTR
C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetModuleVersion(void);
space


  • IGeneralNotificationManager
  • ModuleVersionText

IGeneralNotificationManager::ModuleVersionText property
Get the textual version of the GeneralNotificationManager module. | space
C/C++ calling syntax
[get] HRESULT | ModuleVersionText( BSTR *aBSTR);
space
Calling argument description
[out, retval] BSTR | *aBSTR
C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetModuleVersionText(void);
space


  • IGeneralNotificationManager
  • Modus

IGeneralNotificationManager::Modus property
Get the operation modus.

The default modus is enProduction whereas for developing/debugging purposes enTest can be set.

space
C/C++ calling syntax
[get] HRESULT | Modus( ModusType *aModusType);
[put] HRESULT | Modus( ModusType aModusType);
space
Calling argument description
[out,retval] ModusType | *aModusType
[in] ModusType | aModusType
C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • ModusType *GetModus(void);
  • void PutModus( ModusType aModusType);
space


  • IGeneralNotificationManager
  • PrintCopies

IGeneralNotificationManager::PrintCopies property
Get/Set the number of copies to print. | space
C/C++ calling syntax
[get] HRESULT | PrintCopies( long *along);
[put] HRESULT | PrintCopies( long along);
space
Calling argument description
[out,retval] long | *along
[in] long | along
C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • long *GetPrintCopies(void);
  • void PutPrintCopies( long along);
space


  • IGeneralNotificationRequest

IGeneralNotificationRequest interface |  | V4.40/15 Nov 2013
The IGeneralNotificationRequest interface is used whenever a new message thread is started. All the data and parameters are set by the available interface methods like SetPatient, SetSender,... |  | space
Methods |  | 11 methods
AddInstruction | Adds an automation instruction to the list of instructions |
Finalize | Finalizes and validates all data set so far in the GeneralNotificationRequest interface |
GetAbortInfo | Get the abort information string with the error coded in the module language |
Initialize | Initializes all input data in the IGeneralNotificationRequest interface |
SetMessage | Sets the primary message that starts the notification thread |
SetNotification | Sets the primary notification object reference |
SetPatient | Sets the primary parameters and structured address of the patient if a patient is involved in the notification thread |
SetRecipient | Sets the various identifiers (EAN, ZSR,...) and the structured address of the recipient |
SetRefObject | Sets the optional depended object reference of type credit, invoice, reminder, MCD, or form for which this notification thread is actually started |
SetSender | Sets the various identifiers (EAN, ZSR,...) and the structured address of the sender |
SetTransport | Sets transport information that is the routing information going from a sender (from) over the first intermediate (via) to the receiver (to) |
Properties |  | 1 properties
[get] CreateAddress | Create an instance of the IAddress interface |


  • IGeneralNotificationRequest
  • AddInstruction

IGeneralNotificationRequest::AddInstruction method |  |  |
Adds an automation instruction to the list of instructions. The instruction is formatted as a token/value pair Note that these instructions are defined purely between sender and receiver regarding the semantic meaning. The infoset is just the transport container. Note also that even if the notification deals with such instructions, a meaningful message is still required as forced by the underlying XSD schema. |  |  | space
C/C++ calling syntax |  |  |
HRESULT AddInstruction( | long BSTR BSTR VARIANT_BOOL | lGroupNumber, bstrToken, bstrValue, *pbStatus); |
Calling argument description |  |  |
[in] long | lGroupNumber | The lGroupNumber allows to further group the instruction set by a group numbering scheme. |
[in] BSTR | bstrToken | The token part of the token/value formatted instruction |
[in] BSTR | bstrValue | The value part of the token/value formatted instruction |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralNotificationRequest
  • Finalize

IGeneralNotificationRequest::Finalize method |  |  |
Finalizes and validates all data set so far in the GeneralNotificationRequest interface. This method is the counterpart to the Initialize method. This method should be called after all data have been set in the IGeneralNotificationRequest interface. |  |  | space
C/C++ calling syntax |  |  |
HRESULT Finalize( | VARIANT_BOOL | *pbStatus); |
Calling argument description |  |  |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralNotificationRequest
  • GetAbortInfo

IGeneralNotificationRequest::GetAbortInfo method |  |  |
Get the abort information string with the error coded in the module language. Call this method whenever the returned pbStatus variable of the primarily called method is VARIANT_FALSE and the primarily called method is not an iterator (GetFirst/GetNext). In the later case VARIANT_FALSE signals the end of data. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetAbortInfo( | BSTR VARIANT_BOOL | *pbstrAbort, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrAbort | Abort information string coded in the module language. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error-in-error situation occurred. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralNotificationRequest
  • Initialize

IGeneralNotificationRequest::Initialize method |  |  |
Initializes all input data in the IGeneralNotificationRequest interface. This method is the counterpart to the Finalize method. This method should be called before any input is set in the IGeneralNotificationRequest interface. |  |  | space
C/C++ calling syntax |  |  |
HRESULT Initialize( | LanguageType YesNoType VARIANT_BOOL | eDataLanguage, eIsConfidential, *pbStatus); |
Calling argument description |  |  |
[in] LanguageType | eDataLanguage | Sets the language in which the data part is coded. It is exactly the language in which the response is formulated. Note, that the data language and the module language (given by IGeneralNotificationManager::SetModuleLanguage property) are independent and can be different! |
[in] YesNoType | eIsConfidential | A Boolean that defines if the notification thread is confidential. Note that the confidentiality status is defined at the moment of the initial XML infoset generation, thereafter it must be inherited into each new reply cycle. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralNotificationRequest
  • SetMessage

IGeneralNotificationRequest::SetMessage method |  |  |
Sets the primary message that starts the notification thread. Note that the form OID mechanism is a signal for the receiver to start a form process. In the Sumex1 environment the form OID is one from the medforms.ch space. |  |  | space
C/C++ calling syntax |  |  |
HRESULT SetMessage( | BSTR BSTR BSTR VARIANT_BOOL | bstrMessage, bstrFormOID, bstrPDFFile, *pbStatus); |
Calling argument description |  |  |
[in] BSTR | bstrMessage | The required message |
[in] BSTR | bstrFormOID | An optional form OID. The definition of such a form OID signals the receiver to start a form process using the given OID as form template and using the reference object and the sender, receiver data as additional input. The resulting XML infoset of type generalFormRequest_430 must then be transmitted to receiver (the mirrored sender of this XML infoset). |
[in] BSTR | bstrPDFFile | An optional PDF document that can be attached. The PDF is included inline coded as a Base64 stream. Note that the PDF document transferred to the recipient is thereafter not included in the reply message stream anymore. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralNotificationRequest
  • SetNotification

IGeneralNotificationRequest::SetNotification method |  |  |
Sets the primary notification object reference. The dependent object references form a object reference chain with the notification as topmost object reference. The page "object reference" provides an in-depth description of the concepts of "object reference", "object reference chain", and "topmost object reference". |  |  | space
C/C++ calling syntax |  |  |
HRESULT SetNotification( | BSTR DATE long VARIANT_BOOL | bstrNotificationID, dNotificationDate, lNotificationTimestamp, *pbStatus); |
Calling argument description |  |  |
[in] BSTR | bstrNotificationID | The notification ID is the main software's ID of the notification. This is one of 3 identifiers that constitute the notification object reference. |
[in] DATE | dNotificationDate | The notification date is the main software's date of the notification. This is one of 3 identifiers that constitute the notification object reference. |
[in] long | lNotificationTimestamp | This is a UNIX timestamp defined at the moment of the notification's infoset generation. Set this variable 0 to indicate the generation of a new notification object reference. The IGeneralNotificationManager::GetXML method will return the timestamp that must be used from that point on as 3rd parameter of the object reference. This is one of 3 identifiers that constitute the notification object reference. The timestamp will be generated once for a certain notification object reference and thereafter the timestamp is always referenced |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralNotificationRequest
  • SetPatient

IGeneralNotificationRequest::SetPatient method
Sets the primary parameters and structured address of the patient if a patient is involved in the notification thread. This is in principle true as soon as a dependent object reference is defined. In reverse this means that a dependent object reference must be defined as soon as a patient is defined.

The address is defined via a IAddress interface pointer and the address data must be defined prior to call this method.

Note that the patient as well as the dependent object reference data must stem from that dependent request infoset!

space
C/C++ calling syntax
HRESULT SetPatient( SexType
DATE
BSTR
IAddress
VARIANT_BOOL 		eSexType,
dBirthdate,
bstrSSN,
*pIAddress,
*pbStatus);
Calling argument description
[in] SexType | eSexType | The patient's gender.
[in] DATE | dBirthdate | The patient's birthdate.
[in] BSTR bstrSSN Defines the social security number (SSN) of the patient whereupon 3 distinguished types are allowed:
  • the old 11 digit Swiss SSN ("AHV-Nummer") as defined by Federal Social Insurance Office
  • the new 13 digit Swiss SSN ("SV-Nummer") beginning with 756 as defined by Federal Social Insurance Office
  • the new 4-10 digit SSN of Liechtenstein ("AHV-Nummer") as defined by Liechtensteinische AHV-IV-FAK
The SSN can be supplied in its printed (with dots) or electronic (only digits) form.
[in] IAddress | *pIAddress | Pointer to an IAddress interface instance that holds the structured address parts.
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


  • IGeneralNotificationRequest
  • SetRecipient

IGeneralNotificationRequest::SetRecipient method |  |  |
Sets the various identifiers (EAN, ZSR,...) and the structured address of the recipient. The address is defined via a IAddress interface pointer and the address data must be defined prior to call this method. |  |  | space
C/C++ calling syntax |  |  |
HRESULT SetRecipient( | BSTR BSTR BSTR IAddress VARIANT_BOOL | bstrEAN, bstrZSR, bstrSpecialty, *pIAddress, *pbStatus); |
Calling argument description |  |  |
[in] BSTR | bstrEAN | EAN number of the recipient as supplied by medwin.ch |
[in] BSTR | bstrZSR | Optional ZSR number of the recipient as supplied by santésuisse |
[in] BSTR | bstrSpecialty | An optional specialty, i.e. FMH title of the recipient |
[in] IAddress | *pIAddress | Pointer to an IAddress interface instance that holds the structured address parts. A NULL pointer is supplied if no address should be set. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralNotificationRequest
  • SetRefObject

IGeneralNotificationRequest::SetRefObject method
Sets the optional depended object reference of type credit, invoice, reminder, MCD, or form for which this notification thread is actually started.

This reference object forms an object reference chain with the notification as topmost object reference. The page "object reference" provides an in-depth description of the concepts of "object reference", "object reference chain", and "topmost object reference".

Note that the dependent object reference as well as the patient data must stem from that dependent request infoset!

space
C/C++ calling syntax
HRESULT SetRefObject( ObjectType
BSTR
DATE
long
VARIANT_BOOL 		eRefObjectType,
bstrRequestID,
dRequestDate,
lRequestTimestamp,
*pbStatus);
Calling argument description
[in] ObjectType | eRefObjectType | The type of the depended object reference.
[in] BSTR bstrRequestID The request ID is the main software's identification of the dependent reference object.

This is one of 3 identifiers that constitute this object reference.

[in] DATE dRequestDate The request date is the main software's date of the dependent reference object.

This is one of 3 identifiers that constitute this object reference.

[in] long lRequestTimestamp This is a UNIX timestamp defined at the moment of the dependent reference object's infoset generation.

This is one of 3 identifiers that constitute this object reference.

[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


  • IGeneralNotificationRequest
  • SetSender

IGeneralNotificationRequest::SetSender method |  |  |
Sets the various identifiers (EAN, ZSR,...) and the structured address of the sender. The address is defined via a IAddress interface pointer and the address data must be defined prior to call this method. |  |  | space
C/C++ calling syntax |  |  |
HRESULT SetSender( | BSTR BSTR BSTR IAddress VARIANT_BOOL | bstrEAN, bstrZSR, bstrSpecialty, *pIAddress, *pbStatus); |
Calling argument description |  |  |
[in] BSTR | bstrEAN | EAN number of the sender as supplied by medwin.ch |
[in] BSTR | bstrZSR | Optional ZSR number of the sender as supplied by santésuisse |
[in] BSTR | bstrSpecialty | An optional specialty, i.e. FMH title of the sender. |
[in] IAddress | *pIAddress | Pointer to an IAddress interface instance that holds the structured address parts. A NULL pointer is supplied if no address should be set. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralNotificationRequest
  • SetTransport

IGeneralNotificationRequest::SetTransport method |  |  |
Sets transport information that is the routing information going from a sender (from) over the first intermediate (via) to the receiver (to). All the involved parties are defined by EAN numbers as defined by www.medwin.ch. This method allows to sign and/or encrypt the resulting XML infoset. Therefore, read the notes about signature and encryption to get familiar with these concepts. |  |  | space
C/C++ calling syntax |  |  |
HRESULT SetTransport( | BSTR BSTR BSTR BSTR BSTR BSTR VARIANT_BOOL | bstrFromEAN, bstrFromPFXFile, bstrFromPFXPassword, bstrViaEAN, bstrToEAN, bstrToBinDERFile, *pbStatus); |
Calling argument description |  |  |
[in] BSTR | bstrFromEAN | The EAN number of the sender as supplied by medwin.ch |
[in] BSTR | bstrFromPFXFile | The file name of the PFX certificate that is the private certificate of the "from" entity. If the variable is empty or NULL then no signature is applied otherwise a signature might be applied depending on the lXMLGenerationAttributes of the GetXML method. |
[in] BSTR | bstrFromPFXPassword | The password to open the PFX certificate. The password is only used if a PFX certificate is supplied. |
[in] BSTR | bstrViaEAN | The EAN number of the first intermediate as supplied by medwin.ch |
[in] BSTR | bstrToEAN | The EAN number of the recipient as supplied by medwin.ch |
[in] BSTR | bstrToBinDERFile | The file name of the binary DER certificate that is the public certificate of the "to" entity. If the variable is empty or NULL then no encryption is applied otherwise encryption might be applied depending on the lXMLGenerationAttributes of the GetXML |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralNotificationRequest
  • CreateAddress

IGeneralNotificationRequest::CreateAddress property
Create an instance of the IAddress interface.

Any address is specified using properties and methods of this interface.

space
C/C++ calling syntax
[get] HRESULT | CreateAddress( IAddress **aIAddress);
space
Calling argument description
[out, retval] IAddress | **aIAddress
C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • IAddress **GetCreateAddress(void);
space


  • IGeneralNotificationResponse

IGeneralNotificationResponse interface |  | V4.40/15 Nov 2013
The IGeneralNotificationResponse interface allows to read back all data that have been set by the IGeneralInvoiceRequest interface or by loading a received XML infoset using the IGeneraNotificationManger::LoadXML method. Note that the successful usage of the IGeneralNotificationManager::SetReply method defines a singularity in the data space and the semantic interpretation of the data - cf. IGeneralNotificationManager::SetReply! |  | space
Methods |  | 12 methods
GetAbortInfo | Get the abort information string with the error coded in the module language |
GetFirstInstruction | Retrieves the first instruction as token/value pair |
GetFirstMessage | Retrieves the first notification message |
GetNextInstruction | Retrieves the next instruction as token/value pair |
GetNextMessage | Retrieves the next notification message |
GetNotification | Retrieves the main notification object reference parameters |
GetPatient | Retrieves the primary parameters and structured address of the patient |
GetRecipient | Retrieves the various identifiers (EAN, ZSR,...) and the structured address of the recipient |
GetRefObject | Retrieves the dependent object reference parameters if any was defined |
GetRequest | Retrieves the data language of the notification. |
GetSender | Retrieves the various identifiers (EAN, ZSR,...) and the structured address of the sender |
GetTransport | Returns the transport information that is the routing information going from a sender (from) over the first intermediate (via) to the receiver (to) |
Properties |  | 0 properties


  • IGeneralNotificationResponse
  • GetAbortInfo

IGeneralNotificationResponse::GetAbortInfo method |  |  |
Get the abort information string with the error coded in the module language. Call this method whenever the returned pbStatus variable of the primarily called method is VARIANT_FALSE and the primarily called method is not an iterator (GetFirst/GetNext). In the later case VARIANT_FALSE signals the end of data. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetAbortInfo( | BSTR VARIANT_BOOL | *pbstrAbort, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrAbort | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error-in-error situation occurred. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralNotificationResponse
  • GetFirstInstruction

IGeneralNotificationResponse::GetFirstInstruction method |  |  |
Retrieves the first instruction as token/value pair. VARIANT_FALSE is returned if the end of the instruction list is reached. Note that these instructions are defined purely between sender and receiver regarding the semantic meaning. The infoset is just the transport container. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetFirstInstruction( | long BSTR BSTR VARIANT_BOOL | *plGroupNumber, *pbstrToken, *pbstrValue, *pbStatus); |
Calling argument description |  |  |
[out] long | *plGroupNumber | The lGroupNumber allows to further group the instruction set by a group numbering scheme. Note that the instructions are returned in the same sequence as the input was done. Therefore, the grouping into equal instructions must be done outside the COM module. |
[out] BSTR | *pbstrToken | The token part of the token/value formatted instruction |
[out] BSTR | *pbstrValue | The value part of the token/value formatted instruction |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralNotificationResponse
  • GetFirstMessage

IGeneralNotificationResponse::GetFirstMessage method |  |  |
Retrieves the first notification message. VARIANT_FALSE is returned if the end of the message list is reached. Note that the very first message is the most recent one, any following messages are older by one message exchange. Therefore the message iterator forms a serialized message historization. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetFirstMessage( | BSTR BSTR DATE BSTR VARIANT_BOOL | *pbstrMessage, *pbstrFormOID, *pMessageDate, *pbstrPDFFile, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrMessage | The most recent message. |
[out] BSTR | *pbstrFormOID | An optional OID of a form. If this form OID is set then this signals to start a form process using the GeneralFormRequestManager430 COM module and thereby generating a generalFormRequest_430.xsd based XML infoset. The sender, receiver, and reference object must be copied and the given form OID used as PDF template. To ease and simplify that process the current generalNotification_430 XML infoset can be loaded directly info the GeneralFormRequestManager430 COM module |
[out] DATE | *pMessageDate | The date when the most recent message was generated. |
[out] BSTR | *pbstrPDFFile | An optional PDF document attached to the notification message. If the variable is not empty than the full path to the PDF is replied. The PDF must be copied away before the COM module is closed otherwise the PDF document is deleted. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralNotificationResponse
  • GetNextInstruction

IGeneralNotificationResponse::GetNextInstruction method |  |  |
Retrieves the next instruction as token/value pair. VARIANT_FALSE is returned if the end of the instruction list is reached. Note that these instructions are defined purely between sender and receiver regarding the semantic meaning. The infoset is just the transport container. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetNextInstruction( | long BSTR BSTR VARIANT_BOOL | *plGroupNumber, *pbstrToken, *pbstrValue, *pbStatus); |
Calling argument description |  |  |
[out] long | *plGroupNumber | The lGroupNumber allows to further group the instruction set by a group numbering scheme. Note that the instructions are returned in the same sequence as the input was done. Therefore, the grouping into equal instructions must be done outside the COM module. |
[out] BSTR | *pbstrToken | The token part of the token/value formatted instruction |
[out] BSTR | *pbstrValue | The value part of the token/value formatted instruction |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralNotificationResponse
  • GetNextMessage

IGeneralNotificationResponse::GetNextMessage method |  |  |
Retrieves the next notification message. VARIANT_FALSE is returned if the end of the message list is reached. Note that the any message supplied with that method is older by one message exchange. Therefore the message iterator forms a serialized message historization. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetNextMessage( | BSTR BSTR DATE VARIANT_BOOL | *pbstrMessage, *pbstrFormOID, *pMessageDate, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrMessage | The message on the current historization level. |
[out] BSTR | *pbstrFormOID | An optional OID of a form. This form OID must be ignored as it is just a historicized one. |
[out] DATE | *pMessageDate | The date when the message was generated. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralNotificationResponse
  • GetNotification

IGeneralNotificationResponse::GetNotification method |  |  |
Retrieves the main notification object reference parameters. The dependent object references (if supplied in the request) form a object reference chain with the notification as topmost object reference. The page "object reference" provides an in-depth description of the concepts of "object reference", "object reference chain", and "topmost object reference". |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetNotification( | BSTR DATE long VARIANT_BOOL | *pbstrNotificationID, *pdNotificationDate, *plNotificationTimestamp, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrNotificationID | The notification ID is the main software's identification of the notification. This is one of 3 identifiers that form the notification object reference. |
[out] DATE | *pdNotificationDate | The notification date is the main software's date of the notification. This is one of 3 identifiers that form the notification object reference. |
[out] long | *plNotificationTimestamp | This is a UNIX timestamp defined at the moment of the notification's infoset generation. This is one of 3 identifiers that form the notification object reference. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralNotificationResponse
  • GetPatient

IGeneralNotificationResponse::GetPatient method
Retrieves the primary parameters and structured address of the patient.

The address is defined via a IAddress interface pointer and the address data must be defined prior to call this method.

space
C/C++ calling syntax
HRESULT GetPatient( SexType
DATE
BSTR
IAddress
VARIANT_BOOL 		*peSexType,
*pdBirthdate,
*pbstrSSN,
**ppIAddress,
*pbStatus);
Calling argument description
[out] SexType | *peSexType | The patient's gender.
[out] DATE | *pdBirthdate | The patient's birthdate.
[out] BSTR *pbstrSSN The social security number (SSN) of the patient in its printed form whereupon 3 distinguished types are possible:
  • the old 11 digit Swiss SSN ("AHV-Nummer") as defined by Federal Social Insurance Office
  • the new 13 digit Swiss SSN ("SV-Nummer") beginning with 756 as defined by Federal Social Insurance Office
  • the new 4-10 digit SSN of Liechtenstein ("AHV-Nummer") as defined by Liechtensteinische AHV-IV-FAK
[out] IAddress **ppIAddress The IAddress interface handle that allows to get the structured address data back.
If no address is defined then the handle is NULL.
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then the patient data is undefined.
C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


  • IGeneralNotificationResponse
  • GetRecipient

IGeneralNotificationResponse::GetRecipient method |  |  |
Retrieves the various identifiers (EAN, ZSR,...) and the structured address of the recipient. Note that the recipient address is mirrored and becomes the sender address after calling IGeneralNotificationManager:SetReply. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetRecipient( | BSTR BSTR BSTR IAddress VARIANT_BOOL | *pbstrEAN, *pbstrZSR, *pbstrSpecialty, **ppIAddress, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrEAN | EAN number of the recipient as supplied by medwin.ch |
[out] BSTR | *pbstrZSR | Optional ZSR number of the receiver as supplied by santésuisse |
[out] BSTR | *pbstrSpecialty | The optional specialty, i.e. FMH title of the receiver. |
[out] IAddress | **ppIAddress | The IAddress interface handle that allows to get the structured address data back. If no address is defined then the handle is NULL. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralNotificationResponse
  • GetRefObject

IGeneralNotificationResponse::GetRefObject method |  |  |
Retrieves the dependent object reference parameters if any was defined. The dependent object references (if supplied in the request) form a object reference chain with the notification as topmost object reference. The page "object reference" provides an in-depth description of the concepts of "object reference", "object reference chain", and "topmost object reference". |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetRefObject( | ObjectType BSTR DATE long VARIANT_BOOL | *peRefObjectType, *pbstrRequestID, *pdRequestDate, *plRequestTimestamp, *pbStatus); |
Calling argument description |  |  |
[out] ObjectType | *peRefObjectType | The type of the depended object reference. |
[out] BSTR | *pbstrRequestID | The request ID is the main software's identification of the reminder ("Mahnnummer"). This is one of 3 identifiers that form this object reference. |
[out] DATE | *pdRequestDate | The request date is the main software's date of the dependent reference object. This is one of 3 identifiers that form this object reference. |
[out] long | *plRequestTimestamp | This is a UNIX timestamp defined at the moment of the dependent reference object. This is one of 3 identifiers that form this object reference. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then the referenced object data is undefined. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralNotificationResponse
  • GetRequest

IGeneralNotificationResponse::GetRequest method |  |  |
Retrieves the data language of the notification. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetRequest( | LanguageType YesNoType YesNoType YesNoType VARIANT_BOOL | *peDataLanguage, *peIsConfidential, *peIsXMLLoaded, *peIsSendDataset, *pbStatus); |
Calling argument description |  |  |
[out] LanguageType | *peDataLanguage | Is the language in which the data part is coded. It is exactly the language in which the notification is formulated. Note, that the data language and the module language (given by
[out] YesNoType | *peIsConfidential | A Boolean that defines if the notification thread is confidential. Note that the confidentiality status is defined at the moment of the initial XML infoset generation, thereafter it must be inherited into each new reply cycle. |
[out] YesNoType | *peIsXMLLoaded | A Boolean that defines if the data stem from a XML infoset (enYes) or if a new request was generated (enNo) using the IGeneralNotificationRequest interface. Note, that if eIsXMLLoaded=enYes then a reply can directly be made using the IGeneralNotificationManager:SetReply method. |
[out] YesNoType | *peIsSendDataset | A Boolean that defines if the data represents the input (enNo) or the output (enYes). This Boolean basically defines if the singularity in data space is reached meaning if the |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralNotificationResponse
  • GetSender

IGeneralNotificationResponse::GetSender method |  |  |
Retrieves the various identifiers (EAN, ZSR,...) and the structured address of the sender. Note that the sender address is mirrored and becomes the recipient address after calling IGeneralNotificationManager:SetReply. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetSender( | BSTR BSTR BSTR IAddress VARIANT_BOOL | *pbstrEAN, *pbstrZSR, *pbstrSpecialty, **ppIAddress, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrEAN | EAN number of the sender as supplied by medwin.ch |
[out] BSTR | *pbstrZSR | Optional ZSR number of the sender as supplied by santésuisse |
[out] BSTR | *pbstrSpecialty | The optional specialty, i.e. FMH title of the sender. |
[out] IAddress | **ppIAddress | The IAddress interface handle that allows to get the structured address data back. If no address is defined then the handle is NULL. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IGeneralNotificationResponse
  • GetTransport

IGeneralNotificationResponse::GetTransport method |  |  |
Returns the transport information that is the routing information going from a sender (from) over the first intermediate (via) to the receiver (to). All the involved parties are defined by EAN numbers as defined by www.medwin.ch. If the parameters for the signature and encryption were set then these data are returned as well otherwise the corresponding variables are empty. Note that the transport parameters are mirrored after calling IGeneralNotificationManager:SetReply. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetTransport( | BSTR BSTR BSTR BSTR VARIANT_BOOL | *pbstrFromEAN, *pbstrViaEAN, *pbstrToEAN, *pbstrToBinDERFile, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrFromEAN | The EAN number of the sender as supplied by medwin.ch |
[out] BSTR | *pbstrViaEAN | The EAN number of the first intermediate as supplied by medwin.ch |
[out] BSTR | *pbstrToEAN | The EAN number of the receiver as supplied by medwin.ch |
[out] BSTR | *pbstrToBinDERFile | The file name of the binary DER certificate that is the public certificate of the "to" entity. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • Type definitions

Builtin, composite & enumeration types |  | V4.40/15 Nov 2013
The following list shows ans defines all used data types either basic builtin, composite or enumeration types that are used in the interface of the ATL COM module. |  | space
Data types |  | 15 types
[enumeration] AddressType | Enumerates the defined address categories. |
[builtin] BSTR | A BSTR, known as basic or binary string, is a pointer to a wide character string used by Automation data manipulation functions |
[builtin] DATE | A value denoting a date and time |
[builtin] HRESULT | The HRESULT data type is a 32-bit value that is used to describe an error or warning. |
[builtin] IAddress | IAddress interface. |
[builtin] IGeneralNotificationRequest | The IGeneralNotificationRequest interface |
[builtin] IGeneralNotificationResponse | The IGeneralNotificationResponse interface |
[enumeration] LanguageType | Enumerates all supported languages. |
[builtin] long | A 4-byte integer value. |
[enumeration] ModusType | Enumerates the defined operation mode types |
[enumeration] ObjectType | Enumerates the defined reference object types. |
[enumeration] SexType | Enumerates the defined gender categories. |
[builtin] VARIANT_BOOL | A 16 bit Boolean (True/False) value was specified |
[enumeration] XMLGenerationAttributes | Enumerates the defined types of XML generation attributes |
[enumeration] YesNoType | Boolean enumerator. |


  • Type definitions
  • AddressType

AddressType enumeration type |  |
Enumerates the defined address categories. |  | space
Set of enumeration values |  | 3 elements
enAddressUndefined: 0 | Undefined or unknown address. |
enAddressPerson: 1 | Person's address. |
enAddressCompany: 2 | Company's address. |


  • Type definitions
  • BSTR

BSTR type |
A BSTR, known as basic or binary string, is a pointer to a wide character string used by Automation data manipulation functions. BSTRs are wide, double-byte (Unicode) strings on 32-bit Windows platforms. | space


  • Type definitions
  • DATE

DATE type |
A value denoting a date and time. DATEs are represented as double-precision numbers, where the integral part is the date and the fractional part represents the microseconds since midnight. The base of the DATE type is December 31, 1899.. | space


  • Type definitions
  • HRESULT

HRESULT type |
The HRESULT data type is a 32-bit value that is used to describe an error or warning. | space


  • Type definitions
  • IAddress

IAddress type |
IAddress interface. | space


  • Type definitions
  • IGeneralNotificationRequest

IGeneralNotificationRequest type |
The IGeneralNotificationRequest interface | space


  • Type definitions
  • IGeneralNotificationResponse

IGeneralNotificationResponse type |
The IGeneralNotificationResponse interface | space


  • Type definitions
  • LanguageType

LanguageType enumeration type |  |
Enumerates all supported languages. |  | space
Set of enumeration values |  | 3 elements
enGerman: 1 | German |
enFrench: 2 | French. |
enItalian: 3 | Italian |


  • Type definitions
  • long

long type |
A 4-byte integer value. | space


  • Type definitions
  • ModusType

ModusType enumeration type |  |
Enumerates the defined operation mode types |  | space
Set of enumeration values |  | 2 elements
enProduction: 0 | Production modus. |
enTest: 1 | Test modus - the data should not be forwarded to the receiver. |


  • Type definitions
  • ObjectType

ObjectType enumeration type |  |
Enumerates the defined reference object types. |  | space
Set of enumeration values |  | 6 elements
enObjectUndef: 0 | The object reference is undefined |
enObjectCredit: 1 | The object reference is of type "Credit" |
enObjectInvoice: 2 | The object reference is of type "Invoice" |
enObjectReminder: 3 | The object reference is of type "Reminder" |
enObjectMCD: 4 | The object reference is of type "MCD" |
enObjectForm: 5 | The object reference is of type "Form" |


  • Type definitions
  • SexType

SexType enumeration type |  |
Enumerates the defined gender categories. |  | space
Set of enumeration values |  | 2 elements
enMale: 0 | Male. |
enFemale: 1 | Female. |


  • Type definitions
  • VARIANT_BOOL

VARIANT_BOOL type |
A 16 bit Boolean (True/False) value was specified. A value of 0xFFFF (all bits 1) indicates True; a value of 0 (all bits 0) indicates False. No other values are valid. | space


  • Type definitions
  • XMLGenerationAttributes

XMLGenerationAttributes enumeration type |  |
Enumerates the defined types of XML generation attributes |  | space
Set of enumeration values |  | 2 elements
enGenerateWithoutSignature: 2 | The XML infoset is generated without applying a signature even if the signature parameters have been set by the IGeneralNotificationRequest::SetTransport method. |
enGenerateWithoutEncryption: 4 | The XML infoset is generated without applying encryption even if the encryption parameters have been set by the IGeneralNotificationRequest::SetTransport method. |


  • Type definitions
  • YesNoType

YesNoType enumeration type |  |
Boolean enumerator. |  | space
Set of enumeration values |  | 2 elements
enNo: 0 | No. |
enYes: 1 | Yes. |


 Sumex1 under a 64bit architecture...

All Sumex1 COM modules are written as 32bit managed C++ dll. As a consequence, a 64bit executable cannot load a 32bit COM dll into its process space due to the addressing differences.

Since some necessary underlying sub-modules are not available in a 64bit version, this problem must be addressed differently than by a 64bit compilation. As Microsoft suggests Sumex1 uses the out-of-process proxy approach where a 32bit COM server loads the 32bit COM dll into its process space and delegates each method call to the dll. Since a 32bit COM server exists in its own process space, the main 64bit process can handle the 64/32bit boundary without problems.

As a result, each 32bit Sumex1 COM dll has a 32bit COM server counterpart with the same name and an oopProxy prefix, e.g. oopProxyGeneralNotificationManager440.exe, where the prefix signifies the out-of-process proxy nature of the executable.

Any 64bit software now creates an instance of the 32bit oopProxy server and then calls the same methods and properties as with the 32bit COM dll. However, there is one crucial difference when using the oopProxy mechanism, namely the necessity to forcefully unload to the COM server at the end e.g. by using Marshal.ReleaseComObject() since the automatic garbage collection approach is too error prone.


 Notes about the encryption

XML Encryption is a specification, governed by a W3C recommendation, that defines how to encrypt the contents of an XML element. Although XML Encryption can be used to encrypt any kind of data, it is nonetheless known as "XML Encryption" because an XML element (either an EncryptedData or EncryptedKey element) contains or refers to the cipher text, keying information, and algorithms.

However, it is beyond the scope of this documentation to explain all details of a encryption or the encryption process. Detailed information about all aspects of encryption can be found at W3C.

Boundary conditions and critical aspects

  • the encryption is optional!
  • if an infoset is encrypted then the public certificate of the recipient must be used and this certificate is applied to the body element.

    Here recipient is used in terms of the communication and therefore is defined as the EAN entity given in the transport@to attribute
  • the namespace v1 of W3C http://www.w3.org/2001/04/xmlenc must be used- cf. XML Encryption Syntax and Processing
  • The encryption algorithm is fixed to PKCS1 (RSA-SHA1) (RFC 2437: RSA Cryptography Specifications)
  • The block encryption algorithm is fixed to Triple DES

The generalNotification module does obey all these conditions whenever encryption is "turned on" (cf. IGeneralNotificationRequest::SetTransport).


 VB code snippet for using the generalNotificationManager

Private Sub Notify_Click()

On Error GoTo Err_Trap

Dim bStatus As Boolean

'### GeneralNotificationManager interface
Dim generalNotificationManagerEx As GENERALNOTIFICATIONMANAGER440Lib.GeneralNotificationManager
Set generalNotificationManagerEx = New GeneralNotificationManager

'### GeneralNotificationRequest
Dim generalNotificationRequestEx As GENERALNOTIFICATIONMANAGER440Lib.GeneralNotificationRequest
Set generalNotificationRequestEx = generalNotificationManagerEx.GeneralNotificationRequest

'### initialize the request interface in germand and as confidential
bStatus = generalNotificationRequestEx.Initialize(enGerman, enYes)

Dim IAddress As GENERALNOTIFICATIONMANAGER440Lib.Address
Set IAddress = generalNotificationRequestEx.CreateAddress

'### set a ref object
Dim strRequestID As String
strRequestID = "id-222"
Dim dRequestDate As Date
dRequestDate = DateValue("2010-9-20")
Dim lRequestTimestamp As Long
lRequestTimestamp = 1316469600
bStatus = generalNotificationRequestEx.SetRefObject(enObjectCredit, strRequestID, dRequestDate, _
                                                    lRequestTimestamp)

'### set notification parameters
Dim strNotificationID As String
strNotificationID = "N3000"
Dim dNotificationDate As Date
dNotificationDate = DateValue("2010-9-21")
Dim lNotifiactionTimestamp As Long
lRequestTimestamp = 1316590422

bStatus = generalNotificationRequestEx.SetNotification(strNotificationID, dNotificationDate, _
                                                       lNotifiactionTimestamp)

'### set transform
Dim strFromEAN As String
strFromEAN = "2000000000001"
Dim strViaEAN As String
strViaEAN = "2011111111111"
Dim strToEAN As String
strToEAN = "2034567890222"

bStatus = generalNotificationRequestEx.SetTransport(strFromEAN, "", "", strViaEAN, strToEAN, "")

'### set sender
IAddress.Initialize
bStatus = IAddress.SetPerson("Aerztin", "Patricia", "Frau", "Dr. med.", "")
bStatus = IAddress.SetPostal("Arztgasse 17b5", "", "4000", "Basel", "BS", "")
bStatus = generalNotificationRequestEx.SetSender(strFromEAN, "", "Arzt", IAddress)

'### set recipient
IAddress.Initialize
bStatus = IAddress.SetCompany("Krankenkasse AG", "Sektion Basel", "")
bStatus = IAddress.SetPostal("Kassengraben 222", "", "4000", "Basel", "", "")
bStatus = generalNotificationRequestEx.SetRecipient(strToEAN, "", "", IAddress)

'### patient
IAddress.Initialize
Dim dBirthdate As Date
dBirthdate = DateValue("1950-1-1")
bStatus = IAddress.SetPerson("Muster", "Peter", "Herr", "", "c/o Mieter Karl")
bStatus = IAddress.SetPostal("Musterstrasse 5", "", "7304", "Maienfeld", "", "")
bStatus = generalNotificationRequestEx.SetPatient(eSex, dBirthdate, "756.1234.5678.90", IAddress)

'### set message
Dim strMessage As String
strMessage = "A test message!"
bStatus = generalNotificationRequestEx.SetMessage(strMessage, "")

bStatus = generalNotificationRequestEx.Finalize()

'### get the notification xml
Dim lXMLGenerationAttributes As Long
lXMLGenerationAttributes = 0
Dim strOutFile As String
Dim lValidationError As Long
lValidationError = 0
Dim lTimestamp As Long
lTimestamp = 0

Dim generalNotificationResponseEx As GENERALNOTIFICATIONMANAGER440Lib.GeneralNotificationResponse

bStatus = generalNotificationManagerEx.GetXML(lXMLGenerationAttributes, strOutFile, lValidationError, lTimestamp, _
                                              generalNotificationResponseEx)

Dim strTargetFile As String
strTargetFile = "GeneralNotificationExample.xml"
FileCopy strOutFile, strTargetFile

Exit Sub

Err_Trap:
    MsgBox "Error: " & Err.Description, vbCritical, _
           "Opps! Error" & Str$(Err.Number)
'### relase resources
Set generalNotificationResponseEx = Nothing
Set generalNotificationRequestEx = Nothing
Set generalNotificationManagerEx = Nothing

End Sub


 General use of the generalNotification ATL COM module

The generalNotificationManager is an ATL COM module which provides methods the generate an email like structured message exchange between to partners. The produced XML infoset is transported electronically to the recipient and can optionally can be signed and/or encrypted.

Furthermore, by using the formOID attribute of the message a form request process can be initiated at any point of the message exchange.

Architectural blueprint
Either a new notification is produced from scratch by using the IGeneralNotificationRequest interface or a received notification is loaded into the module by the LoadXML method and a reply to that message is generated thereafter. The all data can be visualized using the Print method.
New notification
To produce such an infoset, firstly an instance of the IGeneralNotificationRequest interface is retrieved by the property IGeneralNotificationManager::GetGeneralNotificationRequest. Thereafter the relevant data is set.

Reply to a notification
Firstly load the XML infoset by calling the IGeneralNotificationManager::LoadXML method. To view the data call the IGeneralNotificationManager::Print method. And lastly set a reply by using the IGeneralNotificationManager::SetReply method.

After all information is defined the data can be visualized by using the IGeneralNotificationManager::Print method. Eventually the data is transformed into a standards-compliant generalNotification XML infoset that is sent to the recipient over a intermediate.

To get a staring point with the generalNotification module there is a Visual Basic code snippet provided that can be used for generating a notification.


 How to generate PDF archive files of a notification

To generate PDF archive files of a notification in the generalNotificationManager use a special print object name (cf. Syntax of the printTemplate variable for an overview).

(PDF=PDF_file_to_generate;)
or
(PDF_NOPRINT=PDF_file_to_generate;)
is used as a print object name on the printTemplate variable of the Print method.

The "PDF" token means to print the notification and generate the PDF files, whereas the "PDF_NOPRINT" token only generates the PDF file without physical printing.
This object definition is only used while printing and is ignored in the preview mode!

In its simplest form this means

     BSTR bstrPrintTemplate = "(PDF="+bstrPDFFile+";)";

     IGeneralNotificationRequestManager::Print(bstrPrintTemplate,...);
in order to generate a PDF archive file of notification.

Since the PDF generation is not the main purpose of the Print method this PDF feature has NO error propagation. The generation is done on a best effort basis, errors are only dumped to the log file!

Boundary conditions:

  • Only active in printing mode
  • No error propagation
  • The supplied PDF archive name must not exist
  • The directory where the PDF is stored must be writable


 Syntax of the printTemplate variable of the Print method

bstrPrintTemplate argument of the IGeneralNotificationManager::Print is either empty or of the general form given below.

If the bstrPrintTemplate variable is empty then the default print template (using the data language as language switch) is used.
However, bstrPrintTemplate can be used to change the normal printing behavior or changing printing objects dynamically. The following syntax is used as content of the bstrPrintTemplate variable:

[logTpl][(objectName1=text;...)][=printTemplateFile][#INIPATH=inipath]

where a [] pair defines an optional part. The commands are case insensitive.
  • logTpl: is the logical template name. Currently only logTpl=Detail is allowed.
  • objectName1=text; does a substitution of the content of the print object objectName1 by text. A print object is terminated by a semicolon and all print objects are enclosed in a () pair.

    There is a predefined pseudo print object with a special meaning:

    • PDF for generating PDF files

  • printTemplateFile is an external print template file name (full path + name!). If an external print template is supplied it must be mapped against a logical template. Therefore detail=full_vps_file must be used!
  • #INIPATH=inipath defines a fully qualified path to a directory where the report engine searches the corresponding .vpd print template INI file. This allows for global settings of a print template in a LAN. The default inipath is the install directory of the Dll

Here are some usage examples:
  • bstrPrintTemplate: "" or bstrPrintTemplate: Detail
    denotes a standard printing situation
  • bstrPrintTemplate: (DOCUMENT_TITLE=Alternate title for the notification;) prints a substituted title as given above.
  • bstrPrintTemplate: detail=C:\myForms\myPrintForm.vps
    uses the print template "C:\myForms\myPrintForm.vps". An optional INI file with the name "C:\myForms\myPrintForm.vpd" is searched under this condition.
  • bstrPrintTemplate: #INIPATH=\\host1\\myForms\
    the default path for the ini files (place of the installed component) is changed to "\\host1\\myForms\". If "\\host1\\myForms\" is accessible by all hosts of the LAN then the same INI settings can be used.


 Object reference...

The following paragraphs defines the concepts of object reference, object reference chain, and topmost object reference. These concepts are of high importance within the XML request/response system.

object reference

An object reference is an identification of an individual XML request defined by a unique triple of data, namely
  • timestamp (UNIX time) defined at the moment of generation
  • date of the object defined by the provider
  • id of the object defined by the provider
Each and every XML request of version 4.4 is defined by such an object reference. All XML responses are replies to the object reference of the corresponding request.

Thus the object reference is a clustered primary key of the request/response system!

object reference chain

As a consequence of the XML schema coded business logic most XML request schemas define more than just 1 object reference, e.g. a "generalNotification" needs 2 object references, namely
  • a optional object reference from another process, e.g. "General Invoice Request" or "General Credit Request"
  • a mandatory notification object reference from the main " General Notification " process
This set of object references by itself defines an ordered object reference chain (e.g. invoice -> notification) with the topmost object reference as unique identification of the XML request. Therefore the object reference chain defines -on business logic point of view- dependencies among different XML requests.

topmost object reference

The end node of an object reference chain is defined as topmost object reference, that is by definition the object reference of the XML request itself. Each request/response communication is always done for this topmost object reference and only for that.


 Notes about the signature

XML signatures are digital signatures designed for use in XML transactions. The W3C standard defines a schema for capturing the result of a digital signature operation applied to an infoset. XML signatures add authentication, data integrity, and support for non-repudiation to the data that they sign.
However, it is beyond the scope of this documentation to explain all details of a signature or the signing process. Detailed information about all aspects of signatures can be found at W3C.

Boundary conditions and critical aspects

  • the signature is optional!
  • if an infoset is signed then the private certificate of the sender must be used and this certificate is applied to the payload element. This inherently qualifies for a detached signature.

    In this context sender is used in terms of the communication and therefore is defined as the EAN entity given in the transport@from attribute

  • the URI attribute of the reference element must use a XPointer syntax of the payload element, e.g. <ds:Reference URI="#xpointer(/notification:notification/notification:payload)">
  • it is recommended to add the public key via a X509Data element such that a key store can be built at the recipient's site
  • The signature algorithm is fixed to PKCS1 (RSA-SHA1) (RFC 2437: RSA Cryptography Specifications)
  • The digest algorithm is fixed to SHA-1
  • the used canonicalization algorithm must be http://www.w3.org/2001/10/xml-exc-c14n#, the exclusive XML Canonicalization

The generalNotification module does obey all these conditions whenever signature is "turned on" by setting the private certificate and password of the "fromEAN" entity (cf. IGeneralNotificationRequest::SetTransport). This certificate must be in the PFX format.