 API browser of hospitalMCDRequest450 COM module
Interface version: | 4.50
Interface date: | 2 Sep 2016

The HospitalMCDRequestManager is an ATL COM module which provides methods to generate a Minimal Clinical Dataset (MCD) that basically defines the required input to a DRG grouper.

The MCD is printed or a XML infoset is produced which can be transported electronically to the recipient. In the latter case the MCD optionally can be signed and/or encrypted .

Due to the processing attributes "storno" and "copy" a previously generated MCD can be canceled or a copy can be produced.

The subchapter object reference provides an in-depth description of the concept of "object reference".

space
Interfaces | 4 interface
IAddress | The utility interface IAddress is available for setting and retrieving structured address data.
IHospitalMCDRequest | With the IHospitalMCDRequest interface all MCD related data can be set/defined by the interface's methods.
IHospitalMCDRequestManager | The main interface IHospitalMCDRequestManager -creatable in its own right- provides methods to generate a Minimal Clinical Dataset (MCD) or load such an MCD back into memory.
IHospitalMCDResult | The interface IHospitalMCDResult allows to read back all data that have been defined with the IHospitalMCDRequest interface object or by loading a previously generated XML infoset.
Types
type definitions | List of all used builtin, composite and enumeration types
Important information about the usage and handling of the module
Document | General usage of the hospitalMCDRequest450 COM module - an overview
Document | Overview of the changes from hospitalMCDRequest440 to hospitalMCDRequest450
Document | What to do in a 64bit environment - is there a 64bit Sumex1 COM dll?
Document | Overview of the concept of "Object reference"
Document | Notes about the processing attributes
Document | Notes about the signature part of the XML infoset
Document | Notes about the encryption part of the XML infoset
Document | Syntax of the printTemplate variable of the Print method
Document | How to generate a PDF archive file of a MCDRequest
Document | How to print electronic stamps onto a MCDRequest
Document | VB code snippet for using the hospitalMCDResponse450 COM module

© by sumex1.net - all rights reserved


  • hospitalMCDRequest450
  • IAddress

IAddress interface |  | V4.50/ 2 Sep 2016
With the IAddress interface structured address data can be set and retrieved. The whole address can be seen as a collection of substructures like the name, the postal part, a communication part etc. Where each of these sub structure can be set or retrieved by an interface method. The name part of a person is set by the method SetPerson and a company's name is entered by the method SetCompany. Before setting a new address the internal data has to be initialized by the method Initialize. |  | space
Methods |  | 15 methods
AddPhone | Adds a structured phone number |
GetAbortInfo | Get the abort information string with the error coded in the module language |
GetCompany | Retrieves the company's naming part of the address |
GetFax | Retrieves the structured fax number |
GetFirstPhone | Retrieves the first phone number information |
GetNextPhone | Retrieves the next phone number information |
GetOnline | Retrieves the structured online part of the address |
GetPerson | Retrieves the person's naming part of the address |
GetPostal | Retrieves the structured postal address part of the address. |
Initialize | Initializes all internal address variables |
SetCompany | Sets the company's naming part of the address |
SetFax | Sets a structured fax number |
SetOnline | Sets the structured online part of the address. |
SetPerson | Sets the person's naming part of the address |
SetPostal | Sets the structured postal address part |
Properties |  | 1 properties
[get] Type | GetType returns the type of address either enAddressPerson or enAddressCompany if an address is defined at all |


  • IAddress
  • AddPhone

IAddress::AddPhone method |  |  |
Adds a structured phone number. The Swiss international calling code +41 is filtered out in the printing. If the main software does not support structured pone numbers then all data is supplied in the bstrNumber variable. However, +41 is then no longer filtered. |  |  | space
C/C++ calling syntax |  |  |
HRESULT AddPhone( | BSTR BSTR BSTR BSTR VARIANT_BOOL | bstrNumber, bstrLocalCode, bstrInternationalCode, bstrExt, *pbStatus); |
Calling argument description |  |  |
[in] BSTR | bstrNumber | The pure phone number part of the telephone number. It is possible to set the full telephone number in this variable and leave the other parts of the telephone number empty |
[in] BSTR | bstrLocalCode | The local area code part of the telephone number. |
[in] BSTR | bstrInternationalCode | The international calling code part of the telephone number. |
[in] BSTR | bstrExt | The optional extension number part of the telephone number. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IAddress
  • GetAbortInfo

IAddress::GetAbortInfo method |  |  |
Get the abort information string with the error coded in the module language. Call this method whenever the returned pbStatus variable of the primarily called method is VARIANT_FALSE and the primarily called method is not an iterator (GetFirst/GetNext). In the later case VARIANT_FALSE signals the end of data. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetAbortInfo( | BSTR VARIANT_BOOL | *pbstrAbort, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrAbort | Abort information string coded in the module language. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error-in-error situation occurred. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IAddress
  • GetCompany

IAddress::GetCompany method |  |  |
Retrieves the company's naming part of the address. Call the property GetType first to test if GetPerson or GetCompany should be called. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetCompany( | BSTR BSTR BSTR VARIANT_BOOL | *pbstrCompanyName, *pbstrDepartment, *pbstrSubaddressing, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrCompanyName | The company's name. |
[out] BSTR | *pbstrDepartment | The optional department part of the company. |
[out] BSTR | *pbstrSubaddressing | The optional subaddressing information, e.g. a "c/o" like information as defined by the Post |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IAddress
  • GetFax

IAddress::GetFax method |  |  |
Retrieves the structured fax number. Empty variables are returned if there is no fax number available. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetFax( | BSTR BSTR BSTR BSTR VARIANT_BOOL | *pbstrNumber, *pbstrLocalCode, *pbstrInternationalCode, *pbstrExt, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrNumber | The pure fax number part of the full fax number. It is possible that the full fax number is returned in this variable and the other parts of the fax number left empty. |
[out] BSTR | *pbstrLocalCode | The local area code part of the fax number. |
[out] BSTR | *pbstrInternationalCode | The international calling code part of the fax number. |
[out] BSTR | *pbstrExt | The extension number part of the fax number. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IAddress
  • GetFirstPhone

IAddress::GetFirstPhone method |  |  |
Retrieves the first phone number information. VARIANT_FALSE is returned if the end of the phone list is reached. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetFirstPhone( | BSTR BSTR BSTR BSTR VARIANT_BOOL | *pbstrNumber, *pbstrLocalCode, *pbstrInternationalCode, *pbstrExt, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrNumber | The pure phone number part of the full telephone number. It is possible that the full telephone number is returned in this variable and the other parts of the telephone number left empty. |
[out] BSTR | *pbstrLocalCode | The local area code part of the telephone number. |
[out] BSTR | *pbstrInternationalCode | The international calling code part of the telephone number. |
[out] BSTR | *pbstrExt | the extension number part of the telephone number. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IAddress
  • GetNextPhone

IAddress::GetNextPhone method |  |  |
Retrieves the next phone number information. VARIANT_FALSE is returned if the end of the phone list is reached |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetNextPhone( | BSTR BSTR BSTR BSTR VARIANT_BOOL | *pbstrNumber, *pbstrLocalCode, *pbstrInternationalCode, *pbstrExt, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrNumber | The pure phone number part of the full telephone number. It is possible that the full telephone number is returned in this variable and the other parts of the telephone number left empty. |
[out] BSTR | *pbstrLocalCode | The local area code part of the telephone number. |
[out] BSTR | *pbstrInternationalCode | The international calling code part of the telephone number. |
[out] BSTR | *pbstrExt | the extension number part of the telephone number. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IAddress
  • GetOnline

IAddress::GetOnline method |  |  |
Retrieves the structured online part of the address. Empty variables are returned if there is no online information available. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetOnline( | BSTR BSTR VARIANT_BOOL | *pbstrEMail, *pbstrUrl, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrEMail | A relevant email address. |
[out] BSTR | *pbstrUrl | A relevant URL. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IAddress
  • GetPerson

IAddress::GetPerson method |  |  |
Retrieves the person's naming part of the address. Call the property GetType first to test if GetPerson or GetCompany should be called. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetPerson( | BSTR BSTR BSTR BSTR BSTR VARIANT_BOOL | *pbstrFamilyname, *pbstrGivenname, *pbstrSalutation, *pbstrTitle, *pbstrSubaddressing, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrFamilyname | The family name (or last name) of the person. |
[out] BSTR | *pbstrGivenname | The given name (or first name) of the person. |
[out] BSTR | *pbstrSalutation | The optional salutation of the person. |
[out] BSTR | *pbstrTitle | The optional title of the person. |
[out] BSTR | *pbstrSubaddressing | The optional subaddressing information, e.g. a "c/o" like information as defined by the Post |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IAddress
  • GetPostal

IAddress::GetPostal method |  |  |
Retrieves the structured postal address part of the address. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetPostal( | BSTR BSTR BSTR BSTR BSTR BSTR VARIANT_BOOL | *pbstrStreet, *pbstrPoBox, *pbstrZip, *pbstrCity, *pbstrStateCode, *pbstrCountryCode, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrStreet | The street name part of an address. |
[out] BSTR | *pbstrPoBox | The P.O. box code part of an address. Note that according to the Post the street and poBox parts should be used mutually exclusive. |
[out] BSTR | *pbstrZip | The ZIP code part of an address. |
[out] BSTR | *pbstrCity | The city name of an address. |
[out] BSTR | *pbstrStateCode | The optional state code part of an address. |
[out] BSTR | *pbstrCountryCode | The optional ISO country code part of an address. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IAddress
  • Initialize

IAddress::Initialize method |  |  |
Initializes all internal address variables. This method should be called before new data is supplied to reset all internally stored data. |  |  | space
C/C++ calling syntax |  |  |
HRESULT Initialize( | VARIANT_BOOL | *pbStatus); |
Calling argument description |  |  |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IAddress
  • SetCompany

IAddress::SetCompany method |  |  |
Sets the company's naming part of the address. Note that the subaddressing is part of the extended name and is always printed before any postal information. |  |  | space
C/C++ calling syntax |  |  |
HRESULT SetCompany( | BSTR BSTR BSTR VARIANT_BOOL | bstrCompanyName, bstrDepartment, bstrSubaddressing, *pbStatus); |
Calling argument description |  |  |
[in] BSTR | bstrCompanyName | The company's name. |
[in] BSTR | bstrDepartment | The optional department part of the company. |
[in] BSTR | bstrSubaddressing | The optional subaddressing information, e.g. a "c/o" like information as defined by the Post |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IAddress
  • SetFax

IAddress::SetFax method |  |  |
Sets a structured fax number. The Swiss international calling code +41 is filtered in the printing. If the main software does not support structured pone numbers then all data is supplied in the bstrNumber variable. However, +41 is then no longer filtered. |  |  | space
C/C++ calling syntax |  |  |
HRESULT SetFax( | BSTR BSTR BSTR BSTR VARIANT_BOOL | bstrNumber, bstrLocalCode, bstrInternationalCode, bstrExt, *pbStatus); |
Calling argument description |  |  |
[in] BSTR | bstrNumber | The pure fax number part of the fax number. It is possible to set the full fax number in this variable and leave the other parts of the fax number empty |
[in] BSTR | bstrLocalCode | The local area code part of the fax number. |
[in] BSTR | bstrInternationalCode | The international calling code part of the fax number. |
[in] BSTR | bstrExt | The extension number part of the fax number. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IAddress
  • SetOnline

IAddress::SetOnline method |  |  |
Sets the structured online part of the address. |  |  | space
C/C++ calling syntax |  |  |
HRESULT SetOnline( | BSTR BSTR VARIANT_BOOL | bstrEMail, bstrUrl, *pbStatus); |
Calling argument description |  |  |
[in] BSTR | bstrEMail | A relevant email address. |
[in] BSTR | bstrUrl | A relevant URL address. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IAddress
  • SetPerson

IAddress::SetPerson method |  |  |
Sets the person's naming part of the address. Note that the subaddressing is part of the extended name and is always printed before any postal information. |  |  | space
C/C++ calling syntax |  |  |
HRESULT SetPerson( | BSTR BSTR BSTR BSTR BSTR VARIANT_BOOL | bstrFamilyname, bstrGivenname, bstrSalutation, bstrTitle, bstrSubaddressing, *pbStatus); |
Calling argument description |  |  |
[in] BSTR | bstrFamilyname | The family name (or last name) of the person. |
[in] BSTR | bstrGivenname | The given name (or first name) of the person. |
[in] BSTR | bstrSalutation | The optional salutation of the person. |
[in] BSTR | bstrTitle | The optional title of the person. |
[in] BSTR | bstrSubaddressing | The optional subaddressing information, e.g. a "c/o" like information as defined by the Post |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IAddress
  • SetPostal

IAddress::SetPostal method |  |  |
Sets the structured postal address part. The Swiss ISO county code is the default but is filtered in the printing. |  |  | space
C/C++ calling syntax |  |  |
HRESULT SetPostal( | BSTR BSTR BSTR BSTR BSTR BSTR VARIANT_BOOL | bstrStreet, bstrPoBox, bstrZip, bstrCity, bstrStateCode, bstrCountryCode, *pbStatus); |
Calling argument description |  |  |
[in] BSTR | bstrStreet | The street name part of an address. |
[in] BSTR | bstrPoBox | The P.O. box code part of an address. Note that according to the Post the street and poBox parts should be used mutually exclusive. |
[in] BSTR | bstrZip | The mandatory ZIP code part of an address. |
[in] BSTR | bstrCity | The mandatory city name of an address. |
[in] BSTR | bstrStateCode | The optional state code part of an address. |
[in] BSTR | bstrCountryCode | The ISO country code of an address. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IAddress
  • Type

IAddress::Type property
GetType returns the type of address either enAddressPerson or enAddressCompany if an address is defined at all.

If no address is defined then enAddressUndefined is returned.

space
C/C++ calling syntax
[get] HRESULT | Type( AddressType *aAddressType);
space
Calling argument description
[out, retval] AddressType | *aAddressType
C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • AddressType *GetType(void);
space


  • IHospitalMCDRequest

IHospitalMCDRequest interface |  | V4.50/ 2 Sep 2016
With the IHospitalMCDRequest interface all MCD related data can be set by the interface's methods. Alternatively, the data of a previously generated XML infoset can be loaded with the IHospitalMCDRequestManager::LoadXML method and thereafter these interface methods allow to change the data appropriately. |  | space
Methods |  | 20 methods
AddBfSRecord | Adds a BfS record to the list of BfS records |
AddDiagnosis | Adds a diagnosis to the list of diagnoses |
AddDocument | Attaches a PDF, JPG or PNG document -either inline or online- to the list of documents |
AddGrouperRecord | Adds a Grouper record to the list of Grouper records |
AddProcedure | Adds a procedure to the list of procedures. |
AddService | Adds one DRG service for which the MCD is defined |
Finalize | Finalizes and validates all data set so far in the IHospitalMCDRequest interface |
GetAbortInfo | Get the abort information string with the error coded in the module language |
Initialize | Initializes all input data in the IHospitalMCDRequest interface |
SetBiller | Sets the biller's various identifiers (EAN, ZSR,...) as well as the structured address |
SetGrouperData | Sets the grouper relevant global parameters |
SetInsurance | Sets the insurance's EAN as well as the structured address |
SetInvoice | Sets the invoice object reference for which the MCD is produced |
SetMCD | Sets the main MCD object reference that is it uniquely characterizes this XML infoset |
SetPackage | Defines the identification parameters of the main software. |
SetPatient | Sets the primary parameters of the patient that are necessary for the DRG grouper. |
SetProvider | Sets the provider's various identifiers (EAN, ZSR,...) as well as the structured address |
SetRequest | Defines the processing parameters, namely the "storno" and "copy" status besides an optional remark |
SetTransport | Sets transport information that is the routing information going from a sender (from) over the first intermediate (via) to the receiver (to) |
SetTreatment | Sets the basic treatment parameters |
Properties |  | 1 properties
[get] CreateAddress | Creates an instance of the IAddress interface |


  • IHospitalMCDRequest
  • AddBfSRecord

IHospitalMCDRequest::AddBfSRecord method
Adds a BfS record to the list of BfS records.

This basically means that a number=name pair in the used data language) from a certain BfS code is supplied, whereas the allowed value space is defined in the "hospital statistics" catalog of the BfS.

Please note, that the input of one BfS record per BfS record type is mandatory to become standard compliant with hospitalMCDRequest_440, whereas in hospitalMCDRequest_450 BfS records have been deleted due to a request of the Federal Data Protection and Information Commissioner (FDPIC). Thus, if you plan to downgrade to version 440 carry out this method.

space
C/C++ calling syntax
HRESULT AddBfSRecord( BfSRecordType
long
BSTR
VARIANT_BOOL 		eBfSRecordType,
lNumber,
bstrName,
*pbStatus);
Calling argument description
[in] BfSRecordType eBfSRecordType The type of BfS record for which the number=name pair is supplied.

Please note, that it is mandatory to input one BfS record per BfSRecordType.

[in] long | lNumber | The number part of a number=name pair.
[in] BSTR | bstrName | The name part of a number=name pair.
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


  • IHospitalMCDRequest
  • AddDiagnosis

IHospitalMCDRequest::AddDiagnosis method |  |  |
Adds a diagnosis to the list of diagnoses. Note, that the first added diagnosis is per definition the main diagnosis! |  |  | space
C/C++ calling syntax |  |  |
HRESULT AddDiagnosis( | BSTR BSTR BSTR BSTR VARIANT_BOOL | bstrCode, bstrText, bstrCatalog, bstrRemark, *pbStatus); |
Calling argument description |  |  |
[in] BSTR | bstrCode | The code of the diagnosis as defined in the diagnoses catalog. |
[in] BSTR | bstrText | The textual description of the diagnosis as given in the diagnoses catalog. |
[in] BSTR | bstrCatalog | The used catalog that lists the diagnosis e.g. "ICD-10-GM 2016". Note that the diagnosis catalog is an input element for the DRG Grouper process as well. |
[in] BSTR | bstrRemark | An optional remark |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IHospitalMCDRequest
  • AddDocument

IHospitalMCDRequest::AddDocument method
Attaches a PDF, JPG or PNG document -either inline or online- to the list of documents.

Internally, the inline document will be transformed to a BASE64 octet representation to safeguard the binary nature of the file.

space
C/C++ calling syntax
HRESULT AddDocument( YesNoType
BSTR
BSTR
BSTR
VARIANT_BOOL 		eIsURL,
bstrSource,
bstrTitle,
bstrMimeType,
*pbStatus);
Calling argument description
[in] YesNoType | eIsURL | Boolean that defines if the document is added online using a URL (enYes) or inline as Base64 coded stream (enNo).
[in] BSTR bstrSource If eIsURL = enYes then bstrSource is a URL for accessing the document online.

If eIsURL = enNo then bstrSource is a full file name (path + name) of the primary document. Be sure, that privileges allows opening and reading the file since the content is internally BASE64 coded.

[in] BSTR | bstrTitle | bstrTitle is the document's title on the primary system and thus describes the document in terms of its semantic content.
[in] BSTR bstrMimeType The MIME type of the document. The MIME type enables applications to define the format and eventually read the file (cf. RFC 2046 standardizes and names the commonly used MIME types).

Since the underlying XSD schema restricts the type of files, the MIME type must>/b> be one of

  • application/pdf for PDF files, , and image/png
  • image/jpeg for JPG graphic files
  • image/png for PNG graphic files
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


  • IHospitalMCDRequest
  • AddGrouperRecord

IHospitalMCDRequest::AddGrouperRecord method
Adds a Grouper record to the list of Grouper records.

This list of Grouper records basically defines a required input to a DRG Grouper. As a consequence 3 Grouper records must be supplied - one for each type of the GrouperRecordType enumeration list.

The input data is supplied in the used data language whereas the allowed value space stems from the Forum Datenaustausch/Generic list.

space
C/C++ calling syntax
HRESULT AddGrouperRecord( GrouperRecordType
long
BSTR
VARIANT_BOOL 		eGrouperRecordType,
lNumber,
bstrName,
*pbStatus);
Calling argument description
[in] GrouperRecordType eGrouperRecordType The type of Grouper record for which the number=name pair is supplied.

Please note, that it is mandatory to input one Grouper record per GrouperRecordType .

[in] long lNumber The number part of a number=name pair

For example, the 2nd choice of the grouper provider type (enGrouperProviderType) is Maison des naissances in french. Therefore to code this combination use number="1" and name="Maison des naissances" for language="french".

[in] BSTR bstrName The name part of a number=name pair

For example, the 2nd choice of the grouper provider type (enGrouperProviderType) is Maison des naissances in french. Therefore to code this combination use number="1" and name="Maison des naissances" for language="french".

[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


  • IHospitalMCDRequest
  • AddProcedure

IHospitalMCDRequest::AddProcedure method |  |  |
Adds a procedure to the list of procedures. |  |  | space
C/C++ calling syntax |  |  |
HRESULT AddProcedure( | BSTR BSTR BSTR SideType DATE BSTR VARIANT_BOOL | bstrCode, bstrText, bstrCatalog, eSideType, dDate, bstrRemark, *pbStatus); |
Calling argument description |  |  |
[in] BSTR | bstrCode | The code of the procedure as defined in the procedure catalog. |
[in] BSTR | bstrText | Textual description of the procedure code as given in the procedure catalog. |
[in] BSTR | bstrCatalog | The used catalog that lists the procedures e.g. "CHOP 11" Note that the procedure catalog is an input element for the DRG Grouper process as well. |
[in] SideType | eSideType | The side dependency of the applied procedure |
[in] DATE | dDate | The date when the procedure was applied. |
[in] BSTR | bstrRemark | An optional remark |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IHospitalMCDRequest
  • AddService

IHospitalMCDRequest::AddService method |  |  |
Adds one DRG service for which the MCD is defined. Please note, that the input of a DRG record is mandatory to become standard compliant with hospitalMCDRequest_440, whereas in hospitalMCDRequest_450 the DRG record has been deleted due to a request of the Federal Data Protection and Information Commissioner (FDPIC). Thus, if you plan to downgrade to version 440 carry out this method. |  |  | space
C/C++ calling syntax |  |  |
HRESULT AddService( | BSTR BSTR BSTR VARIANT_BOOL | bstrTariffType, bstrCode, bstrText, *pbStatus); |
Calling argument description |  |  |
[in] BSTR | bstrTariffType | The official tariff number of the DRG service catalog. |
[in] BSTR | bstrCode | The code of the DRG service. |
[in] BSTR | bstrText | The textual description of the DRG service. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IHospitalMCDRequest
  • Finalize

IHospitalMCDRequest::Finalize method |  |  |
Finalizes and validates all data set so far in the IHospitalMCDRequest interface. This method is the counterpart to the Initialize method. This method should be called after all data have been set in the IHospitalMCDRequest interface since higher-level validation rules can only be called at the end of input phase. Therefore, be prepared to get validation errors at that point. |  |  | space
C/C++ calling syntax |  |  |
HRESULT Finalize( | VARIANT_BOOL | *pbStatus); |
Calling argument description |  |  |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IHospitalMCDRequest
  • GetAbortInfo

IHospitalMCDRequest::GetAbortInfo method |  |  |
Get the abort information string with the error coded in the module language. Call this method whenever the returned pbStatus variable of the primarily called method is VARIANT_FALSE and the primarily called method is not an iterator (GetFirst/GetNext). In the later case VARIANT_FALSE signals the end of data. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetAbortInfo( | BSTR VARIANT_BOOL | *pbstrAbort, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrAbort | Abort information string coded in the module language. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error-in-error situation occurred. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IHospitalMCDRequest
  • Initialize

IHospitalMCDRequest::Initialize method |  |  |
Initializes all input data in the IHospitalMCDRequest interface. This method is the counterpart to the Finalize method. This method should be called before any input is set in the IHospitalMCDRequest interface. |  |  | space
C/C++ calling syntax |  |  |
HRESULT Initialize( | LanguageType VARIANT_BOOL | eDataLanguage, *pbStatus); |
Calling argument description |  |  |
[in] LanguageType | eDataLanguage | Sets the language in which the data part is coded. It is exactly the language in which the response is formulated. Note, that the data language and the module language (given by IHospitalMCDRequestManager::SetModuleLanguage) are independent and can be different! |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IHospitalMCDRequest
  • SetBiller

IHospitalMCDRequest::SetBiller method |  |  |
Sets the biller's various identifiers (EAN, ZSR,...) as well as the structured address. The structured address is defined via a IAddress interface instance and the address data must be defined prior to call this method. |  |  | space
C/C++ calling syntax |  |  |
HRESULT SetBiller( | BSTR BSTR BSTR BSTR IAddress VARIANT_BOOL | bstrEAN, bstrZSR, bstrNIF, bstrSpecialty, *pIAddress, *pbStatus); |
Calling argument description |  |  |
[in] BSTR | bstrEAN | The EAN number of the biller as supplied by Stiftung Refdata |
[in] BSTR | bstrZSR | The optional ZSR number of the biller as supplied by Santesuisse |
[in] BSTR | bstrNIF | The optional IV specific identification number NIF of the biller. |
[in] BSTR | bstrSpecialty | An optional specialty, i.e. FMH title of the recipient |
[in] IAddress | *pIAddress | The instance of a IAddress interface that holds the structured address parts. A NULL pointer is supplied if no address should be set. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IHospitalMCDRequest
  • SetGrouperData

IHospitalMCDRequest::SetGrouperData method |  |  |
Sets the grouper relevant global parameters |  |  | space
C/C++ calling syntax |  |  |
HRESULT SetGrouperData( | double long BSTR VARIANT_BOOL | dAdmissionWeight, lRespirationTime, bstrGrouper, *pbStatus); |
Calling argument description |  |  |
[in] double | dAdmissionWeight | The patient's weight at the moment of the admission given in [kg] or [g]. The weight is automatically converted to an integral [g] value. Note, that the admission weight is mostly relevant for neonates only. |
[in] long | lRespirationTime | The patient's respiration time in [s] during treatment. If respiration is not an issue set lRespirationTime = 0. |
[in] BSTR | bstrGrouper | Name of the grouper software, e.g. "SwissDRG 0.2" |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IHospitalMCDRequest
  • SetInsurance

IHospitalMCDRequest::SetInsurance method |  |  |
Sets the insurance's EAN as well as the structured address. The structured address is defined via a IAddress interface instance and the address data must be defined prior to call this method. |  |  | space
C/C++ calling syntax |  |  |
HRESULT SetInsurance( | BSTR IAddress VARIANT_BOOL | bstrEAN, *pIAddress, *pbStatus); |
Calling argument description |  |  |
[in] BSTR | bstrEAN | The EAN number of the insurance as supplied by Stiftung Refdata |
[in] IAddress | *pIAddress | The instance of a IAddress interface that holds the structured address parts. A NULL pointer is supplied if no address should be set. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IHospitalMCDRequest
  • SetInvoice

IHospitalMCDRequest::SetInvoice method |  |  |
Sets the invoice object reference for which the MCD is produced. The invoice and MCD object references form a object reference chain (invoice -> mcd) with the MCD as topmost object reference.. The page "object reference" provides an in-depth description of the concepts of "object reference", "object reference chain", and "topmost object reference". |  |  | space
C/C++ calling syntax |  |  |
HRESULT SetInvoice( | BSTR DATE long VARIANT_BOOL | bstrRequestInvoiceID, dRequestInvoiceDate, lRequestInvoiceTimestamp, *pbStatus); |
Calling argument description |  |  |
[in] BSTR | bstrRequestInvoiceID | The request ID is the main software's identification of the invoice ("Rechnungsnummer"). This is one of 3 identifiers that form the invoice object reference. |
[in] DATE | dRequestInvoiceDate | The request date is the main software's date of the invoice request ("Rechnungsdatum") This is one of 3 identifiers that form the invoice object reference. |
[in] long | lRequestInvoiceTimestamp | This is a UNIX timestamp defined at the moment of the invoice's infoset generation. This is one of 3 identifiers that form the invoice object reference. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IHospitalMCDRequest
  • SetMCD

IHospitalMCDRequest::SetMCD method |  |  |
Sets the main MCD object reference that is it uniquely characterizes this XML infoset. The invoice and MCD object references form a object reference chain (invoice -> mcd) with the MCD as topmost object reference.. The page "object reference" provides an in-depth description of the concepts of "object reference", "object reference chain", and "topmost object reference". |  |  | space
C/C++ calling syntax |  |  |
HRESULT SetMCD( | BSTR DATE long VARIANT_BOOL | bstrRequestMCDID, dRequestMCDDate, lRequestMCDTimestamp, *pbStatus); |
Calling argument description |  |  |
[in] BSTR | bstrRequestMCDID | The request ID is the main software's identification of the MCD ("MCD Fallnummer"). This is one of 3 identifiers that form the MCD object reference. This ID must be identical for the same MCD object reference e.g. in a storno process! |
[in] DATE | dRequestMCDDate | The request date is the main software's date of the MCD request ("MCD Datum") This is one of 3 identifiers that form the MCD object reference. This date must be identical for the same MCD object reference e.g. in a storno process! |
[in] long | lRequestMCDTimestamp | This is a UNIX timestamp defined at the moment of the MCD's infoset generation. Set this variable 0 to indicate the generation of a new MCD object reference. The IHospitalMCDRequestManager::GetXML and/or IHospitalMCDRequestManager::Print method will return the timestamp that must be used from that point on as 3rd parameter of the object reference. This is one of 3 identifiers that form the MCD object reference. The timestamp will be generated once for a certain MCD object reference and thereafter the timestamp is always referenced. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IHospitalMCDRequest
  • SetPackage

IHospitalMCDRequest::SetPackage method |  |  |
Defines the identification parameters of the main software. |  |  | space
C/C++ calling syntax |  |  |
HRESULT SetPackage( | BSTR long long BSTR VARIANT_BOOL | bstrSoftwarePackage, lSoftwareVersion, lSoftwareID, bstrSoftwareCopyright, *pbStatus); |
Calling argument description |  |  |
[in] BSTR | bstrSoftwarePackage | Name of the main software. |
[in] long | lSoftwareVersion | Version of the main software coded as 32-bit value where lSoftwareVersion = 100*Major version + Minor version. |
[in] long | lSoftwareID | Optional ID of the main software |
[in] BSTR | bstrSoftwareCopyright | The copyright notice of the main software. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then no package data is available |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IHospitalMCDRequest
  • SetPatient

IHospitalMCDRequest::SetPatient method |  |  |
Sets the primary parameters of the patient that are necessary for the DRG grouper. |  |  | space
C/C++ calling syntax |  |  |
HRESULT SetPatient( | SexType DATE VARIANT_BOOL | eSexType, dBirthdate, *pbStatus); |
Calling argument description |  |  |
[in] SexType | eSexType | The patient's gender. |
[in] DATE | dBirthdate | The patient's birthdate. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IHospitalMCDRequest
  • SetProvider

IHospitalMCDRequest::SetProvider method |  |  |
Sets the provider's various identifiers (EAN, ZSR,...) as well as the structured address. The structured address is defined via a IAddress interface instance and the address data must be defined prior to call this method. |  |  | space
C/C++ calling syntax |  |  |
HRESULT SetProvider( | BSTR BSTR BSTR BSTR IAddress VARIANT_BOOL | bstrEAN, bstrZSR, bstrNIF, bstrSpecialty, *pIAddress, *pbStatus); |
Calling argument description |  |  |
[in] BSTR | bstrEAN | The EAN number of the provider as supplied by Stiftung Refdata |
[in] BSTR | bstrZSR | The ZSR number of the provider as supplied by Santesuisse |
[in] BSTR | bstrNIF | The optional IV specific identification number NIF of the provider. |
[in] BSTR | bstrSpecialty | An optional specialty, i.e. FMH title of the sender. |
[in] IAddress | *pIAddress | The instance of a IAddress interface that holds the structured address parts. A NULL pointer is supplied if no address should be set. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IHospitalMCDRequest
  • SetRequest

IHospitalMCDRequest::SetRequest method |  |  |
Defines the processing parameters, namely the "storno" and "copy" status besides an optional remark. Note, that whenever the "storno" and/or "copy" parameters are set then the timestamp of the original MCD object reference (SetMCD) must be defined that is the timestamp > 0 otherwise an error will result in the Finalize method. |  |  | space
C/C++ calling syntax |  |  |
HRESULT SetRequest( | YesNoType YesNoType YesNoType BSTR VARIANT_BOOL | eIsStorno, eIsCopy, eIsConfidential, bstrRemark, *pbStatus); |
Calling argument description |  |  |
[in] YesNoType | eIsStorno | Boolean value that defines the "storno" status of the MCD. eIsStorno should be false when the initial MCD is produced. At this step the MCD timestamp is generated and returned from the IHospitalMCDRequestManager::Print and/or IHospitalMCDRequestManager::GetXML method. Whenever eIsStorno is true then the MCD timestamp must be set otherwise an error will result. |
[in] YesNoType | eIsCopy | Boolean value that defines the "copy" status of the MCD. eIsCopy should be false when the initial MCD is produced. At this step the MCD timestamp is generated and returned from the IHospitalMCDRequestManager::Print and/or IHospitalMCDRequestManager::GetXML method. Whenever eIsCopy is true then the MCD timestamp must be set otherwise an error will result. |
[in] YesNoType | eIsConfidential | Boolean flag that defines the confidentiality status of a MCD when addressed and transmitted to a consulting physician (CE) at the insurance's site in accordance with Article 42 (5) of the Swiss Federal Act on Health Insurance (KVG). By using the flag in the aforementioned case, the health provider declares that all medical information must be seen and used exclusively by the CE. Therefore, the case qualifies according to Article 42 (5) KVG. |
[in] BSTR | bstrRemark | An optional remark for MCD. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IHospitalMCDRequest
  • SetTransport

IHospitalMCDRequest::SetTransport method |  |  |
Sets transport information that is the routing information going from a sender (from) over the first intermediate (via) to the receiver (to). All the involved parties are defined by EAN numbers as defined by Stiftung Refdata. This method allows to define the parameters needed for sign and/or encrypt the resulting XML infoset. Therefore, read the notes about signature and encryption to get familiar with these concepts. |  |  | space
C/C++ calling syntax |  |  |
HRESULT SetTransport( | BSTR BSTR BSTR BSTR BSTR BSTR VARIANT_BOOL | bstrFromEAN, bstrFromPFXFile, bstrFromPFXPassword, bstrViaEAN, bstrToEAN, bstrToBinDERFile, *pbStatus); |
Calling argument description |  |  |
[in] BSTR | bstrFromEAN | The EAN number of the sender as supplied by Stiftung Refdata |
[in] BSTR | bstrFromPFXFile | The file name of the PFX certificate that is the private certificate of the "from" entity. If the variable is empty or NULL then no signature is applied otherwise a signature might be applied depending on the lXMLGenerationAttributes of the GetXML method. |
[in] BSTR | bstrFromPFXPassword | The password to open the PFX certificate. The password is only used if a PFX certificate is supplied. |
[in] BSTR | bstrViaEAN | The EAN number of the first intermediate as supplied by Stiftung Refdata |
[in] BSTR | bstrToEAN | The EAN number of the recipient as supplied by Stiftung Refdata |
[in] BSTR | bstrToBinDERFile | The file name of the binary DER certificate that is the public certificate of the "to" entity. If the variable is empty or NULL then no encryption is applied otherwise encryption might be applied depending on the lXMLGenerationAttributes of the GetXML |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IHospitalMCDRequest
  • SetTreatment

IHospitalMCDRequest::SetTreatment method
Sets the basic treatment parameters.

Note, that the treatment begin and end date is the same period as defined in the corresponding invoice. Furthermore, the calculation of the number of treatment days is dependent on the DRG version used (swissDRG or APDRG).

space
C/C++ calling syntax
HRESULT SetTreatment( BSTR
DATE
DATE
long
YesNoType
VARIANT_BOOL 		bstrACID,
dDateBegin,
dDateEnd,
lTreatmentDays,
eDoCostAssessment,
*pbStatus);
Calling argument description
[in] BSTR | bstrACID | The optional Administrative Case IDentification.
[in] DATE | dDateBegin | Start date of the treatment copied from the corresponding invoice
[in] DATE | dDateEnd | End date of the treatment copied from the corresponding invoice
[in] long lTreatmentDays Number of days of treatment within the given treatment period.

The calculation of these treatment days is dependent on whether SwissDRG is used nor not!
The treatment days are calculated as

  • None-SwissDRG: «(treatment@date_end - treatment@date_begin + 1 - vacation_days)»
  • SwissDRG: «(treatment@date_end - treatment@date_begin - vacation_days)»
where vacation_days is the number of vacation days (the leave days when the patient was not in the hospital for treatment).
Note, that treatment_days is identical to the "length of stay" notion of a DRG service position (either APDRG or SwissDRG)
[in] YesNoType | eDoCostAssessment | The Boolean eDoCostAssessment indicates that another insurance might be responsible for a part of the costs. As a consequence of setting this attribute, the addressed insurance starts an internal assessment about a possible cost splitting.
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


  • IHospitalMCDRequest
  • CreateAddress

IHospitalMCDRequest::CreateAddress property
Creates an instance of the IAddress interface.

Any address data is specified or retrieved using properties and methods of this interface. The interface is reusable for any semantic type of address. Just call the IAddress:Initialize method before starting to input new address data.

space
C/C++ calling syntax
[get] HRESULT | CreateAddress( IAddress **aIAddress);
space
Calling argument description
[out, retval] IAddress | **aIAddress
C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • IAddress **GetCreateAddress(void);
space


  • IHospitalMCDRequestManager

IHospitalMCDRequestManager interface | V4.50/ 2 Sep 2016
The IHospitalMCDRequestManager interface provides methods to load or generate a MCD (Minimal Clinical Dataset) of type hospitalMCDRequest_450 or hospitalMCDRequest_440 that basically defines the required input to a DRG grouper.

The MCD is printed or a XML infoset is produced which can be electronically transported to the recipient. In the latter case the MCD optionally can be signed and/or encrypted .

Due to the processing attributes "storno" and "copy" a previously generated MCD can be canceled or a copy can be produced (cf. Notes about processing attributes).

space
Methods | 8 methods
GetAbortInfo | Get the abort information string with the error coded in the module language
GetLogSettings | Get the log settings for the module.
GetXML | The GetXML method generates the XML infoset based on the data of the IHospitalMCDRequest interface and the XML generation attributes, validates the XML against the XSD schema, and stores the XML content as UTF8 file in the internal working directory
LoadXML | Loads a previously generated XML infoset back into memory for further processing via the returned interface handles
Print | The Print method is a visualization aid to preview/print the currently loaded data on screen or onto the local printer
PrintAdjust | Shows the print object adjustment dialog that allows to move print objects of a .vps report generator file
PrintSetup | Shows the printer setup dialog that allows to define the printer and its settings
SetLogSettings | Sets the log setting preferences for the module
Properties | 5 properties
[get] HospitalMCDRequest | The GetHospitalMCDRequest property generates an instance of the IHospitalMCDRequest interface
[get/put] ModuleLanguage | Gets/Sets the language for the module i.e
[get] ModuleVersion | Gets the version of the HospitalMCDRequestManager module.
[get] ModuleVersionText | Get the version of the HospitalMCDRequestManager module in textual form.
[get/put] Modus | Gets/Sets the operation modus of the module


  • IHospitalMCDRequestManager
  • GetAbortInfo

IHospitalMCDRequestManager::GetAbortInfo method |  |  |
Get the abort information string with the error coded in the module language. Call this method whenever the returned pbStatus variable of the primarily called method is VARIANT_FALSE and the primarily called method is not an iterator (GetFirst/GetNext). In the later case VARIANT_FALSE signals the end of data. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetAbortInfo( | BSTR VARIANT_BOOL | *pbstrAbort, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrAbort | Abort information string coded in the module language. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error-in-error situation occurred. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IHospitalMCDRequestManager
  • GetLogSettings

IHospitalMCDRequestManager::GetLogSettings method
Get the log settings for the module. | space
C/C++ calling syntax
HRESULT GetLogSettings( long
long
YesNoType
BSTR
VARIANT_BOOL 		*plLogLevel,
*plMaxSizeKB,
*peDoArchive,
*pbstrArchiveDir,
*pbStatus);
Calling argument description
[out] long *plLogLevel The log activity level where
lLogLevel = 0 | Logging is turned off
lLogLevel = 1 | Normal log activity
lLogLevel > 1 | Debug log activity. Use this level only for debugging purposes
[out] long | *plMaxSizeKB | The maximum size in KB of the log file.
[out] YesNoType | *peDoArchive | eDoArchive defines if the log file is recycled if the maximum size is reached (enNo) or if the log file is archived (enYes).
[out] BSTR | *pbstrArchiveDir | The base directory where log files are archived. bstrArchiveDir is only defined if eDoArchive=enYes otherwise bstrArchiveDir is empty.
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


  • IHospitalMCDRequestManager
  • GetXML

IHospitalMCDRequestManager::GetXML method
The GetXML method generates the XML infoset based on the data of the IHospitalMCDRequest interface and the XML generation attributes, validates the XML against the XSD schema, and stores the XML content as UTF8 file in the internal working directory. The full file name to this XML document is replied in the pbstrOutputFile output variable.

The XML file must be saved to a different location as all temporary XML files in the working directory are deleted before the COM module shuts down!

Note about compatibility: the COM module is natively capable of producing the current hospitalMCDRequest_450 standard as well as its predecessor, hospitalMCDRequest_440 by using the lGenerationAttributes=enGenerateDowngradeToV440 command.

Note about encryption: an encrypted XML infoset can not be loaded successfully by LoadXML as the private certificate of the "to" is certainly not available. Therefore, to build a local archive besides encrypted XML infoset, call GetXML twice once with the lGenerationAttributes= enGenerateXMLWithoutEncryption.

space
C/C++ calling syntax
HRESULT GetXML( long
BSTR
long
long
BSTR
IHospitalMCDResult
VARIANT_BOOL 		lGenerationAttributes,
*pbstrOutputFile,
*plValidationError,
*plTimestamp,
*pbstrUsedSchema,
**ppIHospitalMCDResult,
*pbStatus);
Calling argument description
[in] long lGenerationAttributes This variable overrules the default behavior of the XML generation process even if the appropriate data have been defined.

lGenerationAttributes is a 32-bit integer where the possible "commands" are values from the generationAttributes data type ORed together to form the overall command.

This feature is necessary to generate different "flavors" of XML infosets without re-setting input data. For instance, an encrypted XML infoset for the "to" entity can be produced and in a second call the XML infoset without encryption (lGenerationAttributes=enGenerateXMLWithoutEncryption) is requested for a local archive (that can be loaded back later!).

[out] BSTR *pbstrOutputFile The full file name (path + name) where the XML infoset is stored in UTF-8 mode.

The XML file must be saved to a different location as all temporary XML files in the working directory are deleted before the COM module shuts down!

[out] long | *plValidationError | lValidationError is filled with the validation error code returned by the MSXML DOM parser. A zero value indicates that the validation was successful.
[out] long *plTimestamp The timestamp of the XML document as epoch time (seconds elapsed since 1.1.1970) that is used as timestamp of the topmost object reference from that point on.

If the timestamp for the topmost object reference was already set (e.g. to produce a copy) then this same timestamp is returned.

[out] BSTR *pbstrUsedSchema The full XSD name that was used to generate the XML infoset.

In a standard situation this would be hospitalMCDRequest_450.xsd. However, a downgrade to hospitalMCDRequest_440.xsd can be requested by using lGenerationAttributes=enGenerateDowngradeToV440.

[out] IHospitalMCDResult **ppIHospitalMCDResult The instance of a IHospitalMCDResult interface allows to read all loaded data back.
The handle is NULL if an error occurred.
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


  • IHospitalMCDRequestManager
  • LoadXML

IHospitalMCDRequestManager::LoadXML method
Loads a previously generated XML infoset back into memory for further processing via the returned interface handles. The HospitalMCDRequest450 COM module understands and processes the hospitalMCDRequest_450 XSD standard as well as its predecessor, namely hospitalMCDRequest_440.

To analyze and retrieve the loaded data use the returned instance of the IHospitalMCDRequest interface and/or preview/print the data.

Furthermore, this method serves as dashboard e.g. to produce a "storno" or "copy" XML infoset.

  • Load the initial XML infoset with LoadXML
  • set the appropriate storno and/or copy values with the IHospitalMCDRequest::SetRequest method
  • produce the XML infoset again with the GetXML method or print the MCD with the Print method.
space
C/C++ calling syntax
HRESULT LoadXML( BSTR
BSTR
IHospitalMCDRequest
IHospitalMCDResult
VARIANT_BOOL 		bstrInputFile,
*pbstrUsedSchema,
**ppIHospitalMCDRequest,
**ppIHospitalMCDResult,
*pbStatus);
Calling argument description
[in] BSTR | bstrInputFile | The input XML infoset (full file name) that must be loaded and analyzed.
[out] BSTR *pbstrUsedSchema The full XSD name of the loaded XML file.

Since the current standard and its predecessor can natively be loaded it must either be of schema type hospitalMCDRequest_450.xsd or hospitalMCDRequest_440.xsd. This variable is not set if the loading of an XML infoset was unsuccessful.

[out] IHospitalMCDRequest **ppIHospitalMCDRequest The instance of a IHospitalMCDRequest interface allows to add further data or override data like setting the "storno" bit.
The handle is NULL if an error occurred.
[out] IHospitalMCDResult **ppIHospitalMCDResult The instance of a IHospitalMCDResult interface allows to read all loaded data back.
The handle is NULL if an error occurred.
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


  • IHospitalMCDRequestManager
  • Print

IHospitalMCDRequestManager::Print method
The Print method is a visualization aid to preview/print the currently loaded data on screen or onto the local printer. The printer selection is done via the used report generator template file. If the template file was not connected to a printer with the PrintSetup method then the default printer with its default settings is used.

The bstrPrintTemplate variable obeys a special syntax and can be used to set special print commands like producing PDFs or changing print objects dynamically.

  • "How to generate PDF archive file" is a description about PDF archive files
  • "Syntax of the printTemplate variable"

IMPORTANT LICENSE NOTE The report engine used is Hexatech's ViewPro (www.hexatech.com). If you supply your own template files then you must have your own ViewPro license. By using this COM module, you implicitly agree upon this restriction! 		space
C/C++ calling syntax
HRESULT Print( BSTR
long
YesNoType
BSTR
long
IHospitalMCDResult
VARIANT_BOOL 		bstrPrintTemplate,
lGenerationAttributes,
ePrintPreview,
bstrSenderID,
*plTimestamp,
**ppIHospitalMCDResult,
*pbStatus);
Calling argument description
[in] BSTR bstrPrintTemplate The bstrPrintTemplate variable is used to explicitly change print template reports and/or print objects as defined in "Syntax of the printTemplate variable".

If bstrPrintTemplate is empty then the default print template of the defined data language ( IHospitalMCDRequest:: Initialize method) is used.

[in] long lGenerationAttributes This variable overrules the default behavior of the print process.

lGenerationAttributes is a 32-bit integer where the possible "commands" are values from the generationAttributes data type ORed together to form the overall command.

[in] YesNoType | ePrintPreview | A Boolean that defines if print preview is used (enYes) or printing is done (enNo)
[in] BSTR bstrSenderID Short sender address identification or empty.

If set then the sender identification is printed atop of the receiver address as an alternative to the sender address on the envelop.

[out] long *plTimestamp The timestamp of the XML document as epoch time (seconds elapsed since 1.1.1970) that is used as timestamp of the topmost object reference from that point on.

If the timestamp for the topmost object reference was already set (e.g. to produce a copy) then this same timestamp is returned.

[out] IHospitalMCDResult **ppIHospitalMCDResult The instance of a IHospitalMCDResult interface allows to read back all currently loaded data.
The handle is NULL if an error occurred.
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


  • IHospitalMCDRequestManager
  • PrintAdjust

IHospitalMCDRequestManager::PrintAdjust method
Shows the print object adjustment dialog that allows to move print objects of a .vps report generator file.

Besides the position adjustment of any available print object, there exists the possibility of move all print objects globally.

space
C/C++ calling syntax
HRESULT PrintAdjust( BSTR
BSTR
VARIANT_BOOL 		bstrPrintTemplate,
bstrINIPath,
*pbStatus);
Calling argument description
[in] BSTR bstrPrintTemplate Either a full file name (path + name) or a logical name of a target .vps report generator file for which the settings will be defined.

There are predefined .vps files that can be accessed via one of the following case insensitive logical names:

Detail[_version]_language

where
  • version is one of {_450, _440}, the absence of a version identifier defaults to _450
  • language is one of {dt, fr, it}.
For example the logical name "Detail_fr" is the French print template of version 450.
[in] BSTR bstrINIPath Optional path to a directory where the .vpd printer setting file is stored. The name of the printer setting file is the same name as the .vps file but with a .vpd extension.

If bstrINIPath is left empty then the standard directory (the directory of the dll) is used.

[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


  • IHospitalMCDRequestManager
  • PrintSetup

IHospitalMCDRequestManager::PrintSetup method
Shows the printer setup dialog that allows to define the printer and its settings. When saving the data the selected print and the currently used computer is connected with the given .vps report generator file. | space
C/C++ calling syntax
HRESULT PrintSetup( BSTR
BSTR
VARIANT_BOOL 		bstrPrintTemplate,
bstrINIPath,
*pbStatus);
Calling argument description
[in] BSTR bstrPrintTemplate Either a full file name (path + name) or a logical name of a target .vps report generator file for which the settings will be defined.

There are predefined .vps files that can be accessed via one of the following case insensitive logical names:

Detail[_version]_language

where
  • version is one of {_450, _440}, the absence of a version identifier defaults to _450
  • language is one of {dt, fr, it}.
For example the logical name "Detail_fr" is the French print template of version 450.
[in] BSTR bstrINIPath Optional path to a directory where the .vpd printer setting file is stored. The name of the printer setting file is the same name as the .vps file but with a .vpd extension.

If bstrINIPath is left empty then the standard directory (the directory of the dll) is used.

[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


  • IHospitalMCDRequestManager
  • SetLogSettings

IHospitalMCDRequestManager::SetLogSettings method
Sets the log setting preferences for the module.

The default for the log activity are: level=1, lMaxSizeKB=1000,eDoArchive=enNo, and the log settings are persistent via the log file itself.

Note, that the log facility is a best effort system. If there is an error e.g. due to insufficient privileges to write the log entries then nothing is logged.

space
C/C++ calling syntax
HRESULT SetLogSettings( long
long
YesNoType
BSTR
VARIANT_BOOL 		lLogLevel,
lMaxSizeKB,
eDoArchive,
bstrArchiveDir,
*pbStatus);
Calling argument description
[in] long lLogLevel The log activity level where
lLogLevel = 0 | Logging is turned off
lLogLevel = 1 | Normal log activity
lLogLevel > 1 | Debug log activity. Use this level only for debugging purposes

Any log level below 0 is corrected to 0.

[in] long lMaxSizeKB The maximum size in KB of the log file.
Any size below 1000 KB (= the default value) is corrected to the default value
[in] YesNoType | eDoArchive | eDoArchive defines if the log file is recycled once the maximum size is reached (enNo) or if the log file is archived (enYes) into the archive directory.
[in] BSTR bstrArchiveDir Defines the base directory where log files are archived. bstrArchiveDir is only used if eDoArchive=enYes. If bstrArchiveDir is empty and eDoArchive=enYes then the place of the module is used as the base archive directory.

If the base archive directory or directories below have insufficient privileges to create directories or write files archiving is not done!

[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


  • IHospitalMCDRequestManager
  • HospitalMCDRequest

IHospitalMCDRequestManager::HospitalMCDRequest property
The GetHospitalMCDRequest property generates an instance of the IHospitalMCDRequest interface.

This interface instance is needed to set all the requested data.

space
C/C++ calling syntax
[get] HRESULT | HospitalMCDRequest( IHospitalMCDRequest **aIHospitalMCDRequest);
space
Calling argument description
[out, retval] IHospitalMCDRequest | **aIHospitalMCDRequest
C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • IHospitalMCDRequest **GetHospitalMCDRequest(void);
space


  • IHospitalMCDRequestManager
  • ModuleLanguage

IHospitalMCDRequestManager::ModuleLanguage property
Gets/Sets the language for the module i.e. the language in which the error strings are coded.

Note, that the module language and the data language (given by IHospitalMCDRequest::Initialize) are independent and can be different!

space
C/C++ calling syntax
[get] HRESULT | ModuleLanguage( LanguageType *aLanguageType);
[put] HRESULT | ModuleLanguage( LanguageType aLanguageType);
space
Calling argument description
[out,retval] LanguageType | *aLanguageType
[in] LanguageType | aLanguageType
C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • LanguageType *GetModuleLanguage(void);
  • void PutModuleLanguage( LanguageType aLanguageType);
space


  • IHospitalMCDRequestManager
  • ModuleVersion

IHospitalMCDRequestManager::ModuleVersion property
Gets the version of the HospitalMCDRequestManager module. | space
C/C++ calling syntax
[get] HRESULT | ModuleVersion( BSTR *aBSTR);
space
Calling argument description
[out, retval] BSTR | *aBSTR
C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetModuleVersion(void);
space


  • IHospitalMCDRequestManager
  • ModuleVersionText

IHospitalMCDRequestManager::ModuleVersionText property
Get the version of the HospitalMCDRequestManager module in textual form. | space
C/C++ calling syntax
[get] HRESULT | ModuleVersionText( BSTR *aBSTR);
space
Calling argument description
[out, retval] BSTR | *aBSTR
C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetModuleVersionText(void);
space


  • IHospitalMCDRequestManager
  • Modus

IHospitalMCDRequestManager::Modus property
Gets/Sets the operation modus of the module.

The default modus is enProduction whereas for developing/debugging purposes enTest can be set.

space
C/C++ calling syntax
[get] HRESULT | Modus( ModusType *aModusType);
[put] HRESULT | Modus( ModusType aModusType);
space
Calling argument description
[out,retval] ModusType | *aModusType
[in] ModusType | aModusType
C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • ModusType *GetModus(void);
  • void PutModus( ModusType aModusType);
space


  • IHospitalMCDResult

IHospitalMCDResult interface |  | V4.50/ 2 Sep 2016
The IHospitalMCDResult interface allows to read back all data that have been defined by using an IHospitalMCDRequest interface object or by loading a previously generated XML infoset with the IHospitalMCDRequestManager::LoadXML method. |  | space
Methods |  | 24 methods
GetAbortInfo | Get the abort information string with the error coded in the module language |
GetBiller | Retrieves the biller's various identifiers (EAN, ZSR,...) as well as the structured address |
GetFirstBfSRecord | Retrieves the first BfS record from the list of BfS records |
GetFirstDiagnosis | Retrieves the first diagnosis from the list of diagnoses |
GetFirstDocument | Retrieves the first document from the list of documents |
GetFirstGrouperRecord | Retrieves the first Grouper record from the list of Grouper records |
GetFirstProcedure | Retrieves the first procedure from the list of procedures |
GetFirstService | Retrieves the first DRG service from the list of DRG services |
GetGrouperData | Retrieves the grouper relevant global parameters |
GetInsurance | Retrieves the insurance's EAN as well as the structured address |
GetInvoice | Retrieves the invoice object reference parameters for which the MCD is produced |
GetMCD | Retrieves the main MCD object reference parameters |
GetNextBfSRecord | Retrieves the next BfS record from the list of BfS records |
GetNextDiagnosis | Retrieves the next diagnosis from the list of diagnoses |
GetNextDocument | Retrieves the next document from the list of documents |
GetNextGrouperRecord | Retrieves the next Grouper record from the list of Grouper records |
GetNextProcedure | Retrieves the next procedure from the list of procedures |
GetNextService | Retrieves the next DRG service from the list of DRG services |
GetPackage | Retrieves the identification parameters of the main software |
GetPatient | Retrieves the primary parameters (sex, birth date) of the patient. |
GetProvider | Retrieves the main provider's various identifiers (EAN, ZSR,...) and the structured address |
GetRequest | Returns the primary parameters of the request, namely the language the data is supplied, the "storno" and "copy" status besides an optional remark. |
GetTransport | Returns the transport information that is the routing information going from a sender (from) over at least one intermediate (via) to the receiver (to) |
GetTreatment | Retrieves the basic treatment parameters. |
Properties |  | 0 properties


  • IHospitalMCDResult
  • GetAbortInfo

IHospitalMCDResult::GetAbortInfo method |  |  |
Get the abort information string with the error coded in the module language. Call this method whenever the returned pbStatus variable of the primarily called method is VARIANT_FALSE and the primarily called method is not an iterator (GetFirst/GetNext). In the later case VARIANT_FALSE signals the end of data. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetAbortInfo( | BSTR VARIANT_BOOL | *pbstrAbort, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrAbort | Abort information string coded in the module language. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error-in-error situation occurred. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IHospitalMCDResult
  • GetBiller

IHospitalMCDResult::GetBiller method |  |  |
Retrieves the biller's various identifiers (EAN, ZSR,...) as well as the structured address. The structured address data is read via the methods of the returned IAddress interface instance. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetBiller( | BSTR BSTR BSTR BSTR IAddress VARIANT_BOOL | *pbstrEAN, *pbstrZSR, *pbstrNIF, *pbstrSpecialty, **ppIAddress, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrEAN | The EAN number of the biller as supplied by Stiftung Refdata |
[out] BSTR | *pbstrZSR | The optional ZSR number of the biller as supplied by Santesuisse |
[out] BSTR | *pbstrNIF | The optional IV specific identification number NIF of the biller |
[out] BSTR | *pbstrSpecialty | The optional specialty, i.e. FMH title of the biller. |
[out] IAddress | **ppIAddress | The instance of an IAddress interface that allows to read back the structured address data. If no address is defined then the handle is NULL. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IHospitalMCDResult
  • GetFirstBfSRecord

IHospitalMCDResult::GetFirstBfSRecord method |  |  |
Retrieves the first BfS record from the list of BfS records. VARIANT_FALSE is returned if the end of the BfS record list is reached. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetFirstBfSRecord( | BfSRecordType long BSTR VARIANT_BOOL | *peBfSRecordType, *plNumber, *pbstrName, *pbStatus); |
Calling argument description |  |  |
[out] BfSRecordType | *peBfSRecordType | The type of BfS record for which the number=name pair is supplied. |
[out] long | *plNumber | The number part of the number=name pair of a BfS record. |
[out] BSTR | *pbstrName | The name part of the number=name pair of a BfS record. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IHospitalMCDResult
  • GetFirstDiagnosis

IHospitalMCDResult::GetFirstDiagnosis method |  |  |
Retrieves the first diagnosis from the list of diagnoses. VARIANT_FALSE is returned if the end of the diagnosis list is reached. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetFirstDiagnosis( | BSTR BSTR BSTR BSTR VARIANT_BOOL | *pbstrCode, *pbstrText, *pbstrCatalog, *pbstrRemark, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrCode | The code of the diagnosis as defined in the diagnoses catalog. |
[out] BSTR | *pbstrText | The textual description of the diagnosis as given in the diagnoses catalog. |
[out] BSTR | *pbstrCatalog | The used catalog that lists the diagnosis e.g. "ICD-10-GM 2009" |
[out] BSTR | *pbstrRemark | The optional remark |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IHospitalMCDResult
  • GetFirstDocument

IHospitalMCDResult::GetFirstDocument method |  |  |
Retrieves the first document from the list of documents. VARIANT_FALSE is returned if the end of the document list is reached. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetFirstDocument( | YesNoType BSTR BSTR BSTR VARIANT_BOOL | *peIsURL, *pbstrSource, *pbstrTitle, *pbstrMimeType, *pbStatus); |
Calling argument description |  |  |
[out] YesNoType | *peIsURL | Boolean that defines if the document is added online using a URL (enYes) or inline as Base64 coded stream (enNo). |
[out] BSTR | *pbstrSource | If eIsURL = enYes then bstrSource is a URL for accessing the file online. If eIsURL = enNo then bstrSource supplies the full file name (path + name) of the document in a temporary working directory. Be sure to copy away the file to a different location as all files in the working directory are deleted before the COM module shuts down! |
[out] BSTR | *pbstrTitle | The title of the document on the primary system. It thus describes the document to a certain degree in terms of its semantic content. |
[out] BSTR | *pbstrMimeType | The MIME type of the document. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IHospitalMCDResult
  • GetFirstGrouperRecord

IHospitalMCDResult::GetFirstGrouperRecord method |  |  |
Retrieves the first Grouper record from the list of Grouper records. VARIANT_FALSE is returned if the end of the Grouper record list is reached. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetFirstGrouperRecord( | GrouperRecordType long BSTR VARIANT_BOOL | *peGrouperRecordType, *plNumber, *pbstrName, *pbStatus); |
Calling argument description |  |  |
[out] GrouperRecordType | *peGrouperRecordType | The type of Grouper record for which the number=name pair is supplied. |
[out] long | *plNumber | The number part of the number=name pair of a Grouper record. |
[out] BSTR | *pbstrName | The name part of the number=name pair of a Grouper record. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IHospitalMCDResult
  • GetFirstProcedure

IHospitalMCDResult::GetFirstProcedure method |  |  |
Retrieves the first procedure from the list of procedures. VARIANT_FALSE is returned if the end of the procedure list is reached. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetFirstProcedure( | BSTR BSTR BSTR SideType DATE BSTR VARIANT_BOOL | *pbstrCode, *pbstrText, *pbstrCatalog, *peSideType, *pDate, *pbstrRemark, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrCode | The code of the procedure as defined in the procedures catalog. |
[out] BSTR | *pbstrText | The textual description of the procedure as given in the procedures catalog. |
[out] BSTR | *pbstrCatalog | The used catalog that lists the procedures e.g. "CHOP 11" |
[out] SideType | *peSideType | The side dependency of the applied procedure |
[out] DATE | *pDate | The date when the procedure was applied. |
[out] BSTR | *pbstrRemark | The optional remark |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IHospitalMCDResult
  • GetFirstService

IHospitalMCDResult::GetFirstService method |  |  |
Retrieves the first DRG service from the list of DRG services. VARIANT_FALSE is returned if the end of the DRG service list is reached. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetFirstService( | BSTR BSTR BSTR VARIANT_BOOL | *pbstrTariffType, *pbstrCode, *pbstrText, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrTariffType | The official tariff number of the DRG service catalog |
[out] BSTR | *pbstrCode | The code of the DRG service. |
[out] BSTR | *pbstrText | The textual description of the DRG service. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IHospitalMCDResult
  • GetGrouperData

IHospitalMCDResult::GetGrouperData method |  |  |
Retrieves the grouper relevant global parameters |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetGrouperData( | double long BSTR VARIANT_BOOL | *pdAdmissionWeight, *plRespirationTime, *pbstrGrouper, *pbStatus); |
Calling argument description |  |  |
[out] double | *pdAdmissionWeight | The patient's weight at the moment of the admission as integral [g] value. If the weight was supplied in [kg] then it was automatically converted to an integral [g] value in the input method. Note, that the admission weight is mostly relevant for neonates only. |
[out] long | *plRespirationTime | The patient's respiration time in [s] during treatment. |
[out] BSTR | *pbstrGrouper | The name of the Swiss Grouper software, e.g. "SwissDRG 0.2" |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IHospitalMCDResult
  • GetInsurance

IHospitalMCDResult::GetInsurance method |  |  |
Retrieves the insurance's EAN as well as the structured address. The structured address data is read via the methods of the returned IAddress interface instance. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetInsurance( | BSTR IAddress VARIANT_BOOL | *pbstrEAN, **ppIAddress, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrEAN | The EAN number of the insurance as supplied by Stiftung Refdata |
[out] IAddress | **ppIAddress | The instance of an IAddress interface that allows to read back the structured address data. If no address is defined then the handle is NULL. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IHospitalMCDResult
  • GetInvoice

IHospitalMCDResult::GetInvoice method |  |  |
Retrieves the invoice object reference parameters for which the MCD is produced. The invoice and MCD object references form an object reference chain (invoice -> mcd) with the MCD as topmost object reference. The page "object reference" provides an in-depth description of the concepts of "object reference", "object reference chain", and "topmost object reference". |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetInvoice( | BSTR DATE long VARIANT_BOOL | *pbstrRequestInvoiceID, *pdRequestInvoiceDate, *plRequestInvoiceTimestamp, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrRequestInvoiceID | The request ID is the main software's identification of the invoice ("Rechnungsnummer") - mirrored from the request. This is one of 3 identifiers that form the invoice object reference. |
[out] DATE | *pdRequestInvoiceDate | The request date is the main software's date of the invoice request ("Rechnungsdatum") - mirrored from the request. This is one of 3 identifiers that form the invoice object reference. |
[out] long | *plRequestInvoiceTimestamp | This is a UNIX timestamp defined at the moment of the invoice's infoset generation - mirrored from the request. This is one of 3 identifiers that form the invoice object reference. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IHospitalMCDResult
  • GetMCD

IHospitalMCDResult::GetMCD method |  |  |
Retrieves the main MCD object reference parameters The invoice and MCD object references form an object reference chain (invoice -> mcd) with the MCD as topmost object reference. The page "object reference" provides an in-depth description of the concepts of "object reference", "object reference chain", and "topmost object reference". |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetMCD( | BSTR DATE long VARIANT_BOOL | *pbstrRequestMCDID, *pdRequestMCDDate, *plRequestMCDTimestamp, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrRequestMCDID | The request ID is the main software's identification of the MCD ("MCD Fallnummer"). This is one of 3 identifiers that form the MCD object reference. This ID must be identical for the same MCD object reference e.g. in a storno process! |
[out] DATE | *pdRequestMCDDate | The request date is the main software's date of the MCD request ("MCD Datum") This is one of 3 identifiers that form the MCD object reference. This date must be identical for the same MCD object reference e.g. in a storno process! |
[out] long | *plRequestMCDTimestamp | This is a UNIX timestamp defined at the moment of the MCD's infoset generation. This is one of 3 identifiers that form the MCD object reference. The timestamp will be generated once for a certain MCD object reference and thereafter always referenced! |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IHospitalMCDResult
  • GetNextBfSRecord

IHospitalMCDResult::GetNextBfSRecord method |  |  |
Retrieves the next BfS record from the list of BfS records. VARIANT_FALSE is returned if the end of the BfS record list is reached. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetNextBfSRecord( | BfSRecordType long BSTR VARIANT_BOOL | *peBfSRecordType, *plNumber, *pbstrName, *pbStatus); |
Calling argument description |  |  |
[out] BfSRecordType | *peBfSRecordType | The type of BfS record for which the number=name pair is supplied. |
[out] long | *plNumber | The number part of the number=name pair of a BfS record. |
[out] BSTR | *pbstrName | The name part of the number=name pair of a BfS record. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IHospitalMCDResult
  • GetNextDiagnosis

IHospitalMCDResult::GetNextDiagnosis method |  |  |
Retrieves the next diagnosis from the list of diagnoses. VARIANT_FALSE is returned if the end of the diagnosis list is reached. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetNextDiagnosis( | BSTR BSTR BSTR BSTR VARIANT_BOOL | *pbstrCode, *pbstrText, *pbstrCatalog, *pbstrRemark, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrCode | The code of the diagnosis as defined in the diagnoses catalog. |
[out] BSTR | *pbstrText | The textual description of the diagnosis as given in the diagnoses catalog. |
[out] BSTR | *pbstrCatalog | The used catalog that lists the diagnosis e.g. "ICD-10-GM 2009" |
[out] BSTR | *pbstrRemark | The optional remark |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IHospitalMCDResult
  • GetNextDocument

IHospitalMCDResult::GetNextDocument method |  |  |
Retrieves the next document from the list of documents. VARIANT_FALSE is returned if the end of the document list is reached. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetNextDocument( | YesNoType BSTR BSTR BSTR VARIANT_BOOL | *peIsURL, *pbstrSource, *pbstrTitle, *pbstrMimeType, *pbStatus); |
Calling argument description |  |  |
[out] YesNoType | *peIsURL | Boolean that defines if the document is added online using a URL (enYes) or inline as Base64 coded stream (enNo). |
[out] BSTR | *pbstrSource | If eIsURL = enYes then bstrSource is a URL for accessing the file online. If eIsURL = enNo then bstrSource supplies the full file name (path + name) of the document in a temporary working directory. Be sure to copy away the file to a different location as all files in the working directory are deleted before the COM module shuts down! |
[out] BSTR | *pbstrTitle | The title of the document on the primary system. It thus describes the document to a certain degree in terms of its semantic content. |
[out] BSTR | *pbstrMimeType | The MIME type of the document. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IHospitalMCDResult
  • GetNextGrouperRecord

IHospitalMCDResult::GetNextGrouperRecord method |  |  |
Retrieves the next Grouper record from the list of Grouper records. VARIANT_FALSE is returned if the end of the Grouper record list is reached. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetNextGrouperRecord( | GrouperRecordType long BSTR VARIANT_BOOL | *peGrouperRecordType, *plNumber, *pbstrName, *pbStatus); |
Calling argument description |  |  |
[out] GrouperRecordType | *peGrouperRecordType | The type of Grouper record for which the number=name pair is supplied. |
[out] long | *plNumber | The number part of the number=name pair of a Grouper record. |
[out] BSTR | *pbstrName | The name part of the number=name pair of a Grouper record. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IHospitalMCDResult
  • GetNextProcedure

IHospitalMCDResult::GetNextProcedure method |  |  |
Retrieves the next procedure from the list of procedures. VARIANT_FALSE is returned if the end of the procedure list is reached. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetNextProcedure( | BSTR BSTR BSTR SideType DATE BSTR VARIANT_BOOL | *pbstrCode, *pbstrText, *pbstrCatalog, *peSideType, *pDate, *pbstrRemark, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrCode | The code of the procedure as defined in the procedures catalog. |
[out] BSTR | *pbstrText | The textual description of the procedure as given in the procedures catalog. |
[out] BSTR | *pbstrCatalog | The used catalog that lists the procedures e.g. "CHOP 11" |
[out] SideType | *peSideType | The side dependency of the applied procedure |
[out] DATE | *pDate | The date when the procedure was applied. |
[out] BSTR | *pbstrRemark | The optional remark |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IHospitalMCDResult
  • GetNextService

IHospitalMCDResult::GetNextService method |  |  |
Retrieves the next DRG service from the list of DRG services. VARIANT_FALSE is returned if the end of the DRG service list is reached. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetNextService( | BSTR BSTR BSTR VARIANT_BOOL | *pbstrTariffType, *pbstrCode, *pbstrText, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrTariffType | The official tariff number of the DRG service catalog |
[out] BSTR | *pbstrCode | The code of the DRG service. |
[out] BSTR | *pbstrText | The textual description of the DRG service. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IHospitalMCDResult
  • GetPackage

IHospitalMCDResult::GetPackage method |  |  |
Retrieves the identification parameters of the main software. Since the package information is optionally VARIANT_FALSE is returned if the sender's main software is undefined. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetPackage( | BSTR long long BSTR VARIANT_BOOL | *pbstrSoftwarePackage, *plSoftwareVersion, *plSoftwareID, *pbstrSoftwareCopyright, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrSoftwarePackage | Name of the main software. |
[out] long | *plSoftwareVersion | Version of the main software coded as 32-bit value where lSoftwareVersion = 100*Major version + Minor version. |
[out] long | *plSoftwareID | Optional ID of the main software |
[out] BSTR | *pbstrSoftwareCopyright | The copyright notice of the main software. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then no package data is available |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IHospitalMCDResult
  • GetPatient

IHospitalMCDResult::GetPatient method |  |  |
Retrieves the primary parameters (sex, birth date) of the patient. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetPatient( | SexType DATE VARIANT_BOOL | *peSexType, *pdBirthdate, *pbStatus); |
Calling argument description |  |  |
[out] SexType | *peSexType | The patient's gender. |
[out] DATE | *pdBirthdate | The patient's birthdate. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IHospitalMCDResult
  • GetProvider

IHospitalMCDResult::GetProvider method |  |  |
Retrieves the main provider's various identifiers (EAN, ZSR,...) and the structured address. The IAddress interface might be NULL if no address was defined. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetProvider( | BSTR BSTR BSTR BSTR IAddress VARIANT_BOOL | *pbstrEAN, *pbstrZSR, *pbstrNIF, *pbstrSpecialty, **ppIAddress, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrEAN | The EAN number of the provider as supplied by Stiftung Refdata |
[out] BSTR | *pbstrZSR | ZSR number of the provider as supplied by Santesuisse |
[out] BSTR | *pbstrNIF | The optional IV specific identification number NIF of the provider. |
[out] BSTR | *pbstrSpecialty | The optional specialty, i.e. FMH title of the sender. |
[out] IAddress | **ppIAddress | The instance of a IAddress interface that allows to read back the structured address data. If no address is defined then the handle is NULL. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IHospitalMCDResult
  • GetRequest

IHospitalMCDResult::GetRequest method |  |  |
Returns the primary parameters of the request, namely the language the data is supplied, the "storno" and "copy" status besides an optional remark. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetRequest( | LanguageType YesNoType YesNoType YesNoType BSTR VARIANT_BOOL | *peDataLanguage, *peIsStorno, *peIsCopy, *peIsConfidential, *pbstrRemark, *pbStatus); |
Calling argument description |  |  |
[out] LanguageType | *peDataLanguage | The language in which the data part is coded. It is exactly the language in which the request is formulated. Note, that the data language and the module language (given by
[out] YesNoType | *peIsStorno | Boolean flag that defines the "storno" status of the MCD |
[out] YesNoType | *peIsCopy | Boolean flag that defines the "copy" status of the MCD |
[out] YesNoType | *peIsConfidential | Boolean flag that defines the confidentiality status of a MCD when addressed and transmitted to a consulting physician (CE) at the insurance's site in accordance with Article 42 (5) of the Swiss Federal Act on Health Insurance (KVG). By using the flag in the aforementioned case, the health provider declares that all medical information must be seen and used exclusively by the CE. Therefore, the case qualifies according to Article 42 (5) KVG. |
[out] BSTR | *pbstrRemark | An overall optional remark for MCD |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IHospitalMCDResult
  • GetTransport

IHospitalMCDResult::GetTransport method |  |  |
Returns the transport information that is the routing information going from a sender (from) over at least one intermediate (via) to the receiver (to). All the involved parties are defined by EAN numbers as defined by Stiftung Refdata. If the parameters for the signature and encryption were set then these data are returned as well otherwise the corresponding variables are empty. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetTransport( | BSTR BSTR BSTR BSTR BSTR BSTR VARIANT_BOOL | *pbstrFromEAN, *pbstrFromPFXFile, *pbstrFromPFXPassword, *pbstrViaEAN, *pbstrToEAN, *pbstrToBinDERFile, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrFromEAN | The EAN number of the sender as supplied by Stiftung Refdata |
[out] BSTR | *pbstrFromPFXFile | The file name of the PFX certificate used for signing that is the private certificate of the "from" entity. If the request is not signed than this parameter is empty |
[out] BSTR | *pbstrFromPFXPassword | The password to open the PFX certificate. If the request is not signed than this parameter is empty |
[out] BSTR | *pbstrViaEAN | The EAN number of the first intermediate as supplied by Stiftung Refdata |
[out] BSTR | *pbstrToEAN | The EAN number of the receiver as supplied by Stiftung Refdata |
[out] BSTR | *pbstrToBinDERFile | The file name of the binary DER certificate used for encryption that is the public certificate of the "to" entity |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IHospitalMCDResult
  • GetTreatment

IHospitalMCDResult::GetTreatment method
Retrieves the basic treatment parameters. | space
C/C++ calling syntax
HRESULT GetTreatment( BSTR
DATE
DATE
long
YesNoType
VARIANT_BOOL 		*pbstrACID,
*pdDateBegin,
*pdDateEnd,
*plTreatmentDays,
*peDoCostAssessment,
*pbStatus);
Calling argument description
[out] BSTR | *pbstrACID | The optional Administrative Case IDentification.
[out] DATE | *pdDateBegin | Start date of the treatment copied from the corresponding invoice
[out] DATE | *pdDateEnd | End date of the treatment copied from the corresponding invoice
[out] long *plTreatmentDays Number of days of treatment within the given treatment period.

The calculation of these treatment days is dependent on whether SwissDRG is used nor not!
The treatment days are calculated as

  • None-SwissDRG: «(treatment@date_end - treatment@date_begin + 1 - vacation_days)»
  • SwissDRG: «(treatment@date_end - treatment@date_begin - vacation_days)»
where vacation_days is the number of vacation days (the leave days when the patient was not in the hospital for treatment).
Note, that treatment_days is identical to the "length of stay" notion of a DRG service position (either APDRG or SwissDRG)
[out] YesNoType | *peDoCostAssessment | The Boolean eDoCostAssessment indicates that another insurance might be responsible for a part of the costs. As a consequence of setting this attribute, the addressed insurance starts an internal assessment about a possible cost splitting.
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


  • Type definitions

Builtin, composite & enumeration types |  | V4.50/ 2 Sep 2016
The following list shows ans defines all used data types either basic builtin, composite or enumeration types that are used in the interface of the ATL COM module. |  | space
Data types |  | 18 types
[enumeration] AddressType | Enumerates the defined types of addresses. |
[enumeration] BfSRecordType | Enumerates the defined types of BfS records that must be supplied to get a standard compliant XML infoset. |
[builtin] BSTR | A BSTR, known as basic string or binary string, is a pointer to a wide character string used by Automation data manipulation functions |
[builtin] DATE | DATE is denoting a date and time represented by a double-precision number, where midnight, January 1st, 1900 has the value 2.0, January 2nd, 1900 is 3.0, and so on. |
[builtin] double | An 8-byte IEEE real value. |
[enumeration] generationAttributes | List of options with which the standard generation of the XML infoset and/or print process can be oversteered. |
[enumeration] GrouperRecordType | Enumerates the defined types of Grouper records that must be supplied to get a standard compliant XML infoset. |
[builtin] HRESULT | The HRESULT data type is a 32-bit value that is used to describe an error or warning. |
[builtin] IAddress | IAddress interface object. |
[builtin] IHospitalMCDRequest | IHospitalMCDRequest interface object. |
[builtin] IHospitalMCDResult | IHospitalMCDResult interface object. |
[enumeration] LanguageType | Enumerates all supported languages. |
[builtin] long | A 4-byte integer value. |
[enumeration] ModusType | Enumerates the defined operation modus types |
[enumeration] SexType | Enumerates the defined basic gender types. |
[enumeration] SideType | Enumerates the defined body side types. |
[builtin] VARIANT_BOOL | A 16 bit Boolean (True/False) value was specified |
[enumeration] YesNoType | Boolean enumerator |


  • Type definitions
  • AddressType

AddressType enumeration type |  |
Enumerates the defined types of addresses. |  | space
Set of enumeration values |  | 3 elements
enAddressUndefined: 0 | Address type is undefined or unknown. |
enAddressPerson: 1 | Address of a person |
enAddressCompany: 2 | Address of a company |


  • Type definitions
  • BfSRecordType

BfSRecordType enumeration type |  |
Enumerates the defined types of BfS records that must be supplied to get a standard compliant XML infoset. |  | space
Set of enumeration values |  | 4 elements
enBfSResidenceBeforeAdmission: 1 | This BfS record type is the BfS code 1.2.V02 which defines the residence from where the patient was admitted |
enBfSAdmissionType: 2 | This BfS record type is the BfS code 1.2.V03 which defines the patient's type of admission |
enBfSDecisionForDischarge: 3 | This BfS record type is the BfS code 1.5.V02 which defines the reason why the patient was discharged |
enBfSResidenceAfterDischarge: 4 | This BfS record type is the BfS code 1.5.V03 which defines the residence to where the patient was discharged |


  • Type definitions
  • BSTR

BSTR type |
A BSTR, known as basic string or binary string, is a pointer to a wide character string used by Automation data manipulation functions. BSTRs are wide, double-byte (Unicode) strings on 32-bit Windows platforms. | space


  • Type definitions
  • DATE

DATE type |
DATE is denoting a date and time represented by a double-precision number, where midnight, January 1st, 1900 has the value 2.0, January 2nd, 1900 is 3.0, and so on. | space


  • Type definitions
  • double

double type |
An 8-byte IEEE real value. | space


  • Type definitions
  • generationAttributes

generationAttributes enumeration type |  |
List of options with which the standard generation of the XML infoset and/or print process can be oversteered. |  | space
Set of enumeration values |  | 4 elements
enGenerateXMLWithoutDocuments: 65536 | The XML infoset is generated without any documents even if such documents have been added in the IHospitalMCDRequest::AddDocument method. |
enGenerateXMLWithoutSignature: 131072 | The XML infoset is generated without applying a signature even if the signature parameters have been set in the IHospitalMCDRequest::SetTransport method. |
enGenerateXMLWithoutEncryption: 262144 | The XML infoset is generated without applying encryption even if the encryption parameters have been set in the IHospitalMCDRequest::SetTransport method. |
enGenerateDowngradeToV440: 1048576 | The XML infoset or print output of type hospitalMCDRequest440 is generated (downgraded) instead of the standard type hospitalMCDRequest450. This explicitly implies that any data unusable for the downgraded standard is silently discarded. |


  • Type definitions
  • GrouperRecordType

GrouperRecordType enumeration type |  |
Enumerates the defined types of Grouper records that must be supplied to get a standard compliant XML infoset. |  | space
Set of enumeration values |  | 3 elements
enGrouperAdmissionType: 1 | This Grouper record type defines the relevant admission mode |
enGrouperDischargeType: 2 | This Grouper record type defines the relevant discharge/separation mode |
enGrouperProviderType: 3 | This Grouper record type defines the relevant care provider |


  • Type definitions
  • HRESULT

HRESULT type |
The HRESULT data type is a 32-bit value that is used to describe an error or warning. | space


  • Type definitions
  • IAddress

IAddress type |
IAddress interface object. | space


  • Type definitions
  • IHospitalMCDRequest

IHospitalMCDRequest type |
IHospitalMCDRequest interface object. | space


  • Type definitions
  • IHospitalMCDResult

IHospitalMCDResult type |
IHospitalMCDResult interface object. | space


  • Type definitions
  • LanguageType

LanguageType enumeration type |  |
Enumerates all supported languages. |  | space
Set of enumeration values |  | 3 elements
enGerman: 1 | German |
enFrench: 2 | French. |
enItalian: 3 | Italian |


  • Type definitions
  • long

long type |
A 4-byte integer value. | space


  • Type definitions
  • ModusType

ModusType enumeration type |  |
Enumerates the defined operation modus types |  | space
Set of enumeration values |  | 2 elements
enProduction: 0 | Production modus. |
enTest: 1 | Test modus - the data should not be forwarded to the receiver. |


  • Type definitions
  • SexType

SexType enumeration type |  |
Enumerates the defined basic gender types. |  | space
Set of enumeration values |  | 2 elements
enMale: 0 | Male. |
enFemale: 1 | Female. |


  • Type definitions
  • SideType

SideType enumeration type |  |
Enumerates the defined body side types. |  | space
Set of enumeration values |  | 4 elements
enSideNone: 0 | No body side dependency available |
enSideLeft: 1 | Left body side is affected |
enSideRight: 2 | Right body side is affected |
enSideBoth: 3 | Both body sides are affected |


  • Type definitions
  • VARIANT_BOOL

VARIANT_BOOL type |
A 16 bit Boolean (True/False) value was specified. A value of 0xFFFF (all bits 1) indicates True; a value of 0 (all bits 0) indicates False. No other values are valid. | space


  • Type definitions
  • YesNoType

YesNoType enumeration type |  |
Boolean enumerator |  | space
Set of enumeration values |  | 2 elements
enNo: 0 | No. |
enYes: 1 | Yes. |


 Sumex1 under a 64bit architecture...

All Sumex1 COM modules are written as 32bit managed C++ dll. As a consequence, a 64bit executable cannot load a 32bit COM dll into its process space due to the addressing differences.

Since some necessary underlying sub-modules are not available in a 64bit version, this problem must be addressed differently than by a 64bit compilation. As Microsoft suggests Sumex1 uses the out-of-process proxy approach where a 32bit COM server loads the 32bit COM dll into its process space and delegates each method call to the dll. Since a 32bit COM server exists in its own process space, the main 64bit process can handle the 64/32bit boundary without problems.

As a result, each 32bit Sumex1 COM dll has a 32bit COM server counterpart with the same name and an oopProxy prefix, e.g. oopProxyHospitalMCDRequestManager450.exe, where the prefix signifies the out-of-process proxy nature of the executable.

Any 64bit software now creates an instance of the 32bit oopProxy server and then calls the same methods and properties as with the 32bit COM dll. However, there is one crucial difference when using the oopProxy mechanism, namely the necessity to forcefully unload to the COM server at the end e.g. by using Marshal.ReleaseComObject() since the automatic garbage collection approach is too error prone.


 Changes from V4.40 to V4.50...

The following list shows how the transition from V4.40 to V4.50 must be made in terms of new, changed, and deleted interface methods a/o arguments.

To ease the spreading towards the new COM module even if the readiness at intermediates and insurances is yet unknown, this new version natively can load, print and generate the V4.50 as well as its predecessor, namely V4.40. So the implementation can be done now and the activation of the V4.50 standard afterwards!

IHospitalMCDRequestManager
changed: The IHospitalMCDRequestManager::LoadXML(...) method can natively load XML infosets of type hospitalMCDRequest_450.xsd and hospitalMCDRequest_440.xsd.
changed: The IHospitalMCDRequestManager::GetXML(...) method can natively generate XML infosets of type hospitalMCDRequest_450.xsd and hospitalMCDRequest_440.xsd.
changed: The IHospitalMCDRequestManager::Print(...) method can natively print requests of type hospitalMCDRequest_450.xsd and hospitalMCDRequest_440.xsd.
IHospitalMCDRequest
changed: The IHospitalMCDRequest::AddDocument(...) method was changed such that a title of the document as is newly included and the inserted MIME types are filtered to block all but JPG, PNG, or PDF files.
obsolete: Since the BfS records are no longer necessary in hospitalMCDRequest450, the corresponding IHospitalMCDRequest::AddBfSRecord(...) method is obsolete.

However, without setting these BfS records, a downgrade is not achievable! Therefore, do not sustain from calling the method in the transitional period.

obsolete: Since the DRG record is no longer necessary in hospitalMCDRequest450, the corresponding IHospitalMCDRequest::AddService(...) method is obsolete.

However, without setting the DRG service records, a downgrade is not achievable! Therefore, do not sustain from calling the method in the transitional period.

IHospitalMCDResult
No changes insofar as some methods are still available whilst not needed for the current standard. However, the downgrade functionality dictates the availability of these methods!
IAddress
no changes


 Notes about the encryption

XML Encryption is a specification, governed by a W3C recommendation, that defines how to encrypt the contents of an XML element. Although XML Encryption can be used to encrypt any kind of data, it is nonetheless known as "XML Encryption" because an XML element (either an EncryptedData or EncryptedKey element) contains or refers to the cipher text, keying information, and algorithms.

However, it is beyond the scope of this documentation to explain all details of a encryption or the encryption process. Detailed information about all aspects of encryption can be found at W3C.

Boundary conditions and critical aspects

  • the encryption is optional!
  • if an infoset is encrypted then the public certificate of the recipient must be used and this certificate is applied to the body element.

    Here recipient is used in terms of the communication and therefore is defined as the EAN entity given in the transport@to attribute
  • the namespace v1 of W3C http://www.w3.org/2001/04/xmlenc must be used- cf. XML Encryption Syntax and Processing
  • The encryption algorithm is fixed to PKCS1 (RSA-SHA1) (RFC 2437: RSA Cryptography Specifications)
  • The block encryption algorithm is fixed to Triple DES

The hospitalMCDRequest module does obey all these conditions whenever encryption is "turned on" by setting a public certificate of the "toEAN" entity (cf. IHospitalMCDRequest::SetTransport). This certificate must be in the format "binary DER".

Where do I get this certificate?
The MCD request/response system is self-contained insofar as the hospitalMCDResponse module (or any other V4.3 module!) extracts the public certificate of a signed response XML infoset and generates a binary DER file named X509DER_from_EAN.cer. This is exactly the certificate to use for encrypting a MCD (or all other V4.3) request XML infosets!


 VB code snippet for using the hospitalMCDRequestManager

Private Sub Create_Click()

On Error GoTo Err_Trap

Dim bStatus As Boolean
Dim strAbortInfo As String

'### HospitalMCDRequestManager interface
Dim hospitalMCDRequestManagerEx As HOSPITALMCDREQUESTMANAGER450Lib.HospitalMCDRequestManager
Set hospitalMCDRequestManagerEx = New HospitalMCDRequestManager

hospitalMCDRequestManagerEx.Modus = enDebug
hospitalMCDRequestManagerEx.ModuleLanguage = enEnglish

'### HospitalMCDRequest interface
Dim hospitalMCDRequestEx As HOSPITALMCDREQUESTMANAGER450Lib.HospitalMCDRequest
Set hospitalMCDRequestEx = hospitalMCDRequestManagerEx.HospitalMCDRequest

'### Initialize before starting
bStatus = hospitalMCDRequestEx.Initialize(enGerman)

bStatus = hospitalMCDRequestEx.SetRequest(enNo, enNo, "")

'### set the transport, this is just an example
bStatus = hospitalMCDRequestEx.SetTransport("7600123456789","","","7600001234567", _
                                            "7600000012345","")

'### set invoice and mcd, this is only a test
Dim dInvoiceDate As Date
dInvoiceDate = Now
Dim lInvoiceTimestamp As Long
lInvoiceTimestamp = 0 ' 1970-01-01
bStatus = hospitalMCDRequestEx.SetInvoice("INVOICE_ID", dInvoiceDate, lInvoiceTimestamp)

Dim dRequestMCDDate As Date
dRequestMCDDate = Now
Dim lRequestMCDTimestamp As Long
lRequestMCDTimestamp = 0 ' 1970-01-01
bStatus = hospitalMCDRequestEx.SetMCD("MCD_ID", dRequestMCDDate, lRequestMCDTimestamp)

'###
Dim IAddress As HOSPITALMCDREQUESTMANAGER450Lib.Address
Set IAddress = hospitalMCDRequestEx.CreateAddress

'### set biller
bStatus = IAddress.SetCompany("Biller AG", "Abteilung Inkasso", "")
bStatus = IAddress.SetPostal("Billerweg 128", "", "4410", "Liestal", "BL", "CH")
bStatus = hospitalMCDRequestEx.SetBiller("7634567890111", "H121111", "", "", IAddress)

'### set provider
IAddress.Initialize
bStatus = IAddress.SetCompany("Spital im Park", "Abteilung Neurologie", "")
bStatus = IAddress.SetPostal("Spitalgasse 17b6", "", "4000", "Basel", "BS", "CH")
bStatus = hospitalMCDRequestEx.SetProvider("7634567890111", "P123456", "","FMH Innere Medizin", _
                                           IAddress)

'### set insurance
IAddress.Initialize
bStatus = IAddress.SetCompany("Unfallkasse AG", "Bereich Nord", "")
bStatus = IAddress.SetPostal("Kassengraben 222", "Postfach 2222", "4000", "Basel", "BS", "CH")
bStatus = hospitalMCDRequestEx.SetInsurance("2034567890222", IAddress)

'### set patient
bStatus = hospitalMCDRequestEx.SetPatient(enMale, DateValue("1940-01-01"))

'### set the treatment data
bStatus = hospitalMCDRequestEx.SetTreatment("someCaseID",DateValue("2017-07-04"),DateValue("2017-08-03"), _
                                            31)

'### set the grouper data
bStatus = hospitalMCDRequestEx.SetGrouperData(68.5, 0, "swissDRG 6.0")

'### set the grouper records
bStatus = hospitalMCDRequestEx.AddGrouperRecord(enGrouperAdmissionType, 0, "normal")
bStatus = hospitalMCDRequestEx.AddGrouperRecord(enGrouperDischargeType, 0, "normal")
bStatus = hospitalMCDRequestEx.AddGrouperRecord(enGrouperProviderType, 0, "Akutspital")

'### add a diagnosis
bStatus = hospitalMCDRequestEx.AddDiagnosis(drgID, "Q75.0", "Dysotosis craniofacialis", "ICD10-2016", "")

'### add a procedure
bStatus = hospitalMCDRequestEx.AddProcedure(drgID, "Z01.24", "Sonstigte Kraniotomie", "CHOP9-2016", _
                                            enSideLeft, DateValue("2017-07-20"), "")

'### Finalize
bStatus = hospitalMCDRequestEx.Finalize()

'### write eveything to a file
Dim strTmpFile As String
Dim lValidationError As Long
Dim lTimestamp As Long
Dim lXMLGenerationAttributes As Long
lXMLGenerationAttributes = 1
Dim hospitalMCDResultEx As HospitalMCDResult
bStatus = hospitalMCDRequestManagerEx.GetXML(lXMLGenerationAttributes, strTmpFile, lValidationError, _
                                             lTimestamp, hospitalMCDResultEx)
If Not bStatus Then
    GoTo Abort
End If
Dim lPrintTimestamp As Long

'### print preview
'### set receiver address
IAddress.Initialize
bStatus = IAddress.SetCompany("Some Company", "A department", "")
bStatus = IAddress.SetPostal("XY-Strasse 17b6", "", "4000", "Basel", "BS", "CH")

bStatus = hospitalMCDRequestManagerEx.Print("", enYes, enYes, "senderID", IAddress, lPrintTimestamp, _
                                            hospitalMCDResultEx)

'### release resources
Set IAddress = Nothing
Set hospitalMCDResultEx = Nothing
Set hospitalMCDRequestEx = Nothing
Set hospitalMCDRequestManagerEx = Nothing

Exit Sub

Err_Trap:
    MsgBox "Error: " & Err.Description, vbCritical, _
           "Opps! Error" & Str$(Err.Number)
Abort:
Set IAddress = Nothing
Set hospitalMCDResultEx = Nothing
Set hospitalMCDRequestEx = Nothing
Set hospitalMCDRequestManagerEx = Nothing

End Sub


 General use of the hospitalMCDRequest ATL COM module

The HospitalMCDRequestManager is an ATL COM module which provides methods to generate a Minimal Clinical Dataset (MCD) that basically defines the required input to a DRG grouper.

The MCD is printed or a XML infoset is produced which can be electronically transported to the recipient. In the latter case the MCD optionally can be signed and/or encrypted.

To produce such an infoset, firstly an instance of the IHospitalMCDRequest interface is retrieved by the property IHospitalMCDRequestManager::GetHospitalMCDRequest. Thereafter the relevant DRG, all diagnosis and procedures are set The transport/routing information is set by the IHospitalMCDRequest::SetTransport method.

After all information is set the MCD can be generated and printed according to the standardized MCD form by using the IHospitalMCDRequestManager::Print method. Alternatively, a file with a hospitalMCDRequest XML infoset is generated by the IHospitalMCDRequestManager::GetXML method.

To get a staring point with the hospitalMCDRequest module there is a Visual Basic code snippet provided that can be used for generating/printing a MCD.


 How to generate PDF archive files of a MCD request

To generate PDF archive files of a MCD in the hospitalMCDRequestManager use a special print object name (cf. Syntax of the printTemplate variable for an overview).

(PDF=PDF_file_to_generate;)
or
(PDF_NOPRINT=PDF_file_to_generate;)
is used as a print object name on the printTemplate variable of the Print method.

The "PDF" token means to print the MCD request and generate the PDF files, whereas the "PDF_NOPRINT" token only generates the PDF file without physical printing.
This object definition is only used while printing and is ignored in the preview mode!

In its simplest form this means

     BSTR bstrPrintTemplate = "(PDF="+bstrPDFFile+";)";

     IHospitalMCDRequestManager::Print(bstrPrintTemplate,...);
in order to generate a PDF archive file of MCD request.

Since the PDF generation is not the main purpose of the Print method this PDF feature has NO error propagation. The generation is done on a best effort basis, errors are only dumped to the log file!

Boundary conditions:

  • Only active in printing mode
  • No error propagation
  • The supplied PDF archive name must not exist
  • The directory where the PDF is stored must be writable


 How to print webstamps onto a MCD request

To print a webstamp onto a MCD request in the hospitalMCDRequestManager use a special print object name (cf. Syntax of the printTemplate variable for an overview).

(WEBSTAMP=file_path_of_BMP_file;)
as a print object name on the printTemplate variable of the Print method.

In its simplest form e.g. in the HospitalMCDRequestManager code this means

     BSTR bstrPrintTemplate = "(WEBSTAMP="+bstrBMPFile+";)";

     IHospitalMCDRequestManager::Print(bstrPrintTemplate,...);
in order to print a webstamp onto the first MCD page.

Since the webstamp printing is not the main purpose of the Print method this feature has NO error propagation. The generation is done on a best effort basis, errors are only dumped to the log file!

Boundary conditions:

  • No error propagation
  • The supplied BMP webstamp must exist


 Syntax of the printTemplate variable of the Print method

bstrPrintTemplate argument of the IHospitalMCDRequestManager::Print is either empty or of the general form given below.

If the bstrPrintTemplate variable is empty then the default print template (using the data language as language switch) is used.
However, bstrPrintTemplate can be used to change the normal printing behavior or changing printing objects dynamically. The following syntax is used as content of the bstrPrintTemplate variable:

[logTpl][(objectName1=text;...)][=printTemplateFile][#INIPATH=inipath]

where a [] pair defines an optional part. The commands are case insensitive.
  • logTpl: is the logical template name. Currently only logTpl=Detail is allowed.
  • objectName1=text; does a substitution of the content of the print object objectName1 by text. A print object is terminated by a semicolon and all print objects are enclosed in a () pair.

    There are 2 predefined pseudo print objects with a special meaning:

    • PDF for generating PDF files
    • WEBSTAMP for printing electronic stamps

  • printTemplateFile is an external print template file name (full path + name!). If an external print template is supplied it must be mapped against a logical template. Therefore detail=full_vps_file must be used!
  • #INIPATH=inipath defines a fully qualified path to a directory where the report engine searches the corresponding .vpd print template INI file. This allows for global settings of a print template in a LAN. The default inipath is the install directory of the Dll

Here are some usage examples:
  • bstrPrintTemplate: "" or bstrPrintTemplate: Detail
    denotes a standard printing situation
  • bstrPrintTemplate: (DOCUMENT_TITLE=Alternate title for the MCD;) prints a substituted title as given above.
  • bstrPrintTemplate: detail=C:\myForms\myPrintForm.vps
    uses the print template "C:\myForms\myPrintForm.vps". An optional INI file with the name "C:\myForms\myPrintForm.vpd" is searched under this condition.
  • bstrPrintTemplate: #INIPATH=\\host1\\myForms\
    the default path for the ini files (place of the installed component) is changed to "\\host1\\myForms\". If "\\host1\\myForms\" is accessible by all hosts of the LAN then the same INI settings can be used.


 Process attributes...

An XML request is primarily defined by its topmost object reference (cf. "Overview over "Object reference"). However, the XML request is further characterized by a state that is formed by a set of Boolean process attributes, namely

"copy" attribute

The copy attribute defines the XML request as an identical copy of an initial request.
The absence of the copy attribute in reverse defines the XML request as "normal" (initial) request.

It is considered an error to send a XML request with turned on copy attribute without having prior sent a "normal" request.

"storno" attribute

The storno attribute cancels the XML request defined by the topmost reference object.
The absence of the storno attribute in reverse defines the XML request as "normal" request.

It is considered an error to send a XML request with turned on storno attribute without having prior sent a "normal" request.

The copy and storno attributes can be combined to form a total of 4 different combinations.


 Object reference...

The following paragraphs defines the concepts of object reference, object reference chain, and topmost object reference. These concepts are of high importance within the XML request/response system.

object reference

An object reference is an identification of an individual XML request defined by a unique triple of data, namely
  • timestamp (UNIX time) defined at the moment of generation
  • date of the object defined by the provider
  • id of the object defined by the provider
Each and every XML request of version 4.5 is defined by such an object reference. All XML responses are replies to the object reference of the corresponding request.

Thus the object reference is a clustered primary key of the request/response system!

object reference chain

As a consequence of the XML schema coded business logic most XML request schemas define more than just 1 object reference, e.g. a "HospitalMCDRequest" needs 2 object references, namely
  • a mandatory invoice object reference from the "General Invoice Request" process
  • a mandatory mcd object reference from the " HospitalMCDRequest" process
This set of object references by itself defines an ordered object reference chain (e.g. invoice -> mcd) with the topmost object reference as unique identification of the XML request. Therefore the object reference chain defines -on business logic point of view- dependencies among different XML requests.

topmost object reference

The end node of an object reference chain is defined as topmost object reference, that is by definition the object reference of the XML request itself. Each request/response communication is always done for this topmost object reference and only for that.


 Notes about the signature

XML signatures are digital signatures designed for use in XML transactions. The W3C standard defines a schema for capturing the result of a digital signature operation applied to an infoset. XML signatures add authentication, data integrity, and support for non-repudiation to the data that they sign.
However, it is beyond the scope of this documentation to explain all details of a signature or the signing process. Detailed information about all aspects of signatures can be found at W3C.

Boundary conditions and critical aspects

  • the signature is optional!
  • if an infoset is signed then the private certificate of the sender must be used and this certificate is applied to the payload element. This inherently qualifies for a detached signature.

    In this context sender is used in terms of the communication and therefore is defined as the EAN entity given in the transport@from attribute

  • the URI attribute of the reference element must use a XPointer syntax of the payload element, e.g. <ds:Reference URI="#xpointer(/mcd:request/mcd:payload)">
  • it is recommended to add the public key via a X509Data element such that a key store can be built at the recipient's site
  • The signature algorithm is fixed to PKCS1 (RSA-SHA1) (RFC 2437: RSA Cryptography Specifications)
  • The digest algorithm is fixed to SHA-1
  • the used canonicalization algorithm must be http://www.w3.org/2001/10/xml-exc-c14n#, the exclusive XML Canonicalization

The hospitalMCDRequest module does obey all these conditions whenever signature is "turned on" by setting the private certificate and password of the "fromEAN" entity (cf. IHospitalMCDRequest::SetTransport). This certificate must be in the PFX format.